amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 Ergebnisse der Suche: 47 Treffer (30 pro Seite)
Cyborg   Nutzer

20.01.2011, 14:41 Uhr

[ - Direktlink - ]
Thema: S: CyberstormPPC für AmigaOS Entwickler
Brett: Kleinanzeigen (keine Auktionen!)

Der OS Entwickler bin ich ;)

Da meine eigene CyberstormPPC dank eines "professionellem" Unternehmen nach Austausch des PPC nun wohl endgültig hinüber ist (Danke an Stan von a1k für die Analyse), suche ich eine "Neue". Einzige Voraussetzung wäre, daß sie 100% funktionstüchtig ist. Welcher PPC drauf ist oder ob 040 oder 060 ist egal.

Also wenn Ihr die OS4 Classic Entwicklung unterstützen wollt und eine CyberstormPPC verkaufen würdet -> Angebote an mich per PM oder EMail!

Danke!
 
Cyborg   Nutzer

14.10.2009, 10:07 Uhr

[ - Direktlink - ]
Thema: USB-Massenspeichergerät unter AOS4.1
Brett: Amiga, AmigaOS 4

Zitat:
Original von Reth:

Als Betaversion sollten USB2.0-Treiber doch schon im Test sein! Und da ich Betatester bin... :D


Als Betatester solltest Du wissen, daß Du unter NDA stehst und in der Öffentlichkeit nicht über Dinge, den Betatest betreffend reden darfst. Darunter fällt auch USB2/EHCI.

Wenn Du Fragen solcher Art hast, stelle Sie auf der Betatester Mailingliste, dafür ist sie schließlich da. Oder berate Dich privat mit einem anderen OS4 Betatester. Aber bitte nicht in einem öffentlichen Forum.


Mir ist klar, daß Du bis jetzt keine besonderen Geheimnisse gelüftet hast. Trotzdem bewegst Du Dich schon sehr nahe an einer Verletzung der von Dir akzeptierten NDA. Daher bitte einfach über Nichts mehr in der Öffentlichkeit reden, was nicht von Hyperion oder einem von Hyperion Beauftragten bereits veröffentlicht wurde.
 
Cyborg   Nutzer

28.08.2009, 10:59 Uhr

[ - Direktlink - ]
Thema: Ariadne oder X-Surf
Brett: Amiga, AmigaOS 4

Zitat:
Original von eliotmc:
@roper67:
Eigentlich ist das völlig egal,
es sind beide sehr stabile Karten.

Achte nur darauf, dass du eine Ariadne 2 erwirbst,
die 1 hat keinen RJ45 Anschluss.


Ich weiß ja nicht was Du für eine Ariadne I hast, aber bei meinen ist sehr wohl ein RJ45 Anschluß drauf und läuft auch einwandfrei.. vielleicht war Deine gebraucht und der Vorbesitzer konnte den RJ45 anderweitig brauchen? ;-)


Edit: Ups, Neodym hat ja bereits gesagt, daß die Ariadne I natürlich einen RJ45 Anschluß hat.

[ Dieser Beitrag wurde von Cyborg am 28.08.2009 um 11:01 Uhr geändert. ]
 
Cyborg   Nutzer

27.08.2009, 08:47 Uhr

[ - Direktlink - ]
Thema: iPhone am AmigaOS
Brett: Amiga, AmigaOS 4

@BJ:

;) Das war auch das Erste, was ich versuchte, gleich nachdem ich letztes Jahr mein iPhone bekam. Leider hat ZeroG recht. Das iPhone benutzt das Media-Transfer-Protocol und dafür gibt es in der Tat noch keinen Treiber.

Wenn ich ein Bild vom iPhone auf dem Amiga brauche und kein anderer Sklaven-Rechner in der Nähe ist, dann schick ich mir im Moment das jeweilige Bild einfach selbst vom iPhone aus per E-Mail. Das ist natürlich nur für einzelne Bilder praktikabel..

Achja, und man muß aufpassen, weil angeblich die "Per E-Mail senden" Funktion der Fotoapp die Bilder verkleinert, bevor sie losgeschickt werden. Ich hab das selbst noch nicht verifiziert, weil ich schon recht lange kein Bild mehr übertragen wollte. Aber man kann das wohl mit iPhoneOS 3.0 und der Zwischenablage umgehen. Einfach etwas länger auf das Bild tippen, dann erscheint der "Kopieren" Button für die Zwischenablage. Das Bild in die Zwischenablage kopieren, dann Mailanwendung aufmachen, neue eMail und das Bild aus der Ablage einfügen.
 
Cyborg   Nutzer

04.08.2009, 17:04 Uhr

[ - Direktlink - ]
Thema: Shutdown Tool für AOS4
Brett: Amiga, AmigaOS 4

@Andreas_Wolf:

Andere Formulierung, gleiche Wirkung ... bin halt OS4 und kein MOS User und Entwickler ;)
 
Cyborg   Nutzer

04.08.2009, 16:40 Uhr

[ - Direktlink - ]
Thema: Shutdown Tool für AOS4
Brett: Amiga, AmigaOS 4

Zitat:
Original von ZeroG:
Cool.
Funktioniert das nur auf dem Peg oder auch auf dem A1 und den SAMs?


Nur mit dem Peg (daher auch der Name "pegoff" ;) ).. bzw. nur mit Open/SmartFirmware, weil das Tool einfach einen "power-off" RTAS Aufruf macht, genau wie das Ambient->Verlassen->Abschalten Menü unter MOS.
 
Cyborg   Nutzer

04.08.2009, 15:56 Uhr

[ - Direktlink - ]
Thema: Shutdown Tool für AOS4
Brett: Amiga, AmigaOS 4

Zitat:
Original von Reth:
Nun würde ich ihn gern per Software runterfahren und das ATX-Board ausschalten lassen statt mich immer zu verbiegen und den Taster zu drücken, bis er abschaltet!

Gibt es so ein Tool für AOS4 irgendwo? AOS4Depot hat mir nix dazu ausgespuckt!


Ich hab mal so ein Tool geschrieben und ins Aminet geladen.. 'pegoff' sollte demnächst freigegeben werden, einfach öfter die Aminet-Recents beobachten.. wahrscheinlicher Direktlink wird dann wohl dieser hier werden (im Moment noch ohne Funktion): http://aminet.net/package/util/cli/pegoff

Edit: pegoff ist jetzt im Aminet zum Download verfügbar.

[ Dieser Beitrag wurde von Cyborg am 05.08.2009 um 08:49 Uhr geändert. ]
 
Cyborg   Nutzer

17.09.2008, 11:42 Uhr

[ - Direktlink - ]
Thema: Texteditor mit Zeilenumbruch gesucht
Brett: Amiga, AmigaOS 4

@Supermatse:

Probier mal NoWinEd:

http://shinkuro.altervista.org/amiga/software/nowined.htm

Ist zwar noch recht jung, aber gibts auch für 68k und ist vielleicht das Richtige für Dich.
 
Cyborg   Nutzer

24.02.2008, 12:10 Uhr

[ - Direktlink - ]
Thema: Umfrage zur Nachfrage nach Blizzard SCSI Treiber
Brett: Amiga, AmigaOS 4

Für diejenigen, die vielleicht nicht so genau amigaworld.net lesen:

Hier bei amigaworld.net

hat Cobra (Entwickler von DvPlayer und Mitglied im OS4 Entwicklerteam)
eine Umfrage gestartet, mit der er herausfinden will, wie hoch das Interesse
an einer OS4 Version des Blizzard SCSI Treibers ist... wenn sich genug
Interessenten melden, würde das die Chancen auf einen Treiber beträchtlich
erhöhen, da der Showstopper tatsächlich einfach fehlende Manpower ist,
die natürlich bei anderen Baustellen bereits verplant ist (siehe Rogues
Kommentare zur AmigaOS4 Update Meldung auf aw.net).

Aber da mit steigendem Interesse an einer Komponente auch automatisch
deren Priorität steigt, sollte dort jeder abstimmen, den es angeht ;)

Vielleicht läßt sich Cobra ja davon überzeugen, daß es den Aufwand wert
ist (das OS4 Device müßte komplett neu geschrieben werden, da keine
Quellen des alten SCSI Treibers verfügbar sind).


So, und nein, Cobra hat NICHTS versprochen, Hyperion hat NICHTS ver-
sprochen, tatsächlich hat NIEMAND irgendetwas versprochen oder ange-
kündigt... nur damit später nicht gleich wieder irgendwelche
haarsträubenden Behauptungen aufgestellt werden, irgendwer hätte
irgendwas versprochen/angekündigt/zugesagt/etc.. Bitte erst selbst bei
aw.net nachlesen was, wer, wie genau gesagt hat .. danke! ;)
 
Cyborg   Nutzer

06.03.2004, 17:31 Uhr

[ - Direktlink - ]
Thema: Prelude 1200 bestellung
Brett: Amiga, AmigaOS 4


Ich würd zur Not auch den Sammler spielen.. aber da sich whose zuerst gemeldet hat, laß ich ihm gern den Vortritt ;-)

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

05.03.2004, 10:24 Uhr

[ - Direktlink - ]
Thema: Prelude 1200 bestellung
Brett: Amiga, AmigaOS 4

Marc, Du bist mein Held ;-)

Ich nehme - natürlich - auch eine!

GolfSyncro: Leitest Du dann die Liste an Marc weiter? Ist schon was über den weiteren Ablauf bekannt?

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

19.04.2003, 22:49 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung

Zitat:
Original von Kronos:

Also ein Device gehöhrt nach devs: (eventuell noch ein Unterverzeicniss)
oder eben in ein ROM. Es mag zwar Ausnahmen geben, aber solange ich
nicht weiss worum es hier eigentlich geht ....

Grundsätzlich stimme ich Euch da ja auch zu.. in diesem Fall denke
ich aber, daß es genau so eine Ausnahme ist..
Zitat:
Also was du willst scheint ja sowas wie usbpar.device zu sein, und
da denke ich du solltest das einfach über den Installer lösen
"Wollen sie den Treiber für den TCP/IP-Fön, oder nicht ?",
und damit hats sich. Wenn jemand doch das Device öffnet ohne das
der Fön angeschlossen ist, gibt es eben die entsprechene Fehler-
meldung (DOS-Code 2666 "no fön available" :P ).

Eben.. Du sagst es, sowas wie usbparallel.device... und das ist
eben *nur* dann im System vorhanden/sichtbar, wenn ein USB-Drucker
angeschlossen ist. Ist keiner da, gibt es das Device auch nicht.
Es wird eben dynamisch zur Verfügung gestellt und liegt nicht
im Devs: rum...

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

19.04.2003, 22:43 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung

Zitat:
Original von thomash:
Das Assemblerbeispiel ist eigentlich recht gut dokumentiert, die Umsetzung in C sollte nicht so schwer sein. Aber Assembler sollte man vielleicht doch dazu können, zumindest ansatzweise... 8)

Da ich in Assembler eine Null bin (welch Wortspiel ;) ), tu ich mir da verdammt
hart.. aber das Beispiel war auch das erste, was ich mir zu dem Thema angesehen
hab..

Es muß da doch auch was in C geben, oder??
Zitat:
Ansonsten habe ich vorhin mal kurz die Autodocs überflogen, es gibt ein AddDevice()/RemDevice() in exec, wie bei einer Library. Die Vorgehensweise zum dynamischen Einklinken in das System müsste auch die gleiche, wie bei einer Library sein.

Und auch Devices kann man entfernen, wie eine Library. Bei den Beispielen zum serial.device war eine kleine Funktion dabei, wie das geht. Eigentlich genauso, wie bei der Library: Expunge() aufrufen.

;-) Ja .. das hab ich kurz nach dem Abschicken meiner letzten Nachricht ebenfalls
entdeckt ... muß mir endlich angewöhnen, etwas genauer zu lesen.. ;)
Zitat:
Ein Device in eine Library zu stecken, macht eigentlich nur noch Sinn, wenn man eine alte Library ersetzen will, weil ein Device praktischer wäre, um die Hardware anzusteuern.
Da ich im Device - egal, ob stand-alone im Devs: oder nicht - sowieso auf Funktionen
in meiner Treiber-Lib zugreifen müßte, dachte ich eben, daß ich die Device-Schnittstelle
gleich in die Library packen und damit zwei Fliegen mit einer Klappe schlagen kann
(1. Zugriff auf die Funktionen und 2. Device nur "sichtbar", wenn auch HW verfügbar
ist).
Anscheinend war das wohl keine so gute Idee .. ;(
Zitat:
Ich kann mir allerdings nicht vorstellen, daß irgendjemand mal eine Hardware nicht direkt per Device angesteuert hätte, sondern den "Umweg" über eine Library gegangen ist.
Nimm als Beispiel USB.. da hast Du keine andere Möglichkeit, als den eigentlich
Treiber in eine Library zu packen und die Befehle wiederum über eine Library (dem Stack)
an die Hardware zu schicken.

Der User (Coder), der jetzt diese von Dir unterstützte Hardware benutzen möchte,
muß ebenfalls über die Stack-Library und evtl. deine Treiber-Library gehen, um
die HW nutzen zu können...

Genau dafür würde ich eben geren ein Device bereitstellen, damit 1. die Handhabung
für Dritte einfacher fällt und 2. auch ältere Programme ohne Rework sofort die
Hardware benutzen können (sofern sie über Devices arbeiten).

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

19.04.2003, 22:33 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung

@ Holger

Wir reden wohl teilweise aneinander vorbei.. ich meinte mit "dynamisch erzeugen",
daß es eben keine #?.device Datei gibt, sondern das Device aus einem anderen
Stück Code heraus zur Verfügung gestellt wird.
Mir ist sehr wohl klar, daß Device <-> Library keinen großen Unterschied
darstellt.

Von wegen mein Nichtskönnen "zugeben".. Du hattest mir unterstellt (wenn auch
nicht wörtlich), daß ich überhaupt nichts mit Devices anfangen kann. Und das
ist so eben nicht richtig. Ich kann ein Device XY benutzen, kein Problem.
Daß ich im Moment noch kein eigenes Device programmieren kann, gebe ich offen
zu.. warum auch nicht? Genau das will ich ja eben lernen.
Genau in diesem Zusammenhang hat mich eben interessiert, wie man ein Device
in anderem Code einbettet. Das war schon alles.
Es wäre schön, wenn Du - anstatt Schadenfreude dafür zu empfinden, daß es
heutzutage tatsächlich Leute gibt, die mit Assembler nichts anfangen können -
mir z.B. eine Quelle nennst, wo ich Informationen zur Device-Programmierung
unter C finden kann.

Beim nächsten Punkt muß ich doch zitieren:
Zitat:
Falsch. Jedes devices wird von einer übergeordneten Instanz geladen und wieder entfernt. Das funktioniert über den gleichen Mechanismus wie bei libraries.
Dies hast Du eindeutig *falsch* verstanden. Der Stack *erfordert*, daß der
eigentliche Hardware-Treiber eine Library ist. Daran beißt die Maus keinen
Faden ab.
Natürlich stimme ich Dir bei der Aussage grundsätzlich zu, aber in diesem
Fall ist sie einfach fehlangebracht.

Was den "Totalen Unfug" angeht, hast Du eigentlich nichts anderes gesagt,
als ich es getan habe.. Nur daß ich eben das Device auch nur dann zur
Verfügung stellen wollte, wenn die Hardware da ist und nicht erst bei einem
Zugriff darauf checken..

Zu der Dateistruktur.. das bezog sich auf die Vorgabe, daß es *kein* #?.device
im Devs: gibt, sondern das Device eben in einem anderen Stück Code untergebracht
ist. Und dieses Stück Code hätte keinen *vernünftigen* Platz, der die angedachte
Verteilung der Dateien des Stacks *nicht* durcheinanderbringen würde.. da
habe ich herzlich wenig damit zu tun.

Es ist richtig, daß ich den User für "dumm" halte.. allerdings *konstruktiv* !
Ich versuche Software zu schreiben, die möglichst DAU- und narrensicher ist..
dadurch können ein Haufen Probleme von vornherein vermieden werden.
Das ist IMO keine Beleidigung des Users, sondern vielmehr eine Vereinfachung
für den User.. es beschränkt sich ja nicht nur auf das Verstecken von Devices,
wenn sie nicht benötigt werden, sondern erstreckt sich über ein viel größeres
Gebiet.
Um Dein Beispiel aufzugreifen: wenn ein User "dir devs:" macht, will er - wie
Du selbst geschrieben hast - wissen, welche Devices *installiert* sind.. sprich:
welche Devices hat er zur Verfügung. Ein Device hat er aber nur zur Verfügung,
wenn er auch die entsprechende Hardware dafür hat. Wenn also diverse Devices
existieren, die der User gar nicht nutzen *kann*, weil die Hardware eben *nicht*
zur Verfügung steht, warum sollten sie dann aufgelistet werden? (Nicht vergessen,
wenn die HW nicht da ist, wird auch der HW-Treiber nicht geladen und damit auch
das Device nicht zur Verfügung gestellt - sollte es in dem Treiber eingebettet
sein).
Aber natürlich sehe ich auch Deinen Standpunkt.

Abschließend: Richtig, ich wollte Antworten auf meine Fragen. Von deinen
Empfehlungen fühlte ich mich allerdings leicht angegriffen.. vielleicht habe
ich dabei etwas überreagiert, kann sein.. in dem Fall, entschuldige. Trotzdem
wären mir handfeste Quellenverweise (Device-Coding in C, etc.) lieber, als
so lapidare Sprüche, wie "Vielleicht solltest Du mehr Anstrengungen...".

Ich würde sagen, wir begraben hier und jetzt unser "Kriegsbeil" .. schließlich
will ich nicht streiten, sondern etwas lernen.. ;)


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

18.04.2003, 11:47 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung

Zitat:
Original von Holger:
Tja, ganz offensichtlich bist Du gerade dabei genau das Gegenteil zu entwickeln, einen aufgeblähten Library-Code, in dem nicht benötigte devices eingelagert sind, egal ob sie benötigt werden oder nicht.
Vielleicht solltest Du mehr Anstrengungen unternehmen, das device-system des Amigas zu verstehen, in dem das dynamische Nachladen bereits seit über zehn Jahren problemlos funktioniert, anstatt dieses umständliche Handling entwickeln zu wollen, das keinerlei erkennbaren Vorteil bietet.


Oh, Vergebung!
Vielleicht sind Eure Hoheit so gändig und erleuchten unseren kleinen Geist ein
wenig, damit wir Eurer Weisheit ein wenig näher kommen, obgleich wir sie niemals
werden erreichen können?!


Im Ernst, anstatt hier nur groß heiße Luft zu versprühen und zu versuchen, mir
meine Arbeit madig zu machen, wären konstruktive Vorschläge weitaus sinnvoller!
Du solltest vielleicht auch erstmal genauer nachfragen, bevor Du meckerst..

z.B. habe ich die Kapitel über Devices im RKRM Devices und RKRM Libraries genau
gelesen... leider steht da aber nur, wie man ein Device *benutzt*, nicht, wie
man eines selbst *programmiert* und schon gar nichts von dynamisch erzeugten
Devices.
Jedenfalls hab ich nichts darüber gefunden, außer einem Assembler-Beispielcode
für ein Custom-Device, mit dem ich aber mangels Assembler-Kenntnisse nichts
anfangen kann..

Nebenbei hast Du anscheinend nicht verstanden, worum es hier eigentlich geht,
also nochmal, nur für Dich: Es wird ein Treiber für eine bestimmte Hardware
benötigt, der von einem übergeordneten Stack geladen oder auch wieder entfernt
wird. Daher *muß* es eine Library sein. Punkt.
Das nächste ist, daß dem User auf einfache Weise Zugriff auf diese Hardware
gestattet werden soll. Das geht nuneinmal am besten über eine deviceähnliche
Schnittstelle.
Natürlich könnte ich darauf verzichten, aber dann wäre jedem älteren Programm,
das nicht mehr gepflegt wird, der Zugriff auf die Hardware versagt. Inzwischen
ist der Anteil der nicht weiter gepfegten Software am Amiga so groß, daß dies
völlig inakzeptabel ist.
Da also die Library nur geöffnet wird, wenn auch die Hardware vorhanden ist,
macht es natürlich Sinn, wenn auch das Device nur dann verfügbar ist. Also
dynamisch erzeugt wird (siehe z.B. duart.device oder auch das usbparallel.device
von Chris Hodges).
Leider sieht es so aus, daß ich keine Möglichkeit habe, den Code für das Device
in einem Verzeichnis bereitzustellen, sodaß ich ihn immer finden kann und
vor allem die Dateistruktur *nicht* durcheinander bringe. Also muß der Devicecode
in der Library eingebettet sein.
Natürlich kommt jetzt von Dir wahrscheinlich wieder, daß ich ein komplettes
Device schreiben und es im DEVS: ablegen soll. Schön und gut, wenn aber keine
Hardware vorhanden ist (was wohl öfter vorkommt, da sie relativ selten ist),
würde dieses Device bei vielen einfach nur rumgammeln und evtl. für Verwirrung
sorgen.

Abgesehen davon, macht es öfter Sinn ein Device dynamisch dem System hinzuzufügen.
Und dieser Mechanismus würde mich *generell* interessieren.. im Moment eben aus
einer Library heraus, ansonsten eben aus einem normalen Programm heraus.


So, jetzt sollte es auch der Letzte verstanden haben, um was es geht. Es ist
wirklich traurig, daß man hier genauso angepflaumt wird, wie in den Kommentaren
zu irgendeiner News-Meldung, wenn mal etwas nicht nach dem Geschmack gewisser
Personen hier ist... tolle Community.. :angry:

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

17.04.2003, 20:15 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung

Zitat:
Original von thomash:

Also quasi wie eine Decoder-Library, die entweder per Software (Library) funktioniert, oder Hardware-beschleunigt, wenn die Karte dazu vorhanden ist.


hmm.. eigentlich nicht... die Library wird nur aktiv, wenn wirklich eine
unterstützte Hardware vorhanden ist. Wenn das aber so ist, soll dem Benutzer
(egal, ob Coder oder Programm) die Hardware über ein Device zur Verfügung
gestellt werden. Und *nur* dann!
Ist keine Hardware vorhanden, wird die Library auch nicht geladen und somit
soll dann auch kein unnötiges Device im System rumgeistern.

Zitat:
Stack ? Also irgendwas mit USB oder Netzwerk ? Oder beides ?

Hehe... das möchtest Du jetzt gerne wissen, gell :D
Vielleicht isses ja auch was völlig anderes :P



--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

17.04.2003, 11:01 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung


Danke für 1. ;)

Zitat:
Original von thomash:
zu 2.: Eigentlich macht es keinen Sinn, ein Device aus einer Library heraus zu erzeugen, da ein Device praktisch eine aufgebohrte Library ist. Ein Programmierer muß nur das Device öffnen und den LibNode einer Basisvariablen zuweisen, wie bei den Libraries, schon sind die "Library"-Funktionen zugänglich. Siehe das Beispiel timer.device in den RKMs.


Es macht schon Sinn.
Der Hardware-Treiber muß als Library vorliegen, damit er von dem eigentlichen Stack
geladen werden kann. Das erfordert nunmal das Design des Stacks.

Wurde der Treiber geladen, sollen das Gerät alle möglichen Applikationen nutzen
können, ohne dafür etwas vom Stack oder der HW-Besonderheiten zu wissen. Also
muß ich ein Device erzeugen.
Da alles schön kompakt bleiben und das System nicht mit unnötigen Devices vollgemüllt
werden soll (mein Device soll ja nur erzeugt werden, wenn auch eine entsprechende
HW gefunden wurde), möchte ich es einfach aus der Treiber-Lib heraus erzeugen.

Zitat:
Aus reiner Neugier: Was ist das denn für eine Hardware, die so ein Vorgehen verlangt ?

Is (noch) geheim ;-)


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

15.04.2003, 15:23 Uhr

[ - Direktlink - ]
Thema: Suchfunktion des Forums
Brett: Forum und Interna


hmm.. dachte, daß sich da jemand drum kümmert...

Schade, schade... ich könnte es mir zwar mal anschaun, aber mangels
Zeit ... ;(


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

15.04.2003, 08:58 Uhr

[ - Direktlink - ]
Thema: Suchfunktion des Forums
Brett: Forum und Interna

Hoi folks..


Ich hätte da einen wichtigen Verbesserungsvorschlag für das Forum..
Falls es den schon gab, sorry, hab nix gefunden..


Die Suchfunktion des Forums nach Beiträgen ist, so wie sie jetzt ist,
schlicht und ergreifend Mist..

Man kann nur nach *einem* Begriff suchen und auch nur in *allen* Brettern..
Das führt dazu, daß man oft biszu 1MB (!) an Results bekommt und noch
stundenlang alle durchgehen muß.. da könnte man das entsprechende Brett
gleich von Hand durchsuchen und wäre wahrscheinlich noch schneller..

Wenn man mehrere Begriffe eingibt, kommt dafür gar nichts :angry:


Also hier meine Vorschläge für die Forums-Suche:

1. Besserer Parser/Suchalgorithmus, um mehrere (mit UND verknüpfte)
Begriffe zuzulassen und bearbeiten zu können. Daduch genauere Ergebnisse.

(Sucht z.B. mal nach "devices" .. ca. 800Kb Ergebnisse.. und nur Müll)

2. Auswahl in welchem Brett gesucht werden soll. Am besten eine Mehrfach-
Auswahl, damit man auch in mehreren (oder allen) Brettern suchen lassen
kann, wenn man will. Dadurch zwar weniger Ergebnisse insgesamt, aber
dafür auch keine Unmengen von unerwünschten Ergebnissen mehr.



Siehe obiges Beispiel.. beim Suchbegriff "devices" oder mit einem
besseren Parser "devices erzeugen" interessiert mich nicht, was in
Interna oder Amiga oder Morhpos oder sonstwas gelabert wird, sondern
*nur* im Programmierer Bereich..


Wäre wirklich gut, wenn das eingebaut werden könnte..

Ach, da fällt mir ein.. ist das nur bei mir so oder braucht das Forum
teilweise eeeeeeewig, bis mal die Einstiegsseite erscheint? Danach
gehts eigentlich ganz gut, aber bis man mal auf http://www.amiga-news.de/forum
ist, vergeht (zumindest bei mir) schon eine beträchtliche Zeit..


So, genug gemeckert ;)


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

15.04.2003, 08:46 Uhr

[ - Direktlink - ]
Thema: Library & Devices proggen
Brett: Programmierung

Hoi folks..


Ich hab da mal ein paar Fragen zum Thema Libraries & Devices programmieren,
die mir die RKMs so nicht wirklich beantworten konnten und über die ich auch
nichts Brauchbares im Internet finden konnte..

1. Muß ich etwas Spezielles beachten, wenn ich eine Library/Device mit Vbcc
kompilieren muß? Bis jetzt halte ich mich beim coden einfach an die Vorgaben
der RKMs und des Beispiels, das bei StormC dabei war..

2. Ich möchte eine Lib programmieren, die als Modul von einem anderen
Programm geladen wird. Im Prinzip ist es ein HW-Treiber.
Wenn dann eine entsprechende HW gefunden und eine Instanz von meiner Lib
erzeugt wird, möchte ich die HW dem User gerne als ein Device zur Verfügung
stellen.
In den RKMs steht zwar, wie man eine Library zur Laufzeit "von Hand" in das
System einfügen und wieder entfernen kann (LoadSeg(), MakeLib(), AddLib(), etc.),
aber wie man das mit einem Device macht, konnte ich nicht finden.

Es ist ja ohne Zweifel möglich ein Device dynamisch zu erzeugen (beweisen ja
viele Programme), aber ich konnte nichts darüber finden, wie man es genau
anstellen muß ;(

Außerdem kommt noch erschwerend hinzu, daß ich dieses Device von meiner Library
aus erzeugen will/muß. Da hört dann mein Verständnis völlig auf.. kann ich
den Code für das Device einfach in eine Funktion der Library packen? Oder
einfach die Device-Funktionen ans Ende (hinter die Library-Funktionen) packen
und dann eben den Einsprungpunkt für LoadSeg() (oder was auch immer) eben
entsprechend setzen?


Wär schön, wenn mich da jemand erleuchten könnte ;)



--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

20.03.2003, 10:29 Uhr

[ - Direktlink - ]
Thema: "Neuer" Amithlon Kernel
Brett: AROS und Amiga-Emulatoren


Jo, das mit der Checksumme hab ich schon überprüft, aber ich habe
nichts gefunden, wo selbige steht.
Also gehe ich davon aus, daß die on-the-fly berechnet wird. Selbst
wenn dafür der alte Kernel "emubox.gz" benutzt werden sollte, statt
dem im Bootloader eingetragenen "new_emubox.gz", hätte es funktionieren
müssen, als ich den alten komplett rausgeworfen habe und _nur_ der
neue auf der CD vorhanden war..

Aber ist eigentlich auch schon egal ... wenn ich das nächste Mal bei
meinem Kumpel bin, werden wir einfach eine Amithlon-Boot-Partition
einrichten und es damit nochmal versuchen.. und wenn es nicht klappt,
dann haben wir (bzw. mein Kumpel) eben Pech gehabt..


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

16.03.2003, 10:12 Uhr

[ - Direktlink - ]
Thema: "Neuer" Amithlon Kernel
Brett: AROS und Amiga-Emulatoren

Zitat:
Original von Askane:

Vielleicht ist der Fehler sehr simpel, das mir das vorher nicht
auffiel. Benenne doch mal die new_emubox in emubox.gz um. Also
Orginal.



Hat etwas gedauert, bis ich dazugekommen bin, das auszuprobieren..
Aber wie erwartet, hat das auch nicht geholfen ... immernoch
Checksum error on kernel image von Isolinux :angry:


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

08.03.2003, 10:08 Uhr

[ - Direktlink - ]
Thema: "Neuer" Amithlon Kernel
Brett: AROS und Amiga-Emulatoren


Danke für die Kurzanleitung, aber die bringt mir nichts... mein Kumpel
will keine Bootplatte einrichten für Amithlon ... frag mich nicht,
warum..

Jedenfalls hat das Bootcd-Erstellen ja einwandfrei geklappt.. nur
Isolinux meckert beim Booten, daß die Checksumme für das Image nicht
stimmt ... das ist mein Problem ..

Noch jemand eine Idee?

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

07.03.2003, 22:38 Uhr

[ - Direktlink - ]
Thema: "Neuer" Amithlon Kernel
Brett: AROS und Amiga-Emulatoren


Hallo Leute..


Keine Ahnung, ob das hier schon gefragt wurde.. ich hab jedenfalls nichts
gefunden..

Also, es geht um Folgendes:

Ein Kumpel hat sich eine GeForce 3 zugelegt, leider wird diese Karte
ja vom original Amithlon Kernel _nicht_ unterstützt. Also haben wir
versucht, eine neue (bootbare) Amithlon CD mit dem "neuen" Kernel
(der GF3 untestützt und im Aminet liegt) zu erzeugen.

- CD ausgelesen
- new_emubox.gz in isolinux/ kopiert
- Amithlon, isolinux.cfg und small auf new_emubox.gz geändert und 200
auf leavepages draufgezählt (wie in Anleitung beschrieben)
- mittels mkisofs ein bootfähiges ISO-Image erzeugt und gebrannt.

Soweit funktionierte alles tadellos.. leider kommt aber beim Booten
von der CD immer eine Fehlermeldung von ISOLINUX, daß die Checksumme
des Images nicht stimmt ...

In der Anleitung und im Web hab ich nichts dazu gefunden, wo ich was
ändern muß, damit das funktioniert...

Hat also einer von Euch das hinbekommen, eine bootfähige Amithlon-CD
mit dem neuen Kernel zu erstellen? Oder irgendwelche Tips?

Bin für jede Antwort sehr verbunden..


--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

27.02.2003, 10:58 Uhr

[ - Direktlink - ]
Thema: Routenplaner
Brett: Amiga, AmigaOS 4

Es wäre gut, wenn Du genauer beschreiben könntest was nicht geht und
was geht! Bekommst Du z.B. Verbindung zum Router, aber nicht ins INet?
Oder geht gar nichts? Etc...

Trotzdem mal hier ein grober Leitfaden:


- Bei MiamiDx die Netzwerkkarte unter 'Hardware' mit dem entsprechenden
SANA2- oder MNI-Device (in Deinem Fall eben das Ethernet-Device von
Elbox für Mediator) einrichten.

- Dann ein Interface zu der Karte unter 'Interfaces' einrichten und
entsprechend konfigurieren. D.h.: statische IP-Adresse im gleichen
Subnet-Bereich wie der Router (also z.B. 192.168.x.x oder 10.0.x.x);
Die 'Netmask' auf z.B. 255.255.255.0, wenn sich Router und Rechner
nur in der letzten Stelle der IP unterscheiden und somit im gleichen
Subnet sind; die IP-Adresse des Routers unter 'Gateway' eintragen und
die Priorität auf z.B. 10 stellen.

- Abspeichern und das Device/die Ethernetkarte (z.B. eth0) online
gehen lassen

- Shell öffnen, ins MIAMI: Verzeichnis wechseln und den Router mittels
MiamiPing versuchen anzupingen. Also z.B. 'MiamiPing 192.168.0.1' wenn
der Router die IP 192.168.0.1 hat. Antwortet er innerhalb weniger
Millisekunden und gehen keine Pakete verloren, ist alles in Ordnung.
MiamiPing kann mit CTRL-C wieder abgebrochen werden.

- Zurück zu Miami und unter 'Database -> DNS Servers' mindestens
einen gültigen DNS-Server eintragen (welche, siehe DSL-Provider oder
bestehende Windoof-Konfig ;) ).
Einstellungen speichern.


---- Jetzt sollte das Internet erreicht werden können (sofern der
Router natürlich online ist). Einfach mal mit einem Browser oder
MiamiPing testen ... (z.B. MiamiPing w w w.heise.d e')

Als weitere mögliche Fehlerquellen fallen mir nur noch fehlende Kabel
bzw. nicht angeschlossene Kabel (alles schon gehabt ;) ), eine defekte
Netzwerkkarte oder die Firewall des Routers (im Konfigmenü des Routers
überprüfen) ein..


Ich weiß, meine Beschreibung ist recht allgemein, aber Deine Problem-
beschreibung war ja auch sehr allgemein ;)

--
Bye,
Cyborg
-- We would die for :commo:

[ Dieser Beitrag wurde von Cyborg am 27.02.2003 editiert. ]
 
Cyborg   Nutzer

19.02.2003, 12:54 Uhr

[ - Direktlink - ]
Thema: Macht OS4 für Classic Sinn?
Brett: Amiga, AmigaOS 4

Natürlich werd ich mir OS4 für meinen 4000er + Cyberstrom zulegen..
Ich werd doch nicht nach etlichen Jahren des Rumgammelns meiner (zum
damaligen Zeitpunkt) 2500 Mark teuren Hardware die einzige Chance
verstreichen lassen, sie endlich mal vernünftig einsetzen zu können!

(Ja, ich hatte MOS auch schon probiert und es ist durchgefallen,
sorry an alle MOSerer ;) )


Und weil ich schon soooo lange nichts mehr Vernünftiges für meinen
Amigawahn kaufen konnte, muß auch noch ein AmigaOne + OS4 als neuer
Hauptrechner her ...

Außerdem hatte eliotmc mit einem Punkt recht.. meine gute alte Freundin
zeigt nach über 10 Jahren nun doch auch ein paar Verschleißerscheinungen :(

--
Bye,
Cyborg
-- We would die for :commo:


[ Dieser Beitrag wurde von Cyborg am 19.02.2003 editiert. ]
 
Cyborg   Nutzer

11.02.2003, 10:45 Uhr

[ - Direktlink - ]
Thema: Absturz wegen Grafik?
Brett: Amiga, AmigaOS 4

Zitat:
Original von AcidCrasher:

Wenn ich über die 3.1 rüberinstalliere. Dann gibts doch probleme, oder . Man sollte doch immer über Rettungsdiskette oder auf eine extra partition installieren.
Aber Danke für den Tip. Ich werde es probieren. Hoffentlich geht das dann.


Nein, sollte keine Probleme verursachen.. OS3.5 bzw. 3.9 basieren
auf 3.1 und brauchen das ja auch dringend, weil sie im Prinzip nur
eine riesige Hack&Patch Sammlung (welch Wortspiel ;) ) sind, die
eben 3.1 ein wenig aufbohren..

Wenn Du 3.9 drauf hast, solltest Du, wie schon erwähnt wurde, die
BoingBags 1 und (nach BB 1!!) 2 installieren.

BB 1: http://os.amiga.com/3.9/download/BoingBag39-1.lha



BB 2: http://www.haage-partner.de/download/AmigaOS/



Bei BB2 mußt Du das Hauptarchiv und eine (oderer mehrere) Locales
laden (die Übersetzungen). Optional sind die Contributions, ob Du
die saugst, bleibt Dir überlassen.

Zitat:
Die Grafikkarte is übrigens ne CyberVision63 ohne 3d

Gibts da gute Anleitungen, wegen Jumper und für was ist genau der IN Eingang gut. Ich benutze nur den VGA Ausgang.
Kann das Problem auch am Monitor liegen.


Du meinst CyberVision64 ... nicht 63 ;)

Bei http://www.amiga-hardware.com/ findest Du mehr Informationen zu
der Karte.

Allerdings mußt Du normalerweise an den Jumpern nichts ändern. Der
IN Anschluß ist dafür da, um das Amiga-Signal durchzuschleifen.
Bringt Dir bei der CV64 aber nur was, wenn Du einen MultiScan-Monitor
hast, der auch die Amiga original Frequenzen verkraftet (z.B. Commo 1942).

Zitat:
Sorry das ich so viel Frage. Ich hatte nur mal nen A500. Da gabs nocj nicht so viele Optionen.

Deswegen gibts ja solche Foren ;)


--
Bye,
Cyborg
-- We would die for :commo:


[ Dieser Beitrag wurde von Cyborg am 11.02.2003 editiert. ]
 
Cyborg   Nutzer

11.02.2003, 10:27 Uhr

[ - Direktlink - ]
Thema: Bilder einbinden ins Amiga Guide?
Brett: Programmierung


Zitat:
Bladerunner:


Ich bin hier gerade dabei eine Dokumentation für einen Freund zu
machen und würde zum besseren verständniss gerne Bilder einbinden,
geht das überhaupt?



Die Frage kann man nur mit "jein" beantworten...

Es war von Commo so vorgesehen, daß man Bilder direkt im Text eines
AmigaGuides einbinden kann.. also z.B TEXT, BILD, TEXT auf einer
Seite.

Man kann das in AmigaGuide auch programmieren, aber leider wird diese
Option (wie so viele eigentlich geniale andere auch) _nicht_ von
MultiView unterstützt. Commo kam damals nicht mehr so weit, das alles
zu implementieren und heute kümmert sich irgendwie keiner so recht
drum ;(

Naja, jedenfalls kannst Du Links auf Bilder setzen, die dann auf
einer eigenen Seite im Guide angezeigt werden. Das klappt mit IFF-ILBM
und JPGs, andere Formate hab ich bis jetzt noch nicht getestet, dürfte
aber nur von den vorhandenen Datatypes abhängig sein.. ist ja MultiView ;)


Jedenfalls sehen die Links dann z.B. so aus:
code:
@{" IFF Button " LINK "pic/bla.iff/main"}

@{" JPG Button " LINK "pic/bla.jpg/main"}


So kann man Bilder aus einem Guide heraus anzeigen.. zwar auf einer
eigenen Seite, aber besser als gar nichts ;)



Zitat:
Auserdem würde ich gerne das Prog openurl irgendwie verwenden
um bequem vom Guide aus auch webadressen anzusurfen.


Kurze Antwort: ARexx

;) Im Ernst, man kann aus AmigaGuide raus auch prima irgendwelche
Programme oder Skripte aufrufen.. für's Anspringen von Webseiten
würde ich ganz klar ARexx benutzen (direkt Browser checken oder
über OpenURL gehen).
Aus AmigaGuide ruft man Programme/Skripte so auf:

code:
@{" Starte Editor " SYSTEM "ed neu.txt"}

@{" Starte ARexx-Skript " SYSTEM "rx rexx:myscript.rexx"}


Also statt dem Schlüsselwort "LINK" das Schlüsselwort "SYSTEM"
benutzen.. man kann die Schlüsselworte natürlich auch klein
schreiben, aber zwecks der Übersicht hab ichs hier halt groß
geschrieben... nur eine Nebeninfo..

Ok, hoffe, ich konnte Dir helfen..
Viel Spaß nocht!


AmigaGuide RULEZZZ :bounce:

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

09.02.2003, 16:56 Uhr

[ - Direktlink - ]
Thema: SFS, aber woher?
Brett: Amiga, AmigaOS 4

Zitat:
Original von Bladerunner:
Cyborg: Ahem nein, da gibts nur die ganz alte SFS Version ;)



Oh, sorry... hab in der Eile nicht drauf geachtet... :glow:
Aber _PAB_ hat ja schon geholfen ;)

--
Bye,
Cyborg
-- We would die for :commo:
 
Cyborg   Nutzer

09.02.2003, 16:53 Uhr

[ - Direktlink - ]
Thema: Hat jemand ein miamipppoe17.device übrig???
Brett: Amiga, AmigaOS 4

Zitat:
Original von Flinx:

Cyborg:
Bei Miami war nur 1.5 dabei.



Ehrlich? Ich hab hier 1.7 und kann mich nicht entsinnen das jemals
geupdated zu haben.. ?(

Vielleicht war die 1.5 nur bis zu einem bestimmten Zeitpunkt bei
Miami dabei und wurde irgendwann durch die 1.7 ersetzt?!

Naja, wie auch immer .. ich hab ihm die 1.7 nicht geschickt, weil
er nicht geschrieben hat, daß er MiamiDx (registriert) hat.. sonst
hätt' ich's auch hergegeben ;)

--
Bye,
Cyborg
-- We would die for :commo:
 
 
-1- 2 Ergebnisse der Suche: 47 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.