amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

Erste 1 2 3 4 5 -6- Ergebnisse der Suche: 164 Treffer (30 pro Seite)
MarkusPohlmann   Nutzer

24.05.2004, 12:15 Uhr

[ - Direktlink - ]
Thema: Leerzeichen,lange Dateinamen
Brett: Amiga, AmigaOS 4

[quote]
Original von chkamiga:
>Was soll das denn jetzt wieder? Du bist im Besitz eines
>Kopierschutzes? Was hast du dafür bezahlt?

Wie meinst du das?

Ich habe den Schutz mit dem Leerzeichen.
[/QUOTE]
Wenn ich Diesel in meinen Benziner tanke, dann ist das
auch eine ziemlich sichere Wegfahrsperre...
Was ich damit sagen will:
Auf die Frage nach einem Kopierschutz damit zu antworten,
die CD einfach nach (k)einem Standard anzulegen, den der zum Kopieren verwendete Computer nicht verarbeiten kann ist irgendwie dumm.
Immerhin sollte der Computer nicht kopieren ABER DIE DATEN TROTZDEM LESEN KÖNNEN! Kann er das?

Oder verstehe ich hier die Bedeutung eines Kopierschutzes falsch?

[QUOTE]
Den schutz mit dem Virus
[/QUOTE]
Nennt man das nicht im allgemeinen Impfung? :lach:

[QUOTE]
Und einen Kopierschutz für AudioCDs
[/QUOTE]
Da hab'ich auch einen entwickelt, der "Durchbruch" überhaupt
auf dem CD-Kopierschutzsektor, wortwörtlich...
*Knack* und schon ist kein Kopieren mehr möglich.
Kostet nichts und geht sogar mit DVDs.


[QUOTE]
Bezahlt habe ich für keines was, hab ich selbst gemacht.
[/QUOTE]
Na dafür hätte ich sicherlich auch keinen Cent ausgegeben...

 
MarkusPohlmann   Nutzer

26.03.2004, 09:43 Uhr

[ - Direktlink - ]
Thema: Probleme mit Mediator/Voodoo3/Picasso
Brett: Amiga, AmigaOS 4

Hallo zusammen,

ich habe immer noch einige Probleme mit Picasso.
Ich habe einen Amiga 1200 mit Mediator, Blizzard PPC, Voodoo3
Grafikkarte und eben Picasso als Treibersystem.

Problem Nr.1: alle Hyperion-Spiele (Heretic II, Descent - Freespace)
spielen bei mir keine Animationen ab. Die Spiele sind vollständig
installiert und liefen auf meinem alten Computer (Cyberstorm PPC,
CybervisionPPC-Graka, Cybergraphics)perfekt mit Animationen.

Woran liegt das? Fehlt mir ein Screenmode für die Animationen?
Snoopdos crasht dummerweise genau in dem Moment, wenn die Animationen
abgespielt werden sollen, also kann ich nicht genau rausfinden
woran das liegt.

Die Spiele selbst laufen perfekt, Warp3d funktioniert bestens.
Nur die Animplayer der Spiele irgendwie nicht, was mache ich falsch?

Bitte jetzt nicht antworten, dann nutze doch Cybergraphics!
Ich bin auf Picasso angewiesen (dank Mediator/Voodoo3-Kombination),
anders läufts nicht.

Dann gibt es da noch dieses Programm "picasso-emulationupdate" welches
cybergraphics emulieren soll. Als ich das ausprobieren wollte, meldet
es "Benötige cybergraphics.library V41". Ist ja ein tolle Emulation,
wenn die original Library gebraucht wird. Installiere ich die
Library, startet allerdings RTG nicht mehr richtig beim Booten,
weil scih CGFX und Picasso nicht gegenseitig vertragen.
Kann mir jemand helfen, wie man das Programm ans laufen bekommt?


Und hier noch meine Dauerbrennerfrage:
Hat mitlerweile irgendjemand rausgefunden, ob man Wipeout
dazu überreden kann, die Animationen (mit oben aufgeführter
Konfiguration) abzuspielen?

Vielen Dank im Voraus für eure Hilfe!

P.S.: Ich habe bereits die Suchen-funktion genutzt, um rauszufinden,
wer noch solche Probleme und hoffentlich Lösungen hat. Auf Probleme
bin ich gestossen, aber noch nicht auf Lösungen die bei mir geholfen
haben...
 
MarkusPohlmann   Nutzer

16.01.2004, 13:46 Uhr

[ - Direktlink - ]
Thema: Wipeout-Intro/Zwischenanimationen mit Picasso
Brett: Amiga, AmigaOS 4

Hm, dann ist das mit Freespace und Heretic also ein Problem nur
bei mir.

Ich sehe jetzt eigentlich 3 mögliche Gründe:
-falsche Env-Variablen (Ich lese mich wieder durch sämtliche Readmes)
-falsche/fehlende Libraries (bei der Installation irgendeine falsche Version eingeschmuggelt?)
-fehlende Screenmodes ?!(Hatte Jahrelang Cybergfx und kenne mich mit
Picasso noch nicht so aus)

Dumm ist, dass SnoopDos abstürzt sobald es zum abspielen
der Animation käme, also muss ich mich anders herantasten,
was es sein könnte.

Heretic II meldet übrigens auf der Konsole, dass die Datei
mit dem Intro abgespielt werden sollte, aber nicht geöffnet
werden konnte. Der Pfad stimmt aber, und die Datei ist da!

Ich gebe dann den Kampf mit Wipeout wohl auf, aber Heretic II
und Freespace sollten schon wieder mit Animation laufen...
 
MarkusPohlmann   Nutzer

15.01.2004, 08:48 Uhr

[ - Direktlink - ]
Thema: Wipeout-Intro/Zwischenanimationen mit Picasso
Brett: Amiga, AmigaOS 4

Sorry für das ausgraben dieses alten Threads, aber es gibt
Fortschritte die vielleicht jemand anderem Helfen eine Lösung
zu finden... oder so...

Also:
Nachdem ich ein Update der Mediator System Files eingespielt habe
habe ich in den Readmes gelesen, dass ich ein paar ENV-Variablen
umsetzen muss.

Meine Adresse für den Grafikspeicher (war glaube ich die Variable gfxaddr?! müsste ich nochmal nachgucken) stand auf einem Wert,
den ich über irgendein PCI-Hilfsprogramm herausgefunden habe.

Diese EInstellung lief zwar für Warp3d war aber wohl für andere
Konfigurationen gedacht.

Die Adresse habe ich nun auf 200000 geändert und Wipeout stürzt nicht
mehr ab, allerdings wird die Animation nicht angezeigt.

Der Animationsplayer läuft an, aber der Bildschirm bleibt schwarz.

An der Festplattenaktivität sieht man aber, dass der MPEG File
abgespielt, bzw. zumindest zur Laufzeit geladen wird.

Jetzt werde ich im nächsten Schritt mal versuchen meine Cybergfx-
emulation neu zu installieren bzw. noch ein paar Env-Variablen
nochmal prüfen (nicht immer dem ersten Readme vertrauen...).


Ähnliche Probleme habe ich allerdings auch noch weiterhin mit Freespace und Heretic II:

Die Anfangsanimationen werden nicht abgespielt, die Spiele
starten einfach ohne. Auch mit dieser Änderung.
Hat hier jemand einen Tipp oder besser noch,
hat jemand die betroffenen Programme auf einem System
mit Mediator / BlizzardPPC / Voodoo3 / WarpUp /Warp3d und Picasso96
laufen, inkusive aller Animationen?
 
MarkusPohlmann   Nutzer

08.01.2004, 08:59 Uhr

[ - Direktlink - ]
Thema: Micronik Zorro Board Stromanschluss ?!
Brett: Amiga, AmigaOS 4

Ich hatte genau das gleiche Problem mit meinem mittlerweile
defekten Board...

Ich war bei Coolbits weil meine ISDN- und Ethernetkarte nicht
im System eingebunden wurden, obwohl Strom da war und habe
folgende kuriose Erklärung mit funktionierender Lösung bekommen:

Man sagte mir, der Widerstand im Board sei zu hoch, die Signale
die über das Board geleitet werden kommen nicht an weil der
Stromverbrauch zu gering wäre. Also: "Mehr Power!"
Dann haben wir ausprobiert, eine Zorro-AT-Bus-Kontroller-Karte
zusätzlich einzustecken, damit noch mehr Strom gezogen wird.

Und siehe da, alle Karten wurden angezeigt und funktionierten.

Nahm man eine Karte raus (egal welche) waren alle Karten wieder
nicht verfügbar.

Ich bin kein Elektriker, weiss nicht ob das wirklich so ist, ich
kann nur sagen, es hat funktioniert.

Versuche es einfach mal, wenn Du irgendwo noch eine alte Zorrokarte,
egal wofür, bekommen kannst und auf einen Port verzichten kannst.

Ein kleiner Tip noch vorweg, damit Dir nicht das gleiche
passiert wie mir:

Achte darauf, dass die Stromstecker nicht zu heiss
werden, bei mir fing irgendwann an, das Plastik zu schmelzen
und seit dem ging es Bergab mit dem Board und dem Computer...

Ich hatte beide Stecker angeschlossen, auf Mainboard und Zorroboard
und beide wurden zu heiss...

Vielleicht hast Du mehr Glück.
 
MarkusPohlmann   Nutzer

02.07.2003, 10:56 Uhr

[ - Direktlink - ]
Thema: Musik und Samples mit AHI abspielen
Brett: Programmierung

Hallo,

erstmal vorweg, ich habe kaum Ahnung von AHI! :D
Durch entsprechende Tutorials habe ich rausbekommen wie
ich im Programm ein AHI-Device öffnen und schliessen
kann, aber was Musik betrifft habe ich keine Informationen
auftreiben können.

Ich möchte zusätzlich zu Samples in meinem Programm
(Bsp.: Schussgeräusch einer Waffe) auch Musik abspielen
und habe keine Ahnung wie das geht (lese in den Tutorials
nur immer was über einzelne Samples).

Bevor ich das Rad neu erfinde, frage ich lieber mal erst um Hilfe.
Es wäre schön wenn jemand sein wissen teilen könnte, damit
ich mich nicht für weitere drei Monate verzetteln muss bis
ich weiter vorran komme. ;)

Also, gibt es Sourcen oder Routinen zum AHI-konformen Musik
abspielen wobei ich eben auch zeitgleich noch einzelene
Samples abspielen kann?

Falls ja, was für (Modul-)Formate werden unterstützt?

Falls nein, kann mir trotzdem jemand helfen? ?(

Mit freundlichen Grüssen
Markus Pohlmann
 
MarkusPohlmann   Nutzer

02.06.2003, 08:14 Uhr

[ - Direktlink - ]
Thema: Wipeout-Intro/Zwischenanimationen mit Picasso
Brett: Amiga, AmigaOS 4

Also was Wipeout angeht, kann ich mich nur Andreas anschliessen.
Ich kann die MPEGs ganz normal mit AMP abspielen, aber Wipeout selber
(egal wie jetzt die Grafik dargestellt wird) crasht.

Muss etwas mit dem Player zu tun haben, Warp3d jedenfalls läuft bei
mir bestens.


Was Freespace angeht, so spielt es die Animationen bei mir weder
von CD noch von Festplatte (sind dort auch installiert).
Ich werde mal eine Neuinstallation probieren, dachte mir eigentlich
eventuell würde es an den Screenmodes liegen.

Mit freundlichem Gruss
Markus
 
MarkusPohlmann   Nutzer

02.06.2003, 08:06 Uhr

[ - Direktlink - ]
Thema: Speicherzugriff im PPC Teil eines Mixed Binary
Brett: Programmierung

Zitat:
Original von Holger:

Besser ist es, von vornherein zwei separate Prozesse zu erzeugen, einen auf 68k und einen auf dem PPC und diese durch Signale/Messages kommunizieren zu lassen. Das gleiche passiert bei den "Kontextswitches" auch, allerdings transparent für den Programmierer.
Der Vorteil der manuellen Vorgehensweise ist die höhere Kontrolle, z.B. kann man die Kommunikation asynchron laufen lassen und den ppc-task nur dann unterbrechen, wenn der 68k-task tatsächlich ein event empfangen hat. Außerdem ist viel schwieriger, aus Versehen eine Message zu verschicken, als einen ungewollten Kontextswitch einzubauen.



Eine interessante Idee, könnte ich mir auch durchaus für diese
Grafikengine vorstellen. Allerdings würde ich
zuvor docherstmal gerne mein Programm nach
Contextswitches durchforsten um den PPC-Teil auch wirklich 100%
auf PPC laufen zu lassen, bevor ich mich an sowas heranwage.
Für's erste wäre ich froh wenn ich mit den zwei Contextswitches
zwischen Steuerung und Bildaufbau klar käme.

Kann mir jemand sagen wo ich dieses oben erwähnte "contextswitch"
Programm finden kann oder kann mir das jemand mailen?
Oder gibt es andere Möglichkeiten Contextswitches zu "entdecken"?

Mit freundlichem Gruss
Markus Pohlmann
 
MarkusPohlmann   Nutzer

30.05.2003, 12:30 Uhr

[ - Direktlink - ]
Thema: Wipeout-Intro/Zwischenanimationen mit Picasso
Brett: Amiga, AmigaOS 4

Hallo,

ich habe eine Blizzard PPC im Mediator mit Voodoo3 Karte, WarpUp,
Warp3d und Picasso96 und habe bereits durch einige
Forumsrecherche Wipeout auf dieser Konfiguration ans laufen
bekommen (Screen mit Edito ins Settings eintragen...).

Allerdings werden die Animationen nicht vom Spiel aus abgespielt
(WarpUp-Exception, irgendwas wie Storage Violation bei Adresse 0).

Kann mir jemand helfen und erklären wie ich die Anims an laufen
bekomme?

Freespace macht mir ähnliche Probleme, die Animationen werden dort
gar nicht gespielt.
Muss ich hier irgendwas umkonfigurieren, oder brauche ich andere
Screenmodes (kann man irgendwie CyberGFX-Screenmodes definieren,
die über die Picassoemulation von CyberGFX angesprochen werden)?

Mit freundlichen Grüssen
Markus
 
MarkusPohlmann   Nutzer

30.05.2003, 08:50 Uhr

[ - Direktlink - ]
Thema: Speicherzugriff im PPC Teil eines Mixed Binary
Brett: Programmierung

Hallo,

vielen Dank schonmal für die Tips.

Ich denke mal dass zur Zeit unbewusste Contextswitchs mein
Problem sind, deswegen werde ich das mit dem Programm mal versuchen.
Allerdings kann ich es nirgends zum Download finden.
Die einzige Webpage die mir Google ausspuckt ist entweder offline
oder verweigert mir den Zugriff. Wo könnte ich es denn sonst
herbekommen, bzw. kann mir das jemand mailen?

Vom Programmstil her würde ich ganz gerne das Programm so ziemlich
alles auf PPC Seite machen lassen und dann einen Contextswitch
zum 68k machen, dort die Funktionen wie Mausclicks (Menüsteuerung),
Joypadabfrage machen (habe keine Ahnung ob ich das irgendwie
auf PPC-Seite durchführen könnte) und dann wieder mit einem
Contextswitch zurück auf den PPC die Grafik zurechtkopieren
und ausgeben.

Dazu habe ich mir die "Rohdaten" der Grafiken gespeichert und
eine Maske, welche Bytes ich davon darstellen möchte und welche nicht.
Die Maske arbeite ich dann ab und kopiere für jeden Grafikblock
den ich darstelle die RGB-Bytes in den Grafikpuffer, bzw. schiebe
den Pointer wohin ich kopiere um soviele Bytes weiter wie ich keine
Pixel darstellen möchte.

Ich habe mir erhofft, dass dieses "Pixelkopieren" auf PPC schneller
läuft. Zur Zeit verwende ich dann allerdings zum darstellen noch
einen 68k Aufruf (habe den Source gerade nicht vor mir, irgendwas
wie WirteRGBArray oder sowas um den ganzen Bildpuffer auf den 16Bit-
Screen zu bekommen), aber das sollte mit chunkyppc.library doch
auch auf PPC-Seite möglich sein, oder?

Mit freundlichem Gruss
Markus
 
MarkusPohlmann   Nutzer

23.05.2003, 11:16 Uhr

[ - Direktlink - ]
Thema: Speicherzugriff im PPC Teil eines Mixed Binary
Brett: Programmierung

Hallo zusammen,

ich habe ein Programm welches jede Menge Speicher umherkopiert
und so einen Bildpuffer im RGB Format aufbaut und das ganze
dann auf einem 16 Bit- Cybergfx Screen ausgibt.

Kann ich, was die Speicherkopiererei angeht, Geschwindigkeitsvorteile
gegenüber 68k erreichen, wenn ich diesen Teil auf PPC umsetze?

Falls ja, worauf muss ich dann achten?
-In welchem Programmteil am besten allokieren (68k,PPC oder Global)
-Welche Parameter muss ich mitgeben, damit der Speicherzugriff
möglichst schnell ist (bei meinen ersten Versuchen waren die
Speicherzugriffe im PPC-Teil immer langsamer als im 68k Teil)?
-Welche Grösse sollten die zu kopierenden Speicherblöcke
idealerweise haben?

Es wäre schön, wenn mir hier jemand helfen könnte, der sowas
vielleicht selber schonmal erfolgreich versucht hat zu optimieren.

Mit freundlichem Gruss
Markus Pohlmann
 
MarkusPohlmann   Nutzer

22.01.2003, 17:38 Uhr

[ - Direktlink - ]
Thema: Läuft Mediator/Voodoo3 auch irgendwie mit CyberGFX?
Brett: Amiga, AmigaOS 4

Danke für die Antworten soweit.

Also was an Warp3d bei mir nicht klappt...

Laut Installation klappt alles, aber sobald ich eines
der Mitgelieferten Demos oder irgendein anderes
Programm, welches Warp3d nutzt (Payback zum Beispiel)
starte, wird mein Bildschirm dunkel und der Computer
resettet sich.

Ich habe da noch keine Ahnung woran das liegt.

Was mein weiteres programmiertechnisches Problem ist,
ich kenne Picasso96 einfach nicht und alle meine
Programme habe ich auf CyberGFX zurechtgeschnitten.

Wenn ich jetzt Funktionen aus den CyberGFX Libraries
nutze, würde Picasso96 damit klar kommen?
Ich denke ich muss wohl die Bildschirmmodi noch
umprogrammieren, denn die habe ich etwas hart kodiert.

Aus diesem Grunde hatte ich gehofft, irgendwie auf
CyberGFX wieder aufsetzen zu können. Wenn die Emulation
das schafft, dann wäre das super, aber dazu würde ich erstmal
gerne auch laufendes Warp3d haben.

Tja, wenn mir da vielleicht jemand weiterhelfen könnte?

Gruss
Markus

 
MarkusPohlmann   Nutzer

21.01.2003, 14:12 Uhr

[ - Direktlink - ]
Thema: Läuft Mediator/Voodoo3 auch irgendwie mit CyberGFX?
Brett: Amiga, AmigaOS 4

Hallo zusammen,

hier mal eine Frage an alle Grafikkartenexperten:

Ich habe einen nagelneuen Amiga 1200 mit Blizzard 1260,
Mediator PCI-Board und Voodoo3 PCI Grafikkarte.

Was ich beim Kauf nicht wusste, war, dass ich an Treibern
nur Picasso96 Software erhalte. Diese läuft jetzt zwar bei
mir, aber um alle meine allten Programme weiter zu nutzen,
welche ich für CyberGFX konfiguriert bzw. programmiert
habe, wüsste ich gerne, ob es irgendwie und wenn ja wie
möglich ist:

1. Die Voodoo3 Grafikkarte unter CyberGFX anzusprechen und
2. Warp3d dafür zu installieren (bekomme ich unter Picasso96
momentan nicht ans laufen)

Vielen Dank für die Hilfe im Vorraus!

Gruss
Markus Pohlmann
 
MarkusPohlmann   Nutzer

15.12.2002, 17:47 Uhr

[ - Direktlink - ]
Thema: Verfügbarkeit von Blizzard PPC-Karten
Brett: Amiga, AmigaOS 4

Hallo,

ich benötige dringend Hilfe.

Mein alter Cyberstorm PPC Rechner ist nun schon seit ca. 2 Monaten
schrott. Die Grafikkarte und das Busboard sind defekt, die gesamte
Stromversorgung überhitzt (die Platiskstecker schmelzen selbst wenn
keine Geräte angeschlossen sind) und eigentlich gibt so alles
den Geist auf (warum der Amiga dennoch online geht muss wohl an seiner
Robustheit liegen... Galgenhumor).

Nun, ich kann aber schon seit langem nicht mehr weiterprogrammieren
(wer sich gefragt hat, warum man nichts mehr von Projekt Crashsite
hört... - ich habe keinen Entwicklungsrechner mehr) und
brauche dringend ein funktionierendes PPC System um weiter zu machen.

Micronik war mir eine Lehre, nie wieder!

Deswegen wartet nun schon seit ca. 2 Monaten ein nagelneuer Computer
auf mich bei einem Versandhändler, das einzige was fehlt ist
eine Blizzard PPC-Karte, die es garantiert Morgen gibt, bzw. übermorgen, nein
über übermorgen dann...

Wer kann mir sagen, wo ich eine funktionierende NICHT GEBRAUCHTE
Blizzard PPC Karte (mit 233Mhz oder schneller, 68060er und möglichst
SCSI) her bekomme?

Damit jetzt dieses Forum hier nicht für Schleichwerbung missbraucht
wird, schreibt mir bitte, wenn ihr mir weiterhelfe könnt und wisst,
wo noch Blizzard PPC Karten original zu kaufen sind
per Email an: Markus-Pohlmann@t-online.de

Vielen Dank für die Hilfe im vorraus.

Mfg
Markus Pohlmann
 
 
Erste 1 2 3 4 5 -6- Ergebnisse der Suche: 164 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.