amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 3 4 5 6 >> Letzte Ergebnisse der Suche: 345 Treffer (30 pro Seite)
Primax   Nutzer

24.01.2023, 13:53 Uhr

[ - Direktlink - ]
Thema: Amiga: Gibt es eine Gruppe in Leipzig?
Brett: Get a Life

@Maverik:

Ja, danke.
Ich hatte mich schon mehrfach bemüht, Amigafuture1000 zu kontaktieren (kontaktieren zu lassen), um mal ein paar Infos zu sammeln und dann ein kleine Meldung zu schreiben. Eben damit jeder davon weiß.
Aber leider keine Rückmeldung bisher.
 
Primax   Nutzer

23.01.2023, 09:06 Uhr

[ - Direktlink - ]
Thema: Amiga: Gibt es eine Gruppe in Leipzig?
Brett: Get a Life

@Gunther:

Morgen.

Leipzig weiß ich nicht, aber es gibt definitiv Nutzer in Halle ;)
 
Primax   Nutzer

22.01.2023, 17:33 Uhr

[ - Direktlink - ]
Thema: AmigaOne X5000: OS4- und MorphOS-SSD-Platte permanent verbunden
Brett: Amiga, AmigaOS 4

@FlynnTheAvatar:

Danke, ja. Das hatte ich jetzt durch Recherchen und freundliche Auskünfte von Entwicklern auch herausgefunden:
OS4 unterstützt von Haus aus nicht (mehr) SFS2. Dafür ist die Enhancer Software notwendig. Die hatte ich gekauft und installiert: das "SmartFileSystem" steht unter Kickstart (V1.293). Ist noch etwas anderes nötig?

Sehen kann ich die MorphOS-Partitionen jedenfalls nicht...Hat das ggf. etwas mit der Fehlermeldung zu tun?

Unter MorphOS werden mir die beiden SSD-Platten als "ide.device:0" für MorphOS und "ide.device:1" für OS4 in der HDToolbox angezeigt. Die beiden Partitionen von MorphOS sind mit SFS V1.229 formatiert. Und die vier Partitionen von OS4 werden ebenso korrekt mit 3x NGF/01 und 1x FFS LNFS angezeigt.

Unter MorphOS werden mir keine Fehler angezeigt...

[ Dieser Beitrag wurde von Primax am 22.01.2023 um 17:36 Uhr geändert. ]

[ Dieser Beitrag wurde von Primax am 22.01.2023 um 17:39 Uhr geändert. ]
 
Primax   Nutzer

22.01.2023, 12:52 Uhr

[ - Direktlink - ]
Thema: AmigaOne X5000: OS4- und MorphOS-SSD-Platte permanent verbunden
Brett: Amiga, AmigaOS 4

@thomas:

Ehrlich gesagt will ich ja gar nicht, dass ich unter OS4 die MorphOS-Partitionen sehen kann. Dann komme ich gar nicht erst in die Versuchung, darauf zuzugreifen. Denn so wirklich weiß doch keiner, was dann passiert, oder?

Aber wenn du sagst, dass die Fehlermeldung nicht kommen sollte, dann schau ich mal unter MorphOS, was da angezeigt wird. Danke.

@ylf

Wie geschrieben: nur eine FFS Partition.
 
Primax   Nutzer

22.01.2023, 06:36 Uhr

[ - Direktlink - ]
Thema: AmigaOne X5000: OS4- und MorphOS-SSD-Platte permanent verbunden
Brett: Amiga, AmigaOS 4

Hallo.

Im letzten Tutorial über die Nutzung zweier Grafikkarten im X5000 (https://www.amiga-news.de/de/news/AN-2023-01-00051-DE.html) ging es auch darum, ob und wie man sowohl die AmigaOS-4, als auch die MorphOS-SSD-Platte permanent und gleichzeitig an die beiden SATA-Ports anschließen kann. Ich hab das in meinem Fall jetzt mal getestet, beide verbunden und dann anschließend nacheinander die beiden OS hochgefahren:

Dabei ist die Ausgangslage bei mir folgendermaßen:
MorphOS hat zwei Partitionen, die beide mit SFS formatiert sind und DH0 bzw. "System" und DH1 bzw. Work heißen.
AmigaOS 4 hat vier Partitionen: drei Mal NGFS (das NGF\01) und einmal FFS mit den RDDH0 (AmigaOS4), RDDH1 (Anwendungen), RDDH2 (SysBackUp) und SDK. Hier gibt es also weder von den Laufwerksbezeichnungen, noch den Namen her Überschneidungen.

1.) AmigaOS 4 erkennt keine der MOS-Partitionen! Allerdings meckert die MediaToolbox beim Starten, dass ein Laufwerk zugefügt wurde und ich es doch aktualisieren solle. Was ich nicht getan hab. Die Platte wird mir mit "fehlerhaftem RDB" angezeigt.

2.) MOS erkennt eine OS4-Partition: nämlich die SysBackUp, die mit FFS formatiert ist.

Das heißt, ich könnte nur von MorphOS aus aktiv auf das andere System zugreifen.

Der MorphOS-Entwickler Frank Mariak meinte auf meine Nachfrage, warum ich unter MorphOS die eine OS4-artition sehe: das sei nachvollziehbar, denn MorphOS sollte eigentlich kompatibel zu FFS bleiben, weil es auch das weiterentwickelte FFS bzw. die Reimplementation von Olaf Barthel benutzt.

Bleibt nur die Frage, warum sehe ich dann nicht die beiden MorphOS-Partitionen unter AmigaOS 4?
 
Primax   Nutzer

21.01.2023, 19:13 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

Er kann die Datei auch mir schicken und ich leite sie an dich weiter.
Aber vielleicht passt ja auch, was du gemacht hast...
 
Primax   Nutzer

21.01.2023, 06:23 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Ergänzung von Zoltan:
"Ich glaube nicht, dass die vorgeschlagenen Änderungen in dieser Nachricht das Problem beheben würden, aber sie könnten helfen, das Problem etwas mehr einzugrenzen:

Es sind 4 Zeilen mit der "snap"-Variable (ihre Definition, 2 Zeilen, die sie verwenden und 1 Zeile, die sie freigibt) in der Datei qemu/hw/display/sm501.c der Funktion sm501_update_display() zu entfernen und int full_update = 0; in 1 am Anfang der Funktion zu ändern und damit neu zu kompilieren.

Dadurch wird die Nachverfolgung geänderter Bereiche auf dem Bildschirm deaktiviert und eine mögliche Race Condition beseitigt, aber wenn dies das Problem war, können Grafikelemente verzögert werden, aber nicht vollständig fehlen. In Ermangelung einer besseren Idee ist es vielleicht trotzdem einen Versuch wert, zumindest könnte es bestätigen, dass es nicht mit diesen Teilen zusammenhängt."
 
Primax   Nutzer

20.01.2023, 05:47 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Zoltan hatte mit deiner Hilfe das Problem etwas eingegrenzt und eine Nachfrage auf QEMU-List veröffentlicht:

https://lists.nongnu.org/archive/html/qemu-devel/2023-01/msg04313.html

Vielleicht kannst du mit Hilfe eines Übersetzungs-Tools dir das mal ansehen und das "commenting out memory_region_snapshot_and_clear_dirty() and memory_region_snapshot_get_dirty()" mal ausprobieren, falls dir das was sagt...
 
Primax   Nutzer

17.01.2023, 14:05 Uhr

[ - Direktlink - ]
Thema: AROS: Tester für neue ABIv0 (32-bit) Version gesucht
Brett: AROS und Amiga-Emulatoren

Wie Krzysztof 'deadwood' Śmiechowicz schreibt, wird an der nächsten Version von AROS ABIv0 für 32-bit x86-Rechner gearbeitet. In diesem Zuge sucht er bei Vorhandensein eines AROS-kompatiblen Rechners Tester:

https://ae.amigalife.org/index.php?topic=1063.75#msg14110
 
Primax   Nutzer

04.01.2023, 07:40 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Zoltan:

"Es ist nicht notwendig, irgendetwas mit einem Debugger zu tun, testen Sie einfach, ob der Build mit --enable-debug das gleiche Problem wie vorher hat, indem Sie den gleichen Befehl verwenden. Die Option --enable-debug deaktiviert die Compiler-Optimierungen und einige QEMU-Optimierungen, sodass dies zeigen sollte, ob das Problem mit diesen oder etwas anderem zusammenhängt.

Mit der Hilfe eines AmigaOS-Entwicklers, der schon einmal dabei geholfen hat, denke ich nun, dass das Problem mit der 2D-Beschleunigung in sm501 zusammenhängt, die nur AmigaOS verwendet (vielleicht auch einige Linux X-Server, aber ich kenne keine einfach zu testende Live-CD, die auf dem sam460ex mit sm501 funktioniert, die meisten benötigen eine Radeon-Karte). Mit den bisherigen Tests können wir auch pixman ausschließen, da das Problem auch bei alten Versionen auftritt, die es nicht verwendet haben. Es sieht also so aus, als ob Daten, die in qemu/hw/display/sm501.c::sm501_2d_operation() geschrieben werden sollten, nicht von sm501_update_display() in derselben Datei gesehen werden. Die Funktion sm501_2d_operation() wird aufgerufen, wenn der Gast die 2D-Engine der sm501-Karte programmiert, die für Blits und Fills verwendet wird und die Pixeldaten im Ram der Karte ablegen soll. Dann ruft das UI-Backend periodisch die Funktion sm501_update_display() auf, um das Bild aus dem Ram der Karte zu holen und es auf die Anzeigefläche zu kopieren, die auf dem Host angezeigt wird. All dies geschieht außerhalb des Codes, den ich jetzt habe, also sehe ich nicht, warum es fehlschlagen könnte. Entweder werden die Daten aus irgendeinem Grund nicht in sm501_2d_operation() geschrieben, oder die Aktualisierungsfunktion sieht nicht denselben Speicher, den die Schreibvorgänge verändert haben (was passieren kann, wenn Hardware-Caching und verschiedene Threads involviert sind, bei denen die Schreibvorgänge nicht richtig synchronisiert werden, was etwas ist, das ARM und PPC brauchen, x86 aber nicht, aber ich weiß nicht, ob das wirklich der Grund ist und wo man es beheben kann). Sobald wir das Problem gefunden haben und eine bessere Vorstellung davon haben, was passiert, werde ich versuchen, in der QEMU-Liste nachzufragen.

Um zusätzliche Debug-Meldungen zu erhalten, können Sie die folgenden Kommandozeilenoptionen hinzufügen: -d unimp,guest_errors -trace enable="sm501_2d*", was einige Zeilen über nicht implementierte Teile und Zugriffe auf die sm501 2d Funktion ausgibt, was mehr sein wird, als man auf einem Screen sehen kann, also sollte man in eine Datei umleiten, um es zu speichern und einen Link dazu zu posten. Diese Optionen funktionieren auch ohne --enable-debug, wenn also der --enable-debug-Build funktioniert, kann man das gleiche ohne --enable-debug testen und sehen, ob die Logs die gleichen sind. Wenn es auch mit --enable-debug fehlschlägt, ist es nicht nötig, beide Optionen zu testen, da das Problem nicht mit der Optimierung zusammenhängt, sondern wahrscheinlich ARM- oder M1-spezifisch ist."
 
Primax   Nutzer

04.01.2023, 07:19 Uhr

[ - Direktlink - ]
Thema: amiga68k.de steht zum Verkauf
Brett: Get a Life

Nachdem es 2018 schon kurzzeitig abgeschaltet war:
https://www.amiga-news.de/de/news/AN-2018-12-00033-DE.html

...scheint es nun endgültig vorbei zu sein:

http://www.amiga68k.de/

Weiß jemand genaueres?
 
Primax   Nutzer

03.01.2023, 18:14 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Zoltan:
"OK, danke für den ausführlichen Test, das hilft, das Problem zu lokalisieren.

Nur eine Vermutung, aber die Option -display gtk könnte einen X-Server benötigen, je nachdem, wie die gtk-Bibliotheken kompiliert wurden. Unter macOS kann gtk auch verschiedene Grafik-Backends verwenden, von denen einer der native Quarz ist, der ohne zusätzliche Software funktionieren sollte, aber es ist auch möglich, es so zu kompilieren, um X zu verwenden. In diesem Fall muss man X11.app installieren, das früher Teil der devel-Diskette war, aber heutzutage wahrscheinlich in brew enthalten ist. Wie auch immer, es ist jetzt nicht benötigt, da das Testen mit Cocoa und sdl bestätigt, dass es nicht am UI Backand-Teil liegt. Das Update Parch hat bestätigt, dass es nicht an der Änderungsverfolgung oder an Updates liegt und dass es mit AROS und MorphOS funktioniert, was darauf hindeutet, dass das Problem entweder in der 2D-Beschleunigung oder in der DMA-Controller-Emulation liegt, da nur AmigaOS diese auf dem sam460ex verwendet, während AROS und MorphOS nur die CPU zum Rendern verwenden, da ihre SM502-Treiber ziemlich minimal sind.

Leider weiß ich immer noch nicht, was falsch ist und warum es nur auf
Apple-Silizium-Macs versagt, während es auf x86_64 funktioniert, aber zumindest gibt es eine Idee, wo das Problem weiter zu suchen ist. Dass das Testen mit der Vor-5.1-Version immer noch das gleiche Problem hervorruft, zeigt auch, dass es nicht an pixman liegt, also vielleicht liegt es doch in QEMU. Es könnte aber auch etwas nicht-triviales sein wie Interaktion zwischen den Interna von QEMU sein, daher bin ich mir nicht sicher, wie man das Problem beheben kann.
Vielleicht könnten Sie versuchen, nach der Konfiguration mit der Konfigurationsoption --enable-debug neu zu kompilieren, die es viel langsamer machen wird, aber es deaktiviert einige Optimierungen und aktiviert einige Prüfungen, so könnte man die Theorie überprüfen, wenn es ein Problem mit Optimierungen in QEMU oder Clang ist oder wirklich etwas falsch mit den Geräteemulationen ist."

[ Dieser Beitrag wurde von Primax am 03.01.2023 um 18:15 Uhr geändert. ]
 
Primax   Nutzer

02.01.2023, 14:46 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Zoltan: "Damit ist zumindest bestätigt, dass das Diry Tracking funktioniert und das Problem nicht dort liegt. Dann kann es bereits im RAM der emulierten Karte defekt sein (in diesem Fall ist es ein Rendering-Problem) oder es bricht während der Anzeige auf der Host-Seite. Um das Problem weiter einzugrenzen, können Sie noch ein paar Dinge testen:

- Probieren Sie verschiedene Display-Backends aus: Das letzte emaculation.com-Build hat cocoa, sdl und gtk, also schauen Sie, ob das Problem mit allen von ihnen auftritt. Wenn ja, dann liegt es auch nicht im Backend-Teil, also müssen wir die sm501-Emulation weiter überprüfen, da wir dann die Update- und UI-Backend-Teile ausschließen können.

- Werden die fehlenden Teile angezeigt, wenn der Gast-Mauszeiger über sie fährt? Der Hardware-Cursor, der von der Maus verwendet wird, bewirkt eine Aktualisierung der Zeilen, auf denen er sich befindet. Wenn also das Überfahren der fehlenden Anzeige das Problem behebt, dann ist es nur ein Problem mit der Aktualisierung der Host-Anzeige. Aber ich denke, das Video hat gezeigt, dass es sich nicht mit der Mausbewegung ändert und das Erzwingen der Aktualisierung des gesamten Bildschirms hat es auch nicht behoben, was bedeutet, dass es wahrscheinlich schon nicht richtig gerendert wird.

- Die 2D-Beschleunigung in sm501 verwendet die pixman-Bibliothek, wenn diese also nicht wie erwartet funktioniert, könnte das ein Problem sein, aber Versionen vor QEMU 5.1 haben pixman nicht verwendet (es wurde in Commit b15a22bbcbe6a hinzugefügt) und emaculation.com-Builds verwenden möglicherweise ihre eigenen Bibliotheken, wenn es also auch mit diesen nicht funktioniert, weiß ich nicht, woher das Problem kommen könnte. Ich habe das libpixman-devel-Paket von macports zum Testen verwendet und zumindest das funktionierte auf x86_64 macOS.

- Es ist auch seltsam, dass einige Teile der Anzeige korrekt wiedergegeben werden, aber einige fehlen. Wenn wir wüssten, was der Unterschied zwischen den beiden ist, hätten wir vielleicht einen Anhaltspunkt, wo das Problem liegt. Kann das Problem mit einem anderen Gastbetriebssystem wie AROS oder Linux reproduziert werden? Auf diese Weise könnten wir es der QEMU-Liste melden, da andere, die kein AmigaOS4 haben, es dann reproduzieren könnten (obwohl wahrscheinlich niemand an sam460ex interessiert ist, sodass ich nicht erwarte, dass sich jemand darum kümmert, aber es wäre zumindest einen Versuch wert, um das Problem zu dokumentieren) oder da diese Betriebssysteme Open Source sind, könnten wir herausfinden, woher die fehlenden Updates kommen. Ich habe im Moment keine bessere Idee, wie man das Problem beheben kann."
 
Primax   Nutzer

01.01.2023, 08:07 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Hatte Zoltan nochmal deine Infos weitergegeben und er hat folgendermaßen geantwortet:

"Das scheint darauf hinzudeuten, dass das Problem nicht von QEMU selbst kommt, sondern vielleicht von einer Änderung in macOS oder den Bibliotheken, die QEMU verwendet (falls es vorher wirklich funktioniert hat, wie jemand sagte, aber da bin ich mir nicht sicher; es könnte auch sein, dass es auf M1-Macs immer kaputt war).
Ich habe es jetzt auf einem älteren macOS 10.15 Catalina mit x86_64 getestet, welches das einzige macOS ist, das ich im Moment habe, und zumindest dort gab es keine Probleme: Die AmigaOS4-Installations-ISO hat keine fehlenden Display-Updates wie im Video in den Fehlerberichten. Ich bin mir immer noch nicht sicher, was das Problem für diejenigen, die es bekommen, verursachen könnte, aber ein Workaround zum Testen könnte sein, die Erkennung von Display-Updates zu deaktivieren und jedes Mal ein vollständiges Update des gesamten Displays zu erzwingen. Dies wird das System wahrscheinlich noch mehr verlangsamen, aber wenn das Problem mit der Erkennung von Änderungen zusammenhängt, könnte dies das Problem vermeiden.
Man kann das mit diesem Patch machen (d.h. den Anfangswert von full_update auf 1 in qemu/hw/display/sm501.c::sm501_update_display() am Anfang der Funktion ändern und dann QEMU kompilieren):

diff --git a/hw/display/sm501.c b/hw/display/sm501.c
--- a/hw/display/sm501.c
+++ b/hw/display/sm501.c
@@ -1655,7 +1655,7 @@ static void sm501_update_display(void *opaque)
int dst_bpp = surface_bytes_per_pixel(surface);
draw_line_func *draw_line = NULL;
draw_hwc_line_func *draw_hwc_line = NULL;
- int full_update = 0;
+ int full_update = 1;
int y_start = -1;
ram_addr_t offset;
uint32_t *palette;
 
Primax   Nutzer

30.12.2022, 07:19 Uhr

[ - Direktlink - ]
Thema: AmigaOs4.1 Youtube
Brett: Amiga, AmigaOS 4

@Maijestro:

Warum das denn? Mach doch mal ein Bildschirmfoto, wenn du Skripte in Odyssey aufgerufen hast.
 
Primax   Nutzer

30.12.2022, 07:13 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

Ich hatte den Amiga-QEMU-Entwickler Zoltan BALATON gebeten, hier mal mitzulesen (er kann gut deutsch lesen) und hat folgende Anmerkungen:

"Ich würde auf meine http://zero.eik.bme.hu/~balaton/qemu/amiga/ Seite verweisen, wo es einige Informationen gibt, die helfen könnten, also empfehle ich, sie sorgfältig zu lesen und es gibt auch einen Kommentarbereich, um Fragen zu stellen.

Die Option -boot wird wahrscheinlich in keiner dieser Befehlszeilen benötigt und kann einfach weggelassen werden. (Der sam460ex und pegasos2 werden sie wahrscheinlich ignorieren und auf dem mac99 wird die Option -prom-env boot-device sie überschreiben, sodass sie den Befehl ohne Wirkung überlagern.)

Ähnlich verhält es sich mit -netdev user oder -net user, die weggelassen werden können, da dies die Standardeinstellung ist, sodass man einfach eine Netzwerkkarte als -device rtl8139 hinzufügen kann und es wird das standardmäßige user/slirp-Netzwerk ohne weitere Kommandozeilenoptionen verwendet. Das Hinzufügen eines Netzwerkgeräts ist wahrscheinlich nur auf sam460ex und pegasos2 notwendig, die keine Standard-Netzwerkkarte haben (ihre On-Chip-NICs werden nicht emuliert, sodass man ein PCI-Gerät dafür hinzufügen muss). Auf dem mac99 ist die Standardkarte sungem, die bereits standardmäßig erstellt ist, und MorphOS hat einen Treiber, der funktionieren sollte, aber es kann Probleme mit DHCP geben, sodass man die Netzwerkkonfiguration zurücksetzen und vielleicht die IP nach der Installation manuell einstellen muss. Das Hinzufügen einer weiteren rtl8139-Karte kann funktionieren, aber dann hat man zwei Netzwerkkarten und das sollte nicht nötig sein.

QEMU verwendet auf allen Plattformen den gleichen Code. Es verwendet keine Apple PPC-Emulation, auch nicht unter macOS (die es wahrscheinlich gar nicht gibt, da Apple x86_64 in Rosetta 2 emuliert, nicht PPC; QEMU kann Apples Hypervisor.framework für die CPU-Virtualisierungsunterstützung verwenden, wenn es ARM-Gäste des gleichen Arches unter macOS ausführt, aber das ist wie KVM unter Linux und hilft nicht bei der Emulation anderer Arches wie PPC, die immer dynamisch von QEMU mit TCG übersetzt werden, dem JIT-Compiler von QEMU). Aber einige Leute im emaculation.com Forum sagten auch, dass es gut auf dem Apple M1 zu laufen scheint, also vielleicht ist diese CPU einfach so schnell.

QEMU emuliert nur NG-Amiga-Maschinen ohne Legacy-Hardware, während WinUAE einen klassischen Amiga mit einem PPC-Beschleuniger emuliert, wobei die PPC-Emulation eine ältere Version von QEMU verwendet, sodass es aus zwei Gründen langsamer sein könnte: wegen der Weiterentwicklung von QEMU im Vergleich zu der alten Version, die in WinUAE verwendet wird, oder wegen der zusätzlichen Komplexität der Ausführung von Software mit Einschränkungen, die durch die klassische Amiga-Architektur auferlegt werden, wo der PPC eher ein Zusatz als die Haupt-CPU ist, aber ich weiß nicht viel über klassische Amiga-Emulation oder klassische PPC-Beschleuniger, sodass ich das nicht mit Sicherheit sagen kann. Es könnte auch sein, dass der Poster die x86_64-Version von WinUAE mit der nativen ARM-Version von QEMU auf dem M1 Mac verglichen hat, also gibt es hier eine Menge Faktoren.

Das Grafikproblem mit AmigaOS 4.1 auf dem M1 Mac wurde auch auf meiner Amiga-Seite berichtet (siehe die Diskussion in den Kommentaren dort), aber ich weiß nicht, was es verursacht und kann nicht über x86_64 berichten, also kann ich es auch nicht beheben, bis jemand den Commit findet, der es zerstört hat. Wenn es vorher funktioniert hat, könnte es durch eine Optimierung in QEMU v5.1 oder später kaputt gegangen sein, sodass man zuerst mit v5.0 testen und dann von dort aus aufwärts gehen könnte, um herauszufinden, wann es kaputt gegangen ist. Das macht am besten jemand, der es aus git auf einem M1 Mac kompilieren kann und dann v5.0.0 Tag oder andere Versionen zum Testen auschecken kann und dann einen git bisect zwischen den Versionen macht, wo es kaputt ging, um den Commit zu finden, der genauer betrachtet werden sollte. Ich kann das nicht tun, da ich keinen M1 Mac habe, also will ich es auch nicht darauf laufen lassen, also sollte jemand, der sich dafür interessiert, etwas Zeit investieren und herausfinden, wo es kaputt ist. Wenn es niemanden gibt, der es kompilieren kann, könnte man die Builds von emaculation.com ausprobieren, um eine ungefähre Vorstellung davon zu bekommen, wo das Problem zu suchen ist. Auch die neueste Version 7.2 von dort unterstützt alle Display-Backends unter macOS, d.h. cocoa, sdl und gtk, die man mit der Option -display auswählen kann. Diese zu testen könnte zumindest einen Hinweis darauf geben, ob das Problem mit der Kartenemulation oder mit der Anzeige von Grafikkarten auf dem Host liegt. Die Art und Weise, wie es grob funktioniert, ist, dass das Gastbetriebssystem die emulierte Karte programmiert, um Grafiken im Speicher der Karte zu rendern, die dann in das Host-Grafikformat konvertiert und angezeigt werden; es gibt eine Optimierung, um nur die Teile während der Anzeige zu aktualisieren, die sich geändert haben. Es könnte also überall scheitern, sei es, dass die Karte nicht korrekt emuliert wird, Aktualisierungen fehlen oder die Karte auf der Host-Seite falsch angezeigt wird. Da es unter Linux und Windows und anscheinend auch unter x86 macOS funktioniert, weiß ich nicht, was ohne weitere Informationen falsch sein könnte. Es sieht so aus, als ob einige Updates fehlen, aber es gab auch Änderungen im Cocoa Display Backend, sodass das auch die Ursache sein könnte, oder die sm501-Emulation oder sogar externe Bibliotheken, die unter macOS verwendet werden, oder sogar einige unzusammenhängende Änderungen weder im sm501- noch im Cocoa UI-Teil, z.B. im Dirty Tracking, um zu prüfen, was sich geändert hat.

Ist das Grafikproblem unter Windows, das im letzten Beitrag beschrieben wurde, dasselbe wie das bekannte Problem Nr. 1 auf http://zero.eik.bme.hu/~balaton/qemu/amiga/#amigaos ? Wenn ja, gibt es dort einige Lösungen dafür, aber der Poster konnte es anscheinend schon lösen. Ich habe keine Ahnung von SFS, obwohl ich glaube, dass einige Leute etwas darüber in der Kommentarsektion gesagt haben, aber ich kann mich nicht erinnern, was oder ob es eine Lösung gab. In Problem #4 wird erwähnt, dass die Blockgröße beim Formatieren einer Partition standardmäßig zu groß ist, aber ich weiß nicht, ob das damit zusammenhängt, wahrscheinlich nicht.

Zum Ausführen von MorphOS ist es wahrscheinlich am besten, qemu-system-ppc -machine pegasos2 -device ati-vga,romfile="" -serial stdio zu verwenden. Der mac99 funktioniert auch, nachdem man die temperature.sensor Aufgabe beendet hat, die ihn sonst ausbremst, aber leider geben die MorphOS-Entwickler nur Lizenzen für echte Hardware heraus, sodass man ihn nicht wirklich auf einer QEMU-emulierten Maschine benutzen kann, sondern nur testen. MorphOS bootet auch auf sam460ex, aber es ist dort viel langsamer, also frage ich mich, ob AmigaOS die gleiche Einschränkung hat und auf Pegasos2 schneller wäre, aber um es zu booten, muss man entweder die Boot-CD modifizieren, um den sm502-Treiber hinzuzufügen, oder man braucht eine Pegasos-II-Maschine, um ihn zu installieren und dann zu modifizieren, bevor man versucht, mit QEMU zu booten. Im Gegensatz zu MorphOS hat AmigaOS keinen ATI Rage128-Treiber und die Radeon-Chips sind komplexer, sodass sie noch nicht genug emuliert sind, um AmigaOS mit ati-vga zu booten. (Alternativ könnte man, wenn man eine echte PCI-Radeon-Karte hat (die, um sie mit moderner Hardware zu verbinden, wahrscheinlich auch eine PCIe-zu-PCI-Brücke benötigt), versuchen, PCI mit vfio unter Linux an das Gastbetriebssystem durchzureichen, aber ich habe noch von niemandem gehört, der das getan hat. Auch dies erfordert zusätzliche Hardware und wahrscheinlich einen Linux-Host, sodass es eingeschränkter ist als eine emulierte Karte sein könnte, aber auf der anderen Seite sollte native Geschwindigkeit sein, wenn es funktioniert. Ich weiß, dass es nicht mit mac99 funktioniert, aber vielleicht mit pegasos2 könnte es funktionieren. Eine PCIe-Karte zu verwenden und sie als PCI-Karte durchzugeben, funktioniert wahrscheinlich auch nicht, also bräuchte man eine echte PCI-Karte, die von AmigaOS 4.1 auf dem Pegasos II unterstützt wird, der kein PCIe hatte. Sam460ex hatte PCIe, aber es ist nicht korrekt emuliert, sodass das Durchreichen dort wahrscheinlich nicht funktioniert).

Auch in diesem Befehl:

qemu-system-ppc -M sam460ex -m 2048 -rtc base=localtime -vga none -device sm501

Die Option -vga none -device sm501 sollte für den sam460ex nicht benötigt werden, da dieser bereits einen sm501 an Bord hat, sodass eine weitere sm501 PCI-Karte hinzugefügt wird. Es funktioniert wahrscheinlich trotzdem, aber dann haben Sie zwei sm501-Geräte. Möglicherweise müssen Sie den sm501 nur auf mac99 oder pegasos2 hinzufügen, wo es standardmäßig keinen gibt, aber sam460ex hat ihn an Bord und QEMU emuliert ihn.
 
Primax   Nutzer

26.12.2022, 17:59 Uhr

[ - Direktlink - ]
Thema: AmigaOs4.1 Youtube
Brett: Amiga, AmigaOS 4

@Maijestro:

Und? Funktioniert?
 
Primax   Nutzer

25.12.2022, 03:05 Uhr

[ - Direktlink - ]
Thema: AmigaOs4.1 Youtube
Brett: Amiga, AmigaOS 4

@Maijestro:

Gerade nochmal unter WinUAE getestet: funktioniert!
Zwar gäääähnend langsam, allerdings habe ich auch einen uralten Laptop...und ich hab iPad 6.1 als Spoofing ausgewählt.

Was ich allerdings komisch finde: jedes Mal beim Starten von Odyssey werden die Fonts initialisiert. Wüsste aber auch nicht, was ich da anders machen soll...

Wie ist es bei dir?
 
Primax   Nutzer

24.12.2022, 21:14 Uhr

[ - Direktlink - ]
Thema: AmigaOs4.1 Youtube
Brett: Amiga, AmigaOS 4

@Maijestro:

"YouTube HTML5 Converter" entspricht dem "YouTube.js"-Skript im entsprechenden Ordner.
Das wird dir nach dem Aufrufen dann als Name angezeigt!
 
Primax   Nutzer

24.12.2022, 13:52 Uhr

[ - Direktlink - ]
Thema: AmigaOs4.1 Youtube
Brett: Amiga, AmigaOS 4

@Maijestro:

Einfach die neueste Version herunterladen...

http://os4depot.net/?function=showfile&file=network/browser/odyssey.lha

Da sind die Skripte enthalten.

Dann wie im Text vorher beschrieben vorgehen.

Fang einfach mal an und wenn du nicht weiterkommst, dann meld dich.
 
Primax   Nutzer

23.12.2022, 20:57 Uhr

[ - Direktlink - ]
Thema: AmigaOs4.1 Youtube
Brett: Amiga, AmigaOS 4

@Maijestro:

Eigentlich ganz einfach. Ich musste selbst kurz suchen, wo das stand und fand es in der Meldung zur letzten Odyssey-Version (die du hoffentlich installiert hast) für OS4:

https://www.amiga-news.de/de/news/AN-2022-01-00012-DE.html

"Es gibt ein neues YouTube-Skript von den MorphOS-Entwicklern (ASiegel), damit der beschleunigte Videoplayer mit dem geänderten YouTube funktioniert. Dazu sind folgende Schritte notwendig:

- Löschen Sie in Ihren Skripten Youtube Fullscreen Fix und Youtube HTML5 Converter. Starten Sie Odyssey neu und fügen Sie die neuen Skripte hinzu (so dass die erlaubten Seiten neu sind)
- Fügen Sie zu den URL-Einstellungen http://youtube.com hinzu und verwenden Sie Ipad 13.2.3 für das Spoofing. So wird immer auf die mobile Version umgeschaltet.
- Wenn Sie jetzt auf ein beliebiges Video klicken, erscheint im rechten/unteren Bereich ein Feld, mit dem Sie das Video erweitern können: Wenn Sie darauf klicken, wird unser beschleunigter Media Player wieder angezeigt."

Also in Odyssey in "Fenster" --> "Skripte"...

[ Dieser Beitrag wurde von Primax am 23.12.2022 um 21:05 Uhr geändert. ]
 
Primax   Nutzer

17.10.2022, 08:58 Uhr

[ - Direktlink - ]
Thema: Amiga37: Kurz-News
Brett: Get a Life

Wir haben grundsätzlich geplant, eine Nachlese der Veranstaltung als News zu veröffentlichen. Für alle Neugierigen und Interessierten hier aber schon mal in kurzen Stichpunkten, was ich von Besuchern der Veranstaltung erfahren habe. Also quasi halboffiziell offiziell ;)

- laut ACube und Trevor werden die A1222-Boards (Tabor) Ende des Jahres produziert und sollen Anfang kommenden Jahres erhältlich sein
- Preis orientiert sich an den Sam-Boards, also um die 900 Euro
- vor Ort wurde ein Board präsntiert, allerdings nicht mit OS4 laufend
- ACubes Laptop soll ein Open Source Laptop werden mit einer T2080-PPC-CPU und aufrüstbarer GPU, auf dem auch AmigaOS 4 laufen kann

- MorphOS-Team zeigte MorphOS 3.13 als Betaversion auf A1200 und A4000 (mit PPC-Karten)

- Apollo-Team arbeitet an Karten für A3000 und A4000

- und: Ben Hermans war ebenfalls auf der Amiga37 und sprach mit Mike Battilana, Matthew und Trevor

[ Dieser Beitrag wurde von Primax am 17.10.2022 um 08:59 Uhr geändert. ]

[ Dieser Beitrag wurde von Primax am 17.10.2022 um 15:31 Uhr geändert. ]
 
Primax   Nutzer

09.10.2022, 17:36 Uhr

[ - Direktlink - ]
Thema: Warum ist die Kommentar-Funktion gesperrt?
Brett: Forum und Interna

Da es niemand aktiv ausgeschaltet hat, ist die Kommentarfunktion wieder aktiviert. Muss ein Versehen (meinerseits?) gewesen sein.
Bitte um Entschuldigung!
 
Primax   Nutzer

08.09.2022, 05:12 Uhr

[ - Direktlink - ]
Thema: Personal Paint 7.1, WordWorth 7.01
Brett: Amiga, AmigaOS 4

@amigadune:
Gibt es die Download-Variante nicht mehr...?
 
Primax   Nutzer

07.09.2022, 20:15 Uhr

[ - Direktlink - ]
Thema: Personal Paint 7.1, WordWorth 7.01
Brett: Amiga, AmigaOS 4

@amigadune:
Hmm, hab in meinem 1200er leider keine Grafikkarte...
Welche Version von PPaint verwendest du denn?
Die aktuellste ist ja die 7.3c von 2019:
http://www.ppaint.com/
 
Primax   Nutzer

07.09.2022, 19:47 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:
Meine Mail bekommen...?
 
Primax   Nutzer

05.09.2022, 20:57 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

Hast du etwas dagegen, wenn ich deinen Erfahrungsbericht in den englischen News als eben solches bringe? Oder möchtest du den gar selbst schreiben? :)

Ich glaube, da interessieren sich einige für...
 
Primax   Nutzer

05.09.2022, 20:55 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Also, die Devices (ahi.device, keyboard.device, netinfo.device etc.) liegen bei mir unter "Mein MorphOS" --> "MOSSYS" --> "Devs".
 
Primax   Nutzer

04.09.2022, 06:15 Uhr

[ - Direktlink - ]
Thema: Qemu AmigaOs4.1/Morphos
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Hallo. Danke für deinen Erfahrungsbericht. Finde ich immer spannend! :)
Eine Sache verstehe ich nicht: du hattest doch AmigaOS 4.1 schon unter FS-UAE laufen. Was war das denn für eine OS4-Version? Nicht die Classic? Gibt es da noch eine andere, spezielle Pegasos-Version?

Der direkte Vergleich FS-UAE mit QEMU wäre natürlich spannend...was die Geschwindigkeit betrifft, aber auch Stabilität etc.

Hast du unter MorphOS mal die aktuelle Wayfarer-Browserversion getestet?

Grüße, Daniel
 
Primax   Nutzer

16.08.2022, 06:50 Uhr

[ - Direktlink - ]
Thema: AmigaOS 4.1 Update 2 unter WinUAE
Brett: AROS und Amiga-Emulatoren

@Maijestro:

Danke für deinen Erfahrungsbericht.
Was für ein macOS verwendest du?

Und hast du mal Browser wie IBrowse oder Odyssey getestet? Geschwindigkeit akzeptabel?
 
 
-1- 2 3 4 5 6 >> Letzte Ergebnisse der Suche: 345 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.