amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- 3 Ergebnisse der Suche: 67 Treffer (30 pro Seite)
RhoSigma   Nutzer

16.10.2009, 08:16 Uhr

[ - Direktlink - ]
Thema: suche dos_lib.i
Brett: Programmierung

@AGSzabo:
Moin,

ist es noch erforderlich, dass ich dir die Datei schicke ??

Wenn ja, oder auch wenn du mal eine anderen Ansatz sehen willst,
den ich verwende, dann must du noch mal ne mail schicken und
bitte deine e-mail mit reinschreiben, denn bei der, die du
geschrieben hast erscheint nur "forum at amiga-news de" als
Absender, das bringt mir net viel :)

Die letzte Version (laut FD-Datei im NDK3.9) ist uebrigens V40.x,
sprich OS3.1

.. und weiter gehts, meine Maschine ist grad mal wieder abgestuertzt,
kein Wunder, welcher Maschinenhersteller ist auch so beschraenkt und
verwendet Windows als Hostsystem fuer seine CNC-Steuerung 8o
 
RhoSigma   Nutzer

15.10.2009, 14:55 Uhr

[ - Direktlink - ]
Thema: suche dos_lib.i
Brett: Programmierung

@AGSzabo:
bin hier grad uff Arbeit, weit wech von meiner Freundin :) , aber
wenn es bis morgen abend ca. 20 Uhr Zeit hat, dann kann ich dir
die gerne mailen. Muestest mir dann nur mal ueber mein AN-Profil
ne Nachricht mit deiner E-Mail-Adresse schicken...
 
RhoSigma   Nutzer

15.10.2009, 14:39 Uhr

[ - Direktlink - ]
Thema: suche dos_lib.i
Brett: Programmierung

@AGSzabo:
Hmm, wie sieht es denn mit der dos_lib.fd (bzw. .sfd) aus, dann
koenntest du dir mit FD2Pragma od. aehnlichen Konvertern die
_lib.i selbst erstellen.
 
RhoSigma   Nutzer

15.10.2009, 14:18 Uhr

[ - Direktlink - ]
Thema: suche dos_lib.i
Brett: Programmierung

@AGSzabo:
http://os.amigaworld.de/index.php?lang=de&page=1

da findest du alles fuer OS3.1, OS3.5, OS3.9, d.h. die NDKs die die
Includes enthalten BoingBags, Updates u.s.w.
 
RhoSigma   Nutzer

07.10.2009, 08:15 Uhr

[ - Direktlink - ]
Thema: Hilfe bei Birdie2000
Brett: Amiga, AmigaOS 4

Moin,

vielleicht hast Du es ja schon, aber hier noch mal der Hinweis,
ich wuerde noch util/boot/titleshadow.lha dazunehmen, damit sich
die Fenstertitel auf den Fuellmustern von birdie etwas besser
abheben, dieses Tool arbeitet mit birdie u. visualprefs perfekt
zusammen u. muss bei Verwendung vor birdie gestartet werden.

 
RhoSigma   Nutzer

03.08.2009, 13:01 Uhr

[ - Direktlink - ]
Thema: WinUAE globale Gamma/Contrast/Brightness Einstellungen
Brett: AROS und Amiga-Emulatoren

Hallo alle zusammen,

versuche gerade mit der Gamma Einstellung mein Bild ein wenig aufzuhellen. Funktioniert aber nur in so weit, dass der Screen
zwar erst hell ist, aber sowie der Workbench Screen geoeffnet wird
doch wieder alles auf normal (sprich zu dunkel) zurueckfaellt.
Funktioniert das vielleicht nur bei nativen Amiga Screen Modes,
momentan verwende ich als Workbench einen uaegfx Screen (sprich Picasso96). Oder brauche ich evtl. einen spezielen picture.datatype dafuer.

Wer kann mir da Informationen geben, bzw. wer verwendet diese Einstellungen mit Erfolg ??
 
RhoSigma   Nutzer

05.12.2008, 10:39 Uhr

[ - Direktlink - ]
Thema: icons immer wieder durcheinander
Brett: Amiga, AmigaOS 4

Hallo,
irgendwo im Workbench Manual (von OS3.1) hatte ichs mal gefunden.

In Dir-Fenstern:
Icons selektieren, dann aus dem Menu Icons->Snapshot oder zu deutsch
Piktogramme->fixieren.

Im WB-Fenster:
Icons anordnen wie gewuenscht, dann aus dem Menu Window!!! -> Snapshot -> all, oder wieder in deutsch
Fenster!!! -> fixieren -> alles

dabei wird uebrigens auch der Zustand des WB-Fensters mit abgespeichert,
sprich ob es sichtbar ist oder auf BACKDROP geschaltet.

Diese Einstellungen landen dann in ENVARC:sys/wbconfig.prefs



[ Dieser Beitrag wurde von RhoSigma am 05.12.2008 um 10:42 Uhr geändert. ]
 
RhoSigma   Nutzer

22.10.2008, 12:59 Uhr

[ - Direktlink - ]
Thema: Power-LED blinkt - Fehlercode ?
Brett: Amiga, AmigaOS 4

@Lippi:
Hi,
Versuchs mal mit dem Programm Scout unter dem Schalter *SYSTEM* sollte
ganz unten der *Last Alert* angegeben sein. Oder wenn du dich auskennst
kannst du dir die Werte auch aus der ExecBase Struktur auslesen, Offsets
siehe Includedatei exec/execbase.(i|h)
 
RhoSigma   Nutzer

12.09.2008, 22:06 Uhr

[ - Direktlink - ]
Thema: Druckproblem
Brett: Programmierung

Also ich verwende in solchen Fällen, ich meine das Warten auf eine Nachricht, immer eine Kombi aus WaitPort() und GetMsg() und falls letzteres dann doch NULL liefert, sprich tatsächlich gar keine Nachricht vorliegt, dann springe ich postwendend zurück zum WaitPort().

Das wird von vielen (hauptsächlich 3rd Party) Quellen & Beispielen auch so angegeben, da angeblich eine "enge" Schleife, die also ohne Zwischenstopps immer nur wieder GetMsg() aufruft bis eine Nachricht vorliegt (GetMsg() != NULL), angeblich auf 68060 CPUs Probleme bereitet (habsch leider nich, kanns also nicht bestätigen).

Was die Sache mit SendIO()/WaitIO() statt DoIO() angeht, so erklärt das sicherlich folgender Kommentar, zu finden hinter dem großen IF Block mit der ganzen POKE Geschichte:

' Always give the user a chance to abort.
' So we'll use SendIO(), instead of DoIO(), to be asynch and
' catch a possible user request to abort printing

 
RhoSigma   Nutzer

31.08.2008, 17:02 Uhr

[ - Direktlink - ]
Thema: Wie WARUP & WARPOS installieren?
Brett: Amiga, AmigaOS 4

Ich glaube AmigaAlliance hat hier etwas Grundsätzliches noch nicht verstanden, wenn ich mir hier diesen ganzen Thread so durchlese, dann
scheint es mir so, als ob er immer noch versucht die ppc.library (also die echte) zu installieren, anstatt der ppclibemu.library, welche er benötigt um unter WOS auch PUP Anwendungen laufen zu lassen.
Also wie einer meiner Vorgänger schon schrieb:

1. WarpUP installieren
2. ppclibemu installieren

Und ohne sarkastisch werden zu wollen, AmigaAlliance, wenn du nicht einmal weißt was env-Variablen sind, das ENVARC: ein logisches Verzeichnis ist und sich nicht unter diesem Namen auf der Festplatte
finden lässt, sondern an SYS:Prefs/Env-Archive zugewiesen ist, dann
würde ich dir wirklich nahelegen dich erst mal mit dem System mit dem du arbeitest, vertraut zu machen, bevor du anfängst dich mit der Installation irgendwelcher zusätzlicher PPC Kernels/Emulationen abzumühen.
 
RhoSigma   Nutzer

25.06.2008, 10:20 Uhr

[ - Direktlink - ]
Thema: Booten mit USB-Stick
Brett: Amiga, AmigaOS 4

@mboehmer:
Ah gudd,
das mit dem ROMOFF Jumper hatte ich auch schon ein paar mal, kombiniert mit dem fehlen der FlashRom.resource (welche ja laut ID-String offensichtlich der Bootloader ist) und daraus folgend dem Fehlen der im Flash installierten Module.
Hatte bis jetzt angenommen, daß das ein Wackler beim Einbau der Deneb war, da es nur sporadisch auftrat, und wollte nächstes Wochenende meinen Amiga noch mal aufschrauben und nachsehen. Das hat sich wohl damit dann erledigt.
Danke.
 
RhoSigma   Nutzer

23.06.2008, 16:42 Uhr

[ - Direktlink - ]
Thema: Frage zum Thema Assign
Brett: Amiga, AmigaOS 4

Zitat:
Sollte es. Thomas wollte mit seinem Einwand wohl eher darauf hinweisen, dass es nicht besonders elegant ist wenn das Starten eines Demos das Diskettenlaufwerk komplett lahm legt. Wenn sich das Demo sowieso nur durch einen Reset beenden lässt dürfte das egal sein, wenn du aber vom Demo zur Workbench zurückkehren kannst hast du dann halt eine WB ohne Floppy-Zugriff.

Ah ja, und wer braucht im Zeitalter von CD/DVD und USB-Sticks noch Zugriff auf eine Floppy ?? - Also ich hab' mein internes Floppy zum letzen mal gebraucht, als ich TurboPrint 7 installiert habe, wieviele Jahre ist das jetzt her ??
 
RhoSigma   Nutzer

23.06.2008, 12:36 Uhr

[ - Direktlink - ]
Thema: Frage zum Thema Assign
Brett: Amiga, AmigaOS 4

Hallo,

nur so vom logischen her, habe keine Ahnung ob es auch funktioniert:

Assign DF0: DISMOUNT

um das eigentliche (physische) Laufwerk abzumelden, dann
eventuell noch ein Avail FLUSH und

Assign DF0: DHx:DasVerzeichnis/deiner/Wahl

um DF0: als logisches Laufwerk auf deinem gewünschten Verzeichnis
anzumelden.
 
RhoSigma   Nutzer

13.06.2008, 12:28 Uhr

[ - Direktlink - ]
Thema: Ordner synchronisieren
Brett: Amiga, AmigaOS 4

Hallo,
habe noch eins gefunden, habe jetzt allerdings nicht reingeguckt, ob das Programm deinen Anforderungen genügt. Laut Readme scheint es aber ein relativ mächtiges Programm zu sein:

http://aminet.net/biz/cloan/DirDiff.lha


[ Dieser Beitrag wurde von RhoSigma am 13.06.2008 um 12:29 Uhr geändert. ]
 
RhoSigma   Nutzer

15.05.2008, 02:17 Uhr

[ - Direktlink - ]
Thema: DENEB USB Controller (von E3B) und DMA
Brett: Amiga, AmigaOS 4

Hallo, mich wuerde an dieser Stelle auch mal interessieren, was nun mit meiner ALGOR passiert ?(
Muss ich die nun rausnehmen und sozusagen fuer Notfaelle erst mal zuruecklegen, wenn die DENEB mal ihren Geist aufgibt, oder kann ich die beiden Karten auch parallel betreiben, sprich:

a) vertragen sich beide Karten miteinander
b) wenn ja, wie ist das mit der Priotitaet der FlashROMs beider Karten beim Einbinden der ROM-Module (spezielle Bootloader/Firmware fuer beide Karten)
c) wenn ja, hat Poseidon4.0 auch entsprechende ueberarbeitete/angepasste/erweiterte Devices fuer die alten USB-Karten von E3B
 
RhoSigma   Nutzer

13.05.2008, 04:39 Uhr

[ - Direktlink - ]
Thema: DENEB USB Controller (von E3B) und DMA
Brett: Amiga, AmigaOS 4

Hallo, mich wuerde an dieser Stelle auch mal interessieren, was nun mit meiner ALGOR passiert ?(
Muss ich die nun rausnehmen und sozusagen fuer Notfaelle erst mal zuruecklegen, wenn die DENEB mal ihren Geist aufgibt, oder kann ich die beiden Karten auch parallel betreiben, sprich:

a) vertragen sich beide Karten miteinander
b) wenn ja, wie ist das mit der Priotitaet der FlashROMs beider Karten beim Einbinden der ROM-Module (spezielle Bootloader/Firmware fuer beide Karten)
c) wenn ja, hat Poseidon4.0 auch entsprechende ueberarbeitete/angepasste/erweiterte Devices fuer die alten USB-Karten von E3B

 
RhoSigma   Nutzer

08.05.2008, 05:30 Uhr

[ - Direktlink - ]
Thema: FD->BMAP Fehler
Brett: Programmierung

Hier ist meine Alternative, die ich mal entwickelt hatte als sich das Konverter-Tool von MaxonBasic als unbrauchbar erwies (schreibt am Ende einer jeden Fuktionen ein LF statt des erforderlichen NULL-Bytes).

http://rhosigma-cw.net/down/FDConvert.BAS

ist ebenfalls in MaxonBasic geschrieben und sollte sich daher ohne weiteres auch bei dir kompilieren lassen, sofern du alle erforderlichen Includes hast.
 
RhoSigma   Nutzer

05.05.2008, 00:56 Uhr

[ - Direktlink - ]
Thema: A4000T Soundproblem
Brett: Amiga, AmigaOS 4

Zitat:
Original von pinhead:
Das komische bei mir ist das das Audiosignal über die Klinkenbuchse 1A ist.
Nur Cinch ist betroffen.
Nutze ich halt erstmal Klinke :)


Ja, jetzt wo du das schreibst, ist ja schon fast gespenstisch, exakt das gleiche Muster. Erst wurde es links leiser (genaugesagt CH4), dann immer mehr bis zum totalausfall des CH4 aber eben nur ueber Chinch, bei Klinke alles Ok. Hab den Fehler nie gefunden, Platine sah gut aus (keine auslaufenden ELKOs). Hatte dann irgendwann mal was bei Vesalia bestellt und in deren Shop dann auch noch relativ preiswert orginal Audio/Video Module fue A4000T gefunden und gleich eins mittbestellt. Seitdem lauft der Sound wieder 1A mit dem neuen modul.
 
RhoSigma   Nutzer

23.02.2008, 00:43 Uhr

[ - Direktlink - ]
Thema: A4000T Pinbelegung ?
Brett: Amiga, AmigaOS 4

Zitat:
Original von pinhead:

Auf dem Audio/Video Modul des A4000T sind 2 eventuelle Jumper worüber ich nichts gefunden habe.
Einmal CN304 und dann CN401.
Weiß jemand wofür die sind?



Hallo, hast du zum A4000T keine Handbücher dazu ?(
sollten normal 6 Stück mit folgenden Titel sein:
- A4000T
- Harddisk
- Supplement
- DOS
- Workbench
- ARexx

im A4000T Buch auf Seite 1-12 Kap. 1.7.4.1 beschreibt das Audio/Video Modul.

CN304 = Anschluss für CD-Laufwerk od. DSP, um deren Audiosignale mit über die Audiokanäle des Amiga auszugeben. Dabei werden die CD/DSP Signale mit denen des Amiga gemixt, sofern von beiden Quellen Ausgaben gemacht werden. (3-poliges Kabel L-Masse-R)

CN401 = aktivieren/deaktivieren der Kopfhörerbuchse des Audio/Video
Moduls (IMHO vollkommen sinnlose Option seitens Amiga :O )
 
RhoSigma   Nutzer

01.02.2008, 10:03 Uhr

[ - Direktlink - ]
Thema: Genesis
Brett: Amiga, AmigaOS 4

Zitat:
Des weiteren sorgt Facts (bei korrekter Einstellung) ja auch ganz komfortabel für die jeweilige Umstellung auf Winter-/Sommerzeit.

Das tut SummertimeGuard auch, nur ohne die Notwendigkeit, dafuer extra online gehen zu muessen.
 
RhoSigma   Nutzer

28.01.2008, 08:28 Uhr

[ - Direktlink - ]
Thema: Problem mit USB-Sticks
Brett: Amiga, AmigaOS 4

@mboehmer:
Ok, werd' ich machen, dauert aber bis naechstes Wochenende, jetzt heisst es erstmal wieder eine Woche arbeiten fernab meiner Amiga-Freundin :(
 
RhoSigma   Nutzer

27.01.2008, 14:12 Uhr

[ - Direktlink - ]
Thema: Problem mit USB-Sticks
Brett: Amiga, AmigaOS 4

Zitat:
- psddevlist?

Product Name : 'Emulated Root Hub' (ID: 1138, Vers: 0001)
Manufacturer : 'E3B' (Vendor: 0b20 (TransDimension Inc.))
Serial Number : 'n/a' (USBVers: 0110)
Device State : fullspeed connected hasaddress hasdevdesc isconfigured
Device Address : 1
Class/Sub/Proto : 9/0/0 (Hub)
Current Language: English (United States)
Supported Langs : English (United States)

This device is bound to hub.class, context 087ec034.

1 configuration(s):
Config 1 (Algor Config)
Attrs : self-powered
MaxPower: 0 mA

1 interface(s) for this config:
Interface 0 (Hub interface)
Alternate Setting: 0
Class/Sub/Proto : 9/0/0 (Hub)

1 endpoint(s) for this interface:
Endpoint 1 (interrupt <-[ IN)
MaxPktSize: 1
Interval : 255
No alternate settings.

Zitat:
- psderrorlog?

von V3.8
---------


 SanDisk U3 Titanium 2GB
 -----------------------
 0-hub.class: New device 'U3 Titanium' at port 3. Very nice.
 0-massstorage.class: Postconfig patchflags 0x0200 NoReset.
 0-massstorage.class: Delaying init sequence by 500ms.
 0-massstorage.class: MSD 'U3 Titanium' LUN 0 available through usbscsi.device unit 1!
 0-massstorage.class: Postconfig patchflags 0x0200 NoReset.
 0-massstorage.class: Delaying init sequence by 500ms.
 0-massstorage.class: MSD 'U3 Titanium' LUN 1 available through usbscsi.device unit 2!
 0-massstorage.class: Device 'U3 Titanium' is of Direct Access type.
 0-massstorage.class: Removable Task started.
 0-massstorage.class: Device 'U3 Titanium' is of CD/DVD ROM type.
 5-massstorage.class: NAK Timeout should be at least 15 seconds for CD/DVD drives!
 5-massstorage.class: FakeGeometry: Total number of blocks is a prime number!
 5-massstorage.class: Fallback: Enabling Fix Capacity.
 5-massstorage.class: Command (28 00 00 00 00 00 00 00 01 00) failed:
 0-hub.class: Device 'U3 Titanium' at port 3 is gone!
10-massstorage.class: Data phase failed: response timeout (6)
 5-massstorage.class: Error searching hardblock in block 0.
 0-massstorage.class: 'U3 Titanium' retreated, pitful coward.
 0-massstorage.class: Removable Task stopped.

 Intenso 2GB
 -----------
 0-hub.class: New device 'USB DISK' at port 3. Very nice.
 0-massstorage.class: Postconfig patchflags 0x0200 NoReset.
 0-massstorage.class: Delaying init sequence by 500ms.
 0-massstorage.class: MSD 'USB DISK' LUN 0 available through usbscsi.device unit 3!
 0-massstorage.class: Device 'Drive SM_USB20' is of Direct Access type.
 0-massstorage.class: Removable Task started.
 5-massstorage.class: Command (1A 00 04 00 FF 00) failed:
10-massstorage.class: Data phase failed: response timeout (6)
 0-hub.class: Device 'USB DISK' at port 3 is gone!
 5-massstorage.class: Fallback: Enabling Simple SCSI.
 5-massstorage.class: Fallback: Enabling CMD6->CMD10.
 5-massstorage.class: Error searching hardblock in block 0.
 0-massstorage.class: 'USB DISK' retreated, pitful coward.
 0-massstorage.class: Removable Task stopped.


 Supertalent 2GB
 ---------------
 0-hub.class: New device 'Flash Disk' at port 3. Very nice.
 0-massstorage.class: Postconfig patchflags 0x0200 NoReset.
 0-massstorage.class: Delaying init sequence by 500ms.
 0-massstorage.class: MSD 'Flash Disk' LUN 0 available through usbscsi.device unit 4!
 0-massstorage.class: Device 'Flash Disk' is of Direct Access type.
 0-massstorage.class: Removable Task started.
 5-massstorage.class: Command (1A 00 03 00 FF 00) failed:
10-massstorage.class: Command status failed: nak timeout (10)
 5-massstorage.class: Fallback: Enabling Simple SCSI.
 5-massstorage.class: Fallback: Enabling CMD6->CMD10.
 5-massstorage.class: Command (28 00 00 00 00 00 00 00 01 00) failed:
10-massstorage.class: Data phase failed: response timeout (6)
 0-hub.class: Device 'Flash Disk' at port 3 is gone!
 5-massstorage.class: Error searching hardblock in block 0.
 0-massstorage.class: 'Flash Disk' retreated, pitful coward.
 0-massstorage.class: Removable Task stopped.[quote]

Zitat:
- nur mit V3.8 oder auch mit anderen Versionen?

sowohl mit V3.4 OEM mit Algor geliefert, als auch mit V3.6 und V3.8
(V3.5/3.7 gabs wohl nicht öffentlich, oder ich habe sie verpasst)

Zitat:
- gehen die Sticks an Windows/Linux Rechnern?

funktionieren alle auf Anhieb und ohne Probleme sowohl FAT als auch NTFS formatiert

Zitat:
- Einstellungen für den Stick (Fixes / Patches) in Trident?

massstorage.class (bei V3.6+ mit entsprechenden Fallback-Optionen)
-----------------
3000ms NAK Timeout
500ms Startup Delay
No Initial Reset

Automount RDB/FAT partitions
Buffers =40
DOS-Device-Name =USB

Zitat:
- registrierte Poseidon-Version?

V3.4 = OEM
V3.6 = nein
V3.8 = nein

Zitat:
- Hub dazwischen oder direkt angesteckt?

Direkt angesteckt, alle 3 Ports mehrfach ausprobiert, hatte die Algor auch zwischenzeitlich
mal aus und wieder eingebaut um eventuelle Wackelkontakte auszuschließen.

Zitat:
- hast du schon mal bei E3B nachgefragt deswegen?

- nein, nur bei Chris Hodges, der es aber auf Grund der damaligen Auseinandersetzungen
mit PAB und seinem damit verbundenen Rückzug vom Amiga, nicht mehr für nötig gehalten hat,
mir zu Antworten

Zitat:
- ALGOR-Seriennummer?

50528457 - laut ExpansionsRom -> er_SerialNumber
 
RhoSigma   Nutzer

27.01.2008, 02:56 Uhr

[ - Direktlink - ]
Thema: Problem mit USB-Sticks
Brett: Amiga, AmigaOS 4

Leute, Augen auf beim Lesen I-)

ich habe nirgends gesagt, daß ich fette MP3s speichern will, es geht erst mal darum überhaupt so weit zu kommen, daß ich ZUGRIFF auf den
scheiß Stick bekomme, sprich daß er als Massenspeicher gemountet ist
und bleibt, denn ohne dies kann ich da weder was lesen noch schreiben, womit sich auch der Hinweis mit dem plattmachen und selbst mit fat95 formatieren erledigt.

Die Sticks werden als Massenspeicher erkannt, das war's dann aber auch schon, dann folgen nur noch NAK Timouts, Data Phase Errors,
Sense Errors u.s.w. das Ding wird ständig an-/abgemeldet und kommt nie bis zum Mount als DOS-Gerät.
 
RhoSigma   Nutzer

25.01.2008, 22:08 Uhr

[ - Direktlink - ]
Thema: Problem mit USB-Sticks
Brett: Amiga, AmigaOS 4

Ja Hallo,

ich habe das gleiche Problem mit diversen 2GB Sticks unterschiedlicher Hersteller (Marken) und hatte dazu auch schon mal einen Thread im AmigaFuture-Forum losgebrochen, dort habe ich auch ein Error-Log geposted. Leider blieb die Diskussion ziehmlich schnell hängen und es kam daher noch zu keiner Klärung des Problems.

http://www.amigafuture.de/viewtopic.php?t=14983

Vielleicht kann uns ja hier einer weiterhelfen...
 
RhoSigma   Nutzer

31.12.2007, 16:56 Uhr

[ - Direktlink - ]
Thema: adresse des cli-screens
Brett: Programmierung

Hallo, LockPubScreen() ist 'nen Intuition-Aufruf, folgend der Ausschnitt der Funktion aus dem HotHelp Libs3.0 Dokument:

LockPubScreen () / intuition.library [V36]

Sperren eines Public-Bildschirms, so daß er nicht geschlossen werden kann.

Prototyp
struct Screen * screen = LockPubScreen (STRPTR name)

Parameter
name (A0)
Zeiger auf den Namen des Public-Bildschirms, od. NULL für den Vorgabe-Public-Bildschirm.
"Workbench" für den Workbench-Bildschirm.

Ergebnis
screen (D0)
Zeiger auf den Public-Bildschirm, dessen Sperrung mittels UnlockPubScreen() wieder
aufgehoben werden muß, od. NULL im Fehlerfall.

Offset
-510

Siehe auch
Funktionen GetScreenData, GetDefaultPubScreen und NextPubScreen.
 
RhoSigma   Nutzer

31.12.2007, 02:48 Uhr

[ - Direktlink - ]
Thema: Fehlersuche
Brett: Programmierung

Hallo, gute Nacht wünsch ich schon mal, denn wenn ich das hier fertig geschrieben habe, dann gehe ich ins Bett :)

Also das hört sich ganz nach dem gleichen Problem an, das ich vor ca. 2 Jahren mit meinem MakeHTMLMap Projekt hatte, da blieb das Programm auch manchmal mittendrin sang und klanglos hängen ohne Fehler ohne Absturtz, nur das Proggi eben.

Des Rätsels Lösung war, daß sich der Garbage Collector von MaxonBasic in bestimmten Situationen offensichtlich festfährt, da du in deinem Programm auch einige Arrays benutzt und Strings sowiso, und diese auch in diversen Schleifen immer wieder mal verändert werden, wodurch ja immer wieder neue temporäre Objekte auf dem Heapspeicher von Basic erzeugt werden (sprich diesen langsam aber sicher aufbrauchen), könnte dieses Problem bei dir auftauchen.

Um dies mal zu überprüfen, solltest du mal einen PRINT FRE(0) in deine Hauptschleife setzen. Da du nun aber keine Basicfenster mehr
verwendest, müstest du dazu zeitweise eben doch mal wieder eins öffnen, der Rest sollte ja trotzdem weiter in deinem Programmfenster landen. Der Befehl gibt nun bei jedem Schleifendurchlauf die größe des noch freien Heapspeichers aus, dabei wirst du feststellen, daß dieser mehr oder weniger abnimmt, dann sprunghaft mal wieder größer wird und wieder abnimmt etc.. Der sprunghafte Anstieg zeigt, daß gerade eine Garbage Collection (Müllsammlung) stattgefunden hat bzw. daß die HEAPDYNAMIC Funktion einen neuen Block alloziert hat. Der
Punkt ist nun folgender, wenn dein Programm einfriert, nachdem der letzte ausgegebene Wert sich nahe gegen Null genährt hat und eigentlich wieder ein entsprechender Anstieg zu erwarten wäre, dieser aber nicht kommt, dann wirds wohl tatsächlich am Garbage Collector liegen, und dann kannst du in deinem eigenen Code auch lange und vergeblich nach einem Fehler suchen ;(

Wenn das nun zutrifft, dann kannst du mal versuchen das Programm mit einer höheren HEAPDYNAMIC Einstellung zu kompilieren, wenn das nichts hilft bzw. den Hänger nur eine Weile hinauszögert dann füge einfach den folgenden Codeblock in deine Hauptschleife mit ein, seitdem ich das bei meinem Programm getan habe, läuft es einwandfrei. Meine Standardwerte für die Compilereinstellungen stehen oben drüber:

code:
' alte Heapgröße = 0KB   /  dyn. Heapgröße = 128KB
' mindest. Stack = 4096B /  mathem. Stack  = 256B

    '-------------------------------------
    ' workaround Garbage Collector hangup
    '-------------------------------------
    IF FRE(0)<500 THEN                               ' Platz auf BASIC-Heap < 500 Bytes ??
        gcTmp$=""                                        ' dann temporären $ vom letzen mal löschen
        tmp&=FRE("")                                     ' und Garbage Collection erzwingen
        IF FRE(0)<500 THEN                               ' immer noch weniger 500 Bytes ??
            WHILE FRE(0)<60000&                              ' dann temp-$ wieder vergrößern,
                gcTmp$=gcTmp$+STRING$(1000,CHR$(0))          ' bis die HEAPDYNAMIC Funktion
            WEND                                             ' einen neuen Block alloziert.
            IF FRE(-1)>262144& THEN                          ' wenn genug freier Systemspeicher,
                POKEL SYSTAB+44,(PEEKL(SYSTAB+44)+65536&)    ' dann Limit für nächste GaCol erhöhen
            ELSE
                tmp&=SetIoErr&(103&)                     ' sonst OutOfMemory
                ERROR 7                                  ' kannste mit ON ERROR GOTO über eine
            END IF                                       ' Aufräumfunktion sauber zum ProgEnde
        END IF                                           ' leiten
    END IF
    '-------------------------------------


P.S. Probleme mit Compileroptionen bemerkt ?? - dann guck dir auch mal mein MBPrefs (Aminet) an...
 
RhoSigma   Nutzer

18.12.2007, 15:00 Uhr

[ - Direktlink - ]
Thema: OS 4 - Erfahrungsberichte
Brett: Amiga, AmigaOS 4

Hallo, um noch mal kurz auf den A4000T onboard SCSI zurueckzukommen:
- sieht irgendwer 'ne Moeglichkeit das NCRscsi.device z.B. aus dem
AOS3.9 BB2 RomUpdate unter der 68k Emu zum laufen zu bekommen, oder gibs da noch andere Probleme DMA etc. was so nicht funktioniert ??
 
RhoSigma   Nutzer

13.12.2007, 15:40 Uhr

[ - Direktlink - ]
Thema: OS 4 - Erfahrungsberichte
Brett: Amiga, AmigaOS 4

Zitat:
Ich kann es auch gerne kurz und verständlich ausdrücken:
Ich kenne nur ganz wenige Programmierer die die Fähigkeit hätten,
ich glaube diese haben aber die Hardware und die Zeit und die
Motivation nicht und sie sehen auch keinen Bedarf. Sorry, aber so
ist es nun mal.


Hmm, schade, dann werd ich wohl doch alles auf UW-SCSI bzw. IDE umbasteln muessen. Ist dann mal wieder son ein typischer Fall von:

Kanst Du machen nix, musst Du gucken zu ;(
 
RhoSigma   Nutzer

13.12.2007, 13:39 Uhr

[ - Direktlink - ]
Thema: OS 4 - Erfahrungsberichte
Brett: Amiga, AmigaOS 4

Nur mal so 'ne Frage, weiss irgend jemand, warum das A4000T onboard SCSI nicht unterstuetzt wird. Ist mir ja klar, dass man nicht jede moegliche Hardware-Kombination auf Anhieb geregelt kriegt, aber dass nicht einmal die Onboard-Komponenten unterstuetzt werden, von denen man praktisch seit beinahe 15 Jahren weiss, das erscheint mir nach einer so langen Entwicklungszeit fuer OS4 doch schon ein Armutszeugnis zu sein. Wenn's jedoch nur an fehlenden Beta-Testern mit der entsprechenden Hardware fehlt, dann wuerde ich mich dafuer anbieten, wo mueste ich mich da melden ?
 
RhoSigma   Nutzer

11.12.2007, 16:38 Uhr

[ - Direktlink - ]
Thema: PubScreenNode auswerten...
Brett: Programmierung

Was'n das fuern Basic-Dialekt ?( (AmiBlitz ??)

Naja, ln_Name ist jedenfals ein Langwort-Pointer, versuchs' mal mit peekl.s, falls es solche Unterscheidungen von der verwendeten Sprache
ueberhaupt gemacht werden :dance3:
 
 
1 -2- 3 Ergebnisse der Suche: 67 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.