amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- Ergebnisse der Suche: 7 Treffer (30 pro Seite)
SRuppert   Nutzer

04.01.2004, 16:04 Uhr

[ - Direktlink - ]
Thema: WinUAE und drucken?
Brett: AROS und Amiga-Emulatoren

Zitat:
Original von Docki:
Auf welchen Windows-Versionen läuft euer UAE denn? AFAIK klappt das drucken nur mit Win98/SE (Ich kann nämlich bei mir drucken. Hostsystem ist Win98SE. Amiga-Druckertreiber TP7irgendwas).


Also hier ist das WinXP Home Edition. Nun es scheint daran zu liegen, dass der Druckkanal nicht richtig geschlossen wird. Ich habe mir jetzt erstmal eine Lösung übers Dateisystem und copy to lpt1 gebastelt. Ist aber nicht wirklich gut...

Danke, Stefan
 
SRuppert   Nutzer

04.01.2004, 12:53 Uhr

[ - Direktlink - ]
Thema: WinUAE und drucken?
Brett: AROS und Amiga-Emulatoren

Hallo!

ich muß ein uraltes Program (Workbench/Kickstart 1.3) von mir unter WinUAE zum Laufen bekommen. Es funkioniert bis auf das Drucken alles einwandfrei. Mein Program schreibt direkt auf den Parallel-Port. Im Windows Drucker-Spooler erscheint auch ein Eintrag, aber der wird nie ausgeführt.

Auch funktioniert "type s:user-startup to prt:" nicht. Gleiches verhalten, wie bei meinem Programm.

Sowohl der Amiga, also auch Windows sind auf den Drucker NEC Pinwriter eingestellt.

Gibts irgendwelche Tipps um dieses Problem zu beheben?

Danke, Stefan
 
SRuppert   Nutzer

08.05.2003, 12:34 Uhr

[ - Direktlink - ]
Thema: Bilder einbinden ins Amiga Guide?
Brett: Programmierung

Nun buggy ist so eine Sache, es sind einige Fehler drinne, die nur selten auftreten sogenannte race-conditions. Dies kommt daher, dass ein relative komplexes Objekt-System als gadget eingebunden ist und daher auch im input-task context läuft und vorallem, da es keine gescheite doku gab/gibt bzgl Programmierung von datatypes und hier vorallem von Basis-datatypes!

Ich habe zwar die meisten Fehler behoben, ist aber noch weit von einem release entfernt.

Ciao,
Stefan
 
SRuppert   Nutzer

03.05.2003, 13:56 Uhr

[ - Direktlink - ]
Thema: Bilder einbinden ins Amiga Guide?
Brett: Programmierung

Naja, es gab mal/gibt noch einen HyperGuide Datatype... Ist kein AmigaGuide sondern einiges mehr. Habe nur schon lange nichts mehr dafür gemacht und die im Aminet liegend Version ist doch noch etwas buggy....

Ciao,
Stefan
 
SRuppert   Nutzer

03.05.2003, 13:53 Uhr

[ - Direktlink - ]
Thema: Startup Code in C
Brett: Programmierung

Ist schon länger her, dass ich mich mit startup code rumgeschagen habe auf dem Amiga. Also noch zwei Dinge.

1. Wie sieht genau dein Linker aufruf aus?

startup.o muss als aller erstes eingebunden werden! Also
etwa : gcc -nostartupfiles -noixemul startup.o app.o -o app

Wenn das nicht hilft, dann noch evtl:

2. Die Variablen "struct Library *SysBase, *DOSBase;" unterhalb
der _main() Funktion definieren.

Also:

extern struct Library *SysBase, *DOSBase;
long _main()
{
}
struct Library *SysBase, *DOSBase;

Ciao, Stefan
 
SRuppert   Nutzer

03.05.2003, 12:26 Uhr

[ - Direktlink - ]
Thema: Startup Code in C
Brett: Programmierung

Hi,

also der startup code sieht ganz gut aus. Die Frage ist wie du das Programm übersetzt ixemul? libnix? Ausserdem kommt es drauf an was in deinem Programm noch benutzt wird: Intution, Gfx...? Wenn du einen eigenen startup code verwendest dann musst du auch alle benötigten libraries selbst öffnen und schliessen...

Hope this helps a little bit!

Ciao,
Stefan
 
SRuppert   Nutzer

07.01.2003, 11:54 Uhr

[ - Direktlink - ]
Thema: Morphos auf OpenFirmware/MPX100
Brett: MorphOS


Zitat:
Original von PeterH:
Ich habe eine Motorola-Workstation "Powerstack MPX100" mit OpenFirmware im Boot-ROM und ohne OS. Original gibt's dafür wohl AIX und vielleicht noch WinNT3.5. Auch PPC-Linux soll mit Mühe drauf zum Laufen zu kriegen sein.

Könnte diese Kiste eigentlich auch MorphOS ausführen? Sie hat einen mit 300MHz getakteten PowerPC 604e und eine CirrusLogic-Grafikkarte.

Grüße, Peter


Hi, na das wäre keine schlechte Sache! Habe hier genau diesen Rechner mit Debian/LinuxPPC laufen. Als Server funktioniert der Rechner echt klasse. Problematisch ist die Grafikkarte, da sie nur als Framebuffer von der Software angesprochen werden kann. Unter X11 bekommt man 800x600 und 1024x768 in 8 bit hin. Im 16 bit Modus ist der Treiber wohl nicht ganz angepasst an die PPC Architektur. Rot und Grün oder Rot und Blau Anteile sind vertauscht. Sieht jedenfalls echt nett aus ;-) (Cirrus Logic GD 5446)

SCSI sollte kein Problem sein ist ein Symbios 825 Chip.

Ethernet würde wohl nicht funktionieren: DECchip 21140

Ciao, Stefan
 
 
-1- Ergebnisse der Suche: 7 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.