amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- Ergebnisse der Suche: 21 Treffer (30 pro Seite)
Torsten_R   Nutzer

11.04.2020, 10:49 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Das Löten hat leider keine Besserung gebracht.
Die Lötstellen sahen gut aus, haben sie dennoch nochmal kurz nachgelötet, siehe hier:

Bild: https://www.bilder-upload.eu/bild-aed052-1586594776.jpg.html

Jetzt versuche ich es mal mit einem Ersatzteil, da ich denke, dass mit einem Pin etwas nicht stimmt:

Ersatzteil 9-pin D-Sub
 
Torsten_R   Nutzer

30.03.2020, 21:27 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von AmigaHarry:
Bis auf den Wackler scheint die Kiste OK zu sein.


[quote]
Original von cgutjahr:
Aber durch das neu Anlöten sollte sich hoffentlich auch ein wackeliger Pin bereinigen lassen.
[quote]

[quote]
Original von cgutjahr:
Ich würde es erst mal mit der existierenden Buchse versuchen, und falls dann immer noch Bedarf besteht beim Händler nachfragen.
[quote]

Danke für eure Hilfe!!

Dann schaue ich mich mal nach einer neuen Maus um und versuche durch das Löten den Port 2 wieder zum Laufen zu bekommen - wenn das nicht klappt, muss ein Ersatzteil ran.
 
Torsten_R   Nutzer

30.03.2020, 13:09 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von AmigaHarry:
Wenn du den Joystick in den Mausport steckst, sollte der Pointer bei betätigen des Joysticks kleine Rucker in die jew. Richtung machen. Der Fireknopf müsste den linken Mausbutton auslösen.


Genau so ist es.
Heißt demnach dass der Port i.O. ist, nur halt die Maus die falsche ist.

Zitat:
Original von AmigaHarry:
Unter F7 und dann F2 könntest du noch die CIA-Ports testen. Ports PA2-PA6 sollten Inputwert 1 haben.


Bei mir haben CIAA.PA2 - CIAA.PA7 den Input-Wert 1.
CIAA.PA0 und CIAA.PA1 haben bei Mode "OUT.0" und Wert 0

siehe Foto:
Bild: https://www.bilder-upload.eu/bild-f7df8e-1585566558.jpg.html
 
Torsten_R   Nutzer

30.03.2020, 13:00 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von AmigaHarry:
Nochwas: Deine Maus ist eine PS/2-Maus mit einem stinkordinären PS2/Serial-Adapter. Das kann am Amiga nicht funktionieren.


Ok, danke auch hier nochmal für deine Antwort.
Dann schaue ich mich mal nach einer Alternative um.
 
Torsten_R   Nutzer

30.03.2020, 12:59 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von cgutjahr:
Ich habe immer noch Zweifel, dass die Maus bzw. der Adapter wirklich für den Amiga gedacht sind - kannst du mal Fotos von beiden machen?


Dann ist der Adapter bzw. die Maus wahrscheinlich tatsächlich nicht geeignet.

Hatte hier mal ein Bild hochgeladen:
Bild: https://www.bilder-upload.eu/bild-f4b2fd-1584787961.jpg.html

Zitat:
Original von cgutjahr:
Du kannst fürs Erste die Maus mit der Tastatur simulieren


Das klappt leider nicht im TestKit.
Oder geht das nur bei Spielen?

Zitat:
Original von cgutjahr:
Da sind wohl die Lötstellen, mit denen der Port am Motherboard befestigt ist, nicht mehr ganz in Ordnung. Sollte dir jeder mit einem Lötkolben richten können, Computer- oder Amiga-Kenntnisse braucht er dafür nicht.


Ok, werde ich mal mit einem Bekannten versuchen, der Löten kann.
Das sind die Lötstellen "unterhalb" am Motherboard, richtig?

Durch das "Wackeln" am Stecker bekomme ich ja die Verbindung korrekt hergestellt.
Daher nochmal die Frage: kann es auch an den Pins liegen, dass die locker / defekt sind und ich deshab den komplett Port austauschen müsste?
z.B. mit solch einem Ersatzteil:

Joystick Port Ersatzteil

[ Dieser Beitrag wurde von Torsten_R am 30.03.2020 um 13:11 Uhr geändert. ]

[ Dieser Beitrag wurde von Torsten_R am 30.03.2020 um 13:12 Uhr geändert. ]
 
Torsten_R   Nutzer

29.03.2020, 15:13 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von ylf:
Die Fire-Tasten bzw. Maus-Tasten gehen auch über U7 (CIA), XY der Maus über Denise und die zweite Maustatse über Paula.


Kann ich im TestKit - außerhalb der beiden Joystick- und Maus-Ports - feststellen, wo der Fehler liegen könnte?
 
Torsten_R   Nutzer

29.03.2020, 15:10 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Nochmal vielen Dank an Harry für die Diskette mit dem Amiga TestKit.
Läuft super!

Das Ergebnis des Tests:

Die Maus reagiert weder an Port 1 noch Port 2.
Heißt im Umkehrschluss, sie wird nicht erkannt, richtig?
Muss daher zwingend eine neue Maus ran oder kann es auch an etwas anderem liegen?

Joystick Port 1:
Funktioniert im TestKit einwandfrei - außer Taste 2 und 3, aber die gibt es dann wahrscheinlich einfach nicht am Joystick.

Joystick Port 2:
Funktioniert analog zu Port 1, aber NUR, wenn ich am Port am Stecker etwas "wackle" bzw. ihn in eine bestimmte Richtung "drücke" - d.h. hier scheint etwas nicht ganz zu passen.
Wahrscheinlich liegt es nicht am Joystick, da es auch beim zweiten Joystick das gleiche Problem ist.

Praxistest Giana Sisters:
Egal, was ich eingesteckt habe, es wird immer Joystick Port 2 angesteuert, kann ich das auch auf den Joystick Port 1 ändern (der ja angeblich lt. TestKit einwandfrei funktioniert)?
Im Zweispielermodus wechselt dann auch nicht der Port (es bleibt bei Joystick Port 2) - ist das immer so, kann mich leider nicht mehr erinnern?

Danke für eure Hilfe!

Grüße & schönen Sonntag
Torsten
 
Torsten_R   Nutzer

26.03.2020, 10:43 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

@AmigaHarry:
Ist erledigt - Danke nochmal!
 
Torsten_R   Nutzer

25.03.2020, 12:09 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von AmigaHarry:
Ja, wäre sinnvoll.
Ich bin keine A500-Experte - die Bilder müssen sich jene im Forum ansehen, die was davon verstehen. Staubige Angelegenheit.....


Sorry für den Staub, müsste ich tatsächlich mal grundreinigen ... :)

Würde mich freuen, wenn sich ein Experte meldet, dem ggfs. etwas auffällt, was anhand der Bilder nicht passt.
Danke für eure Rückmeldung!

Zitat:
Original von AmigaHarry:
Hast du die gesockelten Chips nachgedrückt, bzw. auf Korrosion hin untersucht? Speziell den Paula-Chip?


Jap, hab hier nichts Auffälliges entdeckt.
 
Torsten_R   Nutzer

25.03.2020, 12:07 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

@xxfreshman:
Genau so einen Adapter verwende ich - da das die Originalkiste vom Amiga ist, die ich seit Kindheit benutze, nehme ich an dass es früher auch funktioniert hat (an die Maus bzw. den Ball, den man immer mal reinigen musste, kann ich mich auch erinnern) und keiner in der Zwischenzeit einen "falschen" Adapter reingelegt hat :)

Wenn es nur die Maus wäre, die nicht funktioniert, würde ich mir eine andere kaufen - aber leider funktionieren beide Joysticks auch nicht (am selben Port).
 
Torsten_R   Nutzer

24.03.2020, 12:12 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

So, alles mal aufgeschaubt - aber leider ohne große Erkenntnis:

Gesamtübersicht Innenleben:
Bild: https://www.bilder-upload.eu/bild-7d2e2b-1585048078.jpg.html

Joystick Ports:
Bild: https://www.bilder-upload.eu/bild-ba12c5-1585048105.jpg.html

Denise:
Bild: https://www.bilder-upload.eu/bild-6b7619-1585048117.jpg.html

Einzig bei "RP201" ist oberhalb ein wenig "braune Masse" ausgetreten - vielleicht muss das aber auch so:
Bild: https://www.bilder-upload.eu/bild-c80837-1585048223.jpg.html

@AmigaHarry:
Dann wäre der nächste Schritt jetzt das TestKit laufen zu lassen, oder?
 
Torsten_R   Nutzer

22.03.2020, 18:43 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von AmigaHarry:
Was du selber machen kannst: Die gesockelten Chips nachdrücken bzw. rausnehmen und schauen ob die Pins korrodiert sind. Schaltplan kann ich dir senden - da siehst du welche Chips das vorrangig sind.


Das werde ich morgen mal versuchen.
Auf welche Chips sollte ich denn speziell achten, dann fällt mir das Suchen im Schaltplan einfacher - wäre super, wenn du mir den Schaltplan schicken könntest.
Hatte meinen Amiga noch nie aufgeschraubt, sollte aber nicht so schwierig sein.

Zitat:
Original von AmigaHarry:
Amigatestkit zeigt dir graphisch an ob und welche Signale von Maus und Joystick kommen, wenn du diese bewegst oder Buttons drückst.


Ich melde mich dann nochmal, wenn ich den Amiga aufgeschraubt hatte.
 
Torsten_R   Nutzer

21.03.2020, 16:31 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von AmigaHarry:
Ja, funktionieren immer beide und sind el. gleichwertig. Allerdings gehen ein paar Signale für beide Ports über denselben Chip (74LS157). Wenn der einen Schuß hat, kann es Probleme mit Forward/Back/Left/Right geben.


Ok, das könnte erklären, wieso beide Ports nicht funktionieren.
Aufschluss ergibt dann der Test.
Hieße es muss nicht zwingend an den Ports liegen...


Zitat:
Original von AmigaHarry:
WB1.3: Kannst du die Maus dort normal benutzen?


Leider nein.
 
Torsten_R   Nutzer

21.03.2020, 12:46 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Müsste denn der Joystick Port 2 funktionieren, selbst wenn Port 1 defekt wäre, oder wird standardmäßig immer auf Port 1 zugegriffen und Port 2 wird einzig im Mehrspieler-Modus genutzt?
 
Torsten_R   Nutzer

21.03.2020, 12:22 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

@AmigaHarry:
Die Maus ist PS/2.
Und ja Workbench 1.3 ist drauf.
 
Torsten_R   Nutzer

21.03.2020, 11:49 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

@AmigaHarry:

Ports:
Bild: https://www.bilder-upload.eu/bild-ec91d6-1584787735.jpg.html

Anschlüsse Joysticks und Maus inkl. Adapter
Bild: https://www.bilder-upload.eu/bild-f4b2fd-1584787961.jpg.html

[ Dieser Beitrag wurde von Torsten_R am 21.03.2020 um 11:53 Uhr geändert. ]
 
Torsten_R   Nutzer

21.03.2020, 11:41 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Zitat:
Original von cgutjahr:
Kommst du vom Titelbild in den Startscreen? Wenn ja, wie?


Komme leider nicht über den Startscreen weiter - habe es mit beiden Joysticks probiert, tut sich nichts - scheint dann wohl am Port und dem abgebrochenen Pin links oben zu legen, oder?
 
Torsten_R   Nutzer

21.03.2020, 11:19 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

@AmigaHarry:
Leider habe ich keine ad-hoc Möglichkeit eine Diskette mit dem TestKit zu beschreiben - was wäre hier denn der einfachste Weg?
 
Torsten_R   Nutzer

21.03.2020, 00:21 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Danke für eure Hilfe erstmal!!!

Ich habe mir gerade nochmal mit der Taschenlampe die beiden Ports angeschaut.
An Port 1 ist vermutlich ein Pin (links oben) hälftig abgebrochen.
Der zweite Port sieht gut aus - müsste dann nicht der Joystick über den zweiten Port auch funktionieren (tut er leider nicht)?
Geht die Maus mit Adapter nochmalerweise nur über Port 1 oder auch über Port 2 (bei mir geht beides nicht)?

@cgutjahr:

Giana Sisters teste ich gleich morgen nochmal...
Ich hab im Kopf, dass ich über das Titelbild gar nicht in den Startscreen gekommen bin - mein Gedächtnis von vor 20 Jahren sagt mir, dass das Titelbild anders aussah :)

Der PS2-Adapter ist auch von damals, war im "Keller-Set" dabei, daher vermute ich stark, dass er auch immer funktionierte. Auf dem Adapter steht nichts drauf.
Er sieht so aus:
Beispielbild
Leider kann ich die Maus an keinem anderen Gerät testen :/

@AmigaHarry:

Hab gerade mal zum TestKit recherchiert, sieht für jemanden Ungeübtes wie mich, sehr kompliziert aus. Aber ich lese mich mal ein ...
 
Torsten_R   Nutzer

20.03.2020, 22:09 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

@cgutjahr:

Zu den Joysticks:
Ich habe folgende Spiele probiert: Giana Sisters, Shufflepuck und Glücksrad. Wie beschrieben, leider ohne Erfolg mit beiden Joysticks - bzw. nur ein "Zittern" des Cursors.

Zur Maus:
Ich verwende eine Maus (mechanische Maus mit Gummikugel) die auf einem runden Stecker endet (kenne leider die genaue Bezeichnung nicht - könnte eine IBM PS/2 sein, 6 Pins, je 2 unten, rechts und links, oben ein kleiner Stab), dieser ist dann über einen Adapter (S/2 Adapter, PS/2 auf 9-pol.) an den Port 1 angeschlossen.

[ Dieser Beitrag wurde von Torsten_R am 20.03.2020 um 22:12 Uhr geändert. ]
 
Torsten_R   Nutzer

20.03.2020, 20:07 Uhr

[ - Direktlink - ]
Thema: Joystick Ports defekt
Brett: Amiga, AmigaOS 4

Hallo zusammen,

ich habe aus dem Keller seit gefühlten Jahrzehnten mal wieder meinen Amiga (A500) inkl. Zubehör ausgepackt und angeschlossen.
Nach anfänglichen Anschlussschwierigkeiten lief das System.

Leider funktionieren die beiden Joysticks (QJII Turbo und QJIII Supercharger) nicht, bzw. der Cursor bewegt sich nur minimal - die Tasten funkionieren.
Wenn ich die Maus (IBM) anschließe, tut sich leider gar nichts.

Weiß jemand einen Rat, wie ich der Lösung näherkomme?
Haben sowohl Port 1 als auch Port 2 ausprobiert.

Das Zubehör hat in der Vergangenheit (vor ca. 20) auf jeden Fall funktioniert.

Viele Grüße & Danke schon mal.
Torsten
 
 
-1- Ergebnisse der Suche: 21 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.