amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Suche [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 3 Ergebnisse der Suche: 74 Treffer (30 pro Seite)
Uwe   Nutzer

13.02.2007, 22:26 Uhr

[ - Direktlink - ]
Thema: ScummVm und A4000. leider sehr buggy
Brett: Amiga, AmigaOS 4

@MagicPocket:

ScummVM benötigt eigentlich keine FPU,
ich habe nur die falschen Compiler-Optionen gesetzt.
Du brauchst also keine FPU kaufen.
 
Uwe   Nutzer

12.02.2007, 22:46 Uhr

[ - Direktlink - ]
Thema: ScummVm und A4000. leider sehr buggy
Brett: Amiga, AmigaOS 4

@MagicPocket:

Zitat:
Die Version 0.9 startet erst gar nicht kommt direkt eine Fehlermeldung das das OS neugestartet werden soll da irgendein schwerer Fehler aufgetreten ist.

Hast du zufällig einen 68020 oder 030 ohne FPU?
Ich habe die neue Version mit -m68020-60 (gcc) kompiliert
und zu spät gemerkt, dass mit dieser Option FPU-Code
erzeugt wird. Ich werde demnächst eine Version
veröffentlichen, die auch auf einem reinem 020er läuft.

Zitat:
1. Ich habe generell keinen Sound

Ist AHI installiert?

Zitat:
2. SCUMMVM V0.7 schmeisst mich nach ca. 4 Minuten (varriert) wieder zurück auf dei Workbenchoberfläche und zeigt mir oben links ein Fenster an mit dem Inhalt: WB muß neu gestartet werden aufgrund eines Fehlers, jetzt neu starten oder später neu starten!

Schwer zu sagen bei >10MB Sourcecode. :-(
 
Uwe   Nutzer

10.02.2007, 23:21 Uhr

[ - Direktlink - ]
Thema: ScummVm und A4000. leider sehr buggy
Brett: Amiga, AmigaOS 4

@MagicPocket:

Installiere mal BlazeWCP, dann sollte das Flackern
aufhören. Außerdem wird die Grafikausgabe stark
beschleunigt.

MfG
Uwe
 
Uwe   Nutzer

30.07.2006, 22:20 Uhr

[ - Direktlink - ]
Thema: ScummVM 0.9.0 m68k
Brett: Amiga, AmigaOS 4

Zum Vergleich habe ich unter

http://web.inf.tu-dresden.de/~ur081221/ScummVM_06-30.lzx

mal meine Testversion mit nativen Backend hochgeladen.
Mich würde mal der Geschwindigkeitsunterschied interessieren.

Die Version ist etwas groß, da sie noch Debug-Daten
enthält. Falls jemand segtracker und MuForce (oder ähnliches
Programm) mitlaufen läßt und ein Hit findet, kann
die mir die Ausgabe schicken. Ich habe die zugehörige
Map-Datei.

MfG
Uwe

PS: Die Version unterstützt OggVorbis, MP3, FLAC und MPEG2.


[ Dieser Beitrag wurde von Uwe am 30.07.2006 um 22:25 Uhr geändert. ]
 
Uwe   Nutzer

30.07.2006, 17:27 Uhr

[ - Direktlink - ]
Thema: ScummVM 0.9.0 m68k
Brett: Amiga, AmigaOS 4

Ich wollte nur mitteilen, dass mein ScummVM-Port
schon seit langem nicht mehr den SDL-Backend verwendet.
Dies hatte ich wegen mangelnder Geschwindigkeit
und Instabilitäten aufgegeben.

Deshalb habe ich den nativen Morphos-Backend angepasst
und seither weiterentwickelt.

Da von den Original-Entwicklern öfters mal
die Backend-Spezifikation geändert wurde
und auch wegen Zeitmangel kamen meine ScummVM-Ports
auch immer etwas ;-) verspätet heraus.

Meine Version 0.9.0 ist aber fast fertig.

@Apex

> Wäre es möglich eine Ausgabe bei MP3 über den MAS-Player
> zu realisieren? So spiele ich bei mir MP3 mit fast keiner
> CPU Belastung.

Hattest du dass nicht schon mal gefragt?

Der MAS-Player kann nur einen MP3-Stream auf einmal abspielen.
Bei ScummVM ist es aber nicht ausgeschlossen, dass mehrere
gleichzeit abgespielt werden.

@Gerry

>Allerdings bringt mich das irgendwie auf eine Idee...
>Prozessmäsig die Soundausgabe von der Grafik abzukapseln...
>Ist ne Überlegung wert.

In ScummVM läuft die Soundausgabe immer in einem anderen
Process. Das macht den 68k auch nicht schneller.

Mit freundlichen Grüßen
Uwe Ryssel
 
Uwe   Nutzer

01.05.2006, 17:33 Uhr

[ - Direktlink - ]
Thema: PGP und GnuPG auf dem Amiga
Brett: Amiga, AmigaOS 4

@Valwit

Es gibt kein gpg (GnuPG) für Amiga, nur pgp.
GnuPG und PGP sind zwei verschiedene Projekte,
die nur das gleiche machen und untereinander kompatibel sind.
 
Uwe   Nutzer

01.05.2006, 14:32 Uhr

[ - Direktlink - ]
Thema: PGP und GnuPG auf dem Amiga
Brett: Amiga, AmigaOS 4

@Cottet

Ich habe es gerade mit PGP 5 probiert und es funktioniert
natürlich. Nach dem Import sieht man auch, warum es
mit PGP 2.x nicht funktionieren kann:

Dein Schlüssel ist ein DSS/Diffie-Hellman-Schlüssel.
PGP 2.x unterstützt nur RSA-Schlüssel.

Ich weiß nicht welche neuen Funktionen in PGP 9 sind,
aber die grundsätzlichen Funktionen (Schlüsselgenerierung,
Ver/Entschlüsseln, Signieren/Prüfen, Schlüsselverwaltung)
von PGP 5 sind IMHO kompatibel zu GnuPG und PGP >5.

Also wenn du PGP mit dem Amiga machen willst, verwende PGP 5.
PGP 2.x kann man nur verwenden, wenn nur RSA gewünscht ist.
Da aber heutzutage Diffie-Helman "Voreinstellung" bei der
Schlüsselgenerierung ist, wirst du es mit PGP 2.x schwer haben.

Uwe
 
Uwe   Nutzer

28.04.2006, 20:31 Uhr

[ - Direktlink - ]
Thema: Umsetzung StormC 4 -> gcc
Brett: Programmierung

@Holger

Zitat:
Dir ist schon klar, daß das nicht ganz sauber ist?

Das sollte nur ein kurzes Beispiel sein.

@Holger, Stefan

Ich habe mal gcc 3.3 verwendet. Das gleiche.
Es liegt an libnix. Bei Version 1.2 geht es, ab 2.0 nicht mehr.
Ich habe 2.1 installiert gehabt.

Version 1.2 ist immer bei den gcc-Paketen dabei.
>2.0 gibt's auf der libnix-Homepage (bei Sourceforge.net).

Der Fehler muss also in der Version 2.0 hereingekommen sein.

MfG
Uwe
 
Uwe   Nutzer

27.04.2006, 21:42 Uhr

[ - Direktlink - ]
Thema: Umsetzung StormC 4 -> gcc
Brett: Programmierung

Bevor ihr euch weiter wegen Kleinigkeiten streitet,
hier ein noch gravierender Fehler bei libnix 2.1
(ältere Versionen habe ich nicht probiert).

code:
#include <stdio.h>

int main(int argc, char **argv)
{
    FILE *file1, *file2;
    int a,b;
    char buffer1[10];
    char buffer2[10];

    file1 = fopen("datei1", "rb");
    file2 = fopen("datei2", "rb");

    if (file1 && file2)
    {

        a = fread(buffer1, 1, 10, file1);

        b = fread(buffer2, 1, 10, file2);

        fclose(file1);
        fclose(file2);
    }

    return 0;
}


Ausgaben (im Code weggelassen):
a = 10;
buffer1 = (ersten zehn Bytes von file2, in Worten Zwei)
b = 0;

Das Öffnen der zweiten Datei scheint irgendwie
die File-Strukturen durcheinanderzubringen.
file1 scheint auf die zweite Datei zu zeigen.
file2 scheint ungültig zu sein (aber != NULL).

Das gleiche mit ixemul funktioniert.

Mal nebenbei:
Ich habe mal versucht die libnix-Bibliotheken neuzukompilieren:
Das makefile schlägt immer fehl:

make[1]: *** No rule to make target 'nrcrt0.S',
needed by 'nrcrt0.o'. Stop.

Version von make: 3.80
Version von gcc: 2.95.3

Nachtrag:
Ich habe mal das gleiche mit open/close/read probiert
und es funktioniert. Da fopen/fclose/fread darauf basieren
muss der Fehler dazwischen liegen.






[ Dieser Beitrag wurde von Uwe am 27.04.2006 um 22:07 Uhr geändert. ]
 
Uwe   Nutzer

25.04.2006, 19:39 Uhr

[ - Direktlink - ]
Thema: Umsetzung StormC 4 -> gcc
Brett: Programmierung

Ich habe noch mal genau nachgesehen.
Es war nicht malloc(0), sondern calloc(x,0).

Und nur bei libnix stürzt es ab.
Ich habe mir mal die libnix-Sourcen abgesehen
und etwas experimentiert.

code:
void *calloc(size_t nmemb,size_t size)
{
  size_t l;
  size_t *a;
  void *b;
  l=(nmemb*size+(sizeof(size_t)-1))&~(sizeof(size_t)-1);
  a=(size_t *)(b=malloc(l));
  if(b!=NULL)
  {
    do
      *a++=0;
    while((l-=sizeof(size_t))!=0);
  }
  return b;
}


Ist einer der Argumente 0 ist auch l = 0.
malloc(0) liefert einen gültigen Zeiger.
Danach wird vom Zeiger aus die nächsten 4 GB Speicher gelöscht.
l ist 0 und wird um 4 verringert (=4G-4) und auf 0 geprüft ...

Was bei libnix fehlte probiere ich nochmal aus.
 
Uwe   Nutzer

24.04.2006, 20:40 Uhr

[ - Direktlink - ]
Thema: Umsetzung StormC 4 -> gcc
Brett: Programmierung

Ich versuche gerade ein größeres Projekt (Portierung von ScummVM)
von StormGCC auf gcc 2.95.3 umzusetzen.
Das scheint nicht ganz einfach zu sein. :-(

Scheinbar gibt es Unterschiede in der Implementierung
der ANSI-C-Bibliotheken. Ein Beispiel:

Im Programm kommen Stellen vor, bei dem versucht wird
0 Byte Speicher anzufordern (ist nicht meine Idee).

StormC liefert bei malloc(0) einen gültigen Zeiger.
gcc/ixemul stürzt bei einem malloc(0) ab, da laut
ixemul-Sourcen direkt auf AllocMem(0, ...) abgebildet
wird.

Gibt es noch andere Inkompatibilitäten, besonders
wie oben bei Grenzsituationen?

Gibt es Hinweise und Tipps, die eine "Umsetzung" erleichtern?

Uwe

PS: libnix funktioniert auch nicht
(fehlende Funktionen, weitere Inkompatibilitäten)
 
Uwe   Nutzer

26.12.2005, 21:41 Uhr

[ - Direktlink - ]
Thema: WriteLUTPixelArray funktioniert nicht mit g++
Brett: Programmierung

Ich benutze gcc 2.95.3 (Distribution von Dietmar Eilert)
und habe Probleme mit dem Aufruf der Funktion
WriteLUTPixelArray von Cybergraphics.
Das entsprechende Programm ist in C++ geschrieben.

Nach verzweifelten Suchen, warum mein Programm unter
gcc nicht funktioniert (mit StormC4 ging es) habe ich
folgendes Problem beim Aufruf der Funktion WriteLUTPixelArray
entdeckt. Wird diese Funktion in C++ verwendet funktioniert
sie nicht (es wird nichts gezeichnet), unter C aber wohl.

Die Funktion wird über inlines aufgerufen. Das inline habe
ich selbst erstellt (mit fd2pragma special 40) und entspricht
den Format wie es bei gcc installiert wird.
Für WLUT ist das

code:
#define WriteLUTPixelArray(...) \
    LP11(0xc6, ULONG, WriteLUTPixelArray, ...)


wobei LP11 in inline/macros.h definiert ist:

code:
#define LP11(offs, rt, name, t1, v1, r1, t2, v2, r2, t3, v3, r3, t4, v4, r4, t5, v5, r5, t6, v6, r6, t7, v7, r7, t8, v8, r8, t9, v9, r9, t10, v10, r10, t11, v11, r11, bt, bn) \
({                              \
   t1 _##name##_v1 = (v1);                  \
   t2 _##name##_v2 = (v2);                  \
   t3 _##name##_v3 = (v3);                  \
   t4 _##name##_v4 = (v4);                  \
   t5 _##name##_v5 = (v5);                  \
   t6 _##name##_v6 = (v6);                  \
   t7 _##name##_v7 = (v7);                  \
   t8 _##name##_v8 = (v8);                  \
   t9 _##name##_v9 = (v9);                  \
   t10 _##name##_v10 = (v10);                   \
   t11 _##name##_v11 = (v11);                   \
   {                                \
      register rt _##name##_re __asm("d0");         \
      register struct Library *const _##name##_bn __asm("a6") = (struct Library*)(bn); \
      register t1 _n1 __asm(#r1) = _##name##_v1;        \
      register t2 _n2 __asm(#r2) = _##name##_v2;        \
      register t3 _n3 __asm(#r3) = _##name##_v3;        \
      register t4 _n4 __asm(#r4) = _##name##_v4;        \
      register t5 _n5 __asm(#r5) = _##name##_v5;        \
      register t6 _n6 __asm(#r6) = _##name##_v6;        \
      register t7 _n7 __asm(#r7) = _##name##_v7;        \
      register t8 _n8 __asm(#r8) = _##name##_v8;        \
      register t9 _n9 __asm(#r9) = _##name##_v9;        \
      register t10 _n10 __asm(#r10) = _##name##_v10;        \
      register t11 _n11 __asm(#r11) = _##name##_v11;        \
      __asm volatile ("jsr a6@(-"#offs":W)"         \
      : "=r" (_##name##_re)                 \
      : "r" (_##name##_bn), "r"(_n1), "r"(_n2), "r"(_n3), "r"(_n4), "r"(_n5), "r"(_n6), "r"(_n7), "r"(_n8), "r"(_n9), "r"(_n10), "r"(_n11) \
      : "d0", "d1", "a0", "a1", "fp0", "fp1", "cc", "memory");  \
      _##name##_re;                     \
   }                                \
})


Frage 1: Wieso funktioniert __asm in C++, normalerweise wird
doch asm gar nicht unterstützt?

Übrigens, Funktionen mit weniger Argumenten funktionieren immer.
Ich habe mal die Assembler-Ausgabe überprüft.
Beim Aufruf der Funktionen werden zwei Register gar nicht
gesetzt. Es handelt sich dabei um D5 und D6, die die Breite und
Höhe des zu zeichnenden Rechtecks festlegen. Dadurch
zeichnet er auch nichts.

Frage 2: Sind die Register D5 und D6 in C++ irgendwie reserviert,
so dass sie ignoriert werden?

Bis jetzt habe ich die Sache so gelöst:
Ich habe eine C-Datei mit einer Funktion WLUT erstellt,
die die richtige Funktion WriteLUTPixelArray aufruft.
WLUT wird dann von C++ aufgerufen.
Aber das muss ja auch anders gehen. Oder?

Uwe


[ Dieser Beitrag wurde von Uwe am 26.12.2005 um 21:43 Uhr editiert. ]
 
Uwe   Nutzer

12.10.2005, 21:37 Uhr

[ - Direktlink - ]
Thema: Dateivergleicher
Brett: Amiga, AmigaOS 4

Ein Vergleichsprogramm mit GUI gibt's im Aminet
unter util/misc/CMP15.lha
Dieses Programm ist aber schon ziemlich alt.
 
Uwe   Nutzer

23.09.2005, 15:17 Uhr

[ - Direktlink - ]
Thema: ScummVM 68k Tips & Tricks?
Brett: Amiga, AmigaOS 4

@aPEX:

Bei Spielen mit Sprachausgabe ist es, zumindest bei FFS, wichtig den
Puffer für das Filesystem zu erhöhen (z.B. addbuffers ... 1000).
Damit wird verhindert, dass nicht vor jedem Satz 2-3 Sekunden
gewartet/geladen wird. Ob es etwas bringt eine Partition
mit höherer Blockgröße zu verwenden habe ich noch nicht ausprobiert.

Wenn die Ausgabefrequenz der Adlib-Emulation verringert wird
(siehe Anleitung) kann noch etwas mehr an Geschwindigkeit
herausgeholt werden. Ggf. kann die Hintergrundmusik auch
abgeschaltet werden.

>Wie ist das eigentlich bei Scumm? Greift der automatisch
>auf das AHI Device Unit 0 zu, oder wie? ....

Genau so ist es.

>Wie ist das mit den GFX Modes? Konnte feststellen das er bei
>advmame2x schneller ist, dann aber der Sound spinnt.

Die GFX-Modes sind rechenintensiver und nehmen dem Sound-Thread
die CPU-Zeit weg. Vielleicht läuft dann das Hauptprogramm
schneller, da der Sound-Thread weniger läuft.

Zu Problemen mit P96 und dem Fullscreen-Mode:
Versucht mal ein Update zu finden. Bei einigen Nutzern
hat das geholfen.

Uwe
 
Uwe   Nutzer

02.09.2005, 22:02 Uhr

[ - Direktlink - ]
Thema: DSL mit Fritz!Box?
Brett: Amiga, AmigaOS 4

Ich habe seit heute auch DSL mit der FritzBox FON WLAN 7050.
Funktioniert bei mit wunderbar.

Ich habe einem Amiga 4000 mit Miami und Norway Ethernet
und ein Apple Powerbook dranhängen.
Die Konfiguration der Box habe ich mit dem Powerbook
gemacht, da Aweb nicht mit der FritzBox-Konfig-Seite funktioniert.

> Ins Internet komme ich sicher, zumal die Fritz!Box ja alle
> Zugangsdaten enthält und sich nach Einschalten selber mit
> der DSL-Vermittlungsstelle verbindet.
> (Also bräuchte ich das PPPOe-Device auf dem Amiga gar nicht?)

Wenn die Zugangsdaten in der FritzBox eingegeben worden
fungiert dieser als DSL-Router. PPPoE braucht man
dann nicht auf Amiga-Seite.

Ein (reines) DSL-Modem ist die Fritz-Box, wenn keine Zugangs-
daten in der Box vorhanden sind.

> Wie bekomme ich die Routing-Verbindung hin,
> so dass sich PeeCee-DOSe und Amiga sehen?
> Das klappt hier noch nicht. Der Amiga muss auf jeden Fall
> ran ans Netz!

Auf der Amiga-Seite muss Miami für ein LAN konfiguriert werden.

Siehe http://www.highantdev2.de/adnet/tutorials/network/page2.php



Dieses Tutorial konfiguriert gleichzeitig Samba mit.
Ich weiß nicht genau, was davon für normales Internet
gebraucht wird, aber ich denke, dass Punkt 2.1 und 2.2 reichen.

Unter Schnittstelle habe ich IP-Typ und Netzmasken-Typ auf
DHCP und den Gateway-Typ auf statisch und 192.168.178.1
gesetzt.

Uwe


[ Dieser Beitrag wurde von Uwe am 02.09.2005 um 22:06 Uhr editiert. ]

[ Dieser Beitrag wurde von Uwe am 02.09.2005 um 22:17 Uhr editiert. ]
 
Uwe   Nutzer

25.08.2005, 00:03 Uhr

[ - Direktlink - ]
Thema: ScummVM AGA
Brett: Amiga, AmigaOS 4

@MaikG:

Die input.device von Poseidon ist eine extra Datei.
Aber vielleicht wird diese nur aktiviert, wenn
o.g. Klassen aktiv sind.

Jedenfalls da ForgottenHero eine USB-Maus verwendet,
braucht er sie Poseidon-input.device.
 
Uwe   Nutzer

24.08.2005, 23:06 Uhr

[ - Direktlink - ]
Thema: ScummVM AGA
Brett: Amiga, AmigaOS 4

Zitat:
Original von MaikG:
Falls man keine USB-Tastatur oder Maus hat kann man die
entsprechenden Klassen entfehrnen.


Der Fehler liegt in der input.device und nicht
in irgendwelchen USB-Klassen, die man deaktivieren kann.

Richtig würde es lauten:
Falls man keine USB-Tastatur oder Maus hat kann man die
input.device aus den Poseidon-Paket entfernen,
oder man hat eine input.device, die diesen Fehler nicht
hat. Diese ist von Chris Hodges erhältlich.
 
Uwe   Nutzer

24.08.2005, 17:14 Uhr

[ - Direktlink - ]
Thema: ScummVM AGA
Brett: Amiga, AmigaOS 4

Zitat:
Original von MarkusPohlmann:
Nochwas: MonkeyIsland3? Kannst Du das mit ScummVM spielen?
Die Szene direkt zu Anfang wo man mit der Kanone schiessen muss klappt bei mir nicht, da der Mauspfeil immer in die rechte untere Ecke springt und nicht wegzubewegen ist. Die Kanone ballert also immer nach rechts unten...


Darf ich raten? Du benutzt die input.device vom USB-Stack Poseidon.
Dieses Problem hatte ich auch.
Frag mal Chris Hodges nach einem Update der input.device.

Die Version im Poseidon-Paket hat einen Fehler im Zusammenhang
mit der Input-Klasse IECLASS_NEWPOINTERPOS.

Uwe
 
Uwe   Nutzer

23.08.2005, 15:20 Uhr

[ - Direktlink - ]
Thema: ScummVM AGA
Brett: Amiga, AmigaOS 4

Zitat:
Original von AMike:
Da kann aber was nicht stimmen. The Dig hab ich mit der 0.7 noch nicht getestet, war aber früher mit der 0.5 ziemlich langsam.(WOS) Aber Indy IV und Monkey Island hab ich gestern auf einen 1200er mit einer Blizzard 1230 getestet und war ganz baff wie flott die laufen. Absolut zu empfehlen, aber leider halt noch ohne Ton.
Unter AGA muß übrigens BlazeWCP installiert sein.


Bei AHI wird mindestens Version 4 verlangt.

Was ScummVM so langsam macht ist normalerweise die
MIDI-Emulation, die bei PC-Versionen benötigt wird.
Würde es flächendeckend Amigas mit MIDI-Soundkarten
geben, sehe das ganz anders aus.
 
Uwe   Nutzer

11.07.2005, 23:23 Uhr

[ - Direktlink - ]
Thema: Nightlong Deutsche Sprache von PC CD möglich?
Brett: Amiga, AmigaOS 4

Zitat:
Original von MaikG:
Dafür gibt es breits fertige programme RIPIT z.B. die
Extrahieren Wavs.


RIPIT kann zwar WAVs extrahieren.
Aber ich glaube kaum, dass es die richtigen Dateinamen
zuordnen kann. Das per Hand machen zu müssen, möchte
ich keinen wünschen. Die erste Datei enthält schon
fast 2000 Samples.

Uwe

PS: RIPIT ist bei mir abgestürzt und laut
Anleitung muss man es für WAVs noch registrieren.
 
Uwe   Nutzer

11.07.2005, 14:12 Uhr

[ - Direktlink - ]
Thema: Nightlong Deutsche Sprache von PC CD möglich?
Brett: Amiga, AmigaOS 4

Zitat:
Original von Zettmaster:
Ja...das Wort data kommt danach vor...

Die Datei von der erstn CD ist 48MB groß. Es sind noch 2 mit dem selben Namen auf der CD2 und 3.
Wenn man die Sounds da rausbekommt steht einem Deutschen Hörgenuß mit Bruce Willes deutscher synchron Stimme nichts mehr im Weg...

Ich installiere mir eben noch mal nen Hex Editor...Bringt das was?


Damit kann man die Datei besser ansehen,
Binärdateien in einem Texteditor ansehen ist normalerweise
nicht sehr aufschlussreich.

Zitat:
Kannst du so ein Prog besorgen/schreiben?

Sollte kein Problem sein.
Damit ich es schreiben kann benötige ich
den Anfang einer dieser Dateien.

Ich schicke dir gleich mal eine E-Mail.

Uwe
 
Uwe   Nutzer

11.07.2005, 13:38 Uhr

[ - Direktlink - ]
Thema: Nightlong Deutsche Sprache von PC CD möglich?
Brett: Amiga, AmigaOS 4

Zitat:
Mit dem Texteditor geöffnet sieht man die einzelnen WAV dateien geordnet.Danach nur noch Hieroglyphen---
Wie soll man das nur entpacken? Ist das Verschlüsselt?

Ich kann 2 Wörter entdecken die vieleicht etwas aussagen:

- riff
- wavetmf


Die Wörter RIFF, WAVE und fmt deuten auf einen WAVE-Header hin.
Bestimmt gibt es weiter hinten noch das Wort "data".

Falls es dich interessiert, hier die Beschreibung
einer WAV-Datei:

http://ccrma.stanford.edu/courses/422/projects/WaveFormat/




Versuch mal die Datei in einem Hex-Editor zu laden.
(z.B. Zaphod im Aminet). Da sieht man immer etwas
mehr.

Du sagst, dass die Namen der Dateien am Anfang stehen.
Verstehe ich das richtig?

Vermutlich ist die Datei gar nicht gepackt,
sondern alle nur in eine Datei archiviert.
Also keine Verschlüsselung.

Eigentlich sollte das Auseinandernehmen kein Problem
sein. Es müsste nur ein entsprechendes Programm
geschrieben werden. ;-)

Wie groß ist denn die Datei genau?

Uwe


[ Dieser Beitrag wurde von Uwe am 11.07.2005 um 13:40 Uhr editiert. ]

[ Dieser Beitrag wurde von Uwe am 11.07.2005 um 13:44 Uhr editiert. ]
 
Uwe   Nutzer

01.07.2005, 14:35 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

Zitat:
Original von Stefan:
2. Meine PC2AM Nullmodemverbindung funktioniert nicht, wenn das CDDA gestartet ist. :(


Da ich noch Debug-Ausgaben im Programm habe, die an die serial.device
gesendet werden, werden anderen Programme, die über die
serial.device kommunizieren, gestört.

In der nächsten entgültigen Version, entferne ich
diese Ausgaben natürlich.

Uwe
 
Uwe   Nutzer

01.07.2005, 00:15 Uhr

[ - Direktlink - ]
Thema: amiga plus kündigen..
Brett: Amiga, AmigaOS 4

Ich habe heute bei WEKA angerufen
(die Telefonnummer steht im Impressum von Amiga-Magazin,
und auf dem Umschlag der erhaltenen PCgo/AmigaMagazin.)

Die Kündigung haben sie angenommen und wollen
des Restbetrag erstatten.

Warum sollte ich erst irgendwo hinschreiben?

Uwe
 
Uwe   Nutzer

01.07.2005, 00:08 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

Zitat:
Original von Sprocki:
Das verschwindet sehr wohl wieder, wenn ich die CD herausnehme, ergo wird der Diskwechsel erkannt.
Bis dato erschien jedoch immer ein zweites Icon, so daß ich sehen konnte, daß die CD als Datenträger auch korrekt gemountet wurde. Unter MOS geschieht das auch weterhin, auch mit den neuen Versionen, unter OS3.9/Amithlon nicht mehr.


Da unter Amithlon der CD-Wechsel nicht erkannt wird, habe
ich in einer neuen Testversion einen Schalter eingebaut,
mit dem man, wie bei CacheCDFS/Ohne ChangeInt auf
Polling umstellen kann. Damit sollte es wieder funktionieren.

Dieser Schalter (POLLCDSTATE) brauch nur gesetzt werden,
wenn es ohne nicht geht.

Die neue Version ist unter schon o.g. Adresse zu erhalten.

Uwe
 
Uwe   Nutzer

30.06.2005, 11:10 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

@ Sprocki

Vorher hattest du gesagt, es erscheine kein Icon.
Deshalb dachte ich die CD-Wechselerkennung funktioniert
nicht.

Jetzt schreibst du, dass der Wechsel erkannt wird,
aber nur "ein NDOS-Icon und kein weiteres" gezeigt wird.

Was funktioniert denn nun nicht?

Uwe
 
Uwe   Nutzer

29.06.2005, 21:33 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

@ Sprocki

Versuche es erstmal mit einem C:DiskChange.
Ich vermute bis jetzt, dass Amithlon, solche
Interrupts nicht erzeugt.

Uwe
 
Uwe   Nutzer

29.06.2005, 17:29 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

Zitat:
Original von Sprocki:
Mit der neuen Version des Archivs wird bei mir keine CD mehr gemountet, was vorher noch bei fast allen gelang (abzüglich der vielen Abstürze der WB, die CDDA verursachte). Ich bekomme nur noch das Icon "CD0:CDDA", kein zweites mehr. CDDA habe angeblich keine Disk im Laufwerk.


Welche Device benutzt du?

Seit den letzten beiden Versionen läuft die
CD-Erkennung anders.
Früher habe ich aller 3 Sekunden das Laufwerk gefragt,
ob eine CD vorhanden ist oder nicht,
jetzt gebe ich dem Device die Anweisung, es soll einen
Interrupt erzeugen.
Vermutlich funktioniert das nicht bei allen Devices.

Uwe
 
Uwe   Nutzer

27.06.2005, 23:22 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

Zitat:
Ein Vorschlag für's "Feintuning" wäre, das man eventuell ein anderes Icon für dieses Gerät auf die WB bekommt, als das def_Disk.icon. Was bei mir eben eine stilisierte Festplatte ist, und dadurch etwas unpassend.

Ich habe es zwar noch nicht ausprobiert, aber wenn man
eine def_cdda.info erstellt müsste es doch verwendet werden.

Uwe
 
Uwe   Nutzer

26.06.2005, 22:56 Uhr

[ - Direktlink - ]
Thema: CDDA-FileSystem testen
Brett: Amiga, AmigaOS 4

@Palgucker

Habe nur eine Merkwürdikkeit bei mir entdeckt,
mit dem Dateimanager "Filer" (Aminet-Cd's) kommt bei mir
die Fehlermeldung "Can't access Trackxx :O bjekt nicht gefunden


Bei mir nicht. Ich habe gerade Version 3.23 ausprobiert.
Tritt es immer auf? Bei einer bestimmten Datei/CD?

Uwe


[ Dieser Beitrag wurde von Uwe am 26.06.2005 um 22:57 Uhr editiert. ]
 
 
-1- 2 3 Ergebnisse der Suche: 74 Treffer (30 pro Seite)

Suchbegriffe
Schlüsselwörter      Benutzername
Suchoptionen
Nur in diesen Foren suchen
   nur ganze Wörter
Nur Titel anzeigen
alle Treffer anzeigen

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.