amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > PPaint und Amithlon funktionieren wieder ganz [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

12.04.2004, 16:06 Uhr

Bernward
Posts: 113
Nutzer
Habe im Aminet das kleine Programm SetAgnus gefunden, dass seit einigen Tagen dort zu finden ist.

Hier die Beschreibung aus dem Readme:

--------------------------------

Short: Removes an incompatibility between Amithlon and PPaint
Author: Joerg van de Loo
Uploader: joergloo@aol.com (Joerg van de Loo)
Version: 1.0
Type: util/misc
Status: Public Domain

Makes it possible to use PPaint under Amithlon with screens and images
greater than 1008 pixels in width. No more 800x600 screen limit.

-------------------------------

Meine deutsche Beschreibung (Erklärung) dazu:

Jetzt funktioniert PPaint unter Amithlon wieder mit großen Grafiken.
Bisher hat PPaint schon bei kleinen Grafiken abgebrochen, dass der Speicher zu klein sei, was aber gar nicht stimmte.
Beim OriginalAmiga gab es bei der Cyberstorm einen ähnlichen Patch.

Für mich ist es besonders schön, dass ich wieder z.B. sehr große sw-Grafiken bearbeiten kann (3000x4000).

Auch wenn es andere gute Malprogramme gibt, PPaint bin ich einfach gewohnt und man kann im Hintergrund sehr gut damit arbeiten.

Man bindet SetAgnus wie im readme beschrieben in dei userstartup oder startup-sequence ein, startet neu und es funktioniert...

Einfach ein schönes kleines Programm für alle, die PPaint noch benutzen wollen.

mfG

Bernward

[ - Antworten - Zitieren - Direktlink - ]

13.04.2004, 19:36 Uhr

Jinx
Posts: 2077
Nutzer
es gibt für die cyberstorm auch einen patch? wo finde ich den?
--
eMail: TheJinx@web.de
Homepage: http://www.TheJinx.de

[ - Antworten - Zitieren - Direktlink - ]

17.04.2004, 07:18 Uhr

Bernward
Posts: 113
Nutzer
Ich kann es nicht mehr ganz genau sagen (ist schon zu lange her), weiß nur noch, dass ich alles dem Handbuch/der Beschreibung entnommen habe.

Genaugenommen war es auch nicht genauso ein "patch", sondern es wurde von cloanto selber mit der "PPC Blit library" (2.3) realisiert (entsprechend gings auch mit der 68060er library). Im weitesten Sinne ist das ja auch ein "patch".

Die musste man in seine Umgebung einpassen (genaures findest du in der Anleitung von PPaint, wenn du es nicht weißt).
Hier das readme dieser library (liegt alles auch im Verzeichnis .../PPaint/libs):

--------------------- Begin readme -------------------

Short: Personal PPC Blit Library v. 2.3

Uploader: info@cloanto.com (Cloanto)

Author: info@cloanto.com (Cloanto)

Type: biz/cloan

Distribution: Only Cloanto, Aminet and Aminet CD-ROM


CLOANTO SOFTWARE UPDATE


FILES BEING UPDATED

- personal_ppc_blit.library


PROGRAMS USING THE LIBRARIES

- Personal Paint version 7.0 and higher
- ColorType version 3.1 and higher


INSTALLATION DIRECTORY

- Default : "PPaint:libs", "ColorType:libs"
- Optionally: "LIBS:"
(software checks both paths and uses the newer library if two are found)


ENVIRONMENT VARIABLES

- PBlit_ChipMem (Yes/No/Auto)


DESCRIPTION

This CPU blitting library is used by programs like Personal Paint when the "Settings/Graphics/Amiga Blitter" setting is switched off.

This library automatically detects a CyberGraphX 40.100+ environment, and informs the client software (e.g. Personal Paint) that it is safe to allocate Fast RAM instead of Chip RAM even if the memory has to be accessed by the graphics.library. CyberGraphX "clones", which have a parallel system of version numbers, are detected and will not trigger this condition, as this would currently crash the system.

This library uses the PowerPC CPU to emulate a 32-bit blitter, whereas all libraries prior to version 2.0, like the original Amiga, worked with a 16-bit blitter model. This release is about twice as fast as the 1.x libraries. In particular, a simulation of average blitter operations of this PowerPC version tested on a PowerUP board with a 603e CPU running at 150 MHz resulted in a software blitter more than twice as fast as the AGA Amiga hardware blitter, with the advantage of not requiring precious Chip RAM.

Additional functionality has been integrated in this library to better support future programs.

To use this library, please update the library name in the "Startup_1.set" program settings file. In no case should any of the library files be renamed.

The automatic detection of a RTG environment supporting bitmaps in Fast RAM can be overridden by setting the "PBlit_ChipMem" environment variable, which can be used to force the allocation of bitmaps in Chip RAM or Fast RAM.

This blitting library requires the "ppc.library" to be present in the system, plus a PowerPC kernel compatible with the version released by Phase 5.

Version 2.3 fixes an incompatibility introduced by changes in the software included with newer Phase 5 PowerPC boards. The original library, which may be required for some older PowerPC configurations, is included in the "old" directory.


NOTES

Visit the Cloanto web site at <http://www.cloanto.com> for the latest news.

Your feedback is very appreciated. E-mail: <support@cloanto.com>.

For additional technical and legal information on the files, please refer to the documentation included with the original (commercial) distribution. In particular, all files are Copyright © 1996, 1997 Cloanto Italia srl.

--------------------- End readme ----------------------------------

Hoffe damit dir geholfen zu haben

mfG

Bernward

[ - Antworten - Zitieren - Direktlink - ]

23.04.2004, 17:55 Uhr

Jinx
Posts: 2077
Nutzer
hm, also brauche zur benutzung dieser library nen ppc? dann nutzt sie
mir nix, ich hab nur ne mk ii mit 060. :(
--
eMail: TheJinx@web.de
Homepage: http://www.TheJinx.de

[ - Antworten - Zitieren - Direktlink - ]

27.04.2004, 21:43 Uhr

Bernward
Posts: 113
Nutzer
Wie oben bereits erwähnt gibt es auch eine 68060er library.
Mit der dürfte auch einiges möglich sein - einfach mal ausprobieren, falls nicht schon geschehen...

mfG

Bernward

[ - Antworten - Zitieren - Direktlink - ]

01.05.2004, 02:22 Uhr

Fanne
Posts: 85
Nutzer
Zitat:
Original von Bernward:
Wie oben bereits erwähnt gibt es auch eine 68060er library.


Also ich hab in meinem PPaint-Libs-Ordner ne "personal_68060_blit.library" und "personal_68040_blit.library". Die sind allerdings schon von 1997. Weiß auch nicht mehr, wo ich die herhab. Gabs da nicht mal im AmiNet ein 060-Update ?????(

CU
Fanne
--
Home: http://www.fanne.de.vu


Member of AmCluST

[ - Antworten - Zitieren - Direktlink - ]

01.05.2004, 21:46 Uhr

kadi
Posts: 1503
Nutzer
Ja, und zwar im Cloanto Ordner im Aminet, ist glaube ich direkt unter /biz/.

Unter Amithlon gab es den Bug bei Grafiken die breiter als 1008 Pixel waren. Solche Bilder konnte man zwar erstelen, bearbeiten und speichern, aber nicht wieder einladen.

Unter UAE und WinUAE tritt der Fehler auch auf, wenn man AGA und ECS Emulation abschaltet oder auf das minimum setzt. Ab der ECS-fullAgnus (oder so ähnlich) Emulation tritt der Fehler unter UAE nicht mehr auf.

Leider gibt es bei Amithlon keine solche Einstellung, so das man PPaint nie für größere Grafiken vernünftig einsetzen konnte.

Jetzt solls ja dank dem Patch gehn :-) Wo ich kein Amithlon mehr hab um das zu testen :-(


[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > PPaint und Amithlon funktionieren wieder ganz [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.