amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > RDBSalv [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

17.09.2004, 20:17 Uhr

Valwit
Posts: 750
Nutzer
Hi!

Dummerweise kammen mir heuet 2 partitionen abhanden. Kennt jemand ein Tool zum auffinden/wiederhesrstellen? RDBSalv aus dem Aminet scheint gut zu sein, leider ist es Shareware, und total alt. (Mail funzt nicht, Bestellung per Post).
--
Viele Grüsse
Valwit

[ - Antworten - Zitieren - Direktlink - ]

17.09.2004, 22:41 Uhr

Supimajo
Posts: 1265
Nutzer


[ Dieser Beitrag wurde von Supimajo am 30.07.2005 um 17:13 Uhr editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

18.09.2004, 03:13 Uhr

JoJo
Posts: 92
Nutzer
Hi Valwit

Die Shareware-Gebühr für RDBSalv ist gut angelegtes Geld.

Die Email-Adresse meiner Version von 1996:
Angela.Schmidt at stud.uni-karlsruhe.de

--
JoJo :shoot2:

[ - Antworten - Zitieren - Direktlink - ]

18.09.2004, 03:53 Uhr

Valwit
Posts: 750
Nutzer
tja. eben diese mail funzte nicht. na ja, das problem habe ich mittlerweile gelöst (nach 8 stunden *seufz*). leider weiss ich nicht warum mein rdb kaputt ging.

[ Dieser Beitrag wurde von Valwit am 18.09.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

18.09.2004, 09:19 Uhr

analogkid
Posts: 2392
Nutzer
wenn du eine registrierte Version von RDBSalv suchst, kann ich auch die CD "Amiga Repair Kit" empfehlen, wo neben jener Vollversion auch noch anderen praktische Utilities drauf sind (z.B. DiskSalv 3+4).
--
Join us @ Sarkasmus-pur


:amiga: :dance1:

Take a walk beside yourself

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 00:35 Uhr

Palgucker
Posts: 1341
Nutzer
qoute:

Kennt jemand ein Tool zum auffinden/wiederhesrstellen?

Wundert mich eigendlich, das der Vorschlag noch nicht gefallen ist, aber RDBrecov kann ersteres mit Sicherheit, - solange kein "exotisches" Filesystem benutzt wird. Bei gelingender Wiederherstellung des RDB würde ich zur Sicherheit das ganze mit Check4GB überprüfen, denn ein plötzliches verschwinden des RDB's ist ein typisches Zeichen, das irgendwo eine GB-Grenze vorhanden ist.

mfg Palgucker


[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 12:26 Uhr

thomas
Posts: 7675
Nutzer
Zitat:
Original von Valwit:
Dummerweise kammen mir heuet 2 partitionen abhanden. Kennt jemand ein Tool zum auffinden/wiederhesrstellen? RDBSalv aus dem Aminet scheint gut zu sein, leider ist es Shareware, und total alt. (Mail funzt nicht, Bestellung per Post).


Ich glaube nicht, daß dir RDB-Salv oder RDBrecov helfen kann. Du schreibst nicht, wieviele Partitionen diese Festplatte hat, aber da du von zwei verschwundenen schreibst, gehe ich mal davon aus, daß es noch andere gibt.

RDB-Salv hilft dir nur, wenn *alle* Partitionen einer Festplatte verschwunden sind (sprich, wenn der RDB überschrieben wurde).

In deinem Fall würde ich die beiden defekten Partition erstmal mit DiskSalv bearbeiten (oder mit DiskMonTools, wenn sie oberhalb der 4GB-Grenze liegen).

Vorher, wie schon vorgeschlagen wurde, mal mit Check4GB/CheckHD überprüfen. Das sagt dir auch in der Spalte ">4GB", ob du DiskSalv benutzen kannst, oder lieber nicht.

Wenn die verschwundenen Partitionen nicht in der CheckHD-Liste auftauchen, dann kannst du mit RDB-Salv/RDBRecov arbeiten.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 13:21 Uhr

Valwit
Posts: 750
Nutzer
Zitat:
Ich glaube nicht, daß dir RDB-Salv oder RDBrecov helfen kann.

RDBRecov in diesem Fall nicht, RDBSalv wäre eine Erleichterung gewesen.
Also:
Insgesammt gibt es 14 Partitionen verschiedener Grösse über 40 GB, Irgendwie ging der RDB verloren - auf einmal alle Partitionen weg, Bootlogo am Anfang. Nachdem ich ausgeschlossen habe dass es am Amiga liegt (hatte keine Lust an der Platte zu fummeln wenn es nur ein defektes Kabel wäre) startete ich von meiner Rettungsdiskette (Remapollo, gepatchtes Kick usw, damit man Problemlos an Sachen >4GB kommt), und sah dann, dass eben die Platte leer ist. Zu diesem Zeitpunkt machte ich aber etwas dummes: letztes Jahr ging meine IBM-Platte kaputt und ich bekamm eine Ersatzplatte die um 10 GB grösser war. Deswegen habe ich die Partitionen etwas veändert. Leider habe ich es vergessen und spielte das falsche RDB-Backup zurück. Als ich es bemerkte und das richtige raufspielte, waren die ersten 4 Partitionen weg/kaputt. Die ersten beiden (beides sys: eine normall, zweite nicht gemeuntet, mit dem Mirror von sys:) habe ich sofort wieder gefunden, da ich wusste wo sie anfangen und enden. Die beiden anderen aber nicht. Sie lagen irgenwo zwischen Zylinder 3000 und 8001, denn dieser Bereich war von vorne rein ohne Partitionen (1,5 GB unterhalb von 4GB falls ich mal eine mac/linux/... Partition brauche). RDBSalv hat mir auch die verlorenen 2 gezeigt, nur an Stelle von Anfangs- und Endzylinder stand: <get regitered> :) RDBRecover war eh nicht für sowas vorgesehen (FFS Partitionen, Blockgrösse 4096). Die Lösung, die mir einfiel, war den ganzen Bereich zu mounten und mit DiskSalv zu recovern. Das klappte auch ganz gut, nur am Ende zeigte Disksalv die Daten der 2 Partition, der ersten nicht. Erst mit dem Dilter in DiskSalv konnte ich alles zurückgewinnen (mehrere Durchgänge). Mit RDBalv wäre es eine Sache von 1 Minute :)

PS: ja, ich habe Backups, mache sie jede Woche. Wenn das ganze nicht passiert wären die Backups Nachts angelaufen :) ) Irgendwie passiet sowas IMMER kurz vor dem geplanntem Backup. Vor paar Jahren ging eine Seagate ebenfalls föten, auch kurz vor dem Backup. :D
--
Viele Grüsse
Valwit

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 16:14 Uhr

thomas
Posts: 7675
Nutzer

Zitat:
RDBRecover war eh nicht für sowas vorgesehen (FFS Partitionen, Blockgrösse 4096).

Du verwechselst da etwas. Ich spreche nicht von RDBrecover, sondern von RDBRecov (oder "er"). Das müßte dir alle Partitionen wiederbringen. Es macht im Prinzip das selbe wie RDB-Salv, nur nicht so komfortabel (kein GUI) aber dafür kostenlos und unterstützt auch PFS und SFS.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 18:16 Uhr

Valwit
Posts: 750
Nutzer
Zitat:
Du verwechselst da etwas. Ich spreche nicht von RDBrecover, sondern von RDBRecov (oder "er"). Das müßte dir alle Partitionen wiederbringen.

das meinte ich auch. wurde mir auch im irc empfohlen von leuten die damit gute erfahrungen gemach haben. nur leider hat es bei mir nix angezeigt. wie alle bis auf rdbsalv. ich schätze das lag daran das der rdb mehrfach überschrieben wurde und am ende ein neuer mit 12 der 14 partitionen erstellt wurde. rdbsalv zeiget erst alle partitione die da waren, und dann die sonstigen für die es eintragungen/überreste fand.
--
Viele Grüsse
Valwit

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 19:02 Uhr

thomas
Posts: 7675
Nutzer

Nun, du hast immer zwei Möglichkeiten zu investieren: entweder Geld oder Gehirnschmalz. Mit Geld kannst du RDBSalv kaufen, dann brauchst du nicht nachzudenken, denn es hat deine Partitionen ja schon gefunden. Billiger kommst du weg, wenn du ein bißchen Gehirnschmalz investierst und dir mal die Anleitung von RDBRecov zu Gemüte führst. Es hat jede Menge Optionen und ist garantiert dazu zu bewegen, alle Partitionen zu finden, sogar die, von denen du meinst, sie wären gar nicht mehr da. Im schlimmsten Fall ist der Autor sicher auch bereit, es an deinen Spezialfall anzupassen.

Gruß Thomas


--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 19:35 Uhr

Valwit
Posts: 750
Nutzer
hyhyh :) meinen gehirnschmalz habe ich schon investiert: die daten habe ich wieder, ich habe neue partitionen angelegt, die alten backups von dem ibm-rdb überall gelöscht und durch den aktuellen ersetzt. aber wenn du was an dem programm änderst und jemanden zum testen brauchst helfe ich gerne :)
--
Viele Grüsse
Valwit

[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 19:36 Uhr

Palgucker
Posts: 1341
Nutzer
@ Valvit

quote:
das meinte ich auch. wurde mir auch im irc empfohlen von leuten die damit gute erfahrungen gemach haben. nur leider hat es bei mir nix angezeigt.

Das liegt aber nur daran, das RDBrecov ohne weitere Angabe von Argumenten - ausser Device und Unit - sich die Festplattengeometrie selbst zusammenreimen muss. Kommt es nun zu Unterschieden zwischen den Werten "Cylsectors" seitens RDBrecov und der von der HDToolbox ermittelten - und auch so eingeteilten! - "Blocks per Cylinder", kann RDBrecov nichts finden, da es sozusagen mit der falschen Schrittweite über die gesammte Platte springt und dabei immer die ersten 4 Byte als mögliche DOS-Kennung untersucht.
Du kannst ja mal "spasseshalber" die von der HDToolbox als "Blocks per Cylinder" ermittelten Werte als Wert bei Option CS von RDBrecov eintragen. Dann sollte es bei gleichzeitig passender Cylinderanzahl (Option C) auch bei Dir Ausgaben "hageln".

mfg Palgucker


[ - Antworten - Zitieren - Direktlink - ]

19.09.2004, 20:27 Uhr

thomas
Posts: 7675
Nutzer
@Valwit: wenn du backups hatte1est, warum hast du es dann erst mit RDBSalv & co. versucht ? Das Scannen der kompletten Festplatte dauert Stunden, das ist auf jedenfall länger als das zurückkopieren eines Backups.

Am Programm kann ich nichts ändern, da ich weiß, daß es in der Lage ist, jedwede Partition zu finden. Du mußt mir erstmal sagen, was an deinen so besonders ist, daß sie nicht gefunden werden können.

RDBRecov ist auf Geschwindigkeit optimiert. Weil Partitionen immer auf Cylindergrenzen beginnen, liest es immer nur den Anfang eines Cylinders. Dafür muß man natürlich wissen, wie groß ein Cylinder ist. Und da Cylinder bei heutigen Festplatten nur noch logische Größen sind, können die Angaben durchaus variieren, deshalb muß man dem Program die richtigen Größen mitgeben.

Per Option (DEEPFFS, glaube ich) kann man ihm aber auch sagen, daß es jeden Block einzeln lesen soll, so wie RDB-Salv es macht. Aber das dauert, wie schon gesagt, stundendlang.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

20.09.2004, 00:57 Uhr

Valwit
Posts: 750
Nutzer
> wenn du backups hatte1est, warum hast du es dann erst mit RDBSalv &
> co. versucht ?

weil es die falschen waren bzw alten. 12 von 14 partitionen hatte ich sofort. 2 fehlten. und die beiden galt es zu finden.

> Per Option (DEEPFFS, glaube ich) kann man ihm aber auch sagen, daß es
> jeden Block einzeln lesen soll, so wie RDB-Salv es macht. Aber das
> dauert, wie schon gesagt, stundendlang.

Shit. DeepFFS habe ich nicht versucht. Stunden würde es nicht dauern, es waren nur 1400000 blocks zu scannen. 5000 zylinder mit 280 blocks pro zylinder (laut hdtoolbox)

das proggi ist jetzt auf der notfal diskette, nächstes mal wirds einfacher :)
--
Viele Grüsse
Valwit

[ - Antworten - Zitieren - Direktlink - ]

12.11.2011, 00:10 Uhr

Stephan
Posts: 125
Nutzer
Hallo zusammen!

Altes Thema - gleiches Problem.

Ich brauche mal eure Hilfe, da ich nicht mehr so richtig weiter weiß.


Ich habe eine Festplatte mit 57.2 GB. Diese Platte ist in insgesamt 6 Partitionen unterteilt. Die erste Partition besitzt 3,9 GB, die restlichen 5 Partitionen um die 10 GB.
Nun ist mir die 5. Partition (MDH4) abhandengekommen. D.h. sie erscheint nur noch als "MDH4:Unformatiert".
Auf dieser Partition sind alle meine Bilder abgelegt.

Ich habe bereits viele Tipps aus den verschiedenen Beiträgen versucht:

- Ich habe kein Problem mit der 4GB-Grenze. Geprüft mit Check4GB.
- Ich kann die Daten mit DiskMonTool sehen. Allerdings gibt es zahlreiche Fehlermeldungen beim scannen (Error Code: 45)
- Ich habe auch schon versucht, die Daten auf eine andere Partition (MDH1) mit DiskMonTools zu retten, was teilweise auch geklappt hat. Allerdings ist es sehr Zeitaufwendig.

- Mit RDB-Salv kann ich die Partition MDH4 sehen. Die ermittelten Daten sehen für mich soweit ganz gut aus.
- Mit HD-ToolBox ist die Partition ebenfalls noch sichtbar.


Etwas eigenartiges ist noch geschehen, als ich einen Teil der Daten mit DiskMonTools versucht habe auf eine andere Partition MDH1 zu retten.
Nachdem ich einige Daten bereits gerettet hatte, habe ich diese in eine Schublade verschieben wollen. Nach dieser Aktion war plötzlich auch diese Partition nicht mehr verfügbar, wie die MDH4.
Die Partition MDH1 habe ich dann einfach neu formatiert.

Die Partition MDH4 ist nach wie vor "beschädigt".


Kann mir jemand sagen, wie ich am besten weiter forgehe?
Mir scheint, dass nur der RDB für die Partition MDH4 verschütt ging, kann das sein?
Gibt es für RDB-Salv noch einen key?

Danke für eure Hilfe.
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

12.11.2011, 00:33 Uhr

thomas
Posts: 7675
Nutzer
@Stephan:

Ich würde sagen, du hast doch ein 4GB-Problem. Oder ein SCSI-Problem. Und nein, es liegt nicht am RDB, der ist vollkommen intakt.

Speichere bitte mal die Ausgabe von Check4GB in eine Textdatei und kopiere den Text hier rein mit [ code ] davor und [ /code ] dahinter (ohne die Leerzeichen).

Und beschreibe bitte deine Hard- und Software. Ich bin relativ sicher, dass es sich um eine SCSI-Festplatte handelt (der Fehler 45 ist ein SCSI-Fehler), aber das drumherum ist vollkommen unklar.

Du solltest dich schonmal mit dem Gedanken anfreunden, dass du die Dateien auf eine andere Festplatte retten musst und nicht auf eine andere Partition auf der selben Festplatte. Und dass alle Dateien, die DiskMonTools nicht retten kann, verloren sind. Es sei denn, jemand kennt noch ein anderes Programm, das Dateien von FFS-Partitionen auf Festplatten größer als 4GB retten kann. Der PartitionWizard von OS 4 käme vielleicht in Frage.

Außerdem solltest du mal schauen, ob das SCSI-Kabel und die Terminatoren noch richtig sitzen.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

12.11.2011, 13:56 Uhr

Thore
Posts: 2266
Nutzer
Möglicherweise kann auch WinUAE die Dateien der Platte lesen. Ich bin zwar kein WinUAE-Freund, aber die Einbindung von Amiga-Platten ist ein sehr gutes Feature, es erkennt sogar Byteswap formatierte Platten.
Damit habe ich schon mehrmals Datensicherungen von Amiga-Platten gemacht, die als defekt gegolten haben.

[ - Antworten - Zitieren - Direktlink - ]

12.11.2011, 21:42 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

Hallo Thomas,

mein System ist ein A1200 mit einer BlizzardPPC Karte. In meinem Amiga sind 3 Festplatten.
1 x IDE am internen IDE-Port
1 x SCSI an der BlizzardPPC-Karte
1 x IDE mit einem Adapter als SCSI an der BlizzardPPC-Karte

Die letztgenannte Platte ist die Platte mit den Problemen.

Ein ZIP und ein Scanner befinden sich auch noch am SCSI-Strang. Der Terminator ist im ZIP-Laufwerk.


Wenn ich "check4gb MDH4:" eingebe, wird folgedes ausgespuckt:
10G blizzppc 6 44.24 DOS3 45.13 yes ok


Die gesamte Ausgabe von Check4GB aus der Textdatei ist wie folgt:
code:
Name     Volume       Size Device       Unit Version  DosType  Version   Big Check
EMERGENCY_CD              685M blizzppc        1 44.24    CD01     113.20     no ok
IDH0     Workbench   2186M blizzppc        1 44.24    DOS3     45.13      no ok
IDH1     Spiele      2186M blizzppc        1 44.24    DOS3     45.13     yes ok
IDH2     DTP         2186M blizzppc        1 44.24    DOS3     45.13     yes ok
IDH3     Internet    2184M blizzppc        1 44.24    DOS3     45.13     yes ok
CD0                     2K blizzppc        2 44.24    CD01     40.11      no ok
CD2                   685M blizzppc        2 44.24    CD01     113.20     no ok
CD-RW0                  2K blizzppc        3 44.24    CD01     40.11      no ok
ZIC                    95M blizzppc        5 44.24    MSD0     42.5       no ok
ZIP                    95M blizzppc        5 44.24    DOS3     45.13      no ok
MDH0     OS4.0       4012M blizzppc        6 44.24    DOS3     45.13      no ok
MDH1     Maxtor-01     12G blizzppc        6 44.24    DOS3     45.13     yes ok
MDH2     Programmierung    11G blizzppc        6 44.24    DOS3     45.13     yes ok
MDH3     Downloads     10G blizzppc        6 44.24    DOS3     45.13     yes ok
MDH4                   10G blizzppc        6 44.24    DOS3     45.13     yes ok
MDH5     Musik         10G blizzppc        6 44.24    DOS3     45.13     yes ok
CC0                    20K carddisk        0 40.1     DOS1     45.13      no ok
PC0                   720K mfm             0 41.47    MSD0     42.5       no ok
Datenbank Datenbank    101M scsi            0 119.16   DOS3     45.13      no ok
Grafik   Grafik       169M scsi            0 119.16   DOS3     45.13      no ok
HD0      Workbench-alt   181M scsi            0 119.16   DOS3     45.13      no ok
Sonstiges Sonstiges     55M scsi            0 119.16   DOS3     45.13      no ok
Tabellen Tabellen     150M scsi            0 119.16   DOS3     45.13      no ok
Text     Text         151M scsi            0 119.16   DOS3     45.13      no ok
DF0                   880K trackdisk       0 40.1     DOS0     45.13      no ok



Den Verdacht, dass es am SCSI-Kabel bzw. einem nicht richtig sitzenden Adapter liegen könnte, hatte ich auch schon. Ich habe daher schon mehrmals den Amiga offen und alle Stecker einmal abgezogen und wieder draufgesteckt.


Ich hoffe, ich habe keine Infos vergessen.


Es kam auch schon mal vor, dass die Partitionen dieser Festplatte (MDH) zwar da und sichtbar waren, sich auch öffen ließen und der Inhalt sichtbar war, aber die Platte wurde mit 100% voll angezeigt. Nach einem Neustart war dann meistens alles wieder so wie es sein sollte.

Achso, die Partition "OS4" ist leer. Ich hatte diese Partition mal in der Hoffnung auf ein OS4-Classic mit SCSI-Unterstützung der BlizzardPPC angelegt.

Vielen Dank für die Unterstützung.

Gruß Stephan
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

13.11.2011, 10:42 Uhr

Bluebird
Posts: 3259
Nutzer
Kann es sein das du vor kurzem das FFS durch eine Version dieser Beta Boing Bags upgedatet hast ? oder irre ich mich das 45.13 BB3 > ist ?

mfg Bluebird
--
A1200 Tower, BPPC 060/50-603e/175 256mb, BVision, Z4, ConneXion, DelfinaLite, Oktagon, VarIO, Deneb, RBMKeyInterface, AmigaIIIT, 540mbQuantumFireball, 74gbSamsungSpinPoint, 4gbQuantumFireball,
Yamaha6416S, Mitsumi2801TE, LS120, Siemens17P1, NECP2x

[ - Antworten - Zitieren - Direktlink - ]

13.11.2011, 13:20 Uhr

thomas
Posts: 7675
Nutzer

Nein, 45.13 gehört zu Boingbag2.

Da sind ein paar Ungereimtheiten drin, die aber nichts mit dem Problem zu tun haben:

- EMERGENCY_CD zeigt auf die Festplatte. Das solltest du aus Devs/DosDrivers löschen.
- CD0 und CD2 zweigen beide auf das selbe Laufwerk. Da solltest du auch eins von löschen
- offenbar hast du IDEfix installiert, obwohl du es gar nicht brauchst.


Bezogen auf das Problem sieht die Liste erstmal ok aus. Dann liegt es doch am SCSI-Bus.

D.h. als erstes solltest du die SCSI-Teile in Ordnung bringen, dann kannst du an die Datensicherung gehen. Wie gesagt, zum Retten von FFS-Partitionen auf großen Festplatten kenne ich nichts anders als DiskMonTools.

Vielleicht solltest du mal über PFS3 nachdenken. Das ist ideal für Controller von Phase5. Damit brauchst du dir über 4GB-Probleme keine Gedanken zu machen, egal unter welchem Betriebssystem.

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

14.11.2011, 14:23 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

Hallo Thomas,

IDEfix habe ich mal installiert, da ich Probleme beim Installieren von GoldED von der CD hatte. Der bisherige Treiber unterstützte wohl nicht den Standart auf der CD, so dass das Installerscript nicht alle Daten gefunden hatte. Ich weiß nicht mehr, was es genau war, aber ich glaube es hing mit der Groß- und Kleinschreibung zusammen.

Kann ich PFS3 einfach so auf den Festplatten Installieren? Muss ich dazu in der HDToolBox einfach das Dateisystem aktualisieren?

Woher bekomme ich denn PFS3 überhaupt?


Was meinst Du genau mit "als erstes solltest du die SCSI-Teile in Ordnung bringen"?


Danke für die Unterstützung.
Gruß Stephan
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

14.11.2011, 15:08 Uhr

thomas
Posts: 7675
Nutzer

Solange dein SCSI-Bus Übertragungsfehler produziert (Fehler 45), ist ein Zugriff auf die Festplatte nicht sicher. Da kann alles kaputt gehen oder nichts, das ist nicht vorhersagbar. Du musst also für korrekten Sitz und guten Kontakt aller Teile sorgen sowie für ausreichende Stromversorgung. Spannungsschwankungen können sowas auch hervorrufen.

Alternativ kannst du versuchen, die Festplatte an den IDE-Controller anzuschließen. Ist zwar langsamer aber vielleicht verlässlicher.

PFS3 gibt es jetzt kostenlos im Aminet: http://aminet.net/package/disk/misc/PFS3_53

Nach der Installation findest du die Dokumentation in Tools/PFS3/Doc der Bootpartition.

Um es für eine Partition zu aktivieren, musst du die Dateien der Partition sichern, das Dateisystem in der HDToolbox ändern, den Rechner neu starten, die Partition formarieren und die Dateien zurückspielen.

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

14.11.2011, 22:20 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

Hallo Thomas,

gut, ich werde in den nächsten Tagen mal die Platte an den IDE-Controller anschließen und dann die Daten sichern.

Anschließend werde ich dann das PFS3 installieren. Mal sehen, ob es dann besser ist.

Vielen Dank nochmals. Ich werde mich wieder melden, wenn ich so weit bin.


--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

15.11.2011, 10:19 Uhr

thomas
Posts: 7675
Nutzer

Es wird sicher nicht besser mit PFS3, nur schneller. Solange das Problem in der Hardware liegt, kann die beste Software nichts daran ändern.

Der Geschwindigkeitsunterschied zwischen PFS3 und FFS ist allerdings enorm, ganz besonders, wenn man die Bootpartition umgestellt hat.



--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

23.01.2012, 21:35 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

Hallo Thomas,

es sind jetzt doch einige Wochen vergangen, ehe ich dazu gekommen bin die IDE-Platte an den Standard-IDE-Port des A1200 anzuschließen und die Daten zu sichern. Ich habe mir damit die halbe letzte Nacht um die Ohren gehauen.
Jetzt hatte ich beim Sichern der Daten keine Probleme mehr mit irgendwelchen Lesefehlern oder der Gleichen.

Wie von Dir empfohlen habe ich dann versucht, das Filesystem auf der Platte von FFS auf PFS3 umzustellen. Allerdings habe ich da jetzt ein paar Probleme.

Ich habe in HDToolBox das Dateisystem hinzugefügt. Dann habe ich in einigen Partitionen (nicht alle) das Filesystem umgestellt. Anschließend musste ich den Rechner neu starten und die so eingerichteten Partition formatieren. Alles habe ich mit der HDToolBox durchgeführt.
Bis dahin hat auch soweit alles geklappt.
Allerdings sind die Partition mit PFS3, die über 4GB liegen, nach einem Neustart plötzlich wieder "unlesbar". Die Partitionen mit FFS über 4GB sind dagegen noch vorhanden und können problemlos gelesen werden.

Ich dachte, dass PFS3 kein Problem mit der 4 GB-Grenze hat.

Beim Einrichten gab es ein paar Unstimmigkeiten gegenüber der Beschreibung zu PFS3.

1. Beim dostyp bzw. der Kennung gibt es Unterschiede:
- Beschreibung PFS3: dostyp = 0x50465303 (standard); Version 18.5
- HDToolBox: Kennung: 0x00000000 (standarad)

- Beschreibung PFS3: dostyp = 0x50445303 (pfs3ds); Version 18.5
- HDToolBox: Kennung: 0x43465300 (pfs3ds)
-

2. Soll für eine Paretition das Filesystetm geändert werden, taucht in der Auswahlliste "PFS3" nicht auf, sondern nur 0X0 bzw. andere.

Versuche ich das Einrichten mit dem in PFS3 mitgelieferten Programm HDInstTools tauchen von den vorhandenen Partitionen keine auf. Die Platte scheint keine Partitionierung za haben. Ich müsste alle Partitionen neu anlegen.
Beim dostyp steht dann DOS\1 bei standard und auch DOS\1 bei pfs3ds.

Kannst Du mir da weiterhelfen?
Mache ich was falsch oder habe ich was übersehen?
Habe ich eine falsche Version?

Hat sonst jemand eine Idee?

Hier noch der Ausdruck von Check4GB.log

code:
Name     Volume       Size Device       Unit Version  DosType  Version   Big Check
EMERGENCY_CD              685M blizzppc        1 44.24    CD01     113.20     no ok
IDH0     Workbench   2186M blizzppc        1 44.24    DOS3     45.13      no ok
IDH1     Spiele      2186M blizzppc        1 44.24    DOS3     45.13     yes ok
IDH2     DTP         2186M blizzppc        1 44.24    DOS3     45.13     yes ok
IDH3     Internet    2184M blizzppc        1 44.24    DOS3     45.13     yes ok
CD0                     2K blizzppc        2 44.24    CD01     40.11      no ok
CD2                   685M blizzppc        2 44.24    CD01     113.20     no ok
CD-RW0                  2K blizzppc        3 44.24    CD01     40.11      no ok
ZIC                    95M blizzppc        5 44.24    MSD0     42.5       no ok
ZIP                    95M blizzppc        5 44.24    DOS3     45.13      no ok
CC0                    20K carddisk        0 40.1     DOS1     45.13      no ok
PC0                   720K mfm             0 41.47    MSD0     42.5       no ok
Bilder                 10G scsi            1 119.16   0000     18.5      yes * N T
Datenbank             2101M scsi            1 119.16   0000     18.5      yes * N T
Grafik               5157M scsi            1 119.16   0000     18.5      yes * N T
MDH2     Programmierung    11G scsi            1 119.16   DOS3     45.13     yes ok
MDH3     Downloads     10G scsi            1 119.16   DOS3     45.13     yes ok
MDH5     Musik         10G scsi            1 119.16   DOS3     45.13     yes ok
OS3-9    OS3.9       1909M scsi            1 119.16   0000     18.5       no ok
OS4-1    OS4.1       2102M scsi            1 119.16   0000     18.5       no ok
Sonstiges              912M scsi            1 119.16   0000     18.5      yes * N T
Tabellen             2100M scsi            1 119.16   0000     18.5      yes * N T
Text                 2101M scsi            1 119.16   0000     18.5      yes * N T
DF0                   880K trackdisk       0 40.1     DOS0     45.13      no ok


Vielen Dank schon mal für die Hilfe.
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ Dieser Beitrag wurde von Stephan am 23.01.2012 um 21:56 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.01.2012, 22:19 Uhr

tploetz
Posts: 4026
Nutzer
@Stephan:
da gibt es noch ein anderes pfs, es heisst pfsds, soweit ich mich erinnern kann,
denn bei mir liefen auch Partitionen über 4 GB problemlos.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

23.01.2012, 22:26 Uhr

thomas
Posts: 7675
Nutzer

Der Dostype ist ein Eingabefeld. Den sollst du ändern, nicht nur anschauen.

Bild: http://thomas-rapp.homepage.t-online.de/download/hdtoolbox/de06addupdate.png

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

23.01.2012, 23:31 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

Hallo,

danke für die Antwort.

Doch leider verstehe ich das nicht so ganz.

Wo und wie soll ich den dostyp ändern?

Das Eingabefeld für die Kennung ist bei mir gesperrt.


P.s.: Wie kann ich hier ein Bild einfügen? Dann kan ich Dir das zeigen.



--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ Dieser Beitrag wurde von Stephan am 23.01.2012 um 23:34 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.01.2012, 09:23 Uhr

thomas
Posts: 7675
Nutzer
@Stephan:

Man kann die Kennung nur beim Hinzufügen ändern, d.h. du musst das Dateisystem nochmal löschen und neu hinzufügen.

Außerdem hast du immernoch IDEfix am laufen, das könnte auch ein Problem sein. Startet der Rechner beim Einschalten einmal neu, bevor er hochfährt (d.h. ist das ROM-Update aktiv)?

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > RDBSalv [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.