amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Mediator ? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

09.12.2004, 19:45 Uhr

Tim68
Posts: 82
Nutzer
Hallo,
hab auf Bilder ein Mediator-Board für den Amiga 4000
gesehen und ein paar Fragen dazu:

Muß das Board extra mit Strom versorgt werden, auf dem Bild war
ein Connector zu sehen, könnte eine Stromanschlußleiste (Sieht
zumindest so aus)(Farbe Weiß, mit 6 Kontakten) gewesen sein ?

Müssen extra Treiber für das Board installiert werden, oder
bindet es sich alleine nach dem Start in das System ein ?
Muß es vielleicht im Early Starup-Menü angemeldet werden ?

Ab wann liefert denn eine eingebaute Voodoo-Grafikkarte ein Bild ?
(Erst nachdem die WB geladen wurde ?)
Ab welcher WB-Version funktioniert die Mediator/Voodoo erst ?

Würde die Mediator im Micronik Big Tower mit A4000D-Board
reinpassen ?

Hat jemand Erfahrung ob das Teil zuverlässig arbeitet ?
Funktionieren die für Amiga erhältlichen tatsächlich?
(z.B. Voodoo, Sounblaster, Realtek, TV-Kate, USB 2.0)

Gruß Tim

[ - Antworten - Zitieren - Direktlink - ]

09.12.2004, 20:10 Uhr

Gururom
Posts: 267
Nutzer
Ja ich habe das Mediatorboard in meinem A4k Mikronik BigTower und bin super zufrieden.

zu den meisten Fragen erhälst du antwort auf meiner HP http://www.skolbe.de

Mit der Voodoo verhält es sich zBsp: wie mit allen Grakas im Amiga , sie werden erst durch die entsprechende Software eingebunden und sind also ab Start noch nicht nutzbar.

Ich bastle und versuche jedoch gerade seid einer Weile diese Problem durch mein Flashrom im Highway Controller zu umgehen, soll heißen ich will die Grakasoft bzw die Teile die nötig sind dort reinbringen.

Klappt aber noch nicht so.......
naja wenns dann geht geb ich bescheit, daß wäre ja glaub ich die Sinnvollste Sache wofür so ein Flashrom gut ist, seis Kickflasch, Romulus oder wie sie alle heißen. Volle Grakafähigkeit gleich ab kaltstart.


cu Guru

[ - Antworten - Zitieren - Direktlink - ]

09.12.2004, 20:31 Uhr

Maniac
Posts: 82
Nutzer
Hi Tim68,

also ich so'n Mediator4000 Voodoo3, Soundblaster, Netzwerk und USB2.0 laufen. USB aber leider nicht gleichzeitig mit Warp3d. Meine TV-Karte hab ich noch nich ausprobiert hab aber eine am Mediator1200 laufen sehen (geht also).

Mit dem Tower könntest du Probleme mit dem befestigen des Boards (ich weiß nicht ob die Bohrungen passen) und den Ausgängen auf der Rückseite bekommen hab ich aber nicht probiert.

MfG Maniac

[ - Antworten - Zitieren - Direktlink - ]

09.12.2004, 20:47 Uhr

DJBase
Posts: 3354
[Ex-Mitglied]
Ich hatte einmal ein Mediator4000 gehabt mit TV-Karte, Voodoo, Soundblaster und Netzwerkkarte. Lief soweit alles zufriedenstellend. Als Tower hatte ich jedoch einen E/Box gehabt.




--
Meine Internet-Projekte :: Meine Amiga-Seite :: Meine Pegasos-Seite

[ - Antworten - Zitieren - Direktlink - ]

10.12.2004, 09:42 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Mit der Voodoo verhält es sich zBsp: wie mit allen Grakas im Amiga , sie werden erst durch die entsprechende Software eingebunden und sind also ab Start noch nicht nutzbar.

Nja. Nicht ganz richtig: das Mediator im 4000er wird als Zorro III Karte eingebunden, und zwar vor aller "Software" durch das Kickstart.
Nur die Karten, die drauf sind, sind nicht nutzbar zu diesem Zeitpunkt, da die pci.library noch nicht aktiv ist (mangels FlashROM auf dem Mediator).

Die PIV zum Beispiel kannst du zumindest schon mal als Flickerfixer benutzen, was ich als sehr angenehm empfinde :)

Zitat:
Ich bastle und versuche jedoch gerade seid einer Weile diese Problem durch mein Flashrom im Highway Controller zu umgehen, soll heißen ich will die Grakasoft bzw die Teile die nötig sind dort reinbringen.

Dazu muss die PCI-Software natürlich auch entsprechend programmiert worden sein - und da die Treiber von Elbox auf Umgebungsvariablen zugreifen, dürfte das im jetzigen Zustand nicht möglich sein.
Vielleicht gibts ja von Elbox in Zukunft mal ein Update, das diesen Zustand ändert.

Mit dem Grafiktreiber alleine ist es nicht getan, davor müssen die PCI-Karten auch erst mal durch ihre "Autoconfig"-Phase durch und aktiviert werden.

Michael

[ - Antworten - Zitieren - Direktlink - ]

10.12.2004, 13:21 Uhr

Mika
Posts: 445
Nutzer
Hallo Tim68,

man sollte das Board schon extra mi Strom versorgen, durch eine Zufall hatte ich mal vergessen den Stecker für den Stromanschluss drauf zu stecken und das Board lief ohne Probleme.

Zu den technischen Sachen kann ich nicht viel sagen da haben mir drei User vom U.d.N. geholfen, einen Text kannst du unter folgenden Link finden:

http://www.udnimweb.de (Aktivitäten > News des Jahres 2003 > Januar)


Zu Zuverlässigkeit kann ich nur sagen einfach Super !!

Seit ein paar Tagen nutze ich ein neues Program mit dem man durch einfaches Umschalten Radio oder TV hören bzw. sehen kann.

Mit freundlichen Grüssen

Mika

http://www.udnimweb.de




:bounce: :bounce: :bounce: :bounce: :bounce: :bounce: :bounce: :bounce:
--
Amiga One G4
Amiga 4000/PPC & MediatorBoard
Amiga 4000/060 & Picasso IV
Amiga 500

[ Dieser Beitrag wurde von Mika am 10.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.12.2004, 18:11 Uhr

Tim68
Posts: 82
Nutzer
Hallo,
thx für die Statements, wie ich den Threads entnehme hört sich
ja alles ganz gut an.

Bei folgenden Punkten muß ich nochmal nachfragen:

Brauch das Mediator-Board eine eigene Stromversorgung?
Einen 6-poligen Stromanschlussstecker (ist das ein P9) ist im Micronik-Tower nicht zu finden ? Im original Elbox-Tower wird er ja vorhanden sein.
Gibt es vielleicht einen passenden Adapter aus dem PC-Tower-Bereich ?
Würde das Amiga-Netzteil (hier Micronik)alle benötigten Spannungen liefern ?

Wenn man das Early Startup-Menü aufruft, erhält man ja bei einem Zorro 2/3-Daugtherboard einen Überblick über die eingesteckten Zorro-Karten und Ihren aktuellen Status.
Expansion Board diagnostic: "Status Working"

mboehmer wrote:
"Das Mediator im 4000er wird als Zorro III Karte eingebunden, und zwar vor aller "Software" durch das Kickstart.Nur die Karten, die drauf sind, sind nicht nutzbar zu diesem Zeitpunkt, da die pci.library noch nicht aktiv ist (mangels FlashROM auf dem Mediator)."

Heißt das also, das beim Mediator die PCI-Karten im Early Startup-Menü noch nicht mit Ihrem Status aufgeführt sind?

Gruß Tim

[ - Antworten - Zitieren - Direktlink - ]

10.12.2004, 19:13 Uhr

mboehmer
Posts: 350
Nutzer
[Quote]
Heißt das also, das beim Mediator die PCI-Karten im Early Startup-Menü noch nicht mit Ihrem Status aufgeführt sind?
[/quote]

Richtig. Die PCI-Karten werden auch niemals dort auftauchen.
Das Kickstart macht Autoconfig im Zorro II / Zorro III Adressraum (i.e. auf 0xe80000 bzw. 0xff000000). Damit hat jede Zorro-Karte eine eigene Basisadresse und ist im System ansprechbar.
Jede weitere Funktionalität muss von der jeweiligen Zorro-Karte zur Verfügung gestellt werden - das geht dann über ein Boot- oder Diagnostic-ROM.

Dazu muss eine Zorro-Karte dem Kickstart mitteilen, dass a) ein solcher Programmspeicher auf der Karte ist und b) wo genau er liegt.
Nach Abschluß der Autokonfiguration (in derem Verlauf sich das Kickstart die ROMs merkt) werden die einzelnen ROMs hintereinander in das RAM kopiert und dort ausgeführt. Diese Boot-ROMs (oder im Falle der ALGOR (PRO) / ROMulus das FlashROM) muss dann den Rest erledigen.

Damit du also einen Mediator vom Kaltstart ab nutzen kannst, musst du alle dafür benötigten Programmteile bereits nach der Autokonfiguration (und das heisst: ein Grossteil der Systemfunktionen, auf denen die meisten Treiber aufsetzen fehlt noch, da kein Betriebssystem läuft) am Laufen haben.

Dies geht nur mit speziell dafür angepasster Software (z.B. der PsdStackLoader von Poseidon), da z.B. noch keine Umgebungsvariablen existieren oder Konfigfiles geladen werden können.

Das Einbinden der BootROMs ist auch so flexibel, dass du beispielsweise den Amiga nach einem Kaltstart von einem USB-Flashstick booten kannst oder durchs Einbinden der entsprechenden Software von einer am IDE-Port der Xsurf angeschlossenen Platte booten kannst; d.h. das BootROM einer Karte kann auch Ressourcen von anderen Karten nutzen.

Aber: das geht nur, wenn die Treibersoftware der jeweiligen Karte das mitmacht. Und dafür musst du dich am besten mit dem Hersteller des Mediator in Verbindung setzen.

[ - Antworten - Zitieren - Direktlink - ]

11.12.2004, 14:05 Uhr

Tim68
Posts: 82
Nutzer
Hallo,
mboehmer hat die Problematik mit den Pci-Karten ja super und
erschöpfend erklärt.

Bei der Stromversorgung ist immer noch unklar,ob sie jetzt benötigt wird oder nicht.

Gururom hat auf seiner Homepage einen ausgezeichneten, ausführlichen Bericht dazu abgefasst (sollte man erst alles lesen bevor man wieder postet).
Einen 6-poligen P9 Anschluß ist im Micronik-Tower ja nicht zu finden, Gururom hat ja schon darauf hingewiesen, das das größte Problem der Anschluß -5V ist. Wenn ich es richtig verstanden
habe, ist dieser bei den meisten Amiga-Netzteilen nicht vorhanden.

Hat jemand schon vor den gleichen Problem gestanden ?
Bleibt nur der Austausch des original Micronik-Netzteils gegen ein AT/ATX PC-Netzteils, so wie von Gururom beschrieben?
Ach so, ist ein vorhandener P9-Anschlußstecker vom PC-Netzteil
100% genau so beschaltet wie für das MediatorBoard notwendig
(also gleich dem Elbox-Netzteil)?
Oder gibt es P9-Stecker oder komplette Anschlussadapter im Zubehöhr und kann man sich die -5V Versorgung aus einem geöffneten Micronik-Netzteil abgreifen ?

Mika wrote:
"man sollte das Board schon extra mit Strom versorgen, durch eine Zufall hatte ich mal vergessen den Stecker für den Stromanschluss drauf zu stecken und das Board lief ohne Probleme."
Also müsste es auch ohne Stromversorgung gehen oder laufen dann vielleicht nur die
Zorro-Karten ?

Gruß Tim

[ Dieser Beitrag wurde von Tim68 am 11.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.12.2004, 16:49 Uhr

Gururom
Posts: 267
Nutzer
Habs gerade getestet, mein Rechner bootet nicht ohne Strom am Mediator
Tiefer hab ich es nicht ergründet, da kein FliFi oder so da und ich auf eine Voodoo umlenke.

cu Guru.

PS Ein PC Netzteil einzubauen(passt einwandfrei) und diese zu modifizieren, kann ich nur jeden Emfehlen, ist schon beruigent immer genug Saft auf der Pfanne zu haben.

Und wenn man sich eine MediatorAnlage mit allem Drum und drann zu legt, kommts auf die 20,- EUR fürs ATX auch nicht mehr an.


[ - Antworten - Zitieren - Direktlink - ]

12.12.2004, 15:12 Uhr

Tim68
Posts: 82
Nutzer
@GURU THx für die Mühe

Guru wrote:
"Und wenn man sich eine MediatorAnlage mit allem Drum und drann zu legt, kommts auf die 20,- EUR fürs ATX auch nicht mehr an."

eigentlich nicht :)

Guru wrote auf Homepage:
"die Reihen folge ist noch zu beachten, da der Stecker nicht unbedingt Verpolungssicher ist!!!
Also am Zorroboard befindet sich die Buchse im eingebauten Zustand oben links:
das heisst von links nach rechts ----->
GND....GND.....-5V......+5V......+5V"

ich nehme an es fehlt noch ein......+5V ?

Um noch einmal zu vergewissern:
Das erste GND befindet sich also an der Seite wo die oberste
Slotabdeckung des Towers ist und der 6 und letzte Kontakt ist ein
+5V und zeigt zur Vorderseite Richtung Prozessorkarte ?

Wäre denn ein AT/ATX PC-Netzteil mit P9 Anschluß 100% genau so beschaltet wie für das MediatorBoard notwendig ?

Gruß Tim



[ - Antworten - Zitieren - Direktlink - ]

12.12.2004, 20:24 Uhr

Gururom
Posts: 267
Nutzer
Zitat:
Original von Tim68:
@GURU THx für die Mühe


Guru wrote auf Homepage:
"die Reihen folge ist noch zu beachten, da der Stecker nicht unbedingt Verpolungssicher ist!!!
Also am Zorroboard befindet sich die Buchse im eingebauten Zustand oben links:
das heisst von links nach rechts ----->
GND....GND.....-5V......+5V......+5V"

ich nehme an es fehlt noch ein......+5V ?


nein, +5 Volt hast du doch am Amiganetzteil, was fehlt ist die -5 Volt Spannung
Zitat:
Um noch einmal zu vergewissern:
Das erste GND befindet sich also an der Seite wo die oberste
Slotabdeckung des Towers ist und der 6 und letzte Kontakt ist ein
+5V und zeigt zur Vorderseite Richtung Prozessorkarte ?

Wäre denn ein AT/ATX PC-Netzteil mit P9 Anschluß 100% genau so beschaltet wie für das MediatorBoard notwendig ?

Gruß Tim


Vom Prinzip genau !!!!!
Nur mittlerweile haben kaum noch ATX Netzteile die P8/P9 Stecker also ist selberbauen angesagt, ist aber einfach und auch für den Laien kein Problem, da mittlerweile alles farblich genormt ist.


cu Guru


[ - Antworten - Zitieren - Direktlink - ]

12.12.2004, 20:55 Uhr

Tim68
Posts: 82
Nutzer
GND....GND.....-5V......+5V......+5V"

ich nehme an es fehlt noch ein......+5V ?

---------------------------------------------------------------------

"Guru wrote;
nein, +5 Volt hast du doch am Amiganetzteil, was fehlt ist die -5 Volt Spannung"

Hi,
meinte eigentlich, da es ja 6 Kontakte sind:
GND....GND.....-5V......+5V......+5V......+5V

ansonsten werde ich mich demnächst mit dem Netzteil beginnen :) !

Gruß Tim

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Mediator ? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.