amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > Ghostscript Einstellungen [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

22.12.2004, 12:14 Uhr

Eule
Posts: 1607
Nutzer
Erst mal vorweg, ich kann mit Finalwrtiter oder Grafik Publisher drucken. Aber ich komme mit Ghostscript nicht klar.


Als Testprogramm hab ich APDF verwendet aber ein paar Einstellungen scheinen wirklich verkehrt zu sein, da das Ganze ziemlich wiedersprüchlich ist bräuchte ich dringend Rat.

Hier die Einstellungen von APDF und Turboprint/Ambient:
code:
### Einstellungen in Ambient:

Settings->System Settings->Printer->ps

Command Line:= Gostscript:GS -sDevice=turboprint -q
Temp Dir:= Turboprint:Temp

### Tests

Ram Disk:> list Turboprint:temp
Directory "Turboprint:temp" is empty

### Einstellungen in Apdf

Global Settings->

Print device:= ps:

### Aufzeichnung von Snoopdos

Count Process Name       Action     Target Name                 Options Res.
----- ------------       ------     -----------                 ------- ----
1     Apdf               LockScreen Workbench                           OK  
2     Apdf               LockScreen Workbench                           OK  
3     PDF decoder        Open       ps:                         Write   Fail
4     Devs:NetParSpool   Open       ENV:NetPar/SpoolDir         Read    OK


Was kann ich tun damit z.B. APDF Ghostscript drucken kann

MfG Eule

[ Dieser Beitrag wurde von Eule am 22.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.12.2004, 01:14 Uhr

Eule
Posts: 1607
Nutzer
Also die Beteiligung ist ja etwas dürftig.

Vielleicht sollte ich erst mal 4 einfache Fragen stellen:

[ ] Bei mir funktioniert das Drucken unter MOS (Final Writer/Yam)
[ ] Bei mir funktioniert das Drucken von PDFs aus APDF.
[ ] Ich habe einen Postscript Drucker
[ ] Ich habe keinen Ghostscript Drucker.



[ Dieser Beitrag wurde von Eule am 23.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.12.2004, 01:16 Uhr

Eule
Posts: 1607
Nutzer
Und als Beispiel wie man es beantworten kann:
so sieht die Antwort aus wenn sie von mir kommt

[X] Bei mir funktioniert das Drucken unter MOS (Final Writer/Yam)
[ ] Bei mir funktioniert das Drucken von PDFs aus APDF.
[ ] Ich habe einen Postscript Drucker
[X] Ich habe keinen Ghostscript Drucker.







[ - Antworten - Zitieren - Direktlink - ]

23.12.2004, 01:17 Uhr

Eule
Posts: 1607
Nutzer
MfG Eule und danke
an jeden der teilnimmt.

[ Dieser Beitrag wurde von Eule am 23.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.12.2004, 08:22 Uhr

Yvan
Posts: 294
Nutzer
Hm, weiss zwar nicht was es Dir bringt, aber okay:

[ ] Bei mir funktioniert das Drucken unter MOS (Final Writer/Yam)
[ ] Bei mir funktioniert das Drucken von PDFs aus APDF.
[ ] Ich habe einen Postscript Drucker
[ ] Ich habe keinen Ghostscript Drucker.

Es sind bewusst keine Kreuze drin weil nichts zutrifft.

[ - Antworten - Zitieren - Direktlink - ]

23.12.2004, 09:11 Uhr

roschmyr
Posts: 30
Nutzer
Hallo Eule

[x] Bei mir funktioniert das Drucken unter MOS (Final Writer/Yam)
[x] Bei mir funktioniert das Drucken von PDFs aus APDF.

die Version von Ghostscript die Turboprint beilag, hat bei mir
immer gestreikt.

ich benutze Ghostscript 8.13
http://www.whoosh777.pwp.blueyonder.co.uk/index.html


ansonsten schau mal ins pegasosforum und such nach Ghostscript :-)

[ - Antworten - Zitieren - Direktlink - ]

24.12.2004, 00:20 Uhr

Eule
Posts: 1607
Nutzer
Zitat:
Original von roschmyr:


ich benutze Ghostscript 8.13
http://www.whoosh777.pwp.blueyonder.co.uk/index.html




ansonsten schau mal ins pegasosforum und such nach Ghostscript :-)



Hmm ich hab es mir durchgelesen und noch mal durcgelesen und dann hab ich es versucht obwohl ich mir dachte dass noch was fehlt in der Anleitung.

Irgendwie klappt das mounten von PS: nicht.

Die Stelle die ich nicht verstanden habe war hier:

Zitat:
2. The mountlist: recycle the GS510 DEVS: mount file, to DEVS: not sure what the mountlist is called,

Also folgende Mounts existieren:
code:
Ghostscript    System:MorphOS/TP/GS813/bin
GS813Resource  System:MorphOS/TP/GS813/Resource
GS813Fonts     System:MorphOS/TP/GS813/fonts
GS813Data      System:MorphOS/TP/GS813/lib
....
GS813          System:MorphOS/TP/GS813
....


und mit diesem Aufruf gs813:bin/gs -sDEVICE=jpeg -dJPEGQ=100 -dNOPAUSE -dBATCH -sOutputFile=ram:annots%d.jpeg gs813:examples/annots.pdf konnte ich ein PDF in JPGs umfandeln.


Aber nur diese Devices werden gefunden:
Zitat:
Devices:
TCP USB_SM AUDIO NULL PAR
PIPE PRT SER RAM SYSRAW
SYSCON CON RAW CD1 CD0
DH3 DH2 DH1 DH0


unter DEVS: habe ich ein einen Eintrag ps
zum mounten des Gerätes ps:

folgendes ist drinnen:

code:
/* Ghostscript printing handler mount entry */

Handler         = Ghostscript:L/gs-handler
StackSize       = 15000
Priority        = 5
GlobVec = -1


Aber gerade dann wen ich versuche das Gerät zu mounten passiert einfach nichts.

Also ich hab den Eindruck das geht nicht, hast du irgeneinen Tipp?


Danke für die Tipps
MfG Eule

[ Dieser Beitrag wurde von Eule am 24.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.12.2004, 13:08 Uhr

pagasossigi
Posts: 71
Nutzer
Eule:

Sieh dir auf der GS-Hompage: http://www.whoosh777.pwp.blueyonder.co.uk/

Den Bereich "Setting UP PS:FOR TURBOPRINT USE" an.
Dort gibt es Zwei weitere Links. Der erste führt nach Iree-Soft, wo du in deren Ghostscript-
Version den Handler für PS: findest.
Der Zweite link ist ein nennt sich "TP_PS_files.lha". In diesem Archiv befinden sich:
gs-handler,PS und PS.info. PS und PS.info sind die Mountlisten, und kommen dach DEVS:Dosdrivers.
Der gs-handler kommt nach L:.

Das ganze steht aber in diesem Teil des Textes auch beschrieben, wo was hin muß.


Die Zeile in den Turboprintsettings von Ambient muß volgendermaßen aussehen:

gs813:bin/gs -sDEVICE=tp24 -dBatch -dNOPAUSE -dBitsPerPixel=24 -dColor=24 -dDensity=3 -dBufferSpace=1024000

Diese Zeile funktioniert bei mir.

[ - Antworten - Zitieren - Direktlink - ]

26.12.2004, 23:31 Uhr

Eule
Posts: 1607
Nutzer
Zitat:
Original von pagasossigi:
Eule:



gs813:bin/gs -sDEVICE=tp24 -dBatch -dNOPAUSE -dBitsPerPixel=24 -dColor=24 -dDensity=3 -dBufferSpace=1024000

Diese Zeile funktioniert bei mir.


Eigentlich hatte ich alles so gemacht wie es in der Anleitung stand aber mit Deiner Zeile unter den Printer Prefs funktioniert es endlich.

der gs-handler braucht übrigends nicht noch mal unter L: oder Mossys:L/ kopiert zu werden. Es genügt wenn man ihn unter Ghostscript:l hat.

Aber vielen dank noch, endlich druckt APDF. Jetzt müsst ich nur rauskriegen warum IBrowse immer vergeblich nach einem gsspool.device sucht und dann

Error while opening PostScript Font

ausgibt.

[ - Antworten - Zitieren - Direktlink - ]

26.12.2004, 23:57 Uhr

Schlonz
Posts: 51
Nutzer
Hi,

wie roschmyr ja schon andeutete, wurde im Pegasosforum schon recht detailliert auf dieses Thema eingegangen.

Dort wurde auch herausgestellt, dass das ganze Problem mit dem Drucken mittels Ghostscript an der Kommandozeilen-Option "-dDensity" hängt.

Alternativ kannst Du übrigens diese Option weglassen und bequem die Option "Density" auf der Printer-Pref-Page der System Settings auf irgendwas anderes als "as in Config" stellen. Ist dann etwas einfacher, falls Du mal in einer anderen Auflösung drucken willst.
--
Schlonz

[ - Antworten - Zitieren - Direktlink - ]

27.12.2004, 01:54 Uhr

pagasossigi
Posts: 71
Nutzer
Zitat:
Original von Eule:
Zitat:
Original von pagasossigi:
Eule:



gs813:bin/gs -sDEVICE=tp24 -dBatch -dNOPAUSE -dBitsPerPixel=24 -dColor=24 -dDensity=3 -dBufferSpace=1024000

Diese Zeile funktioniert bei mir.


Eigentlich hatte ich alles so gemacht wie es in der Anleitung stand aber mit Deiner Zeile unter den Printer Prefs funktioniert es endlich.

der gs-handler braucht übrigends nicht noch mal unter L: oder Mossys:L/ kopiert zu werden. Es genügt wenn man ihn unter Ghostscript:l hat.

Aber vielen dank noch, endlich druckt APDF. Jetzt müsst ich nur rauskriegen warum IBrowse immer vergeblich nach einem gsspool.device sucht und dann

Error while opening PostScript Font

ausgibt.


Ibrowse benötigt zum PS-Drucken seine eigenen PS-Fonts.
Die Seite mit der Beschreibung, damit man unter Ibrowse drucken kann, gibt es hier

http://www.google.de/url?sa=U&start=1&q=http://www.amiga-club.de/faq/IB2_druck.html&e=7629





[ Dieser Beitrag wurde von pagasossigi am 27.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

27.12.2004, 16:50 Uhr

pagasossigi
Posts: 71
Nutzer
Zitat:
Original von Eule:
Zitat:
Original von pagasossigi:
Eule:



gs813:bin/gs -sDEVICE=tp24 -dBatch -dNOPAUSE -dBitsPerPixel=24 -dColor=24 -dDensity=3 -dBufferSpace=1024000

Diese Zeile funktioniert bei mir.


Eigentlich hatte ich alles so gemacht wie es in der Anleitung stand aber mit Deiner Zeile unter den Printer Prefs funktioniert es endlich.

der gs-handler braucht übrigends nicht noch mal unter L: oder Mossys:L/ kopiert zu werden. Es genügt wenn man ihn unter Ghostscript:l hat.

Aber vielen dank noch, endlich druckt APDF. Jetzt müsst ich nur rauskriegen warum IBrowse immer vergeblich nach einem gsspool.device sucht und dann

Error while opening PostScript Font

ausgibt.


Übrigens: Hier ist der aktuelle Link mit den Ibrowse-PS-Schriften:

http://ccp14.minerals.csiro.au/ccp/ccp14/CCP14-by-OS/sun/motplot-sunos4.1.3/afm/


[ - Antworten - Zitieren - Direktlink - ]

27.12.2004, 19:49 Uhr

DarkAngel
Posts: 393
Nutzer
Das ominöse gsspool.device existiert nur, wenn du auch Turbospool aktiviert hast.
Wie schon gesagt, Ibrowse braucht eigene Fonts und macht auch die Postscriptausgabe allein (ohne Ghostscript, das brauchst du nur zum Drucken).

[ - Antworten - Zitieren - Direktlink - ]

28.12.2004, 02:28 Uhr

Eule
Posts: 1607
Nutzer
Zitat:
Original von pagasossigi:


Übrigens: Hier ist der aktuelle Link mit den Ibrowse-PS-Schriften:

http://ccp14.minerals.csiro.au/ccp/ccp14/CCP14-by-OS/sun/motplot-sunos4.1.3/afm/



Danke hmm hab ich jetzt auch veersucht, wird wohl nicht funktionmieren, weil ich Problemem mit den Ibrowse Prefs hab.

http://www.amiga-news.de/forum/thread.php3?id=14228&BoardID=15

[ - Antworten - Zitieren - Direktlink - ]

28.12.2004, 20:47 Uhr

Eule
Posts: 1607
Nutzer
Ich hab mir gedacht ich könnte doch gleich einen Scipt machen der mit httpget alle benötigten Dateien aus dem Netz holt alle Direktories einrichtet und den ganzen Kram einfach installiert.

Leider aber funktioniert httpget nicht so wie ich mir das vorgestellt habe. Deshalb wird es nichts aus diesem Script.

Aber vielleicht hat ja jemand ne Idee (es fehlen nur HTTPGet und noch ein paar Korrekturen beim Filehandler)

code:
makedir Mossys:TP/GS813
assign gs813: Mossys:tp/gs813

echo "Load all Ghostscript files from the Internet using wget"
wget http://www.whoosh777.pwp.blueyonder.co.uk/gs813release020nofpu.lha
 
wget http://www.whoosh777.pwp.blueyonder.co.uk/gs813fonts.lha
 
wget http://www.whoosh777.pwp.blueyonder.co.uk/gs813resource.lha
 
wget http://www.whoosh777.pwp.blueyonder.co.uk/gs813examples.lha
 
wget http://www.whoosh777.pwp.blueyonder.co.uk/gs813lib.lha
 
wget http://www.whoosh777.pwp.blueyonder.co.uk/gs813doc.lha
 

echo "Decrunching all Ghostscript Files"
lha -radex x gs813release020nofpu.lha GS813:
lha -radex x gs813fonts.lha GS813:
lha -radex x gs813resource.lha GS813:
lha -radex x gs813examples.lha GS813:
lha -radex x gs813lib.lha GS813:
lha -radex x gs813doc.lha GS813:

echo "Make the Turboprint GS: File"
makedir gs813:bin
wget http://www.irseesoft.de/ghostscript/gs_020.lha
 
assign Ghostscript: gs813:bin
lha -radex x gs_020.lha  Ghostscript:

echo "Get the TP_PS Handler"
wget http://www.whoosh777.pwp.blueyonder.co.uk/TP_PS_files.lha
 
makedir Ghostscript:L
lha x TP_PS_files.lha
copy TP_PS_files/gs-handler Ghostscript:L
copy TP_PS_files/ps#? DEVS:dosdrivers
echo "Handler   = ghostscript:l/gs-handler" > DEVS:dosdrivers/ps
echo "StackSize = 15000" >> DEVS:dosdrivers/ps
echo "Priority  = 5" >> DEVS:dosdrivers/ps
echo "GlobVec   = -1" >> DEVS:dosdrivers/ps


;
; Einfügen der Assigns in die user-startup
;
echo "Put all the assign into s:user-startup"
copy s:user-startup >> s:user-startup.old
echo ";Begin Ghostscript GS813" >> s:user-startup 
echo assign GS813: Mossys:TP/GS813 >> s:user-startup
echo assign GS813Data: GS813:lib >> s:user-startup
echo assign GS813Fonts: GS813:fonts >> s:user-startup
echo assign GS813Resource: GS813:Resource >> s:user-startup
echo assign Ghostscript: GS813:bin >> s:user-startup
echo ";End Ghostscript" >> s:user-startup


[ Dieser Beitrag wurde von Eule am 31.12.2004 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > Ghostscript Einstellungen [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.