amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Booten vom USB memorystick ? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

20.01.2005, 20:34 Uhr

Indy
Posts: 538
Nutzer
Guten Abend...

Kann man eigentlich von einem - via ALGORPro und Poseidon ans System (A4000D, OS 3.9 BB2) angeschlossenen - USB Memorystick booten ?
Hat das vielleicht schon jemand gemacht ?


Gruß, Indy

[ - Antworten - Zitieren - Direktlink - ]

20.01.2005, 20:41 Uhr

Gururom
Posts: 267
Nutzer
Kann man !!!
Lies dir mal dazu die Anleitung zum Algor und zur Soft Luciferin genau durch da stehts beschrieben wie.
Obwohl ichs auch noch nicht hinbekommen habe mit meiner Highway und Romulus in meinen A4k Tower .
LKiegt aber wahrscheinlich an den PCI Gesimse ala Mediator usw.

Bin ja ab und an am basteln ob man nicht gleich ab Strat die Voodookarte einbinden kann, statt immer nur den ollen PAL Screen


cu Guru

[ - Antworten - Zitieren - Direktlink - ]

20.01.2005, 20:47 Uhr

analogkid
Posts: 2392
Nutzer
das ist mit FAT95 etwas tricky, es geht aber. Mit FFS bzw. SFS formatiert ohne Probleme.
--
Join us @ Sarkasmus-pur

:amiga: :dance1:

Talking about music is like dancing about architecture

[ - Antworten - Zitieren - Direktlink - ]

20.01.2005, 21:31 Uhr

Indy
Posts: 538
Nutzer
Zitat:
Original von analogkid:
das ist mit FAT95 etwas tricky, es geht aber. Mit FFS bzw. SFS formatiert ohne Probleme.


Aha, es würde also sogar mit dem fat95 gehen ? Interessant !!

Da habe ich gleich noch einen Frage dazu:

Einstweilen läuft der USB Stick problemlos (original ab Werk formatiert) mit fat95.

Um diesen mit FFS zu formatieren, müßte man doch eigentlich die HDToolBox (v45.6, OS3.9 BB2) verwenden können.
Wenn ich dort das usbscsi.device anwähle, zeigt mir die HDToolBox aber nur ein leeres Fenster, sodaß ich dort gar nichts zum Formatieren auswählen vorfinde.

Hab ich da noch was übersehen/vergessen ?


Gruß, Indy

[ - Antworten - Zitieren - Direktlink - ]

20.01.2005, 21:32 Uhr

Indy
Posts: 538
Nutzer
Zitat:
Original von Indy:
Zitat:
Original von analogkid:
das ist mit FAT95 etwas tricky, es geht aber. Mit FFS bzw. SFS formatiert ohne Probleme.


Aha, es würde also sogar mit dem fat95 gehen ? Interessant !!

Da habe ich gleich noch eine Frage dazu:

Einstweilen läuft der USB Stick problemlos (original ab Werk formatiert) mit fat95.

Um diesen mit FFS zu formatieren, müßte man doch eigentlich die HDToolBox (v45.6, OS3.9 BB2) verwenden können.
Wenn ich dort das usbscsi.device anwähle, zeigt mir die HDToolBox aber nur ein leeres Fenster, sodaß ich dort gar nichts zum Formatieren auswählen vorfinde.

Hab ich da noch was übersehen/vergessen ?


Gruß, Indy




[ - Antworten - Zitieren - Direktlink - ]

21.01.2005, 08:29 Uhr

thomas
Posts: 7678
Nutzer

Vermutlich identifiziert sich der Stick nicht. Geh mal in Trident und schau, ob Fehlermeldungen auftreten. Ändere die Optionen so, daß keine Fehler mehr kommen. Vermutlich mußt du "Fake SCSI Inquiry" einschalten.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

21.01.2005, 12:46 Uhr

Indy
Posts: 538
Nutzer
Zitat:
Original von thomas:

Vermutlich identifiziert sich der Stick nicht. Geh mal in Trident und schau, ob Fehlermeldungen auftreten. Ändere die Optionen so, daß keine Fehler mehr kommen. Vermutlich mußt du "Fake SCSI Inquiry" einschalten.


...ausprobiert, doch nichts passiert.
Soll heißen, "Fake Inquiry" ändert leider auch nichts an der Situation.

Wenn man SnoopDos mitlaufen läßt, so zeigt sich, daß beim Starten der HDToolBox NSDPatch.cfg abgefragt wird.

Ob da etwa ein Eintrag für die ALGOR Pro (usbscsi.device) nötig wäre ?
(...wobei, kann ich mir eigentlich auch nicht ganz vorstellen)


P.S:
Eine Besonderheit dieses USB Sticks ("PowerRAM") ist es, daß er ab Werk mit zwei "Partitionen" versehen ist. Seine 512 MB sind aufgeteilt in einen Bereich mit 1,44 MB (HD-Diskette) und einen Bereich mit dem restlichen Speicherplatz.

Aber selbst die Option "Single LUN" in Trident schafft es nicht, diesen Stick für die HDToolBox erkennbar zu machen.

Ich habe noch testhalber das ältere HDInstTools (v6.9) ausprobiert und dieses erkennt den Stick, OHNE jegliche zuvorige Anpassungen/Änderungen in Trident.

Deshalb auch mein Gedanke an NSDPatch.cfg.


Gruß, Indy

[ - Antworten - Zitieren - Direktlink - ]

21.01.2005, 13:00 Uhr

thomas
Posts: 7678
Nutzer

NSDPatch brauchst du nicht. SnoopDOS hilft dir auch nicht, es werden ja keine Dateien benutzt. Poste lieber mal die Messages, die Trident auflistet, wenn du den Stick einsteckst und wenn du die HDToolbox benutzt.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

21.01.2005, 13:57 Uhr

Indy
Posts: 538
Nutzer
erstmal danke, thomas, für die "Mitarbeit"... ;)

also:

Meldungen in Trident 2.0 beim Anstecken des "USB DISK Pro" ("PowerRAM") Memorysticks:


hub.class New device 'USB DISK Pro ' at port 1. Very nice.
massstorage.class Preconfig patchflags 0x0302
massstorage.class Postconfig patchflags 0x0312
massstorage.class MSD 'USB DISK Pro ' LUN 0 available through usbscsi.device unit 0!
massstorage.class Postconfig patchflags 0x0312
massstorage.class MSD 'USB DISK Pro ' LUN 1 available through usbscsi.device unit 1!
Warning massstorage.class Couldn't read drive geometry, using floppy defaults
massstorage.class Mounted usbscsi.device unit 1 as UMSD:



Meldungen in Trident 2.0 beim Starten der HDToolBox (v45.6) für das usbscsi.device:


Warning massstorage.class Command (12000000 38000000 00000000) failed:
Error massstorage.class Command status failed: nak timeout (10)
Warning massstorage.class Command (12000000 38000000 00000000) failed:
Error massstorage.class Command status failed: nak timeout (10)
Warning massstorage.class Command (12000000 38000000 00000000) failed:
Error massstorage.class Command status failed: nak timeout (10)
Warning massstorage.class Command (12000000 38000000 00000000) failed:
Error massstorage.class Command status failed: nak timeout (10)


Gruß, Indy

[ - Antworten - Zitieren - Direktlink - ]

21.01.2005, 15:31 Uhr

thomas
Posts: 7678
Nutzer

Nun, das mit dem Fake Inquiry mußt du nochmal üben. Kommando 12 *ist* Inquiry. Und wenn das einen NAK (Negative AcKnowledge) bekommt, dann wurde es an das Gerät gesendet und nicht "gefaket".

Ich glaube, du mußt das als Default setzen und dann den Stick nochmal rausziehen, um es zu aktivieren.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

21.01.2005, 20:29 Uhr

Indy
Posts: 538
Nutzer
@thomas

Also ich habe es jetzt mal (nur durch den Einsatz von HDInstTools, da die HDToolBox offenbar "blind" ist und bleibt) so lösen können:

Mit HDInstTools eine neue Partition angelegt, Filesystem angegeben, formatiert, und fertig - funktioniert.

Sogar den Rechner vom USBstick booten klappte...

Als Filesystem habe ich abwechselnd sowohl einmal FFS als danach fat95 eingerichtet und es klappte in beiden Fällen, d.h. die Medien/Partitionen wurden in beiden Fällen auf der Workbench angezeigt.

Die HDToolBox jedoch weigert sich beharrlichst, irgendwetwas am usbscsi.device aufzulisten, ganz gleich, ob unter FFS oder fat95 formatiert....seltsam.



Gruß, Indy

[ - Antworten - Zitieren - Direktlink - ]

22.01.2005, 09:08 Uhr

platon42
Posts: 400
[Ex-Mitglied]
Zitat:
Die HDToolBox jedoch weigert sich beharrlichst, irgendwetwas am usbscsi.device aufzulisten, ganz gleich, ob unter FFS oder fat95 formatiert....seltsam.

HDToolBox wurde in den OS3.5/OS3.9 Version IMHO verschlimmbessert. Die Version von OS3.1 geht.
--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

22.01.2005, 14:44 Uhr

Indy
Posts: 538
Nutzer
Zitat:
HDToolBox wurde in den OS3.5/OS3.9 Version IMHO verschlimmbessert. Die Version von OS3.1 geht.


@platon42

...und nun kann/muß ich das sogar bestätigen ;)

Habe die alte HDToolBox v40.4 von os3.1 ausprobiert, und diese erkennt zumindest eine der beiden Partitionen auf dem UBS Stick (...gottseidank die Größere ;) ).

Allerdings:
So richtig GUT macht seine Sache einzig und allein HDInstTools (v6.9).
Egal wie ich den USBStick auch formatiert habe, dieses Programm erkennt als einziges alle (beiden) Partitionen.

Danke, Chris, für den Tip.


Gruß, Indy

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Booten vom USB memorystick ? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.