amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > 68030-Selbstbau für Amiga 1000 [ - Suche - Neue Beiträge - Registrieren - Login - ]

Erste << 9 10 11 12 13 -14- [ - Beitrag schreiben - ]

03.06.2005, 20:46 Uhr

GB97816
Posts: 250
Nutzer
Zitat:
Original von Ralf_Leonhardt:

Hi...

@ GB97816

> ...auf meiner HP ist eine neue Anleitung zur Turbokarte verfügbar.
> Sie enthält nun Hinweise bezüglich Speichereinbindung und SCSI-Interface.
> Sollte jemand von euch das TK-RAM über Addmem in den 32 Bit Adressraum einbinden wird er
> vermutlich einen deutlichen Einbruch in der Transfergeschwindigkeit des (Phönix) SCSI-Interfaces
> gegenüber einer Speichereinbindung über die Autokonfiguration feststellen.
> Entsprechende Maßnahmen sind in der Anleitung erleutert.

So, ich hab mal endlich Zeit gefunden, um die Turbokarte etwas ausgiebiger zu testen.
Saubere Arbeit, Georg !!!
...ist ja echt 'nen starkes Teil


System-Konfig:
Phoenixboard mit 2MB Chip, ROM/WB 3.1, Turbokarte mit MC68030RC50 + 40MHz Quarz, Aotoconfig-Mem,
kleine Quantum LPS52 am Phoenix-SCSI (pbscsi.device V3.1)

"SysInfo" liefert dafür die folgenden (wichtigsten) Werte:

SPEED COMPARISONS AGAINST KNOWN MODELS & PERIPHERALS
A500 512k or A600 with 1MB CHIP ONLY.........16.28
B2000, A2000, A1000 or A500 with fast ram....12.32
A1200/14 68EC020 ICACHE 2MB CHIP ONLY........ 7.07
A2500/14 A2620 68020 card.................... 4.19
CPU Million Instructions per Second.......... 8.99
FPU Million Floating Operations per Second... 1.05
Blitter Speed vs A4000-68040-25MHz........... 3.00
Speed of Chip Memory vs A600 Chip Memory..... 3.00
Dhrystones per second........................ 8616
CPU speed in MHz.............................40.30

Plattenspeed.....ca 330 kB/sec


Dann wurde das Autoconfig-Mem abgeschaltet, und per "addmem $1600000 $19fffff 32bit" im
oberen Adressbereich des Systems eingebunden.
Die System-Speed ging geringfügig zurück (ca 11,5fach gegenüber einem A500, A1000, A2000).
Mit der Festplatte waren jetzt nur noch Transferraten von ca 120 kB/sec möglich.
Eine Änderung des Mask-Wertes, wie in der TK-Anleitung beschrieben, brachte hier nichts.
Mit Mask-Werten von 0x00fffffe oder 0x00fffffc bzw. 0x7ffffffe oder 0x7ffffffc liess sich
an der Plattenspeed nix ändern.
Das Phoenix-SCSI kann ja nur über's ChipMem auf die Platte zugreifen.
Mit einer FastMem-Karte (autoconfig) am Expansion-Port erhielt ich dann wieder die alten
Werte von ca 330 kB/sec.

Ich hab dann einen Hardwarehack am SCSI-Port eingebaut.
Die Umbauanleitung dazu ist demnächst bei "www.a1k.org" zu finden
Dieser Hack incl. dem neuen "pbscsi.device V7.17", das softwaremässig ins System eingebunden
wird, ergibt eine Transferrate von ca 900 kB/sec. Was gegenüber den ursprünglichen 330 kB/sec
doch schon erheblich ist. Mit einer 1-GB-IBM Platte komme ich auf etwas über 1 MB/sec.
Wird das TK-Ram mit "Addmem" ab $1600000 eingebunden, dann liegt die Plattenspeed gem. SysInfo
immernoch bei etwa 470 kB/sec. Also auch erheblich höher, als mit dem alten SCSI-Device.

Ok, das war mein erster "kurzer" Testbericht zur "Phoenix Turbo FE".

bis denne...

Ralf

--
A2000 T - Blizzard2040 - CV64/3D - Highway - IoBlix - OS3.9
A500 D - Derringer030-33MHz - Oktagon2008 - PicassoII+ - HD - CD - OS3.9
A500plus - VXL30-25MHz - Trumpcard500 - HD - WB2.1
A1000 - A2630/4MB - GVP-SCSI - HD - WB2.1

Hi Ralf,

interessante Erkenntnisse zur Addmem Einbindung des Speichers. Ich habe bei mir überhaupt keine Unterschiede mit SysInfo im HD0-Speed zwischen Addmem und Autokonfig feststellen können. Mir ist der Einbruch in der Zugriffsgeschwindigkeit nur über den Fensteraufbau und
Dateiaufrufe aufgefallen. Da aber sehr deutlich.
Der Eintrag des Maskenwertes sollte 0xfffffffc (7 x f und 1 x c) betragen. Dabei konnte ich dann keine Unterschiede mehr feststellen.
Ich habe kein zusätzliches Fast-Ram eingebaut. Der Einbruch im System-Speed bei der Addmem Einbindung führe ich auf die Verlagerung der Betriebssystemteile ins Chip-Ram zurück.
Mit welcher SysInfo-Version arbeitest Du?

Dank & Gruß,
Georg




[ - Antworten - Zitieren - Direktlink - ]

03.06.2005, 21:31 Uhr

GB97816
Posts: 250
Nutzer
Zitat:
Original von GB97816:
Zitat:
Original von Ralf_Leonhardt:

Hi...

@ GB97816

> ...auf meiner HP ist eine neue Anleitung zur Turbokarte verfügbar.
> Sie enthält nun Hinweise bezüglich Speichereinbindung und SCSI-Interface.
> Sollte jemand von euch das TK-RAM über Addmem in den 32 Bit Adressraum einbinden wird er
> vermutlich einen deutlichen Einbruch in der Transfergeschwindigkeit des (Phönix) SCSI-Interfaces
> gegenüber einer Speichereinbindung über die Autokonfiguration feststellen.
> Entsprechende Maßnahmen sind in der Anleitung erleutert.

So, ich hab mal endlich Zeit gefunden, um die Turbokarte etwas ausgiebiger zu testen.
Saubere Arbeit, Georg !!!
...ist ja echt 'nen starkes Teil


System-Konfig:
Phoenixboard mit 2MB Chip, ROM/WB 3.1, Turbokarte mit MC68030RC50 + 40MHz Quarz, Aotoconfig-Mem,
kleine Quantum LPS52 am Phoenix-SCSI (pbscsi.device V3.1)

"SysInfo" liefert dafür die folgenden (wichtigsten) Werte:

SPEED COMPARISONS AGAINST KNOWN MODELS & PERIPHERALS
A500 512k or A600 with 1MB CHIP ONLY.........16.28
B2000, A2000, A1000 or A500 with fast ram....12.32
A1200/14 68EC020 ICACHE 2MB CHIP ONLY........ 7.07
A2500/14 A2620 68020 card.................... 4.19
CPU Million Instructions per Second.......... 8.99
FPU Million Floating Operations per Second... 1.05
Blitter Speed vs A4000-68040-25MHz........... 3.00
Speed of Chip Memory vs A600 Chip Memory..... 3.00
Dhrystones per second........................ 8616
CPU speed in MHz.............................40.30

Plattenspeed.....ca 330 kB/sec


Dann wurde das Autoconfig-Mem abgeschaltet, und per "addmem $1600000 $19fffff 32bit" im
oberen Adressbereich des Systems eingebunden.
Die System-Speed ging geringfügig zurück (ca 11,5fach gegenüber einem A500, A1000, A2000).
Mit der Festplatte waren jetzt nur noch Transferraten von ca 120 kB/sec möglich.
Eine Änderung des Mask-Wertes, wie in der TK-Anleitung beschrieben, brachte hier nichts.
Mit Mask-Werten von 0x00fffffe oder 0x00fffffc bzw. 0x7ffffffe oder 0x7ffffffc liess sich
an der Plattenspeed nix ändern.
Das Phoenix-SCSI kann ja nur über's ChipMem auf die Platte zugreifen.
Mit einer FastMem-Karte (autoconfig) am Expansion-Port erhielt ich dann wieder die alten
Werte von ca 330 kB/sec.

Ich hab dann einen Hardwarehack am SCSI-Port eingebaut.
Die Umbauanleitung dazu ist demnächst bei "www.a1k.org" zu finden
Dieser Hack incl. dem neuen "pbscsi.device V7.17", das softwaremässig ins System eingebunden
wird, ergibt eine Transferrate von ca 900 kB/sec. Was gegenüber den ursprünglichen 330 kB/sec
doch schon erheblich ist. Mit einer 1-GB-IBM Platte komme ich auf etwas über 1 MB/sec.
Wird das TK-Ram mit "Addmem" ab $1600000 eingebunden, dann liegt die Plattenspeed gem. SysInfo
immernoch bei etwa 470 kB/sec. Also auch erheblich höher, als mit dem alten SCSI-Device.

Ok, das war mein erster "kurzer" Testbericht zur "Phoenix Turbo FE".

bis denne...

Ralf

--
A2000 T - Blizzard2040 - CV64/3D - Highway - IoBlix - OS3.9
A500 D - Derringer030-33MHz - Oktagon2008 - PicassoII+ - HD - CD - OS3.9
A500plus - VXL30-25MHz - Trumpcard500 - HD - WB2.1
A1000 - A2630/4MB - GVP-SCSI - HD - WB2.1

Hi Ralf,

interessante Erkenntnisse zur Addmem Einbindung des Speichers. Ich habe bei mir überhaupt keine Unterschiede mit SysInfo im HD0-Speed zwischen Addmem und Autokonfig feststellen können. Mir ist der Einbruch in der Zugriffsgeschwindigkeit nur über den Fensteraufbau und
Dateiaufrufe aufgefallen. Da aber sehr deutlich.
Der Eintrag des Maskenwertes sollte 0xfffffffc (7 x f und 1 x c) betragen. Dabei konnte ich dann keine Unterschiede mehr feststellen.
Ich habe kein zusätzliches Fast-Ram eingebaut. Der Einbruch im System-Speed bei der Addmem Einbindung führe ich auf die Verlagerung der Betriebssystemteile ins Chip-Ram zurück.
Mit welcher SysInfo-Version arbeitest Du?

Dank & Gruß,
Georg

Hi Ralf,

ich kann Deine Ergebnisse bestätigen. Mit Addmem bricht die Übertragungsgeschwindigkeit auf rund 120 kB/s zurück. Da hilft auch der Masken-Eintrag nichts.
Über die Einbindung des Speichers mit Hilfe des Flash-Treibers liegt die Übertragungsgeschwindigkeit bei 355 kB/s, also wie bei der Autokonfiguration in den 24 Bit Adressraum. Der Eindruck zu Fensteraufbau und Dateiaufrufen bleibt jedoch langsamer (ca. Faktor 2-3) solange der Maskeneintrag nicht umgestellt wird. Als Maß steht mir dabei aber nur die (Maus)Stoppuhr zur Verfügung, also reine Schätzung!

Sorry an Alle,
bei Gelegenheit werde ich die Anleitung entsprechend berichtigen. Der Zusammenhang zwischen Filesystem und SCSI-Controller ist auch falsch dargestellt.

Gruß,
Georg

[ - Antworten - Zitieren - Direktlink - ]

05.07.2005, 22:54 Uhr

Amiga_Digital
Posts: 131
Nutzer
Hallo,...

ist die turbo karte fur der Phoenix im handel ( zukaufen )

grusse,.

:commo: :bounce: :commo:
--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

05.07.2005, 23:35 Uhr

VMC
Posts: 115
Nutzer
@Amiga_Digital:

Hallo Amiga_Digital,

ja du kannst die Karte auch bei Georg oder mir kaufen.

Mit freundlichen Grüßen,

ZappShop.de, Harald Frank

[ - Antworten - Zitieren - Direktlink - ]

06.07.2005, 11:45 Uhr

Ralf207
Posts: 22
Nutzer
was ist das für eine Nr.ROM 391640-03
MFG Ralf

[ - Antworten - Zitieren - Direktlink - ]

06.07.2005, 16:56 Uhr

GB97816
Posts: 250
Nutzer
@Amiga_Digital:
Hallo,

bitte wende Dich an VMC.

Dank & Gruß,
Georg

[ - Antworten - Zitieren - Direktlink - ]

06.07.2005, 16:59 Uhr

Amiga_Digital
Posts: 131
Nutzer
@GB97816:

danke, dann frag ich VMC mal was der turbo-karte fur der phoenic koste

danke,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

06.07.2005, 17:00 Uhr

Amiga_Digital
Posts: 131
Nutzer
@VMC:

hallo Harald

kann ich der karte hier kaufen order via deine internet site

danke,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

08.07.2005, 16:35 Uhr

Amiga_Digital
Posts: 131
Nutzer
@GB97816:

Hallo

kann ich bei dir eine turbo-karte kaufen VMC meld sie nicht

danke,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

08.07.2005, 21:28 Uhr

VMC
Posts: 115
Nutzer
Zitat:
Original von Amiga_Digital:
@GB97816:

Hallo

kann ich bei dir eine turbo-karte kaufen VMC meld sie nicht

danke,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude


Hallo Amiga_Digital,

schau, ich schaue hier nicht immer rein und auch nicht in
jeden Thread. Schreibe mir bitte eine Email an sales @ vmc.de
mit deinem kompletten Namen und Anschrift und du kannst eine
der Karten bekommen.

Da ich bisher *keine* Email von dir habe weis ich nicht auf
was sich dein "VMC meld sie nicht" bezieht.

UPDATE: Habe eben deine Email gefunden, sorry ist leider in
den SPAM Ordner gelandet :) Bekommst sofort deine Antwort :)

Mit freundlichen Grüßen,

ZappShop.de, Harald Frank

[ Dieser Beitrag wurde von VMC am 08.07.2005 um 21:38 Uhr editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

08.07.2005, 21:59 Uhr

Amiga_Digital
Posts: 131
Nutzer
@VMC:

danke harald ich habe mail von dir

bis spatter,.

grussem,..
--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

08.07.2005, 22:43 Uhr

GB97816
Posts: 250
Nutzer
@Amiga_Digital:
Hallo Amiga_Digital und alle weitere Interessenten,

ich habe für den Verkauf keine TKs mehr und werde auch keine mehr dafür bauen. Was bei mir noch an Material vorhanden ist, ist entweder schon reserviert oder wird zur Abdeckung von Ausfällen benötigt.

-> Das Projekt ist für mich soweit abgeschlossen. Aus diesem Grund werde ich mich aus diesem Thread verabschieden. Falls Probleme oder Fragen aufkommen könnt ihr euch direkt an mich wenden. Meine eMail Adresse ist hier hinterlegt. Neuerungen oder Updates zur Hardware gebe ich auf meiner HP bekannt.

Bitte wendet euch bezüglich TKs an VMC.

Viele Grüße,
Georg




[ - Antworten - Zitieren - Direktlink - ]

09.07.2005, 22:40 Uhr

Amiga_Digital
Posts: 131
Nutzer
@GB97816:

danke fur deine info

grusse,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

09.07.2005, 22:40 Uhr

Amiga_Digital
Posts: 131
Nutzer
@VMC:

Hallo Harald du hast post von mir

grusse,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

11.07.2005, 21:53 Uhr

Amiga_Digital
Posts: 131
Nutzer
Hallo VMC ( Harald )

Hallo Harald

das ist super

kann ich auch mit paypal zahlen wenn nicht keine probleme kans du dann
deine IBAN und adresse schicken


p.s der cpu und fpu und quartz habe ich hier

danke,.

ich kann dir keine mail schicken ( reject tomany spam from home.nl )

grusse,.

--
A4000D 604e 150-060-50 144mb
A4000T 604e 233-060-50 128mb
A2000 060-50 128mb gvp spectrum
A500+ 030-40 4mb MultiVision 500
A3000T 060-50 256mb Cybervision 64 Ariadne II Prelude

[ - Antworten - Zitieren - Direktlink - ]

24.07.2005, 13:46 Uhr

jopower
Posts: 364
Nutzer
@ Georg:

Mal eine Frage zum Quarzosszi.. Warum ist das auf der Karte? Ist ja nur 1 Pin angeschlossen...ist mir nicht klar.
:O
--
Mit freundlichen Grüßen

[ - Antworten - Zitieren - Direktlink - ]

24.07.2005, 17:46 Uhr

GB97816
Posts: 250
Nutzer
@jopower:

Hi,

am Oszillator sind drei Pins angeschlossen. Zwei davon über die Innenlagen Vcc und GND, es ist ja eine 4-fach Layer. Eventuell hast Du die Innenlagen im Eagle nicht eingeblendet. Layer 2 & 3 muss Du mit aktvierten und Ratsnest ausführen. Dann werden die Versorgungslayer gefüllt dargestellt und die Verbindungen werden sichtbar.

Gruß,
Georg

[ - Antworten - Zitieren - Direktlink - ]

24.07.2005, 18:47 Uhr

jopower
Posts: 364
Nutzer
Ohh danke. Jetzt wird's mir angezeigt. Hab halt bisher nur 2 Layer Platinen gezeichnet ;) An dieser Platine musst Du ja ewig drangesessen sein.. Wahnsinn.
Das mit dem A1000 Gehäuse zerschnippeln lass ich auch lieber sein. Ein externes CD-Rom tuts auch.
--
Mit freundlichen Grüßen

[ - Antworten - Zitieren - Direktlink - ]

25.07.2005, 11:48 Uhr

aPEX
Posts: 4692
Nutzer
Zitat:
Original von jopower:
An dieser Platine musst Du ja ewig drangesessen sein.. Wahnsinn.


Die Karte ist einfach nur genial!!! Wer sich da keine holt ist selber
schuld. :)
Selbst Andrew war hin und weg als er sein Päckchen mit der Karte
geöffnet hat. Er findet es genial das es in Deutschland noch so
viele Amigaverrückte und sogar Entwickler gibt. :)

Danke George!!!

--
cu, aPEX

:commo: http://www.a1k.org - Die Amiga 1000 & Phoenix Community :commo:
A1000-512KB Chip,8MB Fast,BlizzardTurboMemory,68010P12,ALF-Kontroller
Phoenix, A500+, A600, A1200, A4000 ... http://phase5.a1k.org


[ - Antworten - Zitieren - Direktlink - ]

24.08.2005, 12:18 Uhr

GB97816
Posts: 250
Nutzer
Hallo Phönix-Turbo-FE Besitzer,

auf meiner HP kann unter Projekte ein Bootloader für die TK abgerufen werden. Das Ganze besteht aus zwei kleinen Programmen.
a.) zum löschen des Flash Bausteines
b.) zum Einbinden des RAMs in den 32Bit Adressraum

Bitte die Programme in der Reihenfolge mit RAM-Einbindung über die Autokonfiguration starten.
Sie nutzen Iconx und öffnen ein Meldefenster. Geht alles in Ordnung
schließt sich das Meldefenster ohne Worte. Gibt es eine Fehlermeldung, dann ist etwas schief gelaufen................
Gab es keine Fehlermeldung -> Rechner ausmachen, Autokonfig der TK abschalten (den Jumper setzen) und den Phönix neu starten.

Ich habe den Kram nur unter Kick 3.1 getestet. Bei mir funktioniert es. Ob es aber 100% zu den OS-Richtlinien geschrieben ist kann ich wirklich nicht beantworten. Ich habe zumindest versucht etwas einigermaßen brauchbares zu machen. Also bitte nicht schlagen wenn es in die Hose geht, ich bin kein Amiga Software-Schreiber mit vollem Durchblick im OS.................

Nachtrag:
Sorry, manchmal drücke ich mich recht bescheiden aus:

Das zweite Tool installiert im Flash der TK einen Treiber zur Einbindung des RAMs in den 32 Bit Adressraum. Der Speicher wird dann beim Booten über den Treiber aus dem Flash eingebunden und er übergibt auch die Konfig.-Daten (Hersteller, Seriennummer, usw.) an das OS. Der 24 Bit Adressraum (Zorro- und Expansionsport) ist dann für
Erweiterungen mit 8 MB frei.


Gruß,
Georg


[ Dieser Beitrag wurde von GB97816 am 25.08.2005 um 15:21 Uhr editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

26.09.2005, 00:11 Uhr

GB97816
Posts: 250
Nutzer
@ Alle Turbo-FE-User,

auf meiner HP kann unter Tools/Bootloader nun zusätzlich ein erweiterter Bootloader (FE_RAM_Intro) abgerufen werden.
Er beinhaltet eine Animation die beim Systemstart aufgerufen wird.

Bevor ihr jetzt denkt ich bin zu den Software-Gurus aufgestiegen:

- Das Animationsgerüst ist aus dem Aminet von Triumph und darf frei verwendet werden solange man nicht behauptet es wäre von einem selbst.

- Ohne Herrn Frank Wille (hat PhxAss gemacht) hätte ich den Kram aus dem Flash nicht lauffähig gebracht.

Vielen Dank an Herrn Wille für seine Hilfe.

Viel Spaß damit,
Georg

[ - Antworten - Zitieren - Direktlink - ]

26.09.2005, 11:43 Uhr

aPEX
Posts: 4692
Nutzer
Danke! :rotate:
--
cu, aPEX

:commo: http://www.a1k.org - Die Amiga 1000 & Phoenix Community :commo:
A1000-512KB Chip,8MB Fast,BlizzardTurboMemory,68010P12,ALF-Kontroller
Phoenix, A500+, A600, A1200, A4000 ... http://phase5.a1k.org


[ - Antworten - Zitieren - Direktlink - ]


Erste << 9 10 11 12 13 -14- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > 68030-Selbstbau für Amiga 1000 [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.