amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Andere Systeme > auf AFFS mit Linux [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

12.07.2001, 16:15 Uhr

Schorchgrinder
Posts: 617
Nutzer
Bei der Installation gab es folgendes Problem ,ich habe eine AFFS(3.1)
Partion angelegt und da das Verzeichniss Redhat draufkopiert.
Und beim Installtionspfad Harddiskdrive ausgewält und Fehlermeldung
falsche RootHD ,ich habe nun alles versucht vom FFS des 1.3 Kick ,die Part automount/nichtautomount ,Bootbar /nicht bootbar und immer das selbe.
Hat mal jemand sein Linux von HD aus installieren können?
Die Part wurde auch erkannt als hdb7 ,ich könnte mir nur noch denken das es ein Prob mit dem IDEFIX-4fach-Adapter gibt.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

12.07.2001, 16:27 Uhr

Holger
Posts: 8064
Nutzer
Ich habe zwar schon Linux von HD installiert, aber nicht von einer FFS-Partition. Das Installationsprogramm, bzw. das BootImage muesste dafuer so konfiguriert sein, dass es auch FFS-Partitionen mounten kann und das scheint wohl generell nicht der Fall zu sein.
Ich habe damals das Image einer Testdisk verwendet (Bootdiskette koennte auch gehen, falls vorhanden), auf der die noetigen Befehle vorhanden waren, um eine EXT2-Partition anzulegen und den Inhalt der FFS-Partition rueberzuschaufeln. Installation von der EXT2-Partition ging dann problemlos.

mfg

--


Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

12.07.2001, 16:36 Uhr

Schorchgrinder
Posts: 617
Nutzer
Da die FFS-Platte im Satmmbaumverzeichniss angezeigt worden ist als einzige von den anderen AmigaHDs denke ich mal das das mounten schon richtig funzte.Ich wüßte auch nicht wie man die HD wärend der Installation mounten kann.
Da ja nur bootstrap und die Befehle fürs starten möglich sind.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

12.07.2001, 17:28 Uhr

Holger
Posts: 8064
Nutzer
Normalerweise versucht das Installationsprogramm die Partition zu mounten, nachdem man sie als Quelle ausgewaehlt hat. Wenn an der Stelle die moeglichen FileSysteme hardcodiert sind und nicht "autofs"¹ benutzt wird, hat man ein Problem.
Ich weiss nicht, wie es beim RedHat-Installer ist, bei manchen kann man waehrend der Installation mit ctrl+alt+f2 in eine andere Konsole wechseln und versuchen, einiges per Hand zu fixen.

mfg

¹ Und wenn automatische fs-erkennung benutzt wird, muss im verwendeten kernel auch affs support eincompiliert sein.
--


Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

13.07.2001, 14:16 Uhr

Hammer
Posts: 2899
Nutzer
Tja, wenn im Installerscript nicht die amigapartition angemeldet wird, haste ziemlich Pech gehabt!
Entweder Du schaffst es ein zweites fenster zu öffnen, von wo du die Platte nachträglich mountest, oder Du suchst Dir ein anderes Installerscript, vielleicht selber umschreiben?

hatte damals das selbe Problem!

MFG

Hammer
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

13.07.2001, 18:44 Uhr

Schorchgrinder
Posts: 617
Nutzer
Naja von CD aus ging ja die Installation nur von HD aus nicht .
Von CD ist es nervend ,da mein Low-Cost-CD-LW ständig mit den Geschw.
hoch und runter fährt.Und so die Installzeit nach ober treibt.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

PS
@Hammer
das Buch ist heute so gegen 9 Uhr bei mir aufgeschlagen:boing:

[ Dieser Beitrag wurde von Schorchgrinder am 13.07.2001 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

13.07.2001, 20:47 Uhr

Holger
Posts: 8064
Nutzer
Bei einigen Installern klappt es, das Iso-Image der CD auf eine Partition zu kopieren, und diese als isofs zu mounten.

mfg

--

Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

13.07.2001, 23:00 Uhr

Hammer
Posts: 2899
Nutzer
Hoffe das Buch hilft Dir weiter!

Zum Thema, bei mir war es damals so, das er eine Partition nicht hochgestartet hat. Leider war genau auf der Partition der einzige freie Platz zu dem Zeitpunkt!!! :angry:

Erkennte er jetzt bei dir die Platte, glaube schon, oder?
Ja, vielleicht kannste ja das Installerscript abändern? Wahrschenlich eine der wenigen optionen die Du hast.
Aber normalerweise sind die Amigainstaller so abgeändert, das man zugriff auf mindestnes eine Partition noch hat.
Wie war das mit dem Mounten gleich nochmal? irgendwas mit affs als Filesystem (Amigaffs). Ach ich weiß es nicht mehr!

MFG

Hammer

PS.: Komme morgen zu meinen Eltern und kralle mir mal das andere Linux Buch!
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

15.07.2001, 20:53 Uhr

Schorchgrinder
Posts: 617
Nutzer
Ja die Partion wird vom Linuxinstaller erkannt als Hdb7 oder Hdb2
je wo sie war.Ich werde mal in der Linuxconsole schauen ob da Zugriff auf die Part ist.
Einen möglichen Fehler könnte ich auch gemacht haben ,wenn ich das Buch was ich vom Hammer bekommen habe richtig gelesen habe ,ist die Reihenfolge wie man die Archive in das Redhatverzeichniss kopiert auch wichtig.
Obwohl ,wenn ich die Part angewählt habe hat mir Linux in dem Logbildschirm den Fehler falsche Rootpart gemeldet oder so ähnlich.
Muß noch mal schauen ,aber hatte in letzter Zeit nicht die Zeit ;-)
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

15.07.2001, 23:02 Uhr

Holger
Posts: 8064
Nutzer
Zitat:
Original von Schorchgrinder:
Ja die Partion wird vom Linuxinstaller erkannt als Hdb7 oder Hdb2
[...]
Obwohl ,wenn ich die Part angewählt habe hat mir Linux in dem Logbildschirm den Fehler falsche Rootpart gemeldet oder so ähnlich.
Muß noch mal schauen ,aber hatte in letzter Zeit nicht die Zeit ;-)

Klingt danach, als ob er sie als Linux-Partition (ext2) mounten wollte.
Du müßtest die Partition so mounten können:
mkdir /mnt/ami
mount -t affs /dev/hdb7 /mnt/ami

Bleibt nur noch die Frage, ob der Installer die Möglichkeit bietet, dann das Verzeichnis /mnt/ami als Quelle anzugeben.

mfg


--

Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

16.07.2001, 13:18 Uhr

Schorchgrinder
Posts: 617
Nutzer
Ich werde mich mal heute abend hinsetzten und wieder eine AFFS-Part auf meine HD einrichten und die HD unter Linux mounten.
Schaun wir mal.
Wie gesagt der installer erkennt die Part als AFFS
da steht dann halt Linuxnativ bei HDB1 und bei der Part Hdb7 AFFS.
Ich denke mal das da die HD mit FFS mit gemountet ist ,der Fehler liegt wahrscheinlich woanderst.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

16.07.2001, 16:38 Uhr

Hammer
Posts: 2899
Nutzer
@Schorchgrinder: Im zweiten Buch ist genau dieser Punkt supergenau beschrieben!

MFG

Hammer

PS.: Spätestens am Freitag ist es bei Dir, jeh nachdem wie ich Zeit habe vielleicht schon eher.
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

16.07.2001, 20:16 Uhr

Schorchgrinder
Posts: 617
Nutzer
Problem gelöst.
ich habe auf der sekundär HD eine AFFS Part angelegt und sieheda sie wird erkannt.Also HdaX läuft und HdbX nicht oder dann per Hand gemountet (denk ich mal)
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

17.07.2001, 16:46 Uhr

Hammer
Posts: 2899
Nutzer
Mitthilfe des zweiten Buches bist Du in der Lage die fehlende Partitionen in die Linux Startupdateien zu schreiben, damit sie automatisch mitgemountet werden.

MFG

Hammer
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

17.07.2001, 20:07 Uhr

Schorchgrinder
Posts: 617
Nutzer
Das Geld ist unterwegs ,wann es ankommt ist die andere Frage da die Spaßkasse manchmal nicht die schnellste ist.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 18:42 Uhr

Holger
Posts: 8064
Nutzer
Zitat:
Original von Schorchgrinder:
Problem gelöst.
ich habe auf der sekundär HD eine AFFS Part angelegt und sieheda sie wird erkannt.Also HdaX läuft und HdbX nicht oder dann per Hand gemountet (denk ich mal)

Das kann ein Problem mit der hohen Partitionsnummer sein. Ein Programm, das die Partitionstabelle selbst ausliest, erkennt die vorhandene Partition und auch den Typ, aber um sie anmelden zu können, muß auch der Geräteeintrag (/dev/hda7) existieren. Es kann sein, daß auf dem Installationsimage nur Einträge bis zu einer bestimmten Partitionsnummer angelegt wurden. In dem Fall hat es mit der zweiten Platte geklappt, weil es eine Partition mit kleinerer Nummer war.
Geräteeinträge kann man mit mknod anlegen, im Allgemeinen braucht man das aber nicht, weil auf der Partition, auf der man Linux installiert, mehr Geräteeinträge angelegt werden (Da ist ja auch mehr Platz).

mfg
--

Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

23.07.2001, 20:31 Uhr

Schorchgrinder
Posts: 617
Nutzer
Das hatte ich ja am Anfang auch gedacht und habe die Part in Hdb2 eingerichtet ohne Erfolg.
Bis 16 Parts werden erkannt das habe ich in einer Conf gesehen und da
noch bis HdcX und HddX.
Das Hauptproblem ist meiner Meinung nach der IDE-Doubler ,da er vom PPC-Linux nur als Betatreiber vorliegt.
Auf mein 2.CD-Rom kann ich auch nicht zugreifen oder es ist zualt.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Andere Systeme > auf AFFS mit Linux [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.