amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Subway + X-Surf Clockport = Rauch :-( [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

01.04.2005, 12:10 Uhr

aPEX
Posts: 4692
Nutzer
hallo leute,

also gestern habe ich es auch geschafft meine nagelneue
subway (weihnachtsgeschenk) in die luft zu jagen. :( :(

habe nirgends eine dokumentation finden koennen wo pin1
auf der xsurf ist, bin aber auch nicht der beste googler :)
einen thread dazu gab es hier schon auf anews (2003), dem
konnte ich aber auch nicht soviel informationen entnehmen...

bin auf jedenfall davon ausgegangen alles richtig gemacht zu
haben, habe sogar die masse ueberprueft, stimmte alles....

HAT JEMAND SO EINE KOMBINATION AM LAUFEN??? ?(

kann mir jemand ein bild machen wie das alles verkabelt ist?
so mit nahaufnahme fuer die ganz dummen wie mich... :)

scheinbar bin ich auch nicht der erste, trotzdem schade das es
dann noch immer so wenig infos gibt...

...koennte echt gleich losheulen... ne alte pc tastatur hat schon
im garten leiden muessen :)


--
cu, aPEX :bounce:

Bild: http://www.a1k.org/bilderlink/a1000_lorbeer.gif A1000 Phoenix Revival Project :commo: http://www.a1k.org





[ Dieser Beitrag wurde von aPEX am 01.04.2005 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

01.04.2005, 13:01 Uhr

Gururom
Posts: 267
Nutzer
schreib doch ne Email an Michael oder jens.
sollten doch immer die ersten Ansprechpartner sein.

cu Guru

[ - Antworten - Zitieren - Direktlink - ]

01.04.2005, 13:37 Uhr

MaikG
Posts: 5172
Nutzer
Verpolt heisst nicht immr gleich defekt.
Kann z.B. nur eine Leiterbahn und Kondensatoren defekt sein.
1. kann qualmen, 2. kann knallen+Qualmen.

Ich habe die Subway auch schon verkehrt eingesetzt, hat allerdings
noch nicht gequalmt. Am Simpelsten ist es am Kabel anzufassen,
Amiga an, wenns warm wird sofort wieder aus.
Hat bissher immer geklappt.

Man sollte sich vielleicht einen Verpolungsschutz bauen.
z.B. ein Masse Pin abschneiden und am Stecker zukleben oder reinstecken.

[ Dieser Beitrag wurde von MaikG am 01.04.2005 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

01.04.2005, 13:49 Uhr

aPEX
Posts: 4692
Nutzer
der chip wo glaub lattice drauf steht hatte
auf einmal einen glimmenden punkt in der mitte.
ich gehe davon aus das er defekt ist, habe es aber
auch kein zweites mal testen wollen...

--
cu, aPEX :bounce:

Bild: http://www.a1k.org/bilderlink/a1000_lorbeer.gif A1000 Phoenix Revival Project :commo: http://www.a1k.org



[ - Antworten - Zitieren - Direktlink - ]

01.04.2005, 14:29 Uhr

Lemmink
Posts: 2344
Nutzer
Tja, ist auch ein wenig ärgerlich das Jens auf seinen Karten den "Pin 1" genau entgegebgesetzt zum dem definiert wie er z.B. auf einem A1200 Board zu finden ist (ja, ich weiß, daß es beim Uhrenport keinen Pin 1 gibt, da er erst ab 22 oder so anfängt, halt der Pin an dem die rote Ader ausgerichtet wird). Ich hatte mal mit Michael Böhmer gesprochen und der meinte, es ist am sichersten mit einem Multimeter den Pin mit 5 Volt zu finden und sich daran zu orientieren. Weiß jetzt leider nicht mehr, ob der "rechts" oder "links" sein sollte. Spätestens, wenn ich an den Uhrenport meines Access was anschließen will stellt sich bei mr auch wieder die Frage. Vielleicht kann man ja auch einen Silversurfer als "Mienensucher" mißbrauchen, die gibts ja gebracht recht günstig und der Verlustschmerz dürfte sich somit in Grenzen halten :D
--
Das Grauen hat viele Gesichter und mein Spiegel zeigt mir jeden Morgen ein neues.

Jetzt neuer, aber immer noch nicht interessanter: http://www.lemmink.joice.net

[ - Antworten - Zitieren - Direktlink - ]

01.04.2005, 14:59 Uhr

Ralf_Leonhardt
Posts:
[Ex-Mitglied]
Hi...

@aPEX
> bin auf jedenfall davon ausgegangen alles richtig gemacht zu
> haben, habe sogar die masse ueberprueft, stimmte alles....

@Lemmink
> ...es ist am sichersten mit einem Multimeter den Pin mit 5 Volt zu finden
> und sich daran zu orientieren.

Ich such mir auch immer zuerst die Masse- und +5V Pins mit einem Multimeter,
und klemme dann die Erweiterung an den Clockport.
Dann wird nochmals nachgemessen, mit einem Ohmmeter, ob die +5V auch da hingehen,
wo sie's sollen.

bis denne...

Ralf

--
A2000 T - Blizzard2040 - CV64/3D - Highway - IoBlix - OS3.9
A500 D - Derringer030-33MHz - Oktagon2008 - PicassoII+ - HD - CD - OS3.9
A500plus - VXL30-25MHz - Trumpcard500 - HD - WB2.1
A1000 - A2630/4MB - GVP-SCSI - HD - WB2.1

[ - Ändern - Antworten - Zitieren - Direktlink - ]

01.04.2005, 18:57 Uhr

MaikG
Posts: 5172
Nutzer
>der chip wo glaub lattice drauf steht hatte
>auf einmal einen glimmenden punkt in der mitte.
>ich gehe davon aus das er defekt ist, habe es aber
>auch kein zweites mal testen wollen...

Dann wird er hin sein. Ist zwar ein Standart Chip aber
schwer zu tauschen.

[ - Antworten - Zitieren - Direktlink - ]

01.04.2005, 19:32 Uhr

checker
Posts: 640
Nutzer
Zitat:
Original von MaikG:
>der chip wo glaub lattice drauf steht hatte
>auf einmal einen glimmenden punkt in der mitte.
>ich gehe davon aus das er defekt ist, habe es aber
>auch kein zweites mal testen wollen...

Dann wird er hin sein. Ist zwar ein Standart Chip aber
schwer zu tauschen.



den lattice zu tauschen ist kein thama aber der muss vorher programiert werden und das ist schwer ohne das passende file ..


--
AOne G4 1000 512 MB Fast
A4000 T 200 604e 060/50 144 MB Fast
A1200 T 240 603e 060/50 245 MB Fast
A500 030 50 8 MB Fast
CDTV original =)
und und und..

[ - Antworten - Zitieren - Direktlink - ]

02.04.2005, 10:19 Uhr

MaikG
Posts: 5172
Nutzer
>den lattice zu tauschen ist kein thama aber der muss
>vorher programiert werden und das ist schwer ohne das
>passende file ..

Sowas ähnliches wie ein PIC also? Müsste man von einem
heilen Chip ja auslesen können. Ist natürlich zuviel
aufwand.

[ - Antworten - Zitieren - Direktlink - ]

02.04.2005, 11:54 Uhr

checker
Posts: 640
Nutzer
Zitat:
Original von MaikG:
>den lattice zu tauschen ist kein thama aber der muss
>vorher programiert werden und das ist schwer ohne das
>passende file ..

Sowas ähnliches wie ein PIC also? Müsste man von einem
heilen Chip ja auslesen können. Ist natürlich zuviel
aufwand.


ja richtig nur kannst du die nicht einfach so auslesen da gibt es eine protection gegen.


--
AOne G4 1000 512 MB Fast
A4000 T 200 604e 060/50 144 MB Fast
A1200 T 240 603e 060/50 245 MB Fast
A500 030 50 8 MB Fast
CDTV original =)
und und und..

[ - Antworten - Zitieren - Direktlink - ]

02.04.2005, 12:02 Uhr

Kronos
Posts: 1168
Nutzer
Hab mir grad mal meine HigWay angeschaut, und hab so meine Zweifel ob man den Chip mit handelsüblichen Wurstfingern so ohne weiteres tauschen könnte :lickout:

Bleibt dir wohl nichts anderes über also mal ganz kleinlaut bei Herrn Boehmer anzufragen.....

MfG
Kronos
--
Only the good die young all the evil seem to live forever

[ - Antworten - Zitieren - Direktlink - ]

02.04.2005, 12:04 Uhr

Beeblebrox
Posts: 723
Nutzer
Dieser Chip von Lattice wird ein CPLD oder ähnliches sein. Also kein
Mikrocontroller sondern eine integrierte Logikschaltung - das was
früher mit TTL-ICs aufgebaut wurde. Die sind dann entsprechend
programmiert und können keinesfalls ausgelesen werden, da hier
kein Programm programmiert wird, sondern intern Leiterbahnen gesetzt
oder zerstört werden um die entsprechende Funktion zu erhalten.
Aber vielleicht bekommt man ja Ersatz von Jens Schönfeld.
--
>>> bEeBlEbRoX <<<
http://www.endlosstudent.de

[ - Antworten - Zitieren - Direktlink - ]

02.04.2005, 18:56 Uhr

Lemmink
Posts: 2344
Nutzer
Zitat:
Aber vielleicht bekommt man ja Ersatz von Jens Schönfeld.
Laß das bloß Michael nicht hören, daß Jens schon wieder mit seiner Hardware in Verbindung gebracht wird I-)
--
Das Grauen hat viele Gesichter und mein Spiegel zeigt mir jeden Morgen ein neues.

Jetzt neuer, aber immer noch nicht interessanter: http://www.lemmink.joice.net

[ - Antworten - Zitieren - Direktlink - ]

05.04.2005, 23:22 Uhr

platon42
Posts: 400
[Ex-Mitglied]
Zitat:
Original von aPEX:
hallo leute,

also gestern habe ich es auch geschafft meine nagelneue
subway (weihnachtsgeschenk) in die luft zu jagen. :( :(

habe nirgends eine dokumentation finden koennen wo pin1
auf der xsurf ist, bin aber auch nicht der beste googler :)
einen thread dazu gab es hier schon auf anews (2003), dem
konnte ich aber auch nicht soviel informationen entnehmen...


Mit ein wenig Googlen z.B. nach "Subway Clockport X-Surf" wärst Du ziemlich schnell auf

http://www.amiga-news.de/forum/thread.php3?id=5583&BoardID=1


gestoßen (falls das nicht der Thread ist, den Du oben erwähnt hast). Im Falle von Unsicherheiten hätte eine Mail an Michael Böhmer genügt.
Eine tote Subway kann auch so aussehen: http://www.e3b.de/usb/main_mounting_d.html


Die Anleitung ist diesbezüglich auch ziemlich explizit:

"Die Karten unterschiedlicher Hersteller unterscheiden sich in der Orientierung der Clockport-Pinleiste. Bitte überprüfen Sie die richtige Ausrichtung des Flachbandkabels vor dem Anschluß, andernfalls kann die SUBWAY und/oder Ihr Amiga zerstört werden."

Ich behaupte mal, wenn die Subway mehr als eine Sekunde verpolt angeschlossen war, ist sie tot. Mausetot. Irreparabel (wenn Dir z.B. Leiterbahnen auf dem PCB weggeschmolzen sind).
--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 00:10 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
schreib doch ne Email an Michael oder jens.
sollten doch immer die ersten Ansprechpartner sein.


Hat er schon, und wir sind bereits dabei, eine Lösung auszuarbeiten.

Leider ist die Anleitung zur Xsurf in Punkto Clockport eher... naja... minimalistisch, und alle heiligen Zeiten erwischt es wieder eine unschuldige SUBWAY :(

Michael

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 00:18 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Verpolt heisst nicht immr gleich defekt.

Leider in fast allen Fällen falsch.

Zitat:
Kann z.B. nur eine Leiterbahn und Kondensatoren defekt sein.
1. kann qualmen, 2. kann knallen+Qualmen.


Leider auch falsch. Es kann
- den Überstromschutz-IC erwischen
- den CPLD erwischen
- den USB-Hostkontroller erwischen
- die Leiterbahnen abbrennen
- IC-Pins mit dem Kupfer der Bahnen verschweissen

Und zwar jeweils mit beliebigen Fehlerbildern. Wir hatten schon SUBWAYs, die so eine Misshandlung überstanden zu haben schienen - nur hat der CPLD dann seine Programmierung immer wieder "vergessen", oder der Interrupt-Pin des USB-Kontrollers war tot, oder... meiner Erfahrung nach ist es nach dem Verpolen aus.

Zitat:
Man sollte sich vielleicht einen Verpolungsschutz bauen.

Da haben wir auch dran gedacht, es aber wegen des ohnehin knappen Powerbudgets für USB nicht implementieren können. Die zusätzlichen 0.6V fehlen dann am USB-Stecker, was zu Problemen mit angeschlossenen Geräten führen kann.

Die einzige Lösung wäre, daß alle Hersteller von Clockport-Karten ihre Hardware ordentlich dokumentieren - und Kunden im Zweifelsfall *vorher* nachfragen.

Michael

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 00:20 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
ja richtig nur kannst du die nicht einfach so auslesen da gibt es eine protection gegen.

Und die ist gesetzt :-)
Das Zurücksetzen der Read-Protection ist nur durch einen Bulk Erase des Chips möglich. Und das ist gut so.

Michael

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 00:24 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
kein Programm programmiert wird, sondern intern Leiterbahnen gesetzt
oder zerstört werden um die entsprechende Funktion zu erhalten.


Nicht ganz: moderne CPLDs sind reprogrammierbar. Hier werden keine Fuses mehr geschossen (wie anno Tobak bei PALs), sondern FlashROM-Zellen gesetzt oder gelöscht, die dann wiederum Verbindungen zwischen den einzelnen Signalen herstellen.

Zitat:
Aber vielleicht bekommt man ja Ersatz von Jens Schönfeld.

Argl. Mehr sog I ned.

Michael

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 03:25 Uhr

checker
Posts: 640
Nutzer
Zitat:
Original von mboehmer:
Zitat:
ja richtig nur kannst du die nicht einfach so auslesen da gibt es eine protection gegen.

Und die ist gesetzt :-)
Das Zurücksetzen der Read-Protection ist nur durch einen Bulk Erase des Chips möglich. Und das ist gut so.

Michael


wäre auch ziemlich dumm wenn die nicht gesetzt wäre...

dann könnte man ja ziemlich einfach ( naja relativ einfach.. ) die karte nachbauen.

der clpd ist ja das herzstück der subway.

ich kenne keine erweiterung wo die read protection nicht gesetzt ist.

wer die nicht setzt ist auch selber schuld..

cu




--
AOne G4 1000 512 MB Fast
A4000 T 200 604e 060/50 144 MB Fast
A1200 T 240 603e 060/50 245 MB Fast
A500 030 50 8 MB Fast
CDTV original =)
und und und..

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 08:22 Uhr

MaikG
Posts: 5172
Nutzer
@mboehmer
wie gesagt meine Subway hats überlebts waren <5 sekunden.
Ist es nicht möglich einen Schutz im Stecker/buchse einzubauen
wie bei IDE wo der Pin fehlt?

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 09:08 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
der clpd ist ja das herzstück der subway.

Ja, da steckt einiges an Wissen drinnen (Clockport ist ja leider nicht gleich Clockport).

Zum Glück rechnet sich der Nachbau einer SUBWAY nicht, dazu ist der Markt wohl schon zu klein (siehe auch das angekündigte Konkurrenzprodukt, die UltraBUS, die ist auch nie offiziell rausgekommen).

Allerdings gibts mittlerweile Firmen, die aus PCBs (zu denen es keine Produktionsdaten mehr gibt) mit modernster Technik wieder Gerber-Daten erzeugen - mittels Scannen, Röntgen und ähnlichen.
Und wer wirklich an die Programmierdaten von CPLDs oder Flash-FPGAs kommen will, schafft das auch - der Aufwand dazu ist aber ziemlich hoch bis fast unmöglich (grade die neuesten Actel Flash-FPGAs haben da einige nette Features... Verschlüsselung des Programmierdatenstroms mit 128bit AES, oder spezieller Lagenaufbau des Dies).

Gruss Michael

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 09:14 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
wie gesagt meine Subway hats überlebts waren <5 sekunden.

Glück gehabt, oder ein altersschwaches Netzteil :)
Ich würde sowas aber nicht allzu oft probieren.

Zitat:
Ist es nicht möglich einen Schutz im Stecker/buchse einzubauen
wie bei IDE wo der Pin fehlt?


Nein, leider nicht. Du hast zwei "Problemstellen": a) Stecker der SUBWAY + Kabel - erste Möglichkeit, was falsch zu machen. b) Kabel + Clockport - zweite Möglichkeit.

Dazu kommt noch: manche 1200er haben keinen Clockport, sondern eine falsch aufgelötete Stiftleiste, und zusätzlich kannst du ohne Probleme
das Clockportkabel auch um einen Stift versetzt aufsetzten, oder um 180Grad verdreht.

Wie du es auch anstellst, es bleiben immer noch Möglichkeiten offen, die SUBWAY zu rösten :-(

Das einzige, was hilft, ist:
- Anleitung der SUBWAY *genau* lesen (da sind viele Bildchen drin)
- Anleitung der Clockportkarte (falls kein A1200) genau lesen
- Kabelverbindung zweimal checken
- im Zweifelsfall auf die E3B-Webseite schauen
- oder eine Mail an E3B schicken

Gruss Michael

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 13:51 Uhr

MaikG
Posts: 5172
Nutzer
>Das einzige, was hilft, ist:

Ja hatte mir auch extra die Anleitung runtergeladen etc.
aber man muss manchmal was ändern. Auf dem ZIV-Board sind z.B.
auch 4 Uhrenports wo die Karten nicht immer in die richtige richtung
zeigen.

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 17:17 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
aber man muss manchmal was ändern. Auf dem ZIV-Board sind z.B.
auch 4 Uhrenports wo die Karten nicht immer in die richtige richtung
zeigen.


Nun ja, was soll man ändern? Ich kann nicht für jedes Busboard oder Zorro-Karte, die einen Clockport hat und jemals auf den Markt gekommen ist, das in die Anleitung mit aufnehmen.

Michael


[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 18:56 Uhr

MaikG
Posts: 5172
Nutzer
Auf Wannen-stecker umrüsten und jeder der was mit
Uhrenportanschlüssen baut muss schon welche drauf machen :-)

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 21:50 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Auf Wannen-stecker umrüsten und jeder der was mit
Uhrenportanschlüssen baut muss schon welche drauf machen :-)


Gute Idee - wenns jetzt noch standardgemäß 22polige Wannenleisten mit 90Grad Montage Winkel gäbe, wäre das eine Möglichkeit.
Dummerweise wird niemand die 1200er im Felde sowie die Tausende von Zorro-Karten mit Clockport umrüsten. Das geht ins Leere.

Maik, so gerne ich eine konstruktive Lösung für das Verpolen anbieten würde - es *geht nicht*. Der Clockport ist per Design nicht verpolungssicher.

Eine Lösung elektronischer Art, die *alle* möglichen Fehlbedienungsversuche jedes DAUs(*) abfängt, wäre schon was - kannst ja gerne einen Vorschlag machen :-(

Michael

(*) nein, nicht Apex. Wir hatten auch schon Leute, die eine ALGOR um 180Grad verdreht eingebaut haben, weil sie gehofft hatten, dass sie dann schneller ist (?)...

[ - Antworten - Zitieren - Direktlink - ]

06.04.2005, 22:50 Uhr

GolfSyncro
Posts: 1455
Nutzer
[quote]
Original von mboehmer:
Zitat:
Gute Idee - wenns jetzt noch standardgemäß 22polige Wannenleisten mit 90Grad Montage Winkel gäbe, wäre das eine Möglichkeit.

Ne aber wie wäre es wenn du ein Pin an der seite bei der subway farblich markieren könntest schon vielleicht im platinen layout dann hat man schon mal eine fehler quelle weniger?
Sprich da wo der sogenannte "Pin1" ist muß das Kabel mit der roten ader hin.... nur so als vorschlag

--
Mfg
GolfSyncro


[ - Antworten - Zitieren - Direktlink - ]

07.04.2005, 08:15 Uhr

MaikG
Posts: 5172
Nutzer
Gute Idee. Hab meine Kabel/Uhrenportkarten mit einem Edding
angemalt.

[ - Antworten - Zitieren - Direktlink - ]

07.04.2005, 08:48 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Ne aber wie wäre es wenn du ein Pin an der seite bei der subway farblich markieren könntest schon vielleicht im platinen layout dann hat man schon mal eine fehler quelle weniger?
Sprich da wo der sogenannte "Pin1" ist muß das Kabel mit der roten ader hin.... nur so als vorschlag


Nur so als Gegenvorschlag: lies mal die SUBWAY-Anleitung, Seite 6.
(http://www.e3b.de/usb/ -> Support -> Anleitungen)

Auf der PCB ist ein kleiner goldener (neue Serie) bzw. silberner (alte Serie) Pfeil, der genau das macht.

Michael

[ - Antworten - Zitieren - Direktlink - ]

07.04.2005, 10:29 Uhr

engine5
Posts: 330
Nutzer
:-)




...RTFM!? :lickout:

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Subway + X-Surf Clockport = Rauch :-( [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.