amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Programmierung > Probs mit Picasso96 Programmierung [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

08.01.2002, 08:25 Uhr

Micha1701
Posts: 938
Nutzer
Hallo zusammen!

Ich versuche mich gerade in der Programmierung von Picasso96. Dazu benutze ich StormcV3 prof. auf WinUAE V0.8.8R8 (für WinNT4).

Das Developerarchiv hab ich von der Picasso96 HP runtergeladen und entpackt. Die einzelnen include-Dateien hab ich entsprechend gespeichert. Allerdings kommt mir die Picasso96API.lib komisch vor. Sie ist nur 408 bytes groß. Nochmaliges runterladen des Archivs brachte keine Veränderung.

Nun ja, ich hab nun ein Programm geschrieben, daß Picasso96 Routinen benutzen soll. Wenn ich es aber kompilieren will, bekomme ich folgende Fehlermeldungen:


Fehler: Syntax-Fehler in einem "#pragma".
... Zeile 17: #pragma libcall P96Base p96WritePixelArray 66 5432910808
... Zeile 18: #pragma libcall P96Base p96ReadPixelArray 6C 5432910808
... Zeile 22: #pragma libcall P96Base p96WriteTrueColorData 84 5432910808
... Zeile 23: #pragma libcall P96Base p96ReadTrueColorData 8A 5432910808

Fehler: Die "#pragma amicall"-Deklaration ist für überladene Funktionen nicht erlaubt.
... Zeile 31: #pragma libcall P96Base p96PIP_GetMsg a8 801
... Zeile 32: #pragma libcall P96Base p96PIP_ReplyMsg ae 901
... Zeile 38: #pragma libcall P96Base p96WriteYUVRect c6 a5432910809
... Zeile 39: #pragma libcall P96Base p96WriteYUVRectTags c6 5432910809


Wenn ich einfach die proto/Picasso96.h ändere und somit die pragmas/Picasso96_pragmas.h weglasse, wird das Programm zwar kompiliert, aber es erscheint dann folgender Fehler:


LinkerFehler: Symbol "_autoopenfail" nicht definiert (Hint "").
TOC: symbol_autoopenfail


Weiß jemand Rat? Soll ich vielleicht noch den Quelltext hier reinstellen? Wobei da zur Zeit noch kein P96 Aufruf drin steht.... also wäre das nicht besonders hilfreich (glaub ich)....

--

:boing: Micha :boing:


[ Dieser Beitrag wurde von Micha1701 am 08.01.2002 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

08.01.2002, 12:56 Uhr

thomas
Posts: 7662
Nutzer

Das sieht für mich so aus, als wären die Pragmas nicht für StormC geeignet. Es gibt da von Compiler zu Compiler sehr verschiedene Syntax-Varianten. Viele Pragma-Dateien arbeiten deshalb mit vielen #ifdef's, um es jedem Compiler recht zu machen.

Du könntest es mal mit dem Cybergraphics Developer-Archiv versuchen. CGX funktioniert unter P96 auch, die Funktionen werden dort emuliert. Das hat den Vorteil, daß du auch CGX-User beliefern kannst, ohne eine neue Programmversion zu schreiben.

Außerdem solltest du den Gebrauch von speziellen P96- oder CGX-Funktionen stark limitieren. Die meisten Sachen kannst du ohne weiteres auch mit den standard graphics.library Funktionen machen. Die funktionieren auch mit 16- und 24bit-Screens. Ein Beispiel dafür ist mein Programm PicShow. Ich habe es auch unter WinUAE entwickelt und ziele hauptsächlich auf Grafikkarten-Benutzer. Es benötigt aber nur an einer einzigen Stelle eine spezielle 24bit-Funktion. Diese habe ich dann der CGX-Library entnommen, da die auch unter P96 funktioniert. Ansonsten funktioniert das Programm auf jedem Amiga.

Gruß Thomas

--
Email: thomas-rapp@web.de

Home: home.t-online.de/home/thomas-rapp/


[ - Antworten - Zitieren - Direktlink - ]

08.01.2002, 13:37 Uhr

Micha1701
Posts: 938
Nutzer
Hi!

Danke für den Hinweis...

In der tat wird in den pragmas nach Gcc und sonstigen unterschieden.
Aber sonstiges macht wohl probleme...

Vielleicht laufen die GCC pragmas mit StormC?

Mal probieren...

Wenn CGX auch auf P96 läuft - ok, dann versuch ich mich halt damit...

Danke nochmal!

--

:boing: Micha :boing:

[ - Antworten - Zitieren - Direktlink - ]

08.01.2002, 22:19 Uhr

David
Posts: 65
Nutzer
Hallo

dem Developerarchiv liegt bestimmt das #?.fd file bei.
Mit fd2pragma (im Aminet zufinden) kann man die pragmas
auch für StormC erzeugen.

mfg
David

[ - Antworten - Zitieren - Direktlink - ]

09.01.2002, 08:53 Uhr

Micha1701
Posts: 938
Nutzer
Hi David!

Danke für den Tip. Habs mal ausprobiert. Und tatsächlich, es funktioniert.... zum Teil.

Es sind nicht mehr so viele Fehlermeldungen wie vorher. Lediglich p96PIP_GetIMsg und p96PIP_ReplyIMsg werden noch angemeckert....

Ich glaub ich versuchs mal mit CGX....

Danke trotzdem!

--

:boing: Micha :boing:

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Programmierung > Probs mit Picasso96 Programmierung [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.