amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Andere Systeme > Linux und Karten am Uhrenport [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

15.07.2001, 21:04 Uhr

Schorchgrinder
Posts: 617
Nutzer
Wie ist das so mit der Hypercom /Silversurfer werden die unterstützt oder muß man sich die Treiber selbst schreiben?
Wobei sich meine Programmierfähigkeiten auf


10 PRINT "Hallo Welt"
20 GOTO 10

RUN


erschöpfen.:shock2:
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

16.07.2001, 16:28 Uhr

Hammer
Posts: 2899
Nutzer
Hängt von Deiner Distrubition ab! Wahrscheinlich ist aber keine der Karten schon mit drin. (Ohne Gewähr) Müßte aber irgendwo dabei stehen, was schon unterstützt wird!

MFG

Hammer

PS.: erinnert mich an MACOSX :) )
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

17.07.2001, 20:19 Uhr

AndiW
Posts: 298
Nutzer
Hallo Schorchgrinder

Das wie Hammer gesagt hat, dies von der Distro abhängt, kann ich so nicht stehen lassen. Es hängt nämlich, um ehrlich zu sein, überhaupt nicht von der Distro ab, sondern vom Kernel. Also, schau mal bei APUS ( http://sourceforge.net/projects/linux-apus ) vorbei, uns downloade Dir je einen 2.2.10 und einen 2.4.x kernel, und schau im modules Verzeichnis, was alles dabei ist, bzw. im Begleitfile, in dem stehet, welche Sachen direkt in den kernel und welche als module kompiliert worden sind. Wenn Du dort etwas zu Deinen Karten findest, ist schon mal ein grosser Schritt getan. Dann hilft nur noch ausprobieren. Fall der Treiber als module ausgeführt ist, kannst Du ihn einfach als root mit modprobe nachladen!


Viel Spass mit Linux

AndiW

[ - Antworten - Zitieren - Direktlink - ]

17.07.2001, 20:23 Uhr

Hammer
Posts: 2899
Nutzer
Stimmt ja! War mir aber nicht mehr so sicher, ist bei mir schon wieder über ein Jahr her!

MFG

Hammer

PS.: Buch ist schon eingepackt, vielleicht schaffe ich es morgen noch. Die werden nämlich bei uns gedruckt! :) )
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

17.07.2001, 20:38 Uhr

Schorchgrinder
Posts: 617
Nutzer
Die Hypercom wird aufgerufen vom Kernel aber beim Silbersurfer beim ich mir da nicht so sicher.
Der 2.4 Kernel schmiert bei mir ab.

--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

17.07.2001, 22:05 Uhr

AndiW
Posts: 298
Nutzer
Hallo Schorchgrinder

>Der 2.4 Kernel schmiert bei mir ab.

Was heisst das genau? Wie äussert es sich (Kernel Panic, Oopses)? Welche Kernel-Version benutzt Du genau? Stürzt er bei modprobe oder bei normalem Betrieb ab? Hasst Du einen Fehler betreffend Floating Point Code?

Und wichtig: Welche Hardware benutzt Du? Es sollte nämlich bald Kernel-Version 2.4.6 kommen, die einige Fehler im VM behenben sollte, die vorallem 604er Prozessoren (sprich CSPPC-Besitzer) betreffen.

Herzliche Grüsse, AndiW

[ - Antworten - Zitieren - Direktlink - ]

18.07.2001, 20:01 Uhr

Schorchgrinder
Posts: 617
Nutzer
Er meldet Kernel Panic schon beim Hochfahren hatte ich Probs also habe ich den Vorgänger genommen.
System 40/25;603/175;irgendwann mal BV und 128 MB Fast
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

18.07.2001, 20:56 Uhr

AndiW
Posts: 298
Nutzer
Hallo Schorchgrinder

Also, schon beim hochfahren Kernelpanik? Was gibt dmesg aus? Startest du den kernel mit -v (verbose) um alle Meldungen anzuzeigen (eigentlich immer interessant!)?

Und: Du hast den Vorgänger benutzt. Welcher war nun der Kernel, der nicht ging, und welches der, der dann lief (Vorgänger gibt es beim Linux kernel viele...).

Und wie war die Kernelpanik? Kein Hearbeat mehr? Oder stand ganz einfach, dass der Kernel nicht booten konnte, und es werde ein Restart in 180 Sekunden ausgeführt?


Herzliche Grüsse, AndiW

[ - Antworten - Zitieren - Direktlink - ]

18.07.2001, 21:14 Uhr

Schorchgrinder
Posts: 617
Nutzer
Die genaue Kernel Nummer kann ich dir erst morgen geben sitzte gerade am PC.
Aber er wollte in der besagten Zeit neubooten.
Mit -v habe ich ihn noch nicht laufen lassen.
Schaun wir mal.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

18.07.2001, 22:23 Uhr

AndiW
Posts: 298
Nutzer
Hi

Kein Problem, gib die Kernelversion nur morgen durch.


Also, ich benutze folgende Syntax, um Linux zu booten:

bootstrap --apus -v -k vmlinux root=/dev/hda3 video=pm2fb:mode:1024x768-75


Für Dich interessant wäre wohl nur die korrekte Stellung von -v, die hda3 ist SuSE-Linux spezifisch (root-Partition liegt auf der 3. Partition).

Du hast AZT-ev Linux, stimmt das? Hmm, dann verwendest Du wohl auch deren Kernel (auf jedenfall bei mir war noch ne selber kompilierte Version drauf, bin heute immer noch sehr froh drum unter SuSE-Linux [nur der AZT 2.2.10 Kernel hatte Unterstützung für MS-DOS partition tables drin]). Wies heute ist, weiss ich aber nicht genau!


Also, mail mal was Du so laufen hast!

Liebe Grüsse, AndiW


PS: Das mit dem neu booten klingt interessant!

[ Dieser Beitrag wurde von AndiW am 18.07.2001 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

19.07.2001, 17:01 Uhr

Schorchgrinder
Posts: 617
Nutzer
Also bei mir läuft der 2.2.10 und der andere ist der 2.4Test4
nun bei der Install mit dem Kernel gab es schon Pobleme .
Gestern habe ich es noch mal getestet und siehe da kein Prob.
Wenn ich den anderen Kernel zum Starten verwende dann fährt Linux noch nicht einmal hoch.Die Power LED blinkt zwar aber der Bildschirm
bleibt weiß und nach ein paar Minuten fährt dann das AOS hoch.
Jetzt habe ich versucht den Kernel per Hand in meine bootstrap einzubinden ,dazu brauche ich doch bloß die vmlinux in das Verzeichniss zukopieren und die alte umzubenennen?
Das habe ich gemacht und da auch keine Probs ,nur wo kann man sich unter Linux die Version des Kernels anzeigen lassen.

Bevor ich es vergesse ,ich benutzt die AZT-Linux mit den dazu bestimmten Kerneln(mehrzahl von Kernel????)
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

19.07.2001, 22:05 Uhr

AndiW
Posts: 298
Nutzer
Ähhh, sorry, aber jetzt komm ich nicht mehr ganz draus! :dance3:

Also: Du hast 2.4Test4 zum installieren benutzt, was Dir aber etwelche Probs dabei eingebracht hat (welcher Art auch immer, ich nehme jetzt mal an Abstürze, oder hatte es was mit den Laufwerken zu tun?). Danach hast du nur noch 2.2.10 benutzt

>Gestern hab ich es nochmal getestet und siehe da, kein Prob.

Du hast nochmal neu installiert mit 2.4Test4? Oder nur normal laufen gelassen?

>Wenn ich den anderen Kernel zum Starten verwende dann fährt Linux noch nicht einmal hoch. Die PowerLED blinkt zwar, aber der Bildschirm bleibt weiss und nach ein paar Minuten fährt AOS hoch

Häähh? Welchen Kernel meinst Du jetzt da??

Danach hast Du den Kernel (2.4Test4?) ins Start-Verzeichnis kopiert und in vmlinux umbenannt? Und dann gings? Wieso gings dann oben nicht?? Bitte genauere Details!! X(


Die Kernel Version bekommst Du ganz eifach angezeigt: wechsle mit Alt+F2 in eine andere Konsole als die Start-Konsole, dort wird im Begrüssungstext die Kernelversion angezeigt! Es gäbe auch noch einen Befehl, um es Dir sonst auf der Konsole anzeigen zu lassen, aber den habe ich vergessen..

PS: Hast Du ein Buch über Linux? Ich würde Dir "Linux - Wegweiser zu Installation & Konfiguration" von Welsh, Dalheimer (ja, KDE Dalheimer) & Kaufman im O'Reilly Verlag empfehlen. Wenn Du eine komplette Befehlsübersicht willst, würde ich "Linux in a Nutshell", auch aus dem O'Reilly Verlag raten. Davon gibts mittlerweilen sogar ein Übersetzung der aktuellsten Auflage (3. Auflage wenn es mir recht ist). Im erstgenannten Buch kannst Du auch online schmökern, geh mal auf die deutsche O'Reilly Site und schau dort nach. Das ganze Buch ist im Web lesbar!

Also, mail noch mal, falls Du weitere Angaben hast!

Und, achja, ganz wichtig: welche AmigaOS Version benutzt Du (wegen bootstrap), und welche bootstrap Version benutzt Du? Ansonsten kannst Du auch mal vorkompilierte Kernel von der APUS-Website benutzen! Achtung: Ich möchte hier auf GAR KEINEN FALL die Arbeit des AZT schlechtmachen (vielleicht tönt es manchmal so)!!! Ich habe halt mehr Erfarungen mit den von APUS vorkompilierten Kerneln gemacht, aber ich benutze heute noch den AZT 2.2.10er Kernel!!


Herzliche Grüsse, AndiW

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 18:48 Uhr

Schorchgrinder
Posts: 617
Nutzer
Mein Fehler,ich habe mit dem 2.2.10 Linux installiert und mit dem 2.4.test-4 getestet und der lief nicht.
Dann habe ich ihn nochmal getestet und da lief der Testkernel.
Aber zum starten geht er halt nicht.Das System fährt hoch ,greift 2x kurz auf die Platte zu und das wars ,kein Screen ,nix und wenn ich warte läd dann das Aos.
Also der 2.2.10 ist der bei mir läuft.
Bücher habe ich vom Hammer und da kann ich erstmal lesen.
Ich habe den Test gestern mit der Update_installation von Redhat gemacht ,aber der 2.4 ist schon beim hochfahren abgekackt, nur gestern ist er ohne Probs hochgefahren und ich hätte die Installtion
durchführen können.
Der Kernel ist doch das vmlinux was im Bootstrap geladen wird?
Und da habe ich die VMlinux aus dem Start-2.4Test-Kernel in mein Verzeichniss rein kopiert und denn anderen vmlinux(2.2.10) umbenannt.
So das bootstrap den neuen vmlinux geladen hat.
@Linux in a Nutshell
sollte es das Buch auch im Handel geben oder muß man das bestellen?
Ich habe es noch nicht gesehen ,aber war auch noch nicht überall.
Meine Aos ist kick 3.1 & Work 3.1 ,die bootstrap kann ich dir so aus dem Sehgreif nicht sagen.
Meine Frage wegen dem Kernel Version ,die wird beim hochfahren angezeigt!:)
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 21:00 Uhr

AndiW
Posts: 298
Nutzer
Hmm, also so wie ich das soweit verstanden habe, klappt es manchmal, mit dem 2.4Test4 Kernel zu booten, und manchmal nicht, stimmt das?

>Aber zum starten geht er halt nicht, ...

Öööhhh, aber Schorchgrinder, um einen anderen Kernel zu benutzen musst Du ja Linux neu booten?!!

Das was Du gemacht hast mit kopieren und umbenennen in vmlinux ist übrigens korrekt. Ich mache es meistens so, dass ich die alles in ein directory rein tue, dann kopiere ich es, und ersetze den linuxkernel, damit kann ich nach belieben in verschiedene Kernelversionen booten!

Wie gesagt, versuch mal einen 2.4.4er Kernel von der APUS Website, sind keine Test mehr, und nicht sehr gross zum donwloaden (ca. 1.4 MB), aber Du musst selbst entscheiden, ob Du überhaupt einen neuen Kernel brauchst, oder nicht gescheiter einfach den 2.2.10 fährst, und Dich auf das Benutzen von Linux konzentrierst, als ständig mit Kerneln herumzuprobieren (mache ich eben, und komme deswegen fast nie dazu, Linux auch wirklich zu benutzen, was ja eigentlich viel entspannender wäre...).

Aber wie gesagt, lade Dir mal die neuste (oder die zweitneuste, ist noch am weitesten verbreitet) bootstrap Version von der APUS Website bei Sourceforge, inkl. dmesg (findest Du ebenfalls dort). Dann setzt Du deine bootstrap Zeile wie folgt:

bootstrap --apus -d debug=mem -k vmlinux und so weiter

Wichtig ist hier natürlich -d debug=mem nach dem --apus Argument! Dann fährst Du mal mit dem 2.4TEst4 Kernel hoch (der, der nicht hochziehen will und nach 3 Minuten einen reset macht). Da Du ja kein Bild hast dort, bringt Dir auch die -v (verbose) option nichts. Nach dem restart gehst Du im AmigaOS in eine shell und tippst dmesg ein, und postest dann den Output hier (oder auf der Linux APUS devel list), und dann schaun wir mal weiter, was er der Kernel da bemängelt.


PS: "Linux in a Nutshell" gibt es überall im Handel (wie alle anderen O'Reilly Bücher auch), also auf jedenfall hier in der Schweiz! Sollte doch in jeder grösseren Buchhandlung vertreten sein, ist es das nicht?


Also, bis später, Grüsse, AndiW

[ Dieser Beitrag wurde von AndiW am 20.07.2001 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.07.2001, 20:38 Uhr

Schorchgrinder
Posts: 617
Nutzer
Der Kernel bootet zu Installation seit ein paar Tagen ohne Probs ,nur beim eigendlichen läd er nicht.
Mir ist da noch was eingefallen ,ich werde mal die ide=doubel aus de Bootstrap entfernen.
Die neunen Kernel bekomme ich bald zugeschickt ,da ich mir noch die Erweiterungs CDs zulege.
Aber ich werde den 2.4.Test mal mit debug testen schaun wir mal.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

24.07.2001, 19:21 Uhr

Schorchgrinder
Posts: 617
Nutzer
So ich habe es getestet ,und habe als erstes festgestellt das debug=mem muß ans ende von der bootstrap.
Das habe ich gemacht und habe nach dem der Kernel rumgeladen hat , habe ich dmesg gestartet mit dem Ergebniss das es diese savedsck nicht gefunden hat.
Ich habe es noch mit verschieden Varianten bei der bootstrap probiert und nix wars.
Habe es mal mit dem 2.2.10 ausprobiert und da funzt es.
Liegt also am Kernel der mag irgendwas nicht (2.4) ,er läd auch immer aud der HdaX und nicht wie in der bootstrap angegeben auf der Hbd1.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

24.07.2001, 20:41 Uhr

AndiW
Posts: 298
Nutzer
Am besten postest Du mal deinen bootstrap-Aufruf sowie die ganze dmesg Ausgabe, dann können wir weitersehen!

Grüsse, AndiW

[ - Antworten - Zitieren - Direktlink - ]

25.07.2001, 18:35 Uhr

Schorchgrinder
Posts: 617
Nutzer
Ich habe heute die LinuxerweiterungsCDs bekommen ,da sind neue Kernels drauf ,schaun wir mal .
Ich werde nur die nächste Zeit nicht mehr so oft dazu kommen ,am Linux rumzuspielen.
--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]

25.07.2001, 20:47 Uhr

AndiW
Posts: 298
Nutzer
Yup, versuchs mal mit den neueren Kernels!!!

Bis die posts!!

Herzliche Grüsse, AndiW

[ - Antworten - Zitieren - Direktlink - ]

09.08.2001, 22:31 Uhr

katodev
Posts: 42
Nutzer
Zitat:
Original von Schorchgrinder:
Die Hypercom wird aufgerufen vom Kernel aber beim Silbersurfer beim ich mir da nicht so sicher.


Alle Uhrenportkarten verwenden die 16Cx5x Bausteine und hängen auf den gleichen Adressen und am gleichen IRQ. Ob sie Hypercom, Silversurver oder Twister heissen. Allerdings nutzen sie andere Quarze. Daher muss der Teiler definiert werden. Dazu gibt es bestimmt ein Modulparameter.

C.U.

JP

[ - Antworten - Zitieren - Direktlink - ]

12.08.2001, 14:41 Uhr

Schorchgrinder
Posts: 617
Nutzer
Das hat sich erledigt ,ich werde mir jetzt eine Hypercom holen und
dann ist Schluß mit lustig.

--
CU Schorchgrinder

aMIGA & cannBAL CORpse rULES


123456789 :bounce: 987654321

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Andere Systeme > Linux und Karten am Uhrenport [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.