amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Forum und Interna > TODO-Liste / Ideen [ - Suche - Neue Beiträge - Registrieren - Login - ]

Erste 3 4 5 6 7 -8- [ - Beitrag schreiben - ]

09.11.2006, 13:11 Uhr

Holger
Posts: 8041
Nutzer
Zitat:
Original von _PAB_:
@MaikG:
JavaScript ist bei Smilies und den UBB-Code-Buttons nicht ohne massiven Mehraufwand verzichtbar.


Ich könnte mir nicht vorstellen, wie das dynamische Einfügen von Text ohne JavaScipt überhaupt funktionieren soll.

Aber man könnte den zugehörigen Links ein title Attribut geben, das das zugehörige Tag als Vorlage, z.B. [url=Adresse]...[/url] anzeigt, so dass man es bei Browsern, die es unterstützen, als ToolTip sehen kann. So sieht man auch ohne JavaScript, was man manuell tun muss, um das gleiche zu erreichen.

mfg

PS: Weil ich in diesem Zusammenhang gerade in den Script-code geguckt hatte if(!thisCode == "") erweckt den Eindruck, dass der Programmierer schon leicht überarbeitet war. Ich kenn das, da kann man nicht mehr in einfachen Bahnen denken. Die Steigerungsform wäre if((thisCode == "")==false) :D

[ - Antworten - Zitieren - Direktlink - ]

09.11.2006, 14:57 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
> Ich könnte mir nicht vorstellen, wie das dynamische Einfügen von Text ohne JavaScipt überhaupt funktionieren soll.

Ich schon, aber da ich keine Lust habe *das* mit PHP zu programmieren, behalte ich es lieber für mich.

Den Link-Title werde ich machen.
Und den JS-Code muß ich mir wohl mal ansehen, der ist nicht von mir.

[ Dieser Beitrag wurde von _PAB_ am 09.11.2006 um 15:04 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

09.11.2006, 17:27 Uhr

Holger
Posts: 8041
Nutzer
Zitat:
Original von _PAB_:
Ich schon, aber da ich keine Lust habe *das* mit PHP zu programmieren, behalte ich es lieber für mich.

Ach so, so geht das natürlich. Aber ein komplett neuer Seitenaufbau für 5 einzufügende Zeichen wäre ja nu wirklich unsinnig. Würde ich an Deiner Stelle auch nicht implementieren.
Zitat:
Und den JS-Code muß ich mir wohl mal ansehen, der ist nicht von mir.
Na ja, war eh Erbsenzählerei von mir. Iss nur immer wieder amüsant, wenn man drüber stolpert...

mfg

[ - Antworten - Zitieren - Direktlink - ]

11.11.2006, 15:35 Uhr

_PAB_
Posts: 3016
Nutzer
Ab sofort kann jeder seine eigenen Threads im Kleinanzeigenboard schließen.
Siehe Link am Schluß der Seite.
Diese Möglichkeit gibt es allerdings nur im Kleinanzeigenboard.

[ - Antworten - Zitieren - Direktlink - ]

11.11.2006, 18:00 Uhr

_PAB_
Posts: 3016
Nutzer
Zusätzlich werden noch offene Kleinanzeigen nun vor den geschlossenen angezeigt.

[ Dieser Beitrag wurde von _PAB_ am 11.11.2006 um 18:03 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.11.2006, 21:56 Uhr

MaikG
Posts: 5172
Nutzer
>Den Link-Title werde ich machen.

Danke!

[ - Antworten - Zitieren - Direktlink - ]

16.11.2006, 14:09 Uhr

Solar
Posts: 3674
Nutzer
Zitat:
Original von Holger:

PS: Weil ich in diesem Zusammenhang gerade in den Script-code geguckt hatte if(!thisCode == "") erweckt den Eindruck, dass der Programmierer schon leicht überarbeitet war. Ich kenn das, da kann man nicht mehr in einfachen Bahnen denken. Die Steigerungsform wäre [courier]if((thisCode == "")==false)


Waaaaah!

Da ! stärker bindet als == haben wir hier ein

if ( ( ! thisCode ) == "" )

...was mit hoher Wahrscheinlichkeit nicht das ist, was der Autor hier wollte...

[ - Antworten - Zitieren - Direktlink - ]

16.11.2006, 15:21 Uhr

_PAB_
Posts: 3016
Nutzer
JavaScript-Code wurde geändert. Besser so / Einwände ?

[ - Antworten - Zitieren - Direktlink - ]

16.11.2006, 15:50 Uhr

Holger
Posts: 8041
Nutzer
Zitat:
Original von Solar:
Waaaaah!

Da ! stärker bindet als == haben wir hier ein

if ( ( ! thisCode ) == "" )

...was mit hoher Wahrscheinlichkeit nicht das ist, was der Autor hier wollte...


Du vergisst, dass Du es hier nicht mit einer normalen Programmiersprache zu tun hast.

Statt
if ( ( ! thisCode ) == "" )
kannst Du auch nach Belieben
if ( ( ! thisCode ) == false )
oder
if ( ( ! thisCode ) == 0 )
schreiben.
Also,
if ( ( ! thisCode ) == "0" )
würde auch gehen... Das macht genau das, was der Autor wohl ursprünglich wollte, wenn auch eher zufällig, denn das wäre selbstverständlich etwas anderes als if ( ! (thisCode == "0") )

Ich würde
if ( thisCode )
oder
if ( thisCode!="" )
bevorzugen. ;)

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

16.11.2006, 15:51 Uhr

Holger
Posts: 8041
Nutzer
Zitat:
Original von _PAB_:
JavaScript-Code wurde geändert. Besser so / Einwände ?


Danke.
Jetzt kann ich endlich wieder ruhig schlafen :sleep:

mfg

[ - Antworten - Zitieren - Direktlink - ]


Erste 3 4 5 6 7 -8- [ - Beitrag schreiben - ]


amiga-news.de Forum > Forum und Interna > TODO-Liste / Ideen [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.