amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Forum und Interna > TODO-Liste / Ideen [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- 3 4 5 6 7 Letzte [ - Beitrag schreiben - ]

08.01.2006, 21:40 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von AvE:
Huh, was spricht denn dagegen, den <span>-Tag global per CSS zu formatieren? Und was ist daran nicht HTML/CSS-konform?


Richtig lesen, bitte. <span> ist der richtige Weg. Ein eigenes Tag namens <smallfont> zu erfinden, ist falsch.

mfg

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

08.01.2006, 21:43 Uhr

Holger
Posts: 8033
Nutzer
Operationen am offenen Herzen sind gefährlich.

Ich bin mir sicher, daß der Thread namens "simplemail & yam - custom class konnte nicht erstellt werden" ursprünglich nicht mit zwei Postings mit dem Inhalt "testnachricht ;)" anfing...

http://www.amiga-news.de/forum/thread.php?id=20677&BoardID=1#204379

http://www.amiga-news.de/forum/thread.php?id=20677&BoardID=1#204380

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 01:21 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
1. zum Thread mit den Test-Nachrichten von mir:
Danke, hatte ich übersehen !

2. zu "HTML-3.2" und "HTML-4.0 Transitional":
wir haben HTML-3.2 mit Erweiterungen aus HTML-4.0 (CSS zB.), allerdings gibt es keine W3C-konforme Weise dies zu deklarieren. Und jeweils nur einen der beiden Standards zu verwenden ist gelinde gesagt großer Mist! Die Amiga-Browser verstehen sich nur auf HTML-3.2 und einige der verwendeten Elemente könnten wir nicht mehr benutzen - andererseits würde die Seite auf modernen Browsern dann ziemlich übel aussehen. Auf HTML-4.0 umzustellen ist ebenfalls ein Krampf, weil dann die Amiga-Browser garantiert außen vor bleiben und es obendrein noch einen Haufen unnütze Arbeit bringt.

3. unbekannte Tags wie <smallfont> u.ä.:
diese Tags werden einfach nicht interpretiert. Als Markierung für CSS sind sie aber unter Umständen noch brauchbar. Also können sie drinnen bleiben, da sie nicht stören.

4. Sehe ich auch keinen triftigen Grund, hier validiertes HTML-4.0 [Transitional] einzuführen.

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 10:32 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
3. unbekannte Tags wie <smallfont> u.ä.:
diese Tags werden einfach nicht interpretiert. Als Markierung für CSS sind sie aber unter Umständen noch brauchbar.

Sind sie nicht.
Zitat:
Also können sie drinnen bleiben, da sie nicht stören.
Warum zur Hölle willst Du es noch komplizierter machen?
Reicht es nicht, Amiga-Browser und moderne Brower unterstützen zu wollen? Willst Du unbedingt auch noch Fallunterscheidungen für das Verhalten bei fehlerhaften Html treffen müssen?
Der eine Browser filtert Unsinn wie frei erfundene Tags komplett raus (unterstützt also auch kein CSS für diese Tags), der nächste interpretiert es vielleicht tatsächlich und dann kommt irgendwann einer, der dabei komplett aussteigt.
Willst Du auch noch ständig alle neu erscheinenden Browser(-Versionen) auf ihr Verhalten überwachen müssen?
Was ist so schwer daran, <span class="smallfont"> statt <smallfont> zu schreiben?
Ich kann verstehen, daß diese Gratwanderung schwer ist, aber nicht, wenn es für ein Problem eine standard-Lösung gibt, bei der auch keinerlei Kompromisse eingegangen werden müssen.

Zitat:
Sehe ich auch keinen triftigen Grund, hier validiertes HTML-4.0 [Transitional] einzuführen.
Es gibt einen ganz einfachen: AN ist voll von Html-Fehlern. Wenn man die vermeidbaren entfernt, wird es irgendwann vielleicht auch mal möglich, die Fehler zu entdecken, die nichts mit der Abwärtskompatiblität zu tun haben.

Wobei es mir ohnehin jetzt so vorkommt, als ob die Kompatiblität mit Amiga-Browser nur noch eine faule Ausrede ist. Wahrscheinlich würden die Probleme mit den alten Browser sogar _weniger_ werden, wenn man die Anzahl der Fehler verringern würde.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 11:53 Uhr

schluckebier
Posts: 1059
Nutzer
Zitat:
Original von _PAB_:
wir haben HTML-3.2 mit Erweiterungen aus HTML-4.0 (CSS zB.), allerdings gibt es keine W3C-konforme Weise dies zu deklarieren.
Und jeweils nur einen der beiden Standards zu verwenden ist gelinde gesagt großer Mist!


Nein, kein großer Mist, sondern der richtige Weg. Alles andere, besonders das Basteln von eigenen Tags, ist großer Mist.

Zitat:
Die Amiga-Browser verstehen sich nur auf HTML-3.2 und einige der verwendeten Elemente könnten wir nicht mehr benutzen - andererseits würde die Seite auf modernen Browsern dann ziemlich übel aussehen.

Wenn HTML 3.2 zwingend erforderlich ist, dann nimm HTML 3.2. Ich kann mir allerdings nicht vorstellen, dass die Verwendung von HTML 4.0 problematisch sein soll, denn nicht bekannte Tags werden (genau wie deine selbsterfundenen) einfach ignoriert.

Welche HTML 3.2-Tags brauchst du denn unbedingt, dass sich der Einsatz von HTML 4.0 verbieten würde?

Zitat:
Auf HTML-4.0 umzustellen ist ebenfalls ein Krampf, weil dann die Amiga-Browser garantiert außen vor bleiben und es obendrein noch einen Haufen unnütze Arbeit bringt.

M.E. wäre das eher nützliche Arbeit. Wie Holger schon schrieb, wenn der Code erst einmal fehlerfreies HTML ist, kann man sich viel entspannter den evtl. nötigen Abwärtskompatibilitätsverrenkungen widmen.

Zitat:
3. unbekannte Tags wie <smallfont> u.ä.:
diese Tags werden einfach nicht interpretiert. Als Markierung für CSS sind sie aber unter Umständen noch brauchbar. Also können sie drinnen bleiben, da sie nicht stören.


Wenn ein Tag nicht interpretiert wird, wird der Style dafür i.d.R. ebenfalls nicht interpretiert... Sinnlos.

Zitat:
4. Sehe ich auch keinen triftigen Grund, hier validiertes HTML-4.0 [Transitional] einzuführen.

Dann solltest du deine Einstellung bzgl. der Verwendung von HTML dringend überdenken.

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 13:47 Uhr

_PAB_
Posts: 3016
Nutzer
@schluckebier, Holger:
Dies ist mein letzter Beitrag zur HTML-Debatte:
Nochmal klartext: wir halten uns an keinen Standard und wollen das auch nicht tun, weil wir sonst entweder die Amiga-Nutzer ausschließen oder das Design auf moderneren Browsern grottenschlecht aussieht.
Wollt ihr irgendetwas davon ?

So, und was unbekannte Tags angeht wie <smallfont> und <nobr>, die nicht klar definiert sind, so ist es völlig normal und sogar HTML-konform, daß diese ignoriert werden, falls der Browser damit nichts anfangen kann !
Punkt.

Und schließlich zu den angeblichen "Fehlern" im Code:
Nun, wenn man den W3C-Validator fragt, zeigt er natürlich "Fehler" an, aber nur, weil er meint, wir würden versuchen HTML-4.0 umzusetzen - was wir aber garnicht tun !
Nun könnte man vielleicht das <doctype>-Tag rausschmeißen... allerdings liegen wir am nächsten von HTML-4.0 Transitional, weshalb wir diesen auch deklarieren.

PS: Die Fehler, die dort auftauchen sind übrigens immer wieder die gleichen:
- "&xxx=yyy" in URLs statt "&xxx=yyy" (macht sowieso fast jeder)
- unbekannte Tags (werden sowieso ignoriert)
- <form> nicht an der "richtigen" Stelle, das hat aber seinen guten Grund.

Wenn es irgendein Darstellungs-Problem mit irgendeinem Browser gibt, dann bin ich gerne bereit mir das anzusehen - aber nur für einen W3C-Standard hier alle Seiten komplett umzukrempeln und für ältere Browser unbrauchbar zu machen, dafür habe ich echt keine Zeit.

[ Dieser Beitrag wurde von _PAB_ am 09.01.2006 um 13:49 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 16:53 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
@schluckebier, Holger:
Dies ist mein letzter Beitrag zur HTML-Debatte:
Nochmal klartext: wir halten uns an keinen Standard und wollen das auch nicht tun, weil wir sonst entweder die Amiga-Nutzer ausschließen oder das Design auf moderneren Browsern grottenschlecht aussieht.

Erstens:
ich warte erst mal ab, ob sich jemand anderes vom AN Team dazu äußert und bestätigt daß "wir halten uns an keinen Standard" die Definitiv letzte Aussage von Amiga-News sein soll.

Die Behauptung, sich an einen Standard zu halten würde automatisch Amiga-Browser ausschließen, ist nicht zu halten. Es ist eher ein Wunder, daß die Amiga-Browser überhaupt noch mit so einem Unfug wie <br/> (keiner von denen beherrscht XML) zurecht kommt.

Die Behauptung, daß sich an Standards zu halten dazu führt, daß "das Design auf moderneren Browsern grottenschlecht aussieht", ist erst Recht Unsinn. Wie schafft es nur der Rest des W W W trotz Standards gut auszusehen?
Zitat:
So, und was unbekannte Tags angeht wie <smallfont> und <nobr>, die nicht klar definiert sind, so ist es völlig normal und sogar HTML-konform, daß diese ignoriert werden, falls der Browser damit nichts anfangen kann !
Punkt.

Wie sich ein konformer Browser verhalten soll, mußt DU uns nicht erklären. Hier geht es darum, wie man eine konforme Webseite aufbaut. Und nicht-konforme Tags, deren einziger Zweck ist, ignoriert zu werden, einzubauen, erfüllt ohnehin keinen Zweck.
Außer natürlich Deiner "wir halten uns an keinen Standard"-Prämisse nachdruck zu verleihen.
Erpreßt Du damit das AN-Team? Nach dem Motto entweder den "PAB-Standard" oder gar nicht?
Zitat:
- <form> nicht an der "richtigen" Stelle, das hat aber seinen guten Grund.
Ja klar, die Geschichte von dem guten Grund. Du kannst ihn zwar nicht erklären, oder traust Dich vielleicht auch nicht, ihn vor einem Publikum mit etwas Sachkenntnis darzulegen, aber es gibt ihn, mit Sicherheit.
Irgendwo da draußen.

Zitat:
Wenn es irgendein Darstellungs-Problem mit irgendeinem Browser gibt, dann bin ich gerne bereit mir das anzusehen - aber nur für einen W3C-Standard hier alle Seiten komplett umzukrempeln und für ältere Browser unbrauchbar zu machen, dafür habe ich echt keine Zeit.

Hier geht es doch gar nicht darum "alle Seiten komplett umzukrempel". Es handelt sich um Seiten, die automatisch generiert werden. Einmal das fehlerhafte Skript angepaßt, und es ist überall gefixt.

Daß durch Fehlerbehebung Seiten für ältere Browser unbrauchbar werden, ist nur in Deiner Welt so.

Bestes Beispiel ist das "BORSER"-Attribut. Nicht mehr lange, und Du wirst uns erzählen, daß es einen guten Grund dafür gab und irgendein Browser da draußen es "korrekt" interpretieren würde.

In Wahrheit handelt es sich um einen einfach zu findenden Fehler, wenn man nur einmal eine Verifizierung des Codes durchgeführt hätte. Natürlich erschwert die Liste von dutzenden unnötigen Fehlern das Finden, aber wie heißt es so schön: "wie man sich bettet, so ruht man".
Deshalb geben gewisse Leute lieber dem Validator die Schuld an den Fehlern.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 16:57 Uhr

Holger
Posts: 8033
Nutzer
Hier etwas anderes für die TODO-Liste:
- Es stört erheblich, daß man nicht die drei Buchstaben WWW eingeben kann, ohne so etwas wie WWW zu erhalten

Also für Archiv: so etwas: http://www.zu/

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

09.01.2006, 18:42 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
> wir halten uns an keinen Standard

... habe ich erstens so nicht gesagt und zweitens bezog ich mich *lediglich* auf die Foren-Skripte.

Wir versuchen uns soweit es irgendwie möglich ist und an Standards zu halten,
nur im Falle des Forums ist es derzeit nicht besser möglich.
Ok, wegen <smallfont>, das könnte man noch weglassen...

Für mehr Erläuterungen mußt Du Dich etwas gedulden, ich habe heute abend leider keine Zeit...

[ Dieser Beitrag wurde von _PAB_ am 09.01.2006 um 18:43 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 01:18 Uhr

cgutjahr
Posts: 2614
[Administrator]
@PAB:

Ich hab den Sourcecode dieses Threads genommen und so abgeändert dass er w3c-konform ist:

http://gutjahr.free.fr/thread2.html
http://validator.w3.org/check?uri=http://gutjahr.free.fr/thread2.html

Keine der Änderungen, die ich vorgenommen habe (s.u.), wirkt sich in irgendeiner Weise nachteilig auf einen mir bekannten Browser aus (genauer gesagt können sich diese Änderungen gar nicht auf die Darstellung eines Browsers nachteilig auswirken)

Ausnahme: Die drei Eingabefelder für "News"- "WWW"- und "Google"-Suche. M.W. verwendest du hier absichtlich falsches HTML, da der IE sonst eine hässliche Leerzeile anzeigt. Wenn dieses Problem nur den IE betrifft, müsste man das halt in diesem speziellen Fall mit CSS lösen (oder sich eine sonstige Lösung einfallen lassen).

Änderungen:

(Sollten sich alle problemlos in den generierenden PHP-Code übernehmen lassen)

code:
- "top"><br><FONT FACE="Verdana, Arial, Helvetica, sans-serif" SIZE="2"><blockquote><smallfont>
  durch
  "top"><br><blockquote><font face="Verdana, Ariel, Helvetica, sans-serif" size="-1">
  ersetzt
- <blockquote><smallfont>
  durch
  </font><blockquote><font face="Verdana, Ariel, Helvetica, sans-serif" size="-1">
  ersetzt
- quote:</smallfont><hr>
  durch
  quote:</font><hr><font face="Verdana, Ariel, Helvetica, sans-serif" size="2">
  ersetzt
- <hr></blockquote>
  durch
  </font><hr></blockquote><font face="Verdana, Ariel, Helvetica, sans-serif" size="2">
  ersetzt
- <TR BGCOLOR="#f0f0f0" HEIGHT="64"> -> Attribut "HEIGHT" entfernt
- align="absmiddle" durch align="middle" ersetzt
- <form> und </form> in die selbe Tabellenzelle verschoben wie den Rest des Formulars
- <nobr></nobr> entfernt, in entsprechenden Textpassagen SPACE durch   ersetzt
- Alle "&" in normalem Text oder URLs durch "&" ersetzt

--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 01:24 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
Das Problem mit dem URL-Fänger ist gelöst, da war in einer RegExp "www." geschrieben, was natürlich auch auf "www " angesprungen ist, weil der "." ein Platzhalter für ein beliebiges Zeichen ist...
Gruß an die Programmierer vom AP-Board ;-)
Habe es korrigiert, das Problem ist nun auch in alten Posts nicht mehr zu sehen.

PS: das <smallfont> und <normalfont> habe ich kurzerhand entfernt.

@Christoph:
Danke für den Code, ich werde mir den mal morgen ansehen.
(Wäre der nächste Schritt von mir gewesen, die Leute, die das stört, um Mithilfe zu bitten...)

PS: Wieviel Zeit hast Du für das Ganze gebraucht, und würdest Du das auch im Source-Code tun und zwar nicht nur für thread.php, sondern für alle .php-Dateien ?

[ Dieser Beitrag wurde von _PAB_ am 10.01.2006 um 01:32 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 01:35 Uhr

Maja
Posts: 15429
Nutzer
Kritik: Der knallrote Balken unter <zurück> <Beitrag schreiben> kommt nicht so gut. Passt so gar nicht zum Rest, tut den Augen nicht gut und man kann die Schrift (hier Türkies) nicht lesen.

War das Absicht? Bitte wieder ändern. :)

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 01:44 Uhr

cgutjahr
Posts: 2614
[Administrator]
Noch ein paar Dinge:

Erstmal danke für die vielen Verbesserungen, die Vorschau-Funktion hat mir gerade das Leben erheblich erleichtert ;-)

Die Links im Forum sind alle absolut (http://www.amiga-news.de/forum/...), ich glaube Petra hat für den Rest der Webseite großen Wert darauf gelegt, dass relative URLs verwendet werden.

Der "Navigationsbaum" am Anfang der Seite:

code:
amiga-news.de Forum
  Forenübersicht
    8. Forum und Interna
      TODO-Liste / Ideen
        Antwort erstellen


kann um eine Zeile gekürzt werden da die ersten beiden die gleiche Funktion erfüllen.

Und was Amiga-Browser und W3C-Standards angeht:

Alle Amiga-Browser beherrschen ein Subset von HTML4. Was fehlt sind hauptsächlich DOM- und CSS-bezogene Tags, dazu ein paar Kleinigkeiten wie <BASEFONT> - nichts davon wird hier oder auf ähnlichen Seiten (also Seiten mit Amiga-Bezug) eingesetzt.

Solange als Doctype "HTML 4.0 Transitional" verwendet wird und der W3C-Validator keine Fehler findet, wird auch ein Amiga-Browser die Seite einwandfrei anzeigen.

Das wesentliche Problem ist eher, dass manche Browser (vor allem IBrowse) bei den Abständen einzelner Elemente andere Größenordnungen als IE benutzen oder mal eine Leerzeile zuviel oder zuwenig einsetzen. Mit "Standard-konform oder nicht" hat das aber nichts zu tun.

--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 01:47 Uhr

cgutjahr
Posts: 2614
[Administrator]
Zitat:
Original von _PAB_:
PS: Wieviel Zeit hast Du für das Ganze gebraucht, und würdest Du das auch im Source-Code tun und zwar nicht nur für thread.php, sondern für alle .php-Dateien ?

Ja, kann ich machen. Ich muss morgen mal nachsehen ob mein FTP-Account noch Zugriff auf das entsprechende Verzeichnis hat. Wenn ja melde mich bei dir zwecks Abstimmung.

--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 14:55 Uhr

_PAB_
Posts: 3016
Nutzer
@cgutjahr:
> Das wesentliche Problem ist eher, dass manche Browser (vor allem IBrowse)
> bei den Abständen einzelner Elemente [...] mal eine Leerzeile zuviel oder zuwenig einsetzen.
> Mit "Standard-konform oder nicht" hat das aber nichts zu tun.

Das ist auch genau der Grund, warum die <FORM>s bei uns nicht an der "Standard-konformen" Stelle waren, sondern außerhalb der TDs, weil es so auf allen Browsern vom Aussehen her "richtig" aussah - also ohne zusätzliche Leerzeile.

@Holger:
> Ja klar, die Geschichte von dem guten Grund. [...] es gibt ihn, mit Sicherheit. Irgendwo da draußen.

Reicht Dir obiger Absatz als Erklärung für die absichtlich "falsche" Position der <FORM>s ?
Die übrigen Fehler sind (wie ich ja schon schrieb) entweder sowieso "üblich" bzw. das <nobr> wird zT. auch von Amiga-Browsern verstanden und ein nachträgliches Ersetzen von Leerzeichen durch   kann dadruch vermieden werden.

Im übrigen würde ich mir wünschen, wenn Du in Zukunft mal etwas weniger sarkastisch schreibst, jemand mit einem etwas dünneren Fell als ich könnte sich dadurch persönlich angegriffen fühlen.

> Die Behauptung, daß sich an Standards zu halten dazu führt, daß
> "das Design auf moderneren Browsern grottenschlecht aussieht"

... habe ich nicht geäußert.
Ich schrieb, daß ein Rückschritt auf HTML-3.2 dazu führen würde.

> Hier geht es doch gar nicht darum "alle Seiten komplett umzukrempel".

Doch, es geht wirklich um *alle* Dateien, die hier im Forum überarbeitet werden müßten.

> Es handelt sich um Seiten, die automatisch generiert werden.
> Einmal das fehlerhafte Skript angepaßt, und es ist überall gefixt.

Ja, nur dieses "einmal" ist für mich bisher ein Aufwand für den ich keine Zeit habe. Und gerade das fixen von automatisch generiertem Code ist kein Zuckerschlecken - ich kann nicht einfach hergehen und im PHP-Code alle "&" durch "&" ersetzen - dann funktioniert erstmal garnichts mehr... das wirst Du hoffentlich einsehen !

[ Dieser Beitrag wurde von _PAB_ am 10.01.2006 um 23:51 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 15:16 Uhr

_PAB_
Posts: 3016
Nutzer
@cgutjahr:
Wegen der Überarbeitung:
Bis zum Wochenende mache ich erstmal nichts mehr für die AmigaNews, daher kannst Du bis Freitag wüten - solange Du Dir vorher immer nie neueste Dateiversion vom Server holst.

Auch wichtig ist, daß Du einen Editor verwendest, der Tabs Tabs sein läßt und beim einfügen von Tabs auch Tabs und keine Spaces einfügt.
Tab-Breite ist 8.
Umwandlungen beim laden und speichern sollten deaktiviert werden.

> Die Links im Forum sind alle absolut (http://www.amiga-news.de/forum/...),
> ich glaube Petra hat für den Rest der Webseite großen Wert darauf gelegt, dass relative URLs verwendet werden.

Habe ich bisher nicht gehört, in der DB-config stand dieser Pfad drinnen, habe "http://www.amiga-news.de/forum" durch "." ersetzt, sodaß alle generierten Links stimmen und relativ sind. Man könnte natürlich auch aus allen Links diese config-Variable rausschmeißen... => viel Fleißarbeit !

Was den Navigationsbaum angeht: die beiden ersten Zeilen haben zwar die gleiche Funktion, aber "Forenübersicht" ist aussagekräftiger und der einzige sinnvolle Link für "AN.de forum" ist nunmal auch die Forenübersicht...
An dieser Stelle haben wir genug Platz frei um beide Links zu präsentieren.
Und letztendlich gibt es auch genügend Seiten, wo nur die erste Zeile vorhanden ist und "Forenübersicht" fehlt, zB. "amiga-news.de Forum => Statistik".
Also würde ich dafür plädieren, beide Links drinnen zu lassen.

[ Dieser Beitrag wurde von _PAB_ am 10.01.2006 um 15:28 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 15:56 Uhr

Petra
Posts: 1121
Nutzer
Hallo Philippe,

könntest du bitte in den Threads unten diesen hässlichen roten
Balken wieder weg machen?
--
[°¿°] Ciao, Petra

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:05 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
Ja, nur dieses "einmal" ist für mich bisher ein Aufwand für den ich keine Zeit habe. Und gerade das fixen von automatisch generiertem Code ist kein Zuckerschlecken - ich kann nicht einfach hergehen und im PHP-Code alle "&" durch "& amp;" ersetzen - dann funktioniert erstmal garnichts mehr... das wirst Du hoffentlich einsehen !


Ich hatte eigentlich deutlich gesagt, daß ich Verständnis dafür habe, daß bestimmte Änderungen unterschiedliche Prioritäten haben, usw.
Wenn trotz dieses von vornherein geäußerten Verständnisses Antworten in der Form: "machen wir grundsätzlich nicht und ist sowieso technisch unmöglich" kommen, dann darfst Du Dich nicht wundern, wenn die darauf folgenden Antworten keine Lobeshymnen sind.

Es hindert Dich auch niemand daran, statt "es geht nicht anders" zu behaupten, eine Problembeschreibung zu posten und uns nach Lösungen suchen zu lassen.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:09 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
> "machen wir grundsätzlich nicht und ist sowieso technisch unmöglich"

Ich habe das so nicht geschrieben.
Siehe meine Postings von gestern Abend und heute morgen...

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:11 Uhr

_PAB_
Posts: 3016
Nutzer
@Petra, Maja:
Ich sehe keinen roten Balken...
vielleicht ein Problem auf den Moderations-Seiten - werde es mir gleich ansehen.
[...]
So - ist es jetzt besser ?
(Da fehlten einige Anfürhungszeichen im Footer des Forums.)

[ Dieser Beitrag wurde von _PAB_ am 10.01.2006 um 16:17 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:24 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
Reicht Dir obiger Absatz als Erklärung für die absichtlich "falsche" Position der <FORM>s ?


Also wenn's, wie da oben beschrieben, nur um den IExplorer geht, dann reicht es, wenn man die <form> tags um ein style="margin:0" Attribut ergänzt, und schon ist das Problem behoben.

Und zwar Standard-konform.

Ich frag mich, wie man überhaupt auf die Idee kommt, solche Probleme mittels Durcheinanderwürfeln von Tabellen- und Form-Tags zu lösen.
Ich mein, die Inhalte der Formulare stehen hinter dem schließenden </form> Tag, also außerhalb des eigentlichen Formulars, abgesehen von den zur Tabelle gehörenden Tags zwischen <form> und <input>. Es ist ein Wunder, daß es überaupt funktioniert, und damit meine ich nicht das Layout.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:28 Uhr

Holger
Posts: 8033
Nutzer
Bei der Vorschau fiel auf, daß dem Apostroph ein Backslash vorangestellt wurde (im Eingabefeld).
Das ist natürlich nicht wünschenswert, das Eingabefeld sollte den ursprünglich eingegebenen Text enthalten, auch wenn das Skript ihn während des Verarbeitung umwandeln mußte.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:40 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
>> [...] "falsche" Position der <FORM>s
> Also wenn's, wie da oben beschrieben, nur um den IExplorer geht, dann reicht es, [...]

Nein, es geht um verschiedene Browser u.a. Amiga-Browser.
Wenn mir einer eine Lösung sagen kann, wo ein <FORM> nicht zu einer zusätzlichen Leerzeile führt - die Standard-konform ist - und auf allen Browsern funktioniert - bin ich gerne bereit das so umzusetzen.


> Ich mein, die Inhalte der Formulare stehen hinter dem schließenden </form> Tag, also außerhalb des eigentlichen Formulars, [...]

Das kann eigentlich nicht sein, das sind verschiedene Formulare...

[ Dieser Beitrag wurde von _PAB_ am 10.01.2006 um 16:41 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 16:56 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
> Ich mein, die Inhalte der Formulare stehen hinter dem schließenden </form> Tag, also außerhalb des eigentlichen Formulars, [...]

Das kann eigentlich nicht sein, das sind verschiedene Formulare...

[ Dieser Beitrag wurde von _PAB_ am 10.01.2006 um 16:41 Uhr geändert. ]


Hier ist die Struktur, wie sie in der jetzigen Version in den Seiten steht:
code:
<table border="0" cellpadding="0" cellspacing="2"><tbody>
<tr><td> ... </td></tr>
<form method="post" action="/cgi-bin/htsearch"></form>
<tr><td align="center">
<input name="method" value="and" type="hidden">
...
</td></tr>

<form method="post" action="http://www.nettz.de/Sucher/start/transmeta_www2.cgi"></form>
<tr><td align="center">
<input name="hintergrund" value="ffffff" type="hidden">
...
</td></tr>

<!-- Search Google -->
<form method="get" action="http://www.google.com/search"></form>
<tr><td>
<input name="q" size="15" maxlength="255" value="Google.com" type="text">
<input name="hl" value="de" type="hidden">
</td></tr>

<!-- Search Google -->
</tbody></table>


Deutlich zu erkennen, daß sämtliche <input> Elemente außerhalb der Formulare stehen...

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 17:00 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
> Deutlich zu erkennen, daß sämtliche <input> Elemente außerhalb der Formulare stehen...

Lade Dir die Seite mal mit wget und sieh Dir den Source-Code an.
Es ist definitiv nicht so - scheint als hätte Dein Quelltext-Editor da irgendwas umgestellt...

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 17:02 Uhr

Holger
Posts: 8033
Nutzer
Dieses Problem scheint genereller Natur zu sein, so werden Sequenzen wie
(Backslash n) neuerdings interpretiert...
Ist zum Beispiel auch hier passiert.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 17:06 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
Lade Dir die Seite mal mit wget und sieh Dir den Source-Code an.
Es ist definitiv nicht so - scheint als hätte Dein Quelltext-Editor da irgendwas umgestellt...

Ok, so sieht Firefox Eure Webseite. Vielleicht beantwortet das auch die Frage, warum solcher Code auf lange Sicht keine gute Lösung ist...

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 17:07 Uhr

_PAB_
Posts: 3016
Nutzer
Wegen der Position der <FORM>s habe ich mal meine Umsetzung eurer Vorschläge gemacht:
http://www.amiga-news.de/forum/threadnew.php?id=20373&start=31&BoardID=2
Die Leerzeilen erscheinen wie üblich nicht in Netscape-7 und Mozilla und für IE und Opera habe ich die Leerzeilen mittels CSS "weg-retuschiert".
Voyager-3 und AWeb-3.2 sehen gut aus - IBrowse kann ich leider nicht testen...

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 17:25 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
Das Backslash-Problem ist gelöst - Danke für den Hinweis !

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 17:28 Uhr

Holger
Posts: 8033
Nutzer
Zitat:
Original von _PAB_:
Wegen der Position der <FORM>s habe ich mal meine Umsetzung eurer Vorschläge gemacht:
http://www.amiga-news.de/forum/threadnew.php?id=20373&start=31&BoardID=2
Die Leerzeilen erscheinen wie üblich nicht in Netscape-7 und Mozilla und für IE und Opera habe ich die Leerzeilen mittels CSS "weg-retuschiert".
Voyager-3 und AWeb-3.2 sehen gut aus - IBrowse kann ich leider nicht testen...

IBrowse 2.3 Demo 68k konnte ich hier auf die Schnelle testen. Sieht gut aus-keine Leerzeilen.

mfg

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]


1 -2- 3 4 5 6 7 Letzte [ - Beitrag schreiben - ]


amiga-news.de Forum > Forum und Interna > TODO-Liste / Ideen [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.