amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Forum und Interna > TODO-Liste / Ideen [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 2 -3- 4 5 6 7 8 [ - Beitrag schreiben - ]

10.01.2006, 18:00 Uhr

cgutjahr
Posts: 2622
[Administrator]
@PAB:

Scheint als würdest du doch noch ein bisschen dran rumbasteln. Ich halt mich da erstmal raus, sag' Bescheid wenn du fertig bist, dann mache ich den Kleinkram.

Martin hat mich gerade noch auf etwas hingewiesen: Die Mails zu Foren-Beiträgen die er bekommt sehen derzeit so aus:

Zitat:
Bitte nicht auf diese Mail antworten. Wenn du sofort antworten willst:
./reply.php?replyto=20645&BoardID=1

Dieses Thema abbestellen: ./thread.php?id=20645&BoardID=1¬ify=no

Da müssen wohl wieder absolute Links hin.
--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 18:25 Uhr

_PAB_
Posts: 3016
Nutzer
@cgutjahr:
> Die Mails zu Foren-Beiträgen die er bekommt sehen derzeit so aus: ./...
> Da müssen wohl wieder absolute Links hin.

Richtig, ist korrigiert. Danke !

Dann habe ich hier noch die letzte Knacknuß:
http://www.amiga-news.de/forum/threadnew.php?id=20373&BoardID=2&start=31
läuft schonmal ganz gut, allerdings gibt es ein Problem bei den <PRE>-Tags für "code:"
Man darf kein <FONT> im <PRE> haben und umgekehrt.
Ich brauche aber beides: Einrückung und Schriftart... was kann man da machen ?
(Es ist nötig für die ganzen UBB-Code Formatierungen...)

PS: Christoph, das war in Deinen Test zufälligerweise gerade nicht enthalten.

Ansonsten habe ich das thread.php überarbeitet - Du kannst es als "Vorbild" nehmen für die ganzen anderen Dateien.
Ab sofort bin ich fertig mit den Korrekturen dort.

[ Dieser Beitrag wurde von _PAB_ am 11.01.2006 um 14:48 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 19:23 Uhr

cgutjahr
Posts: 2622
[Administrator]
Zitat:
Original von _PAB_:
Dann habe ich hier noch die letzte Knacknuß:
http://www.amiga-news.de/forum/threadnew.php?id=20373&BoardID=2&start=31
läuft schonmal ganz gut, allerdings gibt es ein Problem bei den <PRE>-Tags für "code:"
Man darf kein <FONT> im <PRE> haben und umgekehrt.

Mist, stimmt - innerhalb von <PRE> darfst du keinen Einfluss auf den Zeichensatz nehmen.

Man könnte mal <CODE> ausprobieren (da sind <FONT>-Tags erlaubt), das ist allerdings eine "logische" Bezeichnung, bedeutet also nur "hier kommt Quelltext" - wie die einzelnen Browser das interpretieren (Fixed-Width-Font? präformatierter Text?) müsste man erst ausprobieren - ich kann mal eine einfache Testseite machen.

Übrigens: <FONT ...><PRE/CODE/BLOCKQUOTE/TABLE/...> ist *immer* "illegal", vor einem "Block-Element" wie PRE, BLOCKQUOTE etc. müssen alle Font-, Kursiv- etc. Anweisungen geschlossen werden, das Block-Element bekommt dann eigene Font-Anweisungen innerhalb des Blocks:



--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 19:59 Uhr

cgutjahr
Posts: 2622
[Administrator]
Okay, hier ist die Testseite:

http://gutjahr.free.fr/code_test.html

Sieht schlecht aus - unter IB bewirkt <CODE> nur einen Font fester Breite, die Präformatierung müsste man erst mit str_replace und nl2br erzwingen...

--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 20:17 Uhr

_PAB_
Posts: 3016
Nutzer
@cgutjahr:
Das war zu erwarten:
Zitat:
CODE
Description
The CODE element changes the character rendering of the contents of the element to logically represent computer code. It is intended for short words or phrases. PRE is recommended for multiple-line listings.

In diesem Fall würde ich bei den <PRE>-Tags bleiben.
(Es fehlt auch noch die Umwandlung von evtl. vorhandenen Tabulatoren.)
Außerdem sind nur die Beiträge mit "code"-Schnippseln nicht konform...
Ich denke, damit könnte man gut leben.

PS: Die Homepage http://www.amiga-news.de ist übrigens inzwischen auch konform zu HTML-4.0 Transitional.

[ Dieser Beitrag wurde von _PAB_ am 11.01.2006 um 14:49 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 21:38 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von cgutjahr:
Mist, stimmt - innerhalb von <PRE> darfst du keinen Einfluss auf den Zeichensatz nehmen.


So würde ich das nicht formulieren. Wenn ich per CSS bei einem beliebigen Block-Element die whitepace-Eigenschaft auf pre setze ändert sich nichts an den Verschachtelungsregeln, <font> darf weiterhin enthalten sein.

Genauso kann ich <span> oder jedem anderen erlaubten inline-Tag innerhalb von <pre> ein anderes font-face zuweisen.

Regeln, die das verbieten, gibt es nicht. Es gibt nur die eine, die ziemlich willkürlich <font> innerhalb von <pre> verbietet.

Da das für nicht-CSS fähige Browser aber die einzige Möglichkeit ist, den font zu bestimmen, würde ich die Regel hier ignorieren.

vim generiert beim Umwandeln von syntax-highlighting nach Html auch genau solchen code, <font> innerhalb von <pre>.

Alternativ kann man ja auf XHTML2 setzen, da sollen m.W. die meisten dieser Regeln abgeschafft werden ;)
Dafür dürfte es natürlich andere Probleme mit Amiga-Browsern geben :D

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 21:50 Uhr

Holger
Posts: 8040
Nutzer
Das Akut-Akzent Zeichen (U+00B4) wird jetzt als Html-Entity #180; dargestellt, weil das einleitende & jetzt nach amp; konvertiert wird. Doppelt hält nicht immer besser...

Referenz: '

Und in alten Beiträgen, wird jetzt das & in die amp; Sequenz konvertiert, was natürlich blöd ist, wenn man sich eigentlich darauf verlassen hat, daß das Forum Html-Entities unverändert wiedergibt.
Solche Entities wurden von einigen Browser auch automatisch eingefügt, wenn man Zeichen eingegeben hat, die nicht im Iso-Latin-9 darstellbar sind.

Kann man evtl. nur die & Zeichen konvertieren, die keine gültige Entity ergeben? Eine Art Smart-Filter...

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

10.01.2006, 23:53 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
http://www.amiga-news.de/forum/help_text.php
"HTML-Code wird in diesem Forum nicht interpretiert !"

Wenn es bisher funtkionierte, war das streng genommen sogar ein Fehler.
Es war immer die Absicht, daß Text 1:1 vom Texteingabefeld in die Datenbank kommt und dann bei der Generierung der Seiten in HTML konvertiert wird. Ausnahme sind derzeit noch " und '

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 11:53 Uhr

Palgucker
Posts: 1338
Nutzer
@_PAB_

Holgers Vorschlag mit dem "Smartfilter" ist wohl durchaus überlegenswert.
Die jetzige Lösung mit den Entities ist für mich jedenfalls sowas, wie Unfug zum Standart zu erklären.
Allein, wenn ich hier über dem Eingabefeld lese:

[ Dieser Beitrag wurde von _PAB_ am 08.01.2006 um 17:31 Uhr geändert. ]

Passiert das den auch mit URLs, die amps enthalten?

mfg Palgucker


[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 12:31 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
Wenn es bisher funtkionierte, war das streng genommen sogar ein Fehler.
Es war immer die Absicht, daß Text 1:1 vom Texteingabefeld in die Datenbank kommt und dann bei der Generierung der Seiten in HTML konvertiert wird. Ausnahme sind derzeit noch " und '


Dieses Ziel ist dummerweise nicht erreichbar, wie gesagt, wenn Zeichen nicht im Encoding der Seite (iso-latin-9) darstellbar sind, werden sie idealerweise vom Browser in Entities umgewandelt, so wie der Browser umgekehrt auch Entities innerhalb von <textarea> interpretiert.

Insbesondere Mac-User haben ein paar Zeichen direkt auf ihrer Tastatur, die davon betroffen sind.

Ansonsten waren Html-Entities ein probates Mittel, um die Interpretation von Code wie [ b] oder Smilies zu verhindern. Gut, ich habs wohl am häufigsten benutzt...

Die Alternative wäre, die Datenbank voll Unicode-fähig zu machen und ein neues Tag der Art [dont-interprete] einzuführen.
☞Das erscheint mir allerdings aufwendiger.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 14:58 Uhr

_PAB_
Posts: 3016
Nutzer
@Palgucker:
> Dieser Beitrag wurde von _PAB_ am 08.01.2006 um 17:31 Uhr geändert.

Ist bereits korrigiert.

Was ist so falsch daran, daß Beiträge jetzt 1:1 dargestellt werden, wie sie eingegeben werden ?
Ich finde nichts falsches daran.
Falls es tatsächlich irgendwelche Sonderzeichen gibt, die zu Problemen führen, bitte ich um ein Beispiel.

> Passiert das den auch mit URLs, die amps enthalten?

URLs sollten dem User immer mit einfachen & erscheinen:
http://www.test.com/?test=1&test=2
Falls jemand HTML-Quellcode postet, erscheinen die URLs mit & (wie man sie postet):
http://www.test.com/?test=1&test=2

Ich denke, das ist die einfachste und unkomplizierteste Art damit umzugehen.

[ Dieser Beitrag wurde von _PAB_ am 11.01.2006 um 15:21 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 15:23 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
Und um die Umwandlung eines [i] oder jeden anderen UBB-Code-Tags zu verhindern,
kann man ab sofort einen Backslash \ voranstellen, also so eingeben: \[i]

Siehe auch in der Forum-Hilfe zu Text-Formatierungen

[ Dieser Beitrag wurde von _PAB_ am 11.01.2006 um 19:44 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 15:45 Uhr

Palgucker
Posts: 1338
Nutzer
@ _PAB_

Zitat:
Was ist so falsch daran, daß Beiträge jetzt 1:1 dargestellt werden, wie sie eingegeben werden ?
Ich finde nichts falsches daran.
Falls es tatsächlich irgendwelche Sonderzeichen gibt, die zu Problemen führen, bitte ich um ein Beispiel.


Siehe

hier

Nun bleibt mir erstmal nur, mich zwischen Mist* und Quatsch* zu entscheiden. Ich sehe in der neuerlichen Form keinen Vorteil - grumml.

Mist = Alle Apostrophe werden in Acut Akzent gewandelt.
Quatsch = verwendete Entities werden als Text dargestellt.

mfg Palgucker


[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 16:37 Uhr

_PAB_
Posts: 3016
Nutzer
@Palgucker:
> Alle Apostrophe werden in Acut Akzent gewandelt.

Das war schon immer so...
siehe dazu meine TODO-Liste am Anfang des Threads.

> verwendete Entities werden als Text dargestellt.

Ich kann mich nur wiederholen: HTML-Code wird in diesem Forum nicht unterstützt.
Wenn es bisher hier und da mal möglich war (zB. mittels ISO-Entities), dann war das streng genommen ein Fehler.

Vorübergehend habe ich für die ISO-Entities & #39; (wird in einen Apostroph konvertiert) und & #91; (wird zu [ konvertiert) einen Workaround gemacht.

Generell sollte man aber immer Apostroph schreiben, wenn man ein Apostroph haben möchte.
Früher oder später werden die Apostrophe richtig dargestellt werden.

[ Dieser Beitrag wurde von _PAB_ am 11.01.2006 um 17:13 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 17:03 Uhr

_PAB_
Posts: 3016
Nutzer
So, die Apostrophe gehen jetzt.
Beispiel:
test ' test
Alte Beiträge mit regulär eingegebenen Apostrophen werden jetzt richtig angezeigt.

Ach, und bevor einer auf die Idee kommt:
nein, eine SQL-Injection wird dadurch nicht ermöglicht.

[ Dieser Beitrag wurde von _PAB_ am 11.01.2006 um 17:13 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 17:17 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
Was ist so falsch daran, daß Beiträge jetzt 1:1 dargestellt werden, wie sie eingegeben werden ?
Ich finde nichts falsches daran.

Nochmal: sie werden nicht so dargestellt, wie sie eingegeben werden. Dazu müßtest Du unterscheiden können, ob die Entities von Hand eingegeben wurden, oder ob sie automatisch per der Zeichensatzkonversion erzeugt wurden.
Zitat:
Falls es tatsächlich irgendwelche Sonderzeichen gibt, die zu Problemen führen, bitte ich um ein Beispiel.

http://www.amiga-news.de/forum/thread.php?id=19493&BoardID=4#193861
http://www.amiga-news.de/forum/thread.php?id=18141&start=61&BoardID=2#178789
http://www.amiga-news.de/forum/thread.php?id=17603&start=31&BoardID=1#171137
http://www.amiga-news.de/forum/thread.php?id=18244&start=61&BoardID=7#179248
http://www.amiga-news.de/forum/thread.php?id=17541&BoardID=5#170103
http://www.amiga-news.de/forum/thread.php?id=18244&start=31&BoardID=7#179064
http://www.amiga-news.de/forum/thread.php?id=1654&BoardID=2#55725
http://www.amiga-news.de/forum/thread.php?id=1654&BoardID=2#55838
http://www.amiga-news.de/forum/thread.php?id=15458&BoardID=2#148489

Man beachte letzte Zeile, ...
http://www.amiga-news.de/forum/thread.php?id=20588&BoardID=5#203564
... aus der beim Zitieren wurde:
http://www.amiga-news.de/forum/thread.php?id=20588&BoardID=5#203566

(Nur Stichprobenartig, ich habe versucht, Dopplungen durch User, die offenbar kein iso-latin-9 System verwenden, zu vermeiden)

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 18:53 Uhr

Palgucker
Posts: 1338
Nutzer
@ _PAB_

Jo, so ist das natürlich schon viel besser - zumal ich auch nicht wild darauf bin, entities zu benutzen.
Auch Holgers angeführte Seiten scheinen ja jetzt korrekt angezeigt zu werden.
Schön!

mfg Palgucker

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 19:02 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
Ich habe den Workaround auf &#___; ausgedehnt, wobei dort mindestens drei Zahlen stehen müssen.

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 19:26 Uhr

_PAB_
Posts: 3016
Nutzer
Ich bin da noch ein wenig am testen mit der Konvertierung bzw. Darstellung von Apostroph und Acutes:

Acute eingegeben: '
Rückwärts-Acute eingegeben: ' (sollte zum Apostroph werden)
Apostroph eingegeben: '

Klappt scheinbar auch mit der Vorschau.

[ - Antworten - Zitieren - Direktlink - ]

11.01.2006, 20:48 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
@Holger:
Ich habe den Workaround auf &#___; ausgedehnt, wobei dort mindestens drei Zahlen stehen müssen.


& n b s p; (non breaking space) und & # x ... ; (hexadezimal) funktionieren leider noch nicht.

Trotzdem schon mal Danke.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

12.01.2006, 20:46 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
  ist HTML-Code und wird daher hier nicht unterstützt.
Möchte man eingerückten Text schreiben, sollte man [code] verwenden.
(Edit: Evtl. könnte man Einrückungen in Zukunft mal durch automatisches konvertieren von Leerzeichen am Zeilenanfang ermöglichen)

Auch die Hexadezimalen ISO-Entities werden, soweit ich weiß, nicht von Browsern gesendet - oder doch ?
(Beispiel? Auf diese würde ich nämlich auch gerne verzichten, wenn es nicht absolut notwendig ist.)

PS: Bei Deinem Forums-Syntaxhighlighing gibt es übrigens noch ein Problem:
Da kommt öfters mal ein Backslash vor einem schließenden UBB-Code-Tag vor, weshalb dieses dann ausgelassen wird.

[ Dieser Beitrag wurde von _PAB_ am 12.01.2006 um 23:13 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

13.01.2006, 18:05 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
@Holger:
ist HTML-Code und wird daher hier nicht unterstützt.

Häh?
Es is genauso ein Zeichen, wie jedes andere auch. Auf'm Amiga kann ich in einigen Programmen auch Alt+Leertaste zum Eingeben eines non-breaking-space benutzen. Unter Explorer geht's über IM oder mittel Alt+Nummernblock, nur FireFox wandelt nbsp's in normale Leerzeichen um.
Dürfen FireFox-User jetzt kein nbsp verwenden, während alle anderen dürfen?
Unterscheidest Du bei den numerischen Entities jetzt auch zwischen spaces und anderen Zeichen?
Zitat:
Auch die Hexadezimalen ISO-Entities werden, soweit ich weiß, nicht von Browsern gesendet - oder doch ?
Es wäre genauso konform wie dezimale. Ich probiere doch jetzt nicht ale Systeme und alle Browser aus. Es gibt zumindest bereits Postings, wo sie verwendet werden.
Zitat:
(Beispiel? Auf diese würde ich nämlich auch gerne verzichten, wenn es nicht absolut notwendig ist.)
Warum?
Zitat:
PS: Bei Deinem Forums-Syntaxhighlighing gibt es übrigens noch ein Problem:
Da kommt öfters mal ein Backslash vor einem schließenden UBB-Code-Tag vor, weshalb dieses dann ausgelassen wird.


Wo?
Und falls es Bestandteil des Codes ist: wie soll ich es denn eingeben, wenn es vom Forum nicht interpretiert werden soll?

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

13.01.2006, 18:24 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
Ich schrieb:
>> "  ist HTML-Code und wird daher hier nicht unterstützt."

> Auf'm Amiga kann ich in einigen Programmen auch Alt+Leertaste zum Eingeben eines non-breaking-space benutzen.

Ich habe nichts dagegen, nicht umbrechende Leerzeichen zu unterstützen.
(Wenn ich das richtig sehe, funktioniert das sowieso schon bei einigen Browsern)

Aber die Eingabe von " " (als Buchstaben) im Eingabefeld, wird nicht dazuführen, daß ein solches später als nicht umbrechendes Leerzeichen dargestellt wird, weil wir in diesem Forum keinen HTML-Code unterstützen. (Dabei wird es auch bleiben.)

>> Auch die Hexadezimalen ISO-Entities werden, soweit ich weiß, nicht von Browsern gesendet

> Es wäre genauso konform wie dezimale. Ich probiere doch jetzt nicht ale Systeme und alle Browser aus.

Ich auch nicht, wenn Du ein Beispiel findest, wo Hexadezimal-Entities gesendet werden, passe ich das gerne an, aber ich denke nicht, daß das ein Browser macht.

> Es gibt zumindest bereits Postings, wo sie verwendet werden.

Ich nehme stark an, daß diese von Hand als Klartext eingegeben wurden.

>> Auf diese würde ich nämlich auch gerne verzichten, wenn es nicht absolut notwendig ist.)

> Warum?

Weil das sonst zusätzlichen Aufwand bei der Programmierung, beim Testen und natürlich auch zur Laufzeit bei der Konvertierung darstellt, ganz abgesehen von neuen potentiellen Fehlerquellen.
Und Aufwand möchte ich immer minimieren.

>> ... Backslash vor einem schließenden UBB-Code-Tag vor, weshalb dieses dann ausgelassen wird.

> Wo?

Weiß ich gerade auch nichtmehr, aber da waren Zeilen mit einem Backslash am Ende (für irgendeinen Multiline-Code) und danach kamen noch ein schließendes UBB-Code-Tag

> Und falls es Bestandteil des Codes ist: wie soll ich es denn eingeben, wenn es vom Forum nicht interpretiert werden soll?

Mache einfach einen Leerschlag vor dem schließenden UBB-Code-Tag, falls ein Backslash vorangeht. Dann werden die UBB-Code-Tags wieder richtig erkannt.

PS: Letztenendes hat dieses Forum (und meine programmier-Laune) auch mal Grenzen.

[ Dieser Beitrag wurde von _PAB_ am 13.01.2006 um 18:25 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

13.01.2006, 20:36 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
Ich habe nichts dagegen, nicht umbrechende Leerzeichen zu unterstützen.
(Wenn ich das richtig sehe, funktioniert das sowieso schon bei einigen Browsern)

Schön.
Zitat:
Aber die Eingabe von " " (als Buchstaben) im Eingabefeld, wird nicht dazuführen, daß ein solches später als nicht umbrechendes Leerzeichen dargestellt wird, weil wir in diesem Forum keinen HTML-Code unterstützen. (Dabei wird es auch bleiben.)
Gucke mal: ich habe jetzt nicht Dein von Hand eingegebenes & n b s p ; in eine Leerstelle verwandelt. DAS war der Browser. Weil der nämlich den Unterschied zwischen von Hand eingegebenen Entities und den anderen gar nicht erkennt, wenn man sie in ein TextArea schreibt.

Und dann wäre da noch die Feinheit, daß per Tastenkombination eingegebene "echte" U+00a0-Zeichen von eurem Forumskript selbständig in & n b s p ; verwandelt werden. Dann muß man aber auch damit rechnen, daß der Browser diese auch so zurückschickt, wie er sie erhalten hat.

Es gab ja schon früher das Problem, daß Zitatantworten verwurstet wurden, wenn man sie nicht von Hand angepaßt hat. Aber jetzt machst Du es eher noch schlimmer.
Zitat:
> Warum?

Weil das sonst zusätzlichen Aufwand bei der Programmierung, beim Testen und natürlich auch zur Laufzeit bei der Konvertierung darstellt, ganz abgesehen von neuen potentiellen Fehlerquellen.
Und Aufwand möchte ich immer minimieren.

Doch wohl nur bei dem Suchbegriff. Dafür gibt es einfache RegExp-Ausdrücke, die ich jetzt hier besser nicht poste, wer weiß, was das Forum daraus macht...
Zitat:
Weiß ich gerade auch nichtmehr, aber da waren Zeilen mit einem Backslash am Ende (für irgendeinen Multiline-Code) und danach kamen noch ein schließendes UBB-Code-Tag
Kann mich nicht erinnern, jemals multiline-code gepostet zu haben. Aber selbst wenn, die Backslash-Syntax gabs ja bis vor kurzem nicht.
Und wer immer mit der "dabei-soll-es-auch-bleiben"-Keule beim Thema Html-wird-nicht-interpretiert rumwedelt, dem müßte es ja auch recht sein, wenn ich bei dem "backslash-hat-keine-Bedeutung" Paradigma bleibe...
Zitat:
PS: Letztenendes hat dieses Forum (und meine programmier-Laune) auch mal Grenzen.
Momentan machst Du es Dir ja schwerer als nötig. Dabei kann Dir niemand von uns helfen.
Wenn Du endlich mal dazu übergehen würdest, Deine Lösungen vorher vernünftig durchzudiskutieren, statt immer sofort das Forum (auch noch mitten im Betrieb) zu ändern, und alle vor vollendete Tatsachen zu stellen, könntest Du mit weit weniger Arbeit bessere Ergebnisse erzielen.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

13.01.2006, 20:54 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
> Gucke mal: ich habe jetzt nicht Dein von Hand eingegebenes   in eine Leerstelle verwandelt. DAS war der Browser.

Nein, das war ein Fehler im Reply.php, den ich wohl noch beheben muß...
(Edit: ein Fehler, der jetzt auch behoben ist.)

> Es gab ja schon früher das Problem, daß Zitatantworten verwurstet wurden,
> wenn man sie nicht von Hand angepaßt hat. Aber jetzt machst Du es eher noch schlimmer.

Falsch: ich bin dabei diese Fehler allesamt auszumerzen, indem ich 1:1 das was man schreibt in die DB schiebe und auch genauso beim Antworten auch präsentieren möchte.
Wenn es irgendwo nicht 100% klappt, liegt das daran, daß fürher etliche Ausnahmen und Konvertierungen gemacht wurden, die ich auf ein absolut notwendiges Minimum reduzieren möchte.

Wenn Du hier (noch) ein Fehlverhalten findest, werde ich das gerne beheben.
PS: Früher war es übrigens noch schlimmer, man konnte nichtmal ein Apostroph schreiben...

> Doch wohl nur bei dem Suchbegriff. Dafür gibt es einfache RegExp-Ausdrücke

Eine zusätzliche Ausnahme ist eine zusätzliche Fehlerquelle und zusätzlicher Aufwand - Punkt.
PS: über RegExp brauchst Du mich wirklich nicht belehren...

> wer weiß, was das Forum daraus macht...

Haha - sehr witzig ! >:-[
Benutz' doch die Vorschau :-P

> Kann mich nicht erinnern, jemals multiline-code gepostet zu haben.

Naja, vielleicht war's auch jemand anderes.

PS: Wie kommst Du dazu, Dir einbilden zu können, meine Arbeitsweise zu kennen ?
Nur wenn mal nicht alles 100%ig funktioniert, hat man es sich nicht vorher überlegt, diskutiert und getestet !?
Da kennst Du mich aber schlecht...

[ Dieser Beitrag wurde von _PAB_ am 14.01.2006 um 00:01 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

14.01.2006, 16:26 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
PS: Wie kommst Du dazu, Dir einbilden zu können, meine Arbeitsweise zu kennen ?
Nur wenn mal nicht alles 100%ig funktioniert, hat man es sich nicht vorher überlegt, diskutiert und getestet !?
Da kennst Du mich aber schlecht...


Deine Arbeitsweise sieht man doch.

Wo hast Du denn auch nur einmal jemanden gefragt, ob es eine tolle Idee ist, einen vorangestellten Backslash als Aufhebung eines Codes zu definieren?

Ich sehe kein derartiges Posting. Statt dessen hast Du die offensichtlich kompliziertere Regel (eine mehr zu den bestehenden), die die Kompatiblität zu alten Postings nach Deiner eigenen Aussage bricht, einfach implementiert und versucht uns die Verantwortung für die jetzt falsch formatierten Posting zuzuschieben.

Wo hast Du denn gefragt, ob die neue Idee, Html-Entities nicht mehr zuzulassen, gewünscht ist?

Nein, Du hast sie erst einmal implementiert und erst nach dem Hinweis, daß solche Sequenzen auch von Usern produziert werden, die vielleicht gar nicht wissen, was eine Html-Entity ist, hast Du gnädigerweise ein paar wieder zugelassen.

Von vorher überlegen oder gar diskutieren keine Spur.

Und TESTEN? Wem willst Du denn hier was vormachen?
Fehlerhaft verschickte E-Mails, verschwundene Postings, falsche Einträge in Threads und dann noch die Auswirkungen Deiner oben genannten neuen Regeln, alle diese Dinge kann man hier im Board nachlesen.
Was verstehst Du denn unter Testen?!

Jeder AN-User kennt Deine Arbeitsweise, offenbar besser als Du selbst.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

14.01.2006, 16:56 Uhr

_PAB_
Posts: 3016
Nutzer
@Holger:
Ich wiederhole mich nur ungern:
HTML wird in diesem Forum nicht unterstützt und wurde es auch nie.
Das konntest Du schon immer in der Forum-Hilfe nachlesen.

Und mein letzter Kommentar zu den ISO-Entities ist: wenn diese vom Browser kommen, sollten die korrekt interpretiert werden - ist das irgendwo nicht so, ist es ein Fehler und wird bestmöglich korrigiert.

Wenn es aber darum geht *von*Hand* eingegebene ISO-Entities darzustellen, so ist es sinnvoller, diese in Klartext darzustellen - alles andere wäre reinster Voodoo-Zauber für den Benutzer.

Stell Dir vor, viele wollten schonmal über HTML-Code diskutieren und haben sich dann gewundern, warum das dann so komische Resultate erzeute und man   nicht einfach hinschreiben konnte, sondern immer "& n b s p ;" oder ähnliches schreiben mußte...

Und über meine Arbeitsweise kann ich mit Dir nicht diskutieren - Du kennst mich nicht und hast nicht im Geringsten eine Ahnung, wie ich arbeite. Oder ist Dir schonmal in den Sinn gekommen, daß ich erstmal mit nicht-öffentlichen Kopieen der Seiten arbeite, die Redaktion bei Grundlegenden Design-Entscheidungen zu rate ziehe und daß dort auch manchmal reichhaltig diskutiert wird ?
Nein, das ist Dir natürlich nicht in den Sinn gekommen.
Und ist Dir schonmal aufgefallen, daß ich mich gerne auf eine Diskussion einlasse, wenn konstruktive Kritik kommt und schon oft Anregungen von Mitgliedern dieses Forums angenommen und umgesetzt habe ? Wenn nicht, solltest Du mal an den Anfang dieses Threads schauen...
Also unterlasse bitte solche abfälligen Kommentare über Dinge, von denen Du keine Ahnung hast.

Für die Zukunft: ich antworte Dir nur noch auf rein sachliche Kommentare mit rein sachlichen Inhalten.
Wenn Du ein Fehlverhalten der Foren-Skripte findest, wofür Du ein (für mich nachvollziehbares) Beispiel hast, sehe ich mir das gerne an, aber für diesen Käse, den Du manchmal von Dir gibst, habe ich echt keine Zeit.
Alles andere als rein sachliche Kommentare werde ich daher ab jetzt ignorieren.

[ - Antworten - Zitieren - Direktlink - ]

15.01.2006, 16:42 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von _PAB_:
Oder ist Dir schonmal in den Sinn gekommen, daß ich erstmal mit nicht-öffentlichen Kopieen der Seiten arbeite, die Redaktion bei Grundlegenden Design-Entscheidungen zu rate ziehe und daß dort auch manchmal reichhaltig diskutiert wird ?

Mir ist durchaus in den Sinn gekommen, daß es so sein sollte. Angesichts der Geschwindigkeit, in der Du Deine Ideen umsetzt, ist aber oftmals klar erkennbar, daß eine solche Dikussion gar nicht stattgefunden haben kann.

Außerdem vermisse ich diesbezüglich die Statements vom AN-Team. Oder ich habe die Meldung, daß DU jetzt das Sprachrohr von Amiga-News zum verkünden der endgültigen Entscheidungen, verpaßt?

Zitat:
Und ist Dir schonmal aufgefallen, daß ich mich gerne auf eine Diskussion einlasse, wenn konstruktive Kritik kommt und schon oft Anregungen von Mitgliedern dieses Forums angenommen und umgesetzt habe
Mir ist aufgefallen, daß Du hinterher die schlimmsten Auswüchse wieder zurücknimmst, wenn es gar nicht anders geht.
Zitat:
Wenn Du ein Fehlverhalten der Foren-Skripte findest, wofür Du ein (für mich nachvollziehbares) Beispiel hast, sehe ich mir das gerne an, aber für diesen Käse, den Du manchmal von Dir gibst, habe ich echt keine Zeit.
Mehr als die Adressen der Postings, die durch Deine Entscheidungen unleserlich geworden sind, kann ich eh nicht tun. Abgesehen davon, daß Du andere betroffene Postings, wie man Deinen Aussagen entnehmen kann, ja selber entdeckt hast.
Zitat:
Alles andere als rein sachliche Kommentare werde ich daher ab jetzt ignorieren.

Nur weil es Deine Arbeitsweise ist, die im Kritikpunkt steht, wird eine Kritik nicht automatisch unsachlich. Das ist Deine unsachliche Sichtweise.

Ich warte ja immer noch auf Aussagen des AN-Teams ob sie wirklich zufrieden sind mit solchen Aktionen wie Umbau der Skripte zu Zeiten der höchsten User-Zugriffe oder eigenmächtige Umdefinitionen der Formatierungdefinitionen.

Aber angesichts Deiner hier gezeigten Kritikfähigkeit kann ich auch verstehen, warum sich niemand dazu äußert. Äußerst Schade für das Forum.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

15.01.2006, 20:10 Uhr

Petra
Posts: 1121
Nutzer
Hallo Holger,

ich weiß nicht, was du für einen Grund hast, hier so auf _PAB_ loszu-
gehen, aber ich kann dir versichern, dass wir absolut damit zufrie-
den sind, wie _PAB_ hier die Verbesserungen durchführt. Wir stehen
in ständigem Kontakt, teils per Telefon, teils auf der internen ML,
um darüber zu beratschlagen, was wir wie durchführen. Das heißt
aber nicht, dass sich Philipp für jede kleine Änderung ein ok holen
muss.

Er ist zuständig für die Forenskripte und kann hier selbstständig
entscheiden, wie und in welcher Reihenfolge er vorgeht. Wir können
jederzeit darüber diskutieren, was sinnvoll und was nicht ist, aber
bitte lasse mal deinen angreifenden Tonfall weg. Muss nicht sein -
und führt bekanntlich zu gar nichts, außer zu Frust. Du musst nicht
mit ihm einer Meinung sein, aber ich denke, eine unterschiedliche
Meinung kannst du auch ohne Angriffe ausdrücken. Das gilt natürlich
für Philipp genauso. Nehmt einfach mal die Schärfe raus!

Ich jedenfalls bin froh, dass Philipp sich der Skripte angenommen
hat, die wie alle wissen, noch in vielen Bereichen Verbesserungen
vertragen können.

Und Christoph Gutjahr hat sich inzwischen angeboten, sich zusätzlich
noch der vielen HTML-Fehler anzunehmen.


--
[°¿°] Ciao, Petra

[ Dieser Beitrag wurde von Petra am 15.01.2006 um 20:12 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

15.01.2006, 22:02 Uhr

Maja
Posts: 15429
Nutzer
@Holger:

> Oder ich habe die Meldung, daß DU jetzt das Sprachrohr von Amiga-
> News zum verkünden der endgültigen Entscheidungen, verpaßt?

Petra hat ja schon was dazu geschrieben. Mich würde nur interessieren, wer dich zum Sprachrohr der Forumsnutzer gemacht hat? Lass mal Kordel ab. Es läuft eben nicht alles immer so, wie man das persönlich gern hätte. Es wäre darum nett, wenn Du nicht jedesmal Sodom und Gomorrah rufst, wenn mal Deiner Meinung nach ein Fehler passiert, der Dir auch hätte unterlaufen können.

> Ich warte ja immer noch auf Aussagen des AN-Teams ob sie wirklich
> zufrieden sind mit solchen Aktionen wie Umbau der Skripte zu
> Zeiten der höchsten User-Zugriffe

Philippe macht das in seiner Freizeit. Was soll er Deiner Meinung nach tun? Auf Schlaf verzichten und die Nächte durchmachen? Ein bisschen viel verlangt für unbezahlte Arbeit....

> oder eigenmächtige Umdefinitionen der Formatierungdefinitionen.

Huch! Wie das klingt. Aber lies dazu, was Petra geschrieben hat. Er muss nicht für Alles fragen. Wenn wir das Alles immer erst durchdiskutieren müssten, hätte es bis dato sicherlich noch gar keine Verbesserungen gegeben.

Und wenn tatsächlich mal was in daneben geht, ist es keine Schande, das hinterher zu korrigieren. Niemand ist perfekt.

@Philippe

Das rote Balken Problem ist gelöst. Danke.


[ - Antworten - Zitieren - Direktlink - ]


1 2 -3- 4 5 6 7 8 [ - Beitrag schreiben - ]


amiga-news.de Forum > Forum und Interna > TODO-Liste / Ideen [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.