amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > MOSNet und bsdsocket.library [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

26.02.2006, 00:01 Uhr

DrNOP
Posts: 4118
Nutzer
Schon wieder ich ... I-)

Ich dachte, wenn ich schon hinter meinen Peg krieche kann ich auch gleich ein Netzwerkkabel mitnehmen und ihn endlich mit seinen Kameraden verbinden - auch wenn er irgendwie anders ist ... :P

Jedenfalls wollte ich dazu MOSNet 0.19 nehmen und was is'? Es geht natürlich nicht auf Anhieb ... :angry:

Ich hab' mich an die Anleitung gehalten und

  • es irgendwohin entpackt

  • den Pfad nach irgendwohin in die user-startup eingetragen. D.h., ich hab' folgendes einfach aus der Anleitung kopiert und den Pfad zu MOSNet angepaßt:
    Assign MOSNet: SYS:MOSNet
    Assign LIBS: MOSNet:Libs ADD
    Path MOSNet:C ADD
    Das wird nach einem ASSIGN in der Shell auch richtig angezeigt, soweit ich das beurteilen kann

  • in db/interfaces eine IP-Adresse eingetragen die zum Rest paßt

  • in db/resolv.conf meine anderen Rechner eingetragen

  • db/general.config gelassen wie sie war. Die ist ja voreingestellt, hoff ich. (*)


So, dann hab' ich einen Reboot gemacht und mit einem "ping 127.0.0.1" angefangen. Und da sagt ping mir: "cannot open bsdsocket.library version 3."
Was jetzt!?

Vor allem frage ich mich was alle anderen wissen was ich nicht weiß, daß ich in den Foren noch nicht über diese Frage gestolpert bin. ;)
Was ich gefunden habe sind Hinweise auf startnet, die man zuerst ausführen soll, am besten aus der User-startup. Startnet ist in meinem MOSNet0.19-Archiv nicht vorhanden, genauso wenig wie eine bsdsocket.library. Wo krieg ich die her? Muß ich mir die aus einem anderen TCP-Stack rüberkopieren?

(*)
Die general.config sieht so aus:
code:
#
# MOSNet configuration file. See documentation for usage.
#
USELOOPBACK=YES
DEBUGSANA=NO
USENS=SECOND
GATEWAY=NO
HOSTNAME=sonic.home.net
LOG FILTERFILE=5
GUI PANEL=MUI
OPENGUI=YES

--
Es gibt keine Notbremse für all den technischen Humbug, mit dem wir unsere Zeit vertrödeln.

[ - Antworten - Zitieren - Direktlink - ]

26.02.2006, 00:08 Uhr

thomas
Posts: 7667
Nutzer

Ich habe seit ezTCP 1.13 oder so nicht mehr "geupdated", aber ich denke, du mußt immer noch den TCP/IP-Stack starten, sonst passiert gar nichts. Dazu mußt du das Script StartNet in MOSNET:C anpassen und (vor allem) aufrufen.

Kann auch sein, daß es jetzt kein Script mehr gibt, sondern eine GUI (sonst wäre der Parameter OPENGUI=YES ziemlich unsinnig). Vermutlich mußt du dafür das Hauptprogramm starten. Das hieß früher ezTCP und jetzt vermutlich MOSNet.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

26.02.2006, 00:31 Uhr

DrNOP
Posts: 4118
Nutzer
Zitat:
Original von thomas:
Vermutlich mußt du dafür das Hauptprogramm starten. Das hieß früher ezTCP und jetzt vermutlich MOSNet.

Das klingt logisch ;) und ich habe auch ein Programm namens MOSNet in der Schublade liegen, das zieht aber drei Fragen nach sich:

1.) Wozu ist der Parameter "UP" in
code:
# Pegasos built-in ethernet
#
eth0 DEV=DEVS:networks/via_rhinepci.device UNIT=0 IP=192.168.0.1 NETMASK=255.255.255.0 UP

?
Die Anleitung sagt dazu, daß dadurch die Schnittstelle automatisch online gesetzt wird. Dazu müßte der Stack ja dann aber auch ohne Hauptprogramm laufen, nicht?

2.) Wenn ich versuche das Hauptprogramm zu starten sehe ich nur einen Requester, der sagt er finde einen Fehler in resolv.conf, Zeile 3, Spalte 10. Das ist in der ersten Zeile die ich eingetragen habe genau das Leerzeichen zwischen Rechnername und IP-Adresse.

3.) Wenn ich diesen ersten Requester wegklicke erscheint der nächste, der sagt er finde ein "unknown command" in netdb, Zeile 39, Spalte 17. Das ist genau das Zeilenende der Zeile
code:
WITH resolv.conf

Hä?

Aber abgesehen davon läuft der Stack jetzt, auch wenn ich keine GUI sehe, und das Ping funktioniert schon mal wenigstens auf 127.0.0.1 - und wenn man den richtigen Port an der Rückseite nimmt auch mit dem Nachbarn. :D
--
Es gibt keine Notbremse für all den technischen Humbug, mit dem wir unsere Zeit vertrödeln.


[ Dieser Beitrag wurde von DrNOP am 26.02.2006 um 00:50 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

26.02.2006, 00:45 Uhr

thomas
Posts: 7667
Nutzer
Zitat:
Dazu müßte der Stack ja dann aber auch ohne Hauptprogramm laufen, nicht?

Wie soll das funktionieren ? Solange du nichts startest, passiert auch nichts. Die ganzen Konfigurationsdateien nützen überhaupt nichts, wenn niemand da ist, der sie liest.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

26.02.2006, 00:49 Uhr

DrNOP
Posts: 4118
Nutzer
Zitat:
Original von thomas:
Wie soll das funktionieren ? Solange du nichts startest, passiert auch nichts. Die ganzen Konfigurationsdateien nützen überhaupt nichts, wenn niemand da ist, der sie liest.

Das stimmt wohl auch, macht den Parameter doch aber irgendwie sinnlos, oder? Oder aber die Beschreibung ist etwas zu knapp...

--
Es gibt keine Notbremse für all den technischen Humbug, mit dem wir unsere Zeit vertrödeln.

[ - Antworten - Zitieren - Direktlink - ]

26.02.2006, 10:35 Uhr

Blackbird
Posts: 634
Nutzer
@DrNOP:

du solltest nicht die V0.19 nehmen, die hat Geschwindigkeitsprobleme..

mir scheint dir fehlt nur ein Eintrag in deiner User-startup

"run >NIL: MosNet:MosNet"

in der Datei resolv.conf solltest du den Eintrag "domain.home.net" rauslöschen

in der Datei static-routes solltest du dein default gateway eingeben

--
regards
Blackbird

Have a look at:
http://www.blackbird-net.de

Skins for PlayCD OS3.9
BlackShoot, Zombies Apocalypse, GalagaWars
PerfectPaint

[ - Antworten - Zitieren - Direktlink - ]

02.03.2006, 17:52 Uhr

Murmel
Posts: 1457
Nutzer
>eth0 DEV=DEVS:networks/via_rhinepci.device UNIT=0 IP=192.168.0.1 >NETMASK=255.255.255.0 UP

Ich habs so geschieben so holt ers sich per dhcp

eth0 DEV=DEVS:networks/via_rhinepci.device UNIT=0 IP=dhcp UP

[ - Antworten - Zitieren - Direktlink - ]

04.03.2006, 15:48 Uhr

nujack
Posts: 245
Nutzer
Hab mir grade die MOSNet Version 1.0 unter MOSPowerUp installiert. Funktioniert prima. Leider gibt es ein Problem beim Beenden. Wenn ich über das MUI-Panel den TCP/IP-Stack stoppe und dann das Programm beende, scheint dieses noch irgend etwas stehen zu lassen. Beim Neustart oder Start eines anderen TCP/IP-Clients(z.B. Miami) erscheint immer der Hinweis, dass ein TCP/IP-Stack bereits gestartet ist. Verwende MOS-Net mit einer X-Surf2. Hat jemand die gleichen Erfahrungen gesammelt?

Bye

nujack

[ - Antworten - Zitieren - Direktlink - ]

04.03.2006, 16:43 Uhr

Angelos
Posts: 9
Nutzer
Zitat:
Original von nujack:
Hat jemand die gleichen Erfahrungen gesammelt?


Ging mir mit meinem Peg1 ebenso. Als ich nach einem kurzen Test Miami wieder starten wollte, kam der Hinweis das bereits ein anderer TCP/IP stack läuft.
--
Regards,

Angelos

[ - Antworten - Zitieren - Direktlink - ]

05.03.2006, 12:34 Uhr

analogkid
Posts: 2388
Nutzer
hier nicht. Nach dem Beenden des Stacks über das Gelbe Panel lässt er sich problemlos wieder starten.
--
Join us @ Sarkasmus-pur
:amiga: :dance1:

Talking about music is like dancing about architecture

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > MOSNet und bsdsocket.library [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.