amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Hilfe mit X-Server unter Debian auf dem Amiga [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

20.03.2006, 22:05 Uhr

Rotzloeffel
Posts: 219
Nutzer
hallo Spezialisten,

ich habe erfolgreich Debian 3.1 Sarge auf meinem Amiga 4000/060 installiert.

Als Framebuffer verwende ich eine PicoloSD64 Grafigkarte. Ich kann problemlos mit fbset jede beliebige Auflösung unter linux einstellen. Der X-Server startet jedoch immer in 800x600-56hz. weiss jemand wie ich diese Einstellung ändern oder beeinflussen kann ?

Im Linuxforum sind leider nur noch Dosen-user unterwegs:-(( deshalb frag ich mal hier nach !

Gruss

Rotzloeffel

[ - Antworten - Zitieren - Direktlink - ]

20.03.2006, 22:24 Uhr

schluckebier
Posts: 1059
Nutzer
Zitat:
Original von Rotzloeffel:
ich habe erfolgreich Debian 3.1 Sarge auf meinem Amiga 4000/060 installiert.


Ui, cool! :o) Welchen Kernel hast du benutzt?

Zitat:
Als Framebuffer verwende ich eine PicoloSD64 Grafigkarte. Ich kann problemlos mit fbset jede beliebige Auflösung unter linux einstellen. Der X-Server startet jedoch immer in 800x600-56hz. weiss jemand wie ich diese Einstellung ändern oder beeinflussen kann ?

Kommt darauf an, welchen X-Server du benutzt.

Bei X.org wäre es "dpkg-reconfigure xserver-xorg", bei XFree86 4.x "dpkg-reconfigure xserver-xfree86".

Alternativ könntest du auch direkt /etc/X11/xorg.conf (bzw. /etc/X11/XF86Conf-4) bearbeiten.

Zitat:
Im Linuxforum sind leider nur noch Dosen-user unterwegs:-(( deshalb frag ich mal hier nach !

Beim PC ist das aber eigentlich gleich, oder gibt es irgendwas Spezielles für die Piccolo?

[ - Antworten - Zitieren - Direktlink - ]

21.03.2006, 19:02 Uhr

Rotzloeffel
Posts: 219
Nutzer
@schluckebier:

Ui, cool! :o) Welchen Kernel hast du benutzt?

Ich habe Kernel 2.4.27 den aktuellsten halt.

quote:
Kommt darauf an, welchen X-Server du benutzt.

Bei X.org wäre es "dpkg-reconfigure xserver-xorg", bei XFree86 4.x "dpkg-reconfigure xserver-xfree86".

Alternativ könntest du auch direkt /etc/X11/xorg.conf (bzw. /etc/X11/XF86Conf-4) bearbeiten.

In der XF86Conf-4 kann ich die Auflösung einstellen 1024x768 in 8 bit jedoch oeffnet sich dann lediglich ein 800x600 screen, auf dem ein viritueller 1024x768 Bildschirm zu finden ist.

Es muss was mit dem FBDEV-Treiber des X-Servers zu tun haben.

Ich habe schon die fb.modes datei dahin gehend geändert, dass ich bei der benutzten Auflösung 800x600-56hz einfach die 1024x768-75Hz Daten eingetragen habe leider ohne Erfolg:-(( Gibt es eine solche fb.modes auch für den X-Server treiber ?

quote:
Beim PC ist das aber eigentlich gleich, oder gibt es irgendwas Spezielles für die Piccolo?

mir ist nicht bekannt, dass für die Piccolo etwas spezielles eingetragen werden muss. Es ist einfach nur der Xserver der auf dem FBDEV Treiber aufsetzt.

wie gesagt, die Konsole lässt sich via fbset beliebig umstellen. Nur der X-Server bleibt stur auf 800x600-56Hz.

irgend eine Idee?

Gruss

Rotzloeffel






[ - Antworten - Zitieren - Direktlink - ]

21.03.2006, 19:38 Uhr

schluckebier
Posts: 1059
Nutzer
Papp doch mal die relevanten Teile von XF86Config hier rein (die Definitionen für Grafikkarte, Screen und Monitor).

[ - Antworten - Zitieren - Direktlink - ]

21.03.2006, 19:56 Uhr

Rotzloeffel
Posts: 219
Nutzer
@schluckebier:
Papp doch mal die relevanten Teile von XF86Config hier rein (die Definitionen für Grafikkarte, Screen und Monitor).

hier ist es:

# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
# FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
# FontPath "/usr/lib/X11/fonts/Type1"
# FontPath "/usr/lib/X11/fonts/CID"
# FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
# Load "GLcore"
Load "bitmap"
# Load "dbe"
# Load "ddc"
# Load "dri"
Load "extmod"
# Load "freetype"
Load "glx"
# Load "int10"
# Load "record"
# Load "speedo"
# Load "type1"
# Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "amiga"
Option "XkbLayout" "usa1"
# Option "XkbLayout" "us"
Option "CustomKeycodes"
# Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/amigamouse"
Option "Protocol" "BusMouse"
Option "Emulate3Buttons" "true"
# Option "ZAxisMapping" "4 5"
EndSection
#Section "InputDevice"
# Identifier "Generic Mouse"
# Driver "mouse"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
# Option "Emulate3Buttons" "true"
# Option "ZAxisMapping" "4 5"
#EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "fbdev"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-54
VertRefresh 50-100
# Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 8
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
# SubSection "Display"
# Depth 15
# Modes "1024x768" "800x600" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 16
# Modes "1024x768" "800x600" "640x480"
# EndSubSection
# SubSection "Display"
# Depth 24
# Modes "1024x768" "800x600" "640x480"
# EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
# InputDevice "Generic Mouse"
EndSection

#Section "DRI"
# Mode 0666
#EndSection

hoffe das hilft ! wie gesagt 1024 ist moeglich allerding nur virituell ! Der Bildschirm an sich hat nur 800x600

Gruss

Rotzloeffel

[ - Antworten - Zitieren - Direktlink - ]

21.03.2006, 20:29 Uhr

schluckebier
Posts: 1059
Nutzer
Zitat:
Original von Rotzloeffel:

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-54
VertRefresh 50-100
EndSection


Das ist das einzige, was mir auf die Schnelle auffällt.
Vergleiche mal hiermit: http://www.linux-m68k.org/faq/whatmodes.html

Der einzige dort für die Piccolo 64 angegebene 1024x768-Modus hat eine höhere Horizontalfrequenz als die bei dir eingetragenen 54 kHz. Wenn dein Monitor es hergibt, erhöhe das doch mal testweise auf 56 kHz.

[ - Antworten - Zitieren - Direktlink - ]

21.03.2006, 21:54 Uhr

Rotzloeffel
Posts: 219
Nutzer
hallo schluckbier
erst einmal vielen dank für deine hilfe! leider hat der tipp nichts gebracht....
icher vermute das problem anderstwo! der x-srever verwendet wohl das device fb0 aus dem dev verzeichnis. kann es sein, dass die standaraufloesung dieses treibers die ursache ist?

hierzu habe ich mal das xf86-logfile analysiert und folgende zeilen gefunden.

schnippel

(II) FBDEV(0): using default device
(II) Running in FRAMEBUFFER Mode
(**) FBDEV(0): Depth 8, (--) framebuffer bpp 8
(==) FBDEV(0): Default visual is PseudoColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: CLgen (video memory: 4096kB)
(II) FBDEV(0): checking modes against framebuffer device...
(II) FBDEV(0): mode "1024x768" ok
(II) FBDEV(0): mode "800x600" ok
(II) FBDEV(0): mode "640x480" ok
(II) FBDEV(0): checking modes against monitor...
(--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
(**) FBDEV(0): Default mode "800x600": 36.0 MHz (scaled from 0.0 MHz), 35.2 kHz, 56.2 Hz
(II) FBDEV(0): Modeline "800x600" 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync
(++) FBDEV(0): DPI set to (100, 100)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(**) FBDEV(0): using shadow framebuffer


-----schnappel--.-----

wie man unschwer erkennen kann, schaltet das device absichtlich auf 800x600 bei 56 hz und 36khz

gibt es eine moeglichkeit diese standartwerte mit fbset zu ändern?oder ist hier anderstwo der hebel anzusetzen

gruss

otzloeffel

[ - Antworten - Zitieren - Direktlink - ]

21.03.2006, 22:57 Uhr

schluckebier
Posts: 1059
Nutzer
Zitat:
Original von Rotzloeffel:
icher vermute das problem anderstwo! der x-srever verwendet wohl das device fb0 aus dem dev verzeichnis. kann es sein, dass die standaraufloesung dieses treibers die ursache ist?


Ja, das haut hin. Wobei Standardauflösung nicht ganz richtig ist, es wird halt die aktuelle Auflösung zum Standard gemacht und für X benutzt, wenn ich das richtig verstanden habe. Dummerweise musste ich heute merken, dass ich mit dem Framebuffer bisher noch nicht wirklich was gemacht habe und entsprechend wenig davon weiß (aber /etc/fb.modes ist gruselig, so viel weiß ich auf jeden Fall schon)... ;o)

Aber es gibt eine einfachere Möglichkeit als fbset und /etc/fb.modes, probier' doch mal direkt die Einstellung einer entsprechenden Auflösung per Bootparameter, etwa so:

video=cirrusfb:1024x768-8@70
(sollte natürlich in /etc/fb.modes enthalten sein)

Wenn Linux damit startet und 1024 x 768 benutzt, dann sollte X das auch so machen. Zumindest klappt das so in der Theorie. :o)

[ - Antworten - Zitieren - Direktlink - ]

22.03.2006, 08:18 Uhr

Rotzloeffel
Posts: 219
Nutzer
@schluckebier:

Aber es gibt eine einfachere Möglichkeit als fbset und /etc/fb.modes, probier' doch mal direkt die Einstellung einer entsprechenden Auflösung per Bootparameter, etwa so:

video=cirrusfb:1024x768-8@70
(sollte natürlich in /etc/fb.modes enthalten sein)

Wenn Linux damit startet und 1024 x 768 benutzt, dann sollte X das auch so machen. Zumindest klappt das so in der Theorie. :o)

bisher ist es mir noch nicht gelungen Linux in 1024x768 direkt per Bootparameter zu starten. In der Anleitung zu CLGEN dem Devicetreiber für den Framebuffer steht jedoch drin, dass das gehen muss. Leider bislang ohne Erfolg.

ich habe in den fb.modes die betitelte Aufloesung 800x600-56 schon mit den Parametern für 1024x768-75 überschrieben (den Namen natürlich nicht) ich wollte den X-server damit hinters licht führen:-)

Mir ist jedoch noch völlig unklar, woher der X-server diese Mode-Line hernimmt! Kann es auch möglich sein, dass diese Einstellung eine angelegenheit des Treibers ist, evtl. muss man den neu compilieren ?

Gruss

Rotzloeffel

[ - Antworten - Zitieren - Direktlink - ]

22.03.2006, 09:07 Uhr

Goos
Posts: 69
Nutzer
Also so richtig kenne ich mich da auchnichtmehr aus, allerdings
laufen alle meine 1024-Screenmodes mit 86 Hz 66 kHz ich würde mal
die HorizSync auf mind. 66 nehmen, am besten aber auf die max. die der Monitor wirklich hergibt.
Ausserdem, kann ich mich noch dunkel an meine Amiga-Linuxzeiten erinnern, dass es dort eine Tastenkompination beim X-Server gab, wodurch man durch die einzelnen Screenmodes switchen kann.

gruss Goos :smokin:

[ - Antworten - Zitieren - Direktlink - ]

22.03.2006, 09:24 Uhr

Goos
Posts: 69
Nutzer
ok hab nochmal nachgeschaut, die shortcuts sind

Ctrl Alt +
und
Ctrl Alt -

und zwichen den Screenmodes zu switchen siehe:

http://linux.about.com/od/linux101/l/blnewbie5_1.htm

gruss Goos :smokin:

[ - Antworten - Zitieren - Direktlink - ]

22.03.2006, 10:37 Uhr

schluckebier
Posts: 1059
Nutzer
Zitat:
Original von Goos:
ok hab nochmal nachgeschaut, die shortcuts sind

Ctrl Alt +
und
Ctrl Alt -

und zwichen den Screenmodes zu switchen


Bei normalen Grafikkartentreibern klappt das auch, aber nicht beim Framebuffer, habe ich gestern extra mal ausprobiert. Überhaupt scheint der Framebuffer etwas sehr Eigensinniges zu sein, ich bin heilfroh, dass ich den nicht brauche. ;o)

Rotzloeffel, hast du mal probiert, ob dein X-Server nicht auch mit vesa statt fbdev funktioniert?

[ - Antworten - Zitieren - Direktlink - ]

22.03.2006, 19:40 Uhr

Rotzloeffel
Posts: 219
Nutzer
@schluckebier:

Rotzloeffel, hast du mal probiert, ob dein X-Server nicht auch mit vesa statt fbdev funktioniert?

sorry, schluckbier es ist leider für die Kiste nur ein fbdev-treiber verfügbar. Ich habe bei einem Kumpel schon mal mit einer Retina grafigkarte experimentiert und da klappt die 1024 auflösung per bootparameter perfekt. nur bei dem clgen treiber versagt die anleitung vollständig ! ich denke, dass der treiber nicht mehr für diesen aktuellen kernel geeignet ist. evtl. muss der kernel neu kompiliert werden. Aber davon hab ich soviel ahnung wie ein fisch vom Fahradfahren.

gruss

Rotzloeffel

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Hilfe mit X-Server unter Debian auf dem Amiga [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.