amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Mad TV [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

25.05.2006, 16:39 Uhr

elprincipal
Posts: 54
Nutzer
HI!

Habe gerade wieder einml Mad Tv herausgekramt und gleich 3 Stunden investiert in dieses Klasse Spiel.

Allerdings stoßen mir mehrere Sachen auf:

1. Whdload Paket führt bei mir regelmäßig zu abstürzen, an unterschiedlichen Stellen, gibt es ein anderes HD-Install Paket was funktioniert (A1200, 1260, 128 MB Ram, AGA only, OS3.9 BB2 u.s.w.)

2. Gabs für dieses eigentlich mal ne Datadisk?
Ich meine mich erinnern zu können (Amiga Games) das da mal was war, wer weiß mehr?

Nin dankbar für jeden Tip. :)

Gruß

Sven

[ - Antworten - Zitieren - Direktlink - ]

25.05.2006, 17:57 Uhr

Chritoph
Posts: 548
Nutzer
Hi Sven!

Hattest du auf deinem Amiga einen TCP/IP Stack laufen?
Wenn Miami und WHDLoad sich treffen, hab ich IMMER freezes.

Wenn es das nicht war...
ich weiß, dass gleich alle sagen werden, der 60er ist nicht schuld, aber ich würde ihn als den Schuldigen ausmachen.
Mit 40er und 60er laufen meiner Erfahrung nach einige WHDLoads nicht.
Flink ist so ein Beispiel. Keine Chance mit 40er und 60er, kein Problem mit 30er. Kein Wunder, wenn der Autor nur nen 30er zum testen hat.
Schalte die Turbokarte doch mal ab.

.

.

.

.

.

Hm. Mit OS3.9 hast du dann ungefähr 512kb Speicher übrig. Das geht auch nicht. Wenn du keine Partition über 4GB für MadTV und WHDLoad benutzt, kannst du eine 3.1er Bootdiskette benutzen, um die Theorie zu überprüfen.
Sollte das klappen, erkläre ich die wie man ein 3.1/3.9 Bootmenü bastelt oder 3.1 automatisch hoch fährt, wenn nur ein 20er da ist. 8)
--
A4000T - 128 MB - 233MHz 604e - 50MHz 68060 - SCSI Platten - Voodoo 3 3000 / Mediator / SB4.1 digital / Highway / Norway / RLT8029

A1200 - 32 MB - 50MHz 68030 & 68882 - IDE Platten - Fiberline Netzwerkkarte

[ - Antworten - Zitieren - Direktlink - ]

25.05.2006, 18:56 Uhr

Stefan
Posts: 936
Nutzer
Zitat:
Original von elprincipal:
[Mad Tv]

Allerdings stoßen mir mehrere Sachen auf:

1. Whdload Paket führt bei mir regelmäßig zu abstürzen, an unterschiedlichen Stellen, gibt es ein anderes HD-Install Paket was funktioniert (A1200, 1260, 128 MB Ram, AGA only, OS3.9 BB2 u.s.w.)


Hast Du schon mal verschiedene Tooltypes versucht? Das Spiel
selbst läuft auch einfach mit NoAGA oder KillAGA.

PS: Ich weiss das ich das Spiel irgendwo (A-Future CD ?) habe.
Wenn ich es finde, kann ich es mal auf BPPC+060 testen.

Gruß Stefan

:boing:

[ - Antworten - Zitieren - Direktlink - ]

25.05.2006, 19:14 Uhr

AndreasM
Posts: 2476
Nutzer
@Stefan

Auf der Amiga Future 12 war es drauf.

@elprincipal

Es gibt keine Data Disk für Mad TV. Zuminderst nicht für den Amiga.
--
Andreas Magerl
APC&TCP
Amiga Future

[ - Antworten - Zitieren - Direktlink - ]

25.05.2006, 19:31 Uhr

Stefan
Posts: 936
Nutzer
Zitat:
Original von AndreasM:
@Stefan

Auf der Amiga Future 12 war es drauf.


Danke, per FDB oder AmiSearch hätte ich es wahrscheinlich
rausgefunden, jetzt kann ich mir das sparen und brauche nur
noch die CD suchen. :)

Gruß Stefan

:boing:


[ - Antworten - Zitieren - Direktlink - ]

25.05.2006, 19:35 Uhr

AndreasM
Posts: 2476
Nutzer
Geht auch viel einfacher. Einfach die Datenbanken auf unserer Page benutzen :)
--
Andreas Magerl
APC&TCP
Amiga Future

[ - Antworten - Zitieren - Direktlink - ]

25.05.2006, 23:14 Uhr

elprincipal
Posts: 54
Nutzer
Hi!

Joh danke an alle.

Schade das es keine Datadisk gibt..

Wenn ich von Disketten spiele funktioniert alles, ohne runterschalten des Rechners.

Mit WHDload (Tooltypes Noaga, killaga, pal, nocache) taugt alles nichts nommu darf ich nicht einstellen da sonst gar nichts mehr startet.

Bevor ich auf 3.9 umgeschwenkt bin (ist schon ne zeitlang her) hatte ich mal die Dateien von Hand kopiert und zwei assigns mit den diskettennamen aufdas Verzeichnis angelegt, anschl. mit Original Chipsatz gestartet und es ging, jetzt aber nach Jahren nicht mehr.

Tcp/ip ist genauso wie Poseidon Stack deaktiviert.

Bin ziemlich ratlos, gibt es andere Tools um den start von platte zu managen?

Gruß

Sven

[ - Antworten - Zitieren - Direktlink - ]

26.05.2006, 07:43 Uhr

Stefan
Posts: 936
Nutzer
Zitat:
Original von elprincipal:

Mit WHDload (Tooltypes Noaga, killaga, pal, nocache) taugt alles nichts nommu darf ich nicht einstellen da sonst gar nichts mehr startet.


Noaga und Killaga sind keine Tooltypes von WHDload,
sondern seperate Tools (Degrader).

http://de4.aminet.net/util/misc/NoAGA.readme
http://de4.aminet.net/util/misc/killAGA2.5.readme

Gruß Stefan

:boing:




[ - Antworten - Zitieren - Direktlink - ]

26.05.2006, 13:58 Uhr

elprincipal
Posts: 54
Nutzer
HI!

Mhm, wie funktionieren eigentlich diese Degrader Tools?

Könnt ihr mir eine kurze Anleitung geben?

Ich glaube die Amigafuture Ausgaben habe ich auch, muß mal schauen ob ich die finde.

Bin dabei jetzt ein großteil meiner Sammlung mit whdload auf platte zu sichern, ist echt ein tolles Programm, muß ich jetzt mal demnächst registrieren, damit der Reuester weg ist :rolleyes:


[ - Antworten - Zitieren - Direktlink - ]

26.05.2006, 16:05 Uhr

Stefan
Posts: 936
Nutzer
Zitat:
Original von elprincipal:
Mhm, wie funktionieren eigentlich diese Degrader Tools?
Könnt ihr mir eine kurze Anleitung geben?


Es gibt weder viel zu beachten, noch ist es kompliziert.
NoAGA legt dir ein Icon auf die WB, dort wirfst Du einfach
die "mtv.exe" drauf. Start aus der Shell ist auch möglich.
(Eine deutsche Anleitung ist ebenso dabei)

Bei Killaga, einfach in der Shell "killaga mtv" eingeben.

PS: Habe die AFuture-CD gefunden und teste es mal mit WHDload

Edit:
----

Also ich habe verschiedene Tooltypes durchprobiert und die
WBStartup abgeschalten etc. Ich kann bestätigen, dass der
Slave nicht benutzbar ist. Auch hier stürzt das Spiel nach
kurzer Zeit ab. Es reicht schon aus z.B. das Büro zu
betreten und den Sendeplan zu ändern. Danach gibt es einen
Absturz oder der Rechner friert einfach ein.
Nach Speichern eines Spielstandes startet das Game jetzt
überhaupt nicht mehr, keine Fehlermeldung der Rechner
friert sofort ein oder stürzt komplett ab.

Bei mir ruckelt zudem der Mauspfeil ziemlich. Es wäre schön,
wenn es mal jemand auf einem 040 oder 030 testen könnte.

Ich würde sagen, klassischer Fall für einen Bugreport,
aber vielleicht bestätigt noch jemand, dass es bei Ihm
läuft.

Meine Testumgebung:
------------------

A1200 BPPC/060/BVision/IDEFix/PFS3, OS 3.9 BB2 + Aminet-Patches,
CGX 4.2, WHDload 16.4x, mtv.slave 1.1

Gruß Stefan

:boing:


[ Dieser Beitrag wurde von Stefan am 27.05.2006 um 11:04 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

27.05.2006, 21:42 Uhr

elprincipal
Posts: 54
Nutzer
HI!

Klasse für deine Forschungsarbeit, kann ich nur bestätigen das der Slave schlecht ist.

Mithilfe der Tools klappt es damit?

Gruß

Sven

[ - Antworten - Zitieren - Direktlink - ]

28.05.2006, 14:28 Uhr

elprincipal
Posts: 54
Nutzer
HI!

Habe die beiden degrader Tools ausprobiert und bin nicht wirklich weitergekommen:

KillAga: führt zu gar nichts ausser einem Guru

NoAGA: Startet in Standardeinstellungen und stürzt anschließend irgendwann im Laufe des ersten Tages ab.

Hat jemand schon probiert ob es vielleicht mit einer anderen Einstellung funktioniert?

Mhm, echt ein schwieriger Fall das ganze.

Gruß

Sven

[ - Antworten - Zitieren - Direktlink - ]

28.05.2006, 18:48 Uhr

Stefan
Posts: 936
Nutzer
Zitat:
Original von elprincipal:

Habe die beiden degrader Tools ausprobiert und bin nicht wirklich weitergekommen:

KillAga: führt zu gar nichts ausser einem Guru

NoAGA: Startet in Standardeinstellungen und stürzt anschließend irgendwann im Laufe des ersten Tages ab.

Mhm, echt ein schwieriger Fall das ganze.


Mittlerweile muss ich etwas revidieren, was ich zuvor
geschrieben, habe, denn offensichtlich ist der "Slave" nicht
der Schuldige. MadTV ist "buggy". Ein besseres, längeres oder
ausführlicheres Log kriege ich nicht hin, da der Rechner leider
einfriert, wenn MuForce läuft, schalte ich MuGuardian noch dazu,
bekomme ich gar kein Log mehr.


28-Mai-06 17:38:51
LONG WRITE to 0000006C data=66FA9DCC PC: 66FA9D36
USP : 66FC67FC SR: 0000 (U0)(-)(-) TCB: 66F0C358
Data: 00000015 B8F00001 000003ED 66D1EA90 00000003 19BC4357 19BC3591 66F6CD94
Addr: 0001B770 0001B848 66F3F226 66F6CD94 66F4602E 66FC68A2 66013D3C 66002654
Stck: 000003ED 66D1EA90 00000003 19BC4357 19BC3591 66F6CD94 66F0C358 66F6CD94
Stck: 66F4602E 66FC68A2 66032814 66F6D508 66D1EA90 66D1EA90 668416C4 6BE56FD8
----> 66FA9D36 - "mtv" Hunk 0001 Offset 0003CF9E
Name: "Shell Process" CLI: "mtv" Hunk 0000 Offset 0003CF9E


28-Mai-06 18:27:11
LONG WRITE to 0000006C data=671163F4 PC: 6711635E
USP : 6712C134 SR: 0000 (U0)(-)(-) TCB: 670D7650
Data: 00000015 06480002 000003ED 670D8B80 00000001 19BE851F 19C35BB5 670D93BC
----> 670D93BC - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0001 Offset FFFFFFFC
Addr: 000204C8 000205A0 6711BA4E 670D93BC 67122856 6712C1DA 66013D3C 66002654
----> 6712C134 - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0005 Offset 00007244
Stck: 000003ED 670D8B80 00000001 19BE851F 19C35BB5 670D93BC 670D7650 670D93BC
Stck: 67122856 6712C1DA 66032814 670D9B30 670D8B80 670D8B80 668401D4 6BE56FD8
----> 6711635E - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0001 Offset 0003CF9E
----> 670D93BC - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0001 Offset FFFFFFFC
----> 670D93BC - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0001 Offset FFFFFFFC
----> 67122856 - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0002 Offset 00007FFE
----> 6712C1DA - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0005 Offset 000072EA
----> 670D9B30 - "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0001 Offset 00000770
----> 6BE56FD8 - "ROM - exec 45.20 (6.1.2002)" Hunk 0001 Offset 00003AE8
PC-8: 4841D2BC 00000028 31410026 48413141 00224279 6711B92A 23F8006C 6711640A
PC *: 21FC6711 63F4006C 33FC8010 00DFF09A 23F96711 B8DC00DF F0804279 00DFF088
6711633e : 4841 swap.l d1
67116340 : d2bc 0000 0028 add.l #$28,d1
67116346 : 3141 0026 move.w d1,$26(a0)
6711634a : 4841 swap.l d1
6711634c : 3141 0022 move.w d1,$22(a0)
67116350 : 4279 6711 b92a clr.w $6711b92a
67116356 : 23f8 006c 6711 640a move.l $6c.w,$6711640a
6711635e : *21fc 6711 63f4 006c move.l #$671163f4,$6c.w
67116366 : 33fc 8010 00df f09a move.w #-$7ff0,$dff09a
6711636e : 23f9 6711 b8dc 00df f080 move.l $6711b8dc,$dff080
67116378 : 4279 00df f088 clr.w $dff088
Name: "Background CLI" CLI: "Amiga-Future-12:Vollversion/MadTV/mtv" Hunk 0000 Offset 0003CF9E

Jetzt habe ich keine Lust mehr, das noch weiter zu testen,
denn so richtig Sinn hat es nicht. Auch ein Bugreport mit
einem WHDLoad-Dump ist vermutlich ebenso sinnlos.

Gruß Stefan

:boing:

[ - Antworten - Zitieren - Direktlink - ]

28.05.2006, 20:17 Uhr

Supermatse
Posts: 137
Nutzer
Moin,

also ich habe Mad TV schon von Festplatte gespielt, bevor ich WhdLoad überhaupt kannte. Es läuft auf meinem CD32 mit SX32, 4mb fast. Hat also nichts mit AGA zu tun. Auf meinem 500er mit 030/40mhz lief es auch. Hat also nicht mit turbo zu tun. Könnte natürlich ne kombination aus beidem sein...

Jedenfalls habe ich das ganz primitiv einfach so gemacht.

- einfach die beiden Disketten in ein gewünschtes Verzeichnis ziehen (ich meine das Diskettenicon per drag and drop, so dass du auf der Festplatte ein Mad1 und ein Mad2 verzeichnis hast.
- dann mit Ed ein popeliges Skript schreiben, etwa so

assign mad1: sys:spiele/madtv/mad1
assign mad2: sys:spiele/madtv/mad2
cd sys:spiele/madtv/mad1
madtv

- abspeichern als z.B. Mad-Start
- per IconEd ein Projekt icon dafür machen und dann als Standardprogramm c:iconX
- doppelklick --> hurra

Die Anleitung habe ich jetzt aus dem Kopf geschrieben, will sagen: Die Namen könnten anders sein. Probier's mal aus, wenn's nicht klappen will, schaue ich nochmal genau nach.
--
supermatse.de
Selecta Novel's VG-Remixes

[ Dieser Beitrag wurde von Supermatse am 28.05.2006 um 20:18 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

30.05.2006, 18:31 Uhr

elprincipal
Posts: 54
Nutzer
HI!

Nett von dir zu schreiben supermatse, aber...

Die von die beschriebene Methode habe ich auch lange Zeit so gehandhabt, bis vor 2-3 Jahren.

Dann nach OS3.9 und 060'er ging es nicht mehr so, hatte gehofft das whdload da Abhilfe schafft.

Ich glaube das MadTv mit irgnedwas kollidiert was vom Betriebssystem oder dem 060'er kommt.

Trotzdem danke...

Gibt es noch vielleicht einen heißen Tip für mich?

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Mad TV [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.