amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Andere Systeme > Brauche Hilfe bei Suse Linux 10.0 [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

16.06.2006, 19:04 Uhr

Amaris
Posts: 941
Nutzer
Hallo

Ich habe seit gestern Suse 10.0 und habe es gerade mal installiert. Meine bisherige Erfahrung mit Linux = NULL. Ich war nur neugierig und wollte es mal ausprobieren.
Ich hab es auf eine zweite Festplatte installiert, die eigentlich primär dazu dient Backup-Images zu archivieren.

Die Installation (von DVD) klappte bis zum Neustart eigentlich problemlos. Nach dem Neustart des Systems und dem Auswählen von "Suse Linux 10.0" im Boot-Menü von "Grub" tat sich jedoch gar nichts mehr.

Ich sah einfach nur den Lade-Bildschirm von Suse - sonst tat sich nichts, keine Aktivität der Festplatte.
Ich habe dann in "Grub" die Option "Suse Linux 10.0 (Failsafe)" ausgewählt. Daraufhin konnte ich die Installtion fortsetzen, bekam aber die Meldung daß der Grafik-Modus nicht geladen werden könne da es scheinbar irgendwie ein Problem mit meiner Grafikkarte gäbe, oder sowas.

Nun ist die Installation abgeschlossen aber ich kann immer noch nur diese Failsafe-Option in Grub auswählen, sonst bleibt er wieder beim Lade-Bildschirm hängen.
Außerdem komme ich auch nur in die Eingabeaufforderung. In die graphische Benutzeroberfläche komme ich eben nicht.

Kann mir jemand sagen was da schief läuft und was ich machen kann ?

Mein System:

Fujitsu-Siemens Pentium IV @ 3,2 GHz
1024 MB RAM
2 x 200 GB HDD (Suse ist auf einer Partition der zweiten Platte)
ATI Radeon 9800 Pro
DVD-ROM
DVD-Brenner



--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

16.06.2006, 20:12 Uhr

ipp0
Posts:
[Ex-Mitglied]
Was ist der Lade- Bildschirm? Steht da irgendwas?
So wie sich das anhört, ist der bootloader nicht korrekt installiert worden.
Ich würde in diesem Fall mal schauen, ob es beim Booten von DVD eine rescue- Option gibt, mit der man ggf. den bootloader neu installieren kann.
Wenn du mit failsafe bis ins System kommst, kannst du ja mal die /etc/grub.conf unter die Lupe nehmen.

ee, joe (oder irgendeinen editor) /etc/grub.conf

Ansonsten sollte man auch mit ner live-cd reinkommen. Mit grub kenn ich mich nicht aus. Probier mal ob's mit lilo geht - falls du die Möglichkeit hast, es nachträglich zu installieren.

gruß

[ - Ändern - Antworten - Zitieren - Direktlink - ]

16.06.2006, 22:55 Uhr

Amaris
Posts: 941
Nutzer
Zitat:
Original von ipp0:
Was ist der Lade- Bildschirm? Steht da irgendwas?


Er sieht fast so aus:

Bild: http://forumsuse.free.fr/ftp/suse10/boot2.jpg

Jedoch sind die 4 Symbole auf der rechten Seite etwas anders.
Bei mir sind da (von unten nach oben) Folgende Symbole zu sehen:
Festplatte, Tastatur, Steckkarte, Computer
Außerdem soll man nicht F2 sondern ESC für weitere Informationen betätigen

Beim Booten von DVD kommt derselbe Bildschirm und es gibt keine Probleme. Beim Booten von HDD bleibt er schon hängen bevor die Tastatur initialisiert wude, ich kann also auch nicht ESC drücken um zu sehen was eventuell nicht stimmt.


--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

16.06.2006, 23:19 Uhr

LarryJones
Posts: 92
Nutzer
Zitat:
Original von Amaris:
Außerdem soll man nicht F2 sondern ESC für weitere Informationen betätigen


Meine Frage dabei: Zeigt er dir nach dem Drücken weitere Informationen an, wovon einige, zb. grafik-treiber, rot sind (Meldung: failt)?

--
____________________________________
PC Wars Episode X - The Return of the Amiga :boing:
:commo: A600HD/30MB - Kickstart 3.1 - AOS 3.1
:commo: A1200HD/40GB - Kickstart 3.1 - AOS 3.9 - Blizzard 1230 IV - CPU 68030@50Mhz SCSI

[ - Antworten - Zitieren - Direktlink - ]

16.06.2006, 23:52 Uhr

harryfisch
Posts: 954
Nutzer
Wenn Du von der 10.0 DVD bootest kannst Du dort im Menue ja von Festplatte Booten anklicken. Wird dann normal gebootet? Dann könntest Du nochmal booten und Installation anklicken. Daraufhin wird eine Reparatur angeboten.
Schau Dir doch ausserdem mal an wo der Bootvorgang von Festplatte hängen bleibt eben durch drücken von ESC. Wie ipp0 schon sagte.
p.s.
Soll ich dir eine open Suse 10.1 DVD machen und senden? Ich meine Falls kein DSL vorhanden wie bei mir... sonst gibts im Supermarkt gerade EasyLinux mit der 10.1 und den ganzen fehlenden Multimedia Sachen auf einer weiteren DVD. (Vorhin gesehen kostet aber 12.- Euro oder so)







:bounce:
--
Amiga 500 1 MB Chip; OS 1.3 D

x86, PIV Prescott 3400, Geforce 7800 GS, 2GB DDR 400; openSuse 10.1

[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 01:11 Uhr

Schorchgrinder
Posts: 617
Nutzer
mh wenn dieses Bild bei dir kommt dann liegt der Fehler nicht beim GRub sondern bei der KDE-Einstellung .Den Bootscreen bekommst du wohl nicht weg ?


title=Linux 2.6.16-gentoo-r7
root (hd0,6)
kernel /boot/kernel-genkernel-x86-2.6.16-gentoo-r7 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda7 video=vesafb:mtrr,ywrap,1024x768-32@75 splash=verbose
initrd /boot/initramfs-genkernel-x86-2.6.16-gentoo-r7


wichtig wäre da ob das splash=verbose da ist

die Grub.conf liegt hier bei mir auf /boot/grub/ aber das kann bei SuSE ein bissel anderst aussehen .
--
CU Schorchgrinder


[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 09:19 Uhr

Amaris
Posts: 941
Nutzer
@Larryjones & Harryfisch:

Ich kann nicht ESC drücken, wie oben schon gesagt - die Tastatur reagiert beim Booten von HDD ja nicht.

Nur beim Booten von DVD kann ich ESC drücken und sehe dann zig Meldungen von Unten nach Oben rattern, so daß kaum viel zu erkennen ist - aber Fehlermeldungen sind mir da nicht aufgefallen.


Zitat:
Original von Schorchgrinder:
mh wenn dieses Bild bei dir kommt dann liegt der Fehler nicht beim GRub sondern bei der KDE-Einstellung .Den Bootscreen bekommst du wohl nicht weg ?


Nein, leider nicht. Die Tastatur reagiert eben nicht.

@Harryfisch:

Danke für das Angebot mit der DVD, aber DSL habe ich selbst. Allerdings habe ich einen Volumentarif und möchte mir den Download diesen Monat gerne sparen. Daher würde ich schon gerne 10.0 zum Laufen bekommen (habe ich von einem Bekannten gebrannt).


--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 10:23 Uhr

Amaris
Posts: 941
Nutzer
Ich habe jetzt mal Folgendes gemacht.

Gebootet mit der Option "Suse Linux 10.0 (Failsafe)". Dann kommt eben die Eingabeaufforderung.
Ich habe nun irgendwo gelesen daß man von der Eingabeaufforderung durch Eingabe von "KDE" in die graphische Benutzeroberfläche kommen soll.

Ich habe also "KDE" eingegeben und es kamen folgende Fehlermeldungen:



xset: unable to open display ""
xset: unable to open display ""
xsetroot: unable to open display ''
startkde: Starting up
kdeinit: Aborting. $Display is not set
Warning: connect() failed: No such file or directory
ksmserver: cannot connect to X server
ERROR: couldn't attach to DCOP server!
startkde: Shutting down
Warning: connect() failed: No such file or directory
Error: Can't contact kdeinit!
/usr/X11R6/bin/kde: line 274: artsshell: command not found
startkde: Running shutdown scripts...
startkde: Done.


Tja...


--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 11:42 Uhr

Dr_Dom
Posts: 655
Nutzer
Hallo Amaris,

ich würde mal alle HDD's abhängen, und nur eine für die Suse Installation dran machen. Neu Installation.. und dein bios auf Default werte stellen. Dein System sollte eigentlich unterstützt werden.

Ich hatte aber auch etwas stress als meine XP-Platte mit lief, also habe ich Suse erst mal allein installiert und die XP-Hdd später im System integriert. Dann ging es!

Bei der Installation genau darauf achten das auch die Pakete für das Grafische System installiert werden.

Suse 10.0 ist schon ein recht ausgewachsenes Linux-system, für so manchen Linux-Freak schon zu ausgewachsen ohne ecken und Kanten ( so wie man es von Linux eigentlich gewöhnt ist.). Nach der Installation und update einiger Pakete läuft es sehr stabil und ohne Probleme.

Ich hoffe es hilft dir weiter.




--
Bild: http://i11.photobucket.com/albums/a166/docdom/DOC_1.jpgcu. Doc_Dom

wenn Dein Rechner defekt ist, funktioniert der Ersatzrechner erst recht nicht

Murphy


[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 11:48 Uhr

Amaris
Posts: 941
Nutzer
Also....ich habe jetzt noch etwas gegoogelt und habe ältere Foren-Postings mit ähnlichen Problemen gefunden.

Irgendwo sagte mal jemand daß man den X-Server starten müsse (was ist das ???), durch Eingabe von "startx" in der Eingabeaufforderung.
Das habe ich gemacht und....schwupps....KDE startete auf der Stelle. Ich schreibe gerade diesen Eintrag von Linux aus.

Was hat das jetzt zu bedeuten ?

Was muß ich machen um KDE nicht immer von der Konsole aus starten zu müssen ???




--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 11:54 Uhr

Dr_Dom
Posts: 655
Nutzer
Gib mal in der Console ( Terminal) „ yast „ ein, dort kannst du die Startoptionen festlegen !

Startoptionen = Grafisch!

Wenn es dann endlich läuft kannst du zwischen den Consolen mit z.B alt/F2 alt/F7 umschalten. Ich benutze lieber Yast in der Console als Yast2 unter KDE.


--
Bild: http://i11.photobucket.com/albums/a166/docdom/DOC_1.jpgcu. Doc_Dom

wenn Dein Rechner defekt ist, funktioniert der Ersatzrechner erst recht nicht

Murphy


[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 12:03 Uhr

Schorchgrinder
Posts: 617
Nutzer
kde wird mit kdm gestartet
gnome gdm usw

hast du ne usb tastatur ?
ich fürchte bei dir werden einige kernelmodule nicht mitgeladen

solong

--
CU Schorchgrinder


[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 17:02 Uhr

Raudi
Posts: 79
Nutzer
@Amaris:

KDE läuft auch auf einem X-Server wie xorg der vorher gestartet werden
muss. Gib startx oder startx startkde ein. Wenn der X-Server korrekt
konfiguriert ist, sollte es funktionieren.

[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 18:35 Uhr

Amaris
Posts: 941
Nutzer
Zitat:
Original von Raudi:
@Amaris:

KDE läuft auch auf einem X-Server wie xorg der vorher gestartet werden
muss. Gib startx oder startx startkde ein. Wenn der X-Server korrekt
konfiguriert ist, sollte es funktionieren.


Ja, wie oben schon geschrieben funktioniert es mit startx von der Eingabeaufforderung aus. Aber das kann ja nicht die Lösung sein. Ich habe aber jetzt mein Problem in zwei Linux-Foren geschrieben, vielleicht bekomme ich dort Hilfe.

Gruß,
Amaris

--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 21:34 Uhr

Raudi
Posts: 79
Nutzer
Dafür ist KDM zuständig, dass während des Bootvorgangs normalerweise
gestartet wird.

[ - Antworten - Zitieren - Direktlink - ]

17.06.2006, 21:43 Uhr

ipp0
Posts:
[Ex-Mitglied]
Poste mal deine /etc/inittab bitte.

gruß

[ - Ändern - Antworten - Zitieren - Direktlink - ]

17.06.2006, 22:31 Uhr

Amaris
Posts: 941
Nutzer
Zitat:
Original von ipp0:
Poste mal deine /etc/inittab bitte.

gruß


Bin gerade nicht am PC, aber wenn du mir sagst wie das geht werde ich das morgen sofort tun.

Wie gesagt - ich habe in einem Linux-Forum mein Problem gepostet und wir sind dort jetzt so weit daß mein Problem wohl Folgendes ist:

Linux bootet in Runlevel 3 statt Runlevel 5, obwohl in Yast Runlevel 5 eingestellt ist. Man meint dort daß meine Installation eventuell defekt ist. Auf der DVD soll es eine Reparatur-Option geben, die werde ich morgen mal ausprobieren.

Siehe auch dieser Thread hier:
http://www.linuxforen.de/forums/showthread.php?t=215892


--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

18.06.2006, 10:18 Uhr

Amaris
Posts: 941
Nutzer
Zitat:
Original von ipp0:
Poste mal deine /etc/inittab bitte.


Habe sie jetzt gefunden, hier:

code:
#
# /etc/inittab
#

# Copyright (c) 1996-2002 SuSE Linux AG, Nuernberg, Germany.  All rights reserved.
#
# Author: Florian La Roche, 1996
# Please send feedback to http://www.suse.de/feedback
#
# This is the main configuration file of /sbin/init, which
# is executed by the kernel on startup. It describes what
# scripts are used for the different run-levels.
#
# All scripts for runlevel changes are in /etc/init.d/.
#
# This file may be modified by SuSEconfig unless CHECK_INITTAB
# in /etc/sysconfig/suseconfig is set to "no"
#

# The default runlevel is defined here
id:5:initdefault:

# First script to be executed, if not booting in emergency (-b) mode
si::bootwait:/etc/init.d/boot

# /etc/init.d/rc takes care of runlevel handling
#
# runlevel 0  is  System halt   (Do not use this for initdefault!)
# runlevel 1  is  Single user mode
# runlevel 2  is  Local multiuser without remote network (e.g. NFS)
# runlevel 3  is  Full multiuser with network
# runlevel 4  is  Not used
# runlevel 5  is  Full multiuser with network and xdm
# runlevel 6  is  System reboot (Do not use this for initdefault!)
#
l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
#l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6

# what to do in single-user mode
ls:S:wait:/etc/init.d/rc S
~~:S:respawn:/sbin/sulogin

# what to do when CTRL-ALT-DEL is pressed
ca::ctrlaltdel:/sbin/shutdown -r -t 4 now

# special keyboard request (Alt-UpArrow)
# look into the kbd-0.90 docs for this
kb::kbrequest:/bin/echo "Keyboard Request -- edit /etc/inittab to let this work."

# what to do when power fails/returns
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
#pn::powerfail:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# for ARGO UPS
sh:12345:powerfail:/sbin/shutdown -h now THE POWER IS FAILING

# getty-programs for the normal runlevels
# <id>:<runlevels>:<action>:<process>
# The "id" field  MUST be the same as the last
# characters of the device (after "tty").
1:2345:respawn:/sbin/mingetty --noclear tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6
#
#S0:12345:respawn:/sbin/agetty -L 9600 ttyS0 vt102

#
#  Note: Do not use tty7 in runlevel 3, this virtual line
#  is occupied by the programm xdm.
#

#  This is for the package xdmsc, after installing and
#  and configuration you should remove the comment character
#  from the following line:
#7:3:respawn:+/etc/init.d/rx tty7


# modem getty.
# mo:235:respawn:/usr/sbin/mgetty -s 38400 modem

# fax getty (hylafax)
# mo:35:respawn:/usr/lib/fax/faxgetty /dev/modem

# vbox (voice box) getty
# I6:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI6
# I7:35:respawn:/usr/sbin/vboxgetty -d /dev/ttyI7

# end of /etc/inittab



--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9



[ - Antworten - Zitieren - Direktlink - ]

18.06.2006, 16:18 Uhr

Amaris
Posts: 941
Nutzer
Seltsam - ich habe nun mal etwas herumprobiert.
Ich habe bei den Bootoptionen ein "acpi=off" hinzugefügt und jetzt klappt alles prima. Keine Ahnung warum oder ob das die "korrekte" Lösung ist, jedenfalls geht es jetzt.

Wie ich darauf gekommen bin:

Bevor der Rechner beim Booten einfror habe ich einfach mal schnell hintereinander ESC gedrückt und tatsächlich wurden dann die ganzen Meldungen des Bootens angezeigt.

Die letzten beiden Zeilen (also vor dem Absturz) begannen mit ACPI....(und dann irgendwas weiter).

Irgendwo habe ich schonmal die Option acpi=off gesehen und sie dann einfach mal ausprobiert ==> es funktionierte.



--
:amiga: Amiga 1200, Infinitiv-Tower, Blizzard 1230 III, Mediator 1200 LT4, 2 MB Chip / 32 MB Fast-RAM, 4 GB HDD, Voodoo 3, Realtek Ethernet-Karte, CD-Brenner, OS 3.9




[ Dieser Beitrag wurde von Amaris am 18.06.2006 um 16:18 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

19.06.2006, 12:56 Uhr

kadi
Posts: 1503
Nutzer
Ich hatte auch mal ACPI Probleme.

Einmal war das BIOS nicht richtig konfiguriert. Bei dem BIOS konnte man zwei Einstellungsstufen von "Default settings" wählen, einmal "Best Performance" und einmal "Optimal Settings", egal was ich auswählte, danach gings, nach einem BIOS-Reset (was bei meieem K7S5A gelegentlich von alleine passiert) muss ich wieder eine der beiden "default Settings aktivieren.

Bei einem schon betagten Athlon 700 Board von ASUS funktioniert ACPI mit Standardkernel nicht, der Rechner bootet zwar durch, aber Powerbutton, Ausschalten und co funktionieren nicht. Wähle ich einen K7 Kernel aus, funktioniert es.

Den Kernel installiert man über den Paketmanager. Meist ist er dann bereits in GRUB voreingestellt, der alte ist aber noch da und lässt sich über GRUB im Zweifelsfall auswählen, zumindest bei Ubuntu und Mandrake ist das so.

An deiner stelle würde ich also mal nach nem an den Prozessor angepassten Standard-Kernel gucken, kann ja nicht schaden.

Ohne ACPI kann man leben, besser ist aber mit.

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Andere Systeme > Brauche Hilfe bei Suse Linux 10.0 [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.