amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Andere Systeme > WinXP findet Gerät immer wieder neu! [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

04.07.2006, 16:35 Uhr

bubblebobble
Posts: 707
Nutzer
Hallo Leute!

Windows sucks, ich weis, aber es läuft nunmal WinUAE drauf. :glow:

Mein Problem:

Ich habe mir ein tolles kabelloses USB Keyboard gekauft, was dank BIOS support auch einigermassen unter Amtihlon läuft. Am gleichen Emfpänger hängt allerdings noch eine Maus, die aber Müll ist und meine PS2 Kabelmaus ist viel besser. Also schalte ich die Maus aus, bzw. habe keine Batterien drin.
Windows bringt jetzt aber jedesmal beim Booten "Maus gefunden", da der Funk emfänger eine Maus vorgaukelt. Selbst wenn ich einen Treiber installiere wird die Maus immer wieder neu gefunden.

Was kann ich da machen ? Das Booten dauert viel länger, weil jedesmal der Setup Assisten aufpoppt und eine Festplatten Orgie losgeht.

Ich habe auch schon versucht, das Gerät in Gerätemanager auszuschalten, hilft aber nichts. Sieht so aus, als ob USB Geräte immer "flüchtig" sind, und wenn es da ist, will Windows auch immer einen Treiber dazu haben.


--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

04.07.2006, 17:59 Uhr

Holger
Posts: 8090
Nutzer
Zwei Dinge, die ich daran nicht verstehe.
1) Wenn man ein USB-Gerät abzieht, wird der Treiber nicht deinstalliert. Man muß ihn normalerweise also auch nicht wieder installieren, wenn das Gerät "erneut gefunden" wird
2) Wieso braucht so etwas triviales wie eine Maus einen zusätzlichen Treiber? Eine Maus sollte auch mit den HID-Treiber von WindowsXP funktionieren.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

04.07.2006, 18:03 Uhr

Schorchgrinder
Posts: 617
Nutzer
îm notfall sperr die sache unter dem (ich glaub geräteman.) und sag in allen profilen .

wobei mir der empfänger für die maus unklar ist ,kannst du den net abmachen ?
--
CU Schorchgrinder


[ - Antworten - Zitieren - Direktlink - ]

04.07.2006, 18:15 Uhr

bubblebobble
Posts: 707
Nutzer
Ja, ich verstehe es auch nicht.
Natürlich, ich kann den Microsoft Standard HID Treiber angeben, dann ist Windows auch zufrieden, und sagt "Geräte installier und kann jetzt benutzt werden ... blabla", aber eben nur für diese Session. Sobald ich neu boote, kommt wieder "Maus gefunden..." und der Setup Assistent öffnet sich.

Im Gerätemanager deaktivieren hilft nichts. Bei der nächsten Session wird das USB Gerät erneut erkannt, habe ich alles schon versucht.

Es ist ein "Kombi" Empfänger für das Keyboard und für die Maus, die dann in einem gemeinsamen USB Kabel in den Rechner gehen. Deshalb kann ich nicht das Keyboard alleine anschliessen. Für den Rechner sieht es also so aus, als ob immer eine Maus und ein Keyboard dran hängen (Emfpänger), auch wenn die eigentlichen Geräte ohne Batterie im Schrank liegen.

--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

04.07.2006, 22:17 Uhr

G60Master
Posts: 601
Nutzer
Herstellerfehler würde ich mal tippen,das läßt sich wenn überhaupt nur mit einem Eintrag in der Registry beheben,dort muß die Mauserkennung deaktiviert werden.

Gibt es bei einigen "Funksystemen",immer dann wenn am "Funk" noch weiter gesplittet wird um mehrere Geräte anzubinden tauchen diese Probleme auf.

Einen zusätzlichen Treiber an USB braucht man immer dann wenn man mehr als der Standardtreiber will,das kann schon die Zuordnung/Belegung der 3ten Maustaste sein oder Scrollradsupport.

Solche Probleme gab es früher auch immer wieder bei der Kombination ISA-Soundkarte und ISA-Netzwerkkarte,da habe ich manchmal die ganze Nacht durch gedreht und getauscht bis der Rechner vom Kumpel dann doch machte. :rotate:
--
G60Master

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 01:45 Uhr

Maja
Posts: 15429
Nutzer
@bubblebobble:

Welches Produkt ist das genau (Hersteller, Bezeichnung)?

> Sieht so aus, als ob USB Geräte immer "flüchtig" sind,

Sind sie eigentlich nicht. Wenn ein USB-Gerät einmal installiert wurde, wird der Treiber nicht erneut installiert. Sebst dann nicht, wenn Du das Gerät vom Rechner trennst und später an denselben USB-Anschluss wieder anschließt, bzw. das Gerät erst einschaltest, nachdem Windows gestartet wurde.

> und wenn es da ist, will Windows auch immer einen Treiber dazu haben.

Na ja, dafür heißt es schließlich Plug'n Play. ;)

Versuche bitte mal Folgendes: Deinstalliere Tastatatur und Maus, trenne Beides vom Recher. Starte das System neu. Installiere nun nur den Tastaturtreiber und schließe die Tastatur an.

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 11:31 Uhr

Vip
Posts: 471
[Benutzer gesperrt]
bubblebobble

"Windows sucks, ich weis, aber es läuft nunmal WinUAE drauf. :glow: "

Naja, wenn es nur "Sucken" würde, dann wäre M$ morgen pleite!


"Ich habe mir ein tolles kabelloses USB Keyboard gekauft, was dank BIOS support auch einigermassen unter Amtihlon läuft."

Sei froh, hat aber nix mit Windows zu tun.

"Am gleichen Emfpänger hängt allerdings noch eine Maus, die aber Müll ist..."

Die Maus die zur Tastatur gehörte, oder ne andere Maus?

"...und meine PS2 Kabelmaus ist viel besser."

Warum nutzt Du die nicht, am PS2 Port?

"Windows bringt jetzt aber jedesmal beim Booten "Maus gefunden", da der Funk emfänger eine Maus vorgaukelt. Selbst wenn ich einen Treiber installiere wird die Maus immer wieder neu gefunden."

Ich vermute mal, Du vertrödelst deine Zeit mit Win98 oder schlimer Win98ME.
Oder Du hast den Falschen Treiber drin.

"Was kann ich da machen ? "

Ebay Rulez!

"Ich habe auch schon versucht, das Gerät in Gerätemanager auszuschalten, hilft aber nichts."

Fummel nicht da rum! :D

"Sieht so aus, als ob USB Geräte immer "flüchtig" sind, und wenn es da ist, will Windows auch immer einen Treiber dazu haben."

Geil, was N00bs immer für Urban Legends auf Lager haben. :lach:

Ich denke mal dein USB ist im ARS***. Hol dir ne 4 Fach USB PCI Karte bei Ebay. Gibt es für ein Taschengeld.

Einen schönen Tag noch










[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 11:35 Uhr

CarstenS
Posts: 5566
Nutzer
@Vip:
> Ich vermute mal, Du vertrödelst deine Zeit mit Win98 oder schlimer Win98ME.

Überschrift nicht gelesen?

Bei dem Problem bin auch ich ratlos und tippe auf einen Herstellerfehler - ich habe so was jedenfalls noch nicht erlebt.

[ Dieser Beitrag wurde von CarstenS am 05.07.2006 um 11:36 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 13:45 Uhr

bubblebobble
Posts: 707
Nutzer
@Vip:
Hast du eigentlich den Thread gelesen oder geht es dir nur um Frust-Abbau nach dem Halbfinal Spiel ?

Nachmal ganz langsam:

- ich benutze WinXP/WinUAE und Amithlon auf meinem Rechner
- ich habe eine PS2 Maus dran, die mir sehr gut gefällt
- ich habe mir eine Funk Tastatur gekauft, die mir ebenfalls
sehr gut gefällt. Leider war die Tastatur mit einer Maus
bebundelt, die aber schlecht ist. Das war mir aber egal, weil ich die Tastatur haben wollte.
- Funk Tastatur + Maus haben einen gemeinsamen Empfänger, der 1 USB Anschluss hat. Sobald der Empfänger dran ist, erkennt der Rechner eine Tastatur und eine Maus.
- ich lasse die Tastatur über den BIOS USB Support laufen, damit die Tastatur auch unter Amtihlon geht.
- unter WinXP sehe ich beide Geräte, und für beide kann ich Treiber installieren. Läuft prima mit den Windows Standard Treibern (HID konformes Gerät)

Problem:
Bei jedem Bootvorgang startet der Setup Assistent neu, mit der Meldung
"Neues Gerät gefunden: Maus", was mitunter recht Festplatten- und zeitintensiv ist, deshalb will ich das abstellen.
Auch mit angeschalteter Funk Maus verhält sich das so. Ich denke, der Rechner weiss gar nicht ob die Maus an oder aus ist, denn der Empfänger sagt immer "Hier bin ich, Maus + Tastatur".

Die Maus im Gerätemanager zu deaktivieren hilft nicht.

@Vip:

Ich bin weder N00b, noch ist mein USB Controller im AR...
Sieht so aus, als ob WinXP jedesmal denkt, es wäre eine andere Maus dran, obwohl es die gleiche ist. Deshalb hilft auch deaktivieren nichts, weil er sie beim nächstenmal nicht wiedererkennt.
Komischerweise habe ich manchnal bis zu 5 USB HID Geräte im Gerätemanager.

Ich werde mal ein bisschen rumprobieren. Wenns gar nicht geht, kann ich das Gerät wohl zurückgeben, oder? Ich denke das stellt schon eine Beeinträchtigung dar.
BTW, mit Poseidon unter Amtihlon läuft alles mit der Erkennung wunderbar. Nur kann ich hier die Tastatur nicht nutzen, weil der BIOS Support übergangen wird und der USB Treiber mit dem normalen input.device kein Keyrepeat unterstützt. Das "neue" input.device ist aber instabil und crashed nach ca. 1min Benutzung. (sollte ich mal an Chris schreiben).



--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 14:26 Uhr

Vip
Posts: 471
[Benutzer gesperrt]
"- Funk Tastatur + Maus haben einen gemeinsamen Empfänger, der 1 USB Anschluss hat.

Auch mit angeschalteter Funk Maus verhält sich das so. Ich denke, der Rechner weiss gar nicht ob die Maus an oder aus ist, denn der Empfänger sagt immer "Hier bin ich, Maus + Tastatur"."

Merkwürdig, bei der Logitech und der Microsoft Sender, hatte ich ein USB und ein PS2 anschluß gleichzeitig dran.

Da haste aber einen echten "Billigheimer" dir geholt.
Ich glaub Hama hat nur USB.

Naja, nu kennst Du das Problem!

Mach dir kein Streß, hol dir ein Cherry Tastatur und Maus set, gibt es schon für 26 Euro.

Cherry sind eh die besten Tastaturen die es zu kaufen gibt.

Qulität zahlt sich später doch aus. :)

Viel Spaß noch
Vip



[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 14:37 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von bubblebobble:
Komischerweise habe ich manchnal bis zu 5 USB HID Geräte im Gerätemanager.

Das ist nicht komisch, bei mir sind's ebenfalls exakt 5 Geräte. Ich vermute, daß die Kernfunktionalität, d.h. Standard Tastatur und Maus, und die zusätzlichen MM-Tasten, Scrollräder, etc. als unterschiedliche Geräte eingebunden werden. So spart man kompliziertere Treiberlogik ein, weil unterschiedliche USB-Eingabegeräte gleich behandelt werden können.

Außerdem taucht wahrscheinlich das "Verbundgerät", bestehend aus Tastatur und Maus auch als Eintrag im Gerätemanager auf, allerdings an anderer Stelle. Du kannst Dir ja auch die "Geräte nach Verbindung" vom Gerätemanager anzeigen lassen.

Wie auch immer, es ist jedenfalls normal.

mfg
--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 14:39 Uhr

bubblebobble
Posts: 707
Nutzer
Die Tastatur/Maus ist von Seitek, und hat etwa 40EUR gekostet, nichts Tolles also, aber auch kein Grabbel-Tisch-Billig-Dreck.
Nur weil es ein reines USB Gerät ist, heisst nicht automatisch das es ein "Billigheimer" ist. Die Tastatur ist wirklich sehr gut, ich bin da sehr empfindlich weil ich viel tippe.
Ich habe auf allen Tastaturen im "Makromarkt" herumgeklimpert, und die hat mir einfach am besten gefallen, weil sie sehr leicht und präziese geht.

--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 18:45 Uhr

Blackbird
Posts: 634
Nutzer
@bubblebobble:

>
- unter WinXP sehe ich beide Geräte, und für beide kann ich Treiber installieren. Läuft prima mit den Windows Standard Treibern (HID konformes Gerät)

<

was passiert den wenn du den Maustreiber zusätzlich installiert hast ?
--
regards
Blackbird

Have a look at:
http://www.blackbird-net.de

Skins for PlayCD OS3.9
BlackShoot, Zombies Apocalypse, GalagaWars
PerfectPaint

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 19:02 Uhr

bubblebobble
Posts: 707
Nutzer
Es ist egal was ich installiert habe. Die Maus wird jedesmal als neues Gerät gefunden.

--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 19:18 Uhr

Andreas_B
Posts: 3121
Nutzer
@bubblebobble:
Wird die Maus eigentlich auch denn jedesmal neu "gefunden", wenn Du sie tatsächlich "angeschlossen" (= mit Batterien und in Reichweite des Empfängers) hast?

Ciao,
Andreas.

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 19:47 Uhr

Blackbird
Posts: 634
Nutzer
@Andreas_B:


ahhh ja, gute Frage !


@Thilo
Falls ja, dann würde ich das Ding zurücktragen!
--
regards
Blackbird

Have a look at:
http://www.blackbird-net.de

Skins for PlayCD OS3.9
BlackShoot, Zombies Apocalypse, GalagaWars
PerfectPaint

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 22:35 Uhr

Vip
Posts: 471
[Benutzer gesperrt]
bubblebobble

"Die Tastatur/Maus ist von Seitek, und hat etwa 40EUR gekostet,...."

Saitek baut Tastaturen und Mäuse? *Schluck*
Ähm... eigentlich sind sie als Flightstik macher für den Homebereich bekannt.

"Ich habe auf allen Tastaturen im "Makromarkt" herumgeklimpert, ..."

Joh, das die kein IBM Rapit Access http://www.caseumbau.de/index.php?page=test70/test70 oder Cherry http://www.cherry.de/deutsch/produkte/tastaturen_mit_maus_master_solar.htm haben ist ja wohl klar.

Naja, klimper mal darauf wenn Du einen bei "Blödiamarkt" siehst.

Den Cherry CyMotion Master Solar müssten die ja haben. Ist wohl unter 30 Euro zu haben.


Einen schönen Abend noch

[ - Antworten - Zitieren - Direktlink - ]

05.07.2006, 23:15 Uhr

Vip
Posts: 471
[Benutzer gesperrt]
Das noch zum schluß : http://www.hardwarecrew.com/content/view/979/26/

Ich habe zwar eine Cherry Kompakt-Tastatur G84-4100 (damit schreibt man wie auf "Wolken"), aber ich werde mir höchst wahrscheinlich, das Tastatur/Maus Set in den oben genannten Link auch noch Kaufen. Sieht sehr gut aus, und die Tasten sind richtig Flach! Und für 25 Euro ziemlich günstig.

So bis Morgen

[ - Antworten - Zitieren - Direktlink - ]

06.07.2006, 12:03 Uhr

bubblebobble
Posts: 707
Nutzer
Also es ist tatsächlich so, dass wenn die Maus angeschaltet und zum Empfänger verbunden ist, meldet sich Windows nicht mehr. Nur wenn die Maus aus ist, bzw. keine Batterien drin sind.
Das ist aber ärgerlich, d.h. man kann die beiden Geräte nur zusammen vernünftig betreiben, meckern im Geschäft wird aber schwierig.
Ich verstehe aber nicht, warum man Windows nicht beibringen kann, die Maus einfach Maus sein zu lassen und nicht jedesmal den Setup Assistenten zu starten. Mit Poseidon gehts ja auch ;-)

Zum Glück gehen aber beide Mäuse (PS2 und USB) parallel.
Dann werde ich die USB Maus wohl angschaltet irgendwo hin legen müssen, als Dongle quasi.


--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

06.07.2006, 12:10 Uhr

Andreas_B
Posts: 3121
Nutzer
@bubblebobble:
>> meckern im Geschäft wird aber schwierig.

Mal vorausgesetzt, für Dich käme auch eine andere Tastatur in Frage:
Wenn Du denen Dein Problem schilderst und um Rücknahme oder Umtausch bittest, dann erweisen sich ProMarkt (daher hattest Du die doch?), MediaMarkt, Saturn, ... eigentlich immer als ziemlich unkompliziert.

Ciao,
Andreas.

[ - Antworten - Zitieren - Direktlink - ]

07.07.2006, 00:39 Uhr

Maja
Posts: 15429
Nutzer
@bubblebobble:

> meckern im Geschäft wird aber schwierig.

Da kann ich mich Andreas_B nur anschließen. Kassenbeleg und Originalverpackung sollte noch vorhanden und intakt sein. Einfach mal hingehen, das Problem schildern und dabei schön höflich bleiben. Dann sollte sich da was machen lassen. Schließlich wollen sie, dass Du als zufriedener Kunde wiederkommst. :)


[ Dieser Beitrag wurde von Maja am 07.07.2006 um 00:39 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Andere Systeme > WinXP findet Gerät immer wieder neu! [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.