amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > MorpOS [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

20.07.2001, 08:51 Uhr

Hammer
Posts: 2899
Nutzer
Hat eigentlich schon mal jemand den geschwindigkeitsunterschied zwischen einem MorpOssystem und einem normalen Amiga gemessen?
Würde mich mal interessieren.

MFG

Hammer

PS.: Wer hat eigentlich damals das Tool Systemspeed programmiert? Das läuft auf meinem Rechner nicht mehr!
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 09:37 Uhr

DJBase
Posts: 3354
[Ex-Mitglied]
Auf aktueller Amiga Hardware macht es relativ wenig Sinn. Die paar Programme, die davon profitieren (kenne eigentlich nur Voyager). Da ja weiterhin alles auf 68k Basis läuft und die Emu nicht genug Power aus den BPPC/CSPPC holen kann, ist ein "normales" Amiga-System deutlich schneller. Zum experimentieren oder so kann man es sich einmal anschauen, aber zum arbeiten nicht zu empfehlen. :nuke:
--
Member of Amiga User Group 99 - http://www.aug99.com

eMail - webmaster@djbase.de

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 10:10 Uhr

Stefan1200
Posts: 1056
Nutzer
Mich würde da auch mal YAM interessieren.
Und MUI gibt es doch auch für MorphOS, oder ?
Sind MUI Progs immer noch lahm ?
--
MfG Stefan1200

Amiga IRC Chat: http://amigafun.stefan1200.de
Wichtig: Rechtschreibfehler entstehen nur durch die elektronische Übertragung und sind daher vom Autor nicht gewollt. :) )

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 15:54 Uhr

TriMa
Posts: 2793
[Ex-Mitglied]
hmm, ich kann dir nur sagen dass MorphOS nachner gewissen Zeit auf a500 Speed runterschaltet*g*

Ich habe das Programm nicht mal zu starten bekommen, es blieb immer hängen und ich musste rebooten, wäre aber mal schön gewesen, MUI und Konsorten aud Speed zu sehen, hehe:)

--
MfG TriMa

Nintendo und Sega History unter
http://www.trimaweb.de.vu

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 16:28 Uhr

DJBase
Posts: 3354
[Ex-Mitglied]
Zitat:
Original von TriMa:
hmm, ich kann dir nur sagen dass MorphOS nachner gewissen Zeit auf a500 Speed runterschaltet*g*

Ich habe das Programm nicht mal zu starten bekommen, es blieb immer hängen und ich musste rebooten, wäre aber mal schön gewesen, MUI und Konsorten aud Speed zu sehen, hehe:)

--
MfG TriMa

Nintendo und Sega History unter
http://www.trimaweb.de.vu



Hm, naja, so vom Hocker gehauen hat mich das jetzt nicht. Keine Ahnung, ob das wirklich viel gebracht hat. Aufgefallen ist es mir jedenfalls nicht. :nuke:
--
Member of Amiga User Group 99 - http://www.aug99.com

eMail - webmaster@djbase.de

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 16:30 Uhr

Michael_D
Posts: 679
Nutzer
Hi,

also MorphOS läuft auf meinem Rechner sehr gut.
Wenn ich es nicht wüsste, würde ich es fast garnicht merken.
Besitzer einer 040/PPC-233MHz-Variante der Cyberstorm dürften
evtl. sogar eine subjektiv höhere 68k-Geschwindigkeit erhalten. :)

Hier ein AIBB-Modul:

http://home.nexgo.de/micky.d/bin/CybPPC-604e_233-MorphOS

und ein SysSpeed-Modul:

http://home.nexgo.de/micky.d/bin/SysSpeedmod.A4k_PPC_CVisionPPC

beide unter MorphOS erstellt. Das AIBB-Modul mit CGX-AGA.


MfG

Michael D.


A4000
CyberstormPPC 060/50MHz + 604e/233MHz +128MB
CyberVisionPPC
GoldenGate486SLC
HyperCOM4+


[ Dieser Beitrag wurde von Michael_D am 20.07.2001 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 16:53 Uhr

TriMa
Posts: 2793
[Ex-Mitglied]
:( aber warum funzt das wiedermal bei mir nicht, gibt es irgendwas was man beachten muss?
Config 1200/233/040-25/BV/96MB

--
MfG TriMa

Nintendo und Sega History unter
http://www.trimaweb.de.vu

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 17:04 Uhr

Stefan
Posts: 936
Nutzer
Auf meinem 1200 PPC 603+/210 060/50 läuft es auch recht gut,zumindest die PPC Seite.Die 68k Emu ist bei mir aber
schon merklich langsamer.Bei YAM merke ich aber einen Unterschied,insbesondere dann,wenn die Mails geholt,einsortiert
werden und auch beim Programmaufbau da MUIPPC viel schneller ist.
Auch das MagicmenuPPC macht Spaß,das geht sehr schnell,wenn man die Menüs öffnet.

Leider stürzen bei mir einige Programme ab,hauptsächlich die OS 3.9 Voreinsteller,der Virenchecker und Safe.
Und meine Uhrzeit scheint öfters verstellt 01-01-78,nachdem ich MorphOS laufen hatte bzw. es abgestürzt ist.



Gruß Stefan



:boing:

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 17:08 Uhr

Stefan
Posts: 936
Nutzer
@TriMa

Ein paar Sachen sind schon zu beachten,ich habe es damals auch nicht alleine geschafft.

Ich kann Dir ja mal meine SS mailen,wenn Du willst.Eigentlich hatte ich sie hier im Forum schon mal gepostet,aber ich finde sie nicht
mehr.


Gruß Stefan


:boing:



[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 17:15 Uhr

Hammer
Posts: 2899
Nutzer
Also, das man gar nichts merkt ist definitiv falsch!
Mit MUI und YAM usw. ist der Bildschirmaufbau von MUI applikationen wesentlich schneller. Und nicht nur das, macht mal den Notepad oder den alten Ed auf, das fetzt nur so beim öffnen!

Aber eigentlich wollte ich ja wißen, ob man da einen Faktor hat, wie z.B. 1,5x 86K Mui, oder so.

MFG

Hammer
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 17:31 Uhr

Stefan
Posts: 936
Nutzer
>Aber eigentlich wollte ich ja wißen, ob man da einen Faktor hat, wie z.B. 1,5x 86K Mui, oder so.

Wie soll man das messen :dance3:


Gruß Stefan


:boing:


[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 18:00 Uhr

TriMa
Posts: 2793
[Ex-Mitglied]
@Stefan

Jo, schickmal deine SS(hmmmmm) an meine addy, trima_@gmx.net
--
MfG TriMa

Nintendo und Sega History unter
http://www.trimaweb.de.vu

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 18:34 Uhr

Michael_D
Posts: 679
Nutzer
Zitat:
Original von TriMa:
:( aber warum funzt das wiedermal bei mir nicht, gibt es irgendwas was man beachten muss?
Config 1200/233/040-25/BV/96MB

--
MfG TriMa

Nintendo und Sega History unter
http://www.trimaweb.de.vu


Hi,

ganz wichtig: Blizkick (soweit installiert) aus dem Speicher entfernen!


@Hammer:

Das man garnichts merkt hat auch keiner gesagt.
Eher im Gegenteil. Ich freue mich, daß der PPC in der Lage ist
den 68060 so gut zu emulieren daß man, im äußerst positiven
Sinne, fast nicht merkt eine Emulation zu verwenden. :)


MfG

Michael D.

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 20:02 Uhr

TriMa
Posts: 2793
[Ex-Mitglied]
Danke @ Stefan wegen der SS, werde ich gleichmal durchgehen und ausprobieren
Damals hatte ich tatsächlich Blizkick drinne, was ich gestern rausgeschmissen habe:)

--
MfG TriMa

Nintendo und Sega History unter
http://www.trimaweb.de.vu

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 20:21 Uhr

DJBase
Posts: 3354
[Ex-Mitglied]
Zitat:
@Hammer:

Das man garnichts merkt hat auch keiner gesagt.
Eher im Gegenteil. Ich freue mich, daß der PPC in der Lage ist
den 68060 so gut zu emulieren daß man, im äußerst positiven
Sinne, fast nicht merkt eine Emulation zu verwenden. :)


MfG

Michael D.



Oh, da bist Du aber falsch unterwegs. Ein 060er ist deutlich schneller als die Emu auf den vorhandenen BPPC/CSPPC Karten. Es profitieren nur PPC Programme.
:nuke:
--
Member of Amiga User Group 99 - http://www.aug99.com

eMail - webmaster@djbase.de

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 21:19 Uhr

MagicSN
Posts: 238
Nutzer
Hi!

Den 060 erreicht MorphOS in seiner Emulations-Geschwindigkeit nicht, was hauptsaechlich daran liegt, dass eine interpretative 68k Emulation verwendet wird, was bedeutet, dass nur PPC Programme profitieren (und hier ist der Profit - sieht man von Kontextswitch-Extremfaellen ab - meist nicht so gross).

Ein PPC kann allerdings durchaus einen 060 in vernuenftiger Speed
emulieren. Ich habe hier eine fruehe Alpha-Version des JIT-68k-Emulators fuer WarpUP (das ist ein neuer Emulator, nicht der von Sam Jordan, der neue Emu ist von Almos Rajnai geschrieben, einem JIT-Emulations-Spezialisten), die versaegt alle bisherigen Emu's auf dem Amiga-PPC. Im Durchschnitt (bei 68k Anwendungen) etwa 5x so schnell wie die Emu von MorphOS :) Erreicht schon auf einer der
derzeitigen PPC-Karten echte 060-Speed :) )) Der Clue ist, dass ich
momentan (nur) eine 40 MHz 040 auf 68k-Seite drin habe, die Emu rennt Kreise um den 040 drum rum :)

Ich schaetz, auf nem AmigaOne sollte das Ding einen 150 MHz 060 bieten, oder was in der Art, so Vergleichsmaessig... dann profitieren nicht nur PPC-Programme von der neuen Hardware :)

Steffen

[ - Antworten - Zitieren - Direktlink - ]

20.07.2001, 21:25 Uhr

Michael_D
Posts: 679
Nutzer
Hi,

@Hammer:

solange man nicht MaxonCinema oder ähnliches benutzt natürlich.
Aber IBrowse oder auch Programme, wie FinalWriter arbeiten durchaus
angenehm.
StrICQ ist allerdings eine Ausnahme. Durch die vielen Pings wird die
Emulation offenbar sehr belastet, sodaß sogar der Mauszeiger ruckelt. :(

Und eine BlizzardPPC kann sicherlich keinen 68060 in voller Geschwindigkeit emulieren.
Bei der CyberstormPPC mit 233MHz sieht das schon wesentlich besser aus.

Außerdem profitiert die Emulation von breits nativen System-Bestandteilen,
wie CGX5 und SFS-PPC.

MfG

Michael D.

[ Dieser Beitrag wurde von Michael_D am 20.07.2001 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 11:05 Uhr

Hammer
Posts: 2899
Nutzer
Also, wie soll man das messen? Früher gabs mal Systemspeed, das zeigte die Geschwindigkeit relativ zu einem A500 an. Leider funktioniert das Progi nicht unter 3.9 bei mir, warum weiß ich nicht. Auf UAE mit AOS3.9 läufts noch.

Sowas meinte ich, auch wenn ich es nicht gleich geschrieben habe. !:)

MFG

Hammer
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 13:04 Uhr

zacman
Posts: 450
Nutzer
Wer das DCE Microserver Statement gelesen hat, wird feststellen,
dass auch MorphOS eine 68k JIT Emulation bekommen wird (sprich 060
Speed auf derzeitigen PPC Boards).

PS: Laut MOS-ML gibt es im Moment keine Plaene fuer ein neues Release
in naechster Zeit, weil man gerade MorphOS komplett system-unabhaengig
macht, damit es auf dem BPlan Rechner laeuft (eine erste Alpha laeuft
ja schon, siehe das Bplan Interview von vor ein paar Wochen).

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 13:12 Uhr

zacman
Posts: 450
Nutzer
@Trima:

Wenn bei Dir das Startup Script haengen bleibt und nicht von *selbst*
in MorphOS bootet, solltest Du mal ein anderes ResetLevel probieren.

Im Extremfall: Ohne Startup-Sequence booten und das MOS-startup Script
aufrufen.

@DJBase:

Wenn Du nur 68k Anwendungen benutzt und keinerlei PPC Sachen ist doch
klar, dass Dir ein PPC OS nichts bringt...
V³ native ist hier wesentlich schneller, YAM und alle anderen
MUI Apps auch.

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 13:26 Uhr

DJBase
Posts: 3354
[Ex-Mitglied]
Zitat:
@DJBase:

Wenn Du nur 68k Anwendungen benutzt und keinerlei PPC Sachen ist doch
klar, dass Dir ein PPC OS nichts bringt...
V3 native ist hier wesentlich schneller, YAM und alle anderen
MUI Apps auch.



Naja, mein System ist schon PPC optimiert, aber eben WOS und damit fahre ich eben schneller als mit MOS. Ist doch klar.
--
Member of Amiga User Group 99 - http://www.aug99.com

eMail - webmaster@djbase.de

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 14:39 Uhr

MagicSN
Posts: 238
Nutzer
Zitat:
Original von zacman:
Wer das DCE Microserver Statement gelesen hat, wird feststellen,
dass auch MorphOS eine 68k JIT Emulation bekommen wird (sprich 060
Speed auf derzeitigen PPC Boards).

PS: Laut MOS-ML gibt es im Moment keine Plaene fuer ein neues Release
in naechster Zeit, weil man gerade MorphOS komplett system-unabhaengig
macht, damit es auf dem BPlan Rechner laeuft (eine erste Alpha laeuft
ja schon, siehe das Bplan Interview von vor ein paar Wochen).


So was ist natuerlich schnell gepostet, dass man einen JIT
schreiben wuerde, aber ihn tatsaechlich zu entwickeln, dauert lange Zeit. Ich erinnere mich noch an Behauptungen von Michael Garlich
von vor ein paar Monaten, dass die neue Version ja einen JIT haette
und in 060 Speed laufen wuerde (inzwischen gibt es schon eine neuere Version als die, die er damals am Laufen hatte, und immer noch kein JIT). So einen JIT zu entwickeln ist extrem zeitaufwendig. Das ist nicht, wie eine interpretative 68k Emulation, die sich noch in RELATIV geringem Zeitaufwand entwickeln laesst. Und ich bezweifle, dass RS momentan viel Zeit dafuer hat. Seine erste Prioritaet wird dieser
Tage Arbeit fuer die bPlan Hardware (MorphOS anpassen, Treiberentwicklung...) sein. Wenn er an einem JIT arbeiten wollte,
haette er kaum Zeit fuer sonst noch Etwas... (Almos arbeitet auch
exklusiv an der JIT fuer WarpUP, und er steckt ne MENGE Zeit dort rein).

Natuerlich ist ein System mit JIT und eins ohne, dann ein Unterschied wie Tag und Nacht. Und das wird (bei WarpUP bzw. wohl dann spaetestens bei AmigaOS 4.0 - und ich gehe davon aus dass die Arbeit, die in den JIT investiert wurde, auch in OS 4.0 einfliessen wird) sich im direkten Vergleich "OS 4.0 mit JIT" vs. "MorphOS ohne JIT" durchaus bemerkbar machen. Da laeuft dann selbst 68k Software (was das OS einschliesst, welches ja selbst bei MorphOS noch zu sehr weiten Teilen in der 68k Emulation laeuft - die PPC Anteile sind da im Grunde genommen noch relativ klein), und das ist ja immer noch die meiste Software - extrem rasant, auf neuer PPC Hardware (AmigaOne) dann um Faktoren flotter als auf einem echten 060. Und wenn dazu dann noch ein PPC Natives OS 4.0 kommt :)

Steffen



[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 15:08 Uhr

zacman
Posts: 450
Nutzer
Zitat:
So was ist natuerlich schnell gepostet, dass man einen JIT
schreiben wuerde, aber ihn tatsaechlich zu entwickeln, dauert lange Zeit. Ich erinnere mich noch an Behauptungen von Michael Garlich
von vor ein paar Monaten, dass die neue Version ja einen JIT haette
und in 060 Speed laufen wuerde (inzwischen gibt es schon eine neuere Version als die, die er damals am Laufen hatte, und immer noch kein JIT). So einen JIT zu entwickeln ist extrem zeitaufwendig. Das ist nicht, wie eine interpretative 68k Emulation, die sich noch in RELATIV geringem
Zeitaufwand entwickeln laesst. Und ich bezweifle, dass
RS momentan viel Zeit dafuer hat. Seine erste Prioritaet wird dieser
Tage Arbeit fuer die bPlan Hardware (MorphOS anpassen, Treiberentwicklung...) sein. Wenn er an einem JIT arbeiten wollte,
haette er kaum Zeit fuer sonst noch Etwas... (Almos arbeitet auch
exklusiv an der JIT fuer WarpUP, und er steckt ne MENGE Zeit dort rein).


Wir werden sehen, was schlussendlich kommt...

Zitat:
Natuerlich ist ein System mit JIT und eins ohne, dann ein Unterschied wie Tag und Nacht. Und das wird (bei WarpUP bzw. wohl dann spaetestens bei AmigaOS 4.0 - und ich gehe davon aus dass die Arbeit, die in den JIT investiert wurde, auch in OS 4.0 einfliessen wird) sich im direkten Vergleich "OS 4.0 mit JIT" vs. "MorphOS ohne JIT" durchaus bemerkbar machen. Da laeuft dann selbst 68k Software (was das OS einschliesst, welches ja selbst bei MorphOS noch zu sehr weiten Teilen in der 68k Emulation laeuft - die PPC Anteile sind da im Grunde genommen noch relativ klein), und das ist ja immer noch die meiste Software - extrem rasant, auf neuer PPC Hardware (AmigaOne) dann um Faktoren flotter als auf einem echten 060. Und wenn dazu dann noch ein PPC Natives OS 4.0 kommt :)

Es wird kein OS4.0(!) native kommen. Das meiste wird immernoch 68k
sein.

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 15:12 Uhr

zacman
Posts: 450
Nutzer
Zitat:
Naja, mein System ist schon PPC optimiert, aber eben WOS und
damit fahre ich eben schneller als mit MOS. Ist doch klar.


Wenn Du WOS einsetzt ist Dein System wohl kaum auf PPC *optimiert*,
denn die ganzen Contxt-Switches brauchen eben verdammt viel Zeit. Bei
PPC-native Dingen ist MOS einfach schneller (sieht man ja schon daran,
dass HereticII unter der WOS Emulation(!) schneller laeuft, als unter
WOS/AmigaOS).

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 15:41 Uhr

DJBase
Posts: 3354
[Ex-Mitglied]
Zitat:
Wenn Du WOS einsetzt ist Dein System wohl kaum auf PPC *optimiert*,
denn die ganzen Contxt-Switches brauchen eben verdammt viel Zeit. Bei
PPC-native Dingen ist MOS einfach schneller (sieht man ja schon daran,
dass HereticII unter der WOS Emulation(!) schneller laeuft, als unter
WOS/AmigaOS).



Für mich macht aber MOS keine Sinn auf der aktuellen Hardware, da ich mit meinem WOS/AmigaOS-Gespann schneller bin und weniger Probleme hab. Ganz einfach. Und wegen den zwei Programmen, gebe ich mir MOS nicht.
--
Member of Amiga User Group 99 - http://www.aug99.com

eMail - webmaster@djbase.de

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 16:05 Uhr

Andreas_Wolf
Posts: 2980
Nutzer
@ DJBase:

> Naja, mein System ist schon PPC optimiert, aber eben WOS und damit
> fahre ich eben schneller als mit MOS. Ist doch klar.

Nein, ist nicht klar. Wenn du jetzt eh viel WarpOS-Soft nutzt, wäre dein System schneller, wenn du MorphOS nimmst und so viel wie möglich durch MOS-Ports ersetzt, bzw. durch PowerUp-Soft. WarpOS-only-Soft kannst du evtl. auch unter MOS laufen lassen (wenn es denn läuft, dann i.d.R. schneller als unter WarpOS selbst). Du darfst nicht vergessen: Kontextwechsel (bei PowerUp/WarpOS-Emu) lediglich in Software, PPC-CGX, PPC-SFS, PPC-MUI, PPC-AHI ...

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 16:50 Uhr

Andreas_Wolf
Posts: 2980
Nutzer
> ...da ich mit meinem WOS/AmigaOS-Gespann schneller bin...

1. ist das Unsinn und 2. wie kannst du das wissen, wenn du es noch nicht probiert hast? Ich nehme mal an, daß du nen 060 als 68k hast. Folglich wären 68k-Programme die einzigen, die unter MOS langsamer als unter AmigaOS/WarpOS laufen. Aber da du deiner eigenen Aussage zufolge dein System auf PPC "optimiert" hast, sollte das nicht so ins Gewicht fallen.

> Und wegen den zwei Programmen, gebe ich mir MOS nicht.

Unter MorphOS läuft Software für MorphOS, PowerUp, WarpOS und AmigaOS(68k). Sollten also schon mehr als "zwei Programme" sein.

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 19:31 Uhr

Hammer
Posts: 2899
Nutzer
Also, wegen zwei Programmen?
Kommt mal wieder runter, ihr kommt total vom Thema ab! 8o
Ich glaube eigentlich schon, das WOS Programme die MUI nutzen auf MOS wesentlich schneller laufen, vorallem, wenn Du MUI für MOS installiert hast. Das funzt nämlich!

Aber um wieder zum Thema zu kommen, ich hätte gerne einen direkten Geschwindikeitsvergleich! 8)

MFG

Hammer

PS.: Habt ihr beide eigentlich MOS schon ausprobiert? Ich habe es als zweitsystem auf der Startpartition drauf, im Endeffekt muß man ja nur ein paar Scripts doppelt haben! YAM und MUI z.B. erkennen ja automatisch was gerade läuft, also kann man alles in einem Verzeichnis lassen.
--
http://people.freenet.de/ThaHammer/


Schreibt mir ins Gästebuch!!!!!!!!

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 21:54 Uhr

zacman
Posts: 450
Nutzer
Zitat:
Aber um wieder zum Thema zu kommen, ich hätte gerne einen
direkten Geschwindikeitsvergleich! 8)


Wie soll ich den denn machen? Ich kann nur folgendes sagen:
Ich habe hier einen 040/25MHz+603e/240MHz. Die Emulation erreicht
leicht dessen Speed, was fuer mich bedeutet, dass der 68k Emulator von
MorphOS (mindestens) genauso schnell laeuft, wie mein Amiga unter
AmigaOS. Durch die PPC native Teile (ram handler, sfs, cgx, ahi etc.)
sind aber die meisten 68k Programme noch wesentlich schneller.

Und die PPC Programme ja sowieso. Wenn Du mir sagst, was ich im
Vergleich testen soll, dann versuch ich das mal, aber SysSpeed oder
aehnliches (bezogen auf CPU Test!) bringt da wie bei UAE reichlich
wenig.

[ - Antworten - Zitieren - Direktlink - ]

21.07.2001, 23:40 Uhr

MagicSN
Posts: 238
Nutzer
Hi!

Meine Standard Speedtester fuer 68k Emulationen sind zum einen ein Mandelbrot-Programm, zum Anderen ein Grafikdemo (bei dem Grafikdemo war der JIT besonders rasant - wobei ich allerdings den Eindruck habe, dass die 68k Emu besonders bei massivem Arithmetik-Einsatz ein bissel in die Knie geht, und der WarpUP-JIT tut das natuerlich nicht).

Ich hab grad die getesteten Werte nicht genau im Kopf, aber es war glaub Faktor 6-7 oder so bei dem Grafikdemo.

In jedem Fall zieht der JIT meinen 40 MHz 040 locker ab. Doppelte
Speed oder so.

Sachen wie sysspeed bringen zum realistischen Speedvergleich nix, klar...

Steffen

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > MorpOS [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.