amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Andere Systeme > Meine erste DOSe [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 2 3 4 -5- 6 7 [ - Beitrag schreiben - ]

06.03.2007, 16:08 Uhr

CarstenS
Posts: 5566
Nutzer
@schluckebier:
> Und genau das kann ich mir mittlerweile kaum noch vorstellen, mit
> Ubuntu oder SuSE müsste eigentlich auch jeder Anfänger klarkommen.

Exakt, das habe ich ja schon öfter gesagt. Ich habe bei meiner Linux-Erforschung lediglich die Erfahrung gemacht, dass das nicht für mich gilt, der auch gern mal Dinge macht, die die Linux-Distribution nicht anbietet - also z.B. nicht enthaltene Applikationen bzw. Treiber für nicht oder schlecht unterstützte Hardware installieren, etc., sondern dass in dem Fall Windows aus meiner Sicht einfach deutlich simpler ist. Ich behaupte jedoch nicht, dass das die alleinige Wahrheit ist - wenn z.B. ipp0 und rbn Linux als einfacher empfinden, ist das ihr gutes Recht. Denn dieses Thema ist eine höchst subjektive Angelegenheit.

[ Dieser Beitrag wurde von CarstenS am 06.03.2007 um 16:14 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

06.03.2007, 16:24 Uhr

schluckebier
Posts: 1059
Nutzer
Zitat:
Original von CarstenS:
@schluckebier:
> mit Ubuntu oder SuSE müsste eigentlich auch jeder Anfänger klarkommen.

Exakt, das habe ich ja schon öfter gesagt.


Es hätte mich auch sehr beunruhigt, wenn du damit nicht klargekommen wärst. ;o)

Zitat:
Ich habe bei meiner Linux-Erforschung lediglich die Erfahrung gemacht, dass das nicht für mich gilt, der auch gern mal Dinge macht, die die Linux-Distribution nicht anbietet - also z.B. nicht enthaltene Applikationen bzw. Treiber für nicht oder schlecht unterstützte Hardware installieren, etc.,

Das muss man aber fein trennen, Applikationen lassen sich meiner Erfahrung nach eigentlich immer recht problemlos hinzufügen, auch wenn sie in der eigenen Distribution nicht zur Verfügung stehen. Wem Kompilieren zu schwierig ist, findet bestimmt irgendwo auch ein passendes .deb oder .rpm.

Treiber sind wieder eine ganz andere Geschichte, da kann's wirklich eklig werden. Falls man unbedingt einen braucht, der nicht im Stock-Kernel enthalten ist, hilft halt nur Dazukompilieren oder eben Selberbacken eines eigenen Kernels.

Zitat:
sondern dass in dem Fall Windows aus meiner Sicht einfach deutlich simpler ist.

Das ist aber auch nur deshalb simpler, weil jeder Hardwarehersteller einen Windows-Treiber zur Verfügung stellt. So ein Glück haben alternative Betriebssysteme halt nicht, man muss sich seine Hardware schon danach aussuchen, ob sie unterstützt wird oder nicht.

Zitat:
Ich behaupte jedoch nicht, dass das die alleinige Weisheit ist - wenn z.B. ipp0 und rbn Linux als einfacher empfinden, ist das ihr gutes Recht.

Ich finde Linux auch besser als Windows. Nicht unbedingt einfacher (anfangs muss man schon eine je nach Distribution mehr oder weniger steile Lernkurve in Kauf nehmen), aber in allen anderen Belangen angenehmer.

[ - Antworten - Zitieren - Direktlink - ]

06.03.2007, 17:13 Uhr

ipp0
Posts:
[Ex-Mitglied]
@rbn:

Bei e-uae habe ich generell immer die aktuellen sourcen von http://www.rcdrummond.net/uae/ verwendet, da die des package-systems manchmal eine Version älter waren.
eRadium habe ich noch nicht benutzt. War das diese Emulator Sammlung?

Ich schreibe Dir einfach mal, wie ich den e-uae installiert habe:

Sourcen runterladen und Entpacken ist klar -> e-uae-0.8.29-WIP3.tar.bz2

Dasselbe mit den cdr-tools
Das scsi-device benötigst Du, damit auch MakeCD usw. unter e-uae funktionieren.

cd cdrtools-2.01/

make

cd e-uae-0.8.29-WIP3/src

./install_libscg /kompletter/Pfad/zu/cdrtools-2.01

Dann wieder zurück ins e-uae Stammvezeichnis:

cd ..

Mir haben einmal diese Pakete gefehlt:
gtk-devel gtk2-devel zlib-devel
(Was evtl. an Abhängigkeiten fehlt, sollte Dir durch eine configure Fehlermeldung angezeigt werden).
Die habe ich dann über den Paketmanager nachinstalliert.

./configure --enable-jit --enable-natmem --enable-autoconfig --enable-aga --enable-scsi-device --enable-cdtv --enable-cd32 --enable-bsdsock

make
su
root-passwort
make install

Damit das Netzwerk funktioniert, mußt Du noch die bsdsocket.library aus e-uae-0.8.29-WIP3/amiga (glaube ich) auf die Amigapartition nach libs: kopieren.

Dann einen Menüeintrag anlegen. Programm: uae.
Kann man auch aus der shell heraus starten. Als user.

[ - Ändern - Antworten - Zitieren - Direktlink - ]

06.03.2007, 17:26 Uhr

ipp0
Posts:
[Ex-Mitglied]
@rbn:

wine kannst du zunächst mal über die Konsole starten:
wine blabla.exe

Wo bei SuSe die Menüeinträge zu finden sind weiß ich nicht. Hier sind es
/usr/lib/menu
/usr/share/applnk
/usr/share/applications
Sind normale Text-Dateien. Kannst du als root edieren oder auf's Desktop kopieren und wieder zurücklegen.

Hier noch ein Paar Hilfen:
http://www.kde-look.org/content/show.php?content=11998
http://www.kde-look.org/content/show.php?content=41801
http://www.kde-look.org/content/show.php?content=18748

[ Dieser Beitrag wurde von ipp0 am 06.03.2007 um 17:34 Uhr geändert. ]

[ - Ändern - Antworten - Zitieren - Direktlink - ]

06.03.2007, 17:38 Uhr

CarstenS
Posts: 5566
Nutzer
@ipp0:
> Ich schreibe Dir einfach mal, wie ich den e-uae installiert habe

Siehst du. Z.B. so was meine ich. WinUAE installiere ich mit ein paar Mausklicks - auch die aktuelle Version, sofort nach Erscheinen. Ich finde das simpler.

[ Dieser Beitrag wurde von CarstenS am 06.03.2007 um 17:41 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

06.03.2007, 17:47 Uhr

ipp0
Posts:
[Ex-Mitglied]
@ CarstenS:

Wenn ich so etwas erkläre, kann ich nicht voraussetzen, das alles so läuft wie bei mir. Das wäre entweder per Mausklick, oder in der Konsole mittels "urpmi e-uae".

Das ist von jetzt gerade:

[root@oma-rheinholz ipp0]# urpmi --test e-uae ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/Mandrakelinux/official/2007.0/i586/media/contrib/release/e-uae-0.8.29-1.WIP3.1mdv2007.0.i586.rpm
Installiere e-uae-0.8.29-1.WIP3.1mdv2007.0.i586.rpm von /var/cache/urpmi/rpms
Vorbereiten ... #############################################
Die Installation ist möglich
[root@oma-rheinholz ipp0]#

Auf die oben genannte Weise kann man relativ sicher sein, daß auch alles so funktioniert, wie es soll. Ich brauche z.B. auch keinen caps-support in meinem uae. Durch das kompileren kann man sich software etwas individueller gestalten, während oben wahrscheinlich alles einkompiliert ist.

[ Dieser Beitrag wurde von ipp0 am 06.03.2007 um 17:54 Uhr geändert. ]

[ - Ändern - Antworten - Zitieren - Direktlink - ]

09.03.2007, 19:02 Uhr

rbn
Posts: 2001
Nutzer
@ipp0:

Danke für die Hilfestellung.

Leider bin ich noch nicht dazu gekommen mich wieder um UAE zu kümmern, aber ich denke mit Hilfe deiner Anleitung werde ich es schon hinkriegen.

Jetzt habe ich aber hier ein ganz anderes Problem, das ziemlich nervt.

Heute morgen habe ich die aktuellen Updates eingespielt. Unter anderem war auch ein Kernelupdate dabei. Die Installation der Updates hat wie gewohnt einwandfrei funktioniert.

Es läuft auch alles wie bisher.

Allerdings habe ich mir in meinem persönlichen home Verzeichnis einen Ordner namens "Games" eingerichtet in den ich einige Spiele installiert habe. Unter anderem sind das AlienArena2007, OpenArena und ArmyOps (AmericanArmy).

Diese Spiele liefen bis gestern einwandfrei. Seit heute ist es so, dass ich wenn ich im Terminal in eines dieser Verzeichnisse wechsel und dann die ausführbare Datei eintipperl um das Spiel zu starten, die Ausgabe kommt "Datei konnte nicht gefunden werden", obwohl mir ein dir die Dateien wie gewohnt auflistet.

AlienArena2007 habe ich daraufhin nochmal neu runtergeladen und dorthin entpackt, aber wenn ich es starten will, schaltet sich der Screenmode um (so wie beim Amiga ein Hires Interlace Screen dargestellt auf Lowres mit Autoscroll). Das Spiel startet nicht. Wenn ich mich abmelde und wieder neu anmelde ist der Screen wieder normal, aber starten tuts trotzdem nicht.

Bei den anderen beiden (die habe ich noch nicht neu installiert) kommt halt dieses "Datei konnte nicht gefunden werden".

Woran liegt das? Kann doch eigentlich nichts großes sein. Alle anderen Sachen die ich normal über YaST installiert habe laufen nach wie vor einwandfrei. Auch andere Sachen, die einen neuen Screen öffnen. Nur die Sachen im Games Verzeichnis nicht ... *grübel* ...

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

09.03.2007, 21:24 Uhr

ipp0
Posts:
[Ex-Mitglied]
@ rbn:
Das Praktische unter UNIX ist u.A., daß ziehmlich genau definiert ist, wo Du was findest. Nach /home gehören Konfigurationsdateien für den jeweiligen user. Alles, was an Spielen für linux so angeboten wird, installiert sich normalerweise nach '/usr/local/games'. Bis auf die KDE-Spiele.
Wie sieht es denn in Deinem /home/games- Verzeichnis aus? Sind dort die Verzeichnisse der von Dir installierten Spiele aufgelistet?
Poste mal, was da drin' ist, und auch mal, was dann in den jeweiligen Unterverzeichnissen vorhanden ist.

Z.B.
'cd /home/games'
'ls > /home/rbn/Desktop/games.txt'.

Was bekommst Du für eine Ausgabe im terminal, wenn Du z.B. eingibst:'cd /home/rbn/games/AlienArena2007 && ./Das Startscript oder den binary?

Wenn die ausführbaren Dateien da sind kann ich mir nicht vorstellen, daß er diese nicht finden kann. Immer mit ./ starten!

An dem kernel-update kann es nach meiner Erfahrung nicht liegen. Hier werden nur die entsprechenden Dateien in /boot , /lib/modules und /usr/src ersetzt.

Bei der Geschichte mit den screenmodes kann ich mir vorstellen, das diverse lib's nicht gefunden werden, wenn du die Spiele im /home Verzeichnis installiert hast. Einige der benötigten lib's müssen root-Rechte haben. Z.b. libGL.so ( Die Grafikkarten Treiber ) usw.

Suche Dir einen Platz im Dateisystem, an welchem Du die games installierst. Wie gesagt: Normalerweise /usr/local/games. Die Spiele lassen sich ganz normal mit grafischem installer installieren und es werden normalerweise auch gleich die Menü- Einträge erstellt.

Wie hast Du die Spiele installiert?
Habe bisher immer diverse installer gefunden:

http://mirrors.sunsite.dk/lokigames/
http://www.liflg.org/?catid=6&gameid=51
http://gentoo-wiki.com/HOWTO_Running_Old_Loki_Games
http://www.holarse-linuxgaming.de/h2006/space/start
http://liflg-tracker.death-row.org/

[ - Ändern - Antworten - Zitieren - Direktlink - ]

17.03.2007, 01:53 Uhr

rbn
Posts: 2001
Nutzer
Danke für die wirklich ausführlichen Antworten ipp0.

Die Programme habe ich laut Anleitungen auf den jeweiligen Webpages per Hand installiert in /home/Games/ und dann in die entsprechenden Unterverzeichnisse.

Ist jetzt aber im Augenblick nicht mehr wirklich aktuell, weil ...

(Ich oute mich jetzt) DER WINDOWS-SWITCH IST VOLLZOGEN!

Ich habe insgesamt jetzt zweimal OpenSuSE, zweimal Ubuntu, einmal Kubuntu und dreimal Windows installiert. Und beim dritten mal bin ich einfach dabei geblieben.

Es ist einfach ein unschätzbarer Vorteil, wenn man bei nem kleinen Problem schnell zum "Nachbarn" gehen kann, und um Rat fragen kann.

Leider ist die Performance unter SuSE definitiv besser gewesen, und vor allem ist das was da bei Windows abgeht alles aber ganz sicher kein Multitasking. Aber es ist jetzt so wie es ist.

Dafür wird jetzt demnächst aber AmigaSYS installiert. Wenn ich irgendeinen Weg finde das 3.1er ROM und die Disketten der WB 3.1 afu den PC zu bekommen.

Vielleicht kann mir da mal jemand unter die Arme greifen ... ;)

Ich habe eigentlich alles da: Original Disketten von Commodore sowie Amiga (Inc, Tec, ... keine Ahnung), ROMs in allen Farben und Größen und auch die Original 3.5 und 3.9 CD. Nur leider im PC keine Floppy und im Amiga keinen Brenner mehr ...

Wie gesagt, vielleicht könnte mal jemand ... bitte ...

So langsam bin ich hier auf Entzug ...

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 08:39 Uhr

Andreas_B
Posts: 3121
Nutzer
Quote von mir selbst:
Zitat:
Vielleicht kannst Du es ja eines Tages noch gebrauchen - in der Vergangenheit hast Du ja auch schon ab und an die Fronten gewechselt

Als hätte ich es geahnt :D Also Dir kann man zumindest nicht vorwerfen, zu lange an einmal getroffenen Entscheidungen festzuhalten :lach:
Allerdings solltest Du Dir vielleicht mal überlegen, ob es für einen wankelmütigen Gesellen wie Dich wirklich sinnvoll ist, oft solche Extrempositionen einzunehmen ;)

>> vor allem ist das was da bei Windows abgeht alles aber
>> ganz sicher kein Multitasking

Was stört Dich denn daran? Funktioniert IMHO besser als beim Amiga.

>> Vielleicht kann mir da mal jemand unter die Arme greifen ...

Aber sicher, die Tatsache, dass Du noch Amigas hast vereinfacht die ganze Angelegenheit:
-Rom auslesen: Du findest bei WinUAE das Programm "Transrom" mitsamt Anleitung. Dieses kannst Du einfach mittels einer auf 720 kb formatierten Diskette zum Amiga übertragen. Das Formatieren auf 720 kb geht unter Windows nur mit einem kleinen Trick:
http://www.andreasbrink.com/Diskette%20formatieren.html
-Disketten umwandeln:
http://www.andreasbrink.com/Disk2ADF_und_ADF2Disk.html
-So ziemlich alle anderen Fragen (inklusive Datentransfer) werden hier beantwortet:
http://thomas-rapp.homepage.t-online.de/faq/faqemulator.html
Wenn Du am Amiga keinen Brenner hast, dann ist es vielleicht das Einfachste, wenn Du einfach nach dem Auslesen und Umwandeln die Festplatte des Amigas im PC anschließt.

EDIT:
gerade erst bemerkt:
>> Nur leider im PC keine Floppy und im Amiga keinen
>> Brenner mehr ...

Ist nicht weiter tragisch, dann kannst Du beispielsweise am PC eine CD mit Transrom brennen und wenn Du alles ausgelesen und umgewandelt hast, dann klemmst Du einfach die ganze Amiga-Platte im PC an.

Ciao,
Andreas.




[ Dieser Beitrag wurde von Andreas_B am 17.03.2007 um 08:44 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 11:19 Uhr

CarstenS
Posts: 5566
Nutzer
@Andreas_B:
> Also Dir kann man zumindest nicht vorwerfen, zu lange an einmal
> getroffenen Entscheidungen festzuhalten :lach:

Ja, allerdings. :lach:

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 13:27 Uhr

rbn
Posts: 2001
Nutzer
@Andreas_B:

Genau das wäre mein Plan gewesen, wenn ich denn noch ne Floppy hätte ...

Muss ich mir jetzt echt die Mühe machen und ewig im Internet suchen?

Hat nicht jemand Erbarmen?

Edit: Ach ... wegen dem Multitasking ... Also wenn ich z. Bsp. bei Audacity ein File nach OGG exportiere und dann den Requester mit dem Fortschrittsbalken mit der Maus anfasse und bewege, stoppt der Vorgang, bis ich das Fenster wieder loslasse. Und sowas ist mir bei vielen Programmen aufgefallen. Und das man diese ganzen Einstellungsfenster nicht in der Größe ändern kann ist auch nach wie vor ätzend. Zumindest, wenn man wie ich in 1600 x 1200 arbeitet. Da braucht man ja schon ne Leselupe für ...

@CarstenS: Stimmt ... :lach:

<-- rbn

--

DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ Dieser Beitrag wurde von rbn am 17.03.2007 um 13:32 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 13:38 Uhr

Palgucker
Posts: 1338
Nutzer
@ rbn

Die Idee mit der Amigafestplatte im Pc unter WinUAE ist doch nun wirklich nicht schlecht?
Romfile oder ähnliches könntest Du Dir ja auch per E-Mail vom Amige zum PC senden.
Ein Diskettenlaufwerk sollte für ca. 10 Euronen auch zu erstehen sein, oder vom örtlichen Recyclinghof.

mfg Palgucker

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 14:01 Uhr

rbn
Posts: 2001
Nutzer
Also, ich habe hier: 2 1200er, 2 500er, 1 CDTV, 1 CD32. Alle in Standardausführung. Dazu noch zwei Tower mit jeweils nem 1200er Board drinne. Will sagen, da ist nix mit Internet oder so. Denn wie soll ich die Daten um überhaupt ins Inet zu kommen da drauf bekommen? Und ich habe auch ehrlich gesagt nicht vor, dafür Geld zu investieren.

Auch die WB ist in Version 1.3, 2.0, 2.01, 3.0 und 3.1 auf Diskette, sowie 3.5 und 3.9 auf CD vorhanden. Da ich also die rechtlichen Voraussetzungen für den Besitz der ROM-Files und der ADFs besitze nochmal gefragt: Kann da mal jemand bitte etwas für mich tun?

<-- rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 14:47 Uhr

CarstenS
Posts: 5566
Nutzer
@rbn:
> Edit: Ach ... wegen dem Multitasking ... Also wenn ich z. Bsp. bei
> Audacity ein File nach OGG exportiere und dann den Requester mit dem
> Fortschrittsbalken mit der Maus anfasse und bewege, stoppt der Vorgang

Tja, nur hat das nichts mit dem Windows-Multitasking zu tun. Ich persönlich achte bei dieser Thematik sowieso auf andere Dinge (v.a. dass mit den richtigen Einstellungen ein flüssiger Betrieb möglichst vieler, auch ressourenfressender, Programme möglich ist) - anscheinend verbindet aber jeder mit Multitasking etwas anderes.
Aber ich habe eben einige Programme mit Forschrittsanzeige (JDisk, WMP11) überprüft, und die arbeiten während des Verschiebens unbeeindruckt weiter - somit scheint es sich um ein Problem bestimmter Programme zu handeln. Gut möglich, dass da im Linux-Bereich mehr Einheitlichkeit herrscht - erstaunen kann das aufgrund der sehr unterschiedlichen Gegebenheiten aber wohl kaum.

> Und das man diese ganzen Einstellungsfenster nicht in der Größe ändern
> kann ist auch nach wie vor ätzend. Zumindest, wenn man wie ich in 1600
> x 1200 arbeitet. Da braucht man ja schon ne Leselupe für ...

Normalerweise ändern sich aber auch die Fensterschriftgrößen, wenn man im Systemsteuerung-Einsteller "Anzeige" unter "Darstellung" die Schriftarten vergrößert (Einzelheiten kann man unter "Erweitert" verändern). Wenn das bei manchen Applikationen nicht der Fall ist, ist das wieder ein Beispiel, dass da jemand seine eigene Suppe gekocht hat.

[ Dieser Beitrag wurde von CarstenS am 17.03.2007 um 14:54 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 14:56 Uhr

Holger
Posts: 8038
Nutzer
Zitat:
Original von rbn:
Also wenn ich z. Bsp. bei Audacity ein File nach OGG exportiere und dann den Requester mit dem Fortschrittsbalken mit der Maus anfasse und bewege, stoppt der Vorgang, bis ich das Fenster wieder loslasse.

So what?
Das ist bei den meisten Amiga-Programmen genauso. Weil während des Fensterbewegens die Layer gelockt sind, und damit jeder task, der eine graphische Ausgabe machen will, gestoppt wird. Damit das Programm nicht angehalten wird, muss man a) asynchrone I/O benutzen (die die dos.library nicht von Hause aus anbietet) oder b) mehrere tasks benutzen (asynchrone Grafikoperationen in gelockten Layern gibt's gar nicht). Alles in allem könnte man das Problem auf dem Amiga vermeiden, es wäre aber komplizierter zu programmieren. Deshalb hat es so gut wie keiner gemacht.

Bei den meisten Amiga-Programmen reicht es schon, die rechte Maustaste gedrückt zu halten, um sie zu stoppen.

Was aber nichts mit der Qualität des Multitaskings zu tun hat. Eher ein Problem, das Systeme ohne Multitasking gar nicht haben. Da werden Deine Mausaktionen nämlich frühestens nach Beendigung der anderen Operation beachtet.

mfg

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 15:29 Uhr

rbn
Posts: 2001
Nutzer
Zitat:
Original von CarstenS:

> Und das man diese ganzen Einstellungsfenster nicht in der Größe ändern
> kann ist auch nach wie vor ätzend. Zumindest, wenn man wie ich in 1600
> x 1200 arbeitet. Da braucht man ja schon ne Leselupe für ...

Normalerweise ändern sich aber auch die Fensterschriftgrößen, wenn man im Systemsteuerung-Einsteller "Anzeige" unter "Darstellung" die Schriftarten vergrößert (Einzelheiten kann man unter "Erweitert" verändern). Wenn das bei manchen Applikationen nicht der Fall ist, ist das wieder ein Beispiel, dass da jemand seine eigene Suppe gekocht hat.

[ Dieser Beitrag wurde von CarstenS am 17.03.2007 um 14:54 Uhr geändert. ]


Genau wie auf dem Amiga ... ;)

< -- rbn
--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

17.03.2007, 15:31 Uhr

rbn
Posts: 2001
Nutzer
@Holger:

Also vom Pegasos bin ich dieses Verhalten aber nicht gewohnt. Unter Linux auf keinen Fall und unter MOS ist es mir auch nicht aufgefallen. Es gab doch sogar damals schon Tools um die Menus non-blocking zu haben (Ich meine "MagicMenu" hatte diese Funktion sogar integriert, kann mich aber auch täuschen).

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

18.03.2007, 08:38 Uhr

UticaKid
Posts: 7
Nutzer
@rbn

>DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz

Findest Du es nicht für jemanden "peinlich",
der hier auf amiga-news.de so auf das Betriebssystem MorphOS schwört,
in seiner Signatur jetzt seinen PC bewirbt???

PS: Alcohol, gibt oder gab es letzten Monat auf PC Zeitschriften.

Wie z.b. WinRar derzeit, es gibt jeden Monat Vollversionen ohne Ende
auf den CDs der PC Zeitschriften.

PPS:

Deine Vorurteile der Software etc. gegenüber Windows kann auch ich nicht teilen.
Gute Freeware Software gibt es, man muss halt nur suchen. ;-)
Liste gefällig? ;-)

[ - Antworten - Zitieren - Direktlink - ]

18.03.2007, 13:30 Uhr

rbn
Posts: 2001
Nutzer
@UticaKid:

Ich bewerbe hier garnichts, das ist einfach mein System.

Hast du was gegen MOS? Ich nämlich absolut nicht.

Der Wechsel hat auch rein garnichts mit meiner Einstellung gegebüber diesem System zu tun, sondern ist eine reine teils finanziell bedingte, teils durch logisches Kalkül begründete Entscheidung gewesen.

Und wenn du meinen Desktop sehen würdest, würdest du sehen, dass das Ding genauso den "Spirit of Amiga" erfüllt wie alle meine Systeme vorher. Einmal Retro - immer Retro!

Inzwischen bin ich auch bei genügend Freeware fündig geworden. Trotzdem ist es so, dass es viele Lockangebote im Netz gibt und dann muss man feststellen, dass es doch eingeschränkte Versionen sind.

Aber man bekommt recht schnell ein Gespür dafür.

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

19.03.2007, 06:48 Uhr

Andreas_B
Posts: 3121
Nutzer
@rbn:
>> Genau das wäre mein Plan gewesen, wenn ich denn noch ne
>> Floppy hätte ...

Ich habe Dir doch eine Alternative genannt, bei der Du ohne Floppy auskommst,...

>> Muss ich mir jetzt echt die Mühe machen und
>> ewig im Internet suchen?

Alles was Du benötigst, habe ich Dir bereits zusammengesucht,...

>> Hat nicht jemand Erbarmen?

Sag doch gleich, dass Du aus Faulheit nur jemanden suchst, der Dir Kopien seiner Software zusendet. Dann hätte ich mir die Erklärungen sparen können.

Ciao,
Andreas.

[ - Antworten - Zitieren - Direktlink - ]

19.03.2007, 12:38 Uhr

rbn
Posts: 2001
Nutzer
@Andreas_B:

Du hast mir nicht genau zugelesen. Denn deine zweite Variante ist mit CD-ROM. Und ich habe gar keines mehr im Amiga ...

Aber ich habe es inzwischen trotzdem geschafft.

Ich habe mir AmiKit installiert mit meiner OS3.9 CD und es läuft absolut top. Fast so gut wie MOS.

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

19.03.2007, 12:58 Uhr

Andreas_B
Posts: 3121
Nutzer
@rbn:
>> Du hast mir nicht genau zugelesen.

Ich habe Dir wohl eher zu genau "zugelesen", denn Du sprachst davon, keinen Brenner mehr am Amiga zu haben, konnte ja keiner ahnen, dass Du Deine Amigas so gnadenlos kastrierst ;)
Aber das ist sowieso alles egal, denn das Wichtigste ist ja, dass es nun läuft :)

Ciao,
Andreas.

[ Dieser Beitrag wurde von Andreas_B am 19.03.2007 um 12:58 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

19.03.2007, 13:50 Uhr

CarstenS
Posts: 5566
Nutzer
@rbn:
> Ich habe mir AmiKit installiert mit meiner OS3.9 CD und es läuft absolut top.

Kein Wunder, du hast ja auch einen schnellen Rechner. :) Als ich AmiKit damals auf meinem 1-GHz-Duron ausprobiert hatte, war es relativ träge.

[ - Antworten - Zitieren - Direktlink - ]

19.03.2007, 20:27 Uhr

rbn
Posts: 2001
Nutzer
Ich hab Amikit hier unter 1600x1200 laufen und da macht das Amiga Computing doch gleich wieder Spaß. Wenn ich bedenke, was ich damals für ein Geld in den Classic gesteckt habe, um eine ähnliche Leistung mit 1280x1024 zu bekommen ...

... darf man eigentlich echt keinem erzählen ...

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

19.03.2007, 22:11 Uhr

Palgucker
Posts: 1338
Nutzer
Da ist mir noch was eingefallen, wie man das Kickfile doch noch auf einen Windowsrechner "verschleppen" kann.
Ausgehend von der Überlegung, das die HDToolbox am "liebsten" so einrichtet, das 2016 Blöcke in einem Cylinder sind, und davon 2 Cylinder für den RDB reserviert sind, hat man im Normalfall noch reichlich Platz , der wohl nie genutzt wird.
So passen in einen Cylinder immerhin 1008 KB - so groß dürften die RDB-Daten kaum werden.
Natürlich am besten den RDB mal sichern, dan weiß man, wie groß der ist.
Weiterhin natürlich in der HDToolbox auch auf der Install-Seite mit "Edit" nachschauen, wieviel Blöcke per Cylinder benutzt werden.
Wenn dieses dann passt, kann man mit transrom z.B. das Kickfile im Ram: als "Kickfile" speichern.
Dann kommt das "abenteuerliche". Dafür benutzt man dd (Diskdump) aus dem FAT95-Paket.
Bei angenommenen 2016 Blocks_per_Cylinder und einem Standard-Amiga mit Kick3.1 (Filelänge 524.288 Bytes) sehe das ganze als Shellkommando z.B. so aus:

code:
schema:
dd Sourcefile Device Unit ZielBlock Anzahl_der_Blöcke*

*Blockzahl, die insgesamt geschrieben wird. Ergibt sich durch
Filelänge/512 und die Filelänge muss glatt durch 512 teilbar sein!

Reale Eingabe:
dd Ram:Kickfile scsi.device 0 2016 1024


Extra etwas ausführlicher, da dd in diesem Modus keine Fehler "verzeiht"!
Aber das Kickfile sollte nun im 2. Cylinder eingetragen sein, ohne das es den weiteren Betrieb beeinflusst.

Nun noch ein paar Rechnereien auf dem Amiga, um ein paar Daten parat zu haben, die man am PC für die Trialversion von WinHex braucht.
Da die Testversion nur höchstens 200KB abspeichert, habe ich die Auslese-Offsets für das Kickfile in 3 Teile - die ersten beiden zu je 400 Blöcken - gesplittet, die ausserdem noch in Bytes und hexadezimal vorliegen müssen.

Berechnung Start vom 1.Teil
eval (2016+0) * 512 lformat %XX
0000000000000000000000000000FC000
Berechnung Ende vom 1.Teil
eval (2016+400) * 512-1 lformat %XX
00000000000000000000000000012DFFF

Berechnung Start vom 2.Teil
eval (2016+400) * 512 lformat %XX
00000000000000000000000000012E000
Berechnung Ende vom 2.Teil
eval (2016+800) * 512-1 lformat %XX
00000000000000000000000000015FFFF

Berechnung Start vom 3.Teil
eval (2016+800) * 512 lformat %XX
000000000000000000000000000160000
Berechnung Ende vom 3.Teil
eval (2016+1024) * 512-1 lformat %XX
00000000000000000000000000017BFFF

Diese 6 Ergebnisse am besten ohne führende Nullen aufschreiben.

Dann die Platte am PC anschliessen um dann das ganze mit Winhex zu bearbeiten.
Winhex starten und Icon "Disk öffnen" anklicken und im Requester die Amigafestplatte auswählen.
Zur Sicherheit noch mit dem Menü "Position/Sektor aufsuchen" auswählen, und dort 2016 eingeben.
Nun sollte oben im Editor auch was von "AMIGA ROM Operating System and Libraries..." zu sehen sein.
Wenn dem so ist, weiter mit dem Menü "bearbeiten/Block festlegen" und dort die ersten Werte vom Zettel eintragen und bestätigen.
Dann "Bearbeiten/Block kopieren -> in neue Datei" und den Schnipsel z.B. als Part-1 abspeichern
Der nun neue Tab "Part-1" kann wieder geschlossen werden.
Das ganze für Part2 und 3 mit den jeweiligen Werten wiederholen.
Dann die Eingabeaufforderung starten und das ganze mit dem copy-Befehl "joinen"

copy /b Part-1 + Part-2 + Part-3 Kick3.1.rom

und Zack ;) - schon hat man sein Kickfile auf dem PC.

Puh - das ist ja fast ein Workshop - Motto: "Wie randaliere ich auf meiner Festplatte" ;)
Aber ich habe das mal durchprobiert, zwar unter UAE, aber mit "scharfer" - also echter Amigaplatte, und funzt. Ist aber nicht ganz ohne!

Gruß Palgucker


[ - Antworten - Zitieren - Direktlink - ]

21.03.2007, 15:47 Uhr

rbn
Posts: 2001
Nutzer
@Palgucker:

Das ist aber jetzt echt die Hardcore Methode.

Und sowas machst du freiwillig?

rbn

--
DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB, MDT 2 x 512 MB DDR2 667 CL 4

-->

[ - Antworten - Zitieren - Direktlink - ]

21.03.2007, 16:34 Uhr

Palgucker
Posts: 1338
Nutzer
@rbn

Naja, da ich dd schon öfter benutzt habe, halten sich die Gefahren in Grenzen. Beim Format-Befehl muss man ja auch aufpassen.
Nur war ich mir auch nicht ganz sicher, ob das alles auch schlussendlich ein brauchbares Kickrom-File auf PC-Seite ergibt.
Deswegen habe ich es ja auch durchexerziert - und es hat ohne "Zwischenfälle" geklappt.
Ist zumindest eine halbwegs simple Variante, die weder arg zeitraubend ist oder extra kostet.

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

15.04.2007, 01:35 Uhr

rbn
Posts: 2001
Nutzer
Hallo zusammen.

Mannomann. Ich hab hier soviel um die Ohren in der letzten Zeit, das geht schon fast garnicht mehr.

Um das ganze noch zu verschlimmern hat sich bei mir der berühmt berüchtigte 60 Hz Bug eingeschlichen. ;)

Wo krieg ich diesen Mist denn nochmal eingestellt bei dem Windows.

Ich weiß, dass ich das auch schon auf zwei verschiedene Arten eingestellt hatte. Wahrscheinlich war eines davon irgendein Tool oder eine Erweiterung mit der ich zu Anfangs herum experimentiert hab. Obwohl ich das beim zweiten Mal eigentlich schon ganz ok gemacht hab.

Weiß jemand wo man die Bildwiederholfrequenz nochmal einstellen kann?

... grübel ...

rbn

--

Aerocool "Baydream", DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB 667MHz, MDT 2 x 512 MB DDR2 667 CL 4 Dual Channel 128 Bit, Maxtor IDE 200 GB, LG DVD-RAM


[ Dieser Beitrag wurde von rbn am 15.04.2007 um 01:45 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

15.04.2007, 02:01 Uhr

rbn
Posts: 2001
Nutzer
Ah. Und schon gefunden. Endlich, danke.

rbn

--
Aerocool "Baydream", DFI Infinity CFX3200-M2/G , AMD Athlon 64 X2 3800+ 2000 MHz (Manchester), Sapphire RadeonX1650 PRO 256 MB 667MHz, MDT 2 x 512 MB DDR2 667 CL 4 Dual Channel 128 Bit, Maxtor IDE 200 GB, LG DVD-RAM


[ Dieser Beitrag wurde von rbn am 15.04.2007 um 02:02 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]


1 2 3 4 -5- 6 7 [ - Beitrag schreiben - ]


amiga-news.de Forum > Andere Systeme > Meine erste DOSe [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.