amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Welche lha Version? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

23.08.2007, 14:08 Uhr

eliotmc
Posts: 925
Nutzer
Hallo,

welche lha Version aus dem aminet könnte ihr empfehlen?
Ich bin hier schon am verwzeifeln!

Ich packe auf meinem A4000 mit:

lha a ram:term.lha term

Kopiere es auf Diskette, gehe zu meinem A1200
und will entpacken:

lha x ram:term: work:tools/

und der sagt mir das Archiv ist defekt???

Diskette geprüft, wieder zurück auf A4000 kopiert,
entpackt, geht, zumindest auf dem A4000.

WelcherVersion geht mit 030er als auch mit 060er
egal auf welchem System??

Habe schon zuiel ausprobiert um noch wirklich durch zu blicken, ...
--
regards

eliot

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 14:30 Uhr

Neodym
Posts: 487
Nutzer
Nimm LZX! Version 1.21r ist als Freeware im Aminet erhätlich, der Public-Key ebenfalls. Läßt sich mit der lha.run (v1.38 von LHA) aus dem Aminet entpacken (falls Dein lha einen Schlag hat - ansonsten geht natürlich auch das) und anschließend für fast alle wichtigen Archivformate am Amiga nutzen. Gehört zudem zu den schnellsten Packern auf dem Amiga bei sehr kleinen Archivgrößen.

Wobei der von Dir oben gepostete Aufruf

lha x ram:term: work:tools/

so nicht funktionieren kann, weil Du kein Archiv angegeben hast (das hätte "lha x ram:term.lha work:tools/" heißen müssen). Aber das ist sicherlich ein Tipfehler gewesen, sonst hättest Du es auf dem 4000er nicht entpacken können... :)

Gruß
Neodym

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 14:46 Uhr

thomas
Posts: 7675
Nutzer
Zitat:
Nimm LZX!

Da muß man sich aber aber erst noch diverse Patches zusammen suchen, um eine Jahr-2000-fähige Version zu bekommen.

@eliotmc:

Die neueste Version von LhA ist 2.12, die sollte diese Fehler nicht mehr machen.

http://freenet-homepage.de/aclogic/lha.html
oder http://lha.a1k.org (verweist auch auf die erste Seite)

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomasrapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 15:03 Uhr

eliotmc
Posts: 925
Nutzer
@Neodym:

Ja, werde ich mal zuahsue ausprobieren.
Und ja, es war vertipper :)
Sollte lha a ram:term.lha work:term heißen,
sorry!
--
regards

eliot

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 20:24 Uhr

eliotmc
Posts: 925
Nutzer
Nabend,

jetzt habe ich es mal ausprobiert.
Egal welche lha Version ich nutze,
immer das gleiche Problem,
jedoch konnte ich es jetzt umgehen:

Kopiere ich das lha Archiv ins Ram und
entpacke auf eine HDD, geht alles wunderbar.
Umgekehrt von HDD ins Ram geht nicht, warum
auch immer.

Es handelt sich um einen A1200 Amiga-Technologies,
Blizzard 1230 IV, 16 MB Ram, nacktes Wb3.1

Äußerst seltsam???

Die HDD ist eine CF Karte via CF2IDE,
ob es damit zusammenhängt???


--
regards

eliot

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 21:13 Uhr

thomas
Posts: 7675
Nutzer
@eliotmc:
Zitat:
von HDD ins Ram geht nicht

Ändere MaxTransfer für alle Partitionen auf 0xfe00.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomasrapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 21:53 Uhr

DaxB
Posts: 1412
Nutzer
@thomas:
Von einem Jahr 2000 Problem bei LZX höre ich zum ersten mal. Wo/Wann/Wie wirkt sich das denn aus?

[ - Antworten - Zitieren - Direktlink - ]

23.08.2007, 21:59 Uhr

eliotmc
Posts: 925
Nutzer
Zitat:
Original von thomas:
@eliotmc:
Zitat:
von HDD ins Ram geht nicht

Ändere MaxTransfer für alle Partitionen auf 0xfe00.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomasrapp.homepage.t-online.de/


Volltreffer, musste aber vorher das Archiv neu von Disk auf
HDD kopieren. Scheint also nur bei größeren Dateien
ein Problem zu sein.

Danke!


--
regards

eliot

[ - Antworten - Zitieren - Direktlink - ]

25.08.2007, 10:03 Uhr

thomas
Posts: 7675
Nutzer
Zitat:
Original von DaxB:
@thomas:
Von einem Jahr 2000 Problem bei LZX höre ich zum ersten mal. Wo/Wann/Wie wirkt sich das denn aus?


Erstelle einfach ein Achriv mit Dateien, die ein Dateidatum nach 2000 haben und schau dir anschließend das Inhaltsverzeichnis an. Die Jahreszahlen sind alle entweder in den 70ern oder größer als 128.

Und selbst wenn man sich das Archiv mit der gepatchten Version anlisten läßt, sind die Jahreszahlen, die vorher größer als 128 waren, jetzt größer als 32. Man braucht also den Y2K-Patch bereits zum Erstellen des Archivs, sonst sind alle Daten falsch.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomasrapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

25.08.2007, 10:18 Uhr

Flinx
Posts: 1073
Nutzer
Zitat:
Original von eliotmc:
Scheint also nur bei größeren Dateien ein Problem zu sein.


Wenn die Dateien kleiner als die 65024 Bytes sind, die Du jetzt als Maximalgröße eingetragen hast, dann kann es ja auch keinen Unterschied machen.

[ - Antworten - Zitieren - Direktlink - ]

25.08.2007, 13:37 Uhr

DaxB
Posts: 1412
Nutzer
@thomas:
Gerade getestet/gesehen. Also sind "nur" die Datumsangaben falsch?

[ - Antworten - Zitieren - Direktlink - ]

30.08.2007, 13:41 Uhr

GREX
Posts: 509
Nutzer
Mal was anderes. Hat sich vielleicht schon mal jemand die Mühe gemacht, zu sehen, welche Lha-Version am schnellsten Archive entpackt? Könnte es zum Beispiel sein, dass die Lha-Executables aus dem Aminet schneller als OS3.9-Unarc (Xadmaster) sind, welches ich normale verwende? War bisher zu faul, das selber auszuprobieren.

I-)

[ - Antworten - Zitieren - Direktlink - ]

31.08.2007, 08:51 Uhr

gni
Posts: 1106
Nutzer
Zitat:
GREX:
Könnte es zum Beispiel sein, dass die Lha-Executables aus dem Aminet schneller als OS3.9-Unarc (Xadmaster) sind, welches ich normale verwende?

Das eigenständige (Amiga-)LhA ist definitiv schneller als xadmaster.libbrary basierte Entpacker.

[ - Antworten - Zitieren - Direktlink - ]

04.09.2007, 14:15 Uhr

GREX
Posts: 509
Nutzer
@gni:

Aha, danke! Werd' ich mir merken, falls ich wiedermal riesige LHA-Dateien zu entpacken habe, wie etwa das Desertracing-Demo.

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Welche lha Version? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.