amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > Olaf Barthel's "Term" und HyperTerminal [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

07.10.2007, 17:17 Uhr

Kaesebroetchen
Posts: 643
Nutzer
Hallo.

Ich habe kürzlich AROS auf meinem alten Notebook ohne CDROM und mit defektem Diskettenlaufwerk installiert (nur nicht fragen wie!).
Jetzt suche ich nach einer einfachen Möglichkeit Daten mit meinem Windows PC auszutauschen.

Als auf dem Notebook noch Windows drauf war, habe ich jeweils auf beiden Rechnern HyperTerminal gestartet und die Dateien per NullModemkabel übertragen.

Auf AROS habe ich natürlich kein HyperTerminal, aber dafür Olaf Barthel's "Term".
Ich habe alles soweit konfiguriert, daß ich jeweils Text übertragen kann (so eine Art chatten also).

Wenn ich aber Dateien per ZMODEM Protokoll übertragen will, hängt die Übertragung mit jeweils unterschiedlichen Fehlermeldungen (timeout, crc16, etc.)

Ich vermute es ist ein Konfigurationsproblem.
In Term kann man für zmodem eine Menge Einstellungen verändern.
Bei HyperTErminal gibt es überhaupt keine Optionen für zmodem.

Hat jemand eine Idee wie ich term konfigurieren muss, damit es kompatibel zu HyperTerminal ist ?

--
http://amidevcpp.amiga-world.de/

[ Dieser Beitrag wurde von Kaesebroetchen am 07.10.2007 um 17:19 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

07.10.2007, 17:58 Uhr

cgutjahr
Posts: 2712
[Administrator]
Zitat:
Original von Kaesebroetchen:
Wenn ich aber Dateien per ZMODEM Protokoll übertragen will, hängt die Übertragung mit jeweils unterschiedlichen Fehlermeldungen (timeout, crc16, etc.)

Ich habe Term (unter OS3/4) und HyperTerminal früher sehr viel zur Datenübertragung benutzt.

Sobald die Übertragung von reinem Text funktioniert, sollten eigentlich auch ZModem-Transfers funktionieren - an den ZModem-Einstellungen musste ich nie etwas verändern.

Zitat:
Hat jemand eine Idee wie ich term konfigurieren muss, damit es kompatibel zu HyperTerminal ist ?
Ich würde die Einstellungen für die serielle Schnittstelle nochmal durchgehen. Handshaking ist auf beiden Rechnern als "RTS/CTS" konfiguriert? Ruhig mal mit ganz kleinen Übertragungsraten anfangen (19.200 bps), vielleicht ist es ja nur ein Timing-Problem bei höheren Übertragungsraten.

--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

07.10.2007, 18:11 Uhr

Kaesebroetchen
Posts: 643
Nutzer
Zitat:
Original von cgutjahr:

Ich würde die Einstellungen für die serielle Schnittstelle nochmal durchgehen. Handshaking ist auf beiden Rechnern als "RTS/CTS" konfiguriert? Ruhig mal mit ganz kleinen Übertragungsraten anfangen (19.200 bps), vielleicht ist es ja nur ein Timing-Problem bei höheren Übertragungsraten.

--
Gutjahrs Amiga Seiten


Das habe ich eigentlich alles schon durchexerziert.

Eigenartigerweise, muss ich bei term RTS/CTS einstellen und bei Hyperterminal Xon/Xoff damit es überhaupt funktioniert. Zumal Hyperterminal als Handshake nur Kein/Hardwareund Xon/Xoff anbietet.

--
http://amidevcpp.amiga-world.de/

[ - Antworten - Zitieren - Direktlink - ]

07.10.2007, 19:59 Uhr

Kaesebroetchen
Posts: 643
Nutzer
So habe es hinbekommen.

Einstellungen:

Bei Term
Serial:
RTS/CTS

Bei HyperTerminal Xon/Xoff

Bei Term
Default Protocol

enable XPR 2.001 Extensions

Damit klappt es bei mir.
--
http://amidevcpp.amiga-world.de/

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > Olaf Barthel's "Term" und HyperTerminal [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.