amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Keyboard und Maus über PS/2-USB Adapter am USB Port [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

22.10.2007, 20:33 Uhr

julius
Posts: 2255
Nutzer
Da mir die Kombination Cocolino/Lyra für jeden meiner 4 Amigas(alle sind mit USB ausgerüstet und hängen an einem KVM) zu teuer war, betreibe ich Keyboard und Maus über diesen PS/2-USB Adapter
http://www.pearl.de/p/PE8498-USB-PS-2-Adapter.html
am USB Port. Soweit ich das bisher beurteilen kann, klappt das ganz gut bis auf eine Ausnahme:
Die Wiederholungsfunktion einer Taste, wenn ich sie gedrückt halte, funktioniert nur bei der Highway, bei der Subway klappt das nicht.
Sind Highway und Subway was, USB betrifft, nicht identisch?
Und noch eine Frage:
Keyboard und Maus werden über die hid.class von Poseidon eingebunden und stehen deshalb erst nach dem Hochfahren desa Rechner zur Verfügung(wenigsten bei mir). In das Early Startup-Menü komme ich damit nicht.
Wie kann man Keyboard und Maus bereits beim Einschalten aktivieren?


[ - Antworten - Zitieren - Direktlink - ]

22.10.2007, 21:14 Uhr

ylf
Posts: 4101
Nutzer
Zitat:
Original von julius:
Wie kann man Keyboard und Maus bereits beim Einschalten aktivieren?

Gar nicht.
Dazu müßte der USB-Stack ins KickStart ROM!

Mein KVM schaltet übrigens auch USB mit um. Das wäre auch noch eine Lösung gewesen.

bye, ylf

[ - Antworten - Zitieren - Direktlink - ]

22.10.2007, 21:32 Uhr

julius
Posts: 2255
Nutzer
Hast Du auch eine Idee, warum es mit der Highway keine Probleme gibt im Vergleich zur Subway?

[ - Antworten - Zitieren - Direktlink - ]

22.10.2007, 22:39 Uhr

platon42
Posts: 400
[Ex-Mitglied]
Zitat:
Original von julius:
Hast Du auch eine Idee, warum es mit der Highway keine Probleme gibt im Vergleich zur Subway?


Weil Du beim einen System das neue input.device resetfest oder im FlashRom hast und beim anderen nicht?
--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

22.10.2007, 22:42 Uhr

platon42
Posts: 400
[Ex-Mitglied]
Zitat:
Original von julius:
Keyboard und Maus werden über die hid.class von Poseidon eingebunden und stehen deshalb erst nach dem Hochfahren desa Rechner zur Verfügung(wenigsten bei mir). In das Early Startup-Menü komme ich damit nicht.
Wie kann man Keyboard und Maus bereits beim Einschalten aktivieren?


Die neueren Versionen der HID.class lassen sich ebenfalls resetfest einbinden. Ansonsten kannst Du auch mit den kleineren bootmouse und bootkeyboard Klassen vorlieb nehmen. Wie auch schon hunderte Male vorher geschrieben (sorry), muss das neue input.device resetfest eingebunden sein, sowie das neue bootmenu von OS3.9 BoingBag 2. Bei Funkmäusen müssen auch noch im richtigen Moment die Maustasten gedrückt werden.
--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

22.10.2007, 23:16 Uhr

julius
Posts: 2255
Nutzer
@chris:
Danke für den Tipp.
Löst das resetfeste Einbinden auch das andere Problem:
Die Wiederholungsfunktion einer Taste, wenn ich sie gedrückt halte, funktioniert nur bei der Highway, bei der Subway klappt das nicht.
Sind Highway und Subway, was USB betrifft, nicht identisch?

Gerhard

[ - Antworten - Zitieren - Direktlink - ]

23.10.2007, 08:01 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Sind Highway und Subway, was USB betrifft, nicht identisch?

Doch, sind sie. Beide Karten benutzen den gleichen Host-Kontroller, lediglich das Memory Mapping der Subway ist anders (indizierter Zugriff statt linearem wegen des kleineren Adressraums am Clockport).

Hast du mal versucht, env:psdstackloader zwischen beiden Systemen auszutauschen (neuen Kontroller einstellen musst du natürlich), um sicherzugehen, dass die Poseidon-Einstellungen bei beiden Systemen exakt gleich sind?

Michael

[ - Antworten - Zitieren - Direktlink - ]

23.10.2007, 09:33 Uhr

julius
Posts: 2255
Nutzer
Zitat:
Original von mboehmer:

Hast du mal versucht, env:psdstackloader zwischen beiden Systemen auszutauschen (neuen Kontroller einstellen musst du natürlich), um sicherzugehen, dass die Poseidon-Einstellungen bei beiden Systemen exakt gleich sind?

Michael


Ich habe bei beiden Systemen das letzte Poseidon Update vom Oktober 2007 gemacht.
Was meinst Du mit neuen Kontroller einstellen?
Und etwas habe ich bisher nicht erwähnt. Die Highway läuft in einem Rechner A4000T unter OS 3.9 mit BoingBag 2, Die Subway in einem A3000T mit OS 3.1.
Ob es daran liegt?

Gerhard

[ - Antworten - Zitieren - Direktlink - ]

23.10.2007, 09:47 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Was meinst Du mit neuen Kontroller einstellen?

Statt des highwayusb.device das subwayusb.device einstellen.

Zitat:
Und etwas habe ich bisher nicht erwähnt. Die Highway läuft in einem Rechner A4000T unter OS 3.9 mit BoingBag 2, Die Subway in einem A3000T mit OS 3.1.

Schwer zu sagen, eine klare Aussage kann man nur dann treffen, wenn softwaremäßig beide Systeme gleich sind. Kannst du dir SUBWAY samt Zorro-Trägerkarte nicht mal testweise in den anderen Rechner transferieren?

Michael

[ - Antworten - Zitieren - Direktlink - ]

23.10.2007, 10:08 Uhr

julius
Posts: 2255
Nutzer
Der Kontroller ist richtig eingestellt.
Ich werde mal die Subway incl. X-Surf in ein OS 3.9 Sytem einzusetzen. Mal sehen, ob sich da was verändert.

[ - Antworten - Zitieren - Direktlink - ]

23.10.2007, 17:49 Uhr

julius
Posts: 2255
Nutzer
Ich habe jetzt die Kombination Subway/Buddha Flash in einen A2000 unter OS 3.9 in Betrieb genommen. Da klappt alles bestens. Also bleibt jetzt nur noch als Urache OS 3.1 oder die Kombination Subway/X-Surf.
Ich kann die Kombination Subway/X-Surf mal in den A2000 einbauen. Muss ich dazu die X_Surf im A2000 komplett einrichten?

[ - Antworten - Zitieren - Direktlink - ]

23.10.2007, 23:00 Uhr

julius
Posts: 2255
Nutzer
Zitat:
Original von platon42:
Zitat:
Original von julius:
Hast Du auch eine Idee, warum es mit der Highway keine Probleme gibt im Vergleich zur Subway?


Weil Du beim einen System das neue input.device resetfest oder im FlashRom hast und beim anderen nicht?
--
--
Best Regards

Chris Hodges


Das input.device ist bei beiden Systemen(OS 3.1 und OS 3.9) resetfest eingebunden, trotzdem klappt der Key repeat nur unter OS3.9 nicht aber unter OS3.1(wenigsten bei mir).

[ - Antworten - Zitieren - Direktlink - ]

24.10.2007, 10:09 Uhr

julius
Posts: 2255
Nutzer
Ich habe heute morgen bei dem OS 3.1 Amiga die Bilschirmauflösung von 640x480 auf 800x600 verändert. Seitdem klappt auch unter OS3.1 der Key repeat.Ist schon lustig oder?

Nach einem Reset war wieder alles beim Alten - Kein Key repeat


[ Dieser Beitrag wurde von julius am 24.10.2007 um 10:59 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.10.2007, 18:05 Uhr

platon42
Posts: 400
[Ex-Mitglied]
@julius:

Meine Vermutung ist, dass irgendwas mit dem Einbinden des input.device' nicht klappt. "version input.device FULL" nach dem Booten gibt da genaue Auskunft. Steht da V50.x und geht Keyrepeat trotzdem nicht, dann ist irgendetwas anderes faul. An OS 3.1 allein kann es eigentlich nicht liegen, ich selbst verwende auch nur OS 3.1.
--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

24.10.2007, 18:33 Uhr

julius
Posts: 2255
Nutzer
@Chris.
in Devs: liegt input.device V50.26
in der startup-sequence steht als erster Befehl
PsdLoadmodule DEVS:input.device QUIET
Trotzdem liefert
version input.device FULL 40.1
mfg
julius

[ - Antworten - Zitieren - Direktlink - ]

24.10.2007, 18:36 Uhr

platon42
Posts: 400
[Ex-Mitglied]
Zitat:
Original von julius:
@Chris.
in Devs: liegt input.device V50.26
in der startup-sequence steht als erster Befehl
PsdLoadmodule DEVS:input.device QUIET
Trotzdem liefert
version input.device FULL 40.1
mfg
julius


Probier doch mal ein anderes LoadModule, z.B. das von THOR.

Hast Du sonst irgendwelche Tools laufen, die ggf. die Reset-Vektoren löschen oder verbiegen? Was sagt Scout zum Thema "Residents"?
--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

24.10.2007, 18:59 Uhr

julius
Posts: 2255
Nutzer
Ich habe eine Ursache möglicherweise gefunden.
Ich habe vor längerer Zeit mit dem OS 3.1 Amiga rum experimentiert.
Dabei habe ich das Setpatch(V43.6) von OS 3.1 durch das Setpatch(V44.2) von OS 3.5 ersetzt.
Das habe ich das jetzt rückgängig gemacht.
Jetzt klappt der Key repeat nach dem ersten Warmstart, aber noch nicht nach einem Kaltstart.

Die Residents ergeben folgendes:
Nach dem Kaltstart:
Zeile 1 (weisse Schrift):
$0FFF2F42---input.device---40----input.device 50.26
Zeile 2(schwarze Scrift):
$0F08C3E0---input.device---40----input.device 40.1

Nach einem Warmstart:
Zeile 1 (weisse Schrift):
$0FFF2F42---input.device---40----input.device 50.26
Zeile 1 (scharze Schrift):
$0FFF2F42---input.device---40----input.device 50.26


[ Dieser Beitrag wurde von julius am 24.10.2007 um 19:53 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

31.10.2007, 10:23 Uhr

julius
Posts: 2255
Nutzer
So, jetzt klappt es bis auf die Tatsache, daß Keyboard und Maus erst nach dem endgültigen Hochlaufen des Rechners zur Verfügung stehen.
Z. B. komme ich in das Early Startup-Menü nicht rein und kann auch keinen Reset machen, wenn sich der Rechner während des Bootens mal aufhängen sollte.
Wie kann man das in den Griff kriegen? Würde eine Algor mit dem ROM helfen?

[ - Antworten - Zitieren - Direktlink - ]

07.11.2007, 17:09 Uhr

julius
Posts: 2255
Nutzer
Hat denn keiner aus der Amiga-Gemeinde einen Tipp für mich?

[ - Antworten - Zitieren - Direktlink - ]

07.11.2007, 17:52 Uhr

ylf
Posts: 4101
Nutzer
Zitat:
Original von julius:
Hat denn keiner aus der Amiga-Gemeinde einen Tipp für mich?


Zitat:
Original von julius:
Wie kann man Keyboard und Maus bereits beim Einschalten aktivieren?

Gar nicht.
Dazu müßte der USB-Stack ins KickStart ROM!

bye, ylf

[ - Antworten - Zitieren - Direktlink - ]

07.11.2007, 17:59 Uhr

julius
Posts: 2255
Nutzer
Was ist denn mit der Algor oder KickFlash OS4?

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Keyboard und Maus über PS/2-USB Adapter am USB Port [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.