amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > Neue Sprach-DLL für WinUAE 1.4.5 ist verfügbar [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

27.12.2007, 21:23 Uhr

Turrican
Posts: 849
Nutzer
Die neue Sprachdatei könnt ihr unter www.amigaemuboard.net downloaden :)
--
A1200T / BlizzardPPC 603+ 060-240 / 256MB FastRAM / Mediator SX / Voodoo4 32MB / DVD-Brenner

amigaemuboard.net - Amiga still alive !!!

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 13:45 Uhr

Turrican
Posts: 849
Nutzer
Leider gabs in der deutschen Sprachdatei für WinUAE 1.4.5 ein paar Bugs. Brasto hat eine gefixte Version erstellt :)
--
A1200T / BlizzardPPC 603+ 060-240 / 256MB FastRAM / Mediator SX / Voodoo4 32MB / DVD-Brenner

amigaemuboard.net - Amiga still alive !!!

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 14:14 Uhr

tploetz
Posts: 4026
Nutzer
@Turrican:
Hallo,
habe die neueste Datei geladen, WinUAE bleibt in englisch.
Unter Misc/Language steht nur Autodetect oder English.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 14:43 Uhr

Palgucker
Posts: 1341
Nutzer
@ tploetz

Zitat:
Unter Misc/Language steht nur Autodetect oder English.

Ein ähnliches oder sogar gleiches Problem hatte ich auch mal.
Dagegen hat Armins "Rezept" gut geholfen.

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 14:57 Uhr

whose
Posts: 2156
Nutzer
@Palgucker:

Ich habe das gleiche Problem (ums Verrecken kein eingedeutschter WinUAE) und das "Rezept" hilft genauso wenig wie der "normale" Weg. Kann es sein, daß ältere Configs den WinUAE etwas ins Schleudern bringen?

Edit: Ich habe mal einen Blick ins Bootlog geworfen:

"failed to load, error 998" für WinUAE_German.dll.

Was ist denn das für ein Fehler?

Und noch n Edit:

Ich habs hinbekommen, indem ich in meiner Standard Config auf "Englisch (builtin)" gestellt und dann gespeichert habe. Beim nächsten Start von WinUAE wars dann Deutsch (obwohl immer noch Englisch builtin angezeigt wurde (!)). Da war dann auch "German" wählbar und es bleibt dann auch Deutsch ;)

--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233


[ Dieser Beitrag wurde von whose am 28.12.2007 um 15:06 Uhr geändert. ]

[ Dieser Beitrag wurde von whose am 28.12.2007 um 15:35 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 16:08 Uhr

Palgucker
Posts: 1341
Nutzer
@ whose

Ich habe das eben auch erst nachträglich ausprobiert, und auch bei mir kam es mit oder ohne "Rezept" zu keiner Eindeutschung.
Merkwürdigerweise wurde die German.dll bei einem Klick direkt auf die WinUAE.exe dann plötzlich gefunden. Ein Abspeichern der (völlig unvollständigen) Config als default.uae brachte es dann, das auch alle anderen Configs in Deutsch waren.
Die Spracheinstellung wird wohl ausschließlich in der Config "default.uae" gespeichert und auch von dort beim Start jeder anderen Config geladen.
Daher kann es auch kommen, das in einer uralten default.uae einfach noch kein "Feld" für dieses Feature angelegt ist, wobei dann gerade die auf die Nase fallen, die diese default.uae eigendlich nie direkt nutzen.

Nachtrag:

Habe nochmal gespielt. ;)

Alte Config "default.uae" löschen oder umbenennen.
WinUAE.exe durch Klick aufs Icon starten.
Configuration in den Properties als default abspeichern (ca. 18 kb groß) und beenden.
Nun sollte sich die Sprache immer auswählen lassen, wenn die WinUAE.exe ohne Config oder eben gleich über default.uae gestartet wird.


Gruß Palgucker




[ Dieser Beitrag wurde von Palgucker am 28.12.2007 um 17:11 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 20:20 Uhr

Mittag12
Posts: 79
Nutzer
Hallo Leute,
habe eben auch alles ?? ausprobiert,
mein WinUae bleibt auch in englischer Sprache !!

Ratloser.

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 21:25 Uhr

Palgucker
Posts: 1341
Nutzer
@ Mittag12

Etwas ratlos war ich auch. Habe mal verschiedenes probiert, und irgendwas läuft da nicht rund.
Starte einfach die default.uae und stelle die Sprache auf English (built-in) und beende es mit Quiet.
Starte erneut, und nun kannst Du auch German aussuchen. Merkwürdiger Weise braucht man hier auch ohne speichern beenden, und es wird auf alle Configs angewendet.

Das ist übrigens genau das, was whose in seinem letzten Edit schon geschrieben hat, ich hab es aber auch nicht richtig gedeutet.

Bleibt die Frage, wo wird es gespeichert, wenn es auch ohne abspeichern der Config geht. Registry??

Gruß Palgucker

Nachtrag:

Ist ein Registry-Schlüssel.
HKEY_CURRENT_USER\Software\Arabuusimiehet\WinUAE\Language.
Die "Nummer 7" sind Wir!. Steht der Wert auf 0, ist's English (built-in) und Autodetect ist 65565 --> 0x0000ffff


[ Dieser Beitrag wurde von Palgucker am 28.12.2007 um 21:42 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 21:42 Uhr

whose
Posts: 2156
Nutzer
Zitat:
Original von Palgucker:
@ Mittag12

Etwas ratlos war ich auch. Habe mal verschiedenes probiert, und irgendwas läuft da nicht rund.


Definitiv. Bei den einen klappts sofort, bei anderen ohne finstere Tricks gar nicht ;)

Zitat:
Das ist übrigens genau das, was whose in seinem letzten Edit schon geschrieben hat, ich hab es aber auch nicht richtig gedeutet.

Nicht ganz... bei mir ging es nicht ohne Speichern der default.conf. Ein einfaches Quit oder starten ohne Config brachte auch nichts (außer z.B. einem neu erstellten Configurations Verzeichnis).
Erst, nachdem ich Englisch (builtin) eingestellt und gespeichert hatte, wurde alles auf Deutsch angezeigt (auf gut Deutsch: jetzt geht nur noch Deutsch).

Zitat:
Bleibt die Frage, wo wird es gespeichert, wenn es auch ohne abspeichern der Config geht. Registry??

Das ist ne gute Frage ;)

Grüße


--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 21:56 Uhr

Palgucker
Posts: 1341
Nutzer
@ whose

Das mit dem Registry-Eintrag scheint gelöst, siehe meinen Nachtrag.
Das mit dem nicht "ganz rund" laufen sehe ich auch so, den aus der "Nummer" mit der "Eindeutschung" komme ich zwar 'raus, wenn ich auf Autodetect stelle. Aber beim nächsten Start fehlt dann wieder die "German-Auswahl". Also wieder auf "built-in" und beim nächsten Start kann ich wieder German auswählen.

Also funktioniert Autodetect zumindest nicht so, wie ich mir das vorstelle, zumal rechts in meiner Taskleiste deutlich "DE" steht.

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

28.12.2007, 22:25 Uhr

whose
Posts: 2156
Nutzer
@Palgucker:

Jap... Zeit für nen Bugreport. Oder hat jemand schon einen abgegeben?

--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233

[ - Antworten - Zitieren - Direktlink - ]

29.12.2007, 14:24 Uhr

Mittag12
Posts: 79
Nutzer
Hallo Whose, hallo Palgucker,
ich gebe auf !
Nach vielem Probieren in der Registry, mit
Abspeichern, quit ohne speichern, etc.,etc. - es
geht nicht. Bei mir ist die German_Dll nicht
auswählbar ! Soll sie doch bleiben, wo der
Pfeffer wächst, ich komme auch mit der
built-in gut klar. Schade nur, um die Arbeit
die manche sich machen, um eine deutsche
Datei zu erstellen.
Grüße aus Hamburg !

[ - Antworten - Zitieren - Direktlink - ]

29.12.2007, 17:42 Uhr

Palgucker
Posts: 1341
Nutzer
@ Mittag12

Mhm?, und Du bist auch sicher, das sowohl die Winuae.exe und die WinUAE_German.dll im selben Verzeichnis jeweils die selbe Dateiversion (1.4.5.0) haben?

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

29.12.2007, 17:45 Uhr

Mittag12
Posts: 79
Nutzer
Ja !!

[ - Antworten - Zitieren - Direktlink - ]

30.12.2007, 23:01 Uhr

Turrican
Posts: 849
Nutzer
Brasto hat die German-DLL nochmal überarbeitet. Die aktuelle Datei steht auf http://www.amigaemuboard.net zum Download bereit.

Ich musste bei mir aber auch zuerst auf "English (Built-in)" stellen und WinUAE beenden. Nach einem Neustart konnte ich dann "Deutsch" als Sprache einstelllen.
--
A1200T / BlizzardPPC 603+ 060-240 / 256MB FastRAM / Mediator SX / Voodoo4 32MB / DVD-Brenner

amigaemuboard.net - Amiga still alive !!!

[ - Antworten - Zitieren - Direktlink - ]

31.12.2007, 14:03 Uhr

tploetz
Posts: 4026
Nutzer
@Turrican:
Deutsch läßt sich immmer noch nicht einstellen.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

31.12.2007, 15:39 Uhr

Mittag12
Posts: 79
Nutzer
Jetzt ist ( bei mir ) WinUAE in deutsch !
Ich habe mir gestern auf der von Turrican
angegebenen Seite die Datei "WINUAE_German_dll_fixed.zip"
runtergeladen. Mit der funktioniert es!
Eben habe ich dort nochmal nachgesehen, jetzt gibt es
diese Datei nicht mehr, sie wird wohl umbenannt
worden sein in WINUAE_German_dll_1.4.5.zip und auch
funktionieren.

Mittag12

[ - Antworten - Zitieren - Direktlink - ]

01.01.2008, 11:58 Uhr

Turrican
Posts: 849
Nutzer
Jep, WinUAE_German_DLL_1.4.5.zip ist die aktuelle Datei :)
--
A1200T / BlizzardPPC 603+ 060-240 / 256MB FastRAM / Mediator SX / Voodoo4 32MB / DVD-Brenner

amigaemuboard.net - Amiga still alive !!!

[ - Antworten - Zitieren - Direktlink - ]

06.02.2008, 19:11 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
die neue Sprach-Datei für WinUAE 1.4.6 funktioniert auch nicht.
Ich weiß nicht, wer sich da soviel Arbeit macht, wenn es nicht geht.

tploetz X( :lickout:

[ - Antworten - Zitieren - Direktlink - ]

06.02.2008, 19:54 Uhr

Palgucker
Posts: 1341
Nutzer
@ tploetz

Geh mal in die Registry

HKEY_CURRENT_USER\Software\Arabuusimiehet\WinUAE\

Dort sollte ein Schlüssel Namens Language sein, dessen Wert 7 sein sollte.

Wenn nicht, lege einen solchen als REG_DWORD an.
Wenn Da schon einer ist, der ein REG_BINARY ist, müsste er mit 00 00 00 07 gefüllt sein (funktioniert bei mir auch).

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

06.02.2008, 21:41 Uhr

tploetz
Posts: 4026
Nutzer
@Palgucker:
Wo finde ich die Registry?

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

06.02.2008, 22:45 Uhr

Palgucker
Posts: 1341
Nutzer
@ tploetz

Zitat:
Wo finde ich die Registry?

Entweder Start-Ausführen oder Eingabeaufforderung starten und dort regedit eintippen - startetet die Regedit.exe in Deinem Windows-Verzeichnis.
Dort folgst Du einfach dem o.g. Pfad.
Auf der linken Seite aktivierst Du durch anklicken einfach WinUAE. Auf der rechten Seite sind dann die beinhalteten Schlüssel sichtbar - configfile,ConfigurationsPhat... usw.
Dort sollte auch ein "Schlüssel" Language zu finden sein. Wenn der Typ
REG_WORD ist(bei mir Standard), brauchst Du darauf nur doppelklicken, um den gewünschten Wert (7) einzutragen.
Ist der Schlüssel vom Typ REG_BINARY, würde ich diesen eventuell löschen - anklicken, Entfernen-Taste und Bestätigen. Dann im rechten Feld des Editors rechte Maustaste ->neu->DWORD-Wert.
Diesen wieder in Language umbenennen und Wert eintragen.
Das ganze sollte nach schließen des Reg-Editors sofort funktionieren - das heißt, die Wirkung wird bei einem erneuten Start des Emulators sofort sichtbar werden - ohne das der Rechner neu gestartet werden muß.

Gruß Palgucker


[ - Antworten - Zitieren - Direktlink - ]

07.02.2008, 18:02 Uhr

tploetz
Posts: 4026
Nutzer
@Palgucker:
Hallo,
den Wert habe ich mit regedit auf 7 geändert, es bleibt alles wie gehabt in englisch, nach einem Neustart ist der Wert 7 bei Language
wieder verschwunden. REG_WORD stand auch da.

tploetz X( X(

[ - Antworten - Zitieren - Direktlink - ]

08.02.2008, 17:01 Uhr

Palgucker
Posts: 1341
Nutzer
@ tploetz

Zitat:
...7 geändert, es bleibt alles wie gehabt in englisch, nach einem Neustart ist der Wert 7 bei Language wieder verschwunden.

Das kann ich so nicht nachvollziehen. Bei mir bleiben die eingetragenen Werte solange dort stehen, bis ich eine neue Sprache in Misc/Language einstelle. Von selbst ändert sich bei mir dieser Wert nicht.
Nur zur Sicherheit - die Sprache >german< kannst Du aber auswählen?
Und in der Registry hat der Schlüssel RomCheckversion und Version den Eintrag >WinUAE 1.4.6 (2008.02.02)<

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

08.02.2008, 18:51 Uhr

tploetz
Posts: 4026
Nutzer
@Palgucker:
Hallo,
gestern stand der Wert bei Langugage bei 7, heute ist die 7 wieder weg,
das verstehe ich nicht.
Die Datei Germam.dll ist bei mir im Verzeichnis C:Programme/Cloanto/AmigaForever/Emulation/WinUAE
Wenn ich die Datei German.dll zweimal anklicke öffnet sich WinUAE.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 08.02.2008 um 19:00 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

08.02.2008, 20:08 Uhr

Palgucker
Posts: 1341
Nutzer
@ tploetz

Merkwürdig ist das schon. Ich gehe mal davon aus, das winuae.exe und winuae_german.dll die selbe Version haben.
Hast Du vielleicht eine WinUAE.exe noch irgendwo anders gespeichert, die anstatt der eigendlich gewollten benutzt wird - deshalb die Frage nach der in der Registry eingetragenen Version.
Du könntest ja mal eine Konfigdatei (.uae) nur zur Sicherheit nochmals per Rechtsklick - Eigenschaften - ändern - durchsuchen mit der neusten Version der WinUAE.exe verknüpfen.
Das WinUAE bei einem Doppelklick auf eine Dll startet, halte ich zwar für bedenklich aber ob es in diesem Fall schadet?
Würde ich auf jedenfall abbiegen.
Schau auch da mal in die Registry. Dort sollte im Schlüssel
>>HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\
auch der Unterschlüssel .dll auftauchen. Diesen anklicken, dann müsstzest Du auf der rechten Seite schon was von WinUAE lesen können. Diesen Schlüssel (rechts) dann löschen.

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

08.02.2008, 21:52 Uhr

tploetz
Posts: 4026
Nutzer
@Palgucker:
ich habe den Schlüssel auf der rechten Seite gelöscht,
sobald ich WinUAE gestartet habe und wieder verlasse,
stellt sich der Wert bei Language von 7 auf 65535 zurück.
Im Einstellfenster von WinUAE bei Misc steht nur Autodetect
oder Englisch Built.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

09.02.2008, 17:47 Uhr

Palgucker
Posts: 1341
Nutzer
@ tploetz

Wie Du das hin bekommst, das der Wert von selbst auf 65535 springt - k.A.
Noch ein Versuch: - Starte mal irgendeine Config und schaue in den Properties (F12) ganz oben unter about nach, ob bei dir wirklich die WinUAE.exe der Version 1.4.6 läuft.
Wenn nicht, klicke mal einfach die WinUAE.exe in Deinem Winuae-Verzeichnis an. Nach ein paar Fehlermeldungen kannst Du diese wieder beenden.
Der Hintergrund ist, das man irgendeine Winuae.exe anklicken kann, und diese sich sofort ins System einträgt. Diese wird dann - ohne das man das unbedingt bemerkt - immer zum starten einer Config benutzt.

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

10.02.2008, 22:26 Uhr

Turrican
Posts: 849
Nutzer
Ich hab die German DLL im selben Verzeichnis wie WinUAE entpackt nach dem starten von WinUAE konnte ich dann die deutsche Sprache auswählen.

Hier noch mal Schritt für Schritt ;)

1. WinUAE_German.dll in den WinUAE Ordner kopieren
2. WinUAE starten, dann
'Settings -> Host -> Misc -> Language' auf 'German' setzen
(auf Deutsch heisst das dann 'Einstellungen -> Host -> Sonstiges -> Sprache' :-) )
3. WinUAE beenden und neu starten
--
A1200T / BlizzardPPC 603+ 060-240 / 256MB FastRAM / Mediator SX / Voodoo4 32MB / DVD-Brenner

amigaemuboard.net - Amiga still alive !!!

[ - Antworten - Zitieren - Direktlink - ]

10.02.2008, 22:58 Uhr

ArminHuebner
Posts: 1349
Nutzer
@Turrican:

> 'Settings -> Host -> Misc -> Language' auf 'German' setzen

Bei mir ist dieses Feld angegraut und dort steht "Autodetect".
Auswählen lässt sich dort nichts... :(
--
Gruß, Armin.
--
'Auch wenn alle einer Meinung sind, können alle Unrecht haben.'
'Viele kaufen mit dem Geld, das sie nicht haben, Dinge, die sie nicht brauchen, um denen zu imponieren, die sie nicht ausstehen können.'

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > Neue Sprach-DLL für WinUAE 1.4.5 ist verfügbar [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.