amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Booten mit USB-Stick [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

23.06.2008, 21:14 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
welche Dateien müssen im ROM der Deneb sein, um mit einem
USB-Stick den Amiga zu starten?
Kann mir jemand weiterhelfen, ich habe es nicht geschafft.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 18:38 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
früher mit der Algor habe ich das immer geschafft das FlashROM
zu füllen, das USB beim Start schon da war, jetzt fehlt
irgendwas.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 19:03 Uhr

tploetz
Posts: 4026
Nutzer
Anscheinend weiß keiner Bescheid, ich weiß auch nicht was zuerst
im FlashROM der Deneb drin stand.
Ich sitze stundenlang vor dem Amiga und bekomme es nicht hin,
mir macht das kein Spaß mehr.
Für mich ist das ärgerlich, das ich mir nicht gemerkt habe, was
ursprünlich im FlashROM stand.

tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 24.06.2008 um 19:23 Uhr geändert. ]

[ Dieser Beitrag wurde von tploetz am 24.06.2008 um 19:36 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 19:53 Uhr

Big_H
Posts: 408
Nutzer
In luciferin gibt es nen poseidon quick install. (Rechter maus button dann oben in der task leise)
das läd dir alles was du für poseidon brauchst in die liste. so das du nur noch flashen brauchst.

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 20:09 Uhr

tploetz
Posts: 4026
Nutzer
@Big_H:
das habe ich schon gemacht, es werden aber nur drei Dateien angezeigt,
poseidon.library, input.device und psdstackloader.
Damit geht es aber nicht.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 20:49 Uhr

Black_Fox
Posts: 56
Nutzer
@tploetz:
Also bei mir hat Luciferin dann den gesamten Poseidon-Stack mit allen Klassen geflasht! Da muß bei Dir irgendwas bei der Installation schief gelaufen sein.
Überprüfe noch mal, ob Poseidon bei Dir richtig installiert wurde.
Gruß
Black_Fox

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 21:18 Uhr

falkone
Posts: 128
Nutzer
@tploetz:

frag doch einfach Chris, ich denke er kann Dir dabei am besten helfen.

Mit welchen Filesystem hast Du denn den Stick formatiert? fat 95, sfs oder ffs?

Und welche Dateien hast Du denn jetzt im Flash?

Gruß

Falkone



--
Amiga 4000 Desktop - CyberstormPPC 233/60 Mhz - Picasso IV (vollbestückt) - Buddha - Algor - Oktagon - OS 3.9/4.0 etc.

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 21:57 Uhr

tploetz
Posts: 4026
Nutzer
@falkone:
um welche Dateien es sich handelt, habe ich weiter oben schon genannt.
Ich meine, das es früher mit der Algor mehr als drei Dateien waren,
habe Luceferin Version 4 installiert und Poseidon Version 4.
Woran soll es liegen?

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.06.2008, 22:18 Uhr

tploetz
Posts: 4026
Nutzer
@falkone:
der USB-Stick ist mit ffs formatiert, wird aber nicht erkannt.
da ich ihn mit HDToolbox eingerichtet habe.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

25.06.2008, 01:28 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Anscheinend weiß keiner Bescheid, ich weiß auch nicht was zuerst
im FlashROM der Deneb drin stand.
Ich sitze stundenlang vor dem Amiga und bekomme es nicht hin,
mir macht das kein Spaß mehr.


Doch, Thomas, hier weiss schon jemand Bescheid. Auf meine Antwort hin kam aber von dir nichts mehr, also bin ich davon ausgegangen, dass es geklappt hat. Und momentan habe ich eigentlich weder den Nerv, noch die Zeit, um alle moeglichen Foren nach Supportanfragen zu durchforsten.
Stattdessen jammerst du hier im Forum, statt mir Bescheid zu geben - dass dir dann der Spass vergeht, ist vielleicht so ein klein bisschen deine eigene Schuld?

Warum keine kurze Mail mit "Schnellkonfiguration hat nicht geklappt" und der Liste der im FlashROM gespeicherten Dateien? Das waere hilfreich zur Loesung des Problems gewesen, und sicher zielfuehrender als stundenlanges Probieren.

Unabhängig davon: bei einer ordnungsgemäßen Installation von Poseidon und Luciferin macht der Menupunkt "Schnellkonfiguration" genau das, was du brauchst.
Es muessen aber insgesamt mindestens fünf Dateien sein.
Bevor du das ganze durchfuehrst, bitte eine funktionierende Konfiguration in Trident erstellen und speichern!

Folgende Dateien müssen rein:

- poseidon.library (libs:)
- massstorage.class (sys:Classes/USB)
- denebXXXusb.device (devs:USBHardware -> z2, pio oder dma statt XXX)
- hub.class (sys:Classes/USB)
- PsdStackloader (envarc:)

Welche hat bei dir gefehlt?

Beliebtester Fehler ist das Weglassen der hub.class, ohne die Poseidon leider nicht ueber den Roothub der DENEB hinaus kommt.

Zweitbeliebtester Fehler: der Watchdog in der FPGA-Firmware V6 (der das FlashROM deaktiviert). Upgrade-Archiv ist gepackt, es muss nur noch online gestellt werden (nicht mehr heute, sorry).
Ist nach dem Booten und Starten von Luciferin eine Fehlermeldung ueber einen angeblich gesteckten ROMOFF-Jumper sichtbar?

Hast du einen der neuen Bootloader von Chris aus dem Luciferin-Update installiert?

Mit der LED deines USB-Sticks erkennst du auch einfach, ob Poseidon aktiv ist nach dem Reset.

Michael

[ - Antworten - Zitieren - Direktlink - ]

25.06.2008, 10:20 Uhr

RhoSigma
Posts: 67
Nutzer
@mboehmer:
Ah gudd,
das mit dem ROMOFF Jumper hatte ich auch schon ein paar mal, kombiniert mit dem fehlen der FlashRom.resource (welche ja laut ID-String offensichtlich der Bootloader ist) und daraus folgend dem Fehlen der im Flash installierten Module.
Hatte bis jetzt angenommen, daß das ein Wackler beim Einbau der Deneb war, da es nur sporadisch auftrat, und wollte nächstes Wochenende meinen Amiga noch mal aufschrauben und nachsehen. Das hat sich wohl damit dann erledigt.
Danke.

[ - Antworten - Zitieren - Direktlink - ]

25.06.2008, 10:52 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Original von RhoSigma:
@mboehmer:
Ah gudd,
das mit dem ROMOFF Jumper hatte ich auch schon ein paar mal, kombiniert mit dem fehlen der FlashRom.resource (welche ja laut ID-String


Firmware-Update kommt. Der Tag hat nur 24h, und ich nur zwei Haende...

Michael

[ - Antworten - Zitieren - Direktlink - ]

25.06.2008, 12:32 Uhr

aPEX
Posts: 4692
Nutzer
Zitat:
Original von mboehmer:
Firmware-Update kommt. Der Tag hat nur 24h, und ich nur zwei Haende...


Hut ab, ich würde mich aber nur auf ein Forum mit dem Support konzentrieren und dann sollen die User doch dahin gehen... Nicht der Support muss zum User, der User muss zum Support. :)


[ Dieser Beitrag wurde von aPEX am 25.06.2008 um 12:37 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

25.06.2008, 18:12 Uhr

tploetz
Posts: 4026
Nutzer
[

Hast du einen der neuen Bootloader von Chris aus dem Luciferin-Update installiert?


Michael
[/quote]

Es sind überhaupt keine Bootloader mehr im Verzeichnis Luciferin,
warum sind die weg? Bei Version 3 waren sie noch da.

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

26.06.2008, 08:07 Uhr

gni
Posts: 1106
Nutzer
Zitat:
tploetz:
Es sind überhaupt keine Bootloader mehr im Verzeichnis Luciferin, warum sind die weg? Bei Version 3 waren sie noch da.

ReadMe und/oder Dokumentation lesen? Steht alles drin... Bei Luciferin 4.0 sind die Loader im Programm integriert.

[ - Antworten - Zitieren - Direktlink - ]

26.06.2008, 08:11 Uhr

gni
Posts: 1106
Nutzer
Zitat:
mboehmer:
Hast du einen der neuen Bootloader von Chris aus dem Luciferin-Update installiert?


Bei mir scheinen die Loader von 4.0 nicht zu funktionieren. Poseidon wird nicht aktiviert. Mit Luciferin 3.0 und dessen Loader(n) ist USB nach dem Booten benutzbar.

[ - Antworten - Zitieren - Direktlink - ]

26.06.2008, 10:05 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Bei mir scheinen die Loader von 4.0 nicht zu funktionieren. Poseidon wird nicht aktiviert. Mit Luciferin 3.0 und dessen Loader(n) ist USB nach dem Booten benutzbar.

Ist nach dem Booten das FlashROM der DENEB deaktiviert (showconfig oder Luciferin)?

Hast du nach dem Update des Bootloaders das FlashROM mal komplett neu beschrieben, um Wechselwirkungen auszuschliessen?

Michael

[ - Antworten - Zitieren - Direktlink - ]

26.06.2008, 13:23 Uhr

gni
Posts: 1106
Nutzer
Zitat:
mboehmer:
Ist nach dem Booten das FlashROM der DENEB deaktiviert (showconfig oder Luciferin)?

Luciferin hat sich nicht über ein deaktiviertes Flashrom beschwert.
Zitat:
Hast du nach dem Update des Bootloaders das FlashROM mal komplett neu beschrieben, um Wechselwirkungen auszuschliessen?
Ich habe mehrfach geflasht. Zuerst alles geleert, dann Luciferin 4.0 neu gestartet. Da wurde das Flash als leer gezeigt. Danach habe ich mit 4.0 meine Config geflasht. Nach dem Booten kein USB, laut Luciferin war aber alles im Flashrom. Als Loader hatte ich die neue Variante mit RMB-NOLMB gewählt, sowohl mit als auch ohne Farbe. Weitere Experimente mit 4.0 wollte ich dann nicht mehr machen, deshalb bin ich dann zur funktionierenden 3.0 Variante zurückgegangen.

FYI, Poseidon manuell starten ging schief, weil meinem PsdStackloader das Execute-Bit fehlte, ich es ohne Pfadangabe aufrief und die Shell dann meinen alten PsdStackloader für die Highway benutzte (ja, der ist bei mir im Pfad). Das hat jetzt nichts mit dem Flashen zu tun, ist aber eventuell als Information für andere interessant, die Poseidon auch manuell starten wollen.

[ - Antworten - Zitieren - Direktlink - ]

26.06.2008, 21:22 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Als Loader hatte ich die neue Variante mit RMB-NOLMB gewählt, sowohl mit als auch ohne Farbe.

Probier bitte mal den LMB-MMB aus.
Eventuell ist ein Fehler im RMB-NOLMB.

Michael

[ - Antworten - Zitieren - Direktlink - ]

27.06.2008, 21:45 Uhr

tploetz
Posts: 4026
Nutzer
@mboehmer:
Gallo,
wo finde ich denn die Bootloader unter Luciferin 4 ?

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

27.06.2008, 22:50 Uhr

amiga23
Posts: 14
Nutzer
Moin,

Luciferin 4.0 stürzt bei mir ab, sobald ich die "Schnellkonfiguration" auswähle, oder sobald ich die "hid.class" manuell hinzufügen will.

Habe auch schon die ENVARC:PsdStackloader gelöscht und im Trident unter config alle Einträge gelöscht. Hilft leider nicht.

Meine Config:
A4000/60
OS 3.9
Cybervision 64
Ariadne II
DENEB im PIO Mode. DMA geht bei mir nicht.

Gibt es ein offizielles Support-Forum?

Mit AHI habe ich auch Probleme. Wenn ich ein USB-Audio device beim booten angeschlossen habe, gibt es bei AHI nur noch dieses USB Audio Device, aber die Paula und 14bit modes nicht mehr.
Wenn ich den Delitracker starte und dann erst das USB Audio Device anschließe, sind alle Modes verfügbar.

Ansonsten bin ich voll begeistert von der DENEB.
USB Maus / Keyboard, USB-Netzwerk Adapter und USB-Stick laufen super.
Sogar das Scrollrad an der Maus funktioniert. :bounce: :commo: :dance1: :boing:

Liebe Grüße
Amiga23
--
1x A4000, 2x CD³², 1x CDTV, 1x A600, 2x A2000, diverse A500, 1x A1000, 1x C= 128, diverse C= 64, 1x C= 16, 1x VC20

[ - Antworten - Zitieren - Direktlink - ]

28.06.2008, 00:25 Uhr

amiga23
Posts: 14
Nutzer
nachdem ich die DENEB jetzt trotzdem (ohne hid.class) geflasht habe, ging erst mal gar nix mehr. Beim starten von ENVARC:PsdStackloader aus der user-startup ist die Kiste immer abgestürzt. Nach mehrfachem hin und her probieren, habe ich kurzerhand die hid.class verschoben, nun geht alles wieder.

Für meine USB Maus/Tastatur wird nun die bootmouse.class und bootkeyboard.class verwendet, damit geht allerdings das scrollrad nicht mehr.

Sobald ich versuche die hid.class über Lucifer hinzuzufügen, oder die hid.class wieder nach SYS:Classes/USB zurückkopiere kommt es wieder zu einem Absturz.

Dafür sind die Recoverable alerts weg :-)
--
1x A4000, 2x CD³², 1x CDTV, 1x A600, 2x A2000, diverse A500, 1x A1000, 1x C= 128, diverse C= 64, 1x C= 16, 1x VC20

[ - Antworten - Zitieren - Direktlink - ]

28.06.2008, 12:18 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Original von tploetz:
wo finde ich denn die Bootloader unter Luciferin 4 ?


RTFM.

Bitte. Lies die Anleitung. Oder wenigstens den Changelog. Oder die Meldung auf amiga-news. Bei letzterem reichen schon die ersten beiden Zeilen, um deine Frage zu beantworten.

Michael

[ - Antworten - Zitieren - Direktlink - ]

28.06.2008, 12:41 Uhr

amiga23
Posts: 14
Nutzer
@tploetz:
Die Bootloader sind bei Luciferin 4.0 in das Programm integriert und liegen nicht mehr auf der Platte.
Es gibt jetzt einen dritten Reiter, bei dem Du auswählen kannst welchen Bootloader Du haben möchtest.
Das ganze ist so benutzerfreundlicher und hilft Bedienfehler zu vermeiden.

Liebe Grüße
Amiga23
--
1x A4000, 2x CD³², 1x CDTV, 1x A600, 2x A2000, diverse A500, 1x A1000, 1x C= 128, diverse C= 64, 1x C= 16, 1x VC20

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Booten mit USB-Stick [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.