amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > AfA_OS: wo ist die zune.library? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

28.06.2008, 12:01 Uhr

Saegezahn
Posts: 26
Nutzer
Hallo. Ich habe Afa 4.0 bei mir installiert. Läuft auch so weit. Zune habe ich auch installiert und kann bei einigen Programmen die veränderten Buttons angucken. Jetzt habe ich mal SnoopDOS gestartet und sehe da, daß ständig versucht wird die zune.librar zu öffnen. Ständig heißt ungefähr 4x pro Sekunde. Das rattert nur so runter. In wenigen Sekunden sind da 400 Einträge voll, man sieht überhaupt nichts mehr. Ja wo ist diese zune. library? Ich finde die in keinem Archiv. Da ist nur eine Datei zune__lib.exe. Die heißt noch am ähnlichsten so. Aber keine zune.library. Warum fehlt die? Warum wird ohne Ende versucht, die zu öffnen? Immer load, read, erst in LIBS: 2x, dann ohne Pfad 2x. Wenn sonst mal ein Programm nicht geht, versucht es bloß 1x die Lib zu öffnen aber nicht endlos. DAs macht den Rechner doch viel langsamer. Also wo kriege ich die zune.library her, damit das aufhört?

[ - Antworten - Zitieren - Direktlink - ]

28.06.2008, 12:43 Uhr

Kaesebroetchen
Posts: 643
Nutzer
@Saegezahn:
So weit ich weiß, ist die zune_lib.exe die zune.library. Wenn die Darstellung der Buttons sich verändert hat, wird die zune.library doch offensichtlich gefunden ?

Frag doch mal den Autor Vielleicht kann der dir das erklären.
--
http://amidevcpp.amiga-world.de/

[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 17:28 Uhr

Saegezahn
Posts: 26
Nutzer
@Kaesebroetchen: Danke für die Antwort. Die Buttons sind geändert, aber das kann ja nicht richtig sein, daß da dauernd nach der Library gescuht wird. Kein anderes Programm macht das so. Und wenn es schon diese Lib ist: wieso heißt die dann nicht auch zune.library? Wird sie etwa deswegen nicht gefunden? Wundert mich dann ja auch nicht. Bei dem Namen denkt mansofort an ein Windowsprogramm. Ich meine kein einziges Amigaprogramm heißt was mit .exe, das verwirrt ja nur. Und wenn das eine Library sein soll muß die doch auch so heißen. Sonst weiß das AmigaOS doch nicht, daß das eine Lib ist. Soll ich die dann umbenennen in zune.library? Ich schreibe dem Autor auch mal. Vielleicht antwortet der ja. Dort im Foruim wollte ich erst schreiben. Aber da gibts ja schon sehr lange keine neuen Einträge mehr. Ich glaube, das hat da wenig Zweck.

[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 17:41 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Vielleicht zur erklärung:

Alle libraries von AfA kommen als "exe" daher.
Die werden ausgefüht und rufen MakeLibrary auf, um die Library im RAm zu erzeugen. Auf dem Amiga muss ja eine Library nicht notwendigerweise als Datei vorliegen, viele Libs kommen z.B. aus dem ROM einer Hardware.
Ausserdem sind nicht alle Libraries komplett, brauchen also noch Funktionen der "alten" Library, und das kann man per MakeLibrary schön umlenken.

Das hat auch noch den Zweck, dass dein System wieder Clean ist, sobald du den AfaLoader nicht in der Startup Sequence ausführst oder während dem Booten den rechten Mausknopf drückst.


--
Thilo Köhler, Author von:
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, TK AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 17:43 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Welches Program versucht denn ständig die zune.library zu öffnen?
Kommt dann OK oder fail?

Vermutlich ist das nicht die Schuld von AfA, sondern von dem jeweiligen Program. Ohne AfA/Zune würde es vermutlich nach mui.library suchen.


--
Thilo Köhler, Author von:
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, TK AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 18:34 Uhr

Saegezahn
Posts: 26
Nutzer
@Der_Wanderer: Die Erklärung ist ja schön und gut aber muß man den Benutzer absichtlich verwirren? Find mal eine einzige Datei auf nem Amiga, die .exexheißt. Ich wette, daß Du keine findest. Also warum nicht einfach alles so machen wie der Rest der Amigawelt auch? Dann weiß wenigstens jder Benutzer, was das für eine Datei ist. Dann hat man auch kein Problem mit verschiedenen Namen. Alle anderen DAtein im AmigaOs heißen doch auch so wie ihr Name ist. Daran erkennt man sie wieder.
Welches Programm das ist? Ich weiß es nicht, das steht nicht da. Kann man das mit SnoopDOS auch herausfinden? Dann muß ich mal gucken, wie das geht. Ich sehe immer nur die runtetrratternden Einträge. Alle gehen schief, immer fail. Immeri m Wechsel 2x in LIBS: und 2x in einem unbenannten/unbekanntn Verzeichnis. Ich dachte, das wäre dann automatisch das Zuneverzeichnis. Ich kann es auch nicht feststellen, weil SnoopDOS ja nicht das allererste Programm ist, das gestartet wird. Schon der allererste Eintrag in SnoopDOS ist zune.library fail. Davor hat das Programm das sicher schon 180000x versucht, aber den ersten Aufruf davon werde ich doch niemals sehen können. Ob 3es nach mui.library sucht: kann ich das rausfinden, indem ich den Eintrag in der Startup-Sequence entferne?

[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 19:35 Uhr

GolfSyncro
Posts: 1455
Nutzer
Das hört sich an als würde ein Assign fehlen...
--
Bild: http://home.arcor.de/golfsyncro/sig.gif
Chef ist man erst, wenn man das Geschäft so verteilt,
das man selber nichts mehr machen muß.



[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 20:19 Uhr

bernd_roesch
Posts: 364
[Benutzer gesperrt]
vermutlich ist dein zune_lib.exe zu alt

Hast du das runtergeladen und installiert nachdem du AFA 4.1/4.2 installiert hattest ?

für AFA 4.0 wurde zune nie releast, und das file findet sich nach AFA 4.1

http://amidevcpp.amiga-world.de/AfA_Binaries/afa_os_zune1.0beta4.lha

>Die Erklärung ist ja schön und gut aber muß man den Benutzer >absichtlich verwirren? Find mal eine einzige Datei auf nem Amiga, >die .exexheißt. Ich wette, daß Du keine findest.

Bei AFA heissen die libs _lib.exe
So wie die bei OS4 .kmod heissen, bei MOS weis nimmer und irgendwo in einem anderen dir sich befinden.Die haben also auch ein anderes lib verfahren.

Bei AFA gehört zune(MUI) wie bei MOS direkt zum System und wird beim boot geladen.

Das dauernde anzeigen in snoopdos ist nur um anzuzeigen, dass etwas nicht geladen werden konnte.

AFA ist safe, d.h das System stürzt auch beim booten mit falschen lib Versionen nicht ab, es sind nur die Features nicht verfügbar.

solltest also immer drauf achten, dass keine snoopdos hits kommen, wenn welche kommen, ist die lib zu alt.



[ Dieser Beitrag wurde von bernd_roesch am 30.06.2008 um 20:24 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 21:17 Uhr

Andreas_Wolf
Posts: 2980
Nutzer
> bei MOS weis nimmer und irgendwo in einem anderen dir sich befinden.Die haben also auch ein anderes lib verfahren.

Bei MorphOS heißt eine PPC-Lib *.library.elf nur dann, wenn sie sich im selben Pfad wie die entsprechende m68k-Lib *.library befindet. Die PPC-Lib hat die höhere Priorität. Bei einer Trennung in SYS:libs und MOSSYS:libs ist das aber natürlich nicht nötig, ersterer Pfad hat dabei die höhere Priorität.

[ - Antworten - Zitieren - Direktlink - ]

30.06.2008, 22:40 Uhr

cgutjahr
Posts: 2709
[Administrator]
Zitat:
Original von bernd_roesch:
Bei AFA heissen die libs _lib.exe
So wie die bei OS4 .kmod heissen, bei MOS weis nimmer und irgendwo in einem anderen dir sich befinden.Die haben also auch ein anderes lib verfahren.

Eine Library heißt unter AmigaOS 4 selbstverständlich *.library, was du meinst ist ein "Kickstart Module" (*.kmod).

--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

01.07.2008, 15:46 Uhr

Gazelle
Posts: 151
Nutzer
Zitat:
Eine Library heißt unter AmigaOS 4 selbstverständlich *.library, ...

Du meinst sicherlich #?.library, SCNR ;)

[ - Antworten - Zitieren - Direktlink - ]

01.07.2008, 18:04 Uhr

cgutjahr
Posts: 2709
[Administrator]
Zitat:
Original von Gazelle:
Du meinst sicherlich #?.library, SCNR ;)

Nö, ich meine *.library - siehe Prefs/DOS ;)
--
Gutjahrs Amiga Seiten

[ - Antworten - Zitieren - Direktlink - ]

03.07.2008, 22:32 Uhr

Saegezahn
Posts: 26
Nutzer
GolfSyncro, hast Du eine Idee, was für ein Assign das sein könnte? Es wird ja nicht danach gefragt oder in SnoopDOS angezeigt, also wie könnte ich das rauskriegen?

Bernd_roesch: ich hatte AFA 4.1/4.2 noch nie installiert, hab wohl übersehen, daß es die gibt. WErde ich mal ausprobieren. Ich installiere mal eine 4.2 und gucke, ob der Fehler dann auch noch kommt.
Ich finde das total dämlich wenn die Libs bei AFA nicht Libs heißen sondern EXE. AFA soll doch ein WEg zwischen OS3 und AROS sein, und bei beiden heißt es immer .library. Also macht da .exe gar keinen Sinn. Es verwirrt nur die Benutzer, die nicht den ganzen Tag im Internet rumhocken und alles wissen.
Da in SnoopDOS keine Hits kommen (ich nehme an die sehe ich dann, so kommt ja immer nur "fail"), ist die Lib wohl nicht zu alt. Aber es steht auch keine Version da. Ich kann nur sagen die DAtei ist vom 27.5.2007 und 579.064 groß.
So, habs mir jetzt runtergeladen und werde es wohl morgen mal ausprobieren (4.2). Die Seite ist ja nicht sehr überscihtlich. Wenigstens etwas sortiert könnte sie sein oder einfach die alten Versionen wegweerfen. Dann muß man nicht so lang suchen, was man nun haben will. Also morgen testen, Heute klappt es nicht mehr.

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > AfA_OS: wo ist die zune.library? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.