amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > CF Karte als Festplatte am Amiga 1200 - Wird nicht gefunden [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

25.10.2008, 05:09 Uhr

HairFU
Posts: 21
Nutzer
Da meine Festplatte in meinem Amiga 1200 sich langsam dem Lebensende entegen neigt, habe ich mir gedacht das ich eine CF Karte mittels IDE Adapter als neue "Festplatte" einbaue.
Als ich das ganze dann benutzen wollte ging es nicht. Und zwar war zunächst das problem das ich einen IDE 3,5 zoll Adapter für meine CF Karte hatte ehe mir bewußt wurde das in meinem Amiga (generell?) nur ein 2,5 zoll anschluss ist. Ok kein Thema, habe nun den IDE 2,5 zoll CF Karten adapter und eingebaut. Booten tut er nur in der richtigen stellung, ist er falsch angeschlossen mag der Amiga nicht booten.
Nach dem Booten hat er zunächst nicht auf die CF Karte zugegriffen. Logisch, da die CF Karte kein Amiga Format besitzt, also dachte ich mir legst du mal die Workbench 3.0 Diskette ein und formatierst die CF Karte mit HD Toolbox. Dann kam nur suche:

search scsi device unit 0

Dabei wurde nichts gefunden und die Liste blieb leer (also kein einrichten und/oder formatieren möglich). Habe dann nochmal versucht den CF Kartenadapter anders anzuschliessen (Amiga war aus!) was aber wie oben beschrieben nicht klappte, also mußte wohl der Adapter richtig angeschlossen sein. Meine andere CF Karte, welche ich schon lange als Datentransfer zwischen PC und Amiga verwendet hatte, hatte mir das selbe eregbniss gebracht.
Beide CF Karten (SanDisk Extreme III 1GB - SanDisk Ultra II 2 GB) gingen vorher problemlos am PC und über den PCMCI slot am Amiga.
Ich habe auch nochmal versucht mit HDInstTools das ganze hinzubekommen, aber auch dieses Programm hat die CF Karte nicht gefunden.

Irgendeine Idee was ich falsch gemacht habe?

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 08:24 Uhr

AmigaHarry
Posts: 1667
Nutzer
Hängt auch vom Adapter ab und möglicherweise auch von der CF ab (wie groß ist die denn?). Ist nur der Adapter am IDE-BUS oder hängt da noch was anderes? - In dem Fall Adapter auf Master und 2. Gerät auf Slave jumpern. Ist er alleine am BUS dann mit ChipSelect (CS) versuchen. Die CF muss bereits in der EarlyStartup auftauchen, wenn auch unformatiert als NDOS.....klappt mit dem Adapter von Conrad eigentlich problemlos.....


--
3xPEG2, 2xA3000,2xA1200 - damit mir nicht fad wird!

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 13:11 Uhr

HairFU
Posts: 21
Nutzer
@AmigaHarry:

Bei dem Adapter handelt es sich um diesen von Yingstar:

Bild: http://www.cf-ide.com/image/IMG_1665ys.jpg

An meinem IDE-Bus ist nur ein ein Gerät (der CF Karten Adapter) und ich habe wie gesagt eine 1 GB und 2 GB Karte und beide getestet, beide jeweils von SanDisk.
Was genau meinst du mit ChipSelect? Das Menü was erscheint wenn man beim booten rechte und linke Maustaste gleichzeitig drückt?

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 15:35 Uhr

Flinx
Posts: 1072
Nutzer
@HairFU:

Zuerstmal hättest Du keinesfalls versuchen sollen, die Anschlußrichtung mittels Ausprobieren herauszubekommen. Am Mini-IDE-Anschluß werden immerhin auch die Betriebsspannungen mitgeliefert, die an anderen Pins eher unerwünscht sind. Pin 1 ist auf Deinem Adapter außerdem schön gekennzeichnet (die schräge weiße Linie), da sollte der richtige Anschluß kein Problem sein.
Teste vorsichtshalber die Karten nochmal an einem anderen Gerät, ob sie das überlebt haben.

Mit CS meint der Harry wahrscheinlich Cable Select, aber das wird der Adapter gar nicht kennen.
Aus der Beschriftung des Adapters kann ich allerdings auch nicht entnehmen, welche Jumperposition nun Master und Slave sein soll, am besten, Du probierst mal beide aus. Funktionieren wird es nur in der Einstellung für Master.

Edit: Gerade habe ich begriffen, daß der Adapter zwei Kartenanschlüsse hat, da wird auch die Beschriftung klar: Jumperposition 1-2 heißt, daß die Master-Karte oben steckt und Slave unten. Wenn Du also nur eine Karte drinhast, dann Jumper auf 1-2 und die Karte oben hinein.



[ Dieser Beitrag wurde von Flinx am 25.10.2008 um 15:42 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 18:07 Uhr

Marcian0
Posts: 70
Nutzer
Manchmal muss man die Karten auch als "Fixed Disk" markieren (meistens sind sie im Standard als "Removable" gekennzeichnet).

Von Sandisk gibt's da ein Tool Namens "atcfwchg.com" . Ein Programm für x86-Dos.
Damit kannst Du die Karte gegebenenfalls umschalten. Ich weiß jetzt nicht mehr, ob die Daten auf der Karte erhalten bleiben.

Hier ist auch ein Link zu amiga.org, wo das Tool verlinkt ist und der Ablauf der Änderung:

http://www.amiga.org/modules/newbb/viewtopic.php?topic_id=46757&forum=8

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 18:36 Uhr

AmigaHarry
Posts: 1667
Nutzer
Kenne diesen Adapter nicht. Würde aber mal versuchen beide Slots mit je einer CF zu belegen....mal sehen was dann passiert (Jumperung wäre dann prinzipiell egal. Und ja, ich meinte Cable Select mit CS, was dein Adapter aber nicht kann, da er scheinbar sowieso nur als Einziger am Bus hängen darf.......

--
3xPEG2, 2xA3000,2xA1200 - damit mir nicht fad wird!

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 18:46 Uhr

Maja
Posts: 15429
Nutzer
Ja, die Karte muss als Laufwerk in der Early Startup Controll des Amigas erscheinen (beide Maustasten beim Einschalten gedrückt halten). Nicht alle CF sind kompatibel. Du hast alles richtig herum angeschossen, eingesteckt? Auf Master und Slave achten. Das Teil sieht mir auch nicht aus, als verfüge es über einen Verpolungsschutz, weder auf IDE- noch auf CF-Seite.

[ Dieser Beitrag wurde von Maja am 25.10.2008 um 18:47 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 19:18 Uhr

Marcian0
Posts: 70
Nutzer
CF-Slots sind codiert, auch wenn's auf den ersten Blick nicht so aussieht, gehen die Karten nicht falsch herum rein. (Links an der Seite ist der "Balken" etwas breiter als rechts.)

Und: Seid ihr sicher, dass die Karte im Early Startup erkannt wird? Ich hab grad keine Möglichkeit es zu testen. Aber erkennt AOS den MBR als NDOS?

[ - Antworten - Zitieren - Direktlink - ]

25.10.2008, 19:45 Uhr

Maja
Posts: 15429
Nutzer
IIRC erkennt KickStart zumindest eine FAT-formatierte HDD als NoDOS. Somit sollte das auch bei CF der Fall sein. Sofern sich die Karte überhaupt als Laufwerk zu erkennen gibt. Und da scheint der Hund begraben zu sein.

[ - Antworten - Zitieren - Direktlink - ]

27.10.2008, 10:44 Uhr

fazonga
Posts: 58
Nutzer
Diese DualAdapter eignen sich nur halb für den Amiga. Ich hatte
mir einen aus Jux gekauft und hatte damit massive Probleme in
einem A2000.

Das Problem ist , du musst den CF-Adapter richtig jumpern
(MAster oder Slave , hat gar nichts mit den 2 Karten zu tun -
nur wie er im IDE-Bus hängt)
und du musst (!) 2 CF-Karten drinne habe und auch lassen.
Dann sollte der Adapter erkannt werden und die HD-Toolbox auch
mitspielen. (Formattieren etc). Es wird auch nur eine CF-Karte erkannt.
Die andere brauchst du wohl , damit der Adapter überhaupt erkannt wird.

Ziehst du eine Karte raus , ist ende.

...viel Glück ;)

[ Dieser Beitrag wurde von fazonga am 27.10.2008 um 10:45 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

27.10.2008, 11:40 Uhr

Marcian0
Posts: 70
Nutzer
Zitat:
Original von fazonga:

und du musst (!) 2 CF-Karten drinne habe und auch lassen.
Dann sollte der Adapter erkannt werden und die HD-Toolbox auch
mitspielen.


In meinem A1200 funktioniert ein Dual-Adapter am internen IDE (auch kein vierfach Adapter oder sonstiges) einwandfrei mit einer einzelnen Karte.
Allerdings habe ich nicht das o.g. Modell, sondern einen 3,5" auf dem Board stecken und einen 3,5"-IDE zu Dual-CF Adapter (5 Stück 9 ¤ inkl Versand aus dem fernen Osten). Als Karte habe ich eine 4GB Sandisk Extreme III.

Keine Probleme bisher.

[ - Antworten - Zitieren - Direktlink - ]

30.10.2008, 23:47 Uhr

Maja
Posts: 15429
Nutzer
@HairFU:

Funktioniert das inzwischen?

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > CF Karte als Festplatte am Amiga 1200 - Wird nicht gefunden [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.