amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > A4000T: Uhr funktioniert nicht [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

10.05.2009, 17:27 Uhr

Mr_Blues
Posts: 347
Nutzer
Hallo
Bei meinem A4000T funktioniert leider die interne Uhr nicht.
Der Vorbesitzer hatte die alte Batterie gegen eine neue ausgetauscht, seitdem: defekt. (Ein Korrosionsschaden liegt nicht vor!)
Woran könnte das liegen?
Was könnte er beim Einsetzen der neuen Batterie kaputt gemacht haben?
Welche Alternativen gibt es? (Gibt es eine Erweiterung mit Uhr für ZorroII oder für den A4000, kann man die Uhrzeit sich über Internet holen und wenn ja, wie funktioniert das?)
Gruß
Mr_Blues

[ Dieser Beitrag wurde von Mr_Blues am 10.05.2009 um 17:28 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 17:45 Uhr

Wolfman
Posts: 3664
Nutzer
Bei meinem 4000T war seinerzeit der Akku kaputt.
Ich habe dann diesen ausgebaut und eine Batterie (Bios-Batterie) eingesetzt (irgendwo, afair an der Frontblende hat der 4000T dafür einen entsprechenden Halter, leider ist das 6 Jahre her, weshalb ich mich an die Einzelheiten nicht mehr erinnere).



--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 18:42 Uhr

tploetz
Posts: 4026
Nutzer
@Wolfman:Bei meinem Amiga 4000T funktioniert die Uhr schon über 6 Jahre nicht,
habe mich mit einer Funkuhr beholfen.
Ich weiss nicht, wie man die Batterie wechselt, möchte da nichts kaputt machen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 19:32 Uhr

Wolfman
Posts: 3664
Nutzer
@tploetz:

Ich musste da nichts auswechseln, sondern nur in den vorhandenen Halter eine Batterie einsetzen. Ob der aber bei allen 4k T vorhanden ist, weiß ich nicht mehr (meiner war von Amiga Technologies/Escom).

Den Akku habe ich sicherheitshalber ausgebaut ("Beine" abgezwickt).

Ich hatte den Amiga seinerzeit eh "offen", weil ich eine Highway und VarIO einbaute (dass er kurz danach langsam den Geist aufgab, war hoffentlich Zufall :( ).
--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 19:51 Uhr

Mr_Blues
Posts: 347
Nutzer
hmmm
danke für die antworten
nur bin ich immer noch nicht schlauer...
gibts denn gar keine alternativen zur internen uhr?

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 19:57 Uhr

Wolfman
Posts: 3664
Nutzer
@Mr_Blues:

Upps, mein Fehler - ich hatte überlesen, dass die Batterie bereits ausgetauscht wurde.

tploetz schrieb doch was von einer Funkuhr - ich kann mich dunkel erinnern, dass es da mal was für den seriellen oder Mouseport gab :dance3:
--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 20:23 Uhr

GMB
Posts: 836
Nutzer
Ich mach's kurz: http://www.g-mb.de/A4000Ttips.html#Bat

Ciao

Retrerni

:boing: :dance1:

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 20:54 Uhr

Mr_Blues
Posts: 347
Nutzer
@gmb

leider hilft das auch nicht
der Vorbesitzer hatte die alte Batterie ausgelötet und seitdem (!) tritt der Defekt auf. Und ich bin zudem auch kein Lötfan (hab ich noch nie gemacht)...
Gibt des keine ALTERNATIVEN (z.B. via Software, Internet, DENEB usw..) ??

Es handelt sich um einer der sehr seltenen A4000T von C=

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 21:09 Uhr

tploetz
Posts: 4026
Nutzer
@Mr_Blues:
Auf OS4.1 kann die Zeit über das Internet eingestellt werden. vielleicht geht das auf OS4.0 auch, oder hast du keine CSPPC? Dann geht OS4.0 nicht.
Es gibt ein Programm "netclock", vielleicht geht das.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 21:19 Uhr

whose
Posts: 2156
Nutzer
@Mr_Blues:

FACTS erledigt das von Dir gewünschte. Das kann man in WBStartup werfen und es erledigt die Synchronisation mit einem Timeserver auf Wunsch automatisch. ptbtime1.ptb.de ist "der offizielle" Timeserver in D, der steht bei der PTB in Braunschweig und ist eigentlich immer verfügbar.

Grüße


--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 21:55 Uhr

Mr_Blues
Posts: 347
Nutzer
@whose

danke, FACTS war schon sehr gut. nach x maligen probieren klappts jetzt, aber noch nicht optimal:

FACTS stürzt ab, wenn miami noch nicht gestartet ist bzw die batterie abgefragt wird...

der FACTS requester nervt und läßt sich anscheinend nicht automatisierend (nur per pull-down menü) verbergen

auch miami startet nicht völlig automatisch (miami hab ich in der wbstartup), es öffnet sich nach dem start ein workbench-requester, daß noch auf miami gewartet wird, erst ein klick auf abbrechen bewirkt einen sinnvollen fortschritt.

wie lassen sich miami und danach facts ganz automatisch im hintergrund. ohne daß irgendeine workbench oder sonstwas eingabe erforderlich ist, starten?

[ Dieser Beitrag wurde von Mr_Blues am 10.05.2009 um 21:59 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.05.2009, 22:43 Uhr

whose
Posts: 2156
Nutzer
Zitat:
Original von Mr_Blues:
@whose

danke, FACTS war schon sehr gut. nach x maligen probieren klappts jetzt, aber noch nicht optimal:

FACTS stürzt ab, wenn miami noch nicht gestartet ist bzw die batterie abgefragt wird...


Huch, ist der Bug schon wieder drin? In der vorigen Version war das eigentlich nicht mehr der Fall...

Zitat:
der FACTS requester nervt und läßt sich anscheinend nicht automatisierend (nur per pull-down menü) verbergen

Uff... ich benutze Facts seit längerem nicht mehr und habe den Rechner, auf dem es sonst installiert war, derzeit nicht zur Verfügung, daher kann ich schlecht selbst nachsehen. Das müßte in den Tooltypes "zu beheben" sein, sprich: CX_POPUP = NO dort hinzufügen (Piktogramm/Information).

Zitat:
auch miami startet nicht völlig automatisch (miami hab ich in der wbstartup), es öffnet sich nach dem start ein workbench-requester, daß noch auf miami gewartet wird, erst ein klick auf abbrechen bewirkt einen sinnvollen fortschritt.

Bei den Miami-Tooltypes DONOTWAIT hinzufügen.

Grüße


--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 00:25 Uhr

Indy
Posts: 538
Nutzer
@Mr_Blues:
Setze auch noch in den Tooltypes von FACTS den Parameter "CHECKONSTARTUP" in Klammer, d.h. deaktiviere diese Option.
Dann sollte alles nach Wunsch klappen.
So läuft es zumindest hier seit Jahren zusammen mit MiamiDX problemlos.
--
Gruß, Indy

[ Dieser Beitrag wurde von Indy am 11.05.2009 um 00:25 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 09:30 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von Mr_Blues:
@whose

danke, FACTS war schon sehr gut. nach x maligen probieren klappts jetzt, aber noch nicht optimal:

FACTS stürzt ab, wenn miami noch nicht gestartet ist bzw die batterie abgefragt wird...

der FACTS requester nervt und läßt sich anscheinend nicht automatisierend (nur per pull-down menü) verbergen


Dann nimm "NetClock". Funktioniert bei mir prima. Sowie Miami(Dx) online ist, startet NetClock und synchronisiert die interne Uhr.

Zitat:
Original von Mr_Blues:

auch miami startet nicht völlig automatisch (miami hab ich in der wbstartup), ...wie lassen sich miami ...ganz automatisch im hintergrund, ohne daß irgendeine workbench oder sonstwas eingabe erforderlich ist, starten?


Keine Ahnung - ich starte Miami immer manuell.


--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih' und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 09:32 Uhr

Mr_Blues
Posts: 347
Nutzer
@whose

danke für die Tips, genau diese haben geholfen. Ich habe noch den Tooltype QietDST gesetzt , um lästige Sekundenrequester loszuwerden und TINT=20 (da mir 300 Sekunden zu lange waren). Damit klappt alles.

@indy
checkonstartup ist anscheinend schon deaktiviert gewesen, aber auch danke!

Vielen Dank nun läuft alles wie gewünscht und auf die interne Uhr kann ich endlich verzichten.

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 13:04 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von dandy:
Zitat:
Original von Mr_Blues:
@whose


Dann nimm "NetClock". Funktioniert bei mir prima. Sowie Miami(Dx) online ist, startet NetClock und synchronisiert die interne Uhr.

Werde ich auch mal probieren, die Funkuhr dauert manchmal sehr lange.
bis das Zeitsignal da ist.
tploetz
Zitat:
Original von Mr_Blues:

auch miami startet nicht völlig automatisch (miami hab ich in der wbstartup), ...wie lassen sich miami ...ganz automatisch im hintergrund, ohne daß irgendeine workbench oder sonstwas eingabe erforderlich ist, starten?


Keine Ahnung - ich starte Miami immer manuell.

Ich starte Miami auch manuell.
tploetz

--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih' und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)


:boing: :boing: :boing: :boing: :boing: :boing: :boing:

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 17:53 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
Netclock funktioniert, geht schneller als die Funkuhr.
Aber es sind zwei Scripte für Miami dabei, welches soll man da nehmen und wo soll das
eingefügt werden? startup-sequence oder user-startup?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 18:35 Uhr

PHabermehl
Posts: 67
Nutzer
Soweit ich mich erinnern kann, kannst Du bei Miami ereignisabhängig Scripts ausführen, d.h. beim Online-gehen führt Miami das Script aus. So hab ich das mit meinem A4kD gemacht...

Gruß Peter
--
_______________
A500 + A2000/A2630 + A3000/A3640 + A4000/CSMK3 060 + CD32/SX1 und keine Zeit zum Spielen

[ - Antworten - Zitieren - Direktlink - ]

11.05.2009, 22:00 Uhr

tploetz
Posts: 4026
Nutzer
@PHabermehl:
Wie soll ich Miami automatisch anmelden, wenn netclock in der WB-Startup liegt, kann das Programm keine Zeit ermitteln. Wo sollen diese Scripte von online.miami hin kopiert werden?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 03:24 Uhr

PHabermehl
Posts: 67
Nutzer
@tploetz:

mmmh ... also, ich kann am Donnerstag mal gucken, wie ich das am A4k gemacht habe. Ich kann mich nur noch so weit erinnern, daß ich Miami von Hand starte, und in Miami ist ein Skript eingerichtet, daß dann die Uhrzeit von einem NTP-Server abfragt und die Amiga-Zeit entsprechend einstellt. Wenns am Donnerstag noch akut ist, seh ich mal nach...

Gruß
Peter
--
_______________
A500 + A2000/A2630 + A3000/A3640 + A4000/CSMK3 060 + CD32/SX1 / SX32 / FMV und keine Zeit zum Spielen

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 07:13 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von PHabermehl:
@tploetz:

...
Ich kann mich nur noch so weit erinnern, daß ich Miami von Hand starte, und in Miami ist ein Skript eingerichtet, daß dann die Uhrzeit von einem NTP-Server abfragt und die Amiga-Zeit entsprechend einstellt.
...


Genau so funktioniert das bei mir auch.
Würde gerne zu Hause nachsehen und Dir näheres dazu sagen - aber ich muss erstmal meinen A4kPPC dazu bringen, daß er wieder mit mir redet...

--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih' und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 14:18 Uhr

PHabermehl
Posts: 67
Nutzer
Zitat:
Original von tploetz:
@PHabermehl:
Wie soll ich Miami automatisch anmelden, wenn netclock in der WB-Startup liegt, kann das Programm keine Zeit ermitteln. Wo sollen diese Scripte von online.miami hin kopiert werden?
tploetz :boing:


Ach ja ... ich *glaub*, daß netclock gar nicht in die WBStartup gehört.

Also: Du startest Miami und gehst online -> miami führt das "online.miami" script aus (daß Du dann natürlich im Miami Setup einstellen mußt!) und das Script startet netclock...

Poste doch mal schnell den Inhalt des scripts ...

*EDIT*: Hab einfach mal ins AmiNet geschaut. Es ist so, wie ich es geschrieben hab, zumindest laut dem .readme zu NetClock...

Gruß
Peter
--
_______________
A500 + A2000/A2630 + A3000/A3640 + A4000/CSMK3 060 + CD32/SX1 / SX32 / FMV und keine Zeit zum Spielen

[ Dieser Beitrag wurde von PHabermehl am 12.05.2009 um 14:24 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 16:00 Uhr

tploetz
Posts: 4026
Nutzer
@PHabermehl
hier das Script für Miami, es scheint zu funktionieren.

/* Online script for Miami */

options results
options failat 21

/* Begin NetClock */
/* full output in a window opened each time NetClock is invoked */
select
when exists('REXX:NetClock.rexx') then progdir = 'REXX:'
when exists('S:NetClock.rexx') then progdir = 'S:'
when exists('NetClock.rexx') then
do
progdir = pragma('D')
if length(progdir) > 0 then
do
if (right(progdir,1) ~= ':') & (right(progdir,1) ~= '/') then progdir = progdir || '/'

end
end
otherwise progdir = ''
end
if exists(progdir || 'NetClock.rexx') then do
call open('tmp','T:MiamiNetClockShell','W')
call writeln('tmp','echo "*Ec"')
call writeln('tmp','cd "'||progdir||'"')
call writeln('tmp','rx "call NetClock.rexx V"')
call writeln('tmp','wait 8')
call writeln('tmp','endshell')
call close('tmp')
address command 'newshell "con:20/60/520/290/NetClock: synchronizing system clock.../auto/close/inactive" "T:MiamiNetClockShell"'
end
/* End NetClock */

EXIT

break_c:
halt:

EXIT 5

error:

EXIT 10
:

tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 12.05.2009 um 16:03 Uhr geändert. ]

[ Dieser Beitrag wurde von tploetz am 12.05.2009 um 17:14 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 17:32 Uhr

PHabermehl
Posts: 67
Nutzer
@tploetz:

Na dann paßts doch :-)


Alles klar jetzt?

Gruß
Peter
--
_______________
A500 + A2000/A2630 + A3000/A3640 + A4000/CSMK3 060 + CD32/SX1 / SX32 / FMV und keine Zeit zum Spielen

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 17:38 Uhr

tploetz
Posts: 4026
Nutzer
@PHabermehl:
Zu früh gefreut, war wohl Zufall, da ich das Script kopiert habe und hier im Forum eingefügt habe. Sonst wenn ich jetzt Miami starte, passiert nichts.
tploetz ;( ;(

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 19:26 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
nachdem ich Miami gestartet habe, muss ich Netclock manuell
anmelden, dann geht die Zeit, weiss nicht wofür die Scripte
für Miami da sind, wenn sie nicht funktionieren, oder ich mache was falsch.
tploetz X( X( X( X( X(

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 19:44 Uhr

PHabermehl
Posts: 67
Nutzer
@tploetz:

Was machst Du denn mit dem Script??? Wo hast Du es eingebunden?



--
_______________
A500 + A2000/A2630 + A3000/A3640 + A4000/CSMK3 060 + CD32/SX1 / SX32 / FMV und keine Zeit zum Spielen

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 19:54 Uhr

tploetz
Posts: 4026
Nutzer
@PHabermehl:
Die Scripts habe ich bei Miami Events eingetragen, funktioniert aber nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 20:19 Uhr

PHabermehl
Posts: 67
Nutzer
@tploetz:

Ok ... dann mach mal folgendes:


Starte Miami, öffne die shell und laß das miami-script von Hand ("rx ...")laufen. Dann müßte eigentlich eine Fehlermeldung kommen...

--
_______________
A500 + A2000/A2630 + A3000/A3640 + A4000/CSMK3 060 + CD32/SX1 / SX32 / FMV und keine Zeit zum Spielen

[ - Antworten - Zitieren - Direktlink - ]

12.05.2009, 22:11 Uhr

tploetz
Posts: 4026
Nutzer
@PHabermehl:
bei shell gibt es die Fehlermeldung "Datei ist nicht ausführbar, Rückgabewert 10"
tploetz

:boing:

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > A4000T: Uhr funktioniert nicht [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.