amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > MorphOS 2.4 lässt sich auf Mac Mini nicht installieren [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

22.10.2009, 18:35 Uhr

Kris
Posts: 650
Nutzer
ich habe hier ein Mac Mini G4 und eine MOS 2.4 CD. Der Mac startet jedoch nicht von der CD sondern fährt immer mit MacOS X hoch. Wie funktioniert die Installation?

Man soll ja die "C" Taste direkt nach dem Einschalten gedrückt halten. Das führt bei mir zu kein Ergebnis. Genausowenig komme ich in eine Bootmenü wenn ich die (linke) ALT Taste gedrückt halten.

Ich habe eine normale USB Maus und Tastatur vom PC angeschlossen
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 18:51 Uhr

Kronos
Posts: 1168
Nutzer
@Kris:

Nicht jede Tastatur die unter OSX funxt geht auch im OF. Da hilft nur ausprobieren.

MfG
Kronos
--
Only the good die young all the evil seem to live forever

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 18:58 Uhr

Kris
Posts: 650
Nutzer
von der OSX CD läßt sich der Rechner starten

--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 19:07 Uhr

Holger
Posts: 8042
Nutzer
Bei mir hat das funktioniert. Ich musste allerdings ziemlich lange c gedrückt halten. Ich hab das so lange gemacht, bis etwas von "Open Firmware" zu lesen war, bzw. der Schmetterling zu sehen war.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 19:30 Uhr

Kris
Posts: 650
Nutzer
habe soeben versucht über die Install CD die Festplatte zu löschen. Mit Erfolg. Leider lässt sich die CD danach aber nicht aus dem Laufwerk nehmen so dass ich gezwungen bin MacOSX erneut zu installieren. Das wird noch eine halbe Stunde dauern... :angry:
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:04 Uhr

microuser
Posts: 33
Nutzer
Hallo. Bei mir tritt das gleiche Problem auf. Es geht auch nicht wenn ich in OF boot cd: xxx eingebe. Es erscheint ein Bildschirm mit Schmetterling und am unteren Bildrand wird boote Morphos 2.4 angezeigt aber dann hängt das System. ?(

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:11 Uhr

Kris
Posts: 650
Nutzer
Das Scheissding fährt nur von der Festplatte oder von der MacOSX CD hoch. Kann wirklich an der Tastatur liegen. Allerdings habe ich keine Lust jetzt eines nach dem anderen zu kaufen nur um zu schauen obs geht oder nicht.

Will jemand das Gerät haben? Für 240 Euro inkl Versand
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:19 Uhr

microuser
Posts: 33
Nutzer
@Kris

Ruhig bleiben. Ich habe eine Original Mac Tastatur und damit gehts auch nicht.

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:36 Uhr

Goja
Posts: 277
Nutzer
Ich hatte auch eine Tastatur, die mit Morphos bzw. Poseidon nicht funktioniert.
Allerdings ist die Tastatur bei der OpenFirmware kein Problem!
Die Tastatur spielt erst eine Rolle, wenn man in Morphos irgendwelche Eingaben machen will.

> MorphOS Helpdesk / Troubleshooting for Mac mini G4 users -> http://www.morphos-team.net/faq.html
--
http://www.baud.de Amiga A4000T MC68060RC50 PPC604E@233Mhz 274Mb OS3.9 & OS4.0

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:38 Uhr

Kris
Posts: 650
Nutzer
der FAQ nutzte leider nichts. Habe alle Tastaturmöglichkeiten ausproibiert und komme nichtmal in den openFirmware der Mac.
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:46 Uhr

Goja
Posts: 277
Nutzer
Und was ist mit den anderen Möglichkeiten, die in der FAQ behandelt werden?

--
http://www.baud.de Amiga A4000T MC68060RC50 PPC604E@233Mhz 274Mb OS3.9 & OS4.0

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 20:59 Uhr

Kris
Posts: 650
Nutzer
welche anderen Möglichkeiten denn?
Keines der Befehle läßt sich nach dem Einschalten ausführen. OSX Bootet immer. Egal was ich bezwecken will. Ich sollte entweder in das Openfirmware Eingabezeile, was mir natürlich nicht gelingt. Oder in das Bootmenü mit der ALT" Taste gedrückt oder "C" mit CD Booten.

Egal wann und wie lang ich die Tasten drücke oder gedrückt halte. Lediglich OSX fährt hoch.
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 21:13 Uhr

microuser
Posts: 33
Nutzer
Ich komme auch nicht weiter. Meine OF kennt kein HFSSetMacBoot command. Was nun?

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 21:18 Uhr

Kris
Posts: 650
Nutzer
immerhin kommst du ins OF.

Mein Mac Mini funkioniert an sonsten tadellos. Mac OSX konnte ich prima und schnell installieren. Die Bedienung der Os geht auch prima sofern man sich damit auskennt. Maus und Tastatur funktionieren super. Ich will aber kein OSX weil ich OSX nicht mag und auch weder die Zeit noch die Lust darauf habe mich in diese Materie einzuarbeiten. Ich möchte MorphOS 2.4 darauf haben. Aber es scheitert eben schon im Keim, weil mein Tastatur wohl während des Bootvorgangs nicht eingebunden wird oder niht funktioniert.

An den CDs sollte es nicht liegen. Hab das ISO dreimal gebrannt auf zwei unterschiedliche Rohlinge auf zwei unterschiedlichen Geräten. Alle CDs werden von MacOS gelesen. Ohne zögern ohne Fehler
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 21:30 Uhr

microuser
Posts: 33
Nutzer
@Kris

Nur die Flint nicht so schnell ins Korn werfen.
Ich denke mal mit der kompetenten Hilfe hier werden wir auch noch Mos auf unsere Minis bekommen!

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 21:38 Uhr

Murmel
Posts: 1434
Nutzer
Ich nehme mal an Du hast keine Apple Tastatur ?

Hälst Du denn nach dem Startsound windowstaste+alt+o+f gedrückt ?

Und hier steht was man tun muss wenn die TastenKobination nicht funktioniert.

http://support.apple.com/kb/HT1379?viewlocale=de_DE&locale=de_DE

Für alle Faule. Openfirmware = Ein und Ausschalter gedrückt halten bis es erscheint.




[ Dieser Beitrag wurde von Murmel am 22.10.2009 um 22:02 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 22:35 Uhr

microuser
Posts: 33
Nutzer
Reset von PRAM und NVRAM bringen auch keine Besserung.
Der Mini bootet nicht von der MOS-CD.

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 22:59 Uhr

Murmel
Posts: 1434
Nutzer
Zitat:
Original von microuser:
Reset von PRAM und NVRAM bringen auch keine Besserung.
Der Mini bootet nicht von der MOS-CD.


Hast Du es mal durch eingeben des Befehls in der OF versucht ?

http://www.osnews.com/story/22337/The_Amazing_MorphOS_2_4_G4_Mac_Testing_Effort_


[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 23:30 Uhr

microuser
Posts: 33
Nutzer
Das hab ich auch versucht. eEs wird kurz auf CD zugegriffen und dann kommt wie schon weiter oben beschrieben schwarzer Screen mit blauem Schmetterling und unten Loading MOS 2.4 ...

Dann gehts nicht weiter?

Mir würde auch mal ne Erklärung reichen wie oder was es mit dem HFSSetMacBoot command auf sich hat und wo oder wie ich das anwenden muss.

[ Dieser Beitrag wurde von microuser am 22.10.2009 um 23:39 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 23:39 Uhr

Murmel
Posts: 1434
Nutzer
Hast Du eine OSX-CD und bootet die ? Wenn ja würde ich versuchen die MorphOS-CD nochmal zu brennen vieleicht ist ja was schiefgegangen. Sonst bleibt wohl nur noch eine Mail an den Support über.

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 23:49 Uhr

microuser
Posts: 33
Nutzer
OSX-CDs booten problemlos.
Ich werde das Install-Iso nochmal neu runterladen und brennen. Und dann werden wir sehen obs was bringt.

[ - Antworten - Zitieren - Direktlink - ]

22.10.2009, 23:55 Uhr

Murmel
Posts: 1434
Nutzer
Achja und ich würde mal alle USB-Geräte (Tastatur, Maus)abstecken beim booten. Den Effekt macht bei mir nen USB-Stick, und es dauert dann sicher ca. 5 Minuten bis er weiterbootet. Sobald man den rauszieht geht es sofort weiter.


[ Dieser Beitrag wurde von Murmel am 22.10.2009 um 23:57 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 00:06 Uhr

microuser
Posts: 33
Nutzer
Sodann melde ich mich mit einer Erfolgsmeldung.
Es war so einfach. Man darf den Mini nicht mit einem DVI -> VGA Adapter betreiben.
Mini direkt mit DVI Kabel an den Monitor anschließen und es funktioniert auf einmal mit der Installation.

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 00:08 Uhr

Murmel
Posts: 1434
Nutzer
>Mir würde auch mal ne Erklärung reichen wie oder was es mit dem >HFSSetMacBoot command auf sich hat und wo oder wie ich das anwenden >muss.

Hm anscheinend kann man damit Files als bootbar deklarieren, leider habe ich keine Ahnung von dem Befehl.

Ich wüsste nur nicht was Dir das helfen sollte, solange das System nicht von CD bootet.

Edit.

Super das es nun geht :)




[ Dieser Beitrag wurde von Murmel am 23.10.2009 um 00:11 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 10:56 Uhr

Holger
Posts: 8042
Nutzer
Zitat:
Original von Kris:
habe soeben versucht über die Install CD die Festplatte zu löschen. Mit Erfolg. Leider lässt sich die CD danach aber nicht aus dem Laufwerk nehmen so dass ich gezwungen bin MacOSX erneut zu installieren. Das wird noch eine halbe Stunde dauern... :angry:

Laut Apple hättest Du nur den Mausknopf beim Einschalten gedrückt halten müssen. Hattest Du keine Möglichkeit zum Googlen?
Zitat:
Original von microuser:
Es war so einfach. Man darf den Mini nicht mit einem DVI -> VGA Adapter betreiben.
Mini direkt mit DVI Kabel an den Monitor anschließen und es funktioniert auf einmal mit der Installation.

Kurios. Bei mir ist Direktanschluss der sicherste Weg, kein Bild zu bekommen. Mit VGA-Kabel sehen ich zumindest etwas, wenn auch mehr schlecht als recht...

@Kris:
Das mag jetzt vielleicht etwas blöd klingen. Aber wenn Mac OS X problemlos läuft, aber nicht mal Open Firmware vorhanden zu sein scheint...hast Du mal in Mac OS X nachgeschaut, ob das wirklich ein G4-Mac und kein Intel Mac ist? :nuke:


--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 11:06 Uhr

Kris
Posts: 650
Nutzer
@Holger:

es ist ein G4 Mac mit 1,25GHz
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 11:39 Uhr

[ujb]
Posts: 422
Nutzer
@Kris:
Was für eine Tastatur hast du denn? Auch sollte die Tastatur nicht hinter einem Hub hängen. Ich kann wowohl mit meienr Apple-Alutatstatur als auch meiner Keysonic (ACK-3400U) auf die Firmare zugreifen.

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 11:55 Uhr

Kris
Posts: 650
Nutzer
es ist eine ganz normale USB Tastatur mit Multimediatasten von Wintech. hab bei Atelco gekauft. Genau so die Maus
--
SAM440ep-Flex 733Mhz 512MB RAM|250GB HDD|Radeon 9250|AmigaOS 4.1
A1200|KS3.1|1230/40|2GB CF-HDD|32MB RAM|882FPU|AmigaOS 3.9
Intel Atom 330 dualcore|4GB RAM|320GB HDD| XP Pro|WinUAE

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 15:27 Uhr

geit
Posts: 332
[Ex-Mitglied]
@microuser:

Das Kommando gibt es für MorphOS nicht für die OF. In die OF muß man gar nicht rein, um MorphOS zu installieren.

@kris

es liegt an der Tastatur. Die geht in der OF nicht. Das OSX von der CD bootet ist logisch. Das macht MorphOS auch, wenn es installiert ist auch ohne Tastatur.

Geit

[ - Antworten - Zitieren - Direktlink - ]

23.10.2009, 17:31 Uhr

microuser
Posts: 33
Nutzer
Es lag nicht nur am VGA Kabel. Irgentetwas mit meinem ersten Image war anscheinend auch nicht in Ordnung. Das zweite was ich jetzt erstellt habe und welches auch perfekt funktioniert ist ca 164 MB Groß. Bei dem ersten Image mit Install Problemen waren es nur ca. 154 MB.

Aber jetzt funktioniert alles besten!
Danke noch mal an Alle für die Hilfe!

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > MorphOS 2.4 lässt sich auf Mac Mini nicht installieren [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.