amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Fat95 und SAM [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- 3 4 5 [ - Beitrag schreiben - ]

04.12.2009, 17:50 Uhr

Flash
Posts: 249
Nutzer
@thomas:

Was ist den mit Ihnen los?
Frustmensch?

Mich so anzufahren obwohl ich in keinster weise provokant war oder
bin, was soll das?

Aber Sie führen mir wieder vor Augen warum ich so selten hier im
Forum bin! X(

[ - Antworten - Zitieren - Direktlink - ]

04.12.2009, 18:28 Uhr

Lippi
Posts: 1247
Nutzer
Zitat:
Original von thomas:
... Weißt du noch, was du alles gemacht hat, damit es funktionierte ? "Einfach so" geht es jedenfalls nicht.
Hast du Vista 32 oder 64 Bit ? Welche Edition ? Irgendwas in der Registry geändert ? Benutzer mit Passwort oder ohne ? Und am Amiga ? Spezielle User eingerichtet ? Mit Passwort oder ohne ?


Also ich hatte eine der ganz frühen Vista-Versionen, 32bit, obwohl Athlet64 hier werkelt :-)
Admin-Password und das musste ich auf dem Amiga eingeben, um zugreifen zu können.
Funktionierte nicht so einfach, wie unter XP mit "einfacher Dateifreigabe" - aber das sollte man ja eigendlich eh nicht machen :-)

Merkwürdigerweise geht das jetzt unter Ubuntu genauso: Beim Amiga das Passwort eingeben und schon kann ich das "Öffentlich" Verzeichnis auf dem Amiga mounten, mit RW-Rechten, wenn ich das in Ubuntu so einstelle.
Dann gibts im Hause noch meine Tochter mit ihrem XP Pro SP3. Da geht es in alle Richtungen ebenso.

Aber nur als Beispiel, wie vielfältig Vista ist:
Auf Arbeit habe ich ständig mit Kundenrechnern zu tun und immer dieselben Modems dran (WLAN - Kabelmodems).
JEDER Vista-Rechner verhält sich irgendwie anders :-)
Manche mögen WEP nicht, andere wieder WPA2 - manchmal könnte ich reinpochen :-)
Solchen Trödel gibt es bei XP/2000ern nicht. Höchstens mit WPA2 unter SP2 abwärts.
--
Oh Gott, bin ich froh, dass ich weg vom Fenster bin ! - AmigaOS3.9 + 4.0 / Ubuntu 9.10
mfg - lippi --- Mario Lippert
Infokanal-tv.de     infokanal@t-online.de

[ - Antworten - Zitieren - Direktlink - ]

04.12.2009, 18:32 Uhr

Lippi
Posts: 1247
Nutzer
Zitat:
Was ist den mit Ihnen los?
Frustmensch?
Mich so anzufahren obwohl ich in keinster weise provokant war oder
bin, was soll das?
Aber Sie führen mir wieder vor Augen warum ich so selten hier im
Forum bin! X(


Du (Sie ?), ich glaube, dass das ein Missverständnis war. Ich hatte erst auch gedacht, die Antwort war jemandem anderes zugedacht.
--
Oh Gott, bin ich froh, dass ich weg vom Fenster bin ! - AmigaOS3.9 + 4.0 / Ubuntu 9.10
mfg - lippi --- Mario Lippert
Infokanal-tv.de     infokanal@t-online.de

[ - Antworten - Zitieren - Direktlink - ]

04.12.2009, 18:52 Uhr

Flash
Posts: 249
Nutzer
@Lippi:

Ich weiß nicht ob Thomas Rapp jemand anderen antworten
wollte wenn er mich zitiert.

Zitat Thomas Rapp:

"Mit XP funktioniert das ja auch, aber nicht mit Vista. Wenn du auf Vista oder Windows7 umgestellt hast, dann kannst du wieder kommen und laut tönen. Jetzt solltest du still sein, wenn du nichts konstruktives beitragen kannst."

Er schreibt ich würde "laut tönen" ? Und ich soll still sein!

Ich finde solange man nich persöhnlich und beleidigend wird
kann man auch "nicht konstruktive Beiträge" schreiben.

Und mein Beitrag sollte nur zeigen das es hier mit XP und µ-A1 läuft.

[ Dieser Beitrag wurde von Flash am 04.12.2009 um 20:40 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

05.12.2009, 20:08 Uhr

whose
Posts: 2156
Nutzer
Zitat:
Original von Flash:
@Lippi:

Ich weiß nicht ob Thomas Rapp jemand anderen antworten
wollte wenn er mich zitiert.

Zitat Thomas Rapp:

"Mit XP funktioniert das ja auch, aber nicht mit Vista. Wenn du auf Vista oder Windows7 umgestellt hast, dann kannst du wieder kommen und laut tönen. Jetzt solltest du still sein, wenn du nichts konstruktives beitragen kannst."

Er schreibt ich würde "laut tönen" ? Und ich soll still sein!

Ich finde solange man nich persöhnlich und beleidigend wird
kann man auch "nicht konstruktive Beiträge" schreiben.

Und mein Beitrag sollte nur zeigen das es hier mit XP und µ-A1 läuft.


Vorbemerkung: Zur Sache kann ich wenig beitragen, denn das wesentliche ist bereits gesagt. Bevor das zwischen Flash und thomas aber in eine Diskussion um persönliche Befindlichkeiten ausartet, möchte ich ein wenig helfen.


Eventuell solltest Du das noch einmal unter einem anderen Licht betrachten und möglichst an die Sache rangehen, ohne die Worte auf Deine Person bezogen zu bewerten.

Was thomas schrieb, hat nämlich, abgesehen von der leicht unpassenden Wortwahl, Hand und Fuß.

Dein Beitrag war, unter Einbeziehung des bisher geschriebenen, extrem überflüssig. Daß die Geschichte unter XP funktioniert, ist bekannt. Es ist aber auch bekannt, daß es unter Vista nicht so "einfach" funktioniert.

Da hilft es natürlich ziemlich wenig, wenn jemand in die Diskussion platzt und verkündet, daß das "so einfach" geht, ohne zu schreiben, wie und auf welchem System.

Erstens ist tploetz damit nicht geholfen, denn wirklich weiter kommt er mit dieser "Uninformation" nicht, und den anderen ist auch nicht geholfen, da Du mit Deinem Beitrag die Verwirrung beim Fragenden mit ziemlicher Sicherheit nochmal erhöht hast.

tploetz hat bisher wohl noch nicht so ganz begriffen, daß für eine Verbindung via Samba das Dateisystem einer Partition so ziemlich gar keine Rolle spielt. Ich denke, in den nächsten Tagen geht ihm das auf. Und da es jetzt jemanden im Thread gab, der das unter Vista zum Laufen bekommen hat, kann es sich nur noch um ein paar weitere Tage handeln, bis tploetz sein Samba am werkeln hat.

Und ich denke, daß thomas da auch noch ein bißchen weiterhelfen kann, sofern man ihn läßt, und nicht mit recht überflüssigen Kommentaren seine ohnehin etwas angegriffenen Nerven strapaziert.

Also: Locker bleiben und die Goldwaage in Omas Schrank lassen :)

Grüße

--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233

[ - Antworten - Zitieren - Direktlink - ]

05.12.2009, 20:38 Uhr

Thore
Posts: 2266
Nutzer
@tploetz
Samba benutzt ein Protokoll zur Übertragung von Dateiinformationen und Daten, welches einem einheitlichen Standard entspricht (etwas vergleichbar wie ftp oder ähnliches), sofern die Versionen untereinander kompatibel sind, daher auch der Konflikt mit Vista im heterogenen Netzwerk.
Das darunterliegende Dateisystem spielt dafür keine Rolle, solange die Daten von Samba im Samba-Konformen Protokoll weitergereicht wird.
Diese Daten sehen im Schema auf jedem Betriebssystem und Dateisystem gleich aus (abgesehen von Unterschieden bei inkompatiblen Versionen).

Schau mal auf der Seite
http://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/install.html

wie man ein einfaches smb.conf erstellt.
Deine war ja noch zweimal mit weiteren configs verknüpft....
Mach am besten ein backup von deinen configs und schreib sie von Hand komplett neu anhand obiger Anleitung.

Möglicherweise hilft es auch in Vista entsprechende Registry Schlüssel zu setzen (hilft leider nicht immer)
http://www.radeldudel.de/blog/0612/WindowsVistaZugriffSambaSMBFreigaben.html

[ - Antworten - Zitieren - Direktlink - ]

05.12.2009, 22:53 Uhr

tploetz
Posts: 4026
Nutzer
@Thore:
Also, ich verstehe jetzt gar nichts mehr, in einem anderen Thread
hatte ich das Samba-Problem angesprochen. Da wurde mir erklärt,
das Windows die Amiga-Laufwerke nicht öffnen kann, da Windows Vista
das Datei-System nicht lesen kann und jetzt soll das Datei-System
keine Rolle spielen?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

05.12.2009, 23:20 Uhr

Thore
Posts: 2266
Nutzer
@tploetz
Vista hat mit Samba nicht nur bei Amigas Probleme sondern auch mit Linux und anderen. Schuld ist nicht das Dateisystem, sondern das Samba, das bei Vista mitgeliefert wird. Das ist schlicht und ergreifend inkompatibel, da M$ wieder mal einen "Standard" am RFC vorbei-kreiert....
Entweder hat der im anderen Thread sich geirrt, oder hat sich ungeschickt ausgedrückt.
Wie die Laufwerke und Flags übermittelt werden (Protection-Bits etc) ist Sache von dem jeweils installierten Samba und nicht direkt vom Dateisystem. Möglich daß bei zu langen Dateinamen oder nicht-spezifischen Flags das eingesetzte Samba entweder nicht richtig tut oder entsprechende Regelungen hat.

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 12:30 Uhr

gerograph
Posts: 621
Nutzer
In einem anderen Thread hatte ich ja mal ein paar links und meine config geposted. Generell gilt für Samba:

1. Ist Samba auf dem Amiga eingerichtet, kann man Verzeichnisse auf dem Amiga freigeben um von XP oder Linux, AOS drauf zuzugreifen. Was für ein Dateisystem die zug. Platte hat, ist völlig egal. Umgekehrt kann man auch freigegebene XP Verzeichniss auf dem Amiga mounten (auch unabhängig vom Dateisystem)

2. Alle Rechner sollten mit einer festen IP laufen.

3. Ist alles richtig eingerichtet, dann ist WinUAE etc. NICHT nötig, die Amigaverzeichnisse oder Laufwerke sind in der "Netzwerkumgebung" von WinXP zu finden. Man kann Sie über "Netzlaufwerk verbinden..." unter XP mounten, was dann zu ein erheblicher Geschwindigkeitsvorteil ist.

O.k. hier die Einschränkungen/bzw. Ideen wo der Fehler bei tploetz liegt:

1. Vista scheint generell ein Problem mit Samba zu haben (s.o.)

2. WinUAE kann anscheinend auf die Amiga OS4 Verzeichnisse zugreifen, Vista aber nicht, das ist sehr komisch.... spricht für mich ehr nach einem Bedienfehler bei Vista.

3. Unter WinUAE kann jedes beliebige Verzeichnis als Festplatte einbinden, als auch freigegebene Verzeichnisse vom OS4 (sog. Samba Shares). Auch hier ist das Dateisystem egal. Anders mag es sein, wenn ich eine komplette Amigafestplatte unter WinUAE einbinde (also NICHT als Verzeichnis) ob das geht weiß ich garnicht, mein altes WinUAE kann nur Verzeichnisse oder Hardfiles als UAE Platte nutzen.

4.Außerdem hat tploetz eine FritzBOX, die ein bisserl speziell ist. Wenn ich micht recht erinnere hatte tploetz dort eine USB Wechselplatte dran, die er ebenfalls einbinden wollte.

5. Damals schlug ich vor mit ftp zu arbeiten, was aber aus irgendeinem Grund nicht funktionierte, hier war anscheinend die FritzBOX "schuld".

6. Auf Amigans.net läuft es zumindest unter Win7, ich hab bisher noch von keiner Lauffähigkeit unter Win Vista gehört (auch in den englischsprachigen foren...). Ausnahme anscheinend hier.

MEIN BAUCHGEFÜHL SAGT MIR, ERSTEINMAL DIE EINSTELLUNGEN DER FRITZBOX PRÜFEN (WAS NATÜRLICH SCHWIERIG IST)

Ansonsten mal Samba komplett neu aufsetzen und den Router außen vor lassen (d.h. Netzwerkbuchse SAM und PC verbinden).

Ansonsten wäre es generell wichtig für tploetz jedes noch so kleinste Detail mitzuteilen dann fällt uns die Hilfe leichter.

Ein guter Anlaufpunkt für Samba ist der Idiots Guide....

http://homepages.tesco.net/michael.carrillo/amigasamba/

Allerdings auf Englisch, notfall würde ich es übersetzten...

Fakt ist (hilft aber nicht unbedingt weiter) ich habe es hier unter Os3.9/Genesis OS4.1 SAM (roadshow) und XP SP2 kabelgebunden laufen. Dazwischen ein Arcor/Zyxel DSL (Wlan) Router.

Gruß Gerograph

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 14:06 Uhr

tploetz
Posts: 4026
Nutzer
@gerograph:
Die Fritz-Box ist auch schwierig einzustellen, habe sie duch Änderungen
bei den Netzwerkeinstellungen komplett aus Vista rausgeworfen, hatte kein Zugriff mehr. Durch ein Telefonat mit 1 und 1 Internet AG habe
ich die Fritz-Box wieder zum laufen bekommen.
Vista erkennt auch die FAT-Partition auf dem SAM nicht, daher liegt
es nicht an dem Dateisystem. FtpMount funktioniert vom SAM her, bei
der Fritz-Box darf nicht der USB-Fernanschluss aktiviert sein.
Die Probleme mit dem Netzwerk können auch mit der Fritz-Box zusammenhängen. Von WinUAE kann ich auf die FAT-Partition des SAM
Daten kopieren, auf SFS geht es nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 16:04 Uhr

tploetz
Posts: 4026
Nutzer
hier ist das log-file von Samba, wenn ich vom PC die Amiga-Laufwerke öffnen will.


2009/12/06 12:59:10, 0] smbd/service.c:(252)
thomas-pc (192.168.178.23) couldn't find service
[2009/12/06 12:59:10, 0] smbd/service.c:(252)
thomas-pc (192.168.178.23) couldn't find service
[2009/12/06 12:59:16, 0] rpc_client/cli_pipe.c:(1202)
cli_nt_session_open: cli_nt_create failed on pipe \spoolss to machine Thomas-PC. Error was NT_STATUS_ACCESS_DENIED
[2009/12/06 12:59:16, 0] rpc_client/cli_spoolss_notify.c:(144)
connect_to_client: unable to open the domain client session to machine Thomas-PC. Error was : NT_STATUS_ACCESS_DENIED.
tploetz
:boing:

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 17:09 Uhr

gerograph
Posts: 621
Nutzer
@tploetz:

Mit dem Samba log kann ich nicht viel Anfangen, bin leider nicht so der Samba Experte, die letzten Zeilen lassen auf ein Berechtigungsproblem schließen.... d.h.:

1. Wenn mein SAM wieder aus der Reperatur zurück ist poste ich hier mal die Befehlzeile, wie ich meine SAM Ordner freigebe...

code:
hier ist das log-file von Samba, wenn ich vom PC die Amiga-Laufwerke öffnen will.


2. D.h. Du kannst die freigegebenen Laufwerke unter Windows zumindest schonmal sehen, richtig ? Ich binde ich die freigegebenen SAM Laufwerke (Samba Freigaben) immer direkt mit der IP des SAMs ein, und nicht mit "thomas-pc" also dem Namen, was man auch wie folgt von der DOS Shell von Windows machen kann:

if not exist S:\ net use S: \\192.168.1.160\MP3 /persistent:no >Nul

code:
Von WinUAE kann ich auf die FAT-Partition des SAM  Daten kopieren, auf SFS geht es nicht."


Hm, das ist sehr komisch, warum das so ist kann ich nicht sagen. Wie sieht es denn mit FFS Partitionen aus (d.h. von WinUAE auf SAM FFS Partitionen zugreifen.)

Nach meiner Logik müsste jede Samba Freigabe die ich von WinUAE lesen/schreiben kann auch unter dem Hostbetriebssystem (bei dir Vista) erreichbar sein. Sehr komisch, vielleicht hilft jemanden Anders dieser Punkt bei der Fehleranalyse weiter ???????????

Ich hab Dich aber richtig verstanden, dass Du auf dem Vista von dem Du auf den SAM zugreifen willst auch WinUAE laufen hast mit dem Du komischerweise auf SAM Partitionen (solange sie nicht SFS sind) zugreifen kannst ??? Ja oder Nein ?

Ok, gib mal
net use S: \\192.168.1.160\MP3 /persistent:no
in eine Windows DOS Shell ein und poste das Ergebnis. Aber Achtung bitte IP von DEINEM SAM und Name der DEINER Freigabe nutzen.

Gruß gerograph










[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 17:11 Uhr

gerograph
Posts: 621
Nutzer
@tploetz:

Mit dem Samba log kann ich nicht viel Anfangen, bin leider nicht so der Samba Experte, die letzten Zeilen lassen auf ein Berechtigungsproblem schließen.... d.h.:

1. Wenn mein SAM wieder aus der Reperatur zurück ist poste ich hier mal die Befehlzeile, wie ich meine SAM Ordner freigebe...

code:
hier ist das log-file von Samba, wenn ich vom PC die Amiga-Laufwerke öffnen will.


2. D.h. Du kannst die freigegebenen Laufwerke unter Windows zumindest schonmal sehen, richtig ? Ich binde ich die freigegebenen SAM Laufwerke (Samba Freigaben) immer direkt mit der IP des SAMs ein, und nicht mit "thomas-pc" also dem Namen, was man auch wie folgt von der DOS Shell von Windows machen kann:

if not exist S:\ net use S: \\192.168.1.160\MP3 /persistent:no >Nul

code:
Von WinUAE kann ich auf die FAT-Partition des SAM  Daten kopieren, auf SFS geht es nicht."


Hm, das ist sehr komisch, warum das so ist kann ich nicht sagen. Wie sieht es denn mit FFS Partitionen aus (d.h. von WinUAE auf SAM FFS Partitionen zugreifen.)

Nach meiner Logik müsste jede Samba Freigabe die ich von WinUAE lesen/schreiben kann auch unter dem Hostbetriebssystem (bei dir Vista) erreichbar sein. Sehr komisch, vielleicht hilft jemanden Anders dieser Punkt bei der Fehleranalyse weiter ???????????

Ich hab Dich aber richtig verstanden, dass Du auf dem Vista von dem Du auf den SAM zugreifen willst auch WinUAE laufen hast mit dem Du komischerweise auf SAM Partitionen (solange sie nicht SFS sind) zugreifen kannst ??? Ja oder Nein ?

Ok, gib mal
net use S: \\192.168.1.160\MP3 /persistent:no
in eine Windows DOS Shell ein und poste das Ergebnis. Aber Achtung bitte IP von DEINEM SAM und Name der DEINER Freigabe nutzen.

Gruß gerograph










[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 17:35 Uhr

gerograph
Posts: 621
Nutzer
@tploetz:

Mit dem Samba log kann ich nicht viel Anfangen, bin leider nicht so der Samba Experte, die letzten Zeilen lassen auf ein Berechtigungsproblem schließen.... d.h.:

1. Wenn mein SAM wieder aus der Reperatur zurück ist poste ich hier mal die Befehlzeile, wie ich meine SAM Ordner freigebe...

code:
hier ist das log-file von Samba, wenn ich vom PC die Amiga-Laufwerke öffnen will.


2. D.h. Du kannst die freigegebenen Laufwerke unter Windows zumindest schonmal sehen, richtig ? Ich binde ich die freigegebenen SAM Laufwerke (Samba Freigaben) immer direkt mit der IP des SAMs ein, und nicht mit "thomas-pc" also dem Namen, was man auch wie folgt von der DOS Shell von Windows machen kann:

if not exist S:\ net use S: \\192.168.1.160\MP3 /persistent:no >Nul

code:
Von WinUAE kann ich auf die FAT-Partition des SAM  Daten kopieren, auf SFS geht es nicht."


Hm, das ist sehr komisch, warum das so ist kann ich nicht sagen. Wie sieht es denn mit FFS Partitionen aus (d.h. von WinUAE auf SAM FFS Partitionen zugreifen.)

Nach meiner Logik müsste jede Samba Freigabe die ich von WinUAE lesen/schreiben kann auch unter dem Hostbetriebssystem (bei dir Vista) erreichbar sein. Sehr komisch, vielleicht hilft jemanden Anders dieser Punkt bei der Fehleranalyse weiter ???????????

Ich hab Dich aber richtig verstanden, dass Du auf dem Vista von dem Du auf den SAM zugreifen willst auch WinUAE laufen hast mit dem Du komischerweise auf SAM Partitionen (solange sie nicht SFS sind) zugreifen kannst ??? Ja oder Nein ?

Ok, gib mal
net use S: \\192.168.1.160\MP3 /persistent:no
in eine Windows DOS Shell ein und poste das Ergebnis. Aber Achtung bitte IP von DEINEM SAM und Name der DEINER Freigabe nutzen.

Gruß gerograph










[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 17:39 Uhr

gerograph
Posts: 621
Nutzer
@tploetz:

Mit dem Samba log kann ich nicht viel Anfangen, bin leider nicht so der Samba Experte, die letzten Zeilen lassen auf ein Berechtigungsproblem schließen.... d.h.:

1. Wenn mein SAM wieder aus der Reperatur zurück ist poste ich hier mal die Befehlzeile, wie ich meine SAM Ordner freigebe...

code:
hier ist das log-file von Samba, wenn ich vom PC die Amiga-Laufwerke öffnen will.


2. D.h. Du kannst die freigegebenen Laufwerke unter Windows zumindest schonmal sehen, richtig ? Ich binde ich die freigegebenen SAM Laufwerke (Samba Freigaben) immer direkt mit der IP des SAMs ein, und nicht mit "thomas-pc" also dem Namen, was man auch wie folgt von der DOS Shell von Windows machen kann:

if not exist S:\ net use S: \\192.168.1.160\MP3 /persistent:no >Nul

code:
Von WinUAE kann ich auf die FAT-Partition des SAM  Daten kopieren, auf SFS geht es nicht."


Hm, das ist sehr komisch, warum das so ist kann ich nicht sagen. Wie sieht es denn mit FFS Partitionen aus (d.h. von WinUAE auf SAM FFS Partitionen zugreifen.)

Nach meiner Logik müsste jede Samba Freigabe die ich von WinUAE lesen/schreiben kann auch unter dem Hostbetriebssystem (bei dir Vista) erreichbar sein. Sehr komisch, vielleicht hilft jemanden Anders dieser Punkt bei der Fehleranalyse weiter ???????????

Ich hab Dich aber richtig verstanden, dass Du auf dem Vista von dem Du auf den SAM zugreifen willst auch WinUAE laufen hast mit dem Du komischerweise auf SAM Partitionen (solange sie nicht SFS sind) zugreifen kannst ??? Ja oder Nein ?

Ok, gib mal
net use S: \\192.168.1.160\MP3 /persistent:no
in eine Windows DOS Shell ein und poste das Ergebnis. Aber Achtung bitte IP von DEINEM SAM und Name der DEINER Freigabe nutzen.

Gruß gerograph










[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 18:34 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von gerograph:
@tploetz:


Ok, gib mal
net use S: \\192.168.1.160\MP3 /persistent:no
in eine Windows DOS Shell ein und poste das Ergebnis. Aber Achtung bitte IP von DEINEM SAM und Name der DEINER Freigabe nutzen.

Gruß gerograph

Ergebnis:
"Systemfehler 67 aufgetreten
Der Netzwerkname wurde nicht gefunden"

Die Amiga-Partitionen sind unter Windows zu sehen.

Auf SFS-Partition kann ich mit WinUAE nur lesen, aber kopieren geht nur von
der Amiga-Partition, nach SAM kopieren geht nicht, funktioniert nur mit FAT95

tploetz






[/quote]

:boing:

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 18:46 Uhr

gerograph
Posts: 621
Nutzer
@tploetz:

1. Welche IP hat Dein SAM und kannst Du Ihn anpingen ?

Zitat:
Die Amiga-Partitionen sind unter Windows zu sehen.

2. Was für eine Meldung bekommst Du, wenn Du unter Win versuchst eine sichtbare Amigapartition zu öffnen ? Was für eine Meldung bekommst Du wenn Du dann etwas darüber kopierst (unter Vista ) ?

Leider habe ich kein Vista, deswegen muss ich hier etwas im dunklen stochern, aber zumindest kann ich schonmal einige Infos rauskitzeln ;-)

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 18:55 Uhr

Lippi
Posts: 1247
Nutzer
@tploetz:
Ich glaube langsam, dass Du etwas nicht verstehst.
Oder wir reden hier alle aneinander vorbei.
--
Oh Gott, bin ich froh, dass ich weg vom Fenster bin ! - AmigaOS3.9 + 4.0 / Ubuntu 9.10
mfg - lippi --- Mario Lippert
Infokanal-tv.de     infokanal@t-online.de

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 19:12 Uhr

gerograph
Posts: 621
Nutzer
@Lippi:
Ja gut, wahrscheinlich versteht tploetz was nicht, aber dennoch wäre interessant zu wissen, warum tploetz von

WinUAE auf den SAM zugreifen kann (zumindest bei FAT95), das Hostbetriebsystem (Vista) auf dem UAE läuft aber nicht ?

Das obige Problem ist ersteinmal FAKT.
Erst wenn diese Frage geklärt ist, macht es meiner Meinung nach Sinn über die Dateisysteme zu reden (was zugegebenermaßen sehr komisch ist)

@tploetz
Du hast aber nicht den AmigaExplorer von Cloanto installiert, und greifst über den zu ? Oder ?

gruß gerograph

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 19:31 Uhr

Andreas_Wolf
Posts: 2980
Nutzer
> in einem anderen Thread hatte ich das Samba-Problem angesprochen.
> Da wurde mir erklärt, das Windows die Amiga-Laufwerke nicht öffnen
> kann, da Windows Vista das Datei-System nicht lesen kann

Link auf den Thread?


> Entweder hat der im anderen Thread sich geirrt, oder hat
> sich ungeschickt ausgedrückt.

...oder tploetz hat eine korrekte und unmissverständliche Aussage (mal wieder) missverstanden ;-)

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 20:10 Uhr

Thore
Posts: 2266
Nutzer
@tploetz
Hast Du mal versucht, eine minimale smb.conf zu erstellen? Ich hatte weiter oben einen Link genannt.
Probier mal zum Beispiel sowas aus:

-- CUT HERE --

[global]
workgroup = WORKGROUP
security = share
serverstring = AmigaSambaServer
loadprinters = yes
browseable = yes
preservecase = no
guest ok = yes

[Work]
path = /Work

[Workbench]
path = /Workbench

[Work2]
path = /Work2
writeable = yes

-- CUT HERE --

Da kannst dann auch mit den Parametern rumspielen.
Mach aber ein Backup deiner vorherigen smb.conf.
Die Werte sind aus deiner vorig geposteten smb.conf übernommen, ich denk mal, das sind die Einstellungen die Du möchtest? Auf jeden Fall aber übersichtlicher wie Deine, wo noch 2 weitere Configs eingebunden werden.

[ - Antworten - Zitieren - Direktlink - ]

06.12.2009, 22:09 Uhr

tploetz
Posts: 4026
Nutzer
@Thore:
Ich habe deine Config ausprobiert, geht aber auch nicht, Windows Vista erlaubt
keinen Zugriff auf die Amiga-Partitionen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 10:25 Uhr

Flash
Posts: 249
Nutzer
@tploetz:

Ich nochmals!
Wenn ich darf?

Hier ein Auszug aus AmigaNetCenter:

3. Vista issues: Even though Vista will display your Amiga's shares, it cannot access
them. WindowsXP and Samba (Linux) work fine. The problem seems to be related to
Vista's updating of certain programs, causing them to no longer work with older
versions.

Sowie es aussieht wird das nicht funktionieren.

Hab hier auch mal versucht meinen Vista-Rechner mit meinen µ-A1 zu
verbinden.

Der Amiga wird zwar von Vista erkannt, ich bekomme auch die freigegebene
Datei angezeigt, aber kann nicht darauf zugreifen!

Beim Zugriff auf "Datei" kommt die Meldung:
"Datei" ist verfügbar, aber dem Benutzerkonto, mit dem Sie sich
angemeldet haben, wurde der Zugriff verweigert.

Ich hab auch mal im Internet nachgeschaut:
Selbst Vista-Netzwerke haben plötzlich auftretende Netzwerkfehler, in denen
einzelne Vista-Rechner nicht mehr erkannt werden.

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 13:02 Uhr

Andreas_Wolf
Posts: 2980
Nutzer
> Ein guter Anlaufpunkt für Samba ist der Idiots Guide....
> http://homepages.tesco.net/michael.carrillo/amigasamba/
> Allerdings auf Englisch, notfall würde ich es übersetzten...

Eine deutsche Übersetzung existiert bereits und war auch schon mal online:

http://www.amiga-news.de/forum/thread.php?id=28411&BoardID=1#285319
http://www.amiga-news.de/forum/thread.php?id=28411&BoardID=1#306472
http://www.amiga-news.de/forum/thread.php?id=28411&BoardID=1#306585

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 16:20 Uhr

gerograph
Posts: 621
Nutzer
@Flash
Ja korrekt steht im Amiganet Center pdf drin... aber wie kann man dann erklären, dass WinUAE dann doch auf die Laufwerke zugreifen kann. Und warum dann nur FAT95 ?

@Andreas_Wolf:
Jup, wie Du sagst, es gab mal eine Übersetzung ! Kenne ich, bin aber zu faul nach einem funktionierenden Link zu schauen. Wenns den noch irgendwo gibt. Klar, bevor ich übersetze würd ich natürlich suchen und den Autor anmailen...

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 17:27 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von Flash:
@tploetz:



Der Amiga wird zwar von Vista erkannt, ich bekomme auch die freigegebene
Datei angezeigt, aber kann nicht darauf zugreifen!

Beim Zugriff auf "Datei" kommt die Meldung:
"Datei" ist verfügbar, aber dem Benutzerkonto, mit dem Sie sich
angemeldet haben, wurde der Zugriff verweigert.


Genau diese Meldung erhalte ich auch von Vista, wenn ich auf
Amiga-Laufwerke zugreifen will.
Es gibt auch im Internet andere Foren, die sich mit Vista und Samba
beschäftigen. Leider kann ich damit nichts anfangen, denn es gibt kein
Netzwerk-Sicherheitscenter auf Vista auf meinem System.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 18:44 Uhr

Flash
Posts: 249
Nutzer
@tploetz:

Kann es daran liegen das Vista einen Benutzernamen verlagt?

Wenn ich mit meinen XP-Rechner auf den Vista-Rechner zugreifen will
muß ich mich zumindest mit dem Benutzernamen anmelden.
Das heist:

Vista als Gast ohne Paßwort am laufen.
XP als Benutzer mit Admin-rechten.

Beim ersten Zugriff von XP auf Vista verlangt Vista den Benutzernamen!
Bei jeden weiteren Zugriff wird der Benutzernamen nicht mehr verlangt.

Ich weis jetzt nicht ob von der Amigaseite aus ein Benutzer übergeben
wird oder gegeben werden kann.

Die folgende Zeile steht bei mir in der user-startup:
run >nil: samba:smbfs domain=NETZ1 user="" server=XP-RECHNER password="" volume="Netzwerk" client=AMIGAONE_0 service="//XP-RECHNER/SharedDocs"

Hiermit wird bei mir ein Ordner mit dem Namen "Netzwerk" auf der WB
angelegt und ich kann vom Amiga auf den XP-Rechner zugreifen.
Aber das ist wahrscheinlich alles soweit bekannt.

Ich wüste aber gerne wofür der "user" und das "password" gebraucht wird?

Sind das die benötigen Daten um auf einen im Netzwerk befindlichen Rechner
der mit Passwort geschützt ist zuzugreifen?

Ich habe versucht die Zeile aus der user-startup für Vista anzupassen,
mit Benutzer und Passwort, ohne Erfolg.
Auch wenn ich über AmigaNetCenter versuche ein Laufwert für den
Vista-Rechner zu mounten bekomme ich nur eine Fehlermeldung.

Was mir noch aufgefallen ist:
Ich hab hier einen Amiga, XP-Rechner und Vista-Laptop im Netz.
Wenn ich den Vista-Rechner soweit hab das er den Amiga erkennt und mir
auch den freigegebenen Ordner anzeigt bekomme ich den Vista-Rechner nicht mehr
auf den XP-Rechner angezeigt.
Die Funktion XP->Amiga bleibt aber voll erhalten.

[ Dieser Beitrag wurde von Flash am 07.12.2009 um 18:45 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 20:05 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von Flash:
@tploetz:

.

Die folgende Zeile steht bei mir in der user-startup:
run >nil: samba:smbfs domain=NETZ1 user="" server=XP-RECHNER password="" volume="Netzwerk" client=AMIGAONE_0 service="//XP-RECHNER/SharedDocs"

Hiermit wird bei mir ein Ordner mit dem Namen "Netzwerk" auf der WB
angelegt und ich kann vom Amiga auf den XP-Rechner zugreifen.
Aber das ist wahrscheinlich alles soweit bekannt.





[ Dieser Beitrag wurde von Flash am 07.12.2009 um 18:45 Uhr geändert. ]


Deine Zeilen in der user-startup habe ich leicht verändert, aber beim Start kommt diese
Fehlermeldung:

smbfs: Gefordertes Argument fehlt
volume: Unbekannter Befehl
Samba:smbfs fehlgeschlagen Rückgabewert 10
tploetz

:boing:

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 21:40 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von Flash:
@tploetz:

Kann es daran liegen das Vista einen Benutzernamen verlagt?

Nein
Zitat:
Wenn ich mit meinen XP-Rechner auf den Vista-Rechner zugreifen will
muß ich mich zumindest mit dem Benutzernamen anmelden.
Das heist:

Vista als Gast ohne Paßwort am laufen.
XP als Benutzer mit Admin-rechten.


Auch wenn ich mich als Gast bei Vista anmelde,m gibt es keinen Zugriff
auf Amiga-Laufwerke.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

07.12.2009, 22:21 Uhr

gerograph
Posts: 621
Nutzer
@Flash:
Zitat:
Ich weis jetzt nicht ob von der Amigaseite aus ein Benutzer übergeben
wird oder gegeben werden kann.


Ja muß, bei mir z.B.:

code:
;BEGIN Samba
run >nil: samba:smbfs domain=WORKGROUP user=ich server=GERICOM-LAPTOP password=blubbla volume=Gero-Laptop client=AMIGA-SAM service="//GERICOM-LAPTOP/Gero" TRANSLATE=L:FileSystem_Trans/DANSK.crossdos
;END Samba


D.h. wenn ich mich bei XP normal anmelde muß ich dies mit

"ich"
"blubbla"

machen.

domain = Arbeitsgruppe, hab ich faulerweise unter WIN nicht geändert, d.h. den MS Standart "WORKGROUP" gelassen. Meich XP Rechner heisst GERICOM-LAPTOP und meine Freigabe "Gero". TRANSLATE ist für das richtige anzeigen von ö,ä,.... verantwortlich.

[ - Antworten - Zitieren - Direktlink - ]


1 -2- 3 4 5 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Fat95 und SAM [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.