amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Fat95 und SAM [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 2 -3- 4 5 [ - Beitrag schreiben - ]

07.12.2009, 22:23 Uhr

gerograph
Posts: 621
Nutzer
Stellt sich natürlich immer noch die Frage, warum kann tploetz aufeinmal unter UAE auf die Partitionen zugreifen, wenn es auf dem Hostsystem nicht geht, glaube hier liegt der Schlüssel... ????

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 17:02 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von tploetz:
Deine Zeilen in der user-startup habe ich leicht verändert, aber beim Start kommt diese
Fehlermeldung:

smbfs: Gefordertes Argument fehlt
volume: Unbekannter Befehl
Samba:smbfs fehlgeschlagen Rückgabewert 10
tploetz

Dir ist aber schon klar, dass, wenn Flash die folgende Zeile schreibt, es sich auch nur um eine Zeile handelt, auch wenn der Browser diese umbricht?

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 18:22 Uhr

tploetz
Posts: 4026
Nutzer
@Holger:
Ich habe die Zeile als eine in die user-startup eingefügt, user-Namen geändert und Passwort, es passiert aber nichts, beim Start ein Fehler,
das smbfs nicht gefunden wird, der Fehlerhinweis verschwindet gleich
danach wieder, bisher blieb der Fehler stehen.
Edit: smbfs "unbekannter Befehl"
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 08.12.2009 um 18:40 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 18:27 Uhr

ZeroG
Posts: 1486
Nutzer
Zitat:
Original von gerograph:
Stellt sich natürlich immer noch die Frage, warum kann tploetz aufeinmal unter UAE auf die Partitionen zugreifen, wenn es auf dem Hostsystem nicht geht, glaube hier liegt der Schlüssel... ????


Damit sowas geht müsste UAE mit anderen Rechten oder unter einem anderen Benutzer laufen.

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 19:33 Uhr

tploetz
Posts: 4026
Nutzer
@ZeroG:
WinUAE läuft nicht mit anderen Benutzernamen, die Amiga-Laufwerke
werden als Netzlaufwerk mit Buchtaben wie Z oder Y angemeldet.
tploetz
:boing:

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 21:50 Uhr

gerograph
Posts: 621
Nutzer
@ZeroG:
Aber das tut es (UAE) ja nicht.... soweit ich weiß, warum sollte es ?

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 22:42 Uhr

tploetz
Posts: 4026
Nutzer
Würde sich ein Upgrade von Vista auf Windows7 lohnen, damit Samba besser läuft?
Oder läuft Samba nicht auf Windows? Weiß das jemand?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 23:05 Uhr

ZeroG
Posts: 1486
Nutzer
@gerograph:
Zitat:
warum sollte es ?
Das weißt du doch:
Programme wie UAE können nur auf Dinge zugreifen auf die das Hostsystem auch zugriff hat. Es sei den jemand startet sie mit anderen Rechten.

[ - Antworten - Zitieren - Direktlink - ]

08.12.2009, 23:06 Uhr

ZeroG
Posts: 1486
Nutzer
Zitat:
Original von tploetz:
Würde sich ein Upgrade von Vista auf Windows7 lohnen, damit Samba besser läuft?
Oder läuft Samba nicht auf Windows? Weiß das jemand?


Wenn du hier zur abwechselung mal mitlesen würdest hättst du die antwort darauf schon...

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 12:42 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von ZeroG:
Zitat:
Original von tploetz:

Wenn du hier zur abwechselung mal mitlesen würdest hättst du die antwort darauf schon...


Das ist keine klare Antwort, wenn Du mir sagen würdest wo das steht,
ich kann nicht alle Threads durchlesen.
tploetz

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 13:16 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von tploetz:
@Holger:
Ich habe die Zeile als eine in die user-startup eingefügt, user-Namen geändert und Passwort, es passiert aber nichts, beim Start ein Fehler,
das smbfs nicht gefunden wird, der Fehlerhinweis verschwindet gleich
danach wieder, bisher blieb der Fehler stehen.
Edit: smbfs "unbekannter Befehl"

Du hast schon ein wirklich merkwürdiges System.
Hier hat smbfs noch gemeldet, dass ein "Gefordertes Argument fehlt", jetzt wird smbfs gar nicht gefunden...

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 13:46 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von ZeroG:
Das weißt du doch:
Programme wie UAE können nur auf Dinge zugreifen auf die das Hostsystem auch zugriff hat. Es sei den jemand startet sie mit anderen Rechten.

Einspruch.
Die Problematik ist in diesem Fall, dass die Ressource gar nicht auf dem Hostsystem liegt. Hier versucht jemand auf die Ressource eines anderen Rechners via SMB-Protokoll zuzugreifen und benutzt einmal die in Windows eingebaute Implementierung (Hostsystem) und einmal ein Samba, das in WinUAE läuft. Beide sind dabei in ihrer Rolle als Client unterwegs.

Das ist nicht anders, als wenn ein Amiga-Browser unter WinUAE und ein Windows-Browser auf dem Hostsystem auf dieselbe Adresse zugreifen. Beide haben die gleiche Berechtigung, nämlich eine TCP/IP-Verbindung zu dem Zielsystem aufzubauen. Ob die Kommunikation mit dem Server funktioniert und was die beiden letztendlich darstellen, hat nichts mit den Berechtigungen auf dem Client zu tun.

Der Unterschied ist klar: Windows versucht, ohne zu fragen, Benutzernamen und Passwort des aktuellen Benutzers zu verwenden und ist in seiner Arbeitsweise nur über kryptische Registry-Keys konfigurierbar.
Samba dagegen verwendet genau die Parameter, die man ihm mitgibt. Und das im UAE laufende Samba hat sich beim Wechsel des Host-Systems von XP auf Vista auch nicht verändert.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 15:19 Uhr

ZeroG
Posts: 1486
Nutzer
@Holger:
Ok, aber ich habe mir jetzt nochmal das ganze Thema durchgelesen und du bist der erste der davon spricht das bei tploetz SAMBA in WinUAE läuft und der zugriff aufs SAM damit klappt.

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 15:23 Uhr

ZeroG
Posts: 1486
Nutzer
@tploetz:
Zitat:
Das ist keine klare Antwort, wenn Du mir sagen würdest wo das steht,
ich kann nicht alle Threads durchlesen.

Ich habe "Hier mitlesen" geschrieben, nicht "das Forum mitlesen" - unterschied klar?

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 15:58 Uhr

tploetz
Posts: 4026
Nutzer
[quote]
Original von Holger:
Zitat:
Original von tploetz:
@Holger:

Du hast schon ein wirklich merkwürdiges System.
Hier hat smbfs noch gemeldet, dass ein "Gefordertes Argument fehlt", jetzt wird smbfs gar nicht gefunden...

--
Good coders do not comment. What was hard to write should be hard to read too.

Ich habe kein merkwürdiges System, habe mich da vertan.

smbfs ist ein unbekannter Befehl, soll das im C-Verzeichnis stehen?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 18:49 Uhr

Lippi
Posts: 1247
Nutzer
@tploetz:
Schaue in das Zitat in Deiner Antwort hier darüber und klicke auf "Hier".
Da wirst Du sehen, dass smbfs sich entweder im Verzeichnis Samba: befindet, oder es einen Verweis darauf gibt / geben sollte.
--
Oh Gott, bin ich froh, dass ich weg vom Fenster bin ! - AmigaOS3.9 + 4.0 / Ubuntu 9.10
mfg - lippi --- Mario Lippert
Infokanal-tv.de     infokanal@t-online.de

Nachtrag: Eventuell fehlt auch der Assign auf Samba ?

[ Dieser Beitrag wurde von Lippi am 09.12.2009 um 18:51 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 20:10 Uhr

tploetz
Posts: 4026
Nutzer
@Lippi:
Hier ein Auszug aus meiner user-startup über die Zuweisung von Samba

;BEGIN AmigaNetCenter
assign samba: Work:AmigaNetCenter
path samba: add
path samba:bin add
run >nil: AmigaNBc
run >nil: samba:smbfs domain=WORKGROUP user=Thomas server=Sony-LAPTOP password=Thomas-PC volume=Sony-Laptop client=AMIGA-SAM service="//SONY-LAPTOP/Gero" TRANSLATE=L:FileSystem_Trans/DANSK.crossdos
;END AmigaNetCenter

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 20:15 Uhr

Lippi
Posts: 1247
Nutzer
@tploetz:
Dann muss smbfs in der Schublade samba liegen.
--
Oh Gott, bin ich froh, dass ich weg vom Fenster bin ! - AmigaOS3.9 + 4.0 / Ubuntu 9.10
mfg - lippi --- Mario Lippert
Infokanal-tv.de     infokanal@t-online.de

[ - Antworten - Zitieren - Direktlink - ]

09.12.2009, 22:02 Uhr

tploetz
Posts: 4026
Nutzer
@Lippi:
Ich erhalte nach dem Start immer noch einen Fehler "samba:smbfs fehlgeschlagen
Rückgabewert 10" Was ist denn in der user-startup falsch?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

10.12.2009, 19:13 Uhr

Flash
Posts: 249
Nutzer
@tploetz

Die Fehlermeldung kommt wenn er den gesuchten Rechner nicht im Netz findet.

Aber was ich noch wissen möchte!

Das UAE worauf läuft das? Auf Vista?

[ - Antworten - Zitieren - Direktlink - ]

10.12.2009, 19:53 Uhr

Flash
Posts: 249
Nutzer
Das bekomme ich von smbstatus geliefert.

Unknown parameter encountered: "masterbrowser"
Ignoring unknown parameter "masterbrowser"

Samba version 2.2.5
Service uid gid pid machine
----------------------------------------------
Daten nobody nogroup 1785019392 laptop (192.168.2.24) Thu Dec 10 19:52:43 2009
Daten nobody nogroup 1802778224 xp-keller (192.168.2.22) Thu Dec 10 19:50:38 2009

No locked files

XP = zugriff auf Amiga/Daten
Vista = Meldung:Konnte nicht zugebriffen werden.
Was sagt der Status auf dem Amiga-Samba aus?

[ - Antworten - Zitieren - Direktlink - ]

10.12.2009, 23:17 Uhr

gerograph
Posts: 621
Nutzer
@tploetz
Zitat:
Original von tploetz:

run >nil: samba:smbfs domain=WORKGROUP user=Thomas server=Sony-LAPTOP password=Thomas-PC volume=Sony-Laptop client=AMIGA-SAM service="//SONY-LAPTOP/Gero" TRANSLATE=L:FileSystem_Trans/DANSK.crossdos

tploetz :boing:


1. versuch mal bitte server=Sony-LAPTOP durch server=SONY-LAPTOP zu ersetzen... (also Großschrift) keine Ahnung, ob das relevant ist, aber probieren kann man es...

2. Du hast also auf Deinem Sony Rechner einen Ordner freigegeben. Und die Freigabe heist "Gero" ? Wie heist der Ordner und auf welcher Platte liegt der ?

Ach ja, hab ich mir schon immer gewünscht einmal im Leben als Freigabe auf einem Vista Rechner zu existieren
:D

Gruß GERO birkenfeld

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 09:29 Uhr

tploetz
Posts: 4026
Nutzer
[quote]
Original von gerograph:
@tploetz
Zitat:
Original von tploetz:





2. Du hast also auf Deinem Sony Rechner einen Ordner freigegeben. Und die Freigabe heist "Gero" ? Wie heist der Ordner und auf welcher Platte liegt der ?


:D

Gruß GERO birkenfeld


Ich habe noch keinen Ordner freigegeben und noch keinen angelegt.
tploetz

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 09:34 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von Flash:
@tploetz

Die Fehlermeldung kommt wenn er den gesuchten Rechner nicht im Netz findet.

Aber was ich noch wissen möchte!

Das UAE worauf läuft das? Auf Vista?


WinUAE läuft auf Vista
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 18:17 Uhr

gerograph
Posts: 621
Nutzer
[quote]
Original von tploetz:
Zitat:
Original von gerograph:
@tploetz
Zitat:
Original von tploetz:





2. Du hast also auf Deinem Sony Rechner einen Ordner freigegeben. Und die Freigabe heist "Gero" ? Wie heist der Ordner und auf welcher Platte liegt der ?


:D

Gruß GERO birkenfeld


Ich habe noch keinen Ordner freigegeben und noch keinen angelegt.
tploetz


Dann sind die o.g. Zeilen in der User Startup unnötig, damit bindest Du einen Windows Ordner unter SAMBA auf dem Amiga ein.

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 18:40 Uhr

tploetz
Posts: 4026
Nutzer
@gerograph:
Ich habe jetzt einen Ordner mit dem Namen "Gero" auf Laufwerk C angelegt und freigegeben, aber es ändert sich nichts, der Fehler beim Start bleibt.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 19:44 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von tploetz:
Ich habe jetzt einen Ordner mit dem Namen "Gero" auf Laufwerk C angelegt und freigegeben, aber es ändert sich nichts, der Fehler beim Start bleibt.

Bist Du Dir sicher, dass der Rechner "SONY-LAPTOP" und nicht "THOMAS-PC" heißt, wie es in Deiner Log-Datei steht?

Mal abgesehen davon, habe ich eine starke Vermutung, warum Du auf die eine Partition schreiben kannst und auf die anderen nicht.

Zitat:
Original von tploetz:
@analogkid:
Hier poste ich meine smb.conf
...

[Work]
path="/Work"
[Workbench]
path="/Workbench"
[Work2]
path="/Work2"
writeable=yes
include = /env/smb_global.conf

wins support = yes
...


Laß mich raten ... Work2 ist Deine FAT-Partition?

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 20:01 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von ZeroG:
@Holger:
Ok, aber ich habe mir jetzt nochmal das ganze Thema durchgelesen und du bist der erste der davon spricht das bei tploetz SAMBA in WinUAE läuft und der zugriff aufs SAM damit klappt.

Hat aber auch niemand gesagt, dass es anders wäre. Ich hoffe, Du erwartest nicht wirklich von jemanden, der versucht auf ein Verzeichnis zuzugreifen, dass er "noch nicht angelegt hat", diesbezüglich eine klare Aussage. Aber Du kannst gerne eine Gegentheorie aufstellen, warum es unter WinUAE funktioniert.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 20:29 Uhr

ZeroG
Posts: 1486
Nutzer
@Holger:
Ich halt mich jetzt hier raus bis tploetz seine Fragen vernümpftig formuliert und eine brauchbare Beschreibung des Ist-Zustandes liefert.

[ - Antworten - Zitieren - Direktlink - ]

11.12.2009, 21:34 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von Holger:
Zitat:
Original von tploetz:
@analogkid:
Hier poste ich meine smb.conf
...


Laß mich raten ... Work2 ist Deine FAT-Partition?

--
Good coders do not comment. What was hard to write should be hard to read too.

Richtig geraten, Work2 ist die FAT-Partition

[ - Antworten - Zitieren - Direktlink - ]


1 2 -3- 4 5 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Fat95 und SAM [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.