amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Andere Systeme > Retro Classix auf Windows7 [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- [ - Beitrag schreiben - ]

12.01.2010, 18:07 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Die Konfig von WinUAE im RetroClassix-Verzeichnis sieht ganz anders
aus, es fehlt oben die Angabe von "Path" was auf die Verzeichnisse
hinweist, unter ROM steht nur"kick.rom"
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

12.01.2010, 20:35 Uhr

Fred_AROS
Posts: 471
Nutzer
Naja, das isses doch !

Die beiden WinUAE Versionen beissen sich, WinUAE deinstallieren und Retro Classix starten, dann sollte das funktionieren ....

[ - Antworten - Zitieren - Direktlink - ]

12.01.2010, 21:18 Uhr

tploetz
Posts: 4026
Nutzer
@Fred_AROS:
Ich kann doch nicht mein WinUAE deinstallierewn, da habe ich soviele
Programme drauf. Warum vertragen sich die beiden nicht?
WinUAE ist doch nicht aktiv oder doch?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

12.01.2010, 21:47 Uhr

Maja
Posts: 15429
Nutzer
@Fred_AROS:

Nicht ganz so schnell schießen. Zwar lässt sich bei ihm unter XP WinUAE starten (das Konfigprogramm), aber Retro Classix auch nicht. Und unter XP hat er keine zweites WinUAE laufen.

@tploetz:

Nein WinUAE wir nicht mit Windwos gestartet. Konflikte können jedoch über die Registry entstehen. Können, müssen aber nicht. Und jetzt langsam und Ruhe bewahren. Das kann immer noch auch nur ein relativ simples Pfad-Problem sein. Wenn der Standardpfad C:\Programme\... während der Installation nicht angepasst wird, hat man sowas schnell mal.

Ist Win7 bei Dir ein 32- oder 64-Bit System?
Poste bitte mal jeweils einen Pfad zu einem der KickROM-Images für WinUAE Retro Classix unter Win7 und unter XP. Das kannst Du per Copy'n Paste machen. Wie Du an die Pfade kommst, habe ich oben beschrieben.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

12.01.2010, 22:03 Uhr

tploetz
Posts: 4026
Nutzer
C:\Users\Public\Documents\Amiga Files\WinUAE\..\system\rom\
Das ist der Pfad von WinUAE auf Win7 auf XP gibt es keinen Pfad
bei WinUAE.
Win7 ist ein 32bit System.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

12.01.2010, 22:17 Uhr

Maja
Posts: 15429
Nutzer
@tploetz:

*sigh*

Den KickROM-Pfad des WinUAE, welches mit Retro Classix installiert wurde, bitte!! Und zwar ein Mal für Win7 und ein Mal für XP. Danke....
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

12.01.2010, 22:47 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Leider ist bei RetroClassix kein Pfad für das SystemRom vorhanden-
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 05:56 Uhr

Maja
Posts: 15429
Nutzer
@tploetz:

:rolleyes: :D ;)

In dem WinUAE-Ordner von Retro Classix ist aber mit an Sicherheit grenzender Wahrscheinlichkeit mindestens ein SystemRom vorhanden, bei Win7 und XP. Darf ich, bite, bitte, jeweils die Dateipfade dazu mal sehen?
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 11:37 Uhr

mk
Posts: 611
[Benutzer gesperrt]
Zitat:
Original von Maja:
Darf ich, bite, bitte, jeweils die Dateipfade dazu mal sehen?


Nö. Die unterliegen dem Datenschutz und werden demzufolge an Personen, die Nepper, Schlepper und Bauernfänger gutheissen, nicht rausgegeben.


[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 13:57 Uhr

thomas
Posts: 7678
Nutzer
@Maja:

Ich denke nicht, daß es irgendwas mit dem ROM zu tun hat. Diese alten WinUAE-Versionen haben ihre ROMs immer aus dem eigenen Verzeichnis geladen.

Ich denke eher, daß es an der Version von WinUAE liegt, die dürfte mit Vista/7 nicht kompatibel sein.

Ohne es selbst auszuprobieren, dürfte es auch schwierig sein, eine Lösung zu finden, wenn es überhaupt eine gibt. Vermutlich muß man die Winuae-Exe durch eine neuere ersetzen, was dann aber wieder zu den von dir vermuteten Problemen führt. Eine Umgehung wäre eine leere Datei namens winuae.ini in jedem WinUAE-Verzeichnis. Allerdings ist das bei Vista/7 wieder ein Problem, weil WinUAE ohne echte Admin-Rechte nicht in sein Programmverzeichnis schreiben darf.

Wie gesagt, es müßte jemand ausprobieren.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 18:50 Uhr

Maja
Posts: 15429
Nutzer
Zitat:
Original von thomas:
@Maja:

Ich denke nicht, daß es irgendwas mit dem ROM zu tun hat. Diese alten WinUAE-Versionen haben ihre ROMs immer aus dem eigenen Verzeichnis geladen.

Stimmt. Doch wenn in den *.uae Dateien, die Retro Classix auf die Festplatte kopiert, bestimmte Pfade schon vorgegeben sind, könnte das zum Problem werden.

Zitat:
Ich denke eher, daß es an der Version von WinUAE liegt, die dürfte mit Vista/7 nicht kompatibel sein.
Könnte natürlich sein. tploetz berichtet aber, dass Retro Classix unter XP auch nicht startet. Vondaher kann der Versuch nicht schaden. Habe ihm eine PM geschickt und gebeten, mir die Konfigs mal zu schicken. Leider gestaltet sich die Kommunikation schwierig. Schaumermal.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 19:26 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Ich muß mal klarstellen, aus VirtualBox kann ich nach Win7 nichts
kopieren. RetroClassix läuft auf XP nicht, aber WinUAE läuft und
die Spiele lassen sich über WinUAE laden.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 19:39 Uhr

Maja
Posts: 15429
Nutzer
@tploetz:

Du kannst auch immer noch, wie oben bereits vorgeschlagen, die WinUAE-Version von Regtro Classix in Win7 durch die aktuell verfügbare ersetzen (im WinUAE-Verzeichnis von Retro Classix). Oder Du schickst mir die UAE-Konfigurationen und ROM-Datei-Pfade aus Retro Classix unter Win7, dann schau ich mir das mal an. Nur solltest Du jetzt langsam mal irgendwas machen. Vom Diskutieren wird das nicht besser.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ Dieser Beitrag wurde von Maja am 13.01.2010 um 19:40 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

13.01.2010, 21:49 Uhr

tploetz
Posts: 4026
Nutzer
Ich habe festgestellt, wenn ich eine ältere WinUAE Version installiere,
funktionuert meine neuere Version nicht mehr, also hat es was mit der Registrierung zu tun.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

14.01.2010, 20:42 Uhr

Maja
Posts: 15429
Nutzer
@tploetz:

Keine voreiligen Schlüsse, bitte. Wenn Du WO eine ätltere Version von WinUAE installierst? Und WARUM überhaupt eine ältere Version?? Der Vorschlag war, die WinUAE-Version in (beispielsweise) C:\Programme\Retro Classix\WinUAE\ auf den aktuellen Stand zu bringen, sprich, gegen die neueste Version auszutauschen.

--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

14.01.2010, 21:23 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Wenn ich die aktuelle Version von WinUAE installiere, habe ich die selben Dateipfade,wie auf meinem anderen WinUAE.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

14.01.2010, 22:08 Uhr

Maja
Posts: 15429
Nutzer
Zitat:
Original von tploetz:
@Maja:
Wenn ich die aktuelle Version von WinUAE installiere, habe ich die selben Dateipfade,wie auf meinem anderen WinUAE.
tploetz :boing:


Nicht installieren, sondern aktualisieren. Das heißt, WinUAE.exe in C:\Programme\Retro Classix\ mit der akutelle Version überschreiben.

Und mach bitte auch, was ich in der letzten Mail beschrieben habe. Die Pfade in den Konfig-Dateien, die Du mir geschickt hast, zeigen auf das Verzeichnis, in dem Retro Classix WinUAE kopiert hat (Beispiele: kickstart_rom_file=Roms\Kick13.rom, floppy0=Games\3dtennis.adf). Die entsprechenden Dateien liegen bei Dir gemäßt Deiner letzten Mail aber in C:\Mein Spiel\RetroClassix\Amiga\msys\games\ Und C:\Mein Spiel\RetroClassix\Amiga\msys\games\Roms.

Für UAE selbst wäre das noch keine Grund, überhaupt nicht zu starten. Aber wenn Retro Classix beim Start noch andere Dateien unter falschen Pfaden sucht, dann kann es sein, dass es sich einen Wolf sucht und deswegen als fensterloser Prozess CPU-Zeit verbrät. Also kopiere BITTE alle Dateien und Verzeichnes aus C:\Mein Spiel\RetroClassix\ an den jeweils entsprechenen Ort unter C:\Programme\Retro Classix\ oder wo auch immer Du es hinsinstalliert hast.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ Dieser Beitrag wurde von Maja am 14.01.2010 um 22:09 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

20.01.2010, 14:38 Uhr

Maja
Posts: 15429
Nutzer
@tploetz:

Und? Läuft das jetzt? Wenn ja, hier bitte mal den Lösungsweg erwähnen. Damit wäre dieser Thread auch für andere mit gleichem Problem hilfreich.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

20.01.2010, 15:30 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Nein auf Window7 läuft es nicht, habe die aktuelle Version
von WinUAE kopiert, dadurch snd alle Konfigurationseinstellungen
falsch.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

20.01.2010, 16:42 Uhr

Maja
Posts: 15429
Nutzer
Zitat:
Original von tploetz:
@Maja:
Nein auf Window7 läuft es nicht, habe die aktuelle Version
von WinUAE kopiert,

Wie bist Du dabei genau vorgegangen?

Was ist mit XP, läuft es da inzwischen?
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

20.01.2010, 17:37 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Bei XP kann ich die Spiele direkt über WinUAE laden, die ganzen Konfigurationen
stehen da drin, ansonsten verlangt XP die Orginal-CD.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

20.01.2010, 18:20 Uhr

Maja
Posts: 15429
Nutzer
Zitat:
Original von tploetz:
@Maja:
Bei XP kann ich die Spiele direkt über WinUAE laden, die ganzen Konfigurationen
stehen da drin, ansonsten verlangt XP die Orginal-CD.


Das hängt mit dem verwendeten Kopierschutz und virtuellen Laufwerken zusammen. Da hatten wir schon durch. Du kannst allerdins nur die Amiga-Spiele auf der CD direkt über WinUAE laden. Auf der CD sind aber auch noch Spiele für C64 und Atari.

Würdest Du nun bitte auch noch die andere Frage bezüglich Win7 beantworten. Es leutet mir nicht unbedingt ein, weshalb nach dem simplen Austausch von winuae.exe gegen eine andere Version dieser Datei im WinUAE-Verzeichnis von Retro Classix aufeinmal alle Konfigurationsdateien (*.uae) in diesem Verzeichnis falsch sein sollten.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ Dieser Beitrag wurde von Maja am 20.01.2010 um 18:21 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

20.01.2010, 18:41 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Dann habe ich was falsch gemacht, habe keine WinUAE.exe gefunden.
Habe die WinUAE-Datei mit Symbol kopiert, deswegen wurde die
Konfiguration vom ersten WinUAE übernommen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

23.01.2010, 15:27 Uhr

Maja
Posts: 15429
Nutzer
@tploetz:

Um die Dateiendung exe zu sehen, musst Du im Windows Explorer zunächst [Alt] drücken und dann über das Menü "Extras" den Unterpunkt "Ordneroptionen" aufrufen. Dort unter "Ansicht" den Eintrag "Erweiterungen bei bekannten Dateitypen ausblenden" deaktvieren. Anschließend unten auf "Übernehmen" klicken.

WinUAE trägt sich bei Installation vielfach in die Registry ein. Hier ein Auszug der gefundenen Einträge:

HKU\ S-1-5-21-3057327916-3674974910-617588396-10008\Software\Arabuusimiehet\WinUAE
"FloppyPath"=".\\"
"KickstartPath"=".\\"
"hdfPath"=".\\"
"ConfigurationPath"=".\\Configurations\\"
"ScreenshotPath"=".\\Screenshots\\"
"StatefilePath"=".\\Savestates\\"
"SaveimagePath"=".\\SaveImages\\"
"VideoPath"=".\\"
"InputPath"=".\\Inputrecordings\\"
"MainPosX"=dword:000000f0
"MainPosY"=dword:000000d4
"GUIPosX"=dword:000000f0
"GUIPosY"=dword:000000d4
"Version"="WinUAE 2.0.1 (2009.12.23)"
"ROMCheckVersion"="WinUAE 2.0.1 (2009.12.23)"
"SoundDriverMask"=dword:0000000f
"ConfigurationCache"=dword:00000001
"QuickStartModel"=dword:00000000
"QuickStartConfiguration"=dword:00000000
"QuickStartCompatibility"=dword:00000001
"InstallDir"="C:\\Program Files (x86)\\WinUAE"

HKU\ S-1-5-21-3057327916-3674974910-617588396-1000\Software\Arabuusimiehet\WinUAE\DiskImageMRUList

HKU\ S-1-5-21-3057327916-3674974910-617588396-1000\Software\Arabuusimiehet\WinUAE\FileAssociations
".uae"=""

Das hindert WinUAE aber nicht daran, in derselben Version aus einem anderen Pfad heraus zu starten. Hier einfach aus dem entpackten Zip-Archiv heraus:

HKU\ S-1-5-21-3057327916-3674974910-617588396-1000\Software\Classes\WinUAE\DefaultIcon
@="C:\\Users\\Martina\\Downloads\\Tools\\WinUAE2010\\winuae.exe,-185"

HKU\ \S-1-5-21-3057327916-3674974910-617588396-1000\Software\Classes\WinUAE\shell\edit\command
@="\"C:\\Users\\Martina\\Downloads\\Tools\\WinUAE2010\\WinUAE.exe\" -f
\"%1\" -s use_gui=yes"

Problematisch könnten die oben rot markierten Einträge sein,wenn sich verschiedene Versionen von WinUAE im System befinden.
--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ Dieser Beitrag wurde von Maja am 23.01.2010 um 15:28 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

29.01.2010, 12:55 Uhr

tploetz
Posts: 4026
Nutzer
@Maja:
Ich muss demnächst mal WinUAE deinstalieren und RetroClassix neu instalieren, mal sehen ob es dann geht.
tploetz

[ - Antworten - Zitieren - Direktlink - ]

29.01.2010, 20:35 Uhr

Maja
Posts: 15429
Nutzer
Zitat:
Original von tploetz:
Habe die WinUAE-Datei mit Symbol kopiert, deswegen wurde die
Konfiguration vom ersten WinUAE übernommen.

Was meinst Du eigentlicht mit, "WinUAE-Datei mit Symbol"? WinUAE.exe erscheint einfach als WinUAE, wenn die Dateiendung versteckt wird. Konfig-Dateien von WinUAE enden auf .uae, heißen aber nicht WinUAE. Und die Pfade in den UAE-Konfig-Dateien von Retro Classix, die Du mir geschickt hattest, zeigen alle auf das Verzeichnis, aus dem heraus WinUAE zuvor gestartet wurde. Unabhängig davon, welches Verzeichnis das ist. Die gesuchten Daten befinden sich aber an ganz anderer Stelle, wie weiter oben bereits auseianderklamüsert. Ob es ein Registry-Problem gibt, ist nur eine Vermtung. Ein Pfad-Problem liegt IMHO aber auf der Hand. Und das hat augenscheinlich nichts mit dem ersten WinUAE zu tun.


--
** Tippfehler sind kostenlos und dürfen unbegrenzt an Dritte weitergegeben werden. **

[ - Antworten - Zitieren - Direktlink - ]

20.04.2010, 21:24 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
Retro Classix läuft auch nicht unter deinstallierten WinUAE, auch als Administrtator
ausführen funktioniert nicht, lediglich lassen sich die Amiga-Programme uber
AmigaForever nutzen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

22.04.2010, 06:56 Uhr

rbn
Posts: 2001
Nutzer
Na dann ist doch alles gut ... ;)

Hatte mit diesen Classix CDs auch immer Probleme und alle die ich kenne auch. Aber die Soft und die Kickstarts die dabei sind laufen wunderbar.

Das reicht doch, oder?

Das Menü ist sowieso nach einiger Zeit nur noch nervig.

Da klick ich doch lieber einmal auf die Verknüpfung zu meiner Batch Datei und starte direkt in die Emulation. Genauso wie ich auch jedes andere Windows Native Programm starten würde ... 8)

rbn

[ - Antworten - Zitieren - Direktlink - ]


1 -2- [ - Beitrag schreiben - ]


amiga-news.de Forum > Andere Systeme > Retro Classix auf Windows7 [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.