amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Diskettenlaufwerk -Unlesbar [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

21.05.2010, 19:39 Uhr

Amiuso
Posts: 130
Nutzer
Wenn ich eine Workbench Diskette ins Laufwerk schiebe
Startet er sie nicht.
Wenn ich zuerst von Festplatte die WB starte und dann die diskette einschiebe erscheint das "DF0:unlesbar"
Mache ich das mit der selben Diskette am A600 oder A1200 funktioniert es. an 2 A500 wieder nicht.
Und die Laufwerke fangen auch an zu starten und machen keine andren Geräuche oder andere auffäligkeiten die sie vorher nicht gemacht haben.

[ - Antworten - Zitieren - Direktlink - ]

22.05.2010, 01:22 Uhr

Bjoern
Posts: 1675
Nutzer
Zitat:
Wenn ich eine Workbench Diskette ins Laufwerk schiebe
Startet er sie nicht.

Grusel.
Zitat:
an 2 A500 wieder nicht.
???
Zitat:
Und die Laufwerke fangen auch an zu starten und machen keine andren Geräuche oder andere auffäligkeiten die sie vorher nicht gemacht haben.
An welchem Rechner denn?

Gruß,
Björn

[ - Antworten - Zitieren - Direktlink - ]

22.05.2010, 09:26 Uhr

Fred_AROS
Posts: 471
Nutzer
Ist das evtl eine WB 3.1 Disk :D ??

Die startet nämlich auf nem A500 mit Kick 1.3 nicht, auf A600 (kick 2.x) und A1200 (kick 3.x) schon ;)

[ - Antworten - Zitieren - Direktlink - ]

22.05.2010, 09:51 Uhr

Bjoern
Posts: 1675
Nutzer
Ok, jetzt ernsthaft. Gestern wars schon spät :)

Zitat:
Original von Amiuso:
Wenn ich zuerst von Festplatte die WB starte und dann die diskette einschiebe erscheint das "DF0:unlesbar"


Wenn das bei einer Diskette passiert, die in anderen Rechnern läuft, dann sieht das so aus als wäre das Laufwerk defekt. Trotzdem solltest du mal sagen um welchen Amiga es sich handelt den du von HD bootest.

[ Dieser Beitrag wurde von Bjoern am 22.05.2010 um 09:52 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

22.05.2010, 13:15 Uhr

GMB
Posts: 836
Nutzer
Ergänzend zu den Angaben meiner Vorschreiber würde ich hier noch anfügen, dass Laufwerke ja mechanische Toleranzen haben, die beim einen Laufwerk z.B. in Plus-Richtung, beim anderen in Minus-Richtung liegen. Somit könnte es sein, dass eine im 1. LW formatierte Diskette im 2. nicht lesbar ist, beide Laufwerke aber beispielsweise eine mit Null-Toleranz beschriebene Diskette eines dritten Laufwerks lesen können.
Zudem ist hier natürlich wie schon angedeutet die Filesystem-Version auf den Disketten nicht unerheblich. Denn eine neuere Filesystem-Version ist zwar rückwärtskompatibel, die alte aber nicht vorwärtskompatibel. Also mal schauen, ob die A500 u.U. nicht nur OFS statt FFS können und dann am FFS-Rechner die Disk mal mit OFS formatieren (so keine wichtigen Daten drauf sind).

Ciao

G-MB

:boing: :dance1:

[ - Antworten - Zitieren - Direktlink - ]

23.05.2010, 20:07 Uhr

AGSzabo
Posts: 1663
Nutzer
Ist es vielleicht eine HD (high density) diskette? der a500 kann nur DD (double density) disketten lesen. du erkennst HD disketten daran, dass sie ein kleines quadratische loch in einer ecke haben, gegenüber dem schreibschutzschieberchen.
--
Sam mini os4.1 upd. 2 -- e-uae 39bb2 -- A4000D 3.0 & 3.9 - 2mbchip/8mbfast - Ariadne_II - ide DVD und HD -- A500 3.1 (mkick) adide 50mb -- Duron 1200mhz Ubuntu Linux

[ - Antworten - Zitieren - Direktlink - ]

23.05.2010, 21:44 Uhr

Amiuso
Posts: 130
Nutzer
Also das Laufwerk am 4000 war falsch angeschlossen.
Am Ende des Kabels ist eine Drehung drinne. Am Ende tauschen 3 Adern
die Position. Warum?

Ich habe dieses Laufwerk einfach mal an den 2 A500 angeschlossen und die Disketten booten und werden angezeigt.
Es scheint echt nur das an beiden 500 die Laufwerke kaputt sind.
Das erschien mir aber unwarscheinlich weil ja das am 4000 auch nicht ging und 3 Defekte auf einmal konnte ich einfach nicht glauben.
Gibt es einfache möglichkeiten wie man versuchten könnte es zu reparieren???

Danke an alle die versucht haben zu helfen!

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 01:56 Uhr

GMB
Posts: 836
Nutzer
Ein Kabel, bei dem drei Adern gedreht werden klingt für mich irgendwie nach einem PC-Floppykabel statt eines Amiga-Floppy-Kabels. Bei den Amigas wird die Laufwerks-ID durch Jumper festgelegt, beim PC durch tauschen der entsprechenden Adern.

Ciao

GMB

:boing: :dance1:

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 11:37 Uhr

Thore
Posts: 2266
Nutzer
Die Drehung gibt an, ob es sich um da fd0 oder fd1 handelt. Dieses wird meist bei PC Floppies gemacht, wo ein entsprechender Jumper fehlt.

Der Jumper und die Drehung bewirken das gleiche. Schau mal ob Du durch eine andere Jumperposition das Laufwerk einbinden kannst. Falls das nicht geht, brauchst du ein Kabel ohne twist :)

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 13:20 Uhr

AGSzabo
Posts: 1663
Nutzer
jumper bei amigalaufwerken gibt es nicht. es können zusätzlich zum internen lw bis zu drei weitere extern angeschlossen werden, in beliebiger reihenfolge und ohne jumper. im a5000 am rechten CIA chip gibt es ein paar leitungen die zb "drive 0 select" und "drive 1 select" heissen. für jedes laufwerk gibt es eine leitung, welche angibt welches laufwerk jeweils jetzt angesteuert werden soll. diese leitungen sind bis zum dritten externen lw durchgeführt, aber in jedem kabel so überkeuzt, dass dass die erste nach aussen führende leitung drive 1 select zb auf den select-anschluss des 1 externen lw gelegt wird. die übrigen selectleitungen rücken nach, so dass für das letzte laufwerk endlich das "drive 3 select" auf den select anschluss des 3. externen lw zu liegen kommt.

tut mir leid, jumper gibts zwar in den lw, aber die sind für was anderes. ist logisch, weil eben mehrere lw ohne jumpern angschlossen werden können.
--
Sam mini os4.1 upd. 2 -- e-uae 39bb2 -- A4000D 3.0 & 3.9 - 2mbchip/8mbfast - Ariadne_II - ide DVD und HD -- A500 3.1 (mkick) adide 50mb -- Duron 1200mhz Ubuntu Linux

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 17:07 Uhr

Thore
Posts: 2266
Nutzer
@AGS
Keiner erwähnte daß der Jumper im Laufwerk ist, aber Du hast recht, da hätte man direkter sein sollen ;)
Es gibt sogar PC Laufwerke die haben ein Jumper-Panel für ID 0-3.

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 17:16 Uhr

AGSzabo
Posts: 1663
Nutzer
@Thore:

im a500 ist jedenfalls auch kein jumper.
--
Sam mini os4.1 upd. 2 -- e-uae 39bb2 -- A4000D 3.0 & 3.9 - 2mbchip/8mbfast - Ariadne_II - ide DVD und HD -- A500 3.1 (mkick) adide 50mb -- Duron 1200mhz Ubuntu Linux

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 18:09 Uhr

Thore
Posts: 2266
Nutzer
Aber da hast auch nicht das Problem von 2 internen Laufwerken ;)

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 18:56 Uhr

AGSzabo
Posts: 1663
Nutzer
@Thore:

beim pc ist das kabel zwischen dem ersten und dem zweiten laufwerk zum teil verdreht. auch da muss man nicht jumpern. das brauchen blos die ide festplatten.
--
Sam mini os4.1 upd. 2 -- e-uae 39bb2 -- A4000D 3.0 & 3.9 - 2mbchip/8mbfast - Ariadne_II - ide DVD und HD -- A500 3.1 (mkick) adide 50mb -- Duron 1200mhz Ubuntu Linux

[ Dieser Beitrag wurde von AGSzabo am 24.05.2010 um 18:56 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 18:58 Uhr

Thore
Posts: 2266
Nutzer
Genau so ist es :)
Gerade wegen der Verdrehung entfällt das Jumpern, und man kann 2 identische Laufwerke nehmen.

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 19:11 Uhr

GMB
Posts: 836
Nutzer
Und ich würde behaupten, dass >50% meiner original Amiga-Diskettenlaufwerke hinten zwischen 3 und 6 Jumper haben, mit denen man u.a. die Laufwerks-ID einstellen kann. Nur die zum Schluß (primär zu AmigaTechnologies-Zeiten) verbauten (PC)-Laufwerke hatten diese nicht mehr.

Ciao

GMB

:boing: :dance1:

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 19:13 Uhr

Thore
Posts: 2266
Nutzer
Auch das stimmt wieder ;)
Es gibt Laufwerke beider Bauarten in beiden Lagern :)

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 21:51 Uhr

Amiuso
Posts: 130
Nutzer
Also bedeutet dass das Kabel zum Floppy kein Amiga Kabel ist?
Es wurde also mal ausgetauscht?

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 21:58 Uhr

Thore
Posts: 2266
Nutzer
Das hängt vom Laufwerk ab. Vielleicht war eins verbaut das den twist gebraucht hat.

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 22:15 Uhr

Amiuso
Posts: 130
Nutzer
@Thore:
Also ich habe es am selben Kabel nur nicht am Ende.
Könnte ich den am Ende etwas anschliessen was diese verdrehung braucht?
Ein Amiga Laufwerk ja nicht ? Sonst hätte meins ja gleich geklappt.
Oder ist zwingend ein df0 notwendig um dann df1 zu verwenden?

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 22:20 Uhr

AGSzabo
Posts: 1663
Nutzer
@Amiuso:

amigadiskettenlaufwerke schlieest man nicht über pc-floppylabel an. amigadiskettenlaufwerke benötigen eine kleine controllerschaltung, wie sie zb in externen amigadiskettenlafuwerken findbar ist.
--
Sam mini os4.1 upd. 2 -- e-uae 39bb2 -- A4000D 3.0 & 3.9 - 2mbchip/8mbfast - Ariadne_II - ide DVD und HD -- A500 3.1 (mkick) adide 50mb -- Duron 1200mhz Ubuntu Linux

[ - Antworten - Zitieren - Direktlink - ]

24.05.2010, 22:27 Uhr

GMB
Posts: 836
Nutzer
AGS, Deine These stimmt für externe Laufwerke, wir reden hier aber über Desktop-Amigas, und da kann man bei allen (A2000, A3000(T), A4000(T)) intern ein 2. Laufwerk an das originale Floppy-Kabel anstecken. Sollte dieses ein PC-Kabel mit Drehung sein, muss man es untypischerweise halt als 2. DF0 jumpern, obwohl es an DF1 verbaut/angesprochen wird... Alle o.g. Geräte haben auf dem Mainboard einen DF1 Jumper, der definiert, ob es intern oder extern ist respektive überhaupt vorhanden.

Ciao

GMB

:boing: :dance1:

[ - Antworten - Zitieren - Direktlink - ]

16.06.2010, 03:27 Uhr

Dennis_50300
Posts: 602
Nutzer
Ich glaube ehrlich gesagt kaum das da das Floppylaufwerk hin ist.

Ich habe das ganz alte 500er-Modell hier sogar und das originale
Laufwerk geht 1A als ob es neu wäre.

Es musste halt nurmal gereinigt werden,
Kabel könnte es sein, ansonsten wäre höchsten der b.z.w.
die Taster vor im Laufwerk das Problem, die dafür
Zuständig sind dem Amiga zurechtzugaukeln
ob eine Floppy im Laufwerk ist und wegen Schreibschutz.

Ich habe hier auch ein Laufwerk was noch mehr spinnt wenn
ich diesen schwarzen Tasterblock etwas in Richtung Diskette
hochdrücke.

Unreadable u.s.w. dadurch auch alles schon angezeigt worden,
richtig nervig ist das, da das Laufwerk an sich eigentlich funktioniert und z.B. eine 1.3er WB normal starten würde wenn dieser/diese Taster nicht hin wären.

Hat da jemand einen Tip wie man das eventuell beheben kann,
vielleicht kann man sowas sogar kaufen und selbst neu einlöten ?

Laufwerk bei mit ist ein: Chinon FB-354 Rev.E

Edit:
X-Copy z.B. greift ja direkt auf die Hardware zu,
kann ich das in etwa so verstehen das da der Schalter
ignoriert wird ?
Und somit das Laufwerk auf sonstige lauffähigkeit richtig testen ?
Könnte ja einfach versuchen von besagtem Laufwerk eine
1.3er WB auf ein externes zu kopieren, normalerweise müssten ja überall grüne Nullen kommen :)
1-2 mal hat es aber schon 1.3er WB hochgeladen, es ist anscheinend
also echt nur diese Tastergeschichte, richtig bemerkbar dadurch
das es meistens so ist als würde ich die Diskette auswerfen und direkt wieder einwerfen.
Dachte mir so naja Isoprpanol hast ja da, hat aber leider auch nicht
geholfen, die Lese/Schreib Köpfe sind ebenfalls gereinigt
mit dem Isop. wie bei meinem Uhralt Amiga 500 was ja einwandfrei geht.
ENDEDIT

Gruß Dennis_50300
--
Amiga 500,Amiga 500Plus
Amiga 600(Zu verkaufen mit Extras)
Amiga 1200

[ Dieser Beitrag wurde von Dennis_50300 am 16.06.2010 um 03:32 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

16.06.2010, 08:57 Uhr

Thore
Posts: 2266
Nutzer
Auf dem A500 ist zwingend DF0 vonnöten, damit DF1 klappt. Da unter Kick1.3 nur von DF0 gebootet werden kann (Festplatten ausgenommen, die können auch vorher booten ab 1.3).
Ab 2.x kann auch von einem anderen Disketten-Laufwerk aus gebootet werden.

Die Ursachen der HD Disketten halte ich für plausibel, ich hab auch 2 Laufwerke bei denen eines nicht immer will, das andere geht mit allen Disketten wunderbar.

[ - Antworten - Zitieren - Direktlink - ]

16.06.2010, 09:27 Uhr

Thore
Posts: 2266
Nutzer
@Dennis:
X-Copy macht ein Low Level Copy. Das heißt er liest/schreibt die Rohdaten blockweise. Was genau da drinsteht ist ihm dabei völlig egal.
Die Workbench decodiert die Rohdaten und sucht den Bootblock und den Rootblock. Findet er einen von beiden nicht dann ist die Disk bereits unlesbar.

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Diskettenlaufwerk -Unlesbar [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.