amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Mein HCMenu Editor funktioniert nicht mehr, bitte um Hiiiiilfeeee [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

05.10.2010, 20:21 Uhr

Dr-Eprom
Posts: 190
Nutzer
Moin...

Ich hoffe bei Euch ist alles soweit in Ordnung. :look:

Also, ich habe folgendes Problem:

Ich benutze das sogenannte "HCMenu", das habe ich mir aus dem Aminet heruntergeladen und bisher funktionierte auch alles echt super.
Zu dem HCMenu gibt es einen HCMenu Editor, der es einem sehr vereinfacht Menüs zu gestalten.
Das HCMenu selber funktioniert noch, nur wenn ich den HCMenu Editor starten möchte, dann geht mein Amiga ab in den Wald.
Es kommt dann folgende Meldung:

HCMenuEditor
Programmfehler (Fehlernummer 80000008)
Warten Sie auf das Ende der Diskaktivität.

Ich weiß echt überhaupt nicht warum dies auf einmal so ist. X(

Da ich noch einen Amiga 500 mit einer E-Matrix 530 besitze, habe ich das HCMenu dort einmal ausprobiert und siehe da, alles läuft super.

Nun habe ich mit SnoopDos zwei LOGS erzeugt. :O
Einen auf dem Amiga 500 und einen auf dem Amiga 1200 (siehe Signatur)


SNOOPDOS LOG AMIGA 500:
SnoopDos logging started on Dienstag, 05-Okt-10 at 20:46:24

Count Process Name Action Target Name Options Res.
----- ------------ ------ ----------- ------- ----
1 WBL ChangeDir OS_3.9_BOOTDISK:Tools/HCMen
2 WBL Load HCMenuEditor OK
3 WBL ChangeDir SYS:
4 ramlib Load LIBS:powerpacker.library OK
5 ramlib Load LIBS:amigaguide.library OK
6 CCCP HCMenuEditor Open PROGDIR:Catalogs/deutsch/am Read Fail
7 CCCP HCMenuEditor Open LOCALE:Catalogs/deutsch/ami Read Fail
8 ramlib Load LIBS:datatypes/amigaguide.d OK
9 CCCP HCMenuEditor Open PROGDIR:Catalogs/deutsch/Sy Read Fail
10 CCCP HCMenuEditor Open LOCALE:Catalogs/deutsch/Sys Read OK
11 CCCP HCMenuEditor Open ENV:AmigaGuide/Path Read Fail
12 CCCP HCMenuEditor Open ENVARC:HcMe.prefs Read OK
13 CCCP HCMenuEditor Open ENVARC:HCMenu.prefs Read OK
14 CCCP HCMenuEditor Open FONTS:MAS.font Read OK
15 CCCP HCMenuEditor Load FONTS:MAS/15 OK
16 CCCP HCMenuEditor Open DH0:S/mainFilme&Demos.Menu Read OK
17 CCCP HCMenuEditor Open DH0:S/mainFilme&Demos.Menu. Read OK
18 CCCP HCMenuEditor Open Devs:ClipBoards/HcMe Read Fail
19 CCCP HCMenuEditor Open Devs:ClipBoards/HcMe.pp Read Fail
20 CCCP HCMenuEditor Delete Devs:ClipBoards/HcMe Fail

Closed SnoopDos log at 20:47:47


SNOOPDOS LOG AMIGA 1200:

SnoopDos logging started on Dienstag, 05-Okt-10 at 19:59:31

Count Process Name Action Target Name Options Res.
----- ------------ ------ ----------- ------- ----
1 WBL ChangeDir OS_3.9_BOOTDISK:Tools/HCMen
2 WBL Load HCMenuEditor OK
3 WBL ChangeDir SYS:

und dann geht es ab in den Wald ;(


Habt ihr eine Vermutung warum das HCMenu auf dem Amiga 1200 auf einmal abstürzt ? ?(


Für Euere Unterstützung wäre ich wie immer sehr dankbar :rolleyes:
--
MfG

Dr. Eprom

Amiga 1200 im Winner-Tower, OS3.9, Blizzard 1260/66Mhz 256MB, Mediator TX, Voodoo 3, SB128, Spider USB, Netzwerk.

[ - Antworten - Zitieren - Direktlink - ]

06.10.2010, 07:29 Uhr

RhoSigma
Posts: 67
Nutzer
Hallo,

hast du eventuell kuerzlich eine neue Version der powerpacker.library
installiert ?? - Die Tatsache, dass das der erste fehlende Eintrag in
der 2. SnoopLog ist, impliziert eigentlich schon, dass beim Laden
dieser Library was schiefgeht.

Ich hatte das mal (lange her) mit der GadToolsBox. Nach dem ich eine
neuere Version der powerpacker.library installiert hatte, ist der
Rechner jedes mal beim Laden eines gepackten GUIs abgeschmiert. Habe
dann die alte Version 36.10 vom 28.9.93 wiederhergestellt und alles
lief wieder.

Gruesse

[ - Antworten - Zitieren - Direktlink - ]

06.10.2010, 10:36 Uhr

Holger
Posts: 8090
Nutzer
Ja, PowerPacker klingt nach einem guten Kandidaten für etwas, das auf dem A500 ohne CPU Caches funktioniert, auf einem A1200 mit Caches aber Probleme bereiten könnte.

Die Alternative zum Wechsel auf eine andere Version wäre, ihn ganz runterzuschmeißen, oder braucht man PowerPacker auf Rechnern mit Festplatte wirklich noch?

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

06.10.2010, 11:15 Uhr

RhoSigma
Posts: 67
Nutzer
@Holger

Ja stimmt, vielleicht hat er das Ding ja aus dem Grunde schon weggeschmissen, und HCMenu schmiert nun ab, weil es das Fehlen
einer Library nicht abfaengt, sondern stumpf weiterackert - In dem
Falle dann mit einem NULL-Pointer :D

[ - Antworten - Zitieren - Direktlink - ]

06.10.2010, 20:00 Uhr

Dr-Eprom
Posts: 190
Nutzer
@RhoSigma:
Moin...

vielen Dank für deinen Tipp mit der Powerpacker.library :)

Ich habe es gleich ausprobiert, aber ohne Erfolg.
Beim Amiga 500 habe ich die Powerpacker.library mal gelöscht, aber der HCMenuEditor funktioniert dann trotzdem noch. ?(

Aber letztendlich habe ich doch noch Erfolg gehabt und folgendes habe ich herausgefunden: Es liegt an Blizkick mit dem Rom Update BoingBag3.9-2 !!!

Folgende Testdurchläufe habe ich gemacht:


- Blizkick mit dem Rom Update BoingBag3.9-2 und der HCMenuEditor funktioniert nicht :(

- Blizkick mit dem Rom Update BoingBag3.9-1 und der HCMenuEditor funktioniert :lach:

- Ohne Blizkick mit dem Rom Update BoingBag3.9-2 und der HCMenuEditor funktioniert :lach:

- Ohne Blizkick mit dem Rom Update BoingBag3.9-1 und der HCMenuEditor funktioniert :lach:

Also hängt das wohl irgendwie mit dem Blizkick zusammen. :dance3:
Soweit alles supi nur zwei Fragen hätte ich da noch ?(

Es hat ja mal mit Blizkick und dem Rom Update BoingBag3.9-2 funktioniert, warum jetzt nicht mehr ?

Und kann man auf das Rom Update BoingBag3.9-2 verzichten ? Hat es irgendwelche Nachteile wenn man nur das Rom Update BoingBag3.9-1 benutzt ? Auf Blizkick möchte ich nämlich nicht verzichten.


Vielen dank für die bisherige Unterstützung :bounce:





--
MfG

Dr. Eprom

Amiga 1200 im Winner-Tower, OS3.9, Blizzard 1260/66Mhz 256MB, Mediator TX, Voodoo 3, SB128, Spider USB, Netzwerk.

[ - Antworten - Zitieren - Direktlink - ]

07.10.2010, 10:12 Uhr

RhoSigma
Posts: 67
Nutzer
Tut mir leid, mit BlizKick wird dir hier irgendjemand anderer weiterhelfen muessen, hab ich nie benutzt und sehe auch keinen Grund es jemals zu benutzen, da ich mein ROM-Update im Flashrom der Deneb habe.

Viel Erfolg noch beim Testen :bounce:

[ - Antworten - Zitieren - Direktlink - ]

07.10.2010, 13:08 Uhr

Holger
Posts: 8090
Nutzer
Zitat:
Original von Dr-Eprom:
Ich habe es gleich ausprobiert, aber ohne Erfolg.
Beim Amiga 500 habe ich die Powerpacker.library mal gelöscht, aber der HCMenuEditor funktioniert dann trotzdem noch. ?(

Hä?
Dass ein Programm auf dem A500 ohne PP funktioniert, beweist doch noch lange nicht, dass es auf dem A1200 mit PP funktioniert.
Zitat:
Und kann man auf das Rom Update BoingBag3.9-2 verzichten ? Hat es irgendwelche Nachteile wenn man nur das Rom Update BoingBag3.9-1 benutzt ?
Warum hast Du es denn überhaupt installiert, wenn Du seine Vorteile nicht kennst?

Guckst Du hier: http://www.amigafuture.de/pdf.php?t=0&kb=1797&c=53

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

07.10.2010, 20:01 Uhr

Dr-Eprom
Posts: 190
Nutzer
@Holger:
> Warum hast Du es denn überhaupt installiert, wenn Du seine Vorteile nicht kennst?

Moin...

weil es neuer ist ??? :lach:

Danke für deine Info. :)
--
MfG

Dr. Eprom

Amiga 1200 im Winner-Tower, OS3.9, Blizzard 1260/66Mhz 256MB, Mediator TX, Voodoo 3, SB128, Spider USB, Netzwerk.

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Mein HCMenu Editor funktioniert nicht mehr, bitte um Hiiiiilfeeee [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.