amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > PegasosII CD Audio - Wie? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

07.10.2010, 22:57 Uhr

Reth
Posts: 1753
Nutzer
Hallo zusammen,

ich nutze auf meinem PegII derzeit AOS4 und EUAE. Dabei habe ich das Problem, dass werder unter AOS4 noch unter emuliertem AOS3.9 Audio direkt von CD wiedergegeben wird (z.B. bei Shadow of the 3rd moon)!

Muss ich da noch was verkabeln oder softwaremäßig umleiten?

Auf dem A4000 musste ich ein Audio-Kabel aus dem CDROM auf dem Mainboard einstecken, damit der Sound mit über den Audioausgang des 4000er kam. Gibts auf dem PegII auch was in der Art?

Vielen Dank schon mal!

Ciao

[ - Antworten - Zitieren - Direktlink - ]

07.10.2010, 23:27 Uhr

AmigaHarry
Posts: 1642
Nutzer
Genau so wie beim A4000. Hinter dem Stromversorgungstecker findest du 4 Stück 4-polige Steckersockel nebeneinander. Der ganz linke (Board von den vorne angesehen) ist der CD-Steckersockel. Steht im Übrigen auch in der Anleitung zum Pegasos........ ( http://www.genesi-usa.com/data/get/92 )
--
Life starts at '030, fun at '040, impotence at '86!

[ Dieser Beitrag wurde von AmigaHarry am 07.10.2010 um 23:32 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

08.10.2010, 15:44 Uhr

ZeroG
Posts: 1482
Nutzer
@Reth:
Kann dein Laufwerk überhaupt noch AudioCDs direkt abspielen?

[ - Antworten - Zitieren - Direktlink - ]

10.10.2010, 23:36 Uhr

Reth
Posts: 1753
Nutzer
@ZeroG:

Ich hoffe doch. Zumindest hat es einen entsprechenden Anschluss. Nur leider musste ich heute feststellen, dass ich kein entsprechendes Kabel habe und mir dieses erstmal besorgen muss!

[ - Antworten - Zitieren - Direktlink - ]

28.10.2010, 18:18 Uhr

Reth
Posts: 1753
Nutzer
Gibt es beim PegII da noch was Besonderes zu beachten? Habe mir ein Audio-Kabel gekauft und das CD-ROM wie beschrieben mit dem Anschluss auf dem Board verbunden. Allerdings kommt beim Abspielen der CD kein einzige Ton aus den Boxen (weder unter AOS4 noch unter AOS3.9)!

Brauchts da noch irgendwelche Libs o.ä.?

[ - Antworten - Zitieren - Direktlink - ]

28.10.2010, 20:37 Uhr

Polluks
Posts: 92
Nutzer
@Reth:
Mixer korrekt eingestellt?
--
Pegasos II G4, MorphOS 2.5
Power Mac G3

[ - Antworten - Zitieren - Direktlink - ]

29.10.2010, 00:49 Uhr

Reth
Posts: 1753
Nutzer
@Polluks:

Naja, hätte den Thread vielleicht doch im anderen Unterforum starten sollen. Ich nutze AOS4 auf dem PegII und dort gibt es keinen Mixer o.ä. (zumindest konnte ich außer AHI und Sound keine Einsteller oder andere Programme für solche Funktionalitäten finden)!

Woran könnte denn das Schweigen liegen? Muss da noch was gejumpert werden, oder ne directaudio.library oder so installiert werden? PlayCD spielt die Titel brav ab, der Laufwerk ist mittels 3-adrigem Kabel mit dem Anschluss auf dem Board verbunden, aber nichts ist zu hören?

Vielleicht muss ich mir nochmal die Anschlüsse am DVD-RW-LW ansehen, da ist auch noch einer neben dem jetzt benutzten. der sieht aber eher wie für digital audio out o.ä. aus!

Oder hat der PegII noch nen 2. Audio-Ausgang, der in diesem Fall zusätzlich angeschlossen werden muss?

Ciao

[ - Antworten - Zitieren - Direktlink - ]

29.10.2010, 16:10 Uhr

Reth
Posts: 1753
Nutzer
OK, hab gerade gesehen, dass es den Mixer für AOS4 auch gibt! Aber hilft der denn auch für alte Games mit CDDA (ggf. auch unter EUAE)?

[ - Antworten - Zitieren - Direktlink - ]

29.10.2010, 17:39 Uhr

ZeroG
Posts: 1482
Nutzer
@Reth:
Wie ich bereits sagte - wahrscheinlich kann das Laufwerk keine CDDA-Tracks direkt abspielen, sondern nur auslesen. Die SCSI-Kommandos zum direkten abspielen wurden vor Jahren aus dem Befehlssatz gestrichen.

[ - Antworten - Zitieren - Direktlink - ]

29.10.2010, 18:55 Uhr

AmigaHarry
Posts: 1642
Nutzer
Wenn dasCDROM noch einen Analogausgang hat kann es die Tracks auch analog abspielen. Ich denke da hat es ein anderes Problem. Unter MOS geht das ganz normal und problemlos - alle meine DVD-Brenner können das und spielen das direkt analog auf das Motherboard.......
Es muss bei dir was mit dem Aktivieren des CD-Einganges am Board haben. Unter MOS (2.6) ist dazu nicht einmal der Mixer nötig - das Signal wird standartmäßig durchgereicht.....

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

29.10.2010, 23:02 Uhr

Reth
Posts: 1753
Nutzer
Zitat:
Original von AmigaHarry:
Es muss bei dir was mit dem Aktivieren des CD-Einganges am Board haben. Unter MOS (2.6) ist dazu nicht einmal der Mixer nötig - das Signal wird standartmäßig durchgereicht.....


Muss man dann ggf. noch was in der OF oder dem AOS4-Kickstart-Setup setzen/einstellen?

[ - Antworten - Zitieren - Direktlink - ]

30.10.2010, 00:09 Uhr

AmigaHarry
Posts: 1642
Nutzer
In der OF wüsste ich nichts.....möglicherweise was bei der OS4-Startup...das wissen andere aber villeicht besser. Als ich OS4 noch auf einem meiner PEG drauf hatte habe ich das mit dem direkten Abspielen leider nie probiert......

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

30.10.2010, 00:53 Uhr

Reth
Posts: 1753
Nutzer
Also Mixer hat schon mal nicht geholfen!

[ - Antworten - Zitieren - Direktlink - ]

30.10.2010, 09:03 Uhr

ZeroG
Posts: 1482
Nutzer
@Reth:
Könntest du jetzt vielleicht erst mal (vielleicht an einem anderen Rechner) testen ob das Laufwerk überhaupt ein direktes abspielen von CDDA unterstützt?

Gerade du als OS4-BT solltest doch wissen das es (abgesehen vom Mixer und den Lautstärken in AHI) keine möglichkeit mehr gibt da irgendwas softwareseitig falsch zu machen, so lange man PlayCD und Co das richtige Device/Unit vorgibt.

[ - Antworten - Zitieren - Direktlink - ]

30.10.2010, 09:53 Uhr

Reth
Posts: 1753
Nutzer
@ZeroG:

Mir gehts hier auch nicht um AOS4 oder Betatest oder Software-Einstellungen! Mir gehts generell darum, das zum Laufen zu bekommen! Vielleicht ist es ja auch ein Hardware bzw. OF-Problem! Oder vielleicht muss ich noch nen 2. Audio-Ausgang an die Lautsprecher anschließen?
Kann ich das CD-Audio-Kabel denn auch an einen der anderen Eingänge des PegII-Board anschließen (AUX o.ä.)?

Als Device hab ich bei PlaCD CD0 eingestellt (wenn ich USEAHI aktiviere funktioniert es natürlich). Allerdings geht CDDA auch nicht z.B. bei Spielen wie The Shadow of the third moon!

Die Möglichkeit zum Testen an einem anderen Rechner hab ich leider nicht!

[ - Antworten - Zitieren - Direktlink - ]

30.10.2010, 11:25 Uhr

Reth
Posts: 1753
Nutzer
OK. Liegt wohl am Laufwerk! Hab bei LG nun ein Manual gefunden. Dort ist bei einem Screenshot der Hinweis gegeben, das die beiden Anschlüsse (für CDDA und wohl digital audio out nicht unterstützt sind - LW: GH22NP20)!

Vielen Dank nochmals!

[ - Antworten - Zitieren - Direktlink - ]

31.10.2010, 09:36 Uhr

Reth
Posts: 1753
Nutzer
Gibt es denn einen Software-Bypass, der es ermöglicht die Tracks im Rahmen der alten Spiele dennoch zu hören (einige Games sind ohne Hintergrundmusik nur halb so toll, z.B. Shadow of the third moon verliert stark an Atmosphere!)?

[ - Antworten - Zitieren - Direktlink - ]

31.10.2010, 12:27 Uhr

ZeroG
Posts: 1482
Nutzer
@Reth:
Nicht das ich wüsste.
Falls eine externe Library (cdplayer.library oder so) von den Spielen benutzt wird könnte man, mit einigem Aufwand, vielleicht eine Ersatzlibrary schreiben die das ganze per AHI abspielt. Das funktioniert natürlich nur bei Spielen die im Multitasking laufen, AHI nicht für andere Programme sperren und nicht selber versuchen die CDDA Tracks abzuspielen. Da rächt sich die abwesenheit einer offiziellen API unter AOS zu diesem Zweck.

Bei UAE könnte man die SCSI-Befehle abfangen und das ganze hinbiegen wie man möchte.

[ - Antworten - Zitieren - Direktlink - ]

31.10.2010, 12:28 Uhr

whose
Posts: 2156
Nutzer
Zitat:
Original von Reth:
Gibt es denn einen Software-Bypass, der es ermöglicht die Tracks im Rahmen der alten Spiele dennoch zu hören (einige Games sind ohne Hintergrundmusik nur halb so toll, z.B. Shadow of the third moon verliert stark an Atmosphere!)?


Es gibt einen denkbaren... mir ist aber nichts davon bekannt, daß der jemals in Software gegossen wurde.

Denkbar wäre, das entsprechende Device so zu patchen, daß es, mit Hilfe einer weiteren Software, die Audio-Kommandos emuliert. Dies wiederum über den Umweg des direkten Lesens von CDDA und Ausgabe via Soundkarte/Paula.

Wie gesagt, mir ist nicht bekannt, daß sowas jemals versucht wurde.

Wenn es Dir allerdings "gut genug" ist, die Tracks einfach nur zu hören:

PlayCDDA.

Solange die Spiele das Multitasking nicht lahmlegen funktioniert das. Auch parallel zu Lesevorgängen.
--
---

:boing: µA1 PPC 750GX-800
:boing: A4000 PPC 604e-233

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > PegasosII CD Audio - Wie? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.