amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > HD-REC [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

08.02.2012, 15:26 Uhr

appleus
Posts: 13
Nutzer
Hallo zusammen

Ich besitze zwar schon lange einen Account bei diesem Forum,
benutze ihn aber jetzt zum 1ten mal :)

Nun, ich habe mir nach langjähriger A-Pause wieder einen Amiga -SAM460ex +OS4.1 angeschafft und möchte diesen für folgender Zweck einsetzen.

Ich spiele E-Bass und will die gespielte Bass- Spur aufnehmen.
Ich habe dazu zwei Programme in 1ter Wahl:

- HD-REC
- Audio Evolution 4

Da mir aber "HD-REC" eher zusagt, möchte ich die Bassaufnahmen mit diesem Programm verwirklichen. Auch wäre ein Synthesizer für später geplant.

Nun meine Frage.
Kann ich den E-Bass über einen herkömmlichen USB- Audiobox anschliessen? Wird das Gerät über die USB Schnittstelle erkannt?

Ich habe diese Box im Auge:

"Presonus Audiobox USB"

Ich habe gesehen, dass bei OS4Depot der CAMD driver for USB in einer neueren Version erhältlich ist. Brauch ich diesen, oder ist der schon in der Version Amiga4.1 enthalten.

--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

09.02.2012, 13:36 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Hm, ich habe kein OS4, aber ich kann dir etwas antworten:

HD-Rec nutzt AHI zur Aufnahme. Wenn es also einen AHI Treiber gibt, dann kann man damit aufnehmen. Gleiches gilt für MIDI via CAMD.

Mit HD-Rec kannst du auch den Bass bearbeiten (Schneiden, Compressor, EQ, Effekte etc.) und z.B. als wav exportieren.
Des weiteren kannst du erstmal einen Softsynth wie den Sweeper probieren, vielleicht reicht dir das ja. Der SAM ist zwar nicht der schnellste, aber eine Drum-Spur sollte drin sein.

Softsynths haben riesige Vorteile in der Handhabung.

- speichern alles mit dem Projekt
- sample-exaktes Timing
- kostet nichts
- braucht kein Platz
- kann nicht kaputt gehen
- skaliert mit deiner CPU

--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

09.02.2012, 20:28 Uhr

appleus
Posts: 13
Nutzer
Hallo Wanderer

Erstmal danke für Deine Antwort.

Da ich seit Jahren nicht mehr mit einem Amiga gearbeitet habe, bin ich mir nicht ganz sicher
ob der AHI Treiber im Grundsystem enthalten ist.

Ich habe mir die Audio BOX nun angeschafft und mache am besten den Test :)

Wie ich Deinem Abspann entnehme, bist Du der Entwickler dieser Software (HD-REC).
Machst Du in Zukunft nochmals was daran, oder ist das Projekt für Dich erledigt? Ich finde das Ganze sieht recht professionell aus!
Ich habe das letzte mal so um die 2005 mit einem Amiga gearbeitet und muss sagen, dass sich einiges getan hat ;)

Dies mit dem Sweeper werde ich mir mal durch den Kopf gehen lassen, obwohl ein Gerät langfristig eher meiner Vorstellung entspricht.


--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

09.02.2012, 21:19 Uhr

Blackbird
Posts: 634
Nutzer
@appleus:

Zitat:
Machst Du in Zukunft nochmals was daran, oder ist das Projekt für Dich erledigt?

Das letzte Update kam vor ca 3 Tagen und ist hier zu finden:

HD-Rec Sourceforge

Da ich nicht genau weis was Thilo zur letzten Version genau geändert hat, gehe ich davon aus das es hauptsächlich um den Fix des Menübugs unter OS4 ging...
--
regards
Blackbird

PerfectPaint : supportOS4@amiforce.de HP: http://perfectpaint.amiforce.de/
Have also a look at my personal Website:
http://www.blackbird-net.de

[ - Antworten - Zitieren - Direktlink - ]

09.02.2012, 22:46 Uhr

appleus
Posts: 13
Nutzer
Danke Blackbird für den Link.

Sobald ich mein System habe, teste ich mal diese Version.
..wäre der Hammer, wenn das ganze so funktioniert wie ich mir das vorstelle. :)
--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

10.02.2012, 13:17 Uhr

AmigaHarry
Posts: 1638
Nutzer
@Thilo (Wanderer): leider funktioniert der Bugtracker nicht, daher versuch ichs über den Weg hier:


Fehlermeldung HD-REC V0.10 beta auf PEGII-MOS2.7 mit Installer installiert:

1. "TBImages not found". Es öffnet der manuelle Assign-Requester. Ein Assign aufs HDREC - Hauptverzeichnis nützt nicht....

2. Es folgen unzählige "file_open: Unable to read TBImages:xxxxx" Fehlermeldungen..

Konnte die TBimages nirgends im Download oder deiner Homepage finden.......

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

10.02.2012, 13:39 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Ja, habe ich auch gemerkt. TBImages: ist der Assign von AISS.
Man sollte den nicht wahllos auf irgendein Verzeichnis setzen, in dem AISS gar nicht installiert ist. Wenn man das ablehnt, dann startet HD-Rec mit den eigenen Grafiken.
Ich muss den Requester noch unterdrücken.

Wenn AISS installiert ist, werden die AISS Bilder genutzt.

--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

11.02.2012, 10:17 Uhr

AmigaHarry
Posts: 1638
Nutzer
Danke!
Werde mir mal AISS runterladen......

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

11.02.2012, 14:05 Uhr

AmigaHarry
Posts: 1638
Nutzer
AISS aus dem Aminet installiert, ist aber zu wenig - es wird das Packet von Mason (Icons) auch benötigt. Danach startet HDREC erst einmal und meldet sich gleich mit einem Requester bez. fehlerhafter AHI-Installation (Bild). Die Installation ist aber OK. Jegliche Änderungen im HDREC-Prefs-Requester für AHI führen zum sofortigen Totalabsturz. Ohne die AHI-Prefs aufzurufen kann man zwar Tracks laden und auch bearbeiten, aber nicht abspielen (vermutl. wegen des AHI-Problems)......


http://www.myimg.de/?img=b1f9480.jpg

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

11.02.2012, 18:05 Uhr

o.eschi
Posts: 984
Nutzer
Hab hier unter MorphOS das gleiche Problem! Das AISS Problem habe ich erstmal über das Config File aus dem Weg geräumt, aber das wird ja vermutlich eh noch gefixt.
--
Amiga User Rheinland
Sachberichte für Landschaftsgärtner

[ - Antworten - Zitieren - Direktlink - ]

11.02.2012, 20:09 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Der DOS Requster hat übrigends auch einen "Abbrechen" Button. Den sollte man drücken, wenn man kein AISS installiert hat.

Die Abfrage ob AISS installiert ist habe ich so geändert, dass sie keinen Requester mehr verursacht. Kommt im nächsten Update.
Trotzdem kann ich natürlich AISS nur empfehlen, gefällt mir mittlerweile besser als meine eigenen Grafiken.

Das mit AHI ist sehr wahrscheinlich ein Bug im Treiber, nicht in HD-Rec, deshalb kommt ja der Requester mit dem Text der darauf hinweist. Da hat der Author des Treibers vergessen, die Anzahl der Bytes des Buffers (hier 8000) durch die Sample-Frame Größe zu teilen (hier 4).


--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ Dieser Beitrag wurde von Der_Wanderer am 11.02.2012 um 20:11 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

11.02.2012, 21:10 Uhr

AmigaHarry
Posts: 1638
Nutzer
@Der_Wanderer:

Hmm...der Treiber ist ja in MOS selbst integriert (bzw. in der Distribution gebündelt) - müsste sich da dann nicht das MOS-Team darum kümmern? Soweit ich weis stammt die Version von Martin Blom, oder?

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

11.02.2012, 21:31 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Ist das der Emu10K Treiber? Der sollte eigentlich funktionieren.

Auf jeden Fall sollte es funktionieren, wenn man das Recording abstellt in den HD-Rec Prefs. (wenn das nicht geht, kann man die Config editieren und "ahi_on = 0" stellen.

Wo genau stürzt das ganze denn ab?

Wenn die oben besagte Meldung kommt, dann wurde AHI bereits initialisiert. Der Requester kommt, wenn die RecFunc nicht den Wert übergeben bekommt, mit dem sie eingerichtet wurde. Der Requester hat historische Gründe weil genau der Fehler auch früher im WinUAE AHI Treiber war.
Die 8000 vs. 2000 in dem Requester sehen sehr verdächtig aus, weil 2000x4 bytes = 8000 sind, d.h. Bytelänge wurde mit Samplelänger verwechselt. HD-Rec macht das bestimmt nicht falsch, sonst würde man auf allen anderen Systemen auch Fehlermeldungen bekommen.


--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

12.02.2012, 10:52 Uhr

AmigaHarry
Posts: 1638
Nutzer
Nachdem ich heute den PEG neu aufgedreht habe, wollte er HDREC überhaupt nur bis zur MIDI-Initialisierung hochfahren. Nachdem ich im Configfile Midi=0 gesetzt habe, startet er wieder wie Gestern bis zum AHI-Erorrequester. Dieser tritt auf wenn "Update Midi views" angezeigt wird. Danach kommt de HDREC-Oberfläche. Schließt man HDREC dann wieder, stürzt es bei "Closing AHI...."
Kann man im Configfile einen AHI-Mode vorgeben? (Hexcode?)

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

12.02.2012, 11:08 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Du kannst auch AHI ausschalten, oder einen Code vergeben, allerdings sollte der dezimal sein oder bei hex ein "$" vorne dran. 0 ist der default AHI modus. Du kannst aber AHI ausschalten, dann solltest du in den HD-Rec Prefs den Modus bequem auswählen können.

!! Allerdings ist das nicht das Problem was du hast. !!

Egal welcher AHI Modus, wenn es der gleiche Treiber ist, wird es nicht funktionieren. Du solltest das Recording (rec_wanted=0) ausstellen. Dann gibt es keinen Memtrash mehr und keine Crashs deshalb.

ahi_on=1
ahi_mode=0
rec_wanted=0

Der Crash beim Exit ist vermutlich eine Folge von Memtrash wegen den 8000 vs. 2000. Das solltest du dem Author des Treibers melden. Um welchen Treiber handelt es sich denn nun, oder das der emu10k von Martin oder was anderes?

Wenn CAMD nicht geht, hast du vermutlich nicht die richtige camd.library. Die original von Commodore funktioniert unter MOS nicht. Es gibt diverse Replacement Libs für MOS, von denen allerdings nur eine funktioniert, der Rest ist Müll.
Versuche mal die CAMD library im Contributions Verzeichnis für MOS.
Wenn die nicht geht, sollte ich sie aus dem Archive entfernen. Ich kann das leider nicht testen.



--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ Dieser Beitrag wurde von Der_Wanderer am 12.02.2012 um 11:18 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.02.2012, 11:27 Uhr

AmigaHarry
Posts: 1638
Nutzer
Habe jetzt folgendes gemacht: bei ahi-mode einfach den Dezimalwert meines AHI-Modes (Pegasos 16Bit stereo Hifi++) ins Pref-file eingegeben, Ahi aktiviert und HDREC hat durchgestartet!!!
Da er diesen Mode aber nicht kannte, musste ich ihn in den PREFS dann direkt nochmal auswählen - er hat dann im Prefs-file den richtigen Wert eingesetzt - allerdings scheint mir der nicht zu stimmen - ich kann keine Entsprechung dazu bei den AHI-Modenummern finden...aber jetzt sehe ich auch die Zeitmarke übers Sample wandern, habe jedoch noch keinen Ton (hab auch andere AHI-Modi probiert.....)

Die von mir verwendete camd.library ist die 40.4 (dieselbe wie in deinem Archiv) - und die geht nicht......(aber die ging schon unter HDREC-light nicht....)

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 09:34 Uhr

appleus
Posts: 13
Nutzer
Mir ist gerade etwas durch den Kopf gegangen.. :rotate:

Kann mit "HD-REC" eigendlich eine Tabulatur- Datei eigelesen werden?
Da ich im Moment noch unter Mac OSX arbeite und zur Tabulaturen- bearbeitung das Programm GuitarPro benutze, wäre ein selbiges auch unter AmigaOS interessant, aber nicht unbedingt notwendig.

Ich kenne das HD-REC sehr schlecht, da ich es 2005/6 nur kurz angesehen habe.


--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 10:08 Uhr

Der_Wanderer
Posts: 1229
Nutzer
Meinst du sowas:

code:
e|-------------0---1-0------------------------------------------
h|------1---3-----------3---0--------0--1---------------0-------
G|---2--2------0--------0------0---2----2---2--2---1-2------1---
D|-----------------------------0-------------------------------2
A|------0------3------------------------0------0----------------
E|----------------------3------3------------------------0-------

--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 10:11 Uhr

appleus
Posts: 13
Nutzer
..ja genau.
..wäre toll, wenn das gehen würde. :)
--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 10:21 Uhr

appleus
Posts: 13
Nutzer
Ok, dass "HD-REC" GuitarPro Dateien nicht einlesen kann ist mir klar..ich kann die GuitarPro Dateien (das sind MIDI Dateien im GuitarPro Fromat) als MIDI exportieren..wenn das dann "HD-REC" einlesen könnte (was eigendlich gehen sollte) und ich eine Tabalaturen- Ansicht hätte (Editor innerhalb "HD-REC") wäre das mehr als nur genug.
--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 19:49 Uhr

AmigaHarry
Posts: 1638
Nutzer
Habe HDREC jetzt auf einem anderen Pegasos installiert - und siehe da, nach der Prozedur mit dem AHI-Mode läuft es jetzt mit Ton! Jetzt muss ich nur noch rausfinden was an dem anderen PEG und EFIKA anders ist.....

Übrigends: Es genügt irgendeine Zahl abweichend von 0 im Prefsfile bei AHI-Mode einzugeben um den Absturz beim Aufruf der Prefs zu vermeiden.....

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

04.03.2012, 15:13 Uhr

appleus
Posts: 13
Nutzer
Nun, ich habe das System erhalten und HD-Rec installiert.

HD-REC meldet beim starten, dass ihm noch folgende Lib's fehlen.

1. mpega.library
2. ptplay.library
3. wizard.library (kann ich niergens finden)
4. zlib.library

..wo kommen diese Library hin..direkt unter LIBS:?

AudioEvolution 4 stürzt bei mir grössten Teil's ab! ?(

Hat jemand von Euch HD-REC auf einem Amiga OS4 Up4 am laufen?


--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

04.03.2012, 15:18 Uhr

Polluks
Posts: 89
Nutzer
@appleus:
Beispielsweise hier http://aminet.net/package/biz/haage/StormC_WizLib
--
Pegasos II G4, MorphOS 2.7, Zalman M220W
Power Mac G3, OSX 10.3

[ - Antworten - Zitieren - Direktlink - ]

04.03.2012, 16:03 Uhr

Maja
Posts: 15429
Nutzer
Zitat:
Original von appleus:
"Presonus Audiobox USB"


Dazu ein Erfahrungsbericht: http://www.musiker-board.de/soundkarten-interfaces-preamps-rec/311559-presonus-audiobox-usb-erfahrungsbericht.html
--
** Alkohol und Nikotin rafft die halbe Menscheit hin. Ohne Schnaps und ohne Rauch stirbt die andre Hälfte auch. **

[ - Antworten - Zitieren - Direktlink - ]

04.03.2012, 16:22 Uhr

appleus
Posts: 13
Nutzer
Danke :)

..gut, habe jetzt fast alles :)
..bis auf die "ptplay.library und zlib.library!

@Maya

Danke für den Link.
Ich habe mir die Box angeschafft, dem Bericht aber kann ich jetzt nicht zustimmen.
Die Box läuft unter Mac OSX mit GarageBand tadellos ;)

..auch die Bass- Aufnahmen funktionieren.

Meine schwierigkeit ist jetzt mal "HD-REC" unter OS4.1 zum laufen zu bringen.




--
liebe Grüsse
appleus;-)

[ - Antworten - Zitieren - Direktlink - ]

04.03.2012, 16:29 Uhr

Maja
Posts: 15429
Nutzer
@appleus:

Danke. Gut zu wissen.
--
** Alkohol und Nikotin rafft die halbe Menscheit hin. Ohne Schnaps und ohne Rauch stirbt die andre Hälfte auch. **

[ - Antworten - Zitieren - Direktlink - ]

04.03.2012, 16:52 Uhr

cgutjahr
Posts: 2615
[Administrator]
Zitat:
Original von appleus:
..gut, habe jetzt fast alles :)
..bis auf die "ptplay.library und zlib.library!

http://aminet.net/search.php?query=ptplay
http://aminet.net/package/util/libs/zlibrary

[ - Antworten - Zitieren - Direktlink - ]

06.03.2012, 21:34 Uhr

Der_Wanderer
Posts: 1229
Nutzer
@cgutjahr:
z.library != zlib.library

http://aminet.net/package/util/libs/zlib-library

Die mpega, ptplay sind optional.

camd (für MIDI), zlib (für AISS) werden gebraucht.

wizard.library wird zwar erfragt aber nicht gebraucht.

--
--
Author of
HD-Rec, Sweeper, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, AudioConverter, ScreenCam, PerlinFX, MapEdit, AB3 Includes und viele mehr...
Homepage: http://www.hd-rec.de



[ Dieser Beitrag wurde von Der_Wanderer am 06.03.2012 um 21:34 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > HD-REC [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.