amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > DOSBOX [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

12.02.2012, 20:46 Uhr

AmigaHarry
Posts: 1637
Nutzer
Unterstützt DOSBOX die parallele Schnittstelle des PEG? Bzw. ein USB2Parallel-Kabel?
Wenn ja, wie ist das im Config-File einzutragen? Habe dazu nichts in den Docs gefunden........

--
Life starts at '030, fun at '040, impotence at '86!

[ Dieser Beitrag wurde von AmigaHarry am 12.02.2012 um 20:46 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.02.2012, 22:06 Uhr

cgutjahr
Posts: 2614
[Administrator]
Ich meine Dosbox emuliert die parallele Schnittstelle überhaupt nicht? Serial ja, aber Parallel?

Was genau willst du denn machen?

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 18:04 Uhr

AmigaHarry
Posts: 1637
Nutzer
Ohje - nicht gut. Hab inzwischen gegoogelt - für PC gibts scheinbar gepatchte Versionen, welche auch die parallele Schnittstelle unterstützen......

Ich würde das wegen meines alten TI74 brauchen. Habe für mir für den ein PC-Interface gebaut, welches aber nur über die parallele Schnittstelle geht und nur unter DOS. Zudem kommt es mit modernen PCs (also besser als ein alter 486er...hihi) nicht klar...... bisher hatte ich das an einem uralt Compaq-Schlepptop (75Mhz!) betrieben, der ist aber jetzt entgültig über den Jordan gegangen....


--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 18:19 Uhr

cgutjahr
Posts: 2614
[Administrator]
Zitat:
Original von AmigaHarry:
Ich würde das wegen meines alten TI74 brauchen. Habe für mir für den ein PC-Interface gebaut, welches aber nur über die parallele Schnittstelle geht und nur unter DOS.

Und die Quellen für die Software hast du nicht? Das wäre sonst vermutlich die eleganteste Lösung - ein DOS-Programm zu portieren ist ja kein Hexenwerk.

[ - Antworten - Zitieren - Direktlink - ]

13.02.2012, 20:50 Uhr

Polluks
Posts: 89
Nutzer
@cgutjahr:
Tatsache, der Hexbus ist kein Hexenwerk :D
http://en.wikipedia.org/wiki/Hexbus
--
Pegasos II G4, MorphOS 2.7, Zalman M220W
Power Mac G3, OSX 10.3

[ - Antworten - Zitieren - Direktlink - ]

14.02.2012, 12:54 Uhr

AmigaHarry
Posts: 1637
Nutzer
Werd mal an den Autor in USA schreiben - hatte schon länger keinen Kontakt zu ihm - villeicht rückt er den Quellcode raus......
--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

14.02.2012, 13:55 Uhr

Bladerunner
Posts: 1474
Nutzer
Was spricht gegen Bochs ? Laut Manual wird der ParPort hier wohl unterstützt, mit ein wenig Glück sollte das auch in der MorphOS Version tun.Auch wenn Bochs saulahm ist, für ein altes Dos Programm sollte es reichen.

DosBox ist für sowas imho nicht geeignet, da es sich primär um einen Spiele optimierten Emulator handelt. (Der braucht nun wirklich kein ParPort)
--
Amiga
It's more than just a name :dance1:

[ - Antworten - Zitieren - Direktlink - ]

14.02.2012, 20:44 Uhr

Wolfman
Posts: 3664
Nutzer
@Bladerunner:
/oT

Hi Olli, schön mal wieder von Dir zu lesen

lg

Wolfman
/oT


--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

14.02.2012, 23:17 Uhr

Thore
Posts: 2266
Nutzer
Es gibt ne neuere Vesion von Bochs die etwas schneller ist, eine 2.3.7, mit Special Features (CD Image, bessere Grafikausgabe,...)
Einfach mail an mich. ParPort hab ich noch nicht getestet.

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 18:38 Uhr

AmigaHarry
Posts: 1637
Nutzer
Der Autor des TIIF-(DOS)Programmes möchte den Quellcode leider nicht offen legen......schade!
Damit bleibt auf einem amigoiden System nur der Weg über einen PC-Emulator. Ich werde Bochs mal probieren. Habe mir auch die Bochs-Gui gezogen, die aber augenscheinlich eine uralte Muiklasse benötigt und daher nicht läuft.....(Ich glaube Infotext.mcc oder so ähnlich - hab den Peg nicht hier....)
Soweit ich mitbekommen habe, steuert TIIF den Port direkt an - ich hoffe das geht über einen Emulator überhaupt, da es sich dabei scheinbar um sehr zeitkritische Routinen zur Kommunikation mit dem TI-Hexbus handelt........na, mal sehen......


--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 19:11 Uhr

Thore
Posts: 2266
Nutzer
So hab dir mal eine Version geschickt. Wie gesagt, Par hab ich nicht getestet. Wenns nicht tut, schreib mir, ich kanns dann mal versuchen zu implementieren.

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 20:22 Uhr

AmigaHarry
Posts: 1637
Nutzer
Kann im Moment keine Mails abrufen - melde mich.

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 21:24 Uhr

AmigaHarry
Posts: 1637
Nutzer
@Thore: Bis jetzt habe ich nichts bekommen.......

--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 21:48 Uhr

Thore
Posts: 2266
Nutzer
Seltsam um 9:08 hab ichs gesendet. Es ist allerdings 2,5 MB gepackt. Verweigert Dein Mail Account diese Größe oder lha Archive?
Schau auch mal in deinem Spam Ordner.

[ Dieser Beitrag wurde von Thore am 15.02.2012 um 22:05 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 22:24 Uhr

AmigaHarry
Posts: 1637
Nutzer
Eigenartig - bis jetzt noch nichts. Die Größe ist auch kein Problem......

Es hat aber bis vor kurzem eigenartige Probleme beim Provider gegeben - ich konnte keine Verbindung zum Server bekommne - villeicht ist deine Nachricht im Nirwana gelandet.....


--
Life starts at '030, fun at '040, impotence at '86!

[ Dieser Beitrag wurde von AmigaHarry am 15.02.2012 um 22:26 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

15.02.2012, 22:40 Uhr

Thore
Posts: 2266
Nutzer
Habs nochmal geschickt. Bin mal gespannt

[ - Antworten - Zitieren - Direktlink - ]

16.02.2012, 21:15 Uhr

AmigaHarry
Posts: 1637
Nutzer
Jetzt ist es angekommen - gleich mehrmals! War wohl wirklich ein Providerproblem. Sehe mir bochs am WOE an......
--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

17.02.2012, 19:44 Uhr

Thore
Posts: 2266
Nutzer
Kommst du mit bochs klar oder brauchst du eine kurze Einweisung? Ich hab die Original Config und meine Test-Config mitgeschickt. Einfach da bei den Festplatten dein Image hinzufügen, und als CD dein Laufwerk oder eine Image Datei angeben.

[ - Antworten - Zitieren - Direktlink - ]

17.02.2012, 20:00 Uhr

AmigaHarry
Posts: 1637
Nutzer
Bin noch nicht dazugekommen - muss mich erst durch das conf-file wühlen - kenne Bochs zwar, hab aber noch nie was damit gemacht......gibts nur die Anleitung im Archiv?

Zudem hab ich mit dem Interface zum TI74 momentan Probleme - teste es gerade an einer alten Dose - es wird erkannt, aber der TI74 stürzt bei Zugriff ab...und ich habe keinen Tau warum plötzlich.....denkbar schlechte Voraussetzungen für einen Versuch mit Bochs.......
--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

17.02.2012, 20:13 Uhr

Thore
Posts: 2266
Nutzer
Ich hab das Config File für meine Bedürftnisse angepasst, es sollte reichen einfach die Medien anzupassen (ata0, CD, Disks...)


[ - Antworten - Zitieren - Direktlink - ]

19.02.2012, 19:27 Uhr

AmigaHarry
Posts: 1637
Nutzer
@Thore: Ich kann leider noch nichts zu deiner Bochs-Version sagen, da ich momentan das TI-Interface nicht zum Laufen bekomme. Zur Erklärung: Der PC hängt an dem Interface als reiner "dummer" Slave bzw. als eine Art Massenspeicher - gesteuert wird komplett vom TI-74 aus (auch die Programmfunktionen am PC!). Problem dabei: Die parallele Schnittstelle zum PC braucht ein genaues Timing, da der Hex-Bus + Interface "starr" gekoppelt sind und das ist (leider wie früher öfter üblich) über Programmschleifen kalibriert.... tollerweise verhält sich jede CPU/Motherboard anders - mit dem alten, abgerauchten 486 gings noch, der ebenso uralte PentiumII (75Mhz) leider nicht mehr. Ich muss jetzt erst einmal die richtigen Timing-Parameter finden, um sicher zu gehen das das Interface 100%ig OK ist - sonst brauche ich mit Bochs gleich gar nicht anfangen......
Abgesehen davon wird dann die Parametersuche über Bochs beginnen.....brrr!
--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > DOSBOX [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.