amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Lohnt eine SSD im Peg2? Wenn ja: Welcher + Welcher Controller? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

18.04.2012, 12:05 Uhr

Reth
Posts: 1757
Nutzer
Hallo zusammen,

da mir leider meine 2. IDE-Platte abgeraucht ist und ich gern ein Extramedium für Downloads + Backups etc. hätte frage ich mich gerade, was die bessere Variante wäre:
  • Normale IDE-Platte am internen Anschluss des Peg2
  • SSD via extra PCI Controller (womit die derzeit andere verbliebene Systemplatte z.T. für die eingangs genannten Aufgaben fungieren wird
?

Das Haupt-OS soll dabei AOS4 sein. Wäre natürlich schön, wenn die Hardware auch unter MOS funktionieren würde (bei internem IDE-Anschluss ja kein Problem).

Wie ist hier euer Erfahrungsstand? Bringt denn SSD via PCI (z.B. SATA) etwas gegenüber den internen IDE-Schnittstellen im Sinne von Übertragungsgeschwindigkeit und im Hinblick auf das insgesamt entstehende Kosten-/Nutzenverhältnis (dass SSDs schneller im Zugriff sind als komventionelle Platten ist mir bekannt)?
Falls eine SSD eurer Meinung nach empfehlenswerter ist, welchen PCI-Controller muss man dann erstehen, damit es unter AOS4 (und möglichst auch MOS) funktioniert? Weiss nicht, wie zuverlässig und aktuell die AOS4-Hardware-Kompatibilitätslisten sind, die ich bisher gefunden habe.

Danke schon mal!

Ciao

[ Dieser Beitrag wurde von Reth am 18.04.2012 um 12:22 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

18.04.2012, 12:43 Uhr

ZeroG
Posts: 1482
Nutzer
@Reth:
Der begrenzende Faktor ist der Bus des Peg2, eine normale Platte reicht.

Was die unterstützung der Controllerkarten von OS4 Seite angeht: Guck ins Verzeichnis SYS:Documentation/IDE/ darin sind die Anleitungen für alle verfügbaren Treiber sammt Chipsatzbezeichnung. Von welchen der peg2 das Kickstart lesen kann weiß ich nicht, wahrscheinlich sinds nicht alle.

[ - Antworten - Zitieren - Direktlink - ]

18.04.2012, 12:58 Uhr

geit
Posts: 332
[Ex-Mitglied]
SATA bringt nichts, außer dem günstigeren Preis und der einfach Beschaffung von Platten.

Der Platten-Speed ist auf allen allen Amiganoiden Systemen komplett Wurst und fällt nur bei größeren Dateien auf, wie z.B. OWB mit seinen >50MB. Wenn man sich die anderen Dateien ansieht, dann sind die meist deutlich kleiner als 100KB. Bei 45MB/s die der Kontroller in etwa schafft, kann man sich die Millisekunden ausrechnen, die das ausmacht. Das bemerkt man faktisch nicht, da die Suche der vielen kleinen Dateien x mal länger dauert als das Laden selbst.

Deshalb beschleuigt *JEDE* noch so günstige SSD jedes Amiganoide System rapide. Wenn man sich die Datenblätter der SSDs ansieht, ist der Speed meist mindestens 3 bis 4 mal höher als der Pegasos überhaupt kann.

Wenn es ne große SSD sein soll, dann einfach zu einem 120GB Model für 120 Euro greifen. Einen IDE->2xSATA (Version Mainboard ->stehend, etwa 10 Euro) gibt es für ein paar Euro bei Ebay. Schon hat man 2 SATA Anschlüsse und kann die SSD einbauen und eine Platte als Speicher für Filme/Musik etc parallel klemmen. An den zweiten IDE kann man CDROM und die alte Platte hängen, wenn man will.

Günstiger kommt ein IDE->2xCF Card Adapter (Version Mainboard stehend, etwa 10 Euro). Dort steckt man eine (oder zwei) CF Karte eines namhaften Anbieters ein. Ich benutze seit 2 Jahren Transcend Karten. Die geben auch 3 Jahre Garantie. Billige Karten sollte man vermeiden, weil die oft kein (U)DMA können, sich nicht als Festplatte zu erkennen geben oder schnell den Geist aufgeben. Hama schreibt zum Beispiel gerne "Highspeed" auf die Verpackung von Karten die satte 6MB/s schaffen. Die Karten (hier sollte man nicht unter 400x (ca. 45MB/s) gehen) kosten derzeit etwa 8 GB 35 Euro, 16GB 50 Euro. Ab 32 GB sollte man mit herkömmlichen SSDs vergleichen und abwägen, da hier der Preis ansteigt. Bei 64GB liegt man schon bei 130 Euro und dafür bekommt man eine 120GB SSD. Allerdings auch jede Menge Kabelgewurstel. Ich komme hier mit einer 16GB Karte locker aus. Musik und Filme sollte man natürlich extern (andere Platte, NAS) lagern.

Der Peg bootet MorphOS in etwa einer Sekunde. Die Festplatte legt sich nach einer weile Schlafen und das System ist lautlos. Eine Defragmentierung der Systemplatte braucht man auch nicht mehr zu machen und alles bleibt immer gleich schnell. Die Geschwindigkeit kommt nicht von der Kartengeschwindigkeit. Das trifft nur bei großen Dateien (MPlayer,OWB) zu. Der echte Speed kommt daher, dass die SSD keine Köpfe bewegen und darauf warten muß, dass die richtigen Sektoren vorbeikommen. Speziell auf unseren Systemen mit vielen kleinen Icons, Libraries, Fonts, Configfiles und Shell Kommandos bringt das richtig was. Selbst eine SSD die nur 22MB/s schafft, bootet den Rechner deutlich schneller als die schnellste Platte. Das ist Fakt. Das es nur 22MB/s sind merkt man dann nur bei großen Dateien jenseits der 10MB.

Ich nutze jetzt schon mindestens zwei Jahre CF ausschließlich CF als Medium im Peg2. Es gab nie Probleme und wenn man das System nach dem Umstieg von einer Festplatte das erste Mal startet, hat man das Gefühl eine Turbokarte eingebaut zu haben. Alles startet noch schneller und ist wirklich sofort da. Wo CubicIDE vorher noch Sekundenlang gerödelt hat, poppt es jetzt sofort auf. Besser geht es nicht.

Auch wenn Dateisysteme nicht für SSD optimiert sind, ist das für mich die einzige Lösung die noch in Frage kommt. Festplatten will ich nicht mehr.

Geit


[ Dieser Beitrag wurde von geit am 18.04.2012 um 13:14 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

18.04.2012, 13:17 Uhr

Reth
Posts: 1757
Nutzer
Super! Dank euch für die Antworten!

@geit:
Wenn ich das richtig verstehe reicht ein auf den internen IDE gesteckter Adapter, um von SATA-SSDs oder CF-Karten booten und auf diese zugreifen zu können?

Ist CF eigentlich nochmal schneller als SSD?

Vorgeschwebt hatte mir ne 120GB SSD, damit ich alles, was viel Zugriff braucht dort ablegen kann (System, Spiele, GCC, Subversion, AAMP, weitere Anwendungen, ...).

Ciao

[ - Antworten - Zitieren - Direktlink - ]

18.04.2012, 13:39 Uhr

geit
Posts: 332
[Ex-Mitglied]
Zitat:
Original von Reth:
Wenn ich das richtig verstehe reicht ein auf den internen IDE gesteckter Adapter, um von SATA-SSDs oder CF-Karten booten und auf diese zugreifen zu können?


Ja, die Adapter benötigen aber noch einen Stromanschluß. Das ist in der Regel der Floppystecker, der sowieso brach liegt. Der CF Adapter braucht ihn, um die Karten zu versorgen und der SATA Adapter um seine Elektronik mit Strom zu versorgen.

Die SATA Lösung kann sehr unschön werden, weil man in der Regel keine SATA-Strom Anschlüsse am Peg Netzteil hat. Da ist der Vorteil der kleineren SATA Kabel verglichen mit IDE schnell weg. Mit einem SATA Kompatiblen Netzteil kann man ohne zusatzadapter den Strom an die Platte bekommen und das ganze sauber aufbauen.

Hier ein IDE->2CF Adapter. Die gibt es auch für die Montage am Kabel, aber ich bin kein Freund von Kabeln.

http://www.ebay.de/itm/Dual-IDE-ATA-2xCompactFlash-CF-Converter-LED-w4W-/350474474366?pt=DE_Technik_Computerzubeh%C3%B6r_Kabel_Adapter&hash=item5199e8137e

Bei den IDE->SATA muß man aufpassen. Es gibt viele Adapter die sich Dual nennen und auch zwei SATA Anschlüsse haben, aber das Dual bezieht sich auf die Richtung. Das heißt man kann den Adapter an ein IDE-CDROM anklemmen und hat ein SATA-CDROM oder man steckt ihn auf ein Mainboard und hat einen (!!) SATA Anschuß auf dem Mainboard. Der IDE-Slave ist somit verschwendet. Das will man nicht wirklich.

Lindy hat einen guten im Programm, der aus einem kompletten IDE Port zwei SATAs macht. Da ist man auf der sicheren Seite, bezahlt aber auch 20 Euro. Bei EBay muß man suchen und der Aussage der Händler vertrauen.


Zitat:
Original von Reth:
Ist CF eigentlich nochmal schneller als SSD?


Nein, der CF Anschluss *IST* IDE mit einem anderen Stecker. Die Adapter sind wirklich nur Adapter und komplett ohne elektonische Bauteile. Da kann also auch nichts kaputt gehen. Die haben meist noch eine LED drauf, die die Kartenaktivität über einen Transistor vom IDE Bus abgreift, wie es das Mainboard auch bei der Gehäuselampe macht. Das ist aber schon alles.

Geit

[ Dieser Beitrag wurde von geit am 18.04.2012 um 13:50 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

18.04.2012, 15:14 Uhr

Reth
Posts: 1757
Nutzer
@geit:
Danke!

Zitat:
Original von geit:
Bei den IDE->SATA muß man aufpassen. Es gibt viele Adapter die sich Dual nennen und auch zwei SATA Anschlüsse haben, aber das Dual bezieht sich auf die Richtung. Das heißt man kann den Adapter an ein IDE-CDROM anklemmen und hat ein SATA-CDROM oder man steckt ihn auf ein Mainboard und hat einen (!!) SATA Anschuß auf dem Mainboard. Der IDE-Slave ist somit verschwendet. Das will man nicht wirklich.

Lindy hat einen guten im Programm, der aus einem kompletten IDE Port zwei SATAs macht. Da ist man auf der sicheren Seite, bezahlt aber auch 20 Euro. Bei EBay muß man suchen und der Aussage der Händler vertrauen.

Woran kann man denn bei vorhandenem Adapter zuverlässig erkennen, ob er wirklich Dual ist und den IDE-Slave nicht verschwendet? Mal das Gerät an beiden Ausgängen des Adapters anschließen und sehen, ob es tut (bei Online-Bestellungen kann man ja 14 Tage zurück geben und bei "falschen" Angaben auch umtauschen)?

Und noch eine Frage: Habe mal nach SSDs gesucht und nach deren Bewertungen. Da findet man ja mehr Schlechtes als Gutes, was die dauerhafte Nutzbarkeit anbelangt. Auch was Aussetzer u.ä. anbelangt. Da scheint es wohl nicht zu viele Unterschiede zw. NoName und Markenhersteller zu geben.
Da die Platte eh in den Peg2 soll muss sie eigentlich nur funktionieren (also erkannt und genutzt werden können). Das aber zuverlässig. Habt ihr gute Empfehlungen für eine 128GB SSD?

Danke schon mal!

[ Dieser Beitrag wurde von Reth am 19.04.2012 um 00:21 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

19.04.2012, 11:07 Uhr

geit
Posts: 332
[Ex-Mitglied]
Zitat:
Original von Reth:

Woran kann man denn bei vorhandenem Adapter zuverlässig erkennen, ob er wirklich Dual ist und den IDE-Slave nicht verschwendet? Mal das Gerät an beiden Ausgängen des Adapters anschließen und sehen, ob es tut (bei Online-Bestellungen kann man ja 14 Tage zurück geben und bei "falschen" Angaben auch umtauschen)?


Nein, die sehen identisch aus. Es sind sogar Modelle im Handel, die zwar 2 SATA anbieten, aber diese müssen zwingend Festplatten sein.SATA CDROMs funktionieren nicht.

Zitat:
Original von Reth:
Und noch eine Frage: Habe mal nach SSDs gesucht und nach deren Bewertungen. Da findet man ja mehr Schlechtes als Gutes, was die dauerhafte Nutzbarkeit anbelangt. Auch was Aussetzer u.ä. anbelangt. Da scheint es wohl nicht zu viele Unterschiede zw. NoName und Markenhersteller zu geben.
Da die Platte eh in den Peg2 soll muss sie eigentlich nur funktionieren (also erkannt und genutzt werden können). Das aber zuverlässig. Habt ihr gute Empfehlungen für eine 128GB SSD?


Klar hast du nur schlechtes gehört, weil diese Bewertungen meistens nur die schlechten enthalten. Bei der ersten Generation gab es Probleme mit Datenverlusten bei einigen Kontrollern. Da gab es dann aber Firmwareupdates. Einige SSDs hatten auch Probleme mit dem Trim-Support. Verglichen mit Festplatten ist das aber nix. Auch da gab es immer wieder Serien die schlicht weg Schrott waren und nach 6 Monaten abgeraucht sind. Alle aktuellen Versionen haben einen von nur wenigen Kontrollertypen (meistens Sandforce) an Bord.

Wenn man sich da nur vorstellt von welchen Dingen es abhängt, das die Daten nach dem Einschalten des Rechners noch da sind, wenn man eine Festplatte verwendet, dann schlafe ich deutlich ruhiger seit ich Flash nutze. Die Motoren müssen anlaufen, die Köpfe müssen sich bewegen und präzise ihre Position über der Datenspur finden. Die Daten auf der Scheibe müssen lesbar sein und keine mechanische Beschädigung haben, weil jemand an den Tisch gestoßen ist. Das setzt natürlich vorraus, das der Laufwerkskopf den Stoß überlebt hat.

Wer einmal mit einer Bohrmaschine ein 10mm Loch in ein Rechnergehäuse gebohrt hat, während der Rechner läuft, der weiß das es gut ist eine SSD zu verwenden. Ich habe letzteres mit einer CF für meinen Spielautomaten gemacht, weil ich den bereits mehrstündig laufenden thermalen Dauertestlauf nicht unterbrechen wollte. Das ist ein komisches Gefühl, wenn das Gehäuse des laufenden Rechners auf dem Tisch herumvibriert, während man das sich bewegende Bild auf dem Bildschirm sieht.

Oder auf Meetings, wenn jemand seinen Mac mini mit schwung anhebt, um jemanden die Unterseite zu zeigen. Im ersten Moment denkt man nur "Oh Gott, die Platte!" und im zweiten Moment die Erklärung kommt: "Nicht schlimm, ist ne SSD drin!"

Wenn es für 120 Euro 1TB Flashlaufwerke gibt, dann sind Festplatten hier sofort Geschichte.

Geit

[ - Antworten - Zitieren - Direktlink - ]

19.04.2012, 15:41 Uhr

Reth
Posts: 1757
Nutzer
@geit:
Deiner Antwort entnehme ich, dass es relativ egal ist, ob man eine günstige oder teurere SSD nimmt?

Mit Festplatten hatte ich bzgl. ihrer Mechanik bisher nur positive Erfahrungen (mit Ausnahme der alten Laptopplatte, die nun ihre Funktion nicht mehr wahrnehmen kann).

Habe nach Rückfragen zumindest von einem Händler die Bestätigung bekommen, dass man an diesen Adapter von Delock 2 SATA-Geräte am IDE Port betreiben können soll.
Vielleicht werd ich den nehmen (wenn das auf Amazon der gleiche ist, dort sind auch schon ein paar Kabel dabei und die fehlenden kann ich gleich dazu bestellen).

[ - Antworten - Zitieren - Direktlink - ]

21.04.2012, 17:40 Uhr

Reth
Posts: 1757
Nutzer
So, die Sachen sind bestellt. Hab nun einen Adapter von InLine bestellt.

Eine Laienfrage noch: Wie bekommt man denn so ne SSD in den klassischen Einbauvorrichtungen eines Midi-Towers befestigt?

[ - Antworten - Zitieren - Direktlink - ]

21.04.2012, 19:35 Uhr

Stanglnator
Posts: 179
Nutzer
Einbauadapter für 2,5" Festplatten in 3,5" Schächte. kosten nicht die Welt. Oder Alternativ auch mit stärkeren Gummiringe. Mit letzeren hab Ich mir so billigst nen Vibrationsabsorber für 3,5" Platten gebastelt. :shoot2:
--
Mir nach! Ich folge Euch!

[ - Antworten - Zitieren - Direktlink - ]

21.04.2012, 19:46 Uhr

Reth
Posts: 1757
Nutzer
@Stanglnator:
Adapter klingt prima. Die SSD soll ja anstelle einer defekten 2,5" Notebook-HD eingebaut werden.

Hast Du für die Gummiringe mal ein Bsp.? Sind die aus dem Baumarkt?

[ - Antworten - Zitieren - Direktlink - ]

22.04.2012, 00:06 Uhr

geit
Posts: 332
[Ex-Mitglied]
@Reth:

Huh? Die meisten SSDs sind doch sowieso 2.5". Eine 2.5" Platte kannst du also direkt gegen eine SSD austauschen.

Geit

[ - Antworten - Zitieren - Direktlink - ]

22.04.2012, 01:15 Uhr

Reth
Posts: 1757
Nutzer
@geit:
Eben drum. Die Notebookplatte ist ja im Peg2 verbaut und daher habe ich auch schon die 3.5"=>2.5" Adapter drinne!

[ - Antworten - Zitieren - Direktlink - ]

22.04.2012, 03:16 Uhr

DaFreak
Posts: 235
Nutzer
@Reth:

könntest du dir aber auch bei 3.5" ssd's sparen. siehe z.b. http://www.ocztechnology.com/ocz-vertex-2-sata-ii-3-5-ssd.html

hab den vorgänger (ocz vertex 2) als 3.5" variante verbaut. preis- & leistungsmäßig eh das gleiche, doch ohne notwendigen 2.5-einbaurahmen.
--
Sam440ep + AmigaOS4.1 im Morex 3677 Gehäuse

[ - Antworten - Zitieren - Direktlink - ]

22.04.2012, 12:57 Uhr

Reth
Posts: 1757
Nutzer
Hab mir mal die hier von Verbatim bestellt und bin mal gespannt, obs funktionieren wird.
Auf die Größe hatte ich gar nicht geachtet. Dachte nur, dass SSDs evtl. nicht so wie HDDs eingebaut werden können (da dünner o.ä.)!

[ - Antworten - Zitieren - Direktlink - ]

24.04.2012, 18:43 Uhr

hjoerg
Posts: 3783
Nutzer
Zitat:
Original von Reth:
Hab mir mal die hier von Verbatim bestellt und bin mal gespannt, obs funktionieren wird.
Auf die Größe hatte ich gar nicht geachtet. Dachte nur, dass SSDs evtl. nicht so wie HDDs eingebaut werden können (da dünner o.ä.)!


Die Bewertungen hast gelesen :dance3:
--
WinUAE Fan
hjörg :dance2:
Nethands

"Wenn ich dir Recht gebe, liegen wir beide falsch"

[ - Antworten - Zitieren - Direktlink - ]

24.04.2012, 19:34 Uhr

Holger
Posts: 8042
Nutzer
Zitat:
Original von hjoerg:
Die Bewertungen hast gelesen

Wird er schon gemacht haben, denke ich. Was man da vor allem rauslesen kann, ist doch, dass man als allererstes die Aktualität der Firmware überprüfen sollte. Mit aktueller Firmware scheint sie dann ja gut zu laufen. So was kann Dir heutzutage leider mit jeder SSD passieren.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

24.04.2012, 20:16 Uhr

Reth
Posts: 1757
Nutzer
Bewertungen hab ich gelesen. Firmwareupdate hoffe ich nicht zu brauchen (wird evtl. schwierig, hab aber so ein Komplett-Extern-Adapterset, damit könnt ichs am Laptop machen).

[ - Antworten - Zitieren - Direktlink - ]

24.04.2012, 20:21 Uhr

hjoerg
Posts: 3783
Nutzer
@Reth:

OK. Trotzdem vorher Update am PC/LAP ist besser.
Vielleicht findet sich was mit internem Controller.
--
WinUAE Fan
hjörg :dance2:
Nethands

"Wenn ich dir Recht gebe, liegen wir beide falsch"

[ - Antworten - Zitieren - Direktlink - ]

24.04.2012, 21:39 Uhr

fingus
Posts: 152
Nutzer
Ich kann nur von meinen Erfahrungen am SAM440ep berichten, ich habe nun seit einiger Zeit auch eine 2,5" 64GB SSD von A-DATA drin. Der SATA-I-Controller kann die SATA-II-SSD natürlich nur halb ausreitzen, aber immerhin konnte ich mit scsispeed Spitzenwerte um die 115MB/Sek erreichen. Zum Vergleich: meine alte 2,5" Western Digital (7200U/Min) schaffte schon passable 85MB/Sek. Man merkte beim Benchmark schnell, das die Platte sich selbst Geschwindigkeitsmässig im weg steht (kleiner Cache und Mechnische HDD halt). Sie arbeitet nun im externen USB-Rahmen als Backup-Platte.

Meine SSD reagierte allerdings zimperlich bei falscher Einrichtung des Dateisystems in der Media-Toolbox bei der Einstellung fürs Dateisystem (SFS/00) bei Maxtransfer mit "Fullspeed (FFFFFFFF). Sie hat sich ein paar mal selbst zerlegt, einmal war der SLB gewurstet und anderes mal einen nicht behebaren Blockfehler erzeugt, und das bei SFS, das ist eigendlich grundsolide das Dateisystem!

Seit dem ich den Maxtransfer auf das für SFS/00 voreingestellte "7FFFFFFF" nach der Neueinrichtung gelassen habe macht die SSD nun keine Probleme mehr.

Hier das Ergebniss der A-Data-SSD:

Neuer Shell-Prozeß 7
7.RAM Disk:> scsispeed DRIVE sii3114ide.device:0 FAST BUF1=8192 BUF2=16384 BUF3=32768 BUF4=65536
MKSoft ScsiSpeed 4.2 Copyright © 1989-92 MKSoft Development
AmigaOS4 port by Stéphane Guillard
------------------------------------------------------------
CPU: 68020 AmigaOS Version: 53.25
Device: sii3114ide.device:0


Testing with a 8192 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 64745395 bytes/sec

Testing with a 16384 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 87748544 bytes/sec

Testing with a 32768 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 108606041 bytes/sec

Testing with a 65536 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 115237331 bytes/sec


Und zum Vergleich meine alte Western Digital 2,5" 7200RPM:

.Workbench:> scsispeed DRIVE sii3114ide.device:0 FAST BUF1=8192 BUF2=16384 BUF3=32768 BUF4=65536
MKSoft ScsiSpeed 4.2 Copyright © 1989-92 MKSoft Development
AmigaOS4 port by Stéphane Guillard
------------------------------------------------------------
CPU: 68020 AmigaOS Version: 53.8
Device: sii3114ide.device:0


Testing with a 8192 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 61070950 bytes/sec

Testing with a 16384 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 77966540 bytes/sec

Testing with a 32768 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 85185331 bytes/sec

Testing with a 65536 byte, MEMF_FAST, LONG-aligned buffer.
Read from SCSI: 85478604 bytes/sec


Und da die Workbench ja beim Booten und benutzen fast nur liesst müsste so eine SSD-Platte zumindest am Amiga ewig halten und später in neueren Amiga-Systemen weiterbenutzt werden am SATA-II-Controller aber dann ;-)

[ - Antworten - Zitieren - Direktlink - ]

25.04.2012, 21:14 Uhr

Reth
Posts: 1757
Nutzer
@hjoerg:
Hm, das mit dem Update wird wohl nicht so leicht! Alles, was ich bisher finden konnte ist dieser Link hier. Ist aber keine Verbatim Seite! Dort hab ich leider nix gefunden!
Die Frage ist: Könnte ich diese Firmware nutzen, oder wisst ihr noch eine zuverlässigere Quelle?

[ Dieser Beitrag wurde von Reth am 25.04.2012 um 21:14 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

26.04.2012, 10:37 Uhr

Holger
Posts: 8042
Nutzer
Zitat:
Original von Reth:
Alles, was ich bisher finden konnte ist dieser Link hier. Ist aber keine Verbatim Seite!

Steht doch so auch in den Amazon-Kommentaren drin, dass die Verbatim SSD auf dem Phison-Controller basiert und dass mind. ein User genau diesen Link vom Verbatim-Support bekommen hat. Andersherum sind bei den Kommentaren zu dem Phison-Update auch welche von Usern, die sagen, dass sie ihre Verbatim damit erfolgreich damit aktualisiert haben.

Wenn Dir das immer noch zu unsicher ist, musst Du wohl selbst beim Verbatim-Support nachfragen.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

27.04.2012, 12:08 Uhr

Reth
Posts: 1757
Nutzer
@Holger:
Den Kommentar mit dem Link vom Verbatim-Support hatte ich auch gefunden, allerdings an ner anderen Stelle (glaub in nem Forum). Der hatte mich allerdings etwas verunsichert.

Hab auch mal die Anleitung zum Flashen kurz überflogen. Auf den ersten Blick scheint das nicht unbedingt durchführbar zu sein, wenn die SSD extern angeschlossen ist (frage mich gerade, ob es in diesen Fällen nicht auch ohne das umständliche Booten von USB geht - mal sehen, muss die Anleitung nochmal genau lesen).

Aber werds erst mal ohne FW-Update versuchen, aktuell fehlt noch ein Kabel (ist aber schon unterwegs) und die Firma, die den Adapter geliefert hat hat den falschen geschick (Delock statt InLine, von Delock hab ich Mails des Support, die bestätigen, dass sie keinen Adapter haben, mit dem man 2 SATA-Geräte gleichzeitig an einem IDE-Port betreiben kann - InLine wirbt damit auf seiner Website).

[ - Antworten - Zitieren - Direktlink - ]

27.04.2012, 23:18 Uhr

Reth
Posts: 1757
Nutzer
Oh weh! Hab gerade gesehen, dass ich mir mit dem Adapter erstmal selbst ins Knie geschossen hab! Der funktioniert laut Hersteller nur, wenn immer 2 SATA-Geräte angeschlossen sind. Hab aber nur eines (kanns noch nicht testen, ein Kabel fehlt noch)!

Allerdings hab ich bei Delock auch noch einen gesehen, von dem dort behauptet wird, er kann 2 SATA-Geräte am IDE nutzen (es müssen allerdings auch bei diesem 2 SATA-Geräte angeschlossen werden!). Der Support von Delock hatte mir allerdings gemailt, dass sie so etwas nicht im Sortiment haben.

Mal sehen, was es an Alternativen gibt.

[ - Antworten - Zitieren - Direktlink - ]

28.04.2012, 01:21 Uhr

geit
Posts: 332
[Ex-Mitglied]
Zitat:
Original von Reth:
Oh weh! Hab gerade gesehen, dass ich mir mit dem Adapter erstmal selbst ins Knie geschossen hab! Der funktioniert laut Hersteller nur, wenn immer 2 SATA-Geräte angeschlossen sind. Hab aber nur eines (kanns noch nicht testen, ein Kabel fehlt noch)!


Teilweise sind die asiatischen Texte mit google übersetzt worden. Bei meinem Adapter stand auch dabei das er "nur mit zwei Festplatten Geräten funktioniert". Gemeint war hier wörtlich das nur Festplatten funktionieren und man keine CDROMs nutzen kann. Daher gehe ich davon aus, das es bei dir auch so ist.

Zitat:
Allerdings hab ich bei Delock auch noch einen gesehen, von dem dort behauptet wird, er kann 2 SATA-Geräte am IDE nutzen (es müssen allerdings auch bei diesem 2 SATA-Geräte angeschlossen werden!). Der Support von Delock hatte mir allerdings gemailt, dass sie so etwas nicht im Sortiment haben.

Ja, das habe ich dir ja schon im ersten Post gesagt. Da muß man zwischen den Zeilen lesen und Glück haben, weil die Verkäufer es selbst nicht raffen.

Oder direkt 20-25 Euro für den Adapter von Lindy nehmen und sich den Ärger sparen.

Ist bei den CF Readern für IDE einfacher. Entweder es sind zwei Slots aufgelötet oder eben nur einer.

Geit

[ Dieser Beitrag wurde von geit am 28.04.2012 um 01:43 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

01.05.2012, 19:32 Uhr

Reth
Posts: 1757
Nutzer
So, vielleicht gehört das ja in nen eigenen Thread aber folgender Stand liegt gerade vor.

SSD ist via Adapter als Master an einem der Peg2-IDE-Controller angeschlossen. Partitionen sind eingerichtet, Datenkopie läuft gerade.
Der Adapter hat die SSD nur an einem seiner Anschlüsse erkannt, am anderen nicht (die Firma war aber so nett, den Kaufpreis zurück zu erstatten und ich darf den Adapter sogar behalten, da sie den anderen derzeit nicht liefern können - das gibt noch ne bombastische Bewertung von mir, hat mich riesig beeindruckt!).
An dem 2. IDE-Controller hängt nun als Master die alte IDE-HDD und als Slave ist das DVD-RW-Laufwerk.

Vorher war die IDE-HD als Master an einem Controller und das DVD-RW am anderen, ebenfalls als Master.

Über Zugriffsgeschwindigkeit kann ich noch nix sagen, da ich noch von der alten HD boote.

Allerdings verhält sich der Peg nun deutlich anders. Vor dem Umbau konnte ich den 10s-Boot-Countdown der Smartfirmware des Peg immer sehen, bevor ich in die Bootauswahl von AOS4 kam.
Das ist nun vorbei. Keine Ahnung, was der Peg nun macht, aber es dauert ewig, bis er ein Bild zeigt, und dann bin ich schon in der AOS4-OF-Bootauswahl. Den Countdown der Smartfirmware bekomm ich gar nicht mehr zu Gesicht! Keine Ahnung, was da los ist.
Auch ist die Zeit nach Laden des AOS4-Kickstart bis das System bootet gefühlt um einiges länger als vor dem Umbau.
Ich hoffe, das wird besser, wenn ich mal komplett auf SSD umgestellt habe und die alte HD nur noch für Backups und Downloads nehme. Kanns mir aber nicht vorstellen.

Habt ihr noch Tips und Erfahrungen zum Thema?

Danke schon mal!

Ciao

[ - Antworten - Zitieren - Direktlink - ]

01.05.2012, 21:59 Uhr

Reth
Posts: 1757
Nutzer
Hier mal die Aktualisierung als neuer Post (falls jmd. antwortet während ich ändere):

Habe nun komplett umgestellt und dabei festgestellt, dass der Peg die SSD als Slave erkennt, obwohl sie als Master gejumpert ist! Zusätzlich habe ich sie am Secondary Bus angeschlossen, HD und DVD-RW hängen am Primary. Kann sich das geänderte Verhalten daher erklären (kann erst die nächsten Tage die Kiste wieder aufschrauben)?
Oder könnte das auch mit der noch nicht aktualisierten Firmware der SSD zusammenhängen?

Zur Geschwindigkeit kann ich nur sagen, dass mein C++-Projekt nun in ca. 2 Minuten compiliert, zuvor hat es >3min benötigt. Ist das in etwa das, was man durch eine SSD im Vgl. zur normalen HD erwarten kann? Gibt es denn noch eine andere Möglichkeit festzustellen, ob die SSD im "normalen" Bereich ihrer Leistung am Peg2 arbeitet?

[ - Antworten - Zitieren - Direktlink - ]

01.05.2012, 23:34 Uhr

geit
Posts: 332
[Ex-Mitglied]
Also wenn die SSD nur als Slave erkannt wird, dann ist es sicherlich das Problem des langsamen Bootvorgangs. Du hast sogar Glück, das es überhaupt klappt, weil der Bus nicht korrekt betrieben wird. Das Problem liegt dann wohl an dem kaputten zweiten S-ATA Anschluß, der dann wohl Master ist.

Was den Geschwindigkeitsvorteil angeht, so ist das normal. Ein Compiler (speziell ältere GCC versionen) suchen viel auf der Platte herum und das verzögert die Compilierung. Einmal geladen hängt alles an der CPU und der effizient der Speicherverwaltung. Compiler sind neben Videobearbeitung/anzeigen fast die einzigen Applikationen, die die CPU voll ausnutzen.

Alternativ kannst du ja mal das GG: ins RAM: kopieren und kompilieren. (Assigns, Pfade und Links nicht vergessen) Das wäre dann der Maximalwert für deinen Rechner. Ich hab das damals mal mit Ambient probiert. Von Platte war es etwa doppelt so langsam wie aus dem RAM:

Aber generell kannst du davon ausgehen, dass die SSD ordentlich funktioniert. Die ist (wenn die Spezifikationen auch stimmen) in jedem Fall schneller als die Pegasos-Hardware kann. Besser geht nicht.

Geit


[ Dieser Beitrag wurde von geit am 01.05.2012 um 23:36 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

02.05.2012, 22:04 Uhr

Reth
Posts: 1757
Nutzer
@geit:
Danke für Deine Hilfe.

Habe heut noch etwas rumprobiert, nicht was Geschwindigkeit angeht, aber bzgl. Erkennung.
Dazu habe ich den Adapter nun am primären IDE-Bus und zusätzlich mit seinen Einstellmöglichkeiten gespielt. Leider keine Verbesserung in der Erkennungsgeschwindigkeit.
Das Seltsamste ist die Mastererkennung der SSD!
Wenn ich den Adapter auf Slave jumpere wird gar nix erkannt. Ohne Jumper oder auf Master gejumpert wird die SSD an beiden Anschlüssen erkannt, an einem als Master, an dem anderen als Slave (obwohl der Adapter als Master gejumpert ist!).
Wenn sie als Master erkannt wird zeigt der Peg2 in seinem Firmwareprompt bei Eingabe von ls /pci/ide/ u.a. disk@0,0. Versucht man aber die Partitionen anzeigen zu lassen mit ls /pci/ide/disk@0,0 kommt die Fehlermeldung "ATA device not present or not responding" (glaub oder so ähnlich).

Liegt das nun am Adapter oder an der noch nicht aktualisierten Firmware der SSD oder am Peg2 selbst?

Am anderen Anschluss und als Slave erkannt arbeitet die SSD gut, nur die Erkennung dauert ewig (das Laden des Kickstarts dauert gefühlt auch etwas länger als von der alten HD)!

Ciao

[ - Antworten - Zitieren - Direktlink - ]

05.05.2012, 13:18 Uhr

Reth
Posts: 1757
Nutzer
Keiner ne Idee woran diese seltsame Mastererkennung liegen könnte?

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Lohnt eine SSD im Peg2? Wenn ja: Welcher + Welcher Controller? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.