amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > PlayCD spielt keine CD ab [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

26.07.2012, 23:32 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
PlayCD zeigt zwar die Musktitel mit Text an, spielt aber nichts ab.
Device und Unit sind in den ToolTypes richtig eingetragen.
Woran liegt das?
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 26.07.2012 um 23:38 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

26.07.2012, 23:48 Uhr

thomas
Posts: 7652
Nutzer

PlayCD spielt keine Musik ab, es schickt nur Befehle an das CD-Laufwerk. Die Musik wird vom Laufwerk abgespielt und zwar analog, d.h. über den Kopfhörerausgang an der Vorderseite des Laufwerks (falls vorhanden) oder über den vierpoligen analogen Audioanschluss an der Rückseite des Laufwerks (falls vorhanden). Letzterer muss per analogem Audiokabel an die Soundkarte angeschlossen werden, damit die Musik über die Soundkarte ausgegeben wird.

http://www.amazon.de/dp/B000AGETME

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 11:53 Uhr

tploetz
Posts: 4026
Nutzer
@thomas:
gibt es noch einen anderen CDPlayer, der die Titel anzeigen und abspielen kannn?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 11:57 Uhr

AmigaHarry
Posts: 1644
Nutzer
Und wo ist das Problem den analogen Audioausgang des CD-LW mit dem CD-Analogeingang auf dem Motherboard zu verbinden? Das hat auch noch den Vorteil das der Datenbus (IDE) und CPU kaum belastet wird.......
--
Life starts at '030, fun at '040, impotence at '86!

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 12:17 Uhr

tploetz
Posts: 4026
Nutzer
@AmigaHarry:
Ich weiss nicht, ob das beim SAM 460ex geht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 14:58 Uhr

Fred_AROS
Posts: 471
Nutzer
http://www.os4depot.net/index.php?function=showfile&file=audio/play/playcdda_gui.lha

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 18:26 Uhr

tploetz
Posts: 4026
Nutzer
@Fred_AROS:
PlayCDDA zeigt nur Tracks an,keine Musiktitel.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 21:29 Uhr

Marcian0
Posts: 70
Nutzer
Zitat:
Original von tploetz:
@AmigaHarry:
Ich weiss nicht, ob das beim SAM 460ex geht.
tploetz :boing:


Ich hab zwar keinen SAM; aber soweit ich das in der Anleitung zum Gerät gefunden habe, ist der entsprechende Anschluss auf dem Board zu finden (J24). Falls Du Deine Anleitung nicht findest: Hier ist ein Link zum PDF.

http://www.acube-systems.biz/download/Sam460ex_EndUserManual_v1.2.pdf

Auf der dritten Seite ist eine Zeichnung vom Board wo Du siehst, wo der Stecker hin muss (Wie gesagt J24). Auf der übernächsten Seite kannst Du nachlesen, dass es wirklich der Anschluss für CD-Audio ist.

Jetzt muss nur noch Dein CD-Laufwerk noch diesen Anschluss haben.

[ - Antworten - Zitieren - Direktlink - ]

27.07.2012, 22:21 Uhr

tploetz
Posts: 4026
Nutzer
@Marcian0:
Danke, kann ich mal probieren.
Warum spielt ADDRipper keine CD ab?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 10:10 Uhr

thomas
Posts: 7652
Nutzer
@tploetz:

http://translate.google.de/translate?sl=en&tl=de&js=n&prev=_t&hl=de&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fos4depot.net%2Findex.php%3Ffunction%3Dshowfile%26file%3Daudio%2Fmisc%2Fadripper.lha

Letzter Satz im ersten Abschnitt der Beschreibung: gleiches Problem wie bei PlayCD.

MakeCD kann Audio-CDs digital abspielen. Ist aber nicht wirklich ein Abspielprogramm. Und liest auch keine CDDB-Daten.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 12:59 Uhr

tploetz
Posts: 4026
Nutzer
@thomas:
Das DVD-Laufwerk hat keinen Audio-Anschluss, kann ich auf dem Board nicht anschliessen, auch keinen Kopfhörer-Ausgang.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 28.07.2012 um 13:00 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 14:30 Uhr

Bjoern
Posts: 1671
Nutzer
http://tinypic.com/r/5096v/6

Sicher?

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 20:48 Uhr

tploetz
Posts: 4026
Nutzer
@Bjoern:
ich habe dieses DVD-Laufwerk, da ist kein Audio-Anschluss vorhanden.
http://www.amazon.de/Lite-On-IHAS122-18-DVD-RW-Laufwerk-SATA/dp/B0048027MW

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 22:27 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Du musst bei die Playcd tooltypes das Tooltype 'USEAHI' eingeben.
Dann spielt PlayCD audioCDs uber AHI ab.

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 22:50 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Danke für den Hinweis, funktioniert.
Spielt aber etwas abgehackt ab, kann man das einstellen?
tploetz

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 23:02 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Ich weiss, das ist bei mir auch so.

Ich habe bis jetzt keine Lösung dafür gefunden.

Ich nützte für AudioCDs PlayCDDA. Dieses Program spielt audioCDs einwandfrei ab, aber hat leider keine CDDB unterstützung.

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 23:05 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Play CDDA habe ich, ich dachte das man den Puffer vielleicht einstellen kann.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.07.2012, 23:18 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Den Puffer kan man nicht einstellen.

Ich gehe davon aus das es ein Bug in PlayCD ist, weil PlayCDDA AudioCds einwandfrei abspielt.


[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 04:02 Uhr

angel77
Posts: 832
Nutzer
@tploetz:

Das hier hast du gesehen?

http://os4depot.net/?function=showfile&file=audio/misc/cddapatch.lha

vlg,

@ngel

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 11:08 Uhr

tploetz
Posts: 4026
Nutzer
@angel77:
Was bewirkt dieses Patch, ich merk da keinen Unterschied.
Ich lass es über die WbStartup ausführen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 17:14 Uhr

angel77
Posts: 832
Nutzer
So wie ich das verstehe wird das audio.device oder irgendwas anderes gepatcht, so dass die Audio-Daten "wie beim PC" über das Datenkabel übertragen werden und nicht mehr über das Audiokabel.

Klappt es denn damit?

Ich kann das selber nicht testen, ich hatte es nur gesehen und an deine Frage gedacht ...

vlg,

@ngel

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 17:47 Uhr

tploetz
Posts: 4026
Nutzer
@angel77:
Der Audio-Augang funktioniert wie bisher, ob nun Audio-Kabel oder
Datenkabel, davon merkt man nichts. Es ändert sich nichts.
Dann ist doch das Patch überflüssig, verstehe das alles nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 20:08 Uhr

Thore
Posts: 2266
Nutzer
Du weißt schon daß die Technik komplett anders ist?
Beim Audio-Kabel wird nur ein Befehl gesendet "Spiel mal". Den Rest erledigt die Hardware, ohne daß die CPU was rechnen muss.
Beim Datenkabel werden die Datenströme von der CPU decodiert und an die Soundkarte weitergegeben.

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 20:21 Uhr

tploetz
Posts: 4026
Nutzer
@Thore:
das mag ja alles richtig sein, bloß hören tut man den Unterschiied nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 20:57 Uhr

AmigaHarry
Posts: 1644
Nutzer
Um es villeicht nochmal zu verdeutlichen:

Methode1: Die rohen Daten der CD werden Track für Track an den Computer übertragen. Dieser muss die diese Daten aufbereiten und an den A/D-Wandler (Soundchip) senden und ausgeben. Dabei wird CPU-Leistung verbraten.

Methode2: Der Computer sendet an das CD-LW nur einen Play-Befehl und dieses wandelt den digitalen Datenstrom im eigenen A/D-Wandler in Analogsound um, der direkt von einem Verstärker ausgeben werden kann. Damit gibts keine Belastung des IDE und der CPU.

Im Soundgenuss sollte es heute kaum mehr Unterschiede geben, da die A/D-Wandler am Motherboard nicht schlechter sind als die im CD-LW......von daher hast du recht!

Bei leistungsschwächeren CPUs ist Methode2 sinnvoller (siehe Classic-Amigas), oder auch bei parallelen, sehr CPU-Intensiven Anwendungen, da das System sonst überlastet werden kann - das ist auch beim SAM nicht unmöglich.
Weiters gibt es einige Spiele direkt vom CD-LW im Hintergrund Soundeffekte abspielen.

Interessant ist das ich schon MusikCDs hatte welche mit Methode 1 nicht abspielbar waren, aber sehr wohl mit Methode 2 (und auch da NUR mit einem älteren SCSI-CD-LW am A3000.......)
--
Life starts at '030, fun at '040, impotence at '86!

[ Dieser Beitrag wurde von AmigaHarry am 30.07.2012 um 20:58 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 21:18 Uhr

Thore
Posts: 2266
Nutzer
@tploetz
Richtig, aber wenn Du CPU intensive Sachen machst, dann fängt der Ton an zu ruckeln. Nimmst Du die Audio-Direkt-Methode dann ruckelt nix :)
Wenns bei dir ausreicht ist super.

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 21:53 Uhr

tploetz
Posts: 4026
Nutzer
@Thore:
Bei PlayCD bekommt man das Ruckeln nicht weg.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 22:01 Uhr

Thore
Posts: 2266
Nutzer
Ja aber das "generelle" Ruckeln kommt daher, daß er Paketweise liest und ausgibt. Da reicht der Puffer nicht aus.

[ - Antworten - Zitieren - Direktlink - ]

30.07.2012, 22:27 Uhr

tploetz
Posts: 4026
Nutzer
@Thore:
man kann den Puffer bei der CD nicht einstellen, es gab mal ein Programm,
wo man die CD virtuell beschreiben konnte.
Wenn ich OWB starte setzt der Ton kurz aus
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 30.07.2012 um 22:56 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

01.08.2012, 12:56 Uhr

angel77
Posts: 832
Nutzer
Also das Verhalten wie unter Windows z. Bsp.

Das wirst du mit deinem Ansatz (der ja technisch grundsätzlich der selbe ist) auch niemals weg bekommen.

Dafür MUSST du das Audio-Kabel anschließen, sonst hast du keine prinzipielle Chance das weg zu bekommen.

(Ich muss dir auch ganz ehrlich sagen: Du musst dich schon etwas mehr an deinen Rechner anpassen. Ein Amiga ist kein PC. Also wenn ich einen Amiga benutzen möchte, dann weiß ich, dass ich Audio-Kabel ziehen muss um die maximale Leistung aus der Maschine zu kitzeln. Das ist genau das gleiche wie mit den Custom Chips damals im Classic. Entlastung der CPU durch externe Hardware-Basteleien. Das ist der Amiga-way tploetz ... ;)

@ngel

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > PlayCD spielt keine CD ab [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.