amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Digital Audio Player [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 2 3 4 -5- 6 7 [ - Beitrag schreiben - ]

29.08.2012, 23:14 Uhr

Wolfman
Posts: 3664
Nutzer
@tploetz:
Du könntest die Datei doch zu Testzwecken einfach mal umbenennen (verkürzen oder die Leerzeichen z.B. durch Unterstriche ersetzen) - wenn es dann geht, wüsste
man die Ursache.
--
God forgives - who forgives God ?

[ Dieser Beitrag wurde von Wolfman am 29.08.2012 um 23:15 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

29.08.2012, 23:17 Uhr

thomas
Posts: 7652
Nutzer
@tploetz:

Wie lautet die Fehlermeldung?

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

29.08.2012, 23:21 Uhr

tploetz
Posts: 4026
Nutzer
@Wolfman:
Habe den Dateinamen verändert, also verkürzt, aber der Fehlerhinweis kommt immer noch. Es muss an etwas anderem liegen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

29.08.2012, 23:34 Uhr

tploetz
Posts: 4026
Nutzer
thomas,
bei id3-tags steht bei dieser Datei Original No, bei den anderen steht Yes,
gibt es da eien Zusammenhang?
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 29.08.2012 um 23:46 Uhr geändert. ]

[ Dieser Beitrag wurde von tploetz am 30.08.2012 um 00:11 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 00:01 Uhr

tploetz
Posts: 4026
Nutzer
thomas
habe die mp3-Datei nochmals von Musikload runtergeladen und sie wird abgespielt
vom DAPlayer.
In id3-tag steht jetzt bei Original Yes.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 30.08.2012 um 00:04 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 00:16 Uhr

tploetz
Posts: 4026
Nutzer
Thomas
Ich würde sagen der DAPlayer spielt nur mp3, wo beim id3-tag Original=Yes steht.
Habe noch einen Titel gefunden, den der DAPlayer nicht abspielt, da steht Original=No
drin.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 06:58 Uhr

thomas
Posts: 7652
Nutzer
@tploetz:

Wie lautet die Fehlermeldung?

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 11:33 Uhr

tploetz
Posts: 4026
Nutzer
@thomas:
der Fehlerhinweis:
Fehler beim Abspielen
Abspielen Anhalten
Aus Playlist entfernen
Auswahl auf alle Fehler anwenden

Hatte ich schon mal geschrieben, die Antwort ist verschwunden.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 13:27 Uhr

thomas
Posts: 7652
Nutzer
@tploetz:

Du hast echt einen an der Waffel. Mich interessiert nicht, wie die Knöpfe beschriftet sind, die habe ich selber programmiert, ich weiß was da steht. Ich möchte die Fehlermeldung wissen!!

Bild: http://thomas-rapp.homepage.t-online.de/download/daplayer_fehler.png

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 13:38 Uhr

Holger
Posts: 8040
Nutzer
Zitat:
Original von tploetz:
habe die mp3-Datei nochmals von Musikload runtergeladen und sie wird abgespielt
vom DAPlayer.
In id3-tag steht jetzt bei Original Yes.

Na wenn die Datei sich in dem Punkt unterscheidet, dann vielleicht auch in anderen? D.h. vielleicht war sie schlichtweg kaputt?

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 14:27 Uhr

tploetz
Posts: 4026
Nutzer
@thomas:
Es steht nur da, Fehler beim Abspielen von Work:Musikload/und die mp3-Datei
das ist alles.
tploetz
:boing:

[ Dieser Beitrag wurde von tploetz am 30.08.2012 um 14:29 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

30.08.2012, 22:54 Uhr

tploetz
Posts: 4026
Nutzer
Thomas
die zwei mp3 Dateien habe ich doppelt, kann ich löschen, sind auch unterschiedlich
in der Dateigröße, das eine File ist doppelt so groß.
Mit id3-tag hat es nichts zu tun, die spielen auch, wenn Original=NO
steht.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 30.08.2012 um 22:57 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

31.08.2012, 14:53 Uhr

thomas
Posts: 7652
Nutzer
@tploetz:

Ich entschuldige mich für meinen abfälligen Ausspruch. Es gibt tatsächlich eine Situation, in der eine leere Fehlermeldung ausgegeben wird.

Die defekte mp3-Datei kann schlicht nicht mit der mpega.library abgespielt werden. Daran kann ich auch nichts ändern.

Der Fall, in der keine Fehlermeldung kommt, ist wenn der FLAC-Dekoder meint, er könne die Datei lesen, aber keine sinnvollen Werte für Frequenz / Anzahl Kanäle und Bits pro Sample zurückgibt. In diesem Fall schlägt die Allokation der Puffer fehl und dafür war keine Fehlermeldung vorgesehen.

Die nächste Version wird
- prüfen, ob FLAC sinnvolle Werte zurückgibt und die Datei nicht als FLAC identifizieren, wenn nicht.
- einen Fehlercode setzen, wenn die Puffer nicht allokiert werden konnten
- für den Fall, dass es noch einen Fall ohne Fehlercode gibt, dann die Meldung "unbekannter Fehler" ausgeben.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

31.08.2012, 15:20 Uhr

tploetz
Posts: 4026
Nutzer
@thomas:
Mich wundert nur. das die defekten Dateien mit AmigaAMP abzuspeilen gehen.
tploetz


:boing:

[ - Antworten - Zitieren - Direktlink - ]

31.08.2012, 17:38 Uhr

Stanglnator
Posts: 179
Nutzer
Also beim Abspielen von Flac-Dateien kann ich berichten das Aussetzer beim Abspielen dabei sind.
Unterschiede bei der Zeit wo es passiert.
Ich hab 1Gb Speicher der zu 100% OK ist.
Egal ob Ich die selbe Flac von Ram: von ner HD0: ober via Ftp: bzw SMBFS: vom Nas abspiele.

Da meine FLACs bis zu 70MB groß sind villeicht ein Pufferproblem?
Ansonsten klappts super.
Oder mein System is total verhunzt.


--
Mir nach! Ich folge Euch!

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 10:12 Uhr

thomas
Posts: 7652
Nutzer
@Stanglnator:

Ich habe die FLACs von dieser Seite zum Testen genommen: http://www.2l.no/hires/index.html

Die sind alle größer als 70 MB. An der Größe kann es nicht liegen.

Welche Qualität haben deine denn?

Und wie schnell ist dein Rechner? Ich habe einen A1XE mit 800MHz, 256 MB RAM und SII680.

Welche Frequenz hast du bei AHI eingestellt?

--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 12:00 Uhr

Stanglnator
Posts: 179
Nutzer
@thomas:
A1Xe 800Mhz, 1Gb Ram, Sil0680 , Sil3112 , Soundblaster , Onboard Via-AC97

Größe der Flac-Dateien 30-120MB Qualität V8 (also das beste was geht)
Gerippt mit EAC (Accuraterip) und encodiert mit der letzten Flac-Version 1.2.1 (mit 44100hz und 16Bit da von CD) sowohl am PC als auch am Amiga.
AHI 44100 Channels 2.

Seltsam ist nur das die Fehler oder Knackser nicht immer an der selben stelle sind.
Hab sie mit einem am PC überprüft und keine Fehler gefunden.

Villeicht sollte Ich mir eine OS4.1.5 installation einrichten die vollkommen clean ist.

--
Mir nach! Ich folge Euch!

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 14:40 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
wo gibt es denn den Encodierer für Flac-Dateien?
CodeAudio hat den Encoder nicht gefunden.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 14:56 Uhr

Thore
Posts: 2266
Nutzer
ffmpeg sollte es können

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 17:58 Uhr

tploetz
Posts: 4026
Nutzer
@Thore:
ffmpeg hat flac Kodierung, aber was soll ich als Ausgabedatei für eien Endung nehemen?
mp3 und wav gehen nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 19:12 Uhr

Wolfman
Posts: 3664
Nutzer
Wie wärs mit flac?




--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 20:10 Uhr

Stanglnator
Posts: 179
Nutzer
@tploetz:
Na auf OS4depot.net Dort in Suche Flac eingeben und schon gibts was ;)

http://os4depot.net/share/datatype/sound/flac.lha
http://os4depot.net/share/audio/play/tunenet/tuneflac_plug.lha
http://os4depot.net/share/datatype/sound/flacdt.lha
http://os4depot.net/share/development/library/audio/libflac.lha

Bis auf den letztem Link kannst alle brauchen.
Wichtig ist ersterer Link.
Die entpackst und die flac.exe kopierst in den ordner von Codeaudio oder nach c: oder der wo Lame ist.
Dann noch in den Einstellungen von Codeaudio den flac-encoder (die flac.exe) aussuchen und anschließend speichern.

Fertig

:shoot2:
--
Mir nach! Ich folge Euch!

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 20:43 Uhr

tploetz
Posts: 4026
Nutzer
@Stanglnator:
Der erste Link funktioniert nicht richtig.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 21:17 Uhr

tploetz
Posts: 4026
Nutzer
@Stanglnator:
bei CodeAudio gehts nicht DosFehler1: Kodierer verursachte einen Fehler
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 22:52 Uhr

Marcian0
Posts: 70
Nutzer
@tploetz:
Anstelle des ersten Links von oben drüber mal das hier testen. Hab kein Os4, aber mal die Suche im OS4-Depot ausprobiert.

http://eu.os4depot.net/share/audio/convert/flac.lha

[ - Antworten - Zitieren - Direktlink - ]

01.09.2012, 23:30 Uhr

tploetz
Posts: 4026
Nutzer
@Marcian0:
http://img4.fotos-hochladen.net/uploads/flac1dpgs8fwj6.jpg

Das ist der Feherhinweis bei CodeAudio, habe die Werte so eingestellt wie im Fehler-
hinweis, der Fehler bleibt aber immer der selbe, was kann man tun?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

02.09.2012, 11:41 Uhr

Stanglnator
Posts: 179
Nutzer
@tploetz:

Naja das kommt darauf an was du encodieren willst!

von CD von wav von MP3 .....
Normalerweise klappts von CD und von wav ohne Einstellung evtl muss das Kästchen "Eingabedatei als RAW/PCM behandeln" aktiv sein.

Erspar Dir aber Zeit und Aufwand von MP3 auf Flac.
Das ist mehr als grausam. Ehrlich!

Versuch mal von CD einen Track zu Flac encodieren bzw von einer Wav-Datei

Schau mal meine Einstellungen an.


https://skydrive.live.com/embed?cid=E9D9E915BAC3D1B7&resid=E9D9E915BAC3D1B7%211478&authkey=ACcZSUguLn2THV0

Encodiert von CD bzw von wav. Du versucht von einem anderen Format nach flac zu konvertieren. Das geht macht nen Fehler.

flac und metaflac hab Ich nach c: kopiert

--
Mir nach! Ich folge Euch!

[ Dieser Beitrag wurde von Stanglnator am 02.09.2012 um 12:39 Uhr geändert. ]

[ Dieser Beitrag wurde von Stanglnator am 02.09.2012 um 12:47 Uhr geändert. ]

[ Dieser Beitrag wurde von Stanglnator am 02.09.2012 um 12:51 Uhr geändert. ]

[ Dieser Beitrag wurde von Stanglnator am 02.09.2012 um 12:52 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

02.09.2012, 15:25 Uhr

tploetz
Posts: 4026
Nutzer
@Stanglnator:
Dein Link funktioniert bei mir nicht und mit Code Audio komme ich nicht klar,
was ich da einstellen muss.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 02.09.2012 um 22:16 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

02.09.2012, 19:24 Uhr

tploetz
Posts: 4026
Nutzer
Der Link funktioniert nur bei Timberwolf,
aber den Fehler des Encodieres bekomme ich nicht weg, bin am verzweifeln.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 02.09.2012 um 22:17 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

02.09.2012, 20:59 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
das Encodieren von CD geht mit ADDRipper ganz einfach im Gegensatz zu CodeAudio.
Die Qualität von flac-Dateien ist sehr gut.
Kann nur ADDRipper empfehlen.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 02.09.2012 um 21:00 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]


1 2 3 4 -5- 6 7 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Digital Audio Player [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.