amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Mit Genesis und Deneb ins Internet [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

17.08.2012, 00:36 Uhr

Stephan
Posts: 125
Nutzer
Hallo zusammen,

ich brauche mal wieder eure Hilfe.

Ich habe meinen A1200 mit einer DENEB und einem USB-Ethernet-Adapter an einem Router von T-Online (Speedport W503V) angeschlossen.
Bisher wähle ich mich über Miami (Demo-Verison) ins Netzt ein.
In Miami habe ich folgende Einstellungen:
Schnittstellen-Typ: SANA-II Ethernet
Treiber: usbasixeth.device
Nummer: 0
IP-Typ: DHCP
Netzmasken-Typ: DHCP
Gatway-Typ: DHCP

Wenn ich nun die gleichen Einstellungen in Genesis mache sieht das wie folgt aus:
IP-Adresse: dynamisch
Ziel: dynamisch
Gatway: dynamisch
Netzmaske: 255.255.255.0

Dann bekomme ich folgende Meldung:
"Kann lokale IP-Adresse nicht ermitteln."


Wenn ich die IP-Adresse meines Routers fest eintrage, dann bekomme ich die Meldung, dass usbasixeth online ist, aber ich habe trotzdem keine Verbindung.


Wenn ich bei Ziel die IP von T-online eintrage (194.25.2.129), dann bekomme ich folgende Meldung:
"iface_setmtu: SIOCSIFMTU; invalid argument"


Ich habe jetzt schon viele Varianten durchgespielt, aber bisher immer ohne Erfolg.
Kann mir jemand weiter helfen und sagen, was ich genau wo eintragen muss?
IP-Adresse: ??
Ziel: ??
Gatway: ??
Netzmaske: 255.255.255.0

Domain Server: ??
Domain Name: ??

Ich bin bei T-Online. Der Speedport hat folgende Werkseinstellungen:
IP-Adress: 192.168.2.1
Subnetzmaske: 255.255.255.0
DHCP-Server ist aktiviert.

Vielen, vielen Dank für eure Hilfe.

p.s.: Ich habe die Beschreibung auf "Tom's Homepage" gelesen. Damit bin ich aber auch nicht ans Ziel gekommen.

Gruß Stephan
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

17.08.2012, 08:53 Uhr

thomas
Posts: 7680
Nutzer

Genesis kann kein DHCP, dehsalb wirst du mit dynamisch nicht weit kommen.

Probier mal:

IP-Adresse: 192.168.2.2
Ziel: leer oder 192.168.2.1
Gatway: 192.168.2.1
Netzmaske: 255.255.255.0

Domain Server: 192.168.2.1
Domain Name: egal


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

17.08.2012, 15:56 Uhr

tploetz
Posts: 4026
Nutzer
@Stephan:
Ich hatte auf dem Amiga 4000 mit der Deneb Miami benutzt, MiamiInit
hat die Einstellungen ermittelt und konnten in Maimi eingefügt werden.
Das Device war das usbasixeth.device.
Hat prima funktioniert.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

17.08.2012, 23:56 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

Hallo Thomas,

leider funktioniert es mit Deinem Vorschlag auch nicht.

Bei
"IP-Adresse: 192.168.2.2
Ziel: 192.168.2.1
Gatway: 192.168.2.1
Netzmaske: 255.255.255.0

Domain Server: 192.168.2.1
Domain Name: egal"

bekomme ich die Meldung:
"iface_setmtu: SIOCSIFMTU: Invalid argument
usbasixeth ist online"
Doch ich habe kenine Verbindung.

Bei
"IP-Adresse: 192.168.2.2
Ziel: leer ==> wird als dynamisch inerpretiert
Gatway: 192.168.2.1
Netzmaske: 255.255.255.0

Domain Server: 192.168.2.1
Domain Name: egal

bekomme ich folgende Meldung:
"Iface_config:SIOCAIFADDT: Object exists
Kann Interface usbasixeth2 nicht konfigurieren."

Hast Du noch ene Idee?

Danke schon mal im Voraus.

Gruß Stephan
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

18.08.2012, 00:00 Uhr

Stephan
Posts: 125
Nutzer
@tploetz:

Hallo tploetz,

mit Miami funktioniert es bei mir ja auch. Allerdings wid die Verbindung wegen der Demo-Version nach 30 min. abgebrochen und ich muss mich wieder neu verbinden.
Ich habe die Hoffnung, dass das mit Genesis besser wrd.

Gruß Stephan

--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

18.08.2012, 00:03 Uhr

huepper
Posts: 481
Nutzer
Schau mal bitte, was in deinem Router bei DNS-Server steht.
Das solltest du auch bei Domain-Server eintragen.

--
Signatur ? hmm wo hab ich sie nur wieder ?

[ - Antworten - Zitieren - Direktlink - ]

18.08.2012, 23:36 Uhr

Stephan
Posts: 125
Nutzer
@huepper:
Hallo,

in meinem Router ist ein DHCP-Server aktiviert, der den angeschlossenen Computern automatisch eine IP-Adresse zuweist. Außerdem teilt der DHCP-Server dem Client die IP-Adresse der zu verwendenden DNS-Server und des Standard-Gateways mit.
Gruß, Stephan
--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

19.08.2012, 10:14 Uhr

thomas
Posts: 7680
Nutzer
@Stephan:

Dies sind meine Einstellungen am A4000 mit X-Surf und OS 3.9:

code:
Modems/TA: leer
Schnittstellen: eine
  Schnittstelle:
    Name: x-surf0
    IP-Adresse: 192.168.1.9
    Ziel: dynamisch
    Gateway: 192.168.1.254
    Netzmaske: 255.255.255.0
    MTU: 1500
    Parameter: leer
  SANA-II:
    SANA-II Gerät festlegen
    Devs:Networks/x-surf.device   Unit: 0
  Modem
    keins
  PPP
    alles grau
  Dienste
    Auto-Online
  Ereignisse
    unwichtig
  Resolv
    Domain Name Server = 192.168.1.254
    Domainname: keiner
    Hostname / Domainname erfragen = aus
    Hostname: leer
Benutzer
  user
  root
  pcguest
Optionen
  Anzeige
    Öffnen beim Start
    Öffne Statusfenster = an
    Zeige serielle Eingaben = an
  Verschiedenes
    oben alles aus
    mitte debug, debug, NIL:
    unten alles an
  Ausführen
    alles leer
  Erweitert
    oben alles aus
    unten alles unverändert


Ich habe einen Speedport W 700V mit der IP 192.168.1.254.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

19.08.2012, 20:41 Uhr

Stefan
Posts: 936
Nutzer
@Stephan:

Hi,

Wenn Du Genesis (AmiTCP) verwenden möchtest solltest beim
Router das "DHCP" rausnehmen. Und dann eine statische IP
für Client und Gateway vergeben.

z.B. 192.168.0.1 Gateway (Router)
192.168.0.2 Amiga

:boing:

[ Dieser Beitrag wurde von Stefan am 19.08.2012 um 20:42 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

19.08.2012, 21:12 Uhr

thomas
Posts: 7680
Nutzer
@Stefan:

DHCP am Router auszuschalten wäre ziemlich dämlich, weil dann außer dem Amiga kein anderes Gerät mehr ins Netzwerk kommt, es sei denn, man macht eine Konfigurationsorgie und stellt bei jedem einzelnen Gerät eine feste IP-Adresse ein.

Das Vorhandensein eines DHCP-Servers im Netz zwingt niemanden, diesen auch zu benutzen. Man kann durchaus seine Windows-Rechner, iPhones, Settop-Boxen usw. mit DHCP ins Internet lassen und am Amiga eine feste Adresse einstellen.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 02:29 Uhr

Murmel
Posts: 1457
Nutzer
Sorry passt nicht zum Thema, aber hat schon jemand mal Holger Kruse angeschrieben ob er das Dingen "Mimai" endlich freigibt ? Es ist ja nur noch Retro...


[ Dieser Beitrag wurde von Murmel am 20.08.2012 um 02:30 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 07:57 Uhr

Lippi
Posts: 1247
Nutzer
Moin,
ich würde das DHCP im Router auch an lassen.
Dann entweder den DHCP-Bereich z.B. ab 192.168.0.11 >> festlegen.
Dann kann man von 192.168.0.2 bis ... 10 fest vergeben ohne Konflikte,
Feste IPs machen sich z.B. auch bei Netzwerkdruckern vorteilhaft :-)

Oder man nimmt für die festen IPs irgendwas hohes - z.B. 200 - das sollte eigentlich nicht erreicht werden bei der automatischen Vergabe der IPs - es sei denn, man hat ne Serverfarm oder Computerladen :-)
--
mfg Lippi - - Bin ich froh, dass ich weg vom Fenster bin! AmigaOS3.9/Ubuntu10.04
Infokanalmeine Arbeit * infokanal@t-online.de

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 09:14 Uhr

thomas
Posts: 7680
Nutzer

Alle Router, die ich bisher hatte, haben für DHCP hohe Nummern benutzt, z.B. von 100 bis 200, sodass man die kleinen Nummern zwischen 2 und 99 gefahrlos für statische IP-Adressen benutzen kann.


@Stephan: versuch bitte mal, mit Miami eine Konfiguration mit festen IP-Adressen zu machen.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 10:15 Uhr

Holger
Posts: 8093
Nutzer
Zitat:
Original von thomas:
Alle Router, die ich bisher hatte, haben für DHCP hohe Nummern benutzt, z.B. von 100 bis 200, sodass man die kleinen Nummern zwischen 2 und 99 gefahrlos für statische IP-Adressen benutzen kann.

So ziemlich jeder Router lässt sich dahingehend konfigurieren, welchen Adressbereich er für DHCP verwendet.

Und dann ist man auch nicht auf 200 Nummern beschränkt. Sofern die Netzmaske richtig eingestellt ist, hat man im Zweifelsfall 65000 verschiedene Adressen zur Verfügung.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 11:19 Uhr

angel77
Posts: 832
Nutzer
@Murmel:

Ja, aber anscheinend die falschen Leute wie man sieht ...

Theoretisch könnte jemand wie ich ihn anschreiben ...

vlg,

@ngel

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 15:17 Uhr

Lippi
Posts: 1247
Nutzer
Zitat:
Original von thomas:
Alle Router, die ich bisher hatte, haben für DHCP hohe Nummern benutzt, z.B. von 100 bis 200, sodass man die kleinen Nummern zwischen 2 und 99 gefahrlos für statische IP-Adressen benutzen kann.


Nun, dann muss meiner hier ein Sonderfall sein.
Ich habe ihm von ....11 - 253 als DHCP-Bereich erlaubt und er fängt immer bei 11 an und nicht oben. :-)
--
mfg Lippi - - Bin ich froh, dass ich weg vom Fenster bin! AmigaOS3.9/Ubuntu10.04
Infokanalmeine Arbeit * infokanal@t-online.de

[ - Antworten - Zitieren - Direktlink - ]

20.08.2012, 17:22 Uhr

thomas
Posts: 7680
Nutzer
@Lippi:

Ich meinte die Standardeinstellungen. Wenn du die Einstellungen änderst, ist das natürlich bei dir anders. Ich gehe allerdings davon aus, dass der Ottonormalbenutzer diese Einstellungen nicht ohne Grund ändert. Plug-and-Play ist doch das Modewort schlechthin.




--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

22.08.2012, 19:03 Uhr

Gazelle
Posts: 151
Nutzer
*** Wegen Verstoß gegen die Netiquette gelöscht (cg)
http://www.amiga-news.de/netiquette.shtml ***


[ Dieser Beitrag wurde von cgutjahr am 22.08.2012 um 20:27 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

22.08.2012, 19:23 Uhr

ylf
Posts: 4101
Nutzer
Viele Router bieten zudem die Möglichkeit, IP-Adressen an MAC Adressen zu binden. So kann man per DHCP den einzelnen Geräten immer die jeweils selbe IP zuweisen, was dann praktisch wie feste IPs ist.

Wollte ich nur so mal erwähnt haben. ;)

[ - Antworten - Zitieren - Direktlink - ]

25.08.2012, 08:46 Uhr

Stephan
Posts: 125
Nutzer
@thomas:

ich habe mal mit Miami eine Konfiguration mit festen IP-Adressen eingestelt.
Aber auch da habe ich so meine Probleme.
Miami übernimmt den Eintrag bei Gateway nicht richtig. Der Eintrag wird immer mit dem Eintrag der Netzmaske überschrieben. Wenn ich die Einstellungen speichere und wieder neu lade, dann steht bei Gateway das gleiche wie bei Netzmaske.
Somit konnte ich dies nicht richtig testen.

Aber wenn ich in Miami die Feste IP-Adresse 192.168.2.2, die Netzmaske 255.255.255.0 und bei Gateway "dynamisch" einstelle, kann Miami das Gateway nicht ermitteln.

Ich glaube, ich bleibe doch bei Miami und muss dann eben immer alle halbe Stunde wieder neu online gehen.

Vielleicht findet sich ja noch jemand, der mit der selben Hardwareausstattung - Deneb + Dlink (USB-Ethernet-Adapter) + Speetport - mit Genesis ins Netzt geht und mir die richtigen Einstellungen sagen kann.

Vielen Dank an alle, die mir Helfen wollten.

--
Schönen Gruß


A1200 Tower (RBM Towerhawk mit Tastaturinterface), BPPC 040/25-603e/240, Chip 2.0MB, Fast 127.5MB, BVision, Onboard1200ex, IOBlix2.0, Deneb

[ - Antworten - Zitieren - Direktlink - ]

25.08.2012, 09:52 Uhr

tploetz
Posts: 4026
Nutzer
@Stephan:
Ich hatte auf dem A4000T die selbe Konfifuration, Dneb +DLink(USB
Ethernet) + Miami Deluxe, Internet hat einwandfrei funktioniert.
Hatte Dir eine Mail vom Forum geschickt, ist die angekommen?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Mit Genesis und Deneb ins Internet [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.