amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > FKey erkennt Multimediatasten nicht [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

24.03.2013, 14:16 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
Ich habe mit Allkeys drei Multimediatasten gespeichert, siehe Bild, werden aber mit Fkey nicht erkannt. Woran liegt das?

Bild: http://img3.fotos-hochladen.net/uploads/fkey8d01x6lcb4.jpg
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 14:46 Uhr

inq
Posts: 445
Nutzer
@tploetz:

Hat nicht FKey selbst auch einen Lern-Modus? Möglicherweise "schluckt" Allkeys die Codes und du mußt die Funktion ENTWEDER mit Allkeys XODER mit FKeys ausführen?

Gruß
inq

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 15:17 Uhr

tploetz
Posts: 4026
Nutzer
@inq:
Ds sind die Tasten die Fkey anzeigt, mit dem Lernmodus geht es auch nicht
Bild: http://img3.fotos-hochladen.net/uploads/fkey1y968dtguo2.jpg

tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 24.03.2013 um 15:18 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 18:27 Uhr

Stanglnator
Posts: 179
Nutzer
Das is so:

Allkeys erkennt die RawCodes die die Tasten von sich geben.
Fkey erkennt nur RawCodes die es einprogrammiert hat.

Fkey gibts ja schon länger daher die beschränkte Tastenerkennung.

Benutz nur noch Allkeys. Für mich einfacher einzurichten.
--
Mir nach! Ich folge Euch!

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 19:40 Uhr

tploetz
Posts: 4026
Nutzer
@Stanglnator:
Wie soll ich mit Allkeys ein Arexx-Script starten?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 20:33 Uhr

Big_H
Posts: 408
Nutzer
so z.b.
in deinem fall sind nur die volume up,down,mute einträget interessant.
Bild: http://www.musik-world.net/bilder/allkeys

[ Dieser Beitrag wurde von Big_H am 24.03.2013 um 20:34 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 21:44 Uhr

tploetz
Posts: 4026
Nutzer
Die drei Multimediatasten funktionieren jetzt, aber wenn ich sie drücke kommt
die Meldung OSDLauncher: "Unbekannter Befehl" "OSDLauncher fehlgeschlagen
Rückgabewert 10"
Dabei habe OSDLauncher nicht in der WbStartup. das verstehe ich nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 22:33 Uhr

Big_H
Posts: 408
Nutzer
@tploetz:
was hast du eingetragen.
die volume tasten aus meinem screenshot greifen nur auf den mixer zu.
die osd-launcher einträge habe damit nichts zu tun da habe ich ne tastatur maus kombination drauf gelegt.


[ Dieser Beitrag wurde von Big_H am 24.03.2013 um 22:34 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

24.03.2013, 22:42 Uhr

tploetz
Posts: 4026
Nutzer
@Big_H:
Das sind die Scripte von OSD-Launcher.

Bild: http://img3.fotos-hochladen.net/uploads/allkeys49fu5qrb1k.jpg
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

25.03.2013, 09:13 Uhr

Robin
Posts: 1056
Nutzer
@tploetz:
Du hast das leicht falsch verstanden.
Sound-.arexx ist eine Scriptdatei und kein ARexx Befehl.
Du müsstest in diese Scriptdatei schauen wie der richtige Befehl lautet.
--
(Bild) http://my.morphosi.net/
morphos

[ - Antworten - Zitieren - Direktlink - ]

25.03.2013, 11:48 Uhr

tploetz
Posts: 4026
Nutzer
@Robin:
Es ist zwar eine Arexx-Datei, wird aber durch Workbench gestartet.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

25.03.2013, 16:00 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
wie ist der Arexx-Name von AmigaAMP, ich habe AMIGAAMP genommen, funktioniert aber nicht,
brauche das für die Multimedia-Tasten.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 00:34 Uhr

Polluks
Posts: 93
Nutzer
@tploetz:
rx "say show(ports)"

ARexx-Skripte werden gewöhnlich mit .rexx gekennzeichnet.
--
Pegasos II G4, MorphOS 3.1, Zalman M220W
Power Mac G3, OSX 10.3

[ Dieser Beitrag wurde von Polluks am 26.03.2013 um 00:54 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 13:37 Uhr

tploetz
Posts: 4026
Nutzer
@Polluks:
Ich bin mit allkeys sehr unzufrieden, funktioniert nur, wenn man nicht neu startet,
dabei ist es in der WbStartup. Ich weiss nicht woran es liegt. FKey geht immer.
Edit:
Nach einem Neustart muss ich bei Allkeys den ARexx Port wiederholt eingeben,
das ist doch nicht Sinn der Sache.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 26.03.2013 um 14:50 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 16:27 Uhr

analogkid
Posts: 2383
Nutzer
Zitat:
Original von Polluks:
rx "say show(ports)"


Wohin er das wohl getippt hat ;)

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 16:46 Uhr

tploetz
Posts: 4026
Nutzer
@analogkid:
rx say show(ports) zeigt das hier an.


rx "say show(ports)"
SFS DosList handler ConClip.rendezvous WORKBENCH AMIDOCK PPC460EX OHCI Shutdown Port dos_lock_handler_port pager_message_port DST port REXX AREXX TCP/IP Control DEFICONS AExplorer SWITCHER3D RINGHIOMP RINGHIO FLIPCLOCK WET.1 OWB.1 deficons
tploetz
:boing:

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 18:03 Uhr

thomas
Posts: 7661
Nutzer
@tploetz:

Du solltest AmigaAMP schon laufen lassen, sonst ist der Port nicht dabei.

So wird die Liste noch etwas leserlicher:

rx "say show(p,,'0a'x)"


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 18:22 Uhr

tploetz
Posts: 4026
Nutzer
@thomas:
auch wenn AmigaAmp läuft gehen die Multimeditasten nicht,
es geht nur mit FKey, bei allkeys darf man nicht neustarten.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 18:27 Uhr

tploetz
Posts: 4026
Nutzer
2.Workbench:> rx "say show(p,,'0a'x)"
SFS DosList handler
ConClip.rendezvous
WORKBENCH
AMIDOCK
PPC460EX OHCI Shutdown Port
dos_lock_handler_port
pager_message_port
DST port
REXX
AREXX
TCP/IP Control
DEFICONS
AExplorer
SWITCHER3D
RINGHIOMP
RINGHIO
FLIPCLOCK
WET.1
OWB.1
deficons

tploetz :amiga:

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 20:24 Uhr

Holger
Posts: 8050
Nutzer
Zitat:
Original von tploetz:
es geht nur mit FKey

Wenn es mit FKey geht, denn gibt doch in AllKeys exakt dasselbe ein, was Du in FKey angegeben hast.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 20:34 Uhr

tploetz
Posts: 4026
Nutzer
@Holger:
Habe das selbe, wie bei FKey eingetragen und gespeichert.
Das Problem ist das allkeys nach dem Neustart nicht mehr funktioniert.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 20:58 Uhr

Big_H
Posts: 408
Nutzer
du musst bei allkey jeden eintrag mit enter/return abschliessen sonst werden die nicht übernommen

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 21:06 Uhr

tploetz
Posts: 4026
Nutzer
@Big_H:
habe ich auch gemacht mit Return, aber irgendwie werden die Tasten nicht übernommen nach dem Neustart, mit dem Mixer Arexx-Port gibt es das Problem nicht, nur AmigaAMP
geht dann nicht.
tploetz
:boing:

[ - Antworten - Zitieren - Direktlink - ]

26.03.2013, 22:49 Uhr

tploetz
Posts: 4026
Nutzer
Ich habe die Pause-Taste erneut gespeichert und jetzt funktioniert das auch nach einem
Neustart.
tploetz :bounce:

[ - Antworten - Zitieren - Direktlink - ]

27.03.2013, 21:10 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
Kann man zwei verschiedene Arexx-Ports auf eine Taste legen?
tploetz
:boing:

[ - Antworten - Zitieren - Direktlink - ]

27.03.2013, 23:10 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
Bei FKey kann man zwei Arexx-Ports auf eine Taste legen, mit dem Häkchen Weiterreichen. Geht das auch bei Allkeys?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 20:46 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Wenn ich es richtig verstehe, willst Du mit einer Taste mehrere Programme steuern.

Das ansprechen von (edit:) mehrere Arexx-ports macht man mit einem script, nicht mit Fkey oder allkeys.

Ich hab für meine multimedia-tastatur arexx-scripts gemacht, und kann damit DaPlayer und AmigaAMP steuern.

z.B. hier ein script um das nächstes Lied ab zu spielen in DA-Player oder AmigaAmp:
Einfach das script speichern und in allkeys oder fkey das script zuweisen an einer taste.

/* play next DAPlayer or AmigaAmp */

if show(p,DAPLAYER.1) then do
port="DAPLAYER.1"
call player
end

amigaamp:
if show(p,AMIGAAMP) then do
port="AMIGAAMP"
call player
end

exit

player:
address value port
NEXT
return


[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 20:49 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 20:50 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 21:13 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 29.03.2013 um 00:45 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 21:47 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Ich habe folgendes Script gespeichert, funktioniert nur bei AmigaAMP.


/* rexx */
if show(p,DAPLAYER.1) then do
port="DAPLAYER.1"
call pause
end

amigaamp:
if show(p,AMIGAAMP) then do
port="AMIGAAMP"
call pause
end

exit

tploetz
:boing:

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 21:54 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Du hast das wichtigste vergessen:

Am Ende (exit) volgendes hinzufügen:

player:
address value port
PAUSE
return


Auch die call funktionen ändern ("call player" statt "call pause")

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 22:17 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Funktioniert bei beiden Playern nicht, was muss bei Allkeys als Arexx-Port stehen?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > FKey erkennt Multimediatasten nicht [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.