amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > FKey erkennt Multimediatasten nicht [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- [ - Beitrag schreiben - ]

28.03.2013, 22:23 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

In allkeys muss den Namem das obengenantes script an einer Taste zugewiesen sein.
Also, wenn Du das oben genannte script gespeichert hast unter den Namen "player-pause.rexx", muss Du diesen Namen in allkeys aufgeben.

Wie sieht das ganze script von Dir jetzt aus?

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 22:25 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 22:26 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:00 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
das Script sieh so aus.
Aber in allkeys steht unter Arexx-Port AMIGAAMP

/* rexx */
if show(p,DAPLAYER.1) then do
port="DAPLAYER.1"
call pause
end

amigaamp:
if show(p,AMIGAAMP) then do
port="AMIGAAMP"
call pause
end

exit

player:
address value port
PAUSE
return

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:19 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Nochmal, Du muss die call funktionen auch ändern ("call player" statt "call pause")

In allkeys beim richtigen Taste in commandfeld: "rx s:player-pause.rexx" eingeben.
Ich hab mein rexx-script gespeichert unter den Namen s:player-pause.rexx".
Ich weiss nicht unter welchen Namen Du das script gespeichert hast. Eventuell das rx command ändern mit dem richtigen Verzeichnis/rexx-script.

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:21 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Was soll denn unter Port stehen?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:28 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

nichts.

Edit: Wenn mann die durch Allkeys unterstützte rexx-funktion nutzt, kann man nur 1 rexx-port eingeben.
Vorteil ist, man kann im arexx-commandfeld direkt das arexx-command eingeben (z.B. NEXT oder PAUSE), also man braucht kein Arexx-script.


[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 23:38 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 23:46 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:38 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Jetzt gibt es keine Reaktion auf die Pause-Taste, von beiden Playern nicht
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:40 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:
Unter welchen namen hast Du das rexx-script gespeichert?

Kannst Du ein screenshot machen von deine allkeys-einstellungen?

Hast Du die call-funktionen in script geandert?

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:49 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
http://img5.fotos-hochladen.net/uploads/allkeys2apch1lbdfy.jpg

[ - Antworten - Zitieren - Direktlink - ]

28.03.2013, 23:56 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Bitte, lese mal das oben genante Antwort.

Ich hab geschrieben:
In allkeys in commandfeld: "rx rexx:AmigaAmpPause.rexx" eingeben.

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 23:56 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 28.03.2013 um 23:57 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:02 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Habe rx in allkeys ergänzt, aber auf die Pause-Taste gibt es noch immer keine Reaktion.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:07 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Nochmal: wie sieht dein script jetzt aus.
Wirkt das andere script amigaampnext.rexx ?

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:11 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
AmigaAmpNext geht auch nicht mehr.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:21 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

TPloetz bitte LESEN !!!

Wie sieht dein script jetzt aus !!! (bitte posten)

Auch wieder ein screenshot machen von allkeys.

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:28 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
http://img5.fotos-hochladen.net/uploads/allkeys2apch1lbdfy.jpg

Das ist der Fehlerhinweis, wenn ich allkeys starte.
tploetz :amiga:

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:33 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Nein, das ist dasselbe Bild wie oben, und darauf habe ich Antwort gegeben (RX hinzufugen weiss Du noch ?)

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:41 Uhr

Robin
Posts: 1056
Nutzer
@tploetz:
Wie ich oben schon versucht hab zu erklären:

Entweder du hast einen "ARexx Port" und ein "ARexx Command"
(sowas wie "MIXER" und "PCMUP" aus dem Screen von Big_H) oder du nutzt ein "Command" und platzierst deinen Port und die Kommandos in eine ARexx-Scriptdatei. Eine ARexx-Scriptdatei ruft man mit dem dazugehörigen Interpreter "rx" aux.
"Command" => "rx rexx:AmigaAmpPause.rexx"
--
(Bild) http://my.morphosi.net/
morphos

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 00:49 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Tut mir leid. das Kopieren und Einfügen geht nicht, weiss nicht warum

http://www.fotos-hochladen.net/view/allkeys3nw8e9okqmy.jpg
hab ich mit Netsurf, OWB ging nicht mit einfügen.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 29.03.2013 um 00:57 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 01:02 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

In allkeys: Felder RXPORT und Arexx command leer machen, und in Command feld folgendes eingeben:

"rx REXX:AmigaAmpPause.rexx"


[ Dieser Beitrag wurde von Mozzerfan am 29.03.2013 um 01:03 Uhr geändert. ]

[ Dieser Beitrag wurde von Mozzerfan am 29.03.2013 um 01:04 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 12:46 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Bild: Bild) http://www.fotos-hochladen.net">(Bild) http://www.fotos-hochladen.net

Diese Fehler wird in Shell angezeigt, wenn ich die Pause-Taste
drücke, wennn AmigaAmp Läuft.
Bei allkkeys habe ich den Befehl in die Kommmanda-Spalte gesetzt.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 13:10 Uhr

Mozzerfan
Posts: 65
Nutzer
@tploetz:

Ok, ich sag es noch einmal: BITTE BITTE BITTE Wie sieht das script jetzt aus? Der Fehler deutet auf einen error im script.
Das script was ich gemacht habe wirkt, also hast Du in deinem script noch ein fehler darin.

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 13:36 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
so sieht das Sript jetzt aus.

/* rexx */
if show(p,DAPLAYER.1) then do
port="DAPLAYER.1"
call player
end

amigaamp:
if show(p,AMIGAAMP) then do
port="AMIGAAMP"
call player
end

exit

player:
address value port
Player
return

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 13:54 Uhr

Mozzerfan
Posts: 65
Nutzer

/* rexx */
if show(p,DAPLAYER.1) then do
port="DAPLAYER.1"
call player
end

amigaamp:
if show(p,AMIGAAMP) then do
port="AMIGAAMP"
call player
end

exit

player:
address value port
Player ===> ändern in "PAUSE"
return

[ - Antworten - Zitieren - Direktlink - ]

29.03.2013, 14:03 Uhr

tploetz
Posts: 4026
Nutzer
@Mozzerfan:
Habe ich geändert in "Pause"
Vielen Dank für Deine ausführliche Hilfe, funktioniert jetzt bei beiden Playern.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]


1 -2- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > FKey erkennt Multimediatasten nicht [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.